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WHERE ARE THE LESSON FILES?


Purchase of this Classroom in a Book in any format gives you access to the lesson files you’ll need to complete the exercises in the book.




	Go to www.adobepress.com/AnimateCIB2020.



	Sign in or create a new account.



	Click Submit.




[image: Image] Note


If you encounter problems registering your product or accessing the lesson files or Web Edition, go to www.adobepress.com/support for assistance.
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	Answer the question as proof of purchase.



	The lesson files can be accessed through the Registered Products tab on your Account page.




[image: Image] Note


If you purchased a digital product directly from www.adobepress.com or www.peachpit.com, your product will already be registered. However, you still need to follow the registration steps and answer the proof of purchase question before the Access Bonus Content link will appear under the product on your Registered Products tab.






	Click the Access Bonus Content link below the title of your product to proceed to the download page. Click the lesson file links to download them to your computer.
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GETTING STARTED


The 2020 release of Adobe Animate provides a comprehensive authoring environment for creating sophisticated animations and interactive, media-rich applications that you can publish to a variety of platforms. Animate is widely used in the creative industry to develop engaging projects that integrate video, sound, graphics, and animation. You can create original content in Animate or import assets from other Adobe applications such as Photoshop or Illustrator, quickly design animation and multimedia, and use code to integrate sophisticated interactivity.


Use Animate to generate graphics and animation assets, to publish broadcast-quality animation, to build innovative and immersive websites, to create stand-alone applications for the desktop, or to create apps to distribute to mobile devices running on the Android or iOS system.


With extensive controls for animation, intuitive and flexible drawing tools, and output options for HD video, HTML5, WebGL, SVG, mobile apps, and desktop applications, Adobe Animate is a robust multimedia authoring environment that enables your imagination to become reality.




About Classroom in a Book


Adobe Animate Classroom in a Book (2020 release) is part of the official training series for Adobe graphics and publishing software developed with the support of Adobe product experts. The lessons are designed so you can learn at your own pace. If you’re new to Animate, you’ll learn the fundamental concepts and features you’ll need to use the program. Classroom in a Book also teaches many advanced features, including tips and techniques for using the latest version of this application.


Although each lesson provides step-by-step instructions for creating a specific project, there’s room for exploration and experimentation. You can follow the book from start to finish or do only the lessons that correspond to your interests and needs. Each lesson concludes with review questions to reinforce what you’ve learned.






What’s new


The 2020 release of Adobe Animate provides more expressive tools, powerful controls for animation, and robust support for a wider variety of playback platforms.


The lessons in this book provide opportunities to use some of the updated features and improvements in Animate, including the following:




	A reorganized Properties panel, incorporating quick access to important document, tool, object, and frame attributes



	New tear-off floating panels for the Tools panel, allowing a fully customizable work environment



	A modernized Timeline that puts adding tweens and keyframes front and center for efficient animation creation



	A powerful new Fluid Brush with responsive and expressive options for greater artistic capabilities



	More onion skinning preferences so you can fine-tune the frame-by-frame animation experience










Prerequisites


Before you begin using Adobe Animate Classroom in a Book (2020 release), make sure your system is set up correctly and that you’ve installed the required software. You should have a working knowledge of your computer and operating system. You should know how to use the mouse and standard menus and commands and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your macOS or Microsoft Windows software.


In addition, you need to download the free Adobe AIR runtime, available at get.adobe.com/air/, to publish desktop applications in Lesson 11.






Installing Animate


You must purchase the Adobe Animate application as part of Adobe Creative Cloud. The following specifications are the minimum required system configurations.




macOS




	Multicore Intel® processor



	macOS version 10.13 (64-bit), version 10.14 (64-bit), or version 10.15 (64-bit)



	2 GB of RAM (8 GB recommended)



	1024x900 display (1280x1024 recommended)



	QuickTime 10.x software recommended



	4 GB of available hard disk space for installation; more free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)



	OpenGL version 3.3 or higher (Metal Support recommended)



	Internet connection and registration necessary for required software activation, validation of subscriptions, and access to online services










Windows




	Intel Pentium™ 4, Intel Centrino™, Intel Xeon™, or Intel Core Duo™ (or compatible) processor (2 GHz or faster processor)



	Windows™ 10 version 1803, 1809, and later



	2 GB of RAM (8 GB recommended)



	1024x900 display (1280x1024 recommended)



	4 GB of available hard disk space for installation; more free space required during installation (cannot install on removable flash storage devices)



	OpenGL version 3.3 or higher (DirectX 12 with feature level 12_0 recommended)



	Internet connection and registration necessary for required software activation, validation of subscriptions, and access to online services






For updates on system requirements and complete instructions on installing the software, visit helpx.adobe.com/animate/system-requirements.html.


Install Animate from Adobe Creative Cloud at creative.adobe.com and make sure that you have your login and password accessible.








Online content


Your purchase of this Classroom in a Book includes online materials provided by way of your Account page on adobepress.com. These include:




Lesson files


To work through the projects in this book, you will need to download the lesson files by following the instructions below.






Web Edition


The Web Edition is an online interactive version of the book providing an enhanced learning experience. Your Web Edition can be accessed from any device with a connection to the Internet and it contains:




	The complete text of the book



	Hours of instructional video keyed to the text



	Interactive quizzes










Accessing the lesson files and Web Edition


You must register your purchase on adobepress.com in order to access the online content:




[image: Image] Note


If you encounter problems registering your product or accessing the lesson files or Web Edition, go to www.adobepress.com/support for assistance.







	Go to www.adobepress.com/AnimateCIB2020.



	Sign in or create a new account.



	Click Submit.



	Answer the question as proof of purchase.



	The lesson files can be accessed from the Registered Products tab on your Account page. Click the Access Bonus Content link below the title of your product to proceed to the download page. Click the lesson file link(s) to download them to your computer.


The Web Edition can be accessed from the Digital Purchases tab on your Account page. Click the Launch link to access the product.








[image: Image] Note


If you purchased a digital product directly from www.adobepress.com or www.peachpit.com, your product will already be registered. However, you still need to follow the registration steps and answer the proof of purchase question before the Access Bonus Content link will appear under the product on your Registered Products tab.











How to use the lessons


Each lesson in this book provides step-by-step instructions for creating one or more specific elements of a real-world project. Some lessons build on projects created in preceding lessons; most stand alone. All the lessons build on one another in terms of concepts and skills, so the best way to learn from this book is to proceed through the lessons in sequential order. In this book, some techniques and processes are explained and described in detail only the first few times you perform them.


You will create and publish a variety of final project files, such as animated GIFs, HTML files, videos, or AIR desktop applications, in the lessons in this book. The files in the End folders (01End, 02End, and so on) within the Lesson folders are samples of completed projects for each lesson. Use these files for reference if you want to compare your work in progress with the project files used to generate the sample projects.


The organization of the lessons is also project oriented rather than feature oriented. That means, for example, that you’ll work with symbols on real-world design projects over several lessons rather than in just one chapter.






Additional resources


Adobe Animate Classroom in a Book (2020 release) is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources, which you can reach by choosing commands on the Help menu or by clicking links in the Start screen:


Adobe Animate Learn & Support: You’ll find and browse Help and Support content at helpx.adobe.com/animate.html. You can also reach that page by choosing Help > Animate Help or by pressing F1. On the Learn & Support page, click User Guide for documentation on individual features, or visit helpx.adobe.com/animate/topics.html. Also on the Learn & Support page, click User Guide, then Animate Manual (PDF) to download Help as a printable PDF document.


Animate tutorials: For a range of interactive tutorials on Animate features, choose Help > Animate Tutorial or visit helpx.adobe.com/animate/tutorials.html. A more limited set of tutorials is available within Animate itself by choosing Help > Learn or by clicking Learn on the Start screen.


Adobe Creative Cloud tutorials: For inspiration, key techniques, cross-product workflows, and updates on new features, go to the Creative Cloud tutorials page, helpx.adobe.com/creative-cloud/tutorials.html. Available to all.


Adobe forums: Tap into peer-to-peer discussions, questions, and answers on Adobe products at forums.adobe.com. The Adobe Animate forum is accessible by choosing Help > Adobe Online Forums.


Adobe Create: The online magazine Create offers thoughtful articles on design and design issues, a gallery showcasing the work of top-notch designers, tutorials, and more. Check it out at create.adobe.com.


Resources for educators: www.adobe.com/education and edex.adobe.com offer a treasure trove of information for instructors who teach classes on Adobe software. Find solutions for education at all levels, including free curricula that use an integrated approach to teaching Adobe software and can be used to prepare for the Adobe Certified Associate exams.


Also check out these useful sites:


Adobe Add-ons: creative.adobe.com/addons is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.


Adobe Animate product home page: www.adobe.com/products/animate.html.






Adobe Authorized Training Centers


Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products. A directory of AATCs is available at training.adobe.com/trainingpartners.











  

1 GETTING ACQUAINTED




Lesson overview


In this lesson, you’ll learn how to do the following:




	Create a new file in Adobe Animate.



	Understand the different Adobe Animate document types.



	Adjust Stage settings and document properties.



	Add layers using the Timeline panel.



	Understand and manage keyframes in the timeline.



	Work with imported images in the Library panel.



	Move and reposition objects on the Stage.



	Add filters and color effects to keyframes.



	Open and work with panels.



	Select and use tools in the Tools panel.



	Preview your animation.



	Save your file.








[image: Image]



This lesson will take less than one hour to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.







[image: ]

In Animate, the Stage is where you lay out all your visual elements, the Timeline panel is where you organize frames and layers, and other panels let you edit and control your creation.






Starting Adobe Animate and opening a file


The first time you start Adobe Animate you’ll see the Home screen, which also serves as the New Document dialog box. It displays the categories of project you can build along with any recently opened files.




[image: ]



In this lesson, you’ll create a simple slideshow-type animation to showcase a few vacation snapshots. You’ll add a background, photos, and some decorative elements, and in the process you’ll learn about positioning elements on the Stage and placing them along the timeline of the animation so that they appear one at a time, in sequence. You’ll begin learning how to use the Stage to organize your visual elements spatially and how to use the Timeline panel to organize your elements temporally.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page on peachpit.com, make sure to do so now. See “Getting Started” at the beginning of the book.







[image: Image] Tip


You can also start Animate by double-clicking an Animate file (*.fla or *.xfl), such as the 01End.fla file that is provided to show you the completed project.







	Start Animate. In Windows, choose Start > Programs > Adobe Animate. In macOS, double-click Adobe Animate 2020 in the Adobe Animate 2020 folder in the Applications folder.



	Choose the Open button or choose File > Open (Command/Ctrl+O). In the Open dialog box, select the 01End.fla file in the Lesson01/01End folder and click Open to see the final project.



	Choose the Test Movie button in the upper-right corner of the application interface, or choose Control > Test.




[image: Image]



Animate exports the project and opens it in a new window.
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An animation plays. During the animation, several overlapping photos appear one by one, with stars appearing at the end. As the new photos appear, the previous photos become blurry, receding into the background.



	Close the preview window and the FLA file.










Understanding document types and creating a new document


Animate is an animation and multimedia authoring tool that creates media for multiple platforms and playback technologies. Knowing where your final animation will play determines what type of document you’ll choose when you create a new file.




[image: Image] Note


Not all features are supported across all document types. For example, HTML5 Canvas documents don’t support the 3D Rotation or Translation tool. Tools that are not supported by the current document type are dimmed in the Animate interface.







Playback environment


The playback, or runtime, environment is the technology that your final, published files use to play. Your animation could play in a browser with HTML5 and JavaScript. Perhaps your animation will be exported as a video to be uploaded to YouTube. Or your project could play as an app on a mobile device or even as a virtual reality immersive experience. You should make that decision first so you can choose the appropriate document type.






Document types


There are nine types of documents, but you’ll likely work with only two or three of them, as they are the most common. The nine documents target different playback environments that determine some of the animation and interactivity features. Your choices for Animate documents are the following:




	Choose ActionScript 3.0 to create animation and interactivity that plays in the Flash Player in a desktop browser. Since Adobe will no longer support the Flash Player by the end of this year, this document type should be used for creating animation for video. It’s best to think of an ActionScript 3.0 document as one that supports the widest range of drawing and animation features in Animate from which you can ultimately export graphics and animation assets, such as sprite sheets or PNG sequences, or finished high-definition video and animated GIFs. ActionScript refers to the native scripting language in Animate, which is similar to JavaScript. Choosing an ActionScript 3.0 document doesn’t mean you have to include ActionScript code.
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The ActionScript 3.0 document also supports publishing content as a projector for either Windows or macOS. A projector plays as a stand-alone application on the desktop, without needing a browser.
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Animate supports only ActionScript 3.0. If you need ActionScript 1.0 or 2.0, you must have Flash Professional CS6 or earlier (versions that are no longer available from Adobe for download).






	Choose HTML5 Canvas to create animated assets that play back in a modern browser using HTML5 and JavaScript. You can add interactivity by inserting JavaScript within Animate or adding it to the final published files.



	Choose WebGL-glTF-Extended or -Standard for interactive animated assets to take advantage of hardware-accelerated support of graphics, or for supported 3D graphics.



	Choose AIR for Desktop to create animation and interactivity that plays as an application on Windows or macOS desktops, without needing a browser. You can add interactivity in an AIR document using ActionScript 3.0.



	Choose AIR for Android or AIR for iOS to publish an app for an Android or an Apple mobile device. You can add interactivity for your mobile app using ActionScript 3.0.



	Choose VR Panorama or VR 360 to publish a virtual reality project for the web browser that lets your audience look in all directions. You can add animation or interactivity to your immersive environments.






Regardless of the playback environment and document type, all documents are saved as FLA or XFL (Animate) files. The difference is that each document type is configured to export different, final published files.
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You can easily switch from one document type to another. For example, you can convert an ActionScript 3.0 document into an HTML5 Canvas document if you have an old Flash banner ad animation that you want to update. Choose File > Convert To > [new document type]. Some functionality and features may be lost in the conversion, however. For example, conversion to an HTML5 Canvas document will comment out ActionScript code.









Creating a new document


You’ll create the simple animation that you previewed earlier by starting a new document.




	Start at the Home screen in Animate, which is the default workspace when you launch the application. You can also get to the Home screen by pressing the Home button at the top left of the interface.
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The Home screen displays preset options for different playback environments and layout sizes.
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For example, the Full HD option creates a new ActionScript 3.0 document meant to export video at 1920 pixels by 1080 pixels. The Canvas option creates a new HTML Canvas document at 550 pixels by 400 pixels meant for playback in a browser.



	Choose More Presets or choose Create new (File > New).
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The New Document dialog box appears. The row at the top contains six categories of intended uses; click a category to display the preset size layouts it contains in the center of the dialog box. You can either use the presets as given or fine-tune their settings using the Details section on the right side of the dialog box. Type the document’s dimensions (in pixels) into the Width and Height boxes and choose a document type from the Platform Type menu, which lists the platforms on which Animate can play back content.



	Select the Advanced category at the far right.




[image: Image]



The center of the dialog box now displays all the available platforms. You can select a document type, and type your document’s dimensions into the Width and Height boxes.



	In the Platforms area in the center of the dialog box, select ActionScript 3.0. In the Details area on the right side of the dialog box, choose the dimensions of the Stage by entering new pixel values for the Width and Height. Enter 800 for Width and 600 for Height.



	Click Create.


Animate creates a new ActionScript 3.0 document with the specified Stage dimensions.



	Choose File > Save. Name the file 01_workingcopy.fla, and from the File Format/Save As Type menu, choose Animate Document (*.fla). Although the software application is called Animate, be aware that the file extension is .fla or .xfl, both of which preserve echoes of the name of the ancestor of Animate: “Flash.” Navigate to the 01Start folder and click Save.




[image: Image] Note


If you save your Animate document as an Animate Uncompressed Document (.xfl), your document is saved as a collection of files in folders and not as a single document. This exposes the contents of your document to you and to other developers to swap assets easily. The XFL format is a more advanced saved document that you won’t be using in this book.





Saving your file right away is a good working habit that ensures your work won’t be lost if the application or your computer crashes. You should always save your Animate file with the extension .fla (or .xfl if you save it as an Animate Uncompressed Document) to identify it as the Animate source file.












Getting to know the workspace


The Animate work area includes the command menus at the top of the screen and a variety of tools and panels for editing and adding elements to your movie. You can create all the objects for your animation in Animate, or you can import elements you’ve created in Adobe Illustrator, Adobe Photoshop, Adobe After Effects, or other compatible applications.


There are many different interface configurations, but in the Essentials workspace, Animate displays the menu bar, Timeline panel, Stage, Tools panel, Properties panel, Edit bar, and a few other panels. As you work in Animate, you can open, close, group, ungroup, dock, undock, and move panels around the screen to fit your work style or your screen resolution.
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Choosing a new workspace


Animate also provides a few preset panel arrangements (“workspaces”) that may better suit the needs of particular users. Use the Window > Workspaces submenu or the workspace switcher at the top right of the interface to choose a different workspace or to save a new one.




	Click the workspace switcher and choose a new workspace.
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The various panels are rearranged and resized according to their importance in the chosen workspace. For example, the Animator and Designer workspaces put the Timeline panel at the top of the work area for easy and frequent access.



	Select the Essentials workspace.


This book shows the step-by-step lessons with the Essentials workspace. It provides a good balance with access to the Stage and the most commonly used panels.



	If you have moved some of the panels around and want to return to one of the prearranged workspaces, choose Window > Workspaces > Reset [preset name] and click OK in the confirmation dialog box. Or, choose the reset icon in front of the workspace name from the workspace switcher.
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The default workspace is Basic.









Saving your workspace


If you find an arrangement of panels that suits your style of work, you can save it as a custom workspace and return to it at a later date.




	Open the workspace switcher and enter a name for your new workspace in the field below New Workspace.
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	Click the Save Workspace icon next to the new name.
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Animate saves the current arrangement of panels and adds it to the options in the Workspace menu, which you can access at any time.
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	By default, the Animate interface is rather dark. However, you can change the interface to a lighter gray if you prefer. Choose Animate > Preferences > Edit Preferences (macOS) or Edit > Preferences (Windows), and in the General preferences category, choose a different level of gray.
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In this book, the screenshots are shown in the Dark mode.
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If you want to save and share your workspace preferences (in addition to other customizations), you can export them into an ANP file. Choose Animate > Preferences > Export Preferences to save a file that others can import.









About the Stage


The big white rectangle in the middle of your screen is called the Stage. As with a theater stage, the Stage in Animate is the area that viewers see when a movie is playing. It contains the text, images, and video that appear on the screen. Move elements on and off the Stage to place them in and out of view. You can use the rulers (View > Rulers) or grids (View > Grid > Show Grid) to help you position items on the Stage. Other positioning aids include guides (pulled from the top or side rulers; View > Guides) or the Align panel and other tools you’ll learn about in later lessons in this book.


By default, you’ll see the gray area off the Stage where you can place elements that won’t be visible to your audience. The gray area is called the pasteboard. To see only the Stage, choose View > Magnification > Clip To Stage to select the option. For now, leave Clip To Stage deselected, allowing the pasteboard to remain in view.


You can also click the Clip Content Outside The Stage button to crop the graphic elements that fall beyond the Stage area to see how your audience will view your final project.
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You can view the Stage in full-screen mode without the distraction of the various panels by choosing View > Screen Mode > Full Screen Mode. Press F4 to toggle the panels, and press the Esc key to return to Standard Screen Mode.





To scale the Stage so that it fits completely in the application window, choose View > Magnification > Fit In Window. You can also choose different magnification view options from the menu just above the Stage.
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Changing the Stage properties


Now you’ll change the color of the Stage. The Stage color, along with document properties such as the Stage dimensions and frame rate, is available in the Properties panel, which is the vertical panel just to the right of the Stage.




	In the Properties pane of the Properties panel, note that the dimensions of the current Stage (the Size parameters) are set at 800x600 pixels, which you chose when you created the new document.




[image: Image]




	Also in the Properties panel, click the Background Color box next to Stage and choose a new color from the color palette. Choose dark gray (#333333).
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Your Stage is now a different color. You can change the Stage properties at any time.












Working with the Library panel


The Library panel is accessible from a tab just to the right of the Properties panel. The Library panel displays the contents of your document’s library, which is where you store and organize symbols created in Animate, as well as imported files, including bitmaps, graphics, sound files, and certain video clips. Symbols are graphics used frequently for animation and for interactivity.




[image: Image] Note


You’ll learn much more about symbols in Lesson 2.







About the Library panel


The Library panel lets you organize library items in folders, see how often an item is used in a document, and sort items by type. You can also create folders in your Library panel to help group items. When you import items into Animate, you can import them directly onto the Stage or into the library. However, any item you import onto the Stage is also added to the library, as are any symbols you create. You can then easily access the items to add them to the Stage again, edit them, or see their properties.


To display the Library panel, choose Window > Library, or press Command+L (macOS)/Ctrl+L (Windows).
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You can also access the assets that you’ve stored in your Creative Cloud account by clicking the CC Libraries icon (Window > CC Libraries).









Importing an item to the Library panel


Often, you’ll create graphics directly with the drawing tools in Animate and save them as symbols, which are stored in the library. Other times you’ll import media such as JPEG images or MP3 sound files, which are also stored in the library. In this lesson, you’ll import several images into the library to be used in the animation.




	Choose File > Import > Import To Library. In the Import To Library dialog box, select the background.png file in the Lesson01/01Start folder and click Open. Choose All Files (*.*) from the Enable menu if the image files are dimmed.
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If the Enable menu isn’t visible, click the Options button to activate it.





Animate imports the selected PNG image and places it in the Library panel.



	Continue importing photo1.jpg, photo2.jpg, and photo3.jpg from the 01Start folder.


You can also hold down the Shift key to select multiple files and import all of the images at once.


The Library panel lists the filenames of all the imported images and provides a thumbnail preview of any selected file. These images are now available to be used in your Animate document.
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Adding an item from the Library panel to the Stage


To use an imported image, simply drag it from the Library panel onto the Stage.




	Choose Window > Library to open the Library panel if it isn’t already open.



	Drag the background.png item onto the Stage and place it approximately in the center of the Stage.
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You can also choose File > Import > Import To Stage, or press Command+R (macOS) or Ctrl+R (Windows), to import an image file to the library and put it on the Stage all in one step.











Understanding the Timeline panel


In the Essentials workspace, the Timeline panel is located below the Stage. The Timeline panel contains playback controls for your animation as well as the timeline itself, which displays the sequence of events in the animation from left to right. An Animate movie measures time in frames, just as in a filmstrip. As the movie plays, the playhead, shown as a blue vertical line, advances through the frames shown in the timeline. You can change the content on the Stage for different frames. To display a frame’s content on the Stage for any particular time, move the playhead to that frame in the timeline.


At the top of the Timeline panel, Animate indicates the selected frame number and the current frame rate (how many frames play per second).
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The timeline portion of the Timeline panel also displays layers, which help you organize the artwork in your document. At the moment, your project has only one layer, which is called Layer_1. Think of layers as multiple filmstrips stacked on top of one another. Each layer can contain a different image that appears on the Stage, and you can draw and edit objects on one layer without affecting objects on another layer. The layers are stacked in the order in which they overlap each other so that objects on the bottom layer in the timeline are on the bottom of the stack on the Stage. You can hide, lock, or show the contents of layers as outlines by clicking the dots or square in the layer under the layer option icons.


If you have multiple layers, you can use the View Only Active Layer option above the Timeline to show only the currently selected layer.
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Changing the appearance of the timeline


You can adjust the timeline’s appearance to accommodate your workflow. When you want to see more layers, choose Short from the Frame View menu in the upper-right corner of the Timeline panel. The Short option decreases the height of frame cell rows. The Preview and Preview In Context options display thumbnail versions of the contents of your keyframes in the timeline.
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For finer control over the timeline frame sizes, drag the Resize Timeline View slider. The slider adjusts the size of the frames so you can see more or less of the timeline. Click the Reset Timeline Zoom To The Default Level button to revert the Timeline view to its normal size.







Renaming a layer


It’s a good idea to separate your content on different layers and name each layer to indicate its contents so that you can easily find the layer you need later.




	Double-click the name of the existing layer, Layer_1, to rename it, and type background.



	Click outside the name box to apply the new name.
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	Click below the lock icon to lock the layer. Locking a layer prevents you from accidentally moving or making changes to whatever is inside that layer.
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A lock icon appears in the layer. The lock icon indicates that you can’t make edits to the layer because it is locked.










Adding a layer


A new Animate document contains only one layer, but you can add as many layers as you need. Objects in the top layers will overlap objects in the bottom layers.




	Select the background layer in the timeline.



	Choose Insert > Timeline > Layer. You can also click the New Layer button above the timeline. A new layer appears above the background layer.




[image: Image]




	Double-click the new layer to rename it, and type photo1. Click outside the name box to apply the new name.


Your timeline now has two layers. The background layer contains the background photo, and the newly created photo1 layer above it is empty.



	Select the top layer, called photo1.



	Choose Window > Library to open the Library panel if it isn’t already open.



	Drag the library item called photo1.jpg from the library onto the Stage.


The photo1 JPEG appears on the Stage and overlaps the background image.
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As you add more layers and your overlapping graphics become more complicated, click the dot below the eye icon in any layer to hide its contents. Alternatively, hold Shift and click the dot below the eye icon to make the layer partially transparent so that you can see what’s below it. Hiding or making a layer transparent affects only how you see your project in Animate—it doesn’t affect your final exported project. Double-click the Layer icon to modify the level of transparency in the Layer Properties dialog box.






	Choose Insert > Timeline > Layer, or click the New Layer button above the timeline, to add a third layer.



	Rename the third layer photo2.








Working with layers


If you don’t want a layer, you can easily delete it by selecting it and then clicking the Delete button above the timeline.
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If you want to rearrange your layers and change how your graphics overlap each other, simply drag any layer up or down to move it to a new position in the layer stack.









Inserting frames


So far, you have a background photo and another overlapping photo on the Stage, but your entire animation exists for only a single frame, which is only a fraction of a second. To create more time on the timeline and make this animation run for a longer duration, you must add additional frames.




	Select frame 48 in the background layer. Use the Resize Timeline View slider at the upper-right corner of the Timeline panel to expand the timeline frames to make it easier to identify frame 48.
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	Choose Insert > Timeline > Frame (F5). You can also right-click and choose Insert Frame from the context menu that appears.


Animate adds frames in the background layer up to the selected frame, frame 48.
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	Select frame 48 in the photo1 layer.



	Choose Insert > Timeline > Frame (F5) or right-click and choose Insert Frame to add frames in the photo1 layer up to frame 48.



	Select frame 48 in the photo2 layer and insert frames on this layer.






You now have three layers, all with 48 frames on the timeline. Since the frame rate of your Animate document is 24 frames per second, your current animation lasts two seconds.




Selecting multiple frames


Just as you can hold down the Shift key to select multiple files on your desktop, you can hold down Shift to select multiple frames on the Animate timeline. If you have several layers and want to insert frames into all of them, hold down Shift and drag where you want to add frames. Then choose Insert > Timeline > Frame.









Creating a keyframe


A keyframe indicates a change in content on the Stage. Keyframes are indicated on the timeline as a circle. An empty circle means there is nothing in that particular layer at that particular time. A filled-in black circle means there is something in that layer at that time. The background layer, for example, contains a filled keyframe (black circle) in the first frame. The photo1 layer also contains a filled keyframe in its first frame. Both layers contain photos. The photo2 layer, however, contains an empty keyframe in the first frame, indicating that it is currently empty.
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You’ll insert a keyframe in the photo2 layer at the point in time when you want the next photo to appear.




	Select frame 24 on the photo2 layer. The frame number of a selected frame is displayed above the left end of the timeline.
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	Choose the Insert Keyframe button above the Timeline, or choose Insert > Timeline > Keyframe (F6).


A new keyframe, indicated by an empty circle, appears in the photo2 layer in frame 24.
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	Select the new keyframe at frame 24 in the photo2 layer.



	Drag photo2.jpg from your library onto the Stage.


The empty circle at frame 24 becomes filled, indicating that there is now content in the photo2 layer. When your animation plays, your photo appears on the Stage at frame 24. You can drag the blue playhead along the top of the timeline to “scrub,” or show what’s happening on the Stage, at any point along the timeline. You’ll see that the background photo and photo1 remain on the Stage throughout the timeline but that photo2 appears only at frame 24.
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Understanding frames and keyframes is essential for mastering Animate. Be sure you understand how the photo2 layer contains 48 frames with two keyframes—an empty keyframe at frame 1 and a filled keyframe at frame 24.




[image: Image]







Moving a keyframe


If you want photo2.jpg to appear later or earlier in time, you need to move the keyframe in which it appears closer to or farther from the right on the timeline. You can easily move any keyframe by simply dragging it to a new position.




	Select the keyframe in frame 24 on the photo2 layer.



	Drag the keyframe to frame 12 in the photo2 layer. As you drag, you’ll see a box icon appear under your cursor, indicating that you are repositioning the keyframe.
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The photo2.jpg file now appears on the Stage much earlier in the animation.




[image: Image]









Removing keyframes


If you want to remove a keyframe, do not press the Delete/Backspace key! Doing so will delete the contents of that keyframe on the Stage, leaving you with an empty keyframe. Instead, select the keyframe and choose Modify > Timeline > Clear Keyframe (Shift+F6). Your keyframe (and its contents) will be removed from the timeline.











Organizing layers in a timeline


At this point, your working Animate file has only three layers: a background layer, a photo1 layer, and a photo2 layer. You’ll be adding more layers for this project, and as in most other projects, you’ll end up having to manage multiple layers. Layer folders help you group related layers to keep your timeline organized and manageable, just as you make folders for related documents on your desktop. Although it may take some time to create the folders, you’ll save time later because you’ll know exactly where to look for a specific layer.




Creating layer folders


For this project, you’ll continue to add layers for additional photos, and you’ll place those layers in a layer folder.




	Select the photo2 layer and click the New Layer button above the timeline.



	Name the layer photo3.



	Insert a keyframe at frame 24.



	Drag photo3.jpg from the library onto the Stage.


You now have four layers. The top three contain photos of scenes from Coney Island that appear at different keyframes.
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	Select the photo3 layer and click the New Folder icon [image: ] at the top of the Timeline panel.


A new layer folder appears above the photo3 layer.



	Name the folder photos.
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Adding layers to layer folders


Now you’ll add the photo layers to the photos folder. As you arrange layers, remember that Animate displays the content in the layers in the order in which they appear in the timeline, with the top layer’s content at the front and the bottom layer’s content at the back.




	Drag the photo1 layer into the photos folder.


Notice how the bold line indicates the destination of your layer. When you place a layer inside a folder, Animate indents the layer name.
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	Drag the layers photo2 and photo3 into the photos folder.


All three photo layers should be in the photos folder, in the same stacking order as they were in outside the folder.
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You can collapse the folder by clicking the arrow just to the left of the folder name. Expand the folder by clicking the arrow again. Be aware that if you delete a layer folder, you delete all the layers inside that folder as well.






Layer highlighting


Sometimes it’s useful to highlight certain layers as you’re working on a project to indicate that something is important in that layer.


Click the dot in the layer below the Highlight Layers indicator.
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The selected layer becomes highlighted in color—the same color that is used for outlines and bounding boxes for the Show Layers As Outlines option.
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Cut, copy, paste, and duplicate layers


When managing multiple layers and layer folders, you can rely on cut, copy, paste, and duplicate layer commands to make your workflow easier and more efficient. All the properties of the selected layer are copied and pasted, including its frames, its keyframes, any animation, and even the layer name and type. You can also copy and paste layer folders and their contents.


To cut or copy any layer or layer folder, simply select the layer, right-click the layer name, and choose Cut Layers or Copy Layers.
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Right-click the timeline again and choose Paste Layers. The layer or layers that you cut or copied are pasted into the timeline. Use Duplicate Layers to copy and paste in one operation.


You can also cut, copy, paste, or duplicate layers from the application menu bar. Choose Edit > Timeline, and then choose Cut Layers, Copy Layers, Paste Layers, or Duplicate Layers.











Using the Properties panel


The Properties panel gives you quick access to the attributes you’re most likely to need to modify as you create your animation. What appears in the Properties panel depends on what you’ve selected. For example, if nothing is selected, the Properties panel includes options for the general Animate document, including changing the Stage color or dimensions. If you’ve selected an object on the Stage, the Properties panel shows its x and y coordinates and its width and height, among other information. If you’ve selected a keyframe on the Timeline, as shown in the following figure, the Properties panel shows attributes of that keyframe, such as its label or whether it contains any sound. Different attributes are divided into sections that can be collapsed or expanded.
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You can also quickly change the focus of the selection from the keyframe to objects on the Stage with the Properties panel. For example, selecting the Object tab at the top of the Properties panel switches the display from the attributes of the keyframe to the attributes of the selected item on the Stage in that keyframe.
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You’ll use the Properties panel to move your photos on the Stage.




Positioning an object on the Stage


You’ll begin by using the Properties panel to move the photos. You’ll also use the Transform panel to rotate the photos.
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If the Properties panel is not open, choose Window > Properties, or press Command+F3 (macOS) or Ctrl+F3 (Windows).







	Move the playhead to frame 1 of the timeline, and select the photo1.jpg image that you dragged onto the Stage in the photo1 layer. A very narrow blue outline indicates that the object is selected.



	In the Properties panel, type 50 for the X value and 50 for the Y value. Press Return (macOS)/Enter (Windows) to apply the values. You can also drag over the X and Y values to change their values. The photo moves to the left side of the Stage.
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The X and Y values are measured on the Stage from the upper-left corner. X begins at 0 and increases to the right, and Y begins at 0 and increases downward. The registration point (the point from which Animate makes measurements) for imported photos is at the upper-left corner.



	Choose Window > Transform to open the Transform panel. The Transform window is also accessible from the column of icons on the side of the Properties panel.



	In the Transform panel, select Rotate and type –12 in the Rotate box, or drag over the value to change the rotation. Press Return/Enter to apply the value.


The selected photo on the Stage rotates 12 degrees counterclockwise.
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	Select frame 12 of the photo2 layer. Now click photo2.jpg on the Stage to select it.



	Use the Properties panel and Transform panel to position and rotate the second photo in an interesting way. Use X=200, Y=40, and a Rotate value of 6 to give it some contrast with the first photo.
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	Select frame 24 in the photo3 layer. Now click photo3.jpg on the Stage to select it.



	Use the Properties panel and Transform panel to position and rotate the third photo in an interesting way. Use X=360, Y=65, and a Rotate of –2 so that all your photos have visual variety.
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[image: Image] Note


When images are scaled or rotated in Animate, they may appear jagged. You can use the Bitmap Properties dialog box to smooth each image. Double-click the bitmap icon or the image thumbnail in the Library panel to open the dialog box and select the Allow Smoothing option.











Working with panels


Just about everything you do in Animate involves a panel. In this lesson, you use the Library panel, Tools panel, Properties panel, Transform panel, History panel, and Timeline panel. In later lessons, you’ll learn to use other panels to control various aspects of your project. Because panels are such an integral part of the Animate workspace, it pays to know how to manage them.


To open any panel in Animate, choose its name from the Window menu.
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Individual panels float freely, and they can be combined in docks, groups, or stacks.




	A dock is a collection of panels or panel groups in a vertical column. Docks stick to the left or right edges of the user interface.



	A group is a collection of panels that can be placed within a dock or that can float freely.



	A stack is similar to a dock but can be placed anywhere in the interface.






In the Essentials workspace, most of the panels are organized in three docks on the right side of the screen. The Timeline and Output panels are grouped at the bottom, and the Stage is on the top. However, you can move a panel to any position that is convenient for you.




	To move a panel, drag it by its tab to a new location.



	To move a panel group or stack, drag it by the area next to the tabs.






As the panel, group, or stack passes over other panels, groups, docks, or stacks, a blue highlighted drop zone will appear. If you release the mouse button while a drop zone is visible, the panel will be added to the group, dock, or stack.




	To dock a panel, drag it by its tab into a new position at the left or right edge of the screen. If you drag it over the top or bottom of an existing dock, a horizontal drop zone will show you the panel’s new location. If a vertical drop zone appears, dropping the panel will create a new dock.



	To group a panel, drag its tab onto the tab of another panel or the drop zone at the top of an existing group.



	To create a stack, drag a group out of a dock or an existing stack so it floats freely. Alternatively, drag one free-floating panel onto the tab of another floating panel.






You also have the option of displaying most of the panels as icons to save space but still maintain quick access. Click the double arrowheads in the upper-right corner of a dock or stack to collapse the panels to icons. Click the double arrowheads again to expand the icons into panels.











Using the Tools panel


The Tools panel—the long, narrow panel on the far left side of the Essentials work area—contains selection tools, drawing and type tools, painting and editing tools, navigation tools, and tool options. You’ll use the Tools panel frequently to switch to tools designed for the task at hand. Most often, you’ll use the Selection tool, which is the black arrow tool at the top of the Tools panel, for selecting and clicking items on the Stage or the Timeline.




Selecting and using a tool


When you select a tool, the options available at the bottom of the Tools panel and the Properties panel change. For example, when you select the Rectangle tool, the Object Drawing Mode option appears. When you select the Zoom tool, the Enlarge and Reduce options appear.


The Tools panel contains too many tools to display all at once. Some tools are arranged in hidden groups in the Tools panel; only the tool you last selected from a group is displayed. A small triangle in the lower-right corner of the tool’s button indicates that there are other tools in the group. Press and hold the icon for the visible tool to see the other tools available, and then select one from the menu.






Tear-off tools


You can customize the Tools panel to display only the tools you need or the tools you use the most often. You can also arrange the tools to your liking.




	Click the Edit Toolbar option at the bottom of the Tools panel.




[image: Image]




	Additional tools appear in an adjacent Drag And Drop Tools panel. Drag the tools that you want into the Tools panel.


You can add spacers (horizontal separators) to create groups of tools, which can be torn off from the main Tools panel to create a floating panel.
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	Choose the options from the upper-right corner to reset the Toolbar to its default workspace configuration, select a different size icon for the tools, or close the Drag And Drop Tools menu.
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[image: Image] Note


You cannot select a tool for use from the Drag And Drop Tools menu. You must add a tool to the Toolbar, and then it becomes available to be used.







[image: Image] Note


If you’re working with a smaller display, the bottom of the Tools panel may be cut off. That makes some of the tools and buttons invisible. But there’s an easy way to fix the problem: drag the left edge of the Tools panel to widen it so that it can show multiple columns of tools.




[image: Image]














Adding graphics


You’ll use the PolyStar tool to add a little decoration to your short animation.




	Select the folder in the timeline, and then click the New Layer button.



	Name the new layer stars.



	Lock the other layers below it so that you don’t accidentally move anything into them.



	In the timeline, move the playhead to frame 36 and select frame 36 in the stars layer.





	Choose the Insert Keyframe button above the Timeline, or choose Insert > Timeline > Keyframe (F6), to insert a new keyframe at frame 36 in the stars layer.
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You will create star shapes to appear at frame 36 in this layer.



	In the Tools panel, select the PolyStar tool, which is indicated by the hexagon shape.



	In the Properties panel, click the colored square next to the Stroke option, which indicates the color of the outline, and select the red diagonal line.
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The red diagonal line represents a color of None for the stroke.



	Click the colored square next to the Fill option, which indicates the color of the inside of the shape, and select a bright, cheery color such as yellow. You can click the color wheel at the upper right to access the Adobe Color Picker, or you can change the Alpha percentage, which determines the level of opacity, also at the upper right.
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	In the Properties panel, under the Tool Options section, choose Star from the Style menu. For Number Of Sides, enter 5, and for Star Point Size, enter 0.5. These options define the shape of your star.
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	Make sure the empty keyframe in frame 36 of the stars layer is selected. Start dragging on the Stage where you want to add a star, and continue dragging to change the width of your star. Without releasing the drag, move your cursor around the center of the star to rotate it. Make multiple stars of different sizes and with different angles of rotation.
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	Exit the PolyStar tool by selecting the Selection tool.



	Use the Properties panel or the Transform panel to reposition or rotate selected stars on the Stage, if desired. Or select the Selection tool and simply click to select a star and drag it to a new position on the Stage. The X and Y values in the Properties panel update as you drag the star around the Stage.












Adding layer effects


You can add interesting visual effects that change the appearance of objects in a particular layer. These layer effects include color effects and filters, both available in the Properties panel when a keyframe is selected.


The options on the Style menu in the Color Effect section include Brightness, Tint, and Alpha. Brightness controls the relative darkness or lightness of the layer. Tint controls how much color is added to the layer. Alpha controls the transparency of the layer. A fourth option, Advanced, allows you to vary brightness, tint, and alpha together all at once.


Filters are special effects that change or distort the appearance in more dramatic ways, such as adding a drop shadow or adding a blur.




Adding layer effects to a keyframe


Layer effects are keyframe based. That is, a single layer can have different layer effects in different keyframes. You’ll add a filter and a color effect to different keyframes in your layers to help add some depth to the slideshow and to help new images stand out as they’re added.




	Move the playhead to frame 12 on the timeline, and select frame 12 in both the photo1 layer and the background layer by pressing Shift as you click each frame. Frame 12 is the point at which photo2 appears in the slideshow.



	Choose the Insert Keyframe button above the Timeline (F6).


A keyframe appears in frame 12 in both layers.
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	While the two keyframes are still selected, click the Add Filter button in the Properties panel and choose Blur to add a blur filter to the two selected keyframes.
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	Increase the Blur X and Blur Y values to 8px.


The background photo and the first photo become blurry, which accentuates the new photo that appears in the photo2 layer.
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The keyframes on your Timeline become colored white, indicating that there is a layer effect applied.



	Select frame 24 in the photo2 layer; this is the moment when photo3 appears.



	Choose Insert Keyframe from above the Timeline (F6). This keyframe allows you to add a filter to the layer to change its appearance at that point in time.
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	Click Add Filter in the Properties panel and choose Blur. Increase Blur X and Blur Y to 8 px.


The photo in the photo2 layer becomes blurry, helping your audience focus on the new photo that appears in the photo3 layer.
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	Select frame 36 in the photo1, photo2, photo3, and background layers and insert a keyframe (F6).
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	In the Color Effect section of the Properties panel, choose Brightness from the Style menu and drag the Bright value to –30%.






The selected layers become slightly darker, which adds drama to the bright yellow stars that appear at that moment in the stars layer.
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You can also apply color effects and filters to individual symbol instances on the Stage, which you’ll learn about later in this book.











Undoing steps in Animate


In a perfect world, everything would go according to plan. But sometimes you need to move back a step or two and start over. You can undo steps in Animate using the Undo command or the History panel.


To undo a single step in Animate, choose Edit > Undo or press Command+Z (macOS)/Ctrl+Z (Windows). To redo a step you’ve undone, choose Edit > Redo.


The easiest way to undo multiple steps in Animate is to use the History panel, which displays a list of the last 100 steps you’ve performed. Closing a document clears its history. To access the History panel, choose Window > History.


For example, if you aren’t satisfied with the newly added stars, you can undo your work and return your Animate document to a previous state.




[image: Image] Note


If you remove steps from the History panel and then perform additional steps, the removed steps will no longer be available.







	Choose Edit > Undo to undo the last action you made. You can choose the Undo command multiple times to move backward as many steps as are listed in the History panel. You can change the maximum number of Undo commands by choosing Animate > Preferences (macOS) or Edit > Preferences (Windows).



	Choose Window > History to open the History panel.



	Drag the History panel slider up to the step just before your mistake. Steps below that point are dimmed in the History panel and are removed from the project. To add a step back, move the slider back down.
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	Finish by returning the History panel slider to its original position next to the bottom step in the panel.










Previewing your movie


As you work on a project, it’s a good idea to preview it frequently to ensure that you’re achieving the desired effect. To quickly see your animation, choose Control > Play, or simply press the Return/Enter key.


To see how an animation or movie will appear to a viewer, choose the Test Movie button at the upper-right corner of the Animate workspace, or choose Control > Test. You can also press Command+Return (macOS) or Ctrl+Enter (Windows) to preview your movie.




	Choose Control > Test or the Test Movie button at the upper-right corner of the Animate workspace.


Animate opens and plays the animation in a new panel.
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Animate automatically loops your movie in this preview mode.



	Close the Test Movie panel.










Modifying the content and Stage


When you first started this lesson, you created a new file with the Stage set at 800 pixels by 600 pixels. However, your client may later tell you that they want the animation in several different sizes to accommodate different layouts. For example, they’d like to create a smaller version with a different aspect ratio for a banner ad. Or they may want to create a version that will run on AIR for Android devices, which require specific dimensions.


Fortunately, you can modify the Stage even after all your content is put in place. When you change the Stage dimensions, Animate provides the option of scaling the content with the Stage, automatically shrinking or enlarging all your content proportionally.




Stage resizing and content scaling


You’ll create another version of this animated project with different Stage dimensions. Choose File > Save to save the work you’ve done so far.




	In the Document Settings section of the Properties panel, note that the dimensions of the current Stage are set at 800×600 pixels. Click the More Settings button to open the Document Settings dialog box.
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	In the Width and Height boxes, enter new pixel dimensions. Enter 400 for Width and 300 for Height.


You can click the link icon between the Width and Height fields to constrain the proportions of the Stage. With the link icon selected, changing one dimension will automatically change the other proportionately.



	Select the Scale Content option. Leave the Anchor option as is.
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The Anchor option lets you choose the origin from which your content is resized, if the proportions of the new Stage are different.



	Click OK.


Animate modifies the dimensions of the Stage and automatically resizes all the content. If your new dimensions are not proportional to the original size, Animate will resize everything to maximize the content to fit. This means that if your new Stage size is wider than the original, there’ll be extra Stage space to the right. If your new Stage size is taller than the original, there’ll be extra Stage space on the bottom.



	Choose File > Save As.



	In the Save dialog box choose Animate Document (*.fla) from the File Format menu, and name the file 01_workingcopy_resized.fla. Save the file.


You now have two Animate files, identical in content but with different Stage dimensions. Close this file and reopen 01_workingcopy.fla to continue this lesson.












Saving your movie


A mantra in multimedia production is “Save early, save often.” Applications, operating systems, and hardware crash more often than anyone wants, and at unexpected and inconvenient times. You should always save your movie at regular intervals to ensure that if a crash does happen, you won’t have lost too much of your time.




[image: Image] Note


If you have unsaved changes in your open document, Animate adds an asterisk to the end of its filename at the top of the document window as a friendly reminder.





Animate can help alleviate much of the worry over lost work. The Auto-Recovery feature creates a backup file in case of a crash.




Using Auto-Recovery to create a backup


The Auto-Recovery feature is a preference setting that applies to all Animate documents. It saves a backup file, so in case of a crash, you have an alternate file to return to.




	Choose Animate > Preferences > Edit Preferences (macOS) or Edit > Preferences (Windows).


The Preferences dialog box appears.



	Select the General category from the left column.



	Select the Auto-Recovery option, if it’s not already selected, and enter a time (in minutes) for the interval at which Animate creates a backup file.
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[image: Image] Note


To find out how to keep your copy of Animate up to date and to learn about the many sources of help available to you within Animate, see the “Getting Started” section at the beginning of this book.






	Click OK.


If you make changes to your file but do not save it within the Auto-Recovery interval, Animate creates a new file in the same location as your FLA with RECOVER_ added to the beginning of the filename. The file remains as long as the document is open. When you close the document or when you quit Animate safely, the file is deleted.








Review questions


1 What is the Stage?


2 What is the difference between a frame and a keyframe?


3 How do you access hidden tools?


4 Name two methods to undo steps in Animate and describe them.


5 What document type would be best for playing back animation in a modern browser?


6 What are layer effects, and how do you add them?


Review answers


1 The Stage is the rectangular area viewers see when a movie is playing. It contains the text, images, and video that appear on the screen. Objects that you store on the pasteboard outside of the Stage do not appear in the movie.


2 A frame is used to measure time on the timeline. A keyframe is represented on the timeline with a circle and indicates a change in content on the Stage.


3 Because there are too many tools to display at once in the Tools panel, some tools are grouped, and only one tool in the group is displayed. (The tool you most recently used is the one shown.) Small triangles appear on tool icons to indicate that hidden tools are available. To select a hidden tool, press and hold the tool icon for the tool that is shown, and then select the hidden tool from the menu. Other tools are hidden in the drag and drop panel accessible from the Options button at the bottom of the Tools panel. Drag a tool into the Toolbar to make it available for use.


4 You can undo steps in Animate using the Undo command or the History panel. To undo a single step at a time, choose Edit > Undo. To undo multiple steps at once, drag the slider up in the History panel.


5 An HTML5 Canvas document targets modern browsers for playback of animation and interactive content. HTML5 Canvas exports HTML, JavaScript, and all the assets required to play in a browser without requiring the Flash Player.


6 Layer effects are filters or color effects that you can add to a keyframe on the timeline that change the appearance of the contents of the keyframe. Layer effects are added by selecting a keyframe and choosing a style or a filter from the Color Effect or Filter section of the Properties panel.
















  

2 CREATING GRAPHICS AND TEXT




Lesson overview


In this lesson, you’ll learn how to do the following:




	Draw rectangles, ovals, and other shapes.



	Modify the shape, color, and size of drawn objects.



	Understand fill and stroke settings.



	Create and edit curves and variable-width strokes.



	Apply gradients and transparencies.



	Use the Fluid Brush tool and Art and Pattern brushes for expressive drawing.



	Create and edit text, and use web fonts.



	Distribute objects on the Stage.



	Create and edit symbols.



	Understand symbols and instances.



	Apply filters to symbol instances.
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This lesson will take about three hours to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.







[image: ]

You can use rectangles, ovals, lines, and custom brushes to create interesting, complex graphics and save them as symbols, which will be displayed in your Library panel. Combine gradients, transparencies, text, and filters for even greater expressive possibilities.






Getting started


Start by viewing the finished project to see what you’ll be creating in this lesson.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Double-click the 02End.html file in the Lesson02/02End folder to view the final project in a browser.
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The project is a simple static illustration for a banner ad. This illustration is for Mug’s Coffee, a fictional café that’s promoting its store and coffee. In this lesson, you’ll draw the shapes, modify them, and learn to combine simple elements to create more complex visuals. You won’t create any animation just yet. After all, you must learn to walk before you can run! And learning to create and modify graphics is an important step before doing any animation with Adobe Animate.



	In the Animate Home screen, select More Presets or click Create New.




[image: Image]



The New Document dialog box opens.



	Choose Advanced from the top row of categories. In the Platforms section, choose HTML5 Canvas. In the Details section, make the Stage size 700 pixels by 200 pixels, and click Create.
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	Choose File > Save. Name the file 02_workingcopy.fla and save it in the 02Start folder. Saving your file right away is a good working habit (even if you’ve enabled the Auto-Recovery feature). It ensures that you won’t lose your work if the application or your computer crashes.










Understanding strokes and fills


Every graphic created within Animate starts with a shape. A shape consists of two components: the fill, or the insides of the shape, and the stroke, or the outlines of the shape. If you always keep these two components in mind, you’ll be well on your way to creating beautiful and complicated visuals.


The fill and the stroke function independently of each other, so you can modify or delete either without affecting the other. For example, you can create a rectangle with a blue fill and a red stroke, and then later change the fill to purple and delete the red stroke entirely. You’ll be left with a purple rectangle without an outline. You can also move the fill or stroke independently, so if you want to move the entire shape, make sure that you select both its fill and its stroke.






Creating shapes


Animate includes several drawing tools, which work in different drawing modes. Many of your creations will begin with simple shapes such as rectangles and ovals, so it’s important that you’re comfortable drawing them, modifying their appearance, and applying fills and strokes.




[image: Image] Note


In Animate, as well as in HTML documents and in web design and development in general, colors are often specified by hexadecimal numbers. The six digits after the # sign represent the red, green, and blue contributions to the color.





You’ll begin by drawing the cup of coffee.




Using the Rectangle tool


The coffee cup is essentially a cylinder, which is a rectangle with an oval at the top and an oval at the bottom. You’ll start by drawing the rectangular body. It’s useful to break down complicated objects into their component parts to make drawing them easier.




	In the Tools panel, select the Rectangle tool [image: ]. Make sure the Object Drawing mode button [image: ] at the bottom of the Tools panel or in the Properties panel is not selected.



	Choose a stroke color and a fill color from the bottom of the Tools panel. Choose #663300 (dark brown) for the stroke and #CC6600 (light brown) for the fill.



	On the Stage, draw a rectangle that is a little taller than it is wide. You’ll specify the exact size and position of the rectangle in step 6.
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	Select the Selection tool.



	Drag the Selection tool around the entire rectangle to select its stroke and its fill. When a shape is selected, Animate displays it with white dots. You can also double-click a shape, and Animate will select both the stroke and fill of the shape.
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	In the Properties panel, in the Position And Size section, enter 130 for the width and 150 for the height. Press Return (macOS) or Enter (Windows) to apply the values.










Using the Oval tool


Now you’ll create the opening at the top and the rounded bottom.




	In the Tools panel, select the Oval tool.



	Make sure the Snap To Objects button [image: ] in the Doc tab of the Properties panel is selected. This option forces shapes that you draw on the Stage to snap to each other to ensure that lines and corners connect to one another.



	Drag from one side of the rectangle to the other to make an oval that touches both sides. Snap To Objects makes the sides of the oval connect to the sides of the rectangle.
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	Draw another oval near the bottom of the rectangle.
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[image: Image] Note


The last fill and stroke you used are applied to the next objects you create, unless you change the settings before you draw.







Animate drawing modes


Animate provides three drawing modes that determine how objects interact with one another on the Stage and how you can edit them. By default, Animate uses Merge Drawing mode, but you can enable Object Drawing mode or use the Rectangle Primitive or Oval Primitive tool to use Primitive Drawing mode.


Merge Drawing mode


In this mode, Animate merges drawn shapes, such as rectangles and ovals, where they overlap, so that multiple shapes appear to be a single shape. If you move or delete a shape that has been merged with another, the overlapping portion is permanently removed.
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Object Drawing mode


In this mode, Animate does not merge drawn objects; they remain distinct and separate, even when they overlap. To enable Object Drawing mode, select the drawing tool you want to use, and then click the Object Drawing button at the bottom of the Tools panel.


To convert an object to shapes (Merge Drawing mode), select it and choose Modify > Break Apart (Command+B/Ctrl+B). To convert a shape to an object (Object Drawing mode), select it and choose Modify > Combine Objects > Union. The current shape becomes an object, but keep in mind that it doesn’t restore the shape to how it was originally drawn.
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Primitive Drawing mode
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When you use the Rectangle Primitive tool or the Oval Primitive tool, Animate draws your rectangles or ovals as independent objects that maintain some editable features. Unlike with regular objects, you can modify the corner radius and start and end angle of rectangle primitives, and adjust the inner radius of oval primitives using the Properties panel.











Making selections


To modify an object, you must first be able to select different parts of it. In Animate, you can make selections using the Selection, Subselection, or Lasso tool. Typically, you use the Selection tool to select an entire object or a section of an object. The Subselection tool lets you select a specific point or line in an object. With the Lasso tool, you can make a free-form selection.




Selecting strokes and fills


Now you’ll make the rectangle and ovals look more like a coffee cup. You’ll use the Selection tool to delete unwanted strokes and fills.




	In the Tools panel, select the Selection tool.



	Click the fill above the top oval to select it.


The shape above the top oval is highlighted.
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	Press the Delete (macOS)/Backspace (Windows) key.


The fill is cleared from the selected area.
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	Shift-click each of the three line segments above the top oval to select them all, and press Delete/Backspace.


Animate deletes the individual strokes, leaving only the top oval connected to the rectangle.
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	Shift-click the fill and strokes below the bottom oval, and press Delete/Backspace.


The remaining shape appears as a cylinder.
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Editing shapes


When drawing in Animate, you’ll often start with the Rectangle and Oval tools. But to create more complex graphics, you’ll use other tools to modify those base shapes. The Free Transform tool, the Copy and Paste commands, and the Selection tool can help transform the plain cylinder into a coffee cup.




Using the Free Transform tool


The coffee cup will look more realistic if you taper the bottom rim. You’ll use the Free Transform tool to change its overall shape. With the Free Transform tool, you can change an object’s scale, rotation, or skew (the way it is slanted), or distort an object by dragging control points around a bounding box.




	In the Tools panel, select the Free Transform tool [image: ].



	Drag the Free Transform tool around the cylinder on the Stage to select it.


Transformation handles appear on the cylinder.
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	Press and hold Shift+Command/Shift+Ctrl as you drag one of the lower corners inward. Holding these keys while dragging lets you move both corners the same distance simultaneously.
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	Click outside the shape to deselect it.


The bottom of the cylinder is narrow, and the top is wide. It now looks more like a coffee cup.








[image: Image] Tip


If you press the Option or Alt key while moving one of the control points, Animate scales the selected object relative to its transformation point, represented by the circle icon. You can move the transformation point anywhere, even outside the object. Press Shift to constrain the object proportions. Hold Command/Ctrl to distort the object from a single control point.









Using Copy and Paste


Use the Copy and Paste commands to easily duplicate shapes on the Stage. You’ll set the surface level of the coffee by copying and pasting the top rim of the coffee cup.




	Select the Selection tool. Hold down the Shift key and select the top arc and bottom arc of the coffee cup opening.
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	Choose Edit > Copy (Command+C/Ctrl+C). The top strokes of the oval are copied.



	Choose Edit > Paste In Place (Shift+Command+V/Shift+Ctrl+V).


A duplicate oval appears on the Stage, exactly overlying the original that you copied. The duplicate remains selected.



	In the Tools panel, select the Free Transform tool.


Transformation handles appear on the oval.



	Press the Shift key as you drag a corner inward. Make the oval about 10% smaller. Pressing the Shift key lets you change the shape uniformly so that the oval maintains its aspect ratio.
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The top edge of the coffee cup is in place.



	Choose Edit > Paste In Place (Shift+Command+V/Shift+Ctrl+V) one more time to add another duplicate of the original oval to the Stage.



	Select the Free Transform tool. Shift-drag a corner inward to shrink the new oval about another 10% smaller.



	Drag the oval over the rim of the coffee cup so that it overlaps the front lip. You can also press the Down Arrow key to nudge the selected oval down the Stage.
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	Click outside the selection to deselect the oval.



	Select the lower portions of the smaller oval and the upper portions of the bottom oval and delete them.
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Your coffee cup now is complete!










Changing shape contours


With the Selection tool, you can push and pull lines and corners to change the overall contours of any shape. It’s a fast and intuitive way of working with shapes.




	In the Tools panel, select the Selection tool.



	Move your mouse cursor close to one of the sides of the coffee cup.


A curved line appears near your cursor, indicating that you can change the curvature of the stroke.



	Drag the stroke outward.


The side of the coffee cup bends, giving the cup a slight bulge.
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Hold down the Option/Alt key while dragging the sides of a shape to add a new corner point.






	Drag the other side of the coffee cup outward slightly.


The coffee cup now has a more rounded body.










Changing strokes and fills


If you want to change the properties of any stroke or fill, you can use the Ink Bottle tool or the Paint Bucket tool. The Ink Bottle tool changes stroke colors; the Paint Bucket tool changes fill colors.




	In the Tools panel, select the Paint Bucket tool [image: ].



	In the Properties panel, choose a darker brown fill color (#663333).



	Click the top surface of the coffee that is inside the cup.


The fill of the top oval changes to the darker brown color.




[image: Image] Tip


If your Paint Bucket tool changes the fill in surrounding areas, there may be a small gap in the shape outline that allows the fill to spill over. Close the gap manually, or use the Gap Size menu at the bottom of the Tools panel to choose the gap size that Animate will close automatically.
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You can also select a stroke or a fill and change its color by using the Properties panel without selecting the Paint Bucket or Ink Bottle tool.






	In the Tools panel, select the Ink Bottle tool [image: ]. The Ink Bottle tool is hidden under the Paint Bucket tool.



	In the Properties panel, choose a darker brown stroke color (#330000).



	Click the top stroke above the surface of the coffee.


The stroke around the surface of the coffee changes to a darker brown color.
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Using gradient fills


The fill is the interior of the drawn object. Currently, you have selected a solid brown fill color, but you can also use a gradient as a fill, or you can specify that the object have no fill at all.


In a gradient, one color gradually changes into another. Animate can create linear gradients, which change color horizontally, vertically, or diagonally, or radial gradients, which change color moving outward from a central focal point.


For this lesson, you’ll use a linear gradient fill to add three-dimensionality to the coffee cup.




Creating gradient transitions


You’ll use the Color panel to define the colors to use in your gradient. By default, a linear gradient moves from one color to a second color, but you can use up to 15 color transitions in a gradient in Animate. A color pointer determines where each color is defined, and smooth color changes happen between each of the pointers. Add color pointers beneath the gradient definition bar in the Color panel to add more colors and, hence, more gradients.


You’ll create a gradient that moves from tan to white to dark tan on the surface of the coffee cup to give it a rounded appearance.




	Select the Selection tool and then select the fill that represents the front surface of the coffee cup.



	Open the Color panel (Window > Color). In the Color panel, click the Fill Color button and choose Linear Gradient from the Color Type menu.
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The front surface of the coffee cup is filled with a color gradient that changes from left to right.
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	In the Color panel, select the color pointer at the left end of the color gradient definition bar (the triangle above it turns black when selected), and then type FFCCCC in the hex value field to specify a light tan color. Press Return/Enter to apply the color. You can also select a color from the Color Picker or double-click the color pointer to select a color from the color swatches.



	Select the far-right color pointer, and then enter B86241 for a dark tan color. Press Return/Enter to apply the color.
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The gradient fill for the coffee cup changes from light tan to dark tan across its surface.



	Click beneath the gradient definition bar to create a new color pointer.
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	Drag the new color pointer to the middle of the gradient.



	Select the new color pointer, and then type FFFFFF in the hex value field to specify white for the new color. Press Return/Enter to apply the color.
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The gradient fill for the coffee cup now has a highlight on the surface closest to the viewer, gradually changing from light tan to white to dark tan.
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	Deselect the fill on the Stage by clicking elsewhere on the Stage. Select the Paint Bucket tool and make sure the Lock Fill button at the bottom of the Tools panel is unselected.




[image: Image] Tip


If the Lock Fill button isn’t visible on your Tools panel, widen the panel by dragging the left edge (as explained in Lesson 1). This allows multiple columns of tools to be shown.
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To delete a color pointer from the gradient definition bar, simply drag it off the bar.





The Lock Fill option locks the current gradient to the first shape to which it was applied so that subsequent shapes extend the gradient. You’ll want a new gradient for the back surface of the coffee cup, so the Lock Fill option should be unselected.



	With the Paint Bucket tool, select the back surface of the coffee cup.


Animate applies the gradient to the back surface.
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Using the Gradient Transform tool


In addition to choosing colors and positioning the color pointers for a gradient, you can adjust the size, direction, or center of a gradient fill. To squeeze the gradient in the front surface and reverse the gradient in the back surface, you’ll use the Gradient Transform tool.




	Select the Gradient Transform tool. (The Gradient Transform tool is grouped with the Free Transform tool.)



	Click the front surface of the coffee cup. Transformation handles appear.




[image: Image]




	Drag the square handle on the right side of the bounding box inward to squeeze the gradient tighter. Drag the center circle to move the gradient to the left so the white highlight is positioned slightly left of center. You can even rotate the gradient counterclockwise by dragging the round handle in the upper-right corner of the bounding box. Drag slightly to the left so that the gradient tilts along the curve of the cup.
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	Click the back surface of the coffee cup. Transformation handles appear.




[image: Image] Tip


Move the center circle to change the center of the gradient, drag the round handle to rotate the gradient, or drag the square handle to stretch or compress the gradient.






	Drag the round handle on the corner of the bounding box to rotate the gradient 180 degrees so that the gradient fades from dark tan on the left to white to light tan on the right. Narrow the gradient and move it to the right slightly so that the highlight falls on the right side of the inner surface.
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The coffee cup now looks more realistic because the shadows and highlights make it appear that the front surface is convex and the back surface is concave.










Adding a radial gradient


Now you’ll add a deep, rich brown radial gradient for the top surface of the coffee.




	Select the top surface of the coffee with the Selection tool.



	Open the Colors panel and choose Radial Gradient. For the left color pointer, choose a light brown color, and for the right color pointer, choose a deep chocolate brown color.


The top surface of the coffee is filled with a radial gradient that is lighter in the center and darker at the edges.
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	Select the Gradient Transform tool.



	Drag the center point handle of the gradient near the right edge of the cup.



	Drag the width handle to the right to flatten the elliptical gradient so that it is about twice as wide as high.



	Drag the size handle to the left to shrink the ellipse so that the gradient just covers the surface of the coffee.
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[image: Image] Tip


You can also use the Gradient Transform tool to change the width, orientation, size, or rotation of a bitmap fill.





The top surface of the coffee is complete! With subtle variations to linear and radial gradients, you can achieve nice effects that give dimensionality and form to your objects.


Rename the layer containing your completed drawing coffee cup.




[image: Image] Tip


When choosing colors in the Color panel, you can enter a hex code, as you’ve done in these steps, or you can choose one freely from the color picker. The color picker allows you to choose colors based on hue, saturation, brightness, or values of red, green, or blue.













Grouping objects


Now that you’re finished creating your cup of coffee, you can make it into a single group. A group holds together a collection of shapes and other graphics to preserve their integrity. When the elements that compose the coffee cup are grouped, you can move them as a unit without worrying that the cup might merge with underlying shapes. Use groups to organize your drawing.




	Select the Selection tool.



	Select all the shapes that make up the cup of coffee.



	Choose Modify > Group.


The cup of coffee is now a single group. When you select it, a blue-green outline indicates its bounding box.
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	If you want to change any part of the cup of coffee, double-click the group to edit it.


Notice that all the other elements on the Stage dim, and the Edit bar above the Stage displays Scene 1 Group. This indicates that you are now in a particular group and can edit its contents.
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To change a group back into its component shapes, choose Modify > Ungroup (Shift+Command+G/Shift+Ctrl+G).






	Click the Scene 1 icon in the Edit bar at the top of the Stage, or double-click an empty part of the Stage, and return to the main scene.












Using variable-width strokes


You can make many different styles of lines for your strokes. In addition to a solid line, you can choose dotted, dashed, or ragged, or even customize your own. In addition, you can create lines with variable widths and edit the variations with the Width tool.


In this lesson, you’ll use the Pencil tool to create variable-width lines to represent the aroma wafting off the coffee. You’ll also make the aroma slightly transparent. Transparency is measured as a percentage and is referred to as alpha. An Alpha value of 100% indicates that a color is totally opaque, whereas an Alpha value of 0% indicates that a color is totally transparent.




Adding variable-width lines


Now you’ll add some whimsical lines above your coffee illustration to give it some personality.




	On the timeline, insert a new layer above the coffee cup layer and name it coffee_aroma. You’ll draw your lines in this layer.



	In the Tools panel, select the Pencil tool.



	Choose Smooth from the Pencil Mode menu in the Properties panel.




[image: Image]




	In the Color And Style section of the Properties panel, select a dark brown stroke color.



	Enter 15 for the stroke size. From the Style menu, choose Solid, and from the Width menu, choose the thick and thin profile, Width Profile 2.
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[image: Image] Tip


Edit variable-width lines as you would any other stroke. Use the Selection or Subselection tool to bend the curves or move the anchor points.






	Draw a few wavy lines above the coffee.


Animate renders each line with a thick and thin width. Although it appears as a complicated shape, the entire object is a single selectable stroke.
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Editing the width of lines


You can finesse where the bulges appear in your lines and how much of a bulge there is. Use the Width tool to make those edits.




	In the Tools panel, select the Width tool [image: ].



	Move your mouse pointer over one of your variable-width strokes.


Anchor points appear along the line to show you where the thick and thin portions of the line are located.



	Drag the handles at any anchor point to change the width of the line. Exaggerate some of the restrictions and bulges.
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[image: Image] Tip


To delete an anchor point of a variable-width line, click to select the anchor point, and press Delete/Backspace.






	Drag an anchor point along the stroke to move its location.



	Drag anywhere along the stroke to add a new anchor point and define the width at that location. Animate displays a small plus sign next to your pointer to indicate that you can add an anchor point.








[image: Image] Tip


Hold down Option/Alt when you want to modify only one side of a variable-width line.











Using swatches and tagged swatches


Swatches are predefined samples of color. Access them via the Swatches panel (Window > Swatches, or Command+F9/Ctrl+F9). You can also save colors that you’ve used in your graphics as new swatches so you always have them to refer to.


Tagged swatches are specially marked swatches that are linked to the graphics on your Stage that are using them. If you change a tagged swatch in your Swatches panel, all your graphics that use the tagged swatch will be updated.




Saving a swatch


You’ll save a swatch for the brown color that you used for the wisps of coffee steam above the mug.




	Select the Selection tool and click one of the variable-width strokes above your coffee mug.



	Open the Swatches panel (Command+F9/Ctrl+F9) or click the Swatches icon.




[image: Image]



The Swatches panel opens, showing the default colors with gradients in the bottom row.



	Click Create A New Swatch at the bottom of the Swatches panel.


A new swatch appears with the exact color of the coffee wisp that you selected.
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Creating a tagged swatch


You’ll convert your saved swatch to a tagged swatch and use it for all the coffee wisps.




	With the coffee steam color swatch selected, click Convert To A Tagged Swatch at the bottom of the Swatches panel.




[image: Image]



The Tagged Color Definition dialog box appears.



	Enter coffee steam in the Name field and click OK.




[image: Image]



The dialog box closes and a new tagged swatch appears in the Tagged Swatches section of the Swatches panel.
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Using a tagged swatch


You’ll use your new tagged swatch for all your coffee wisps above the mug.




	Select the Selection tool and, holding down the Shift key, click every coffee wisp above the mug.
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	Open the Swatches panel.



	Select the coffee steam tagged swatch.


The selected graphics use the tagged swatch as their color. In the Properties panel, a tagged swatch is indicated by the white triangle in the lower-right corner of the color.
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Updating tagged swatches


The real power of tagged swatches is apparent when you have to make updates to your project. Suppose the art director or your client doesn’t like the color of the coffee steam rising above the mug and wants it to be a different color. Since each wisp uses a tagged swatch, you can simply update the color of the tagged swatch and all graphics using that tagged swatch will update.




	Open the Swatches panel.



	In the Tagged Swatches section of the Swatches panel, double-click the coffee steam tagged swatch.


The Tagged Color Definition dialog box opens with the name and color information.



	Change the color to a different shade of brown. The new color appears in the top half of the color preview window. Click OK to close the dialog box.
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The new color information is saved and all the graphics using the tagged swatch update to the new color.
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Creating curves


You’ve used the Selection tool to pull and push on the edges of shapes to intuitively make curves. For more precise control, you can use the Pen tool.




Using the Pen tool


Now you’ll create a soothing, wavelike background graphic.




	First, change the Stage background to a light brown color (#CC9966).



	Choose Insert > Timeline > Layer, and name the new layer dark_brown_wave.



	Drag the layer to the bottom of the layer stack and then lock all the other layers.
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	In the Tools panel, select the Pen tool [image: ] . If it’s not on the Tools panel, you must add it by choosing Edit Toolbar at the bottom of the panel and dragging it from the drag and drop panel.



	Set the stroke color to a dark brown and Alpha to 100%. Choose Hairline from the Style menu and Uniform from the Width menu.



	Begin your shape by clicking off the left edge of the Stage to establish the first anchor point.



	Move the mouse pointer over the Stage and press—but don’t release!—the mouse button to place the next anchor point. Keep holding the mouse button and drag in the direction you want the line to continue. You will drag out a direction line from the new anchor point, and when you release the mouse button you will have created a smooth curve between the two anchor points.


To learn more about drawing with the Pen tool, see the sidebar “Creating paths with the Pen tool.”



	Continue to move the mouse to the right across the Stage, pressing and dragging out direction lines to build the outline of the wave. Keep going past the right edge of the Stage and click once to set a corner point.




[image: Image]



You have drawn the top edge of your wave; now you need to complete the shape by drawing the bottom.



	Click once below the previous corner point, and then draw a wavy line back to the left across the Stage, similar (but not exactly parallel) to the first curved line. Take care not to place your anchor points directly under the anchor points in the upper line so that the wave has a free-form outline.



	Continue the lower wavy line past the left edge of the Stage and click below the initial anchor point to place another corner point.



	Close your shape by clicking the first anchor point.




[image: Image]




	Select the Paint Bucket tool.



	Set the fill color to a dark brown.



	Click inside the outline you just created to fill it with color.



	Select the Selection tool and double-click the outline to select all of it. Press the Delete key to remove the stroke.
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[image: Image] Note


Don’t worry about making all the curves perfect. It takes practice to get used to the Pen tool. You’ll also have a chance to refine your curves in the next part of the lesson.









Editing curves with the Selection and Subselection tools


Your first try at creating smooth waves probably won’t be very good. Use the Selection tool or the Subselection tool to refine your curves.




	Select the Selection tool.



	Hover over a line segment and look at the arced line segment that appears near your pointer. This indicates that you can edit the curve. If a right-angle segment appears near your cursor, this indicates that you can edit the corner point.



	Drag the curve to edit its shape.
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	In the Tools panel, select the Subselection tool (hidden under the Selection tool).



	Click the outline of the shape.



	Drag the anchor points to new locations or move the handles to refine the overall shape. Lengthening the handles makes the curve flatter. Tilting the handles changes the direction of the curve.
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Deleting or adding anchor points


Once you have added the Pen tool to your Toolbar, additional Pen tool options are also added, hidden under it. Use the hidden tools under the Pen tool to delete or add anchor points as needed.




	Click and hold the Pen tool to access the hidden tools under it.
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	Select Delete Anchor Point Tool.



	Click an anchor point on the outline of the shape to delete it.



	Select Add Anchor Point Tool.



	Click the curve to add an anchor point.








Creating paths with the Pen tool


You can use the Pen tool to create paths that are straight or curved, open or closed. If you’re unfamiliar with the Pen tool, it can be confusing to use at first. Understanding the elements of a path and how to create those elements with the Pen tool makes paths much easier to draw.




[image: ]

Creating a straight line.




To create a straight path, click the mouse button. The first time you click, you set the starting point. Each time that you click thereafter, a straight line is drawn between the previous point and the current point. To draw complex straight-segment paths with the Pen tool, simply continue to add points.




[image: ]

Creating a curved line.


A. Curved line segment


B. Direction point


C. Direction line


D. Selected anchor point


E. Unselected anchor point






[image: ]

Creating a closed path.




To create a curved path, start by pressing the mouse button to place an anchor point, then drag to create a direction line for that point and release the mouse button. Then move the mouse to place the next anchor point and drag out another set of direction lines. At the end of each direction line is a direction point; the positions of direction lines and points determine the size and shape of the curved segment. Moving the direction lines and points reshapes the curves in a path.


Smooth curves are connected by anchor points called smooth points. Sharply curved paths are connected by corner points. When you move a direction line on a smooth point, the curved segments on both sides of the point adjust simultaneously, but when you move a direction line on a corner point, only the curve on the same side of the point as the direction line is adjusted.


Path segments and anchor points can be moved after they’re drawn, either individually or as a group. When a path contains more than one segment, you can drag individual anchor points to adjust individual segments of the path, or select all of the anchor points in a path to edit the entire path. Use the Subselection tool to select and adjust an anchor point, a path segment, or an entire path.


Closed paths differ from open paths in the way that you end each one. To end an open path, select the Selection tool or press Escape. To create a closed path, position the Pen tool pointer over the starting point (a small ° will appear by the pointer) and click. Closing a path automatically ends the path. After the path closes, the Pen tool pointer appears with a small *, indicating that your next click will start a new path.


Excerpted with permission from Adobe Photoshop CC Classroom in a Book. © 2017 Adobe Systems Incorporated and its licensors. All rights reserved.











Using transparency to create depth


Next, you’ll create a second wave to overlap the first wave. You’ll make the second wave slightly transparent to create a rich, layered effect. You can apply transparency to either the stroke or the fill.




Modifying the Alpha value of a fill




	Select the Selection tool and select the shape in the dark_brown_wave layer.



	Choose Edit > Copy.



	Choose Insert > Timeline > Layer, and name the new layer light_brown_wave.




[image: Image]




	Choose Edit > Paste In Place (Command+Shift+V/Ctrl+Shift+V).


The Paste In Place command puts the copied item in the exact same position from where it was copied.



	Move the pasted shape slightly to the left or to the right so the crests of the waves are somewhat offset.
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	Select the fill of the shape in the light_brown_wave layer.



	Choose Window > Color to open the Color panel. Set the fill color to a slightly different brown hue (#CC6666), and then change the Alpha value to 50%.
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You can also change the transparency of a shape from the Properties panel by clicking the Fill Color icon and changing the Alpha value in the pop-up color picker.





The color swatch in the Color panel previews your newly selected color. Transparency is indicated by the gray grid that you can see through the transparent color swatch.












Being expressive with the Fluid Brush and custom brushes


Although the Pen tool excels at making precision curves like the waves you created in the background, it’s not very good for creating spontaneous, expressive marks.


For a more painterly approach, use the Paint Brush or the Fluid Brush tool.


The Paint Brush tool allows you to make shapes that are more organic and free-form as well as shapes with regularly repeating patterns for borders and decorations. Choose from dozens of different brushes, and if you don’t find something you can use, you can customize the brushes or even create your own.


The Fluid Brush tool also makes more painterly marks, but it is designed to respond to pressure from a graphics tablet or the speed at which you draw.


The other difference between the two brushes is that the Paint Brush produces strokes (by default), while the Fluid Brush produces fills.




Exploring the Brush Library for the Paint Brush


You’ll add a little pizzazz to this banner ad by using the Paint Brush tool for the café name and logo. You’ll hand-draw the letters with a brush that simulates rough chalk to provide a rustic atmosphere to the café brand.




	In the timeline, add a new layer on top of your other layers and rename it chalk.



	Drag the Paint Brush tool from the Drag And Drop Tools into the Tools panel.
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	Select the Paint Brush tool. In the Properties panel, choose a nice stroke color that will contrast against the reds and oranges in the artwork that you’ve already created. In this example, we chose a vibrant yellow.



	In the Color and Style section, enter 15 for the stroke size.


This will give you a good thickness for the café lettering.



	Now, to choose your brush style, click Style options next to the Style menu and choose the Brush Library.




[image: Image]



The Brush Library panel opens. Animate organizes all the brushes in large categories in the left column: Arrows, Artistic, Decorative, Line Art, Pattern Brushes, and Vector Pack.



	Select a category to see the subcategories, and select a subcategory to view the individual brushes. For this task, select Artistic > Chalk Charcoal Pencil and double-click the Charcoal — Thick brush. Close the panel.
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The Charcoal — Thick brush is added to the Style menu in the Properties panel, and it becomes the currently active brush style.
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	Unlock the coffee cup and coffee_aroma layers.



	Select the Selection tool and move your coffee mug and its aroma to the side to make some room.



	Select the chalk layer and then select the Paint Brush tool.



	Now for the fun. Hand-letter the name of the café, Mug’s Coffee.
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The chalk-style lettering looks very complex, but it’s controlled by a simple vector line. You can use the Subselection tool to edit the vector path of the paintbrush mark. Push and pull on the stroke, move it, or edit it with the Transform tool just as you would any other vector shape.
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[image: Image] Note


You can also choose to create fills, rather than strokes, with the Paint Brush. In the Properties panel, select the Draw As Fill option. The resulting mark will be a grouped fill.









Creating a pattern


Now it’s time to add a decorative border around your banner ad.




	Create a new layer above all your other layers and rename it border.



	Select the Line tool. Click the Stroke color swatch in the Properties panel and select a muted brown or orange color that would harmonize well with the rest of the background graphics.



	In the Properties panel, click the Brush Library button next to Style.


The Brush Library panel opens, unless it is already open.



	Select Pattern Brushes > Dashed > Dashed Square 1.3. If you find something more appealing, feel free to select it instead. Double-click your choice.
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The Dashed Square 1.3 brush is added to the Style menu, and it becomes the currently active brush style.
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	Create a long horizontal line at the top edge of the Stage and another one at the bottom of the Stage.




[image: Image]





[image: Image] Tip


Hold Shift while drawing with the Line tool to constrain the tool to horizontal or vertical lines.





The dashed regular pattern at the top and bottom of the Stage provides a nice contrast to the curves and chalk-style lettering.








Editing and creating your own Art or Pattern brush


You might not find a brush to your liking in the Brush Library, or you may need something very specific for your project. In either case, you can edit an existing brush or you can create an entirely new one. Pattern brushes repeat a shape over the length of a stroke, whereas Art brushes stretch the base art over the length of the stroke.


To edit a brush, click the Edit Stroke Style button next to the Style menu in the Properties panel.




[image: ]



The Paint Brush Options dialog box appears, with multiple controls for refining how the brush applies the base shapes.




[image: ]



Art brushes and Pattern brushes have different options. Experiment with different spacing, how the shapes repeat or stretch to fit, or how corners and overlaps are handled. When you’re satisfied with your new brush, click Add to add your customized brush to the Style menu.


To create an entirely new brush, first create some shapes on the Stage that you want to base your brush on. For example, if you want to create a train track, create the base art that repeats for a Pattern brush.
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Select the artwork on the Stage, then click the Create New Paint Brush icon at the top of the Properties panel.
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The Paint Brush Options dialog box appears. From the Type menu, you can choose either Art Brush or Pattern Brush, and then refine the brush options. The preview window shows you the results of your chosen options.
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Enter a name for your new brush and click Add. Your new brush will be added to your Style menu and available for you to use.
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Managing paint brushes


If you’ve created a new brush or customized an existing one, you can save it to the Brush Library.




	Click the Manage Paint Brushes button in the Properties panel.
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The Manage Document Paint Brushes dialog box appears, displaying the current paint brushes that you’ve added to the Style menu. It shows you which ones are currently in use on the Stage and which ones aren’t.
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	Select the brushes you want to delete or save to your Brush Library. You cannot delete a brush that is currently in use.


If you save a brush to your Brush Library, it’ll appear in the Brush Library in the category called My Brushes.
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[image: Image] Note


Animate supports input from pressure-sensitive tablets, such as the Wacom graphics tablets, to control variable-width strokes or the Art or Pattern brushes. Pressing harder with the stylus creates fatter strokes, whereas pressing lightly results in thinner strokes. You can adjust the tilt or sensitivity percentages in the Paint Brush Options dialog box to modify the range of thicknesses in the shapes you create. Try drawing with a stylus on a tablet with variable-width strokes enabled for a natural, intuitive way of creating vector images.







Rotating the Stage for easier drawing


When you draw on regular paper, it’s often easier to rotate the page to get a better angle to draw or to write something. In Animate, you can do the same thing with the Stage using the Rotation tool.


The Rotation tool is grouped under the Hand tool in the Tools panel and is also accessible above the Stage.


Select the Rotation tool and click the Stage to specify the pivot point, indicated by a crosshair. Once the pivot point has been established, drag the Stage to rotate it to your desired angle.
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Click the Center Stage button at the top of the Stage to reset the Stage to its normal orientation.
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Using the Fluid Brush


If you have a drawing tablet, then the Fluid Brush can be a source of endless fun, as you can customize the brush in countless ways to respond to both pressure and velocity. In the next task, you’ll replace the coffee aroma wisps that you created previously with the Variable Width tool.




	Select the graphics in the coffee_aroma layer and delete them.



	Select the Fluid Brush tool.



	At the top of the Properties panel, select the option called Change The Brush Size Based On Pointer Velocity.


With this option enabled, the quicker you move your pointer across the Stage, the thicker the resulting mark will be created.



	In the Properties panel, choose a nice brown fill color at 50% Alpha. In the Fluid Brush Options section, explore the numerous customizable features that affect the shape of the brush stroke.
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	In the coffee_aroma layer, draw a few curvy, whimsical wisps above the mug.
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Get a feel for the fluidity and responsiveness that the Fluid Brush provides, and imagine the creative possibilities!












Creating and editing text


Now let’s add text to this illustration. Various options are available for text depending on what kind of document you’re working on. For an HTML5 Canvas document like the one in this lesson, you can use static text or dynamic text.


Use static text for simple display text that uses fonts available on your (the designer’s) computer. When you create static text on the Stage and publish to an HTML5 project, Animate automatically converts fonts into outlines. That means you don’t have to worry about your audience having the required fonts to see the text as you intended it. The downside is that too much text can bloat your file size.


Use dynamic text to leverage web fonts available either through Adobe Fonts (formerly Typekit) or Google Fonts. Thousands of high-quality fonts are available to you through your Creative Cloud subscription, and the fonts are hosted by Adobe and accessible directly through the Properties panel within Animate. High-quality open source fonts are available through Google Fonts, which are hosted on Google servers.


In the next task, you’ll create a tag line for the café and some descriptions of its products. You’ll choose an appropriate web font and add the text.




Using the Text tool to add dynamic text


You’ll create your text with the Text tool.




	Select the top layer.



	Choose Insert > Timeline > Layer, and name the new layer text.



	Select the Text tool.



	Choose Dynamic Text from the Text Type menu in the Properties panel.
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	Drag out a text box under the café name starting near the coffee cup and ending at the right edge of the Stage.



	Begin typing. Enter Taste the difference.
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The text may not fit, or it might not be the size or font that you want. Don’t worry—you’ll select a web font for your text box in the next task.



	Exit the Text tool by selecting the Selection tool.



	Add three more pieces of smaller text on the Stage in the same layer just below your tag line: Coffee, Pastries, and Free Wi-Fi.
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Adding a web font


Now you’ll link a web font to your project. Make sure you have an Internet connection because Animate retrieves the list of available fonts from the web. The processes for adding an Adobe Font and a Google Font are very similar. In this task, you’ll add an Adobe Font.




	Select the “Taste the difference” text and click Add Web Fonts (its icon is a globe) in the Properties panel, in the Character section. Choose Adobe Fonts from the menu that appears.
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Animate displays the Add Adobe Fonts dialog box. The list of fonts can be very slow to load. Be patient!
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	Choose Name from the Sort By menu.
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The list of Adobe fonts on the right is displayed alphabetically. You can choose to sort by date, by popularity, or by other criteria.


The Adobe Fonts are listed with a sample AaBbCcDd string of characters. You can scroll through the font families with the scroll bar on the right. You can also search for specific fonts or use the Category menu to narrow your search.



	For now, peruse the range of typefaces and pick one that you think would suit this banner ad. Click the name of your preferred font under the sample text.


The style variations of that font are displayed.



	Click Select and then OK.




[image: Image]



Your selected Adobe font is added to the list of fonts available. Web fonts appear at the top of the menu.
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	Select your text and apply the new Adobe font. Choose a color that works nicely with the composition. Adjust the font size and/or the line spacing (the space between lines) in the Properties panel (line spacing is in the Paragraph section) to get all the text to fit comfortably in the space.



	Select the other three pieces of text and apply the same font.
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Don’t worry if the text in your banner illustration looks a little different from the one printed in this book. Use your own discretion to pick the font that appeals to you!






Removing a web font


If you change your mind, you can easily remove an Adobe web font and choose a different one.




	Select all the text that uses the web font you want to remove.



	Deselect the font by choosing a different one.



	Click the Add Web Fonts button and choose Adobe Fonts to open the Add Adobe Fonts dialog box.



	Click the Selected Fonts tab.
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Animate displays all the fonts, indicated by a blue checkmark, that have been selected for your project. In this example, the Adobe Font Acuta is selected because it was previously added to our project.


If the font has a gray checkmark, that means you’re still using it in some text on the Stage. You must deselect a font from every bit of text before removing it from your project.



	Deselect the font by clicking it.


Now, no fonts are displayed in the Selected Fonts area.



	Click OK.


The Add Web Fonts dialog box closes. The web font is removed from the Family menu in the Properties panel.










Matching the color of an existing object


If you want to match a color exactly, you can use the Eyedropper tool to sample a fill or a stroke. After you click an object with the Eyedropper tool, Animate automatically switches to the Paint Bucket tool or the Ink Bottle tool loaded with the selected color and associated properties that you can apply to another object.


You’ll use the Eyedropper tool to sample the color of one of the decorative background waves and apply it to the three pieces of smaller text.




	Select the Selection tool.



	Shift-click all three of the smaller pieces of text: Coffee, Pastries, and Free Wi-Fi.
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	Select the Eyedropper tool.



	Click the fill of the shape in the dark_brown_wave layer.
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The three selected pieces of text change color to match the fill of the dark_brown_wave layer. Using the same colors helps to unify the composition.












Aligning and distributing objects


You’ll tidy up the text so that the layout is organized. Although you can use rulers (View > Rulers) and grids (View > Grid > Show Grid) to help position objects, here you’ll use the Align panel, which is more effective when you’re dealing with multiple objects. You’ll also rely on the smart guides that appear when you move objects around the Stage.




Aligning objects


The Align panel, as you might guess, aligns any number of selected objects horizontally or vertically. It can also distribute objects evenly.




	Select the Selection tool.



	Select the first small piece of text, Coffee.



	Move the text box left or right until smart guides appear. Align the left edge of the selected text with the left edge of the larger text above it.




[image: Image]




	Select the third small piece of text, Free Wi-Fi.



	Move the text left or right until smart guides appear. Align the right edge of the selected text with the right edge of the larger text above it.
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	Shift-click all three small pieces of text to select them.
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	Open the Align panel (Window > Align).
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	Deselect the Align To Stage option, if it is selected. Click the Align Bottom Edge button.


Animate aligns the bottom edges of the text.



	Click the Space Evenly Horizontally button.


The selected pieces of text are adjusted so that the spaces between them become uniform.
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[image: Image] Tip


You might have to lock the lower layers so you don’t accidentally select the shapes in the lower layers.







Using rulers and guides


You may want to be more precise in your placement of your graphics. In Lesson 1, you learned how to use the x and y coordinates in the Properties panel to position individual objects. Here, you’ve learned to use the Align panel to align several objects to each other.


Another way to position objects on the Stage is to use rulers and guides. Rulers appear on the top and left edge of the pasteboard to provide measurement along the horizontal and vertical axes. Guides are vertical or horizontal lines that appear on the Stage but that do not appear in the final published movie.


To use rulers, choose View > Rulers (Option+Shift+Command+R/Alt+Shift+Ctrl+R). Horizontal and vertical rulers measured in pixels appear along the top and left edges of the pasteboard. As you move objects on the Stage, tick marks indicate the positions of their bounding boxes on the rulers. The x=0 and y=0 points begin at the upper-left corner of the Stage, with the X values increasing to the right and the Y values increasing going down. Move your mouse pointer over the top horizontal ruler or the left vertical ruler and drag a guide onto the Stage. A colored line appears on the Stage that you can use as a guide for alignment.
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Double-click any guide with the Selection tool to call up the Move Guide dialog box to enter pixel values for precise guide positioning.


Choose View > Snapping and make sure Snap To Guides is selected. Objects will now snap to any guides on the Stage.


Choose View > Guides > Lock Guides to lock your guides. This prevents you from accidentally moving them. Remove all guides by choosing View > Guides > Clear Guides. Change the color of the guides and the snapping accuracy by choosing View > Guides > Edit Guides.











About symbols


Now let’s say you wanted to add another coffee cup to the scene. You could copy the existing cup and paste it into the document, but that would add to the size of your file and performance can suffer. Instead, a better approach is to convert your coffee cup into a symbol so you can use it over and over again.


A symbol is a reusable asset that you can use for special effects, animation, or interactivity. Animate uses three kinds of symbols: graphic, button, and movie clip. You can use a symbol countless times in a project, but Animate includes its data only once. Symbols also make editing easier. If you had two coffee cups on the Stage and wanted to change their color, you’d have to edit two drawings. If they were symbols, you would have to make the edits to only a single symbol.


Symbols are listed in the Library panel. When you drag a symbol to the Stage, Animate creates an instance of the symbol, leaving the original in the library. An instance is a copy of a symbol that has been placed on the Stage. You can think of the symbol as an original photographic negative and the instances on the Stage as prints of the negative. From a single negative, you can create multiple prints.


It’s also helpful to think of symbols as containers for content. A symbol can contain a JPEG image, an imported Illustrator drawing, or a drawing that you created in Animate. At any time, you can go inside your symbol and edit it, which means editing or replacing its contents. Changing the contents of a symbol also causes all the symbol’s instances to change.




[image: Image] Note


In spite of its name, a movie clip symbol isn’t necessarily animated.







Three types of symbols


Each of the three kinds of symbols in Animate is used for a specific purpose. You can tell whether a symbol is a graphic [image: ], button [image: ], or movie clip [image: ] by looking at the icon next to it in the Library panel. Throughout this book, you’ll encounter and learn to use all three symbols.


Movie clip symbols


The movie clip is one of the most versatile types of symbol. When you create animation, you will typically use movie clip symbols. You can apply filters, color settings, and blending modes to a movie clip instance to enhance its appearance with special effects.


A movie clip symbol also contains its own independent timeline. You can have an animation inside a movie clip symbol just as easily as you can have an animation on the main timeline. This makes very complex animations possible; for example, a butterfly flying across the Stage can move from left to right as well as have its wings flapping independently of its movement.


You can also control movie clips with code to make them respond to the user’s input. For example, you can control a movie clip’s position or rotation to create arcade-style games. Or a movie clip can have drag-and-drop behavior, which comes in handy when building a jigsaw puzzle.


Button symbols


Button symbols are used for interactivity. They contain four unique keyframes that describe how they appear when the mouse pointer is interacting with them. However, buttons need code to make them do something.


You can also apply filters, blending modes, and color settings to buttons. You’ll learn more about buttons in Lesson 8 when you create a nonlinear navigation scheme to allow the user to choose what an animation displays.


Graphic symbols


Often you use graphic symbols to build more complex movie clip symbols. They do not support interactivity, and you can’t apply filters or blending modes to a graphic symbol.


Graphic symbols are useful when you have multiple versions of a drawing that you want to easily switch between—for example, when synchronizing lips to sound, keeping all the different mouth positions in individual keyframes of a graphic symbol makes voice syncing easy. Graphic symbols also are used when you need to synchronize an animation inside a symbol to the main timeline.









Creating symbols


There are two main ways of creating a symbol. Both methods are valid; the one you use depends on your preferred way of working.


The first method is to start with nothing selected on the Stage and then to choose Insert > New Symbol. Animate will put you in symbol-editing mode, where you can begin drawing or importing graphics for your symbol.


The second method is to select existing artwork on the Stage and then convert the artwork to symbols. Whatever is selected will automatically be placed inside your new symbol.


Many designers prefer to use the second method because they can create all their graphics on the Stage and see them together before making the individual components into symbols.




[image: Image] Note


When you use the command Convert To Symbol, you aren’t actually “converting” anything; rather, you’re placing whatever you’ve selected inside a symbol.







Converting artwork on the Stage into a symbol


For this task, you’ll select your coffee mug art and then convert it to a movie clip symbol.




	On the Stage, select only the coffee mug group.



	Choose Modify > Convert To Symbol (F8).


The Convert To Symbol dialog box opens.



	Name the symbol coffee mug and choose Movie Clip from the Type menu.
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	Leave all other settings as they are. The Registration grid indicates the registration point (x=0, y=0) of your symbol. This is the point around which all transformations (for example, rotations or scalings) are centered and the point that Animate uses to measure its position on the Stage. Leave the registration at the upper-left corner.



	Click OK. The coffee mug symbol appears in the Library panel.
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You now have a symbol in your library, and an instance of that symbol is on the Stage.












Managing symbol instances


Having a symbol saved in your library allows you to use multiple copies, or instances, of that asset in your project without increasing your file size. Most importantly, every instance doesn’t have to be an exact duplicate of every other instance. Instances can vary slightly from their original master symbol—they can vary in position on the Stage and in size, rotation, and even color, transparency, or applied filters. Next, you’ll add a second cup of coffee and change it slightly so that it appears to be behind the first cup.




Adding another symbol instance


Additional symbol instances are added to the Stage by dragging them from the Library panel.




	Select the coffee cup layer.



	Drag the coffee mug movie clip symbol from the Library panel to the Stage.


A duplicate of your coffee mug graphic appears on the Stage in the coffee cup layer. You now have two instances of the coffee mug symbol on the Stage.
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	Right-click the newly placed instance and choose Arrange > Send To Back.


Your second instance is moved behind the first.
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Changing the size and position of an instance


You’ll now use the Free Transform tool to reduce the size of the second instance so that it appears to be farther in the background.




	Using the Selection tool, click the second instance of the coffee mug on the Stage to select it.



	Select the Free Transform tool.



	Holding the Shift key to constrain its proportions, drag a corner point inward so that the instance gets smaller by about a third or a fourth.
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Changing the color effect of an instance


Each instance can have its own value for transparency, color tint, or brightness. The controls for these settings are in the Color Effects section in the Properties panel.




	Using the Selection tool, select the coffee mug instance that you just made a little smaller.



	In the Properties panel, in the Color Effects section, choose Brightness from the Style menu.



	Drag the Bright slider to −20%.
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The coffee mug instance on the Stage becomes darker and appears to recede into the distance.
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Choosing Advanced from the Style menu allows you to change the tint, transparency, and brightness of an instance at the same time by adjusting the individual color components (RGB) together with the Alpha percentage.







[image: Image] Tip


To reset the color effect of any instance, choose None from the Style menu.









Editing a symbol from the library


You can also edit any symbol at any time. If you decide you want to change the shape of the coffee mug, for example, you can easily go into symbol-editing mode and make that change. You can edit symbols directly from the Library panel whether or not they’ve been used on the Stage.


What’s important to remember is that when you edit a symbol, you’re making changes to the “master,” so those edits will be reflected in all the individual instances of that symbol on the Stage.




	Double-click the coffee mug movie clip symbol icon in the Library panel.


Animate puts you in symbol-editing mode. In this mode, you can see the contents of your symbol—in this case, the coffee mug on the Stage. Notice that the Edit bar at the top of the Stage tells you that you are no longer in Scene 1 but are inside the symbol called coffee mug.
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	With the Selection tool active, double-click the drawing to edit it.


Animate drills down one level deeper to show all the shapes that make up the group. All strokes and fills should be selected, indicated by the dots.



	Click the Stage to deselect all the strokes and fills. Double-click the outline of the cup to select just the outer stroke.



	In the Properties panel, increase the stroke size to 4.0.


The coffee mug now has a thick outline.
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	Click Scene 1 on the Edit bar above the Stage to exit symbol-editing mode and to return to the main timeline.


The thumbnail of the movie clip symbol in the Library panel reflects the changes you made. The same is true of both instances on the Stage. All instances of a symbol change if you edit the symbol.
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You can quickly and easily duplicate symbols in the Library panel. Select the symbol, right-click, and choose Duplicate. Or choose Duplicate from the Library panel menu (in the upper-right corner of the panel). Animate will open a dialog box to give you an opportunity to create an exact copy of the selected symbol in your library.









Editing a symbol in place


You may want to edit a symbol in context with the other objects on the Stage. You can do so by double-clicking an instance on the Stage. You’ll enter symbol-editing mode, but you’ll also be able to see the symbol’s surroundings. This editing mode is called editing in place.




	Using the Selection tool, double-click the large coffee mug movie clip instance on the Stage.


All other objects on the Stage are dimmed and you are put into symbol-editing mode. Notice that the Edit bar shows that you are no longer in Scene 1 but are inside the symbol called coffee mug.
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	Double-click the group to edit it.


The shapes that make up the group inside the symbol are now editable. Note that the Edit bar shows that you are in a group inside the symbol called coffee mug.



	Make some edits to your mug as you see fit. Perhaps make it narrower, change its color, or add a handle as we’ve done in this example, if you’re up for a challenge.
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Notice that, as you edit your symbol in place, the other instance gets updated and reflects all the changes you make.



	Click Scene 1 on the Edit bar above the Stage to return to the main timeline. You can also just double-click any part of the Stage outside the graphic with the Selection tool to return to the next-higher group level.
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Breaking apart a symbol instance


If you no longer want an object on the Stage to be a symbol instance, you can use the Break Apart command to return it to its original form.




	Use the Selection tool to select one of the coffee mug instances on the Stage.



	Choose Modify > Break Apart.


Animate breaks apart the movie clip instance. What’s left on the Stage is a group, which looks the same as the symbol instance. You can break apart the group even further to edit it.



	Choose Modify > Break Apart once more.


Animate breaks apart the group into its individual components, which are the shapes.



	Choose Edit > Undo several times to return your coffee mug to a symbol instance.












Applying filters for special effects


In the previous lesson, you applied filters to keyframes on the timeline. You can also apply filters to symbol instances on the Stage. Use filters to create special effects such as blurs, glows, or drop shadows. Several filters are available in the Filters section of the Properties panel. Each filter has different options that can refine the effect.




Applying the Blur filter


You’ll apply the Blur filter to the smaller coffee mug instance to help give the scene a greater sense of depth.




	Select the smaller coffee mug instance.



	In the Properties panel, expand the Filters section.



	Click Add Filter and choose Blur from the menu.


Properties and values for the Blur filter are displayed.
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	If the link icons next to the Blur X and Blur Y values aren’t already selected, click one of them to constrain the blur effect in both directions.



	Leave Blur X and Blur Y at their default values (4 pixels).


The instance on the Stage becomes blurry, helping to give an atmospheric perspective to this scene.
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It’s best to choose Low from the Quality menu for filters. Higher settings are processor-intensive and can bog down performance, especially if you’ve applied multiple filters.







More filter options


The Options menu at the upper-right corner of the Filters section lists commands that help you manage and apply multiple filters.


Save As Preset lets you save a particular filter and its settings so that you can apply it to another instance. Copy Selected Filter and Copy All Filters let you copy one or more filters, and Paste Filters lets you paste the selected filter(s) to other instances. The Reset Filter command resets the values for the selected filter to the defaults. The Enable Or Disable Filter button (the eyeball icon at the head of the Value column) lets you see your instance with or without the filter applied.











Converting and exporting art


You’ve completed your composition, made up of a simple illustration, layered design and text elements, and symbol instances. You may still need to take additional steps, however, to optimize it for display in the final, published playback environment.




Converting vector art to bitmap art


Vector art, especially art with complex curves and many shapes and different line styles, can put heavy demands on CPU resources. This can especially be a problem on mobile devices, whose less powerful processors struggle to render complex artwork. The Convert To Bitmap command provides a way to turn selected artwork on the Stage into a single bitmap, which can be less taxing on the processor.


Once you’ve converted the object to a bitmap, you can move it without worrying about it merging with underlying shapes. However, the graphics are no longer editable with Animate’s editing tools.




	Select the Selection tool.



	Unlock your layers. Select the wavy coffee aroma lines in the coffee_aroma layer, as well as one of the coffee mug instances in the coffee cup layer.



	Choose Modify > Convert To Bitmap.
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Animate converts the cup of coffee and wavy lines to a single bitmap and stores the bitmap in the Library panel.


Choose Edit > Undo (Command+Z/Ctrl+Z) to undo the conversion to bitmap and revert your coffee mug and aroma strokes to vector graphics.








[image: Image] Note


Another option to improve performance when you have complex vector art is to use the Export As Bitmap command (available only for ActionScript 3.0 documents). This command renders the vector art as a bitmap when you publish your project but keeps the selection as editable vector graphics in the FLA file so that you can still make modifications. Export As Bitmap is accessed from the Render menu in the Display section of the Properties panel.









Exporting art as PNG, JPEG, or GIF


If you want a simple image file in a format such as a PNG, JPEG, or GIF, use the Export Image panel to choose your format and fine-tune the compression for optimal web download performance.




	Choose File > Export > Export Image.


The Export Image dialog box opens. The figure shows the dialog box with GIF chosen from the Optimized File Format menu. The dialog box will look different with other settings.
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[image: Image] Note


To learn more about optimization options for images and different image file formats, check out the Animate User Guide under Workspace and Workflow, “Optimization Options for Images and Animated GIFs.” Instructions for accessing the User Guide are provided in the “Getting Started” section near the start of this book, under “Additional resources.”






	Choose the appropriate file format, select the amount of compression, select a color palette, and even compare different settings to weigh image quality and file size. You can also resize the image.


That Animate provides such a robust environment for creating compelling, rich, and sophisticated graphics and text paired with such flexibility in output options is truly remarkable and something that will help drive all your creative pursuits.
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If your Animate document contains multiple frames, you can also choose to export it as an animated GIF.







Exporting art as SVG


Scalable Vector Graphics (SVG) is a common XML-based format for displaying vector graphics in a browser. You can export your final composition from Animate as SVG, with the choice of embedding or linking any bitmap images. The exported SVG produces a static image of your project. However, SVG supports only static text.


To export your artwork as SVG, do the following:




	Choose File > Export > Export Image (Legacy).



	From the File Format menu, choose SVG Image (*.svg) and click Save.



	In the ExportSVG dialog box that appears, select Embed For Image Location.


The Image Location options determine whether your bitmap images are encoded into the SVG file or kept as separate files and linked to your SVG. Embedding images creates larger SVG files, whereas linking allows you to swap and edit the images easily.



	Click OK.






Animate exports an SVG file with any image data encoded in the text file. An SVG document is a text file marked up much like an HTML document. All the visual information, including corner points, curves, text, and color information, is encoded in a compact form.


When you open an SVG file in your browser, it renders the image, and all the vector information is preserved. Curves remain sharp even up close, and any static text in your composition is selectable.







Creating an Adobe Creative Cloud Library to share assets


Creative Cloud Libraries make your favorite assets available to you anywhere. You can use CC Libraries to create and share your graphics and more, including colors, brushes, symbols, and even entire documents. Share and access them across other Creative Cloud apps whenever you need them. You can also share libraries with anyone who has a Creative Cloud account, so it’s easy to collaborate, keep designs consistent, and even create style guides to use across projects. Your shared library assets are always up to date and ready to use. CC Libraries work much like the Animate Library panel you used in this lesson.


To create a new CC Library to share assets, follow these steps:




	Choose Window > CC Libraries to open the CC Libraries panel, or click the CC Libraries panel icon.



	Click the Library panel menu, and choose Create New Library.


The Create New Library dialog box opens.



	Enter a new name for your library, and then click Create.


Your new CC Library is created. Click the Plus button at the bottom of the library to add assets for sharing.
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To share your CC Library, do the following:




	Open the CC Libraries panel menu and choose Collaborate or Share Link.






If you choose Collaborate, your browser will open and you can invite others to view or edit your CC Library. If you choose Share Link, a public link is created for others to download the assets from your CC Library.







Review questions


1 What are the three drawing modes in Animate, and how do they differ?


2 When would you use each of the selection tools in Animate?


3 What can you do with the Width tool?


4 What is the difference between an Art brush and a Pattern brush?


5 What are web fonts and how are they used in HTML5 Canvas documents?


6 What is a symbol, and how does it differ from an instance?


7 What are the two ways to edit symbols?


8 How can you change the transparency of an instance in Animate?


Review answers


1 The three drawing modes are Merge Drawing mode, Object Drawing mode, and Primitive Drawing mode.




	In Merge Drawing mode, shapes drawn on the Stage merge to become a single shape.



	In Object Drawing mode, each object is distinct and remains separate, even when it overlaps another object.



	In Primitive Drawing mode, you can modify the angles, radius, or corner radius of an object.






2 Animate includes three selection tools: the Selection tool, the Subselection tool, and the Lasso tool.




	Use the Selection tool to select an entire shape or object.



	Use the Subselection tool to select a specific point or line in an object.



	Use the Lasso tool to draw a free-form selection area.






3 Use the Width tool to edit the variable widths of a stroke. You can drag the handle bars of any anchor point to expand or narrow the width, add or delete anchor points, or move anchor points along the stroke.


4 An Art brush uses a base shape and stretches it to fit a vector stroke to simulate an expressive, creative, and often painterly mark. A Pattern brush uses a base shape that repeats to create decorative patterns.


5 Web fonts are fonts specifically created for online viewing that are hosted on a server. Animate offers two kinds of web fonts for inclusion in HTML5 Canvas documents: Adobe Fonts and Google Fonts.


6 A symbol is a graphic, button, or movie clip that you create once in Animate and can then reuse throughout your document or in other documents. All symbols are stored in your Library panel. An instance is a copy of a symbol located on the Stage.


7 To edit a symbol, either double-click the symbol in the library to enter symbol-editing mode, or double-click the instance on the Stage to edit it in place. Editing a symbol in place lets you see the other objects around the instance.


8 The transparency of an instance is determined by its Alpha value. To change the transparency, select Alpha from the Color Effects menu in the Properties panel and then change the alpha percentage.
















  

3 ANIMATING SYMBOLS




Lesson overview


In this lesson, you’ll learn how to do the following:




	Animate the position, scale, and rotation of objects using motion tweening.



	Adjust the pacing and timing of your animation.



	Animate transparency and filters.



	Change the path of an object’s motion.



	Create a nested animation.



	Split a motion tween.



	Change the easing of an object’s motion.



	Animate in 3D space.
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This lesson will take about two hours to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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Use Adobe Animate to change almost any aspect of an object—position, color, transparency, size, rotation, and more—over time. Motion tweening is the basic technique of creating animation with symbol instances.






Getting started


Start by viewing the finished movie file to see the animated title page that you’ll create in this lesson.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Double-click the 03End.mp4 file in the Lesson03/03End folder to play the final animation, which was exported as a high-definition video file.
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The project is an animated opener that would be placed on a website for an imaginary soon-to-be-released motion picture. In this lesson, you’ll use motion tweens to animate several components on the page: the cityscape, the main actors, several old-fashioned cars, and the main title.



	Close the 03End.mp4 file.



	Double-click the 03Start.fla file in the Lesson03/03Start folder to open the initial project file in Animate. This file is an ActionScript 3.0 document that is partially completed and already contains many of the graphic elements imported into the library for you to use. You’ll use all the animation functionality available in an ActionScript 3.0 document, but instead of using the Flash Player for playback in a browser, you’ll export an MP4 video file.



	From the view options above the Stage, choose Fit In Window, or choose View > Magnification > Fit In Window, so that you can see the entire Stage on your computer screen.



	Choose File > Save As. Name the file 03_workingcopy.fla, and save it in the 03Start folder.


Saving a working copy ensures that the original start file will be available if you want to start over.










About animation


Animation is the movement, or change, of objects through time. Animation can be as simple as moving a ball across the Stage from one frame to the next. It can also be much more complex. As you’ll see in this lesson, you can animate many different aspects of a single object. You can change an object’s position on the Stage, change its color or transparency, change its size or rotation, or animate the filters that you saw in the previous lesson. You also have control over an object’s path of motion and even its easing, which is the way an object accelerates or decelerates.


In Animate, the basic workflow for animation goes like this: Select an object on the Stage and choose Create Motion Tween above the timeline. Move the playhead to a different point in time and move the object to a new position or change one of its properties. Animate takes care of the rest by smoothly interpolating the changes between the two points in time.


Motion tweens create animation for changes in position on the Stage and for changes in size, color, or other attributes. Motion tweens require you to use a symbol instance. If the object you’ve selected is not a symbol instance, Animate will automatically ask to convert the selection to a symbol.


Animate also automatically separates motion tweens onto their own layers, which are called tween layers. There can be only one motion tween per layer, and there can be no other element on the layer. Tween layers allow you to change various attributes of your instance at different key points over time. For example, a spaceship could be very small on the left side of the Stage at the beginning keyframe and much larger at the far-right side of the Stage at an ending keyframe, and the resulting tween would make the spaceship both fly across the Stage and slowly grow in size.


The term “tween” comes from the world of classic animation. Senior animators would be responsible for drawing the beginning and ending poses for their characters. The beginning and ending poses were the keyframes of the animation. Junior animators would then come in and draw the “in-between” frames, or do the “in-betweening.” Hence, “tweening” refers to the smooth transitions between keyframes.






Understanding the project file


The 03Start.fla file contains a few of the animated elements already or partially completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and ground—contains an animation. The man and woman layers are in a folder called actors, and the Middle_car and Right_car layers are in a folder called cars.
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You’ll be adding more layers to create an animated cityscape, refining the animation of one of the actors and adding a third car and a 3D title. All the necessary graphic elements have been imported into the library. The Stage is set at a standard HD size, 1280 pixels by 720 pixels, and the Stage color is black. You might need to choose a different view option to see the entire Stage.






Animating position


You’ll start this project by animating the cityscape. It will begin slightly lower than the top edge of the Stage and then rise slowly until its top is aligned with the top of the Stage.




	Lock all the existing layers so you don’t accidentally modify them. Create a new layer above the footer layer and rename it city.
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	Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library panel to the Stage.
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	In the Properties panel, set the value of X to 0 and the value of Y to 90.


This positions the cityscape image just slightly below the top edge of the Stage.
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	Select the cityscape image and choose Create Motion Tween above the timeline, or right-click and choose Create Motion Tween, or choose Insert > Motion Tween.
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	A dialog box appears warning you that your selected object is not a symbol. Motion tweens require symbols. Animate asks if you want to convert the selection to a symbol so that it can proceed with the motion tween. Click OK.
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Although in this task you had Animate automatically convert your object into a symbol for tweening, it’s best practice to do it yourself before animating. That way, you control the naming and choice of the symbol yourself and have a better understanding of all your assets in your library.





Animate automatically converts your selection to a symbol, with the default name Symbol 1, and stores it in your library. Animate also converts the current layer to a tween layer so that you can begin to animate the instance. Tween layers are distinguished by a special icon in front of the layer name, and the frames are tinted gold in the timeline. The range of frames covered by the tween is the tween span. The tween span is represented by all the colored frames from the first keyframe to the last keyframe. Tween layers are reserved for motion tweens; hence, no drawing is allowed on a tween layer.
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	Move the blue playhead to the end of the tween span, at frame 191.
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	Select the instance of the cityscape on the Stage, and while holding down the Shift key, move the instance up the Stage.


Holding down the Shift key constrains the movement to the vertical or horizontal direction.



	For more precision, set the value of Y to 0.0 in the Properties panel.


A small black diamond appears in frame 191 at the end of the tween span. This indicates a keyframe at the end of the tween.


Animate smoothly interpolates the change in position from frame 1 to frame 191 and represents that motion with a motion path on the Stage.
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Temporarily hide all the other layers to isolate the cityscape and to better see the results of the motion tween.
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	Drag the playhead back and forth at the top of the timeline to see the smooth motion. You can also choose Control > Play (or press Return/Enter) to make Animate play the animation.




[image: Image] Tip


Remove a motion tween by selecting the tween and clicking Remove Tween in the Frame tab of the Properties panel. You can also right-click the motion tween on the timeline or the Stage and choose Remove Motion Tween.





Animating changes in position is simple because Animate automatically creates keyframes at the points where you move your instance to new positions. If you want to have an object move to many different points, simply move the playhead to the desired frame and then move the object to its new position. Animate takes care of the rest.








Preview the animation


Integrated into the Timeline panel is a set of playback controls. These controls allow you to play, rewind, or go step by step backward or forward through your timeline to review your animation in a controlled manner. You can also use the playback commands on the Control menu.




	Click any of the playback buttons on the controller above the timeline to play, stop, or step forward or backward one frame. Hold the Step Forward or Step Backward button to move the playhead to the last or first frame.
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	Select the Loop button (to the left of the controller), and then click the Play button.
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The playhead loops, allowing you to see the animation over and over for careful analysis.
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You can also use the Time Scrub tool (hidden under the Hand tool) to move back and forth on the timeline to preview your animation. Select the Time Scrub tool (or hold down Spacebar+T) and drag left and right on the Stage.






	Move the start or end markers in the timeline header to define the range of frames that you want to see looped.


The playhead loops within the marked frames. Click the Loop button again to turn it off.












Changing the pacing and timing


You can change the duration of the entire tween span or change the timing of the animation by dragging keyframes on the timeline.




Changing the animation duration


If you want the animation to proceed at a slower pace (and thus take up a much longer period of time), you need to lengthen the entire tween span between the beginning and end keyframes. If you want to shorten the animation, you need to decrease the tween span. Lengthen or shorten a motion tween by dragging its ends on the timeline.




	Move your mouse pointer close to the end of the tween span in the city layer.


Your pointer changes to a double-headed arrow, indicating that you can lengthen or shorten the tween span.
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	Drag the end of the tween span back to frame 60.
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Your motion tween shortens to 60 frames, reducing the time it takes the cityscape to move.
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	Move your pointer close to the beginning of the tween span (at frame 1).
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	Drag the beginning of the tween span forward to frame 10.
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Your motion tween begins at a later time, so it now plays only from frame 10 to frame 60.
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[image: Image] Note


If you have multiple keyframes in a tween, changing the length of the tween span by dragging one end or the other will distribute all your keyframes uniformly. The relative timing of events in your animation remains the same; only the length changes.









Adding frames


You’ll want the last keyframe of your motion tween to hold for the remainder of the animation. Add frames by Shift-dragging the end of a tween span.




	Move your pointer close to the end of the tween span.



	Hold down the Shift key and drag the end of the tween span forward to frame 191.
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You can also add individual frames by choosing Insert > Timeline > Frame (F5) or remove individual frames by choosing Edit > Timeline > Remove Frames (Shift+F5).





The last keyframe in the motion tween remains at frame 60, but Animate adds frames through frame 191.
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Moving keyframes


If you want to change the pacing of an animation, you can select individual keyframes and then drag them to new positions.




	Click the keyframe at frame 60.


The keyframe at frame 60 is selected. Begin dragging the keyframe. A tiny box appears next to your mouse pointer, indicating that you can move the keyframe.




[image: Image]




	Drag the keyframe to frame 40.
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Now, because the last keyframe in the motion tween is reached earlier in the animation, the motion of the cityscape proceeds more quickly.
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Span-based vs. frame-based selection


By default, Animate uses frame-based selection, which means you can select individual keyframes within a motion tween. However, if you prefer to click a motion tween and have the entire span (the beginning and end keyframes, and all the frames in between) be selected, you can enable Span Based Selection from the Frame View menu in the upper-right corner of the Timeline panel (or you can Shift-click to select the entire span).


With Span Based Selection enabled, you can click anywhere within the motion tween to select it, and move the whole animation backward or forward along the timeline as a single unit.
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If you want to select individual keyframes while Span Based Selection is enabled, hold down Command/Ctrl and click a keyframe.







Moving keyframes vs. changing time in tween spans


Managing the timing of your animation by moving keyframes and stretching or squashing tween spans can sometimes be frustrating because you will get different outcomes depending on what you’ve selected on the timeline and how you drag those selections.


If you want to simply move the location of a keyframe within a tween span, make sure that only a single keyframe is selected, and that the tiny box appears next to your pointer as you begin dragging the keyframe to a new location.


If you want to select individual keyframes while Span Based Selection is enabled, hold down the Command/Ctrl key and click a keyframe.


Consider the following animation, where a ball moves from the left side of the Stage to the bottom edge and then to the right side, making a figure “V.” On the timeline, three keyframes mark the three positions of the ball.
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Moving the middle keyframe changes the timing of when the ball hits the bottom of the Stage.
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When you select a span of frames within a tween, you can compress or expand its duration by dragging the selection when the double-headed arrow appears near the right edge of the selection. A black flag appears indicating when the amount of compression or expansion is a multiple of the original length (x0.5, x2, x4, etc.).
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Understanding frame rate


The speed of your animation is tied to the frame rate of your document (shown in the Properties section of the Properties panel), but do not modify the frame rate to change the speed or duration of your animation.
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The frame rate determines how many frames on the timeline make up one second of time. The default is 30 frames per second (fps). The seconds are marked on the timeline. Frame rate is a measure of how smooth an animation appears—the higher the frame rate, the more frames there are to show the action. Animations at slower frame rates appear choppy because there are fewer frames to show the action. Slow-motion videography depends on very high frame rates to capture action that happens very quickly, such as a speeding bullet or a falling water droplet.


If you want to modify the overall duration or speed of your animation, don’t change the frame rate. Instead, add frames to, or delete frames from, your timeline.


If you want to change the frame rate but keep the overall duration constant, select the Scale Spans option in the Properties panel before you modify the frame rate.











Animating transparency


In the previous lesson, you learned how to change the color effect of any symbol instance to change the transparency, tint, or brightness. You can change the color effect of an instance in one keyframe and change the value of the color effect in another keyframe, and Animate will automatically display a smooth change, just as it does with changes in position.


You’ll change the cityscape in the beginning keyframe to be totally transparent but keep the cityscape in the ending keyframe opaque. Animate will create a smooth fade-in effect.




	Move the playhead to the first keyframe of the motion tween (frame 10).
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	Select the cityscape instance on the Stage.



	In the Color Effects section of the Properties panel, choose Alpha from the Style menu.



	Set the Alpha value to 0%.
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The cityscape instance on the Stage becomes totally transparent, but you can still see the blue bounding box around it.
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	Move the playhead to the last keyframe of the motion tween (frame 40).




[image: Image]




	Make sure that the cityscape instance on the Stage is still selected.



	In the Properties panel, in the Color Effects section, set the Alpha value to 100%.


The cityscape instance on the Stage becomes totally opaque.
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	Preview the effect by choosing Control > Play (or pressing Return/Enter).


Animate interpolates the changes in both position and transparency between the two keyframes.










Animating filters


Filters, which give instances special effects such as blurs and drop shadows, can also be animated. You’ll next refine the motion tween of the actors by applying a blur filter to one of them to make it appear as if the camera changes focus. Animating filters is no different from animating changes in position or changes in color effect. You simply set the values for a filter at one keyframe and set different values for the filter at another keyframe, and Animate creates a smooth transition.




[image: Image] Note


Filters can be applied, but not animated, in an HTML5 Canvas document.







	Make sure that the actors layer folder on the timeline is visible.



	Unlock the woman layer.



	Move the playhead to the beginning keyframe of the motion tween in the woman layer, at frame 23.
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	Select the instance of the woman on the Stage. You won’t be able to see her because she has an alpha value of 0% (totally transparent). Click the upper-right side of the Stage to select the transparent instance. Or click frame 23 in the woman layer in the timeline to highlight it, then click the Object tab in the Properties panel.
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	In the Properties panel, click the Add Filter (+) button in the Filters section, and choose Blur from the menu to add a blur to the instance.
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	In the Filters section of the Properties panel, select the link icon to apply equal values to the x and y directions. Set the Blur X value to 20 pixels.


The Blur Y value also changes to 20 pixels.



	Move the playhead along the entire timeline to preview the animation.


The woman instance is blurred throughout the motion tween.
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	Select frame 140 in the woman layer and choose Insert Keyframe above the timeline.


Animate establishes a keyframe at frame 140.
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	Select frame 160 of the woman layer and choose Insert Keyframe above the timeline to add another keyframe.
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	Select the Object tab of the Properties panel.



	In the Properties panel, change the value of the Blur filter to X=0 and Y=0.
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The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. Animate creates a smooth transition from a blurry instance to an in-focus instance.
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Click the Enable or Disable Filter button in the Filters section of the Properties panel to toggle the visibility of the filter effect on your animation to make your work easier. The Enable or Disable Filter option doesn’t affect the final exported animation, however.
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You can add more than one filter to an animation. Drag the filters to rearrange the order in which they appear in your Properties panel, or collapse each filter to save space in the panel.











Understanding property keyframes


Changes in properties are independent of one another and do not need to be tied to the same keyframes. That is, you can have a keyframe for position, a different keyframe for the color effect, and yet another keyframe for a filter. Managing many different kinds of keyframes can become overwhelming, especially if you want different properties to change at different times during the motion tween. Fortunately, Animate provides a few helpful tools for keyframe management.


When viewing the tween span, you can choose to view the keyframes of only certain properties. For example, you can choose to view only the Position keyframes so that you can see when your object moves. Or you can choose to view only the Filter keyframes so that you can see when a filter changes. Right-click a motion tween in the timeline, choose View Keyframes, and then choose the desired property from the list. You can also choose All or None to see all the properties or none of the properties.
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When inserting a keyframe, you can also insert a keyframe specific to the property you want to change. Right-click a motion tween in the timeline, choose Insert Keyframes, and then select the desired property.


You can also view an advanced panel, called the Motion Editor, to see and edit how the different properties of your object change over the course of the motion tween. You’ll learn more about the Motion Editor in the next lesson.









Animating transformations


Now you’ll learn how to animate changes in scale or rotation. These kinds of changes are made with the Free Transform tool or with the Transform panel. You’ll add a third car to the project. The car will start small and then become larger as it appears to move forward toward the viewer.




	Lock all the layers on the timeline.



	Insert a new layer inside the cars folder, and rename it Left_car.
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	Select frame 75 and insert a new keyframe (F6 or Insert Keyframe button).
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	Drag the movie clip symbol called carLeft from the Library panel to the Stage at frame 75.



	Select the Free Transform tool.


The transformation handles appear around the instance on the Stage.
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	While holding down the Shift key, drag a corner handle inward to make the car smaller.



	In the Properties panel, make sure that the width of the graphic is about 400 pixels.


Alternatively, you can use the Transform panel (Window > Transform) and change the scale of the car to about 29.4%.



	Move the car to its starting position at about X=710 and Y=488.
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	In the Properties panel, in the Color Effects section, choose Alpha from the Style menu.



	Set the Alpha value to 0%.


The car becomes totally transparent.



	Choose Create Motion Tween from the button above the timeline.
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The current layer becomes a tween layer.



	Move the playhead to frame 100.
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	Make sure the transparent instance of the car on the Stage is selected, and in the Properties panel, change the Alpha value to 100%.


A new keyframe is automatically inserted at frame 100 to indicate the change in transparency.



	While holding down the Shift key, drag a corner handle outward to make the car larger. For more precision, use the Properties panel and set the dimensions of the car to width=1380 pixels and height=445.05 pixels.



	Position the car at X=607 and Y=545.
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You have used Animate to tween the change in position and the change in scale as well as the change in transparency from frame 75 to frame 100.



	Move the Left_car layer in between the Middle_car and Right_car layers so that the car in the center overlaps the cars on the side.
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Holding down the Option/Alt key while dragging one corner handle of the bounding box causes the box to resize relative to the opposite corner rather than relative to the object’s transformation point (usually the center).





Save your progress so far in this document, 03_workingcopy.fla.










Editing multiple frames


If you need to make the same change across multiple keyframes, you can use the Edit Multiple Frames option above the timeline. The option allows you to make edits that affect many keyframes in the same layer or even across many different layers.


For example, imagine that you liked the animation of the cars in this project, but you wanted to move the animation to a different location on the Stage. Instead of moving every instance at each keyframe of the animation, the Edit Multiple Frames option lets you do one move for all of them at once.




Moving the animation of the cars


You will move the animation of the cars so that they are centered on the Stage.




	Lock all the layers except the layers in the cars folder.
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	Select and hold the Edit Multiple Frames option above the timeline and choose All Frames.


Brackets appear on the timeline indicating the span of frames that will be editable. The All Frames option automatically puts the brackets at the beginning and end to encompass all the frames of the timeline.
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Choose Selected Range if you want to select only a span of frames. With the Selected Range option, you can move the beginning or end bracket.



	Choose Edit > Select All (Command/Ctrl+A).


All the frames in the layers of the cars folder become selected.
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	While holding down the Shift key, drag the selected group of cars to the left of the Stage. Move the group so that they are generally centered on the Stage.
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You are actually moving multiple instances in multiple keyframes across all three layers at the same time.



	Deselect Edit Multiple Frames.



	Scrub the timeline from frames 70 to 191.
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The three cars remain animated with changes in size, color effect, and position, but they have been moved to the center of the Stage.


In the next section, you’ll work with a different file.












Changing the path of the motion


The motion tween of the left car that you animated shows a colored line with dots indicating the path of the motion. You can easily edit the path of the motion to make the car travel in a curve, or you can move, scale, or rotate the path just like any other object on the Stage.


To better demonstrate how you can edit the path of the motion, open the sample file 03MotionPath.fla in the Lesson03/03Start folder. The file contains a single tween layer with a rocket ship moving from the top left of the Stage toward the bottom right.
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Moving the path of the motion


You will move the path of the motion so that the relative movement of the rocket ship remains the same but its starting and ending positions change.




	Select the Selection tool.



	Click the path of the motion to select it.


The path of the motion becomes highlighted.



	Drag the motion path to move it to a different place on the Stage.
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The relative motion and timing of the animation remain the same, but the starting and ending positions are relocated.










Changing the scale or rotation of the path


You can also manipulate the path of the object’s motion using the Free Transform tool.




	Select the path of the motion.



	Select the Free Transform tool.


Transformation handles appear around the path of the motion.
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	Scale or rotate the path of the motion as desired. You can make the path smaller or larger or rotate the path so that the rocket ship starts from the bottom left of the Stage and ends at the top right.
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Editing the path of the motion


Making your objects travel on a curved path is a simple matter. You can edit the path with Bezier precision using anchor point handles, or you can edit the path in a more intuitive manner with the Selection tool.




	Select the Convert Anchor Point tool, which is hidden in the additional tear-off tools at the bottom of the Toolbar (you’ll have to add it to your Toolbar to use it).
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	Drag from the starting point and the ending point of the motion path on the Stage to pull control handles out from each anchor point.


The handles on the anchor points control the curvature of the path.
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You can also directly manipulate the path of the motion with the Selection tool. Select the Selection tool and make sure the path is deselected. Move your pointer close to the path of the motion. A curved icon appears next to your pointer, indicating that you can edit the path. Drag the path of the motion to change its curvature. Choose the spots where you drag carefully! Each drag breaks the path into smaller segments, making it harder to achieve a smooth curve. Mastery will come with practice.






	Select the Subselection tool.



	Drag the handles at either end of the path to edit its curve. Make the rocket ship travel in a wide curve.




[image: Image]











Orienting objects to the path


Sometimes the orientation of the object traveling along the path is important. In the motion picture promotional project, the orientation of the car is constant as it moves forward. However, in the rocket ship example, the rocket ship should follow the path with its nose pointed in the direction in which it is heading. Orient To Path in the Properties panel gives you this option.




	Select the motion tween on the timeline (Shift-click to select the whole tween).



	In the Properties panel, under the Tweening section, select the Orient To Path option.
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To direct the nose of the rocket ship, or any other object, along the path of its motion, you must orient its position so that it is facing in the direction that you want it to travel. Use the Free Transform tool to rotate its initial position so that it is oriented correctly.





Animate inserts keyframes for rotation along the motion tween to orient the nose of the rocket ship to the path of the motion.
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Swapping tween targets


The motion tween model in Animate is object based. This means that an object and its motion are independent of each other, and you can easily swap out the target of a motion tween. If, for example, you’d rather see an alien than a rocket ship moving around the Stage, you can replace the target of the motion tween with an alien symbol from your Library panel and still preserve the animation. This is especially useful when you want to work out the motion of a character before the design is final. You can create the animation with placeholder graphics and easily swap them in the end with the final versions.
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You can also use the Properties panel to swap instances. Select the object that you want to swap on the Stage. In the Properties panel, click the Swap button. In the dialog box that appears, choose a new symbol and click OK. Animate will swap the target of the motion tween.







	Drag the movie clip symbol of the alien from the Library panel onto the rocket ship.
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Animate asks if you want to replace the existing tween target object with a new object.
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	Click OK.


Animate replaces the rocket ship with the alien. The motion remains the same, but the target of the motion tween has changed.
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If your symbol instance disappears from view after the symbol swap, choose View > Magnification > Show All (Command+3/Ctrl+3) to change the zoom level to show all objects on the Stage.









Creating nested animations


Often, an object that is animated on the Stage will have its own internal animation. For example, the wings of a butterfly moving across the Stage may flap as the butterfly moves. Or the alien that you swapped with the rocket ship could be waving his arms. These kinds of animations are called nested animations because they are contained inside the movie clip symbols. Movie clip symbols have their own timeline that is independent of the main timeline.


In this example, you’ll give the alien his own independent movement so he can wave as he flies across the Stage.




Creating animations inside movie clip symbols


We’ll animate some of the symbols that make up the alien’s body to allow him to wave.




	In the Library panel, double-click the alien movie clip symbol icon.


You are now in symbol-editing mode for the alien movie clip symbol. The alien appears in the middle of the Stage. In the timeline, the parts of the alien are separated in layers.
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	Select the Selection tool.



	Select the alien’s left arm and choose Create Motion Tween.
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Animate converts the current layer into a tween layer and inserts one second’s worth of frames so that you can begin to animate the instance.
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	Select the Free Transform tool.



	Move the mouse pointer near the corner transformation handle until the pointer changes to the rotation icon. Drag the corner handle near the hand to rotate the arm upward to the alien’s shoulder height.
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A keyframe is inserted at the end of the motion tween. The left arm rotates smoothly from the resting position to the outstretched position.



	Move the playhead back to frame 1.



	Create a motion tween for the alien’s other arm. Select his right arm and choose Create Motion Tween.


Animate converts the current layer into a tween layer and inserts one second’s worth of frames.



	Select the Free Transform tool if it’s not selected already.



	As you did for the left arm, drag the corner transformation handle near the right hand to rotate the arm upward to the alien’s shoulder height.
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Animate inserts a keyframe at the end of the motion tween. The arm rotates smoothly from the resting position to the outstretched position.



	Select the last frame in all the other layers and insert frames (F5) so that the head, body, and feet all remain on the Stage for the same amount of time as the moving arms.
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Animations inside movie clip symbols won’t play on the main timeline. Choose Control > Test to preview nested animations, or use the Test Movie button at the upper-right corner of the interface.






	Click the Scene 1 button in the Edit bar at the top of the Stage to exit symbol-editing mode.


Your animation of the alien raising his arms is complete. Wherever you use the movie clip symbol, the alien’s nested animation will continue to play.



	Preview the animation by choosing Control > Test.
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Animate opens a window showing the exported animation. The alien moves along the motion path while the nested animation of his arms moving plays and loops.



	Save your project and close it. You’ll return to your previous animation in the next section.
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Animations inside movie clip symbols will loop automatically. To prevent the looping, you need to add code to tell the movie clip timeline to stop on its last frame. You’ll learn to control those timelines with ActionScript or JavaScript in later lessons.











Easing


Easing refers to the way in which a motion tween proceeds. You can think of easing as acceleration or deceleration. An object that moves from one side of the Stage to the other side can start off slowly, build up speed, and then stop suddenly. Or the object can start off quickly and then gradually slow to a halt. Your keyframes indicate the beginning and end points of the motion, but the easing determines how your object gets from one keyframe to the next.


A simple way to apply easing to a motion tween is to use the Properties panel. Easing values range from −100 to 100. A negative value creates a more gradual change from the starting position (known as an ease-in). A positive value creates a gradual slowdown (known as an ease-out).


A more advanced way of applying eases to a motion tween is to use the Motion Editor, which you’ll learn about in the next lesson.




Splitting a motion tween


Easing affects the entire span of a motion tween. If you want the easing to affect only frames between keyframes of a longer motion tween, you should split the motion tween. For example, return to the 03_workingcopy.fla file of the cinematic animation. The motion tween of the car in the Left_car layer begins at frame 75 and ends at frame 191, at the very end of the timeline. However, the actual movement of the car starts at frame 75 and ends at frame 100. You’ll split the motion tween so that you can apply an ease to the tween just from frame 75 to frame 100.




	In the Left_car layer, select frame 101, which is the frame just after the second keyframe, where the car ends its movement.
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	Right-click frame 101 and choose Split Motion.
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The motion tween is cut into two separate tween spans. The end of the first tween is identical to the beginning of the second tween.
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	In the Middle_car layer, select frame 94, right-click, and choose Split Motion to cut the motion tween into two separate tween spans.



	In the Right_car layer, select frame 107, right-click, and choose Split Motion to cut the motion tween into two spans.


The motion tweens of all three cars have now been split.
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Applying eases to motion tweens


You’ll apply an ease-in to the motion tweens of the approaching cars to give them a sense of weight and to make them decelerate, as real cars would.




	In the Middle_car layer, select any frame between the first and second keyframes of the first motion tween (frame 70 to frame 93).
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	In the Ease section of the Properties panel, enter 100 for the Ease value.
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This applies an ease-out to the motion tween.



	In the Left_car layer, select any frame between the first and second keyframes of the first motion tween (frame 75 to frame 100).
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	In the Properties panel, enter 100 for the Ease value to apply an ease-out to the motion tween.



	In the Right_car layer, select any frame between the first and second keyframes of the first motion tween (frame 78 to frame 106).
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	In the Properties panel, enter 100 for the Ease value to apply an ease-out to the motion tween.



	Select Loop at the top of the Timeline panel and move the start and end markers in the timeline header to frames 60 and 115, respectively.



	Click Play (Return/Enter).


Animate plays the timeline in a loop between frames 60 and 115 so that you can examine the ease-out motion of the three cars. The three cars slow down as they approach their final keyframes, giving them a sense of weight and realism.












Frame-by-frame animation


Frame-by-frame animation is a technique that creates the illusion of movement by making incremental changes between every keyframe. Frame-by-frame animation in Animate is similar to traditional hand-drawn cel animation, where each drawing is on a separate sheet of paper, and it’s just as tedious.


Frame-by-frame animations increase your file size rapidly because Animate has to store the contents for each keyframe. Use frame-by-frame animation sparingly.


In the next section, you’ll insert a frame-by-frame animation inside the carLeft movie clip symbol to make it move up and down in a jittery fashion. When the movie clip loops, the car will rumble slightly to simulate the idle of the motor.




Inserting a new keyframe


The frame-by-frame animations inside the carMiddle and carRight movie clip symbols have already been done. You’ll finish the animation for the carLeft symbol.




	In the Library panel, double-click the carRight movie clip symbol to examine its completed frame-by-frame animation.
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Inside the carRight movie clip, three keyframes establish three different positions for the car and its headlights. The keyframes are spaced unevenly to provide the unpredictable up and down motion.



	In the Library panel, double-click the carLeft movie clip symbol.


You enter symbol-editing mode for the carLeft symbol.
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	Select frame 2 in both the lights layer and the smallRumble layer.



	Choose Insert Keyframe (or F6).


Animate inserts a keyframe in frame 2 of the lights layer and the smallRumble layer. The contents of the previous keyframes are copied into the new keyframes.
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If the image of the car isn’t visible, select Fit In Window from the Zoom menu in the upper-right corner of the Stage.









Changing the graphics


In the new keyframe, change the appearance of the contents to create the animation.




	In frame 2, select all three graphics (the car and its two headlights) on the Stage (Edit > Select All, or Command+A/Ctrl+A) and move them down the Stage by one pixel. Use the Properties panel to decrease the Y-position value by 1 pixel, or press the Down Arrow key to nudge the graphics by one pixel.


The car and its headlights move down slightly.



	Next, repeat the process of inserting keyframes and changing the graphics. For a random motion like an idling car, using at least three keyframes is ideal.


Select frame 4 in both the lights layer and the smallRumble layer.



	Choose Insert Keyframe (or F6).


Keyframes are inserted into frame 4 of the lights and smallRumble layers. The contents of the previous keyframes are copied into the new keyframes.



	Select all three graphics on the Stage (Edit > Select All, or Command+A/Ctrl+A) and move them up the Stage by two pixels. You can use the Properties panel or press the Up Arrow key twice to nudge the graphics by two pixels.


The car and its headlights move up slightly.



	You now have three keyframes for both layers inside the movie clip.
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[image: Image] Note


In this section, you created the car’s idling motion by manually moving the car’s position frame by frame. In the next lesson, you’ll learn to use the Refine Tween panel, which can automatically modify your motion tween to simulate natural movements such as bounces or random jitters (as in the idling of a car).





Test the idling motion by enabling the Loop option at the top of the Timeline panel and clicking Play (Return/Enter). Choose Control > Test to preview the entire animation.












Animating 3D motion


Finally, you’ll add a title and animate it in 3D space. Animating in 3D presents the added complication of a third axis (z). When you choose the 3D Rotation or 3D Translation tool, you need to be aware of the Global Transform option at the bottom of the Tools panel (see the sidebar “Global vs. local transformations”). Global Transform toggles between a Global option (when you select the button) and a Local option (when you deselect the button). Moving an object in global mode makes the transformation relative to the global coordinate system, whereas moving an object in local mode makes the transformation relative to itself.




[image: Image] Tip


You can navigate quickly between multiple keyframes by choosing Control > Step Forward To Next Keyframe (Command+./Ctrl+.) or Control > Step Backward To Previous Keyframe (Command+,/Ctrl+,). You can also click the forward-pointing or backward-pointing arrow to the left of the playback controls at the top of the Timeline panel to move to the next or previous keyframe, respectively.







Global vs. local transformations


When you select the 3D Rotation or 3D Translation tool, be aware of the Global Transform toggle button found at the bottom of the Tools panel when one of the 3D tools is selected. When the button is toggled on (and highlighted), Global mode is engaged and the rotation and positioning of 3D objects are relative to the global, or Stage, coordinate system. The 3D display over the object that you’re moving shows the three axes in constant position, no matter how the object is rotated or moved. Notice in the following image how the 3D display is perpendicular to the Stage.
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However, when the Global Transform option is turned off (the button is not highlighted), Local mode is in force and rotation and positioning are relative to the object. The 3D display shows the three axes oriented relative to the object, not to the Stage. For example, in the following image, notice that the 3D Rotation tool shows the rotation relative to the object, not to the Stage.
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	Click Scene 1 in the Edit bar to return to the main timeline. Insert a new layer at the top of the layer stack and rename it title.
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	Lock all the other layers.



	Insert a new keyframe at frame 120.
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	Drag the movie clip symbol called movietitle from the Library panel onto the Stage.


The movietitle instance appears in your new layer in the keyframe at frame 120.



	Position the title in the empty sky at x=180 and y=90.




[image: Image]




	With the movie title selected, choose Create Motion Tween.


Animate converts the current layer to a tween layer so that you can begin to animate the instance.



	Move the playhead to frame 140.
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	Select the 3D Rotation tool. The 3D Rotation tool is hidden in the additional tear-off tools at the bottom of the Toolbar (you’ll have to add it to your Toolbar to use it).
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The 3D rotation control appears on the selected movie clip.
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	Deselect the Global Transform button at the bottom of the Tools panel to put the 3D Rotation tool into Local mode.



	Drag the left arm of the green Y control to rotate the title around the y axis to angle it so that it seems to recede into the distance. Its angle is at about −50 degrees. You can check the rotation values in the Transform panel (Window > Transform).
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	Move the playhead to the first keyframe, at frame 120.



	Drag upward on the right arm of the Y control to rotate the title around the y axis in the opposite direction so that the instance looks like just a sliver.
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[image: Image] Note


Animating the 3D rotation or translation of a symbol is not currently supported in HTML5 Canvas documents.





The change in the 3D rotation becomes a motion tween, so the title appears to swing in three dimensions.










Exporting your final movie


You can quickly preview your animation by “scrubbing” the playhead back and forth on the timeline, by choosing Control > Play, or by using the Time Scrub tool from the Tools panel. You can also use the integrated controller at the top of the Timeline panel. But to create your final project as a movie, you must export it.


Create an MP4 movie file by exporting the project and converting it in Adobe Media Encoder, a freestanding application that is part of Adobe Creative Cloud (you’ll learn more about Media Encoder in Lesson 10).




	Choose File > Export > Export Video/Media.


The Export Media dialog box opens.
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	Keep Render Size at its original dimensions. Choose H.264 for the format. Click the Output folder to select the destination filename and location. Make sure that the Start Adobe Media Encoder Render Queue Immediately option is selected. Click Export.


Animate generates a temporary SWF file (.swf) and MOV file (.mov) from it. Adobe Media Encoder automatically launches.



	In Adobe Media Encoder, your MOV file should automatically be added to the Queue panel.
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	The encoding process will begin automatically. If it doesn’t, click the Start Queue button (the green triangle) or press Return/Enter to begin the encoding process.


Media Encoder converts the MOV file into an H.264-formatted video with the standard .mp4 extension.
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Congratulations—you’re done! The final file can be uploaded to Facebook, YouTube, or other video-sharing sites or put up on a promotional website for the fictional cinematic release.
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Review questions


1 What are two requirements of a motion tween?


2 What kinds of properties can a motion tween change in an ActionScript 3.0 document?


3 What are property keyframes, and why are they important?


4 How can you edit the path of an object’s motion?


5 What does easing do to a motion tween?


Review answers


1 A motion tween requires a symbol instance on the Stage and its own layer, which is called a tween layer. No other tween or drawing object can exist on the tween layer.


2 A motion tween creates between different keyframes smooth transitions of an object’s location, scale, rotation, transparency, brightness, tint, filter values, or 3D rotation or translation.


3 A keyframe marks a change in one or more properties of an object. Keyframes are specific to each property, so a motion tween can have keyframes for position that are different from keyframes for transparency.


4 To edit the path of an object’s motion, choose the Selection tool and drag directly on the path to bend it. You can also choose the Convert Anchor Point tool and Subselection tool to pull out handles at the anchor points. The handles control the curvature of the path.


5 Easing changes the rate of change in a motion tween. Without easing, a motion tween proceeds linearly, where the same amount of change happens over time. An ease-in makes an object begin its animation slowly, and an ease-out makes an object end its animation slowly.














  

4 ADVANCED MOTION TWEENING




Lesson overview


In this lesson, you’ll learn how to do the following:




	Use the Motion Editor to refine and create complex motion tweens.



	Understand when to use the Motion Editor.



	Change the Motion Editor view.



	Edit a property curve.



	Copy and paste a property curve.



	Use eases to create more realistic motion.



	Add different eases to individual property curves.



	Modify or remove an ease.



	Understand the difference between a property curve and an ease curve.
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This lesson will take about one hour to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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The advanced Motion Editor in Adobe Animate makes creating complicated animation with motion tweens fast and easy. Use the Motion Editor to view how the properties of your motion tween change over time, and apply eases for sophisticated effects.






Getting started


Start by viewing the finished movie file to see the animated infographic that you’ll create in this lesson.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Double-click the 04End.html file in the Lesson04/04End folder to play the animation in a browser.
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The project is a short animated infographic illustrating the idea of China as an emerging economic threat to the highest-traded currencies in the world. The animation is something you might see accompanying a story in the business and economy section of a news site. In the animation, blocks with the American, European Union, and Japanese flags, representing the Dollar, the Euro, and the Yen, respectively, stack themselves up. A moment later, a large hand with the Chinese flag bumps the stack, sending them tumbling down. In this lesson, you’ll use the Motion Editor to make refinements in the motion tweening of the blocks, including the bouncing movements as they fall.



	Close the 04End.html file.



	Double-click the 04Start.fla file in the Lesson04/04Start folder to open the initial project file in Animate. This file is an HTML5 Canvas document that already contains all the graphics created for you, with movie clip symbols saved in the library. Each of the graphics has its own layer, and instances of the symbols have been placed on the Stage in their initial positions.
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	Choose View > Magnification > Clip To Stage to deselect the option (or deselect the Clip Content Outside The Stage button above the Stage) to enable the pasteboard so that you can see all the graphics positioned just off the Stage.



	Choose File > Save As. Name the file 04_workingcopy.fla, and save it in the 04Start folder.


Saving a working copy ensures that the original start file will be available if you want to start over.










About the Motion Editor


You don’t have to use the Motion Editor at all to create your animations. However, if you’re dealing with a motion tween that contains multiple properties that change at different times through the animation (for example, a rocket that fades and rotates as it moves across the Stage), or if you’re handling animation that mimics real-world physics (like bounces and springs), then the Motion Editor can make your task much simpler.


The Motion Editor is an advanced panel that is integrated into the timeline and accessible only when editing a motion tween. The panel shows you how the properties of your animation change over the course of the tween as lines on a graph. It takes some time to become familiar with the meaning of the lines and how the curves translate to visual changes on the Stage. But once you recognize how the curves reflect changes in your animation, you have a powerful tool at your disposal. You can modify the curves on the graph, called property curves, by adding or deleting anchor points, and change their curvature with Bezier precision. You can copy property curves and apply them to other properties or other motion tweens.




[image: Image] Note


The Motion Editor is available only for motion tweens (and not classic tweens, shape tweens, inverse kinematics with the Bone tool, or frame-by-frame animations).





The Motion Editor also allows you to apply sophisticated eases to your animation. Although you can apply eases through the Properties panel, the Motion Editor provides a wider range of ease types, with options to customize any ease. The Motion Editor also visually shows you how your ease affects a property curve. You can even apply different eases to the curves for each of the properties of a tween.






Understanding the project file


The 04Start.fla file has five layers. The background layer contains background elements that will not be animated. The China layer contains the movie clip instance of the hand and Chinese flag representing China. Each of the middle three layers (US, Euro, and Yen) contains a corresponding movie clip instance of a block representing those currencies.
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The Stage is set at 500 pixels by 600 pixels, and the color of the Stage is gray.


For this lesson, you’ll add motion tweens in the top four layers, and refine the movements of the blocks with the Motion Editor.






Adding motion tweens


You’ll start this project by animating the three boxes representing the US Dollar, the Euro, and the Japanese Yen. The three boxes will start below the Stage and rise up.




	Select all three blocks (the ones with the US flag, the European Union flag, and the Japanese flag).



	Right-click the multiple selection and choose Create Motion Tween.
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Animate creates motion tweens for all three movie clip instances and extends the timeline for those three layers to frame 24, representing one second of time.
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	Move the blue playhead to frame 24.



	Add additional frames to the other two layers so they extend to frame 24.



	Select all three blocks and, while holding down the Shift key, move them up onto the Stage. Drag the blocks high enough onto the Stage so that they’ll have room to fall down and tumble over. The American block should be positioned at about Y=160.
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Ending keyframes are added to all three instances.



	Press Return/Enter to preview your animation.


The three blocks move upward onto the Stage, sticking together.










Editing property curves


The motion tween of the three blocks positions them on the Stage for the viewer to see, but the movement is sluggish and not very interesting. To create a more dynamic animation that gives some life and snappiness to the blocks, you’ll modify the curve for their Y-properties in the Motion Editor.




	Double-click the motion tween in the US layer on the timeline, or right-click and choose Refine Motion Tween.
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The motion tween expands to reveal the Motion Editor panel. The Motion Editor contains two straight red lines. One represents the change in the X-position, and the other represents the change in the Y-position. For both properties, the horizontal axis represents time; the vertical lines correspond to the selected property values (in this case, they are the X and Y position in pixels). Both the X- and Y-properties are grouped under the Location property group.
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	Click the disclosure triangle next to Location to reveal the properties it contains, then click the X-property to select it.


The horizontal red line becomes bold, and the downward diagonal line fades. The horizontal red line represents the value of the block’s X-position, which remains unchanged over the span of the motion tween. Note that the scale on the vertical axis of the graph is limited to a range from 238 to 240.
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	Now, select the Y-property.


The downward diagonal line becomes bold, and the horizontal line fades. The diagonal line represents the value of the block’s Y-position, which decreases over the course of the tween (the block moves upward on the Stage). Because of the change in Y-property values, the vertical scale now expands to encompass a wider range.
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Understanding the Motion Editor values


The vertical axis of the Motion Editor represents the values of the selected property measured in pixels. For example, when you select the Y-property, Animate shows the value (in pixels) of the Y-position of the motion tween.


The initial value of the curve appears to be greater than 560, and the final value of the curve appears to be about 200. However, those values don’t seem to match the initial Y values when you look at the position of the US movie clip in the Properties panel. Why the discrepancy?


The Motion Editor measures from the transformation point of your object. Since the transformation point of your object is in the center, the Motion Editor vertical values show the Y-property values as the initial position plus half of the movie clip’s height.




[image: Image]







Adding anchor points


You want to create a nonlinear property curve for the first block that moves on the Stage—that is, you want the block to move a different distance during each interval of time. An object on a linear property curve moves the same distance during each interval of time, which is represented by a straight line in the Motion Editor. A nonlinear path is curved.


To change the shape of the property curve, you add anchor points. At each anchor point you can change the curvature or direction of the curve.




	Select Add Anchor Point On Graph at the bottom of the Motion Editor.
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	Make sure the Y-property curve is still selected, and move your mouse pointer over the property curve.


Your cursor changes to the Pen tool icon with a plus sign, indicating that you can add an anchor point to the curve.
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	Use your mouse to drag the curve downward at frame 21 and release the mouse button when the anchor point is at about the 200-pixel mark (the graph will scroll to follow your pointer).


This adds a new anchor point to the curve, and a new keyframe is added at frame 21.
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The added anchor point allows you to change the motion of your animation. The new curve overshoots the final Y value of the motion tween just before the final keyframe. The resulting motion makes the movie clip move rapidly up, then fall back to its final Y-position value. You can see the motion by pressing the Return/Enter key.




[image: Image] Tip


Remember that you can turn off the visibility of the other layers to make it easier to focus on just the motion of the US block.






	Select Add Anchor Point On Graph again.



	Add a new anchor point at frame 5 and drag it to the right to about frame 8.
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Adding another anchor point to the graph also adds a new keyframe to the motion tween. The new curve looks like a broad, lazy “S” shape, with a smooth flattened slope at the beginning, a steep section in the middle, and the bump at the end.




[image: Image] Tip


You can also double-click a location on a property curve to add a new anchor point.






	Test your new motion by pressing Return/Enter.


Your playhead moves through the motion tween. Your new curve makes your movie clip slowly accelerate into its motion, rapidly shoot past its destination, and then fall back to its ending value.










Changing the curvature


Each new anchor point comes with direction handles on either side that allow you to change the curvature at that point. The anchor points and direction handles work just like the ones created by the Pen tool when drawing paths.




	Click the anchor point on the Y-property curve at the keyframe at frame 21.


The direction handles at the selected anchor point appear.



	Move the anchor point downward until the Y value reaches about 150. Drag the left handle downward so that the direction handles are horizontal.
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The property curve flattens out at frame 21, which makes the movie clip remain at that Y-position for just a split second before moving again. That slight hang-time gives the movie clip a more realistic physics-based motion, just as a ball that you throw up in the air stays still for a moment before falling back to the ground.



	Test your new motion by pressing Return/Enter.


Your playhead moves through the motion tween. Your new curve makes the motion of your movie clip more realistic.








[image: Image] Note


Some anchor points (for example, the first and last anchor points of a property curve) do not have direction handles by default. Select the anchor point you want to add direction handles to, then hold down the Option/Alt key and pull out a direction handle and edit the curvature.









Moving anchor points


You can move any anchor point, including the ones at the first and last keyframes, to new property values along the vertical axis. You can also move any of the anchor points (except the first one) to new times along the motion tween. In effect, when you move anchor points to new times, you move the keyframes within the tween span.
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Option/Alt-click an anchor point to remove its direction handles, converting it to a corner point without smooth curves.







	Select the anchor point at frame 8.


The handle bars at the selected anchor point appear.



	Drag the anchor point slightly to the right.
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The keyframe at frame 8 has now moved a few frames over, to frame 10. The property curve flattens out even more, creating a more extended ease-in effect.
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Hold down Option/Alt as you move a direction handle of an anchor point to change the angle of that direction handle independently of the other handle. You can adjust the length of each direction handle without holding Option/Alt. If you adjust the length or angle of one side of a direction handle independently of the other, you can create more dramatic changes to the property curve.






	Test your new motion by pressing Return/Enter.


The final motion is more interesting than a linear one, with your motion tween rising up and falling back down as If somebody had tossed it up in the air.
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Hold down Shift to constrain the dragging motion to a vertical or horizontal direction.









Deleting anchor points


If you’ve added too many anchor points, you can always remove them (except for the first and last anchor points). Removing an anchor point has the same effect as removing a keyframe of the motion tween.
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You can use the arrow keys to nudge a selected anchor point for precise control. Press the Up or Down Arrow key to move the anchor point one property unit up or down, or Shift-Up or Shift-Down to move the anchor point 10 property units up or down.





Hold down the Command/Ctrl key.


Your cursor turns into the Pen icon with a minus sign when you hover over any anchor point. Click any anchor point (except the first or last).
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Animate removes the anchor point from the property curve. Do not remove any anchor points from your project at this point in the lesson. If you do so inadvertently, press Command+Z (macOS)/Ctrl+Z (Windows) to undo the operation.






Deleting property curves


If you want to delete a curve, click Remove Tween For Selected Property (the trash can icon) at the bottom of the Motion Editor to delete a tween for a selected property curve.
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At the moment, your animation has a tween for only one property—the Y-property—so deleting the curve would remove the property changes in your tween. Use the Remove Tween option if you want to delete the animation of a particular property when you have multiple properties changing.








Viewing options for the Motion Editor


Animate provides different viewing options for the Motion Editor so you can refine your property curves with greater accuracy.
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	Use the menu at the bottom of the Motion Editor to change the zoom level.


The vertical axis expands to show a more granular level of property values. Scroll up or down to see the top or bottom of the curve.



	Click Zoom 100% to reset the Motion Editor to its default view.



	Click Fit To View to expand the Motion Editor to fill the existing space on the timeline. Click the icon again (its name is now Restore View) to return to the default view.
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You can enter a custom magnification level for the Motion Editor, but the minimum value is 100% and the maximum value is 400%.







[image: Image] Tip


You can also hold down the Command/Ctrl key and scroll inside the Motion Editor to change the magnification.









Copying and pasting curves


You’ve spent a lot of effort creating a custom property curve for the motion of the first movie clip. Fortunately, you don’t have to work through the same steps for the other movie clips. Animate provides quick and easy ways to duplicate individual property curves or entire motion tweens.


In the following section, you’ll duplicate the motion of the US block to the European Union and Japanese blocks.




	In the Motion Editor of the motion tween for the US movie clip, select the Y-property under Location.



	Right-click the Y-property curve and choose Copy.
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Animate copies the curve for the Y-property.



	Double-click the motion tween in the Euro layer.


The Motion Editor in the US layer collapses and the Motion Editor in the Euro layer expands. Both the X-property and Y-property curves of the motion tween in the Euro layer are straight, each representing linear motion.
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	Select the Y-property under Location.



	Right-click the Y-property curve and choose Paste To Fit Current Range.
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The property curve data copied from the US clip is applied to the Euro clip, but it is adjusted to fit the range of Y-position values for the Euro clip’s motion.
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The final pasted curve has the correct shape and anchor point curvatures, but it is squeezed to fit the beginning and ending points of the Euro motion tween. That means its ending point is lower on the Stage than you want.



	Hold down the Shift key and drag the final anchor point down so that its property value is identical to the previous anchor point. (The final anchor point should be at a point where the Euro block sits immediately under the US block with no space between them.)
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	Hold down the Shift key and drag the anchor point at frame 21 to about Y=200 in the Motion Editor to re-create the gentle slope in the original curve.
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	Test your new motion by pressing Return/Enter.


Both the US and the European Union blocks slowly ease in to their motion, fly up high, and then settle back down in the middle of the Stage.
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In the Motion Editor, you can use Command+C (macOS)/Ctrl+C (Windows) to copy a selected property curve and Command+V (macOS)/Ctrl+V (Windows) to paste a curve.







Paste vs. Paste To Fit Current Range


When you paste a copied property curve, you have the choice between two commands: Paste and Paste To Fit Current Range. In the previous task, you used Paste To Fit Current Range, which mapped the beginning and end points of the copied curve onto the beginning and end points of its destination.


The simple Paste command will paste the exact property curve—both the shape of the curve and its original values. If you were to choose Paste for your Euro movie clip property curve, it would follow the exact motion on the y axis as the copied curve (the US motion tween). The end result would be the Euro movie clip hiding under the US movie clip.







Duplicating entire motion tweens


Copying and pasting individual curves in the Motion Editor allows you to duplicate the animation of individual properties. For example, you could duplicate the Y-motion of a tween, but not its rotation.


In this project, since you want to duplicate the motion tween of blocks you’ve already finished (which consists of change only along the Y-property), you can use the commands Edit > Timeline > Copy Motion and Edit > Timeline > Paste Motion.


You’ll use Copy Motion and Paste Motion to copy the motion tween of the European Union movie clip and paste it into the Yen movie clip.




	Double-click the motion tween in the Euro layer to collapse the Motion Editor.



	Shift-click the motion tween in the Euro layer.


The entire motion tween span is selected.
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	Right-click and choose Copy Motion, or choose Edit > Timeline > Copy Motion.
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The entire Euro layer motion tween is copied.



	Select the motion tween in the Yen layer.



	Right-click and choose Paste Motion, or choose Edit > Timeline > Paste Motion.
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The property curves of the Yen motion tween now are identical to that of the Euro motion tween, with different beginning and ending values. The Paste Motion duplicates the copied tween but applies it to the object’s starting position.


If you want to refine the motion of the Yen block further, open its Motion Editor. Select the Y-position property and lower the height to which it rises (by dragging the anchor point in frame 21 up slightly) before falling back down. Doing so will create a slight separation between the Yen block and the Euro block. Make minor adjustments to the positions of the property curve keyframes until you’re satisfied with the overall motion.


Wrap things up by closing the Motion Editor.












Adding complex eases


Now that your three blocks representing the US, European Union, and Japanese currencies are animated, it’s time to animate the hand that pushes them. The hand will move horizontally onto the Stage and give the stack of blocks a shove, sending them toppling.


The motion of the hand easing into the Stage and the toppling motion can be quite complex. As the blocks topple, they bounce up and down, decreasing in height after each bounce. The Motion Editor, fortunately, makes much of the motion quick and easy to edit.




Adding the next motion tween


The next motion tween will be applied to the hand of China. The movie clip is positioned just off the left of the Stage, in the layer called China.




	Select frame 90 for all the layers, and press F5 (Insert > Timeline > Frame).
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Animate adds frames to all the layers up to frame 90. This establishes the span of time for the hand to enter and knock over the blocks.



	Select frame 40 in the China layer and insert a new keyframe (F6) to define the moment when the hand starts to move.
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The movie clip instance from the previous keyframe is copied into the new keyframe.



	Right-click the China movie clip instance just off the Stage and choose Create Motion Tween.
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	Move the playhead to frame 55, the point where we want the hand to make contact with the blocks.



	Move the hand straight across the Stage so that its palm butts up against the stack of blocks. (Use the Right Arrow key to keep the movie clip’s motion restricted to a horizontal direction.) The X-position of the instance should be at about 2. Make sure that the Y-position remains at Y=210 in the ending keyframe, as in the beginning keyframe.
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The China movie clip instance is now animated, and it moves straight across the Stage from left to right and stops at frame 55. The movie clip stays at its ending position from frame 55 to frame 90.



	Select frame 56 of the China layer.



	Right-click and choose Split Motion.
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The motion tween in the China layer is split into two motion tweens—one that begins at frame 40 and another that begins at frame 56.
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	At frame 56, right-click and choose Remove Motion Tween.


The motion tween at frame 56 is deleted, leaving the movie clip instance as a static graphic from frame 56 to the last frame of the animation. The motion tween from frame 40 to frame 56 is now ready for an ease.










Adding an ease-in


The Motion Editor provides a host of different ease types that can give a simple motion, like the China movie clip’s shove, a more interesting effect.




	Double-click the motion tween in the China layer, or right-click and choose Refine Motion Tween.


The Motion Editor opens to reveal property curves for both the X- and Y-properties. The X-property curve is angled upward, whereas the Y-property curve is relatively flat.
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	Select the X-property curve.



	Click the Add Ease button at the bottom of the Motion Editor.




[image: Image]



The Ease panel opens, listing the different ease presets grouped by category, from No Ease at the top to Custom Ease at the bottom. The different ease presets change the way the motion tween proceeds from the first keyframe to the last.
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	Double-click the Simple category.


The category opens, revealing Slow, Medium, Fast, and Fastest presets. The eases in the Simple category affect one side of the motion tween (either the beginning or the end). The eases in the Stop and Start categories affect both sides of the motion tween. The eases in the other categories are more complex ease types.
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After you’ve chosen an ease preset, the label on the Add Ease button changes to the name of the preset.
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You can use the Up, Down, Left, and Right Arrow keys to navigate the ease types in the Ease panel of the Motion Editor.






	Select the Fast ease preset.
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The Fast ease curve is displayed, showing graphically the intensity of the ease. Slower eases are fairly shallow and closer to a straight line, whereas faster eases have progressively greater curvature.



	Double-click the Easing value and change it to −60; then press Tab or Return/Enter to exit the entry field and confirm the value. You can also drag on the Easing value to change it (drag left or down to decrease the value; drag right or up to increase it).
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The Easing value determines the strength of the ease for each ease preset and the direction of the ease. A positive number represents an ease-out, and a negative number represents an ease-in.



	Click off the Ease panel to dismiss it, or press the Esc key.
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A dotted line appears in the Motion Editor superimposed on the original property curve. This is called the “resultant curve” and shows the effect of the ease on the tween.



	Close the Motion Editor and test your new motion by pressing Return/Enter.


The motion tween of the China block proceeds slowly, gaining momentum until it finally collides with the stack of smaller blocks in the middle of the Stage.




[image: Image]



If the motion tween is selected, its motion tween path on the Stage shows the position of the instance at each frame. The clustering of the dots on the left side of the tween path means that the object doesn’t move very far in the beginning of its motion but gradually speeds up.










Removing an ease


Eases can be deleted as quickly as you’ve added them.




	Double-click the motion tween in the China layer, or right-click and choose Refine Tween.



	Click the Ease button at the bottom of the Motion Editor, which now bears the label Simple (Fast).


Animate opens the Ease panel, displaying the currently selected ease.



	Select No Ease to remove the ease preset, and press Esc to close the Ease panel.
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	Press Command+Z (macOS)/Ctrl+Z (Windows) to undo the removal of the ease. You’ll keep the ease in place for this project.



	Double-click the China motion tween to close the Motion Editor.








Property curves vs. ease curves


When you apply an ease to a motion tween with the Motion Editor, the original property curve is not altered permanently. In the first section of this lesson, you altered the property curves of a motion tween directly by adding anchor points and changing its curvature. Applying eases is akin to applying a filter that influences the outcome of an original property. Like a filter, the ease can be edited or removed altogether.


It is possible to both modify a property curve and add an ease, but the combined result can be unpredictable.









Animating bounces


As soon as the hand graphic hits the stack of blocks, you’ll want to animate the blocks tumbling down. You’ll create a motion tween with multiple complex eases to create the bouncing effect.




	Drag to select frame 55 in the US, Euro, and Yen layers. (If you are using span-based selection, hold down Command/Ctrl while you drag.)
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	Right-click and choose Split Motion.
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New motion tweens begin at frame 55 in all three layers.
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	Move the playhead to frame 90.



	Move the US movie clip instance to the right of the bottom of the Stage at X=500 and Y=530.
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	Using the Free Transform tool, rotate it 180 degrees clockwise so that it appears upside down.
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	Move the Euro movie clip instance to the bottom just off the Stage in the same manner and use the Free Transform tool to rotate it 90 degrees clockwise. You may have to hide the US layer above it so that you can grab the Euro graphic.
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	Move the Yen movie clip instance to the bottom just off the Stage and use the Free Transform tool to rotate it 180 degrees clockwise. Hide the Euro layer so that the Yen graphic is easier to work with.
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	Test your new motion by pressing Return/Enter.


The three blocks fall gracefully in a diagonal direction, rotating as they fall. You’ll want a more violent, realistic tumble, so the next step is to add some eases.
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Using the BounceIn ease


One of the presets in the Ease panel is BounceIn, which simulates a bouncing motion. The distance to the final property value gradually decreases as the motion tween approaches its ending keyframe.




	Double-click the last motion tween in the US layer to open the Motion Editor.


Animate expands the motion tween in the US layer, revealing the Motion Editor panel. The Motion Editor contains property curves for both the X- and Y-properties for Location as well as the Z-property for Transform > Rotation.
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	Select the Y-property under Location.



	Click Add Ease at the bottom of the Motion Editor to open the Ease panel.



	Double-click the Bounce And Spring category to reveal the presets within.



	Select the BounceIn ease preset and enter 5 for the Easing value.
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The BounceIn ease simulates a bounce that slowly decays as the motion tween approaches its end. The Easing value for the BounceIn ease determines the number of bounces.



	Press Tab to confirm the Easing value and press Esc to close the Ease panel.



	Test your new motion by pressing Return/Enter.
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The US instance bounces (only in the Y-direction) as it falls to the ground. Note the path of the bounce on the Stage defined by the dots.



	Collapse the Motion Editor for the US layer, and expand the Motion Editor for the Euro layer.



	Apply a BounceIn ease to the Euro instance, and change the Easing value to 4.
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	Collapse the Motion Editor for the Euro layer, and expand the Motion Editor for the Yen layer.



	Apply a BounceIn ease to the Yen instance, and change the Easing value to 3.



	Test your new motion by pressing Return/Enter.
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When the three blocks fall, each tumbles with a different number of bounces. The top block bounces the most with five bounces, the middle bounces four times, and the bottom block bounces three times.
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[image: Image] Note


If you’re encountering strange, unpredictable behaviors, check to make sure that you’ve applied the BounceIn ease only to the Y-property curve. You want the bouncing motion to affect only the vertical motion and not the horizontal motion or the rotation.









Applying a second ease to a different property curve


The Motion Editor is powerful because it enables you to treat each property curve of one motion tween independently. For example, you can apply one ease for the Y-property and a different ease for the X-property. This is exactly what you’ll do next. You’ll add an ease-out for the horizontal motion of each instance, while maintaining the BounceIn ease for the vertical motion.




	Expand the Motion Editor for the US layer.



	Select the X-property under Location.
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	Click Add Ease at the bottom of the Motion Editor to open the Ease panel.



	Double-click the Simple category.



	Select the Fast ease preset and enter 50 for the Easing value.
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The Easing value of 50 represents a strong ease-out motion.



	Apply Fast eases with an Easing value of 50 for the X-property curves of the other two motion tweens (the Euro and the Yen instances).



	Test your new motion by pressing Return/Enter.
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As the three blocks bounce to the ground in the Y-direction, their forward momentum gradually slows down, creating a more realistic animation in the X-direction.








Review questions


1 How do you access the Motion Editor for a motion tween?


2 What’s the difference between a property curve and an ease curve?


3 What does the Easing value do to an ease?


4 How do you change the curvature of a property curve?


Review answers


1 To open the Motion Editor panel, double-click a motion tween span on the timeline, or right-click a motion tween span and choose Refine Motion Tween.


2 A property curve is the graphical representation of how a property of a motion tween changes values over time. An ease curve represents a different rate of change that you can apply to an individual property curve. Animate displays the effects of an ease curve on a property curve as a dotted line.


3 The Easing value changes the strength and direction of an ease. Easing values affect eases differently, depending on the type of ease selected. For example, the Easing value for BounceIn eases determines the number of bounces, whereas the Easing value for a Simple Fast ease determines whether the ease is an ease-in or ease-out, and the strength of the ease.


4 To change the curvature of a property curve, select the property in the Motion Editor and select Add Anchor. Click the curve to add a new anchor point and move the direction handles to change the shape of the curve at that point. You can move the anchor points up or down to change the property value, or you can move the anchor points left or right to change the position of the keyframe within the motion tween.
















  

5 CHARACTER ANIMATION




Lesson overview


In this lesson, you’ll learn how to do the following:




	Understand the differences between motion tweening and classic tweening.



	Animate characters with classic tweening.



	Create and edit object hierarchies with layer parenting.



	Swap symbol instances.



	Use the Asset Warp tool to create and animate deformations.



	Understand how the Bone tool creates armatures.



	Automatically synchronize dialogue with graphic symbols.
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This lesson will take about 90 minutes to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.







[image: ]

Sometimes an animation benefits from a simpler approach. Classic tweening, an older method favored among character animators, provides an easy way to animate symbol instances when you don’t need the subtle or advanced controls of motion tweens. Combine classic tweening with layer parenting and automatic lip-syncing to bring your characters to life.






Getting started


Start by viewing the finished project to see the short animation that you’ll create in this lesson.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Double-click the 05End.mp4 file in the Lesson05/05End folder to play the finished video.
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[image: Image] Note


Monkey character design by Chris Georgenes (www.keyframer.com) used with permission.





The project is an animation of a monkey who waves to you and then recites some of Hamlet’s famous “To be or not to be” soliloquy while an annoying fly buzzes around.



	Close the 05End.mp4 file.


As you complete this project, you’ll learn how to animate with classic tweens, create object hierarchies with layer parenting, and synchronize dialogue for character animation.










Layer parenting


Animating characters depends a lot on object hierarchies, which describe how one object is connected to another object. For example, your hand is connected to your forearm, which is connected to your upper arm, which in turn is connected to your torso. When you move your upper arm, your forearm and hand must follow. When you move your torso, all the pieces connected to your torso also move.


Defining how objects are linked creates a hierarchy, which we often describe in terms of relationships: the torso is the parent to the upper arm and the upper arm is the child of the torso.


In Adobe Animate, you create hierarchies for your layers using the Parenting View option in the timeline. In Parenting View, you connect the child layer to the parent layer. A colored line in between the layers shows the relationship. When objects in the parent layer move, so do the objects in the child layer.


The following shows the Parenting View option in the timeline for this finished project. The colored lines connecting the layers indicate the various relationships between the objects in those layers.
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Connecting the monkey parts in Parenting View


To begin animating the monkey character, you need to establish the relationships between the various parts of his body.




	Open the 05Start.fla file and then save it as 05_workingcopy.fla.


The file contains all the completed graphics and symbols saved in the library. Symbol instances have been placed and arranged on the Stage. Each instance is separated on its own layer.
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	On the main timeline, click the Parenting View button.
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The button remains depressed, indicating that Parenting View is enabled. The space after the layer names expands.



	Drag from the colored rectangle in the monkey_mouth layer to the colored rectangle in the monkey_head layer.
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A curvy line connects the monkey_mouth layer to the monkey_head layer. The monkey_mouth is now the child to the monkey_head.
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	Drag from the colored rectangle in the monkey_head layer to the monkey_body layer.
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A curvy line connects the monkey_head layer to the monkey_body. You now have three layers that are connected: the body is connected to the head, which is connected to the mouth. It’s important that your layer names are accurate so that you can easily understand the object relationships on the Stage.
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	Connect the parts of the right arm by dragging from monkey_handR to monkey_forearmR, then from monkey_forearmR to monkey_armR, and then finally from monkey_armR to monkey_body.


You’re always connecting child to parent (not the other way around).
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The monkey’s right arm is now connected to the body. Notice that a single layer—in this case, monkey_body—can have more than one child. However, a child layer cannot have more than one parent.



	Connect the parts of the left arm by dragging from monkey_handL to monkey_forearmL, then from monkey_forearmL to monkey_armL, and then finally from monkey_armL to monkey_body.
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Your Parenting View diagram should look similar to this figure. All layers are connected to the monkey_body except for the monkey_legs layers.










Editing layer parenting


If you make a mistake, you can easily change a layer’s parent or remove a parent.




	To remove a layer’s parent, click the dark gray area to the right of the layer’s name in Parenting View and choose Remove Parent.
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[image: Image] Note


The connections between layers in Parenting View are keyframe based, which means they can be broken and changed in new keyframes.






	To change a layer’s parent, click the layer in the Parenting View section of the timeline and choose Change Parent, and then select a different layer.
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	To change a layer’s parent, you can also simply drag from a layer’s colored rectangle to a new layer.




[image: Image] Note


When you change a layer’s parent, that layer’s children will follow.













Editing layer stacking


Keep in mind that connecting layers in Parenting View is independent from how your layers overlap each other. The order in which your layers appear in the timeline determines how the objects in your layers overlap each other on the Stage.


You can reorder layers to change how objects overlap and still maintain the parent–child connections.




	Drag the monkey_forearmL layer below monkey_armL, and then drag the monkey_handL layer below monkey_forearmL.
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The stacking order of the monkey’s left arm changes so that the hair at the monkey’s wrist more naturally overlaps the monkey’s arm. The parent–child relationships do not change, however.
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	Rearrange the monkey’s right arm parts so that his hand is below his forearm, and his forearm is below his arm.
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Using classic tweens


Now you’re ready to animate our monkey. You’ll start by making it wave to us.


In Lesson 3, you learned to animate a symbol instance with motion tweening, and in Lesson 4, you applied sophisticated eases to tweens for complex motions. In this lesson, you’ll learn to animate objects with classic tweens, an older, but still popular, way of creating animations. Classic tweens are similar to and a bit simpler than motion tweens. Both approaches use symbol instances, and both animate changes in symbol instance properties between two keyframes. For example, classic tweens can animate a symbol instance’s position, rotation, transformation, color effect, or filter, just as motion tweens can. So why use one over the other?


Classic tweens have retained their popularity with many animators, especially character animators, primarily because of the simplicity of the process. Classic tweens animate only instance properties between keyframes, and there is no Motion Editor to worry about. No motion path is displayed on the Stage. (Editing the path requires a separate layer in classic tweens. See the later section “Adding motion guides for classic tweens.”)


The key differences between classic tweens and motion tweens are as follows:




	Classic tweens require a separate motion guide layer to animate along a path.



	Classic tweens are not supported in the Motion Editor.



	Classic tweens don’t support 3D rotations or translations.



	Classic tweens are not separated onto their own tween layer. However, classic and motion tweens share the same restriction that no other object can exist in the same layer as the tween.



	Classic tweens are timeline based and not object based, meaning you add, remove, or swap the tween or the instance on the timeline and not on the Stage.






Learning to create animation with classic tweens will help you understand the full scope of the animator’s toolkit and better prepare you to choose the right approach for any project.




Creating beginning and end keyframes


Classic tweens require a beginning and an end keyframe.




	Select frame 72 in all your layers and add frames (F5) so that you have about three seconds in your timeline to work with this animation.
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	Select frame 8 in the monkey_forearmR layer.



	Choose the Insert Keyframe option from above the Timeline (F6).


A new keyframe appears in frame 8. This will establish the start of the motion to raise the monkey’s arm.
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	Select frame 15 in the monkey_forearmR layer and insert another keyframe.
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You now have an ending keyframe.



	Select the monkey’s right forearm on the Stage.



	Select the Free Transform tool and drag a corner point to rotate the monkey’s forearm upward as if to wave.
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As you rotate the forearm, the hand that’s connected to it automatically follows. You now have a beginning keyframe where the forearm is at the monkey’s hips and an ending keyframe where the forearm is raised.










Applying a classic tween


A classic tween interpolates the changes in a symbol instance between two keyframes.




	Select any frame in between the beginning keyframe (frame 8) and the frame just before the last keyframe.



	Choose Create Classic Tween from the Create Tween menu above the Timeline.
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Animate creates a classic tween between your two keyframes, resulting in the monkey raising its arm and the arm’s child (the hand). Even though only the forearm layer contains keyframes and a tween, the child layer also moves.
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Finishing the arm wave


You’ll insert additional tweens to complete the animation.




	In the monkey_handR layer, insert keyframes (F6) at frames 15, 18, 22, 25, and 29.
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These keyframes will represent the different up and down positions of the hand for the waving motion.



	At frame 18, select the hand on the Stage and choose the Free Transform tool to swivel the monkey’s hand downward.
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	At frame 25, do the same to lower the monkey’s hand.


The resulting keyframes show the hand in alternating up and down positions.



	Select the span of frames between the first keyframe up to a frame before the last keyframe.



	Choose Create Classic Tween above the Timeline.


Tweens are applied across all the keyframes. The monkey raises his arm and waves. Notice that moving a child layer does not affect the parent layer.
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	Insert keyframes (F6) at frames 29 and 35 in the monkey_forearmR layer.
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	In frame 35, select the forearm and select the Free Transform tool. Rotate the forearm downward to bring the attached hand back to the monkey’s hip.
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[image: Image] Note


While changing an instance’s position or rotation in a parent layer affects all the objects in a child layer, the same is not true for color effects or filters. Changes in color effects or filters are not inherited by the objects in the children layers. So if you changed the transparency of the monkey’s forearm, its hand would still remain opaque.






	Select the first keyframe (or any frame between the two keyframes) and choose Create Classic Tween.
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After the monkey waves, his arm lowers to the original position.










Tweening the parent layer


When you tween parent layers, all their children are affected as well. Next, you’ll bend the monkey’s body slightly, and all the connected parts—even those that are animated—will follow.




	In the monkey_body layer, insert keyframes at frames 20 and 35.
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	At frame 20, select the monkey body on the Stage and select the Free Transform tool.



	Rotate the body counterclockwise just slightly to give some overall sway.
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	Select the span of frames between frame 1 and frame 34.



	Choose Create Classic Tween above the Timeline.
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As the monkey sways back and forth slowly between frames 1 and 35, all the connected parts, including its waving right arm, move along with the rotation, maintaining the integrity of the whole character.










Swapping instances


For the animation to be complete, the monkey needs to reach behind his back and pull out a skull to ponder life and death before his soliloquy. You’ll animate his left arm for the motion and then swap his hand instance with another that includes a skull.




	In the monkey_armL layer, insert keyframes at frames 35, 45, and 55.
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	At frame 45 (the middle keyframe), select the monkey’s left upper arm on the Stage.



	Use the Free Transform tool and rotate the upper arm clockwise so that his hand disappears behind his back.
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	Select the span of frames between frames 35 and 54 and click Create Classic Tween above the Timeline.



	In the monkey_forearmL layer, insert keyframes at frames 55 and 59.
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	At frame 59, select the monkey’s left forearm on the Stage.



	Use the Free Transform tool to rotate the forearm counterclockwise so that his arm is extended all the way horizontally.
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	Select the span of frames between frames 55 and 58 and choose Create Classic Tween above the Timeline.
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	Insert a keyframe in the monkey_handL layer at frame 45, where the hand is behind the back.
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	Now you’ll need to swap the hand instances so that when the monkey pulls his hand from behind his back, a skull appears. At frame 45, select the hand on the Stage. You’ll have to hide or lock all the layers above the monkey_handL layer to select it.



	In the Object tab of the Properties panel, click the Swap icon.
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The Swap Symbol dialog box appears, showing you all the symbols in your library. The current symbol has a dot in front of it.



	Select the symbol monkey_hand skull down and click OK.
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The instance of the plain hand is swapped with one that shows a hand holding a skull.



	Unlock or unhide all the layers.



	Insert keyframes at 55 and 59 in the monkey_handL layer and rotate the monkey’s hand in the last keyframe so that it is level with its arm.
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	Apply a classic tween between the keyframes at 55 and 59.




[image: Image] Note


Any classic tween can have an ease applied to it. In the Properties panel, choose Classic Ease for a simple ease-in or ease-out, or choose the options under Classic Ease to create complex and even customized ease curves similar to the ones you learned about in Lesson 4. Later in this lesson, you’ll apply some eases to classic tweens.





As the monkey pulls the skull from behind his back, his hand rotates so that his arm, forearm, and hand are all level.



	Insert a keyframe at frame 60 in the monkey_handL layer.



	Select the hand instance on the Stage and swap it with the monkey_hand skull up symbol.
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The swapped instances work with the tweens to create a smooth, integrated animation.










Adding motion guides for classic tweens


In the next step, you’ll animate the annoying fly that buzzes around our monkey character. The fly moves along a very loopy and convoluted path. To move an object along a specific path, classic tweens require that you draw the path in a separate layer called a motion guide.


A motion guide tells an object in a classic tween how to move from its position in the first keyframe to its position in the last keyframe. Without a motion guide, a classic tween will animate an object’s position in a straight line from the first to the last keyframe. You draw the path in the motion guide. The path can curve, zigzag, or make all sorts of detours as long as the path doesn’t cross itself. The path itself should be a stroke (and not a fill).




	Choose Insert > New Symbol (Command+F8/Ctrl+F8).



	In the Create New Symbol dialog box that appears, enter fly for the name and choose Movie Clip from the Type menu. Click OK.




[image: Image]



Animate puts you into symbol-editing mode for your new movie clip symbol.



	Drag the little fly symbol instance from the Library panel onto the Stage.
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Your movie clip symbol now contains an instance inside of it, which you will animate along a path.



	Insert a keyframe (F6) at about the five-second mark (frame 120) in the layer containing the little fly instance.
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	Select the first keyframe or any frame before the last keyframe and choose Create Classic Tween above the Timeline.


A classic tween is applied between the first and last keyframes, but since the fly is in the same position in both keyframes, there is no motion yet.
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	Right-click the layer on the timeline and choose Add Classic Motion Guide.
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A new layer, called a motion guide, is added above the layer containing your classic tween. The classic tween layer becomes indented under the motion guide, indicating that it will follow any path drawn in the motion guide layer.
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	Select the Pencil tool and choose the Smooth option in the Tool tab of the Properties panel.



	Select the motion guide layer and then start drawing on the Stage. Draw a path for the fly to move on that has many curves but does not cross itself. End the path near the start of the path.




[image: Image]




	Switch to the Selection tool and make sure that Snap To Objects is selected (the magnet icon is depressed) in the Properties panel.
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The Snap To Objects option makes sure that objects align with each other, and it will help position the fly’s registration point on the path.



	Move the playhead to the first keyframe (frame 1) and select Layer_1. Drag the fly so that it snaps to the starting point of the path.
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	Move the fly in the last keyframe so that it snaps to the end of the path.
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	Press Return/Enter to test the effect of the motion guide on the classic tween.


The fly buzzes around the Stage, following the path that is drawn in the motion guide.



	Exit symbol-editing mode, and on the main timeline, add a new layer called fly at the top of your layers.



	Drag an instance of your fly movie clip symbol from the Library panel onto the Stage.
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The movie clip instance contains the animation of the fly buzzing around, which will loop repeatedly when you test the movie (Control > Test).




[image: Image] Note


You can edit the path in the motion guide with any of the editing tools, such as the Selection tool, Subselection tool, or Pen tool. Any change you make to the path will immediately change the object’s motion as long as the object remains snapped to the path in both the beginning and ending keyframes.





Double-click the instance of your fly animation on the Stage to use the Edit In Place function with the symbol. This allows you to see how the path of the fly is positioned relative to the rest of the objects on the Stage. Exit symbol-editing mode to the main timeline and reposition the fly animation so that its path covers the entire Stage. You may have to use Edit In Place a few times to see where the path of the fly is once you reposition the instance.




[image: Image] Note


You can have more than one tween follow the same motion guide. Simply drag your tween layer under a motion guide layer so that all the tween layers are indented.
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[image: Image] Note


When you publish your final animation, the path drawn in the motion guide is not displayed.















Making and animating deformations


There’s something missing: our monkey needs a tail. But not just any static tail—you’ll create and animate a tail that curls and uncurls like a real tail. Animating flexible objects like a curling tail requires some special techniques beyond the usual motion tweening or classic tweening. You could use inverse kinematics, which relies on the Bone tool (see the sidebar “Inverse kinematics with the Bone tool” in this lesson), or shape tweening (covered in Lesson 7), or you could use the Asset Warp tool, which deforms vector shapes or bitmap images. In this section, you’ll learn to use the Asset Warp tool to animate the monkey’s tail.




Asset Warp tool


The Asset Warp tool is similar to the Puppet Warp tool in Adobe Photoshop, which provides you with a visual, net-like mesh over your image to allow you to dramatically distort some parts while leaving other parts intact. The Asset Warp tool can be used either on vector images that you draw in Animate or with bitmap images that you import.




	Double-click the movie clip symbol in the Library panel called monkey tail.




[image: Image] Note


The Asset Warp tool is particularly powerful for bitmap images because no other tool or technique can animate distortions for imported images.





Animate puts you into symbol-editing mode. On the Stage is a simple graphic of a straight tail with a bushy end.
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	Select all the graphics in the symbol (Edit > Select All) and then select the Asset Warp tool [image: ].



	Click inside the monkey tail near the base.


A mesh is created over the entire tail with a single pin point. The pin anchors that part of the image in place.
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[image: Image] Note


If you make a mistake, you can always remove a pin by selecting it and pressing Delete/Backspace.






	Click to create a second pin in the middle of the tail and a third pin at the end of the tail just below the bushy part.
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You now have three anchor points on the tail.



	Drag the third pin (closest to the end of the tail) upward.
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The mesh warps the tail so that it curls upward.
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[image: Image] Note


If the mesh over your image is too distracting, you can deselect the Show/Hide Mesh option in the Warp Options section of the Properties panel to hide the mesh.






	Hold Option/Alt and click the third pin or choose the Fixed Handle mode option in the Properties panel. Move your pointer close to the dashed circle around the pin until your pointer changes to a curved arrow. Rotate the mesh around the pin to rotate the bushy end.
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[image: Image] Note


You can select and move multiple pins at the same time by Shift-clicking your pin points.







[image: Image] Note


To animate a warped mesh, the mesh in the first keyframe and in the last keyframe must have an identical number and position of pins. For example, you can’t have three pins on your mesh in the first keyframe and four pins on your mesh in your last keyframe.









Animating distortions


You’ve created a warped image in one keyframe. Now you’ll create another warped image in a later keyframe and animate the changes.




	Insert a keyframe in frame 16.



	Insert another keyframe in frame 40.


You now have three keyframes with identical meshes over the monkey tail.
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	Select the middle keyframe (in frame 16).



	With the Asset Warp tool, drag the pins to uncurl the monkey tail slightly.
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	Select any frame in between the first and second keyframes, then choose Create Classic Tween above the Timeline.


A classic tween is applied between your first mesh and your second mesh, and the tail uncurls smoothly.



	Select any frame in between the second and third keyframe, then choose Create Classic Tween above the Timeline.


A classic tween is applied between your second mesh and your third mesh, and the tail curls again.
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	Add frames (F5) to frame 72 so that the tail remains curled for three seconds.
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[image: Image] Note


You can choose whether to rotate or move a pin using the Handle mode options. When an object has a mesh applied and the Asset Warp tool is selected, the Warp Options area appears in the Properties panel. Select one of the Handle mode options: Use the Fixed option if you want the pin to anchor the image in a rigid fashion and allow rotation. Use the Open option (the default setting) if you want the pin to have a little flexibility with no rotation. You’ll get more natural warping results if you use the Open option. Switch modes for any pin using Option/Alt-click.






	Exit symbol-editing mode.



	Create a new layer at the bottom of all your other layers and rename the new layer monkey_tail. Drag an instance of the monkey tail movie clip from the Library panel into the new layer. Position the tail behind the monkey (where a tail should be!).




[image: Image]




	Test your movie (Control > Test) or press the Test Movie button at the upper-right corner of the Animate interface.


The warped tail curls and uncurls as the rest of the animation proceeds.
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[image: Image] Tip


Double-click a warped shape to edit the original. For example, you can double-click your curled monkey tail inside the movie clip symbol to change the color of the fill, and the distortions will apply to the new, edited shape.









Classic tween easing


Classic tweens can also have eases, which will make your motions look more natural. You’ve learned to apply eases to motion tweens in previous lessons. For classic tweens, eases are applied from the Properties panel.




	Double-click the monkey tail movie clip symbol in the Library panel to enter symbol-editing mode, and move the playhead between the first and second keyframe.
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	In the Properties panel, enter –100 for the Classic Ease value.
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A negative value represents an ease-in, where an object gradually starts off from its initial keyframe.



	Select any frame between the second and third keyframe in your monkey tail movie clip symbol.



	In the Property panel, enter 100 for the Classic Ease value.
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A positive value represents an ease-out, where an object starts off quickly but gradually slows down as it moves toward its next keyframe.



	Press Return/Enter to preview the effects of the ease-in and ease-out on the animation of the tail. Exit symbol-editing mode to return to the main timeline.


The tail uncurls slowly and then snaps back a little quickly. The eases give the animation a little more of an interesting movement.








Advanced easing for classic tweens


For advanced control over easing for classic tweens, click the Edit Easing button in the Properties panel. The Custom Ease dialog box will appear, showing you the ease profile for the animation. This profile is identical to the ease profiles that you learned about in Lesson 4.
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The graph shows you how a property value changes from the first keyframe to the last keyframe. In this example, the curved line means that, in the beginning, the change is fast, but near the end, the changes in value slow down. You can edit the ease profile in any frame by simply clicking the graph to add an anchor point. Move the handles to change the curve of the graph to change the ease.
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Graphic symbols for lip-syncing dialogue


So far, you’ve been using movie clip symbols for your animation, and you’ve seen that they allow for independent nested animations. The monkey’s tail, for example, curls at its own pace while the main timeline animates the monkey limbs. And the fly buzzes around independently on its own timeline while everything else is happening. But you can also have nested animations and graphics inside graphic symbols, although they work a little differently.


An animation inside a graphic symbol doesn’t play independently the same way it does in a movie clip symbol. It will play only if there are sufficient frames on the main timeline where the instance is placed. In other words, the two timelines are synchronized. And while you can control the internal playhead of a movie clip timeline with code, you can control the playhead of a graphic symbol only from the Properties panel. Because of the ease with which you can choose what frames appear inside graphic symbols, they are ideal for lip-syncing or other character variations.




Using the Frame Picker and lip-syncing


When animated characters talk, their mouths should be synchronized with their words. Each sound, or phoneme, is produced by a different mouth shape. For example, an explosive “p” or “b” sound is made by closing the lips, and an “o” sound is made by a rounded open mouth. Animators draw a collection of these mouth positions, called visemes, to synchronize to the soundtrack.


You can store each mouth position as a keyframe in a graphic symbol. The Frame Picker panel (accessed from the Properties panel) lets you choose the frame on the timeline that matches each sound.


Animate also includes a powerful feature that analyzes any imported voice recording to detect individual phonemes and then automatically applies the correct viseme from a graphic symbol to create lip-syncing animation.


In this exercise, you’ll use the Frame Picker panel and the Lip Syncing feature to animate the mouth of the monkey to match imported dialogue.




	Create a new layer at the top of all the other layers and rename it audio.
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	Insert a new keyframe (F6) at frame 72, three seconds into the animation and just after the animation of the monkey holding the skull finishes.



	Drag the sound file called To_Be_or_Not.wav from the Library panel onto the Stage. The audio file is a recording of Hamlet’s famous soliloquy pondering life and death.
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The sound file gets added to the audio layer in the keyframe at frame 72. A tiny waveform representing the audio file is displayed in the keyframe.
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	With frame 72 selected, in the Sound area of the Properties panel, choose Stream from the Sync menu.
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The Stream option ties the audio to the timeline so that you can synchronize animation to it.



	Extend the timeline for all your layers to frame 938—enough frames so that the entire audio file can play to the end. When you’ve added the frames, you’ll see the end of the sound file represented in the audio layer.
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	In the Library panel, double-click the graphic symbol mouth_positions to examine it.
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Animate takes you to symbol-editing mode for the mouth_positions symbol. Notice that in the bottom layer, there are 12 individual keyframes, each containing a different graphic corresponding to a mouth position for a specific sound.
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In the top layer, individual keyframes are labeled (indicated by red flags). In the Properties panel each label has a different name corresponding to the phoneme.
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The first keyframe is labeled “neutral” because the mouth position is closed in a resting state. The second keyframe is labeled “Ah” because the mouth position is open in a way that produces that particular sound.


When you create your own lip-synced animation, you’ll want to set up a graphic symbol similar to this one, where you draw 12 different mouth positions in 12 different keyframes.



	Exit Symbol Editing mode.



	Select the mouth_positions symbol instance on the Stage in the monkey_mouth layer.




[image: Image]




	In the Properties panel, click the Lip Syncing button.
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The Lip Syncing dialog box opens. The first step is to set up the visemes. A grid of 12 visemes is displayed, each associated with a specific phoneme. At first, all of the visemes are set to the same graphic. You’ll change that next.
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	Click the first viseme marked as “neutral.”


A menu opens allowing you to choose one of your frames from the mouth_positions graphic symbol. The labeled keyframes from your graphic symbol correspond to the required visemes, making the matching process simple. Select the “neutral” keyframe.
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	Click the second viseme marked as “Ah,” and in the menu that opens, select the second keyframe from your graphic symbol labeled “Ah.”


Animate matches the second keyframe from your graphic symbol to the “Ah” viseme.



	Continue setting all 12 visemes by matching them with the corresponding keyframes from your graphic symbol.
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	Now move on to step 2 in the Lip Syncing dialog box. Choose the layer named audio from the menu, if it is not already chosen. This is the sound file that Animate will use to match the visemes.
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	Click Done.


Now sit back and watch the magic happen!
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Animate will process the selected audio file and then automatically create labeled keyframes in the monkey_mouth layer with the correct keyframe from your graphic symbol to synchronize the dialogue.
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	Press Return/Enter to play the animation.
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As the sound file plays, the graphic symbol switches from one of its keyframes to another, matching the sound to the correct mouth position.



	If you want to make any adjustments to a particular mouth position at any keyframe, select the instance on the Stage and choose Frame Picker in the Properties panel.
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In the Frame Picker panel that appears, you can manually choose a different keyframe from your graphic symbol.










Adding head motion


Whenever characters talk, there is usually other motion besides their mouth opening and closing. There may be times when the head may tilt or shake, a nose may wrinkle, or an eyebrow may rise. These are all important movements that contribute to an animation’s overall naturalness. The monkey_head movie clip symbol already includes a few keyframes to make occasional blinks and eye movements, but you’ll add slight head tilts as well.




	Insert keyframes in the monkey_head layer at frames 89, 94, 102, and 109.
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	In the keyframe at frame 94, select the monkey head instance and choose the Free Transform tool.



	Rotate the head slightly clockwise about nine degrees to give some head tilt just as the monkey begins to speak. Make the same rotation in frame 102.
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Since the monkey_head layer is a parent to the monkey_mouth layer, the rotation also affects the monkey mouth.



	Select any frame between frames 89 and 94 and choose Create Classic Tween above the Timeline.


The slight head tilt is animated.



	Select any frame between frames 102 and 109 and choose Create Classic Tween above the Timeline.


The monkey’s head animates back to its normal position.
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	Experiment with adding little head bobs and tilts along the timeline for emphasis to the dialogue and to give some visual variety to the animation. Have fun with giving your character some attitude and making it come to life!


As you did in Lesson 3, export your finished project as a video (File > Export > Export Video/Media) using the Adobe Media Encoder to produce an MP4 video file.








Inverse kinematics with the Bone tool


Another option for character animation is to create an armature with the Bone tool. An armature is like a puppet, where each part is connected to another part in a hierarchical fashion. If you move one part, the connected parts follow. The calculations that are required to move all the parts of an armature naturally are called inverse kinematics.


Building armatures


You use the Bone tool to create an armature. The Bone tool tells Animate how a series of movie clip instances are connected or provides the jointed structure within a shape. Each rigid piece that makes up an armature is called a bone, and the connections between bones are called joints. Using the Bone tool for character animation is an alternative to layer parenting.


There are two ways to use the Bone tool. First, you can place a series of movie clip instances on the Stage and connect the instances by dragging from the parent movie clip to the child movie clip. Our monkey from this lesson could be rigged as an armature with the Bone tool, as shown in the following figure.
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Showing all layers as outlines helps you visualize only the armature. Pulling on the hand moves all the connected bones accordingly.
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The second way to use the Bone tool is to define the armature inside a shape. An armature inside our monkey’s tail could be created as shown in the next figure. Pulling on the end of the armature moves the shape in a connected fashion.
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You can edit each bone’s relative position. Holding down the Option/Alt key allows you to move the position of any bone in your armature.


If you want to change the point where one bone connects to another, use the Free Transform tool to move its transformation point. This also moves the rotation point of the bone.


Animating armatures with poses


When you create an armature, Animate automatically puts it in a special layer called an armature layer. This special type of layer keeps your armatures separate from other objects on the timeline, such as graphics or motion tweens.
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To create an animation with your armature, you define keyframes, called poses, in this layer. In the timeline, you insert poses just as you would insert keyframes for a motion tween. Animate will also automatically insert a new pose if you move your armature at a different frame along the timeline. Animate calculates the angles for the different bones to get from one pose to the next to create a smooth, natural motion.
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Refinements


You have many options you can use to refine your animation and to make it easier to pose your armature, many of which are in the Properties panel when you select a bone in your armature:
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	Hold down the Shift key as you move individual bones to isolate their rotation.



	Use the Pin option in the Location section to fix individual bones in place, leaving the child bones free to move in a different pose.



	Use the Joint: Rotation and Joint: Translation options to constrain the rotation or translation (linear movement) of joints to make positioning of your armature more realistic. For example, your forearm can rotate up toward your bicep, but it can’t rotate in the other direction beyond your bicep.



	Use the Spring options to add a bit of physics. Spring makes your armature react with internal motion as it moves from pose to pose. A flexible object would normally have some “springiness” that would cause it to jiggle on its own as it moves and continue to jiggle even after the motion of the entire body stops. The amount of springiness depends on the object. For example, a dangling rope would have a lot of jiggle, but a diving board would be much stiffer and have less jiggle. You can set the strength of the spring depending on your object, and you can even set different springiness amounts for each bone in an armature to help you get an exact amount of rigidity or flexibility in your animation.






So...Bone tool or layer parenting?


Many character animators prefer layer parenting because it works with time-tested animation techniques such as classic tweens. Layer parenting also allows you to break and reconnect hierarchies in later keyframes. An armature can’t be reassembled during an animation in the same way. However, there may be cases where creating an armature with the Bone tool can help solve a unique animation problem that isn’t so straightforward with layer parenting. Both techniques have their merits, and only you can decide what approach works best for your project.







Review questions


1 What are two ways in which classic tweening and motion tweening are similar?


2 What are three ways in which you can edit a parent–child relationship between layers?


3 Why is the Snap To Objects option in the Tools panel important when adding a motion guide to a classic tween?


4 How can you edit the path of an object’s motion?


5 How is a graphic symbol different from a movie clip symbol?


6 What are the 12 visemes, and what is required for lip-syncing animation to dialogue?


Review answers


1 Both a motion tween and a classic tween require a symbol instance on the Stage. Another way in which they are similar is that they require their own layer; no other tween or drawing object can exist on the tween layer.


2 You can edit a parent–child relationship between layers by dragging the child layer to a new parent, you can click the child layer and choose Remove Parent, or you can click the child layer and choose Change Parent and select a new layer for its parent.


3 The Snap To Objects option forces an object to snap to other nearby objects. For an object to travel along a path in a motion guide, the object must be attached to the path in the first and the last keyframe.


4 To edit the path of an object’s motion, choose the Selection tool and drag directly on the path to bend it. You can also choose the Convert Anchor Point tool and Subselection tool to pull out handles at the anchor points. The handles control the curvature of the path.


5 A graphic symbol plays an animation on its timeline only if there are sufficient frames on the main timeline where the instance is placed. A movie clip symbol, on the other hand, contains an independent timeline, so it will play its animation regardless of how long the main timeline lasts, as long as an instance remains on the Stage.


6 The 12 visemes are graphical representations of 12 positions of a character’s mouth that correspond to individual sounds, called phonemes. To lip-sync dialogue in an animation, you create 12 visemes in separate keyframes of a graphic symbol. Click the Lip Syncing button in the Properties panel to automatically have Animate analyze an audio file on the timeline and create synchronized keyframes containing the correct frame of your graphic symbol along the main timeline.
















  

6 CONTROLLING THE CAMERA




Lesson overview




	In this lesson, you’ll learn how to do the following:



	Understand the kinds of motion that are best animated with the Camera tool.



	Activate the camera.



	Hide or reveal the camera.



	Pan, rotate, and zoom the camera.



	Create depth with the Layer Depth panel.



	Attach layers to the camera to keep them independent of camera motion.



	Apply color effects to the camera.
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This lesson will take about one hour to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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Use the camera to focus your audience’s attention on your animation. Use filmmaking techniques such as panning, zooming, and even rotating to direct the action for more cinematic approaches. In combination with the Layer Depth panel, achieve a sense of realistic depth.






Animating camera moves


So far, you’ve learned to animate different properties of symbol instances on the Stage—their position, scale, rotation, transparency, filters, and 3D position. You’ve also explored how you can animate complex motion that uses easing, and you’ve learned how to animate characters that use layer hierarchies.


However, as an animator you’re not just directing the motion of your characters and objects on the Stage like a play. You’re also in control of the camera, making you more like the director of a movie. That means controlling where to point the camera to frame the action, zooming in or out, panning, or rotating the camera for special effect. All of these camera movements are available in Adobe Animate with the Camera tool.






Getting started


Start by viewing the finished movie file to see an educational video that you’ll create in this lesson.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Double-click the 06End.mp4 file in the Lesson06/06End folder to play the video file.
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The project is an animation showing the trajectory of the Juno spacecraft, which was launched from Earth in 2011 and reached Jupiter in 2016. The animation is something that you might see on an educational site or at a museum. Notice how the audience’s view zooms in and out, and how the camera tracks the Juno as it moves across the solar system. At various points in the animation, captions appear to explain what’s happening.



	Close the 06End.mp4 file.



	Double-click the 06Start.fla file in the Lesson06/06Start folder to open the initial project file in Animate.
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This file is an ActionScript 3.0 document that contains the completed animation of the Juno’s trajectory and the orbiting Jupiter and Earth. There are no camera moves in this project; you’ll add those in this lesson. It also contains additional graphic elements imported into the library for you to use.



	Choose File > Save As. Name the file 06_workingcopy.fla, and save it in the 06Start folder.


Saving a working copy ensures that the original start file will be available if you want to start over.



	Choose Control > Test.
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Animate generates a SWF in a new window for you to preview the animation. You see a partial view of the solar system, with the sun in the middle and Earth and Jupiter orbiting. A spacecraft launches from Earth and follows a gray track. Watch how it circles back toward Earth to be flung away to intercept Jupiter.


The animation is decent, and the Stage shows all the action: the orbiting planets and the movement of the Juno spacecraft. However, it lacks drama, and some details get lost because of the different scales we’re seeing. When Juno circles back toward Earth to use its gravity as a slingshot effect to propel it toward Jupiter, wouldn’t it be nice to see it up close as it approaches Earth to get flung back out? That’s where the Camera tool can help. You’ll animate the camera to direct our attention to the action. Get close when you need to, or zoom back out to show the big picture. Use a camera to follow the spacecraft just as you would follow a character across the Stage.








Understanding the project file


Your 06_workingcopy.fla project file contains three layers—earth, juno, and jupiter—containing classic tweens with a motion guide layer for each. The motion guides keep the animation on track. Remember that the motion guides for classic tweens are not visible when the animation is published, so to show the orbits of the planets and the trajectory of Juno, the guides have been duplicated in the layers called orbits and juno_trajectory. The bottom layer, called sun, contains the sun in the middle of the solar system.
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Using the camera


Think of the camera as just another object to which you can apply a motion or classic tween to animate its position, rotation, or scale. If you’re already comfortable with managing keyframes and tweens, then the Camera tool should feel familiar.




Enabling the camera


Enable the camera with the Camera tool [image: ] in the Tools panel (it may be hidden in the Drag And Drop Tools panel) or by clicking the Add/Remove Camera button at the top of the Timeline panel.




[image: Image]



A Camera layer is added to the top of your timeline and becomes active.
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On the Stage, the camera controls appear.
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Characteristics of the camera


The Camera layer operates a little differently from a normal layer to which you add graphics:




	The size of your Stage becomes the frame of your camera view.



	You can have only one Camera layer, and it is always at the top of all your other layers.



	You cannot rename the Camera layer.



	You can’t add objects or draw in the Camera layer, but you can add classic or motion tweens to the layer, which allows you to animate the camera motion and camera filters.



	When the Camera tool is selected, you cannot move or edit objects in other layers. Disable the camera by selecting the Selection tool or by clicking the Remove Camera button at the top of the Timeline panel.
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The Camera tool is not available for all types of Animate documents.
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Clicking the Remove Camera button at the top of the Timeline panel doesn’t actually delete your Camera layer; it only disables it. You can click the button again to restore the Camera layer. To delete the Camera layer entirely, select it and click the Delete button (trash can icon).









Setting the camera frame


First, you’ll use the camera to frame just a small part of the solar system to focus on the beginning of the action: the launch of the Juno from Earth.




	Make sure that your Camera tool is active and that the on-Stage controls are present. There are buttons for two modes on the controls, one for Rotate and another for Pan And Zoom. The Pan And Zoom mode should be highlighted.
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	Drag the slider to the right.


The Camera view zooms closer into the Stage.



	When your slider reaches the edge of the Camera control, release your mouse button.


The slider snaps back to the center, allowing you to continue dragging to the right to continue zooming.


You can also enter a numerical value for the zoom in the Properties panel’s Camera Settings section.
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	Continue zooming the camera until you’ve reached about 260%.
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	Now drag your camera so that the sun in the middle of the solar system is more or less centered in the Stage, with many of the orbits in view. The Properties panel should display an X value of about –309 and a Y value of about 221.
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It may seem backward to see the objects on the Stage move in the opposite direction that you drag, but remember that you’re moving the camera and not the objects.


As you scrub the timeline to see the animation, notice that your point of view is now closer into the action.








[image: Image] Note


When using the camera zoom mode, be aware of the image resolution. As with any bitmap, zooming in too dramatically will reveal the limitations of the original embedded image.









Animating a zoom-out


Since your camera is zoomed in to the earth, you can more easily see the launch of the Juno spacecraft. However, at about frame 60, Juno leaves the Stage boundaries. You’ll want to zoom the camera out to keep the spacecraft in view.




	Select frame 24 on the Camera layer.
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	Insert a new keyframe (F6) at frame 24.
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You’ll keep the camera in the zoomed-in position from frame 1 to frame 24, and then begin to animate the camera motion from frame 24.



	Select the keyframe you just created on frame 24 on the Camera layer and choose Create Motion Tween above the Timeline.
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A motion tween is applied starting at frame 24, indicated by the gold tween span on the Camera layer.
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	Move the playhead to frame 72.



	Drag the Camera zoom slider on the Stage to the left to zoom out and see more of the solar system. The zoom percentage in the Properties panel should be about 170%.
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Move the camera so that Juno remains roughly in the center of view. The camera position should be close to X=20 and Y=90.
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A keyframe is automatically created at frame 72 with the new Zoom value and position for the camera.
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	Scrub the timeline between frames 24 and 72 to see the animated zoom.


As Juno moves farther away from Earth, the camera zooms out to keep it in the frame.










Animating a pan


A pan is the motion of the camera side to side or up and down. In this next step, you’ll pan the camera slowly from left to right to follow the motion of the Juno spacecraft.




	Move the playhead on the timeline to frame 160.


At this point in time, you’ll create another keyframe that establishes a new position for the camera.



	Move the camera on the Stage to the right. Hold down the Shift key to constrain the movement to the horizontal direction only. You can also just drag the X value in the Properties panel to change the horizontal position to about –250.
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The spacecraft should remain roughly at the center of the frame.
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	A new keyframe is automatically created at frame 160.
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	Press Return/Enter to preview the motion tween, which animates your camera zooming out from frames 24 to 72, and then panning from left to right from frames 72 to 160, tracking the spacecraft.










Animating a zoom-in


A crucial part of this animation is when Juno does a fly-by of Earth, using its gravity as a slingshot to get a boost to Jupiter. You’ll zoom in closer to show how the spacecraft approaches Earth.




	Right-click frame 160 and choose Insert Keyframe > All.
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Inserting a keyframe for all the camera properties at frame 160 ensures that any future changes in zoom, position, or rotation occur from frame 160 and not from an earlier point on the timeline.



	Move the playhead on the timeline to frame 190.


At this point in time, Juno is at its closest to Earth.



	Zoom and move the camera on the Stage so that Earth and Juno are close-up and nearly centered. The Zoom value should be about 760% and the Position should be about X=–1309 and Y=767.




[image: Image]




	A new keyframe is automatically created at frame 190.



	Move the playhead to the start of the timeline at frame 1 and press Return/Enter to preview the motion tween.


From frame 160 to frame 190, the camera does a dramatic zoom in as Juno flies toward Earth.










Animating a rotation


Rotating the camera is unusual, but in some cases, the motion can be quite dramatic and effective. In this project, rotating the camera will intensify the feeling of flying right next to the spacecraft as it approaches Earth.




	Make sure the playhead on the timeline is still on frame 190.



	Click the Rotation button on the Camera slider.
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	Drag the Camera slider to the right so that the camera rotates clockwise (and the objects in view rotate counterclockwise).


The Rotation value should be about –39 degrees.



	Change the camera option back to the Pan And Zoom option and move the camera so that the spacecraft behind the earth is roughly in the center.
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	Preview the animation by pressing Return/Enter or by scrubbing the timeline.


The dramatic fly-by of Earth by Juno is captured by the camera zooming in and rotating to be close to the action.










Finishing the camera moves


After the Earth fly-by, Juno continues its trajectory toward Jupiter. You’ll animate the camera to frame the rest of its journey with additional zooms, rotations, and pans.




	Move the playhead to frame 215 and click the Camera frame on the Stage.



	Reset the Rotation value of the Camera to 0 degrees. In the Properties panel, enter 0 for the Rotate value or click the Reset Camera Rotation button in front of the Rotate label.
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The Camera view tilts back to its default angle.



	Move the camera so that Earth and Juno are about at the center.
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	Now move the playhead to frame 228.


Juno is moving farther out from the inner solar system, so you’ll need to keep backing up the camera.



	Change the Zoom value to about 90%. Move the camera so that most of the solar system, including Jupiter’s orbit, is in view.
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	Select frame 480. Right-click and choose Insert Keyframe > All to create a new keyframe.
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Your final camera move is to zoom in to Juno’s approach to Jupiter, so you have to create a beginning keyframe to establish the beginning values for the camera’s zoom, position, and rotation.



	Zoom in for a close-up of Jupiter. The Zoom value of the camera should be about 1400%.



	Move the camera to keep Jupiter and Juno in the frame.
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When you zoom in too far all at once, you may lose sight of your graphics and may have trouble putting them back into the camera frame. It’s best to zoom a little bit at a time, and move the camera to keep the graphics that you want to zoom in on within the frame.






	Preview the entire animation by choosing Control > Test.


Animate exports the animation as a SWF in a new window. The animation plays with camera pans, zooms, and rotations that closely follow Juno’s journey from Earth to Jupiter.








Camera easing, the Motion Editor, and motion paths


Animating the camera is just like animating any other object on the Stage with motion tweening or with classic tweening. As with motion tweening and classic tweening, you can also apply eases to the camera motion to make any of your pans, zooms, or rotations ease-in or ease-out for a more natural movement. If you’re using motion tweening, you can even access the Motion Editor (see Lesson 4) by double-clicking the tween span (or by right-clicking the span and choosing Refine Motion Tween) in the Camera layer to apply a complex ease or to customize the property curve. The following figure shows the Motion Editor for the camera moves that you just completed.
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However, not all features of motion tweening or classic tweening are available to the camera. You cannot animate the camera on a path. If you use classic tweens, you can’t add a motion guide to the Camera layer for your camera to follow. If you use motion tweens, there is no path on the Stage for you to edit.











Creating depth


When you move a camera to film a scene in real life, you get a sense of depth because foreground elements move across the frame a little quicker than background elements. This is called a parallax effect, and we’re familiar with the effect when we look out the window of a moving car. The closer trees and street signs zip past our window, whereas the distant mountains on the horizon move very slowly.


Animate offers the ability to create the same sense of depth when you animate camera moves using the Layer Depth panel. The Layer Depth panel allows you to set a layer’s z-depth, which is its distance from the Camera layer.


By default, all layers have a z-depth value of 0, which means they all are the same distance from the camera. Camera pans and zooms do not show a sense of depth, and the overall effect is as if the camera were panning across or zooming in or out of a flat picture. The picture moves or gets bigger or smaller, but there is no differential movement of separate layers.




[image: Image] Note


The Layer Depth panel can be used independently of the Camera tool. That is, you can place objects in layers with different depth levels and animate them without activating the Camera tool. However, it is the motion of the camera in conjunction with layers at different z-depths that allows viewers to see the three-dimensionality of a scene.







[image: Image] Note


The Layer Depth panel mimics the real-life multiplane camera invented and used by Walt Disney Studios for their traditional animated features, like Snow White and the Seven Dwarfs. The multiplane camera was a gigantic setup that allowed multiple layers of artwork to be filmed for a more realistic sense of depth. However, unlike in Animate, Disney’s multiplane camera remained stationary while the individual layers moved at different speeds.







Adding layers of stars


In the following tasks, you’ll enhance the animation of Juno’s journey to Jupiter by creating a sense of depth. You’ll add a few layers of stars and position them at different z-depth distances, which will enhance the vastness of space.




	Add a new layer in your timeline and move it to the bottom of the layer stack.



	Rename the layer stars1.
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The stars1 layer will contain the first layer of stars.



	In the Library panel, drag the graphic symbol called stars1 from the library onto the Stage.


The graphic is simply a collection of gray and white dots randomly scattered over a large area. Don’t worry too much about precise placement; select the Selection tool and just position the instance to cover most of the solar system and a little of the space on the left since that’s where the camera moves.
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It may be helpful to change the Stage view magnification level so that you can see more of the graphics that may be off the Stage (and out of camera view).



	Add another layer called stars2 below stars1, and add another instance of the graphic symbol stars1 in that layer.



	Use the Free Transform tool to rotate the instance 180 degrees so that the stars in this layer don’t align exactly with the stars in the stars1 layer. Again, make sure the stars cover most of the solar system.
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	Add a third layer of stars called stars3 below all the others, and add a third instance of the graphic symbol stars1 in that layer.



	Use the Free Transform tool to rotate the instance about 55 degrees so that the stars in this bottommost layer don’t align exactly with the stars in the layer above it.
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	Select the first keyframe of the stars3 layer, and in the Properties panel, change the Color Effect so the Brightness value is at –60%.
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The stars in that layer become slightly dimmer, which will reinforce the sense of distance.



	Preview your animation by pressing the Return/Enter key.


Although the stars add a nice touch of realism to the highly diagrammatic solar system, the stars are still flat and don’t move with any parallax effect. You’ll change that with the Layer Depth panel, next.










Setting the z-depth in the Layer Depth panel


The Layer Depth panel manages the distances of each layer from the Camera layer.




	In the Timeline panel, click the Layer Depth button, or choose Window > Layer Depth.
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The Layer Depth panel appears, showing all the layers in the order in which they appear in the timeline. Next to each layer is a 0, indicating its current z-depth value. Next to the z-depth value is a color that is coded to the depth diagram on the right of the panel.
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Since all the layers are currently at a z-depth of 0, they are at the same depth level, and they lie at the same plane as the camera frame.


The camera is indicated by the ball with the dotted lines radiating from it. The flat blue line attached to the dotted diagonal lines shows the field of view of the camera.



	Make sure your view of the stage is at 100% (View > Magnification > 100%). In the Layer Depth panel, drag to the right on the z-depth value for the stars3 layer to increase it to 500. You can also click the value to enter a numeric value, or you can drag the corresponding colored line.
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Notice the effect of the stars1 graphic on the Stage as you change the z-depth value. As the z-depth increases, the layer’s distance from the camera increases and the stars recede on the stage. If you drag the opposite way, you can decrease the z-depth into negative values and you can make the layer appear behind the camera (try it out!).



	The problem with changing the distance of the stars3 layer is that the graphics in that layer get small—sometimes too small for your animation. You can use the Maintain Size option to prevent your graphics from changing size as you change the layer distance. Move the z-depth value for the stars3 layer back to 0.



	Now click the Maintain Size option in the Layer Depth panel to select it.



	Drag the z-depth value for the stars3 layer to increase it to 500.
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Notice how the size of the stars remains constant. The Maintain Size option must be clicked before every z-depth change, so if you drag the stars3 layer z-depth value three times to get to 500, make sure you click the Maintain Size option three times.



	Click the Maintain Size option and set the z-depth value for the stars2 layer to 300 and the z-depth value for the stars1 layer to 150.
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The diagram on the right in the panel indicates the positions of the three layers relative to the camera and the other layers (which remain at a z-depth value of 0). The bold highlighted layer in the diagram is the layer that is currently selected.



	That’s all you have to do! Close the Layer Depth panel. Preview the effects of setting your last three layers farther behind the others.


The parallax effect due to the motion of the camera over levels at varying depth levels is most noticeable if you scrub the timeline between frames 72 and 160. That’s when the camera is panning from left to right, tracking Juno. You see the orbits sliding by faster than some of the stars, which are sliding by faster than the more distant ones. The overall effect is a realistic sense of space.
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To maintain your sanity, it’s best to keep your layers’ order and their z-depth order the same. As you may have noticed, you could change the z-depth value of a top layer so that it is actually farthest from the camera and, hence, won’t overlap graphics in the other layers. This can get very confusing. So maintain the same overlapping order of your layers in the Timeline panel as well as in the Layer Depth panel. Change the z-depth values just to change the different spacing between layers.







More on the Layer Depth panel: Animating z-depth


Be aware that the z-depth property is tied to an individual keyframe for each layer. That means that the same layer can have a certain z-depth at one keyframe, and then an entirely different z-depth at another keyframe later in the timeline. Objects can jump around, changing distances from the camera. For our project in this lesson, you won’t have to worry about different keyframes having different z-depths, since our stars1, stars2, and stars3 layers have only a single keyframe, at frame 1.


However, because the z-depth is tied to individual keyframes, you can apply tweens between the two keyframes to animate motion toward and away from the camera. Animating the z-depth opens up a whole new world of possibilities in three dimensions and is a powerful approach to animating in three dimensions in addition to the 3D Translation and 3D Rotation tools.











Attaching layers to the camera for fixed graphics


There’s one last item to add to the animation of the Juno spacecraft, and that’s the informative captions that pop up to explain the different parts of its trajectory. However, any graphic that we add to the Stage would be subject to all the camera moves—the panning, rotating, and zooming—that is, unless we fix, or attach, a layer containing the graphic in such a way that it is unaffected by the camera motion.


Animate allows you to do this to one or more layers when you attach them to the Camera layer.




Attaching a layer to the Camera layer


The attached layer is an option in the Layer Properties dialog box. You can also attach a layer by selecting the Attach Layer To Camera option in the timeline.




	Create a new layer, drag it to the bottom of the layer stack, and rename it information.


This new layer will contain the captions that appear at various points along your animation.
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	Click next to the layer name under the Attach Layer To Camera icon in the timeline.


A chain link icon indicates that the layer is currently locked to the Camera layer.
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	Double-click the layer icon in front of its name, or choose Modify > Timeline > Layer Properties.


The Layer Properties dialog box appears. Confirm that the Attach To Camera option is selected and click OK to close the dialog box.
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Adding the captions


Now you’ll add the information for the animation in keyframes along the timeline.




	Add about two seconds’ worth of time (48 frames) at frame 1 before the animation begins (F5). The easiest way to do this is to drag-select frame 1 in all the layers and then press F5 (add frames) 47 times to add two seconds of time before the tweens in the earth, juno, and jupiter layers.
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The slight pause before the animation begins will give your audience a chance to read the first caption.



	Select frame 1 of the information layer.



	Select the Rectangle tool. Choose None for the Stroke Color and a 50% transparent white for the Fill Color.



	Create a long rectangle from the upper-left corner about 700 pixels wide and 50 pixels high. The Position for your rectangle should be X=0 and Y=0.


The semitransparent rectangle will be the box for your text.
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	Select the Text tool and choose Static Text in the Properties panel.



	Choose a font that appeals to you by choosing from the Family and Style menus in the Character section of the Properties panel. Make the size 28 points (but you may have to increase or decrease the size depending on your font) and the color black. Click the Format: Align Center button in the Paragraph section.
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	Drag out a text box over the semitransparent white rectangle in your information layer.



	Type Juno’s journey to Jupiter begins and use the Align panel to center the text over the box horizontally and vertically (see Lesson 2 if you don’t remember how to use the Align panel).


The first caption is complete.
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	You’ll make the first caption disappear before the next one appears, so at frame 90 in the information layer, right-click and choose Insert Blank Keyframe (F7).


A blank keyframe appears at frame 90 and the caption disappears from the Stage.



	The second caption appears as Juno doubles back toward Earth, so create another keyframe at frame 118.



	Copy your text and semitransparent rectangle from frame 1 and paste it into this new keyframe at frame 118.
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	Change the contents of the text to read Juno heads back to Earth.
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	Continue in a similar manner to add the third caption. The second caption should disappear at about frame 192, with the third caption appearing at frame 236. The third caption should read Juno uses Earth’s gravity as a slingshot. The third caption should disappear at frame 336. Feel free to play around with the timing and positioning of the caption!
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	The final caption, which should appear at about frame 454 as the camera zooms into Jupiter, reads Juno arrives at Jupiter 5 years later.
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	Move the information layer higher in your layer stack just below the Camera layer so that the captions overlap all the other graphics.



	Test your movie.


As the animation plays, your captions appear one by one. Since the information layer is attached to the Camera layer, the rotations, pans, and zooms do not affect the contents of the layer.








[image: Image] Note


You can have more than one layer attached to the Camera layer.







[image: Image] Note


You can still change the z-depth value of a layer that is attached to the Camera layer.







Camera color effects


You can also apply and animate camera color effects to create a color tint or to change the contrast, saturation, brightness, or hue of the entire view on the Stage. The effect simulates a filter that a cameraperson might put on a lens to heighten certain colors for a mood, or to create a black-and-white film noir feeling.
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To apply a color effect, click the Apply button (eye icon) in front of the Tint or Adjust Color option in the Camera Color Effects section of the Properties panel. The Camera tool must be active to apply a camera color effect. Click the color box next to the Tint value to select the color of the tint, or change the Red, Green, and Blue values individually and then change the value of the Tint to set the amount. A value of 100 is the maximum.


For example, you could apply a sepia tint like this one to your camera to simulate an old-fashioned, aged film reel.
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The color effects are applied to each keyframe of the Camera layer. In this project, since you’ve already animated your camera (and the Camera layer contains multiple keyframes), you would have to apply a color effect to each new keyframe if you want the effect to be consistent throughout the movie.











Exporting your final movie


Create the MP4 movie file by exporting it from Animate and converting it in Adobe Media Encoder, a separate app that is part of Creative Cloud (you’ll learn more about Adobe Media Encoder in Lesson 10).




	Choose File > Export > Export Video/Media.


The Export Media dialog box opens.



	Keep the Render size at the original 700 pixels by 400 pixels. Select Start Adobe Media Encoder Render Queue Immediately. Click Browse to select the destination filename and location. Click Export.
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Animate generates a temporary SWF file and a MOV file from it. The Adobe Media Encoder automatically launches.



	In Adobe Media Encoder, the exported media file is added to the Render Queue panel.



	Animate begins the encoding process automatically. If not, click the Start Queue button (the green triangle) or press Return/Enter to begin the encoding process.
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	Adobe Media Encoder converts the MOV file into an H.264-formatted video with the standard .mp4 filename extension.
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The final file can be uploaded to Facebook, YouTube, or other video sharing sites, or put up on your own website.








Review questions


1 What are the three kinds of camera motion that you can animate with the Camera tool?


2 How do you activate the Camera layer?


3 What are two ways to attach a layer to the Camera layer?


4 What is the z-depth and how do you change it?


5 What does the Maintain Size option in the Layer Depth panel do?


Review answers


1 You can animate a pan (motion from one side to another or up and down), a zoom, or a rotation with the Camera tool.


2 Activate the Camera layer by selecting the Camera tool from the Tools panel or by clicking the Add Camera button at the top of the Timeline panel.


3 Attach a layer to the Camera layer by clicking the dot next to the layer name and under the Attach Layer To Camera icon in the Timeline panel. The layer displays a chain link icon, indicating that it is attached to the Camera layer. You can also open the Layer Properties window and select Attach To Camera.


4 Z-depth is a numerical value that indicates a layer’s distance from the camera. Open the Layer Depth panel (Window > Layer Depth). You may have to enable Advanced Layers in the Document Settings (Modify > Document). Change a layer’s z-depth by selecting the number to the right of the layer name and typing a new value or by dragging the colored line that represents a layer relative to the dot that represents the camera.


5 The Maintain Size option in the Layer Depth panel maintains the size of the graphics in a layer when its z-depth value changes. Normally, when a layer’s z-depth increases and it moves farther away from the camera, graphics in the layer get smaller since they recede in the distance. The Maintain Size option keeps the size of the graphics constant.














  

7 ANIMATING SHAPES AND USING MASKS




Lesson overview


In this lesson, you’ll learn how to do the following:




	Animate shapes with shape tweens.



	Use shape hints to refine shape tweens.



	Animate gradient fills.



	View onion skin outlines.



	Apply easing to shape tweens.



	Create and use masks.



	Understand mask limitations.



	Animate the mask and masked layers.
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This lesson will take about one hour to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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You can easily morph—create organic changes in shape—with shape tweens. Masks provide a way to selectively show only parts of a layer. Together, they allow you to add more sophisticated effects to your animations.






Getting started


You’ll start the lesson by viewing the animated logo that you’ll create as you learn about shape tweens and masks in Adobe Animate.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Switch to a web browser, choose File > Open File, and navigate to Lesson07/07End/07End.gif to play the finished animated GIF. An animated GIF is a single file that often combines multiple images as a looped animation, popular for Internet memes.
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The project is an animated logo for a fictional company intended as a profile image for different social media platforms. The animation shows a flame flickering at the top of the company name. Not only does the shape of the flame change constantly but so does the radial gradient fill inside the flame. A linear gradient sweeps across the letters of the company name from left to right. In this lesson, you’ll animate both the flame and the colors that move across the letters.



	Close your browser. Double-click the 07Start.fla file in the Lesson07/07Start folder to open the initial project file in Animate.



	Choose File > Save As. Name the file 07_workingcopy.fla and save it in the 07Start folder. Saving a working copy ensures that the original start file will be available if you want to start over.










Animating shapes


In the previous lessons, you learned to create animations with symbol instances. You could animate the motion, scale, rotation, color effect, or filters applied to symbol instances. You also learned to deform shapes and bitmaps with the Asset Warp tool and create internal armatures within shapes to move them with the Bone tool. However, those techniques don’t animate the actual contours of a graphic. For example, creating an animation of the slowly changing shape of clouds in the sky, or the deformation of a water droplet as it falls, is difficult with the Asset Warp or Bone tool and nearly impossible using motion or classic tweening with symbol instances (try it for a challenge!). You could draw each frame in a frame-by-frame animation, but that is difficult and time-consuming. To achieve something more organic, you can turn to shape tweening.


Shape tweening is a technique for interpolating stroke and fill changes between different keyframes. Shape tweens make it possible to smoothly morph one shape into another. Any kind of animation that requires the stroke or fill of a shape to change—for example, animation of smoke, water, or hair—is a perfect candidate for shape tweening.


Because shape tweening applies only to shapes, you can’t use groups, symbol instances, or bitmap images.






Understanding the project file


The 07Start.fla file is an ActionScript 3.0 document that contains most of the graphics already completed and organized in different layers. However, the file is static, and you’ll add the animation.


The text layer is at the very top and contains the company name, “Fire starter.” The flame layer contains the flame, and the bottom layer, called glow, contains a radial gradient to provide a soft glow.
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There are no assets in the library.






Creating a shape tween


To create the flickering flame effect, you’ll animate the undulating changes in a flame’s typical teardrop shape. You’ll rely on shape tweening to handle the smooth morphing from one shape to the next, as well as the gradual shifts in color. A shape tween requires at least two keyframes on the same layer. The beginning keyframe contains a shape drawn with the drawing tools in Animate or imported from Adobe Illustrator. The ending keyframe also contains a shape. A shape tween interpolates the smooth changes between the beginning keyframe and the ending keyframe.




Establish keyframes containing different shapes


In the following steps, you’ll animate the flame that will sit on top of the company name.




	Select frame 40 in all three layers and choose Insert > Timeline > Frame (F5).


Forty frames are added to all three layers to define the overall length of the animation.
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	Lock the text layer and the glow layer. This prevents you from accidentally selecting or moving the graphics in those layers.



	Select frame 40 in the flame layer and choose Insert Keyframe above the Timeline (or right-click and choose Insert Keyframe or choose Insert > Timeline > Keyframe [F6]). The contents of the previous keyframe in frame 1 are copied into the new keyframe.
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You now have two keyframes on the timeline in the flame layer, at frame 1 and at frame 40. Next, you’ll change the shape of the flame in the end keyframe.



	Select the Selection tool.



	Click away from the shape to deselect it. Move your cursor close to the outlines of the shape, and drag the contours of the flame to make the flame skinnier.
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The beginning keyframe and the ending keyframe now contain different shapes—a fat flame in the beginning keyframe, and a skinny flame in the ending keyframe in frame 40.










Apply the shape tween


Next, you’ll apply a shape tween between the keyframes to create the smooth transitions.




	Click any frame between the beginning keyframe and the ending keyframe in the flame layer.



	Press and hold the Create Tween button above the Timeline and choose Create Shape Tween. Or right-click, and choose Create Shape Tween or choose Shape Tween from the Insert menu.
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Animate applies a shape tween between the two keyframes, which is indicated by a black forward-pointing arrow and an orange fill in the tween span.
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	Watch your animation by choosing Control > Play (Return/Enter) or by clicking the Play button at the top of the Timeline panel.
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You have created a smooth animation between the keyframes in the flame layer, morphing the shape of the first flame into the shape of the second flame.
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Don’t worry if your flame doesn’t morph exactly the way you want it to. Small changes between keyframes work best. Your flame may rotate while going from the first shape to the second. You’ll have a chance later in this lesson to refine the shape tweening with shape hints.







Blend types


In the Properties panel, you can modify your shape tween by choosing either the Distributive or the Angular option for Blend. These two options determine how Animate makes the interpolations to change the shapes from one keyframe to the next.
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The Distributive option is the default and works well for most cases. It creates animations in which the intermediate shapes are smoother.


Use the Angular blend if your shapes have many points and straight lines. Animate attempts to preserve apparent corners and lines in the intermediate shapes.











Changing the pace


The keyframes of a shape tween can be easily moved along the timeline to change the timing or pacing of the animation.




Moving a keyframe


The flame slowly transforms from one shape to another over a period of 40 frames. If you want the flame to make the shape change more rapidly, you need to move the keyframes closer together.




	Select the last keyframe of the shape tween in the flame layer.




[image: Image]




	Make sure the box icon appears near your cursor as you drag the last keyframe to frame 6.


The shape tween shortens.
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	Press Return/Enter to play your animation.


The flame flickers quickly and then remains static until frame 40.












Adding more shape tweens


You can add shape tweens by creating more keyframes. Each shape tween simply requires two keyframes to define its beginning state and its end state.




Insert additional keyframes


You want the flame to continually change shape, just as a real flame would. You’ll add more keyframes throughout the animation and apply shape tweens between all the keyframes.




	Select frame 17 in the flame layer and choose Insert Keyframe above the Timeline. Or choose Insert > Timeline > Keyframe (F6).


The contents of the previous keyframe are copied into the second keyframe.
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	Select frame 22 in the flame layer and choose Insert Keyframe (or F6) to copy the contents of the previous keyframe into the new keyframe.
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	Continue inserting keyframes at frames 27, 33, and 40.


Your timeline now has seven keyframes in the flame layer, with a shape tween between the first and second keyframes.
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	Move the blue playhead to frame 17.




[image: Image]




	Select the Selection tool.



	Click away from the shape to deselect it. Drag the contours of the flame to create another variation in its shape. You can make the base thicker, or change the curvature of the tip to make it lean left or right.
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	Modify the flame shapes in each of the newly inserted keyframes to create subtle variations.
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Extending the shape tweens


Your next step is to extend the shape tween so that the flame morphs from one shape to the next.




	Select any frame between the second and third keyframes, and choose Create Shape Tween. Or choose Insert > Create Shape Tween.
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A black forward-pointing arrow on an orange background appears between the two keyframes, showing that you’ve applied a shape tween.
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	Continue to insert shape tweens between all the keyframes.


You should have six shape tweens in the flame layer.
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	Press Return/Enter to watch the animation play.
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Your flame flickers back and forth for the duration of the animation. Depending on how extensive your modifications to the flame have been, your flame may undergo some weird contortions between keyframes—for example, flipping or rotating unpredictably. Don’t worry! You’ll have a chance later in the lesson to refine your animation with shape hints.








[image: Image] Note


Try this shortcut: select a range of frames that cover multiple keyframes, right-click, and choose Create Shape Tween to apply a shape tween across all keyframes.







Broken tweens


Every shape tween needs a beginning and an end keyframe with a shape inside each. If the last keyframe of a shape tween is missing, Animate shows the broken tween as a dotted black line (rather than a solid arrow).
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In this example, insert a keyframe at frame 40 to fix the tween.











Creating a looping animation


Your flame should flicker back and forth continuously for as long as the logo is onscreen. You can create a seamless loop by making the first and last keyframe identical and putting the animation inside a graphic or a movie clip symbol. A movie clip timeline loops continuously, independently of the main timeline, while a graphic symbol plays as long as there are enough frames on the main timeline.




Duplicating keyframes


Make the first keyframe identical to the last keyframe by duplicating its contents.




	Right-click the first keyframe on the flame layer and select Copy Frames. Or choose Edit > Timeline > Copy Frames.
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The contents of the first keyframe are placed on your clipboard.



	Right-click the last keyframe on the flame layer and select Paste Frames. Or choose Edit > Timeline > Paste Frames.
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The first and last keyframes now contain identical flame shapes.
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You can quickly duplicate keyframes by first selecting a keyframe and then Option/Alt-dragging the keyframe to a new position.









Previewing the loop


Use the Loop button at the top of the Timeline panel to preview your animation.




	Click the Loop button or choose Control > Loop Playback (Option+Shift+L/Alt+Shift+L) to enable continuous playback when you play the movie.
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Markers appear on the timeline header indicating the range of frames that loop during playback. Next, adjust the markers to extend the loop to include the entire movie.



	Drag the markers to include all the frames on your timeline (frames 1 through 40). Hold down the Command/Ctrl key while you’re dragging either marker to move both of them in equal amounts.
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	Press Return/Enter to test the animation.


The flame animation plays and loops continuously. Click the Pause button or press Return/Enter again to stop the animation. Deselect the Loop button at the top of the Timeline panel to hide the markers and end the loop playback mode.
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The Loop Playback option loops the animation only in the Animate authoring environment and not in the published animation.









Inserting the animation into a graphic symbol


When your animation plays in a graphic clip symbol, the animation loops automatically as long as there are sufficient frames on the main timeline.




	Select all the frames on the flame layer, right-click, and choose Cut Frames. Or choose Edit > Timeline > Cut Frames.
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The keyframes and shape tweens are removed from the timeline and placed on the clipboard.



	Choose Insert > New Symbol (Command+F8/Ctrl+F8).


The Create New Symbol dialog box appears.


Enter flame as the name of the symbol, and choose Graphic from the Type menu. Click OK.
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A new graphic symbol is created and opens in symbol-editing mode.



	Right-click the first frame on your graphic symbol timeline and choose Paste Frames. Or choose Edit > Timeline > Paste Frames.
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The flame animation from the main timeline is pasted into your graphic symbol’s timeline.
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	Click the arrow button on the Edit bar at the top of the Stage to exit symbol-editing mode, or choose Edit > Edit Document (Command+E/Ctrl+E).


You exit symbol-editing mode and return to the main timeline.



	Select the flame layer, which is currently empty. Drag your newly created flame graphic symbol from the Library panel to the Stage.
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An instance of the flame movie clip symbol appears on the Stage.



	Press Return/Enter.


Animate plays the animation on the timeline. Since your graphic symbol contains 40 frames and the main timeline contains 40 frames, the entire animation of the flame flickering fits into the main timeline.
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The reason why we’re using a graphic symbol rather than a movie clip symbol to create the looping animated flame is that movie clip timelines do not get included in exported animated GIFs, and the last exercise in this lesson will involve publishing this file as an animated GIF.







Shape tweening with variable-width strokes


Any aspect of a shape can be shape tweened, including variable widths of a shape’s stroke. In Lesson 2, you learned to use the Width tool to create lines with thick and thin variations for more expressive graphics. You can change the width of the strokes in different keyframes, and when you apply a shape tween between those keyframes, Animate creates smooth interpolations of those stroke widths.


Considering the ability to animate the thickness of a shape’s stroke, the contours of the stroke itself, and the inside fill (with solids, gradients, or transparencies) of a shape, the creative possibilities are nearly limitless.











Using shape hints


Animate creates the smooth transitions between keyframes of your shape tween, but sometimes the results are unpredictable. Your shapes may go through strange contortions, flips, and rotations to get from one keyframe to another. You may like the effect, but more often than not you’ll want to maintain control of the transformations. Using shape hints can help refine the shape changes.


Shape hints force Animate to map points on the start shape to corresponding points on the end shape. By placing multiple shape hints, you can more precisely control how a shape tween appears.




Adding shape hints


Now you’ll add shape hints to the shape of the flame to modify the way it morphs from one shape to the next.




[image: Image] Tip


Shape hints should be placed on the edges of shapes.







	Double-click the flame graphic symbol in the library to enter symbol-editing mode. Move the playhead to frame 1 of the shape tween in the flame layer.
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	Choose Modify > Shape > Add Shape Hint (Command+Shift+H/Ctrl+Shift+H).


A red-circled letter “a” appears on the Stage. The circled letter represents the first shape hint.
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	Select the Selection tool and make sure that Snap To Objects in the Doc tab of the Properties panel is selected.


Snap To Objects ensures that objects snap to each other when being moved or modified.



	Drag the circled letter to the tip of the flame.
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	Choose Modify > Shape > Add Shape Hint again to create a second shape hint.


A red-circled “b” appears on the Stage.
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	Drag the “b” shape hint to the bottom of the flame shape.
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You have two shape hints mapped to different points on the shape in the first keyframe.



	Select the next keyframe of the flame layer (frame 6).


A corresponding red-circled “b” appears on the Stage, hiding an “a” shape hint that is directly under it.
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	Drag the circled letters to corresponding points on the shape in the second keyframe. The “a” hint goes on the top of the flame, and the “b” hint goes on the bottom of the flame.


The shape hints turn green, indicating that you’ve correctly placed them so that they correspond to equivalent locations in the first keyframe.
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	Select the first keyframe.


Note that the initial shape hints have turned yellow, indicating that they are correctly placed. When placed properly, the shape hints in the beginning keyframe turn yellow and those in the ending keyframe turn green.
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	Scrub the playhead through the first shape tween on the timeline to see the effect of the shape hints on the shape tween.


The shape hints force the tip of the flame in the first keyframe to map to the tip of the flame in the second keyframe and force the bottoms to map to each other. This restricts the transformations.
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To demonstrate the value of shape hints, you can deliberately create a mess of your shape tweens. In the end keyframe, put the “b” hint at the top of the flame and the “a” hint at the bottom.


Animate forces the tip of the flame to tween to the bottom of the flame and vice versa. The result is a strange flipping motion as Animate tries to make the transformation. Put the “a” back at the top and the “b” back at the bottom after you’re done experimenting.








[image: Image] Tip


You can add a maximum of 26 shape hints to any shape tween. Be sure to add them consistently in a clockwise or counterclockwise direction for best results.









Removing shape hints


If you’ve added too many shape hints, you can easily delete the unnecessary ones. Removing a shape hint in one keyframe will remove its corresponding shape hint in the other keyframe.




	If you want to remove a shape hint, drag an individual shape hint entirely off the Stage and pasteboard.



	If you want to remove all shape hints, choose Modify > Shape > Remove All Hints.












Previewing animations with onion skinning


It’s sometimes useful to see how your shapes are changing from one keyframe to another on the Stage all at once. Seeing how the shapes gradually change lets you make smarter adjustments to your animation. You can do so using the onion skinning option, available at the top of the Timeline panel.


Onion skinning shows the contents of the frames before and after the currently selected frame.


The term “onion skin” comes from the world of traditional hand-drawn animation, in which animators draw on thin, semitransparent tracing paper known as onionskin. A light box shines a light behind the drawings to allow them to be seen through several sheets. When creating an action sequence, animators flip back and forth quickly between drawings held between their fingers. This allows them to see how the drawings smoothly connect to each other.




Turning on onion skinning


The Onion Skin button is above the Timeline, allowing you to toggle it on or off. Pressing and holding the Onion Skin button displays additional options.




	Click the Onion Skin button at the top of the Timeline panel.
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Animate shows several shapes for the flame, representing the shapes in previous and future frames. Seeing multiple frames all on the Stage at once allows you to compare the changes between frames. The currently selected frame is in red. The previous frames are shown in blue, and the future frames are shown in green. The outlines of the flame fade the farther away they are from the current frame.
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On the timeline, Animate displays markers to bracket your currently selected frame. The blue-marked bracket (to the left of the playhead) indicates how many previous frames are shown on the Stage, and the green-marked bracket (to the right of the playhead) indicates how many future frames are shown.
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	Move the playhead to a different frame.


Animate keeps the markers around the playhead no matter where you move it, always showing the same number of frames behind and ahead.
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You can even scrub the playhead back and forth along the timeline to see the ghostly images of the onion skins moving along with the animation. You cannot see onion skins during normal playback, however.









Adjusting the markers


You can move either marker to show more or fewer onion skin frames.




	Drag the blue marker to adjust the number of past onion skin frames shown.



	Drag the green marker to adjust the number of future frames displayed.



	Hold down Command/Ctrl while dragging either marker to move the past and future markers in equal amounts.



	Hold down Shift while dragging either marker to move the onion skin range to a different spot on the timeline (as long as it still encompasses the playhead).



	Press and hold the Onion Skin button at the top of the Timeline panel and choose Anchor Markers. With the Anchor Markers option enabled, you can move your playhead on the Timeline and the bracketed onion-skinned frames will remain locked in place.
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	Press and hold the Onion Skin button at the top of the Timeline panel and choose All Frames. With the All Frames option enabled, the brackets will automatically move to cover the first frame and the last on the Timeline.
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Advanced onion skin options


If you don’t like the blue and green color coding of previous and future frames, or you want to change the opacity of the onion skins, you can change them in the advanced settings.




	Press and hold the Onion Skin button at the top of the Timeline panel and choose Advanced Settings.
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The Onion Skin Settings dialog box appears.
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You can fine-tune how the onion skin frames appear by adjusting the following settings:




	Choose the previous or future frame range numerically.



	Click the color swatches to change the color of the previous or future frames.



	Choose between seeing the onion skin frames only as outlines, as shown here, or fully rendered.
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	Move the opacity sliders to change the starting opacities and how quickly the onion skin frames fade.



	Choose to see only keyframes.



	Anchor the frame markers.




[image: Image] Note


Animate remembers the most recent preferences set in the Onion Skin Settings panel. Clicking the Onion Skin button above the Timeline will toggle onion skins with those settings on and off.















Animating color


Shape tweens interpolate all aspects of a shape, which means that both the stroke and fill of a shape can be tweened. So far, you’ve modified the stroke, or outlines, of the flame. In the next section, you’ll modify the fill so that the color gradient can change—perhaps the flame will glow brighter and more intensely at some points in the animation.




Adjusting the gradient fills


Use the Gradient Transform tool to change the way the color gradient is applied to a shape, and use the Color panel to change the actual colors used in a gradient.




	If you’re not already in symbol-editing mode for your flame symbol, double-click the flame graphic symbol in the library to edit it.



	Select the second keyframe on the flame layer (frame 6).



	Select the Gradient Transform tool, which is grouped with the Free Transform tool in the Tools panel.


The control points for the Gradient Transform tool appear on the gradient fill of the flame. The various control points allow you to stretch, rotate, and move the focal point of the gradient within the fill. (The Stage color is shown in white so that you can better see the Gradient Transform tool control points.)
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	Use the control points to tighten the color gradient into the base of the flame. Reduce the gradient’s size, make it wider, position it lower on the flame, and move the focal point (represented by a tiny triangle) of the gradient to one side.
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Your flame’s orange core appears lower and more intense because the colors are distributed in a smaller area.



	Move the playhead along the timeline between the first and second keyframe.


The shape tween automatically animates the colors inside the flame as well as its contours.



	Select the third keyframe on the flame layer (frame 17). In this frame, you’ll adjust the actual color of the gradient.



	Select the Selection tool and click the fill of the flame on the Stage.



	Open the Color panel (Window > Color).


The Color panel appears, showing you the gradient colors of the selected fill.
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	Click the inner color marker, which is currently yellow.



	Change the color to a hot pink (#FF33CC).
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The center color of the gradient turns pink.



	Move the playhead along the timeline between the second and third keyframes.
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The shape tween automatically animates the center color in the gradient from yellow to pink. Experiment with the other keyframes by modifying the gradient fill and see what kinds of interesting effects you can apply to your flickering flame.








[image: Image] Note


Shape tweens can smoothly animate solid colors or color gradients, but they can’t animate between different types of gradients. For example, you can’t shape tween a linear gradient into a radial gradient.











Creating and using masks


Masking is a way of selectively hiding and displaying content on a layer. It enables you to control the content that your audience sees. For example, you can make a circular mask and allow your audience to see only through the circular area so that you get a keyhole or spotlight effect. In Animate, you put a mask on one layer and the masked content in a layer below it.


For the animated logo you’re creating in this lesson, you’ll make the text a little more visually interesting by using the text itself as a mask.




Define the mask layer


From the “Fire starter” text, you'll create a mask that will reveal an image of a fire beneath it.




	Return to the main timeline. Unlock the text layer. Double-click the icon in front of the text layer name, or select the text layer and choose Modify > Timeline > Layer Properties.


The Layer Properties dialog box appears.
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	Select Mask and click OK.
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Masks do not recognize strokes, so use only fills in the mask layer. Text created with the Text tool also works as a mask.





The text layer becomes a mask layer, indicated by the mask icon in front of the layer name. Anything in this layer will act as a mask for a masked layer below it.
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For this lesson, we’re using the text already in place as the mask, but the mask can be any filled shape. The color of the fill doesn’t matter. What’s important to Animate are the size, location, and contours of the shape. The shape will be the “peephole” through which you’ll see the content on the layer below. You can use any of the drawing or text tools to create the fill for your mask.
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Animate does not recognize different Alpha levels in a mask created on a timeline, so a semitransparent fill in the mask layer has the same effect as an opaque fill, and edges will always be hard. However, in an ActionScript 3.0 document, you can use ActionScript code to dynamically create masks that will allow transparencies.









Create the masked layer


The masked layer is always indented under the mask layer.




	Click the New Layer button, or choose Insert > Timeline > Layer.


A new layer appears.



	Rename the layer fiery_effect.




[image: Image]




	Drag the fiery_effect layer under the mask layer (named “text”) and a little to the right so that it becomes indented.
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The fiery_effect layer becomes a masked layer, paired with the mask layer above it. Any content in the masked layer will be masked by the layer above it.



	Choose File > Import > Import To Stage, and select fire.jpg from the 07Start folder. Then click Open.


The bitmap image of fire appears on the Stage, and the words appear over the image.
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You can also double-click a normal layer under a mask layer, or choose Modify > Timeline > Layer Properties, and select Masked to modify the layer into a masked layer.









See the effects of the mask


To see the effects of the mask layer on its masked layer, you must lock both layers.




	Click the Lock option for both the text layer and the fiery_effect layer.
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Both the mask and masked layers become locked. The shapes of the letters in the mask layer reveal parts of the image in the masked layer.
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You can have multiple masked layers under a single mask layer.






	Choose Control > Test.


As the flame flickers above the text, the letters reveal the fiery texture in the layer below it.








Traditional masks


It might seem counterintuitive that the shapes in the mask layer reveal, rather than hide, the content in the masked layer. However, that’s exactly how a traditional mask in photography or painting works. When a painter uses a mask, the mask protects the painting from paint splatters so that the underlying painting will be visible. When a photographer uses a mask in the darkroom, the mask protects the photosensitive paper from the light, to prevent those areas from getting any darker. So thinking of a mask as something that protects a lower, masked layer is a good way to remember which areas are hidden and which are revealed.











Animating the mask and masked layers


The letters of your animated logo have more drama now that you’ve created a mask with an image of fire behind it. However, the client for this fictional project now demands that it have even more punch. Although she likes the look of the fiery letters, she wants an animated effect.


Fortunately, you can include animations in either the mask or the masked layer. You can create an animation in the mask layer if you want the mask itself to move or expand to show different parts of the masked layer. Or you can create an animation in the masked layer if you want the content to move under a mask, like scenery whizzing by a train window.




Adding a tween to the masked layer


To make the logo more compelling for your client, you’ll add a shape tween to the masked layer. The shape tween will move a glow from left to right for a portion of the movie under the letters.




	Unlock both the text layer and the fiery_effect layer.


The effects of the mask and masked layer are no longer visible, but their contents are now editable.



	Delete the bitmap image of the fire in the fiery_effect layer.



	Select the Rectangle tool and open the Color panel (Window > Color).



	In the Color panel, make sure Fill Color is selected and choose Linear Gradient from the Color Type menu.



	Create a gradient that starts with red on the far left (#FF0000), goes to yellow in the middle (#FFFC00), and becomes red again on the far right (#FF0000). Make sure your Alpha is set to 100% so that the colors are not transparent.
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	Create a rectangle in the fiery effect layer that encompasses the letters in the text layer.
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	Choose the Gradient Transform tool, and click the fill of your rectangle to select it.


The control handles for the Gradient Transform tool appear on the fill of the rectangle. We’ll use this tool to position the gradient off the Stage so that it can make a dramatic entrance.
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	Drag the center point of the gradient so that the yellow color appears on the far left side of the Stage.
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The yellow glow will enter from the left and move to the right.



	Select frame 20 in the fiery_effect layer and choose the Insert Keyframe button above the Timeline (or F6).
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The contents of the previous keyframe are copied into the new keyframe.



	Select the last frame (frame 40) in the fiery_effect layer and choose the Insert Keyframe button above the timeline (or F6).
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The contents of the keyframe at frame 20 are copied into the new keyframe. You now have three keyframes in the fiery_effect layer.



	Make sure that your playhead is still in the last frame (frame 40).



	Drag the center point of the gradient far enough to the right so that the yellow color is just barely visible on the right side of the Stage.




[image: Image]




	Select any frame on the timeline between the second and third keyframe in the fiery_effect layer, and choose Create Shape Tween above the timeline. Or, from the main menu bar, choose Insert > Shape Tween.


The color gradient is shape tweened so that the yellow glow moves within the fill of the rectangle from left to right.
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	Watch your animation by choosing Control > Test or by pressing Return/Enter.
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While the flame burns above the letters, a soft yellow glow flashes across the letters.












Easing a shape tween


Eases help your animation bear a sense of weight by enabling you to add an acceleration or deceleration component to its motion.




[image: Image] Note


The Motion Editor, which is the advanced panel integrated into the timeline that provides different ease types, is not available for shape tweens.





You can use the Properties panel to add an ease to a shape tween. Ease values range from −100, which indicates an ease-in, to 100, which indicates an ease-out. An ease-in makes the motion start off slowly. An ease-out slows down the motion as it approaches its ending keyframe.




Adding an ease-in


You’ll make the glow that flashes across the letters of the logo begin slowly and then pick up speed. The ease-in will help viewers take notice of the animation before it proceeds.




	Click anywhere inside the shape tween in the fiery_effect layer.



	In the Properties panel, enter -100 for the Easing Intensity value.
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Animate applies an ease-in effect to the shape tween.



	Make sure that your mask and masked layers are locked, and choose Control > Test to test your movie.




[image: Image] Note


As with classic tweens, you can apply more advanced eases or even custom eases. Click the Classic Ease button to access the additional ease options, or click the pencil icon to customize your ease curve.





The soft yellow glow flashes across the letters, starting off slowly and then adding a little more sophistication to the entire animation.










Exporting the finished animated GIF


Your project is done, and you’ll export the animated GIF to be used as your client’s Facebook profile image.




	Choose File > Export > Export Animated GIF.


Animate opens the Export Image dialog box. It shows a preview of the image and various options for optimizations. In the Preset area, make sure the Transparency option is unselected.
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	In the Preset area, choose GIF from the Optimized File Format menu. Choose 0 from the Lossy menu and 256 from the Colors menu. This will maximize the quality of your image. You can select Selective and Diffusion for the other two menus. These options determine how the 256 colors are chosen and mixed to create the final image.
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	In the Image Size area, keep all the values at their default settings. The Width and Height should match the original Stage size.



	In the last area, Animation, you can choose the type of looping behavior for your animated GIF. Select Forever, which will make your animated GIF loop endlessly. You can preview the animation by clicking the Play button. You can also examine each of the 40 frames individually by moving forward or backward one frame at a time.
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	Click Save, and in the dialog box that appears, provide a filename and navigate to the 07End folder to save your animated GIF.








Review questions


1 What is a shape tween, and how do you apply it?


2 What are shape hints, and how do you use them?


3 What does the color-coding of the onion skin markers indicate?


4 How is a shape tween different from a motion tween?


5 What is a mask, and how do you create one?


6 How do you see the effects of a mask?


Review answers


1 A shape tween creates smooth transitions between keyframes containing different shapes. To apply a shape tween, create different shapes in an initial keyframe and in a final keyframe. Then, select any frame between the keyframes in the timeline and choose Create Shape Tween from the Create Tween button above the Timeline.


2 Shape hints are labeled markers that indicate how one point on the initial shape of a shape tween will map to a corresponding point on the final shape. Shape hints help refine the way the shapes will morph. To use shape hints, first select the initial keyframe of a shape tween. Choose Modify > Shape > Add Shape Hint. Move the first shape hint to the edge of the shape. Move the playhead to the final keyframe, and move the corresponding shape hint to a matching edge of the shape.


3 By default, Animate shows the onion skins in previous frames in blue and the onion skins in future frames in green. The onion skin in the currently selected frame is in red. The colors can be customized in the Advanced Settings options in the Onion Skin menu.


4 A shape tween uses shapes, whereas a motion tween uses symbol instances. A shape tween smoothly interpolates the change of stroke or fill of a shape between two keyframes. A motion tween smoothly interpolates the changes in location, scale, rotation, color effect, or filter effect of a symbol instance between two keyframes.


5 Masking is a way of selectively hiding and displaying content on a layer. In Animate, you put a mask on the top mask layer and the content in the layer below it, which is called the masked layer. Both the mask and the masked layers can be animated.


6 To see the effects of the mask layer on the masked layer, you must lock both layers, or test your movie by choosing Control > Test.
















  

8 CREATING INTERACTIVE NAVIGATION




Lesson overview


In this lesson, you’ll learn how to do the following:




	Create button symbols.



	Add sound effects to buttons.



	Duplicate symbols.



	Swap symbols and bitmaps.



	Name button instances.



	Understand how ActionScript 3.0 and JavaScript are used in Animate documents.



	Use the wizard in the Actions panel to quickly add JavaScript for interactivity.



	Create and use frame labels.



	Create animated buttons.
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This lesson will take about two hours to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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Let your viewers explore your project and become active participants. Button symbols and code work together to create engaging, user-driven interactive experiences.






Getting started


To begin, view the interactive restaurant guide that you’ll create as you learn to make interactive projects in Adobe Animate.
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If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.
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This project contains buttons and bitmaps that may generate security errors when you try to play the HTML file locally. Your browser may be blank or simply show a static picture when you double-click the HTML file to open it in a browser. Upload all required files to your server (see Lesson 11), or test the movie within Animate.







	Double-click the 08End.fla file in the Lesson08/08End folder to open the animation in Animate. Choose Control > Test to see the final project.


The project opens in your default browser. You can ignore any warnings that appear in the Output panel.
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The project is an imaginary city’s interactive restaurant guide that runs in the browser. Viewers can click any button to see more information about a particular restaurant. In this lesson, you’ll be working in an HTML5 Canvas document to create interactive buttons and structure the timeline properly. You’ll learn to add JavaScript code to provide instructions for what each button will do.



	Close the 08End.fla file.



	Double-click the 08Start.fla file in the Lesson08/08Start folder to open the initial project file in Animate. The file is an HTML5 Canvas document that will play in a browser. The document includes several assets already in the Library panel, and the Stage has already been sized properly.



	Choose File > Save As. Name the file 08_workingcopy.fla and save it in the 08Start folder. Saving a working copy ensures that the original start file will be available if you want to start over.
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Animate may warn you if your computer doesn’t have the same fonts contained in a FLA file. Choose substitute fonts, or click Use Default to have Animate automatically make the substitutions.









About interactive movies


Interactive movies change based on the viewer’s actions. For example, when the viewer clicks or taps a button, a different graphic with more information is displayed. Interactivity can be simple, such as a button click, or it can be complex, receiving inputs from a variety of sources, such as the movements of the mouse, keystrokes from the keyboard, or even the tilting of a mobile device.






ActionScript and JavaScript


In Animate, you add interactivity with either ActionScript 3.0 or JavaScript, depending on the kind of document you’re working in.


If you’re working in an ActionScript 3.0, AIR for Desktop, or AIR for iOS or Android document, you use ActionScript to achieve interactivity. ActionScript provides the instructions that enable an animation to respond to the user. Those instructions could be to play a sound, skip to a keyframe on the timeline where new graphics appear, or make a calculation.


In an HTML5 Canvas, WebGL glTF, VR 360, or VR Panorama document, you use JavaScript, the same code that drives interactivity for web pages in a browser.


ActionScript 3.0 and JavaScript are very similar (in fact, both are based on an ECMA coding language standard), but there are slight differences in syntax and usage.


In this lesson, you’ll use JavaScript in an HTML5 Canvas document to learn to create a nonlinear navigation—one in which the movie doesn’t have to play straight from the beginning of the timeline to the end. You’ll add JavaScript to tell the Animate playhead to jump around and go to different frames of the timeline based on which button the user clicks. Different frames on the timeline contain different content. The user doesn’t actually know that the playhead is jumping around the timeline; the user just sees (or hears) different content appear as the buttons are clicked on the Stage.


Don’t worry if you don’t think you’re good at programming! You don’t have to be a code ninja, because Animate provides an easy-to-use menu-driven wizard in the Actions panel that allows you to add JavaScript quickly and simply.






Creating buttons


A button is a basic visual indicator of something users can interact with. Users often click a button with the mouse or tap a button with their finger, but many other types of interactions are possible. For example, something can happen when a user rolls the mouse pointer over a button.


A button is a kind of symbol that has four special states, or keyframes, that determine how the button appears. Buttons can look like virtually anything—an image, a graphic, or a bit of text. They don’t have to be those typical pill-shaped gray rectangles that you see on many websites.




Creating a button symbol


In this lesson, you’ll create buttons with small thumbnail images and restaurant names. A button symbol’s four special states are represented on the button’s timeline as frames, just like on the main timeline. The four frames include the following:




	The Up state shows the button as it appears when the pointer is not interacting with it.



	The Over state shows the button as it appears when the pointer is hovering over it.



	The Down state shows the button as it appears when the pointer is hovering over it and the user presses the mouse button or trackpad.



	The Hit state indicates the clickable area of the button.






You’ll understand the relationship between these states and the button appearance as you work through this exercise.




	Choose Insert > New Symbol.



	In the Convert to Symbol dialog box, choose Button from the Type menu and name the symbol gabel loffel button. Click OK.
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Animate puts you in symbol-editing mode for your new button.



	In the Library panel, expand the restaurant thumbnails folder and drag the graphic symbol “gabel loffel thumbnail” to the middle of the Stage.
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	In the Properties panel, set the X value to 0 and the Y value to 0.


The upper-left corner of the small gabel loffel restaurant image is now aligned to the registration point of the symbol (marked by the small cross in the center of the screen).



	Select the Hit frame in the timeline and choose Insert > Timeline > Frame to extend the timeline.


The gabel loffel image now extends through the Up, Over, Down, and Hit states.
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	Insert a new layer. The new layer will accommodate an image that appears when the user’s mouse cursor hovers over the button.



	In the new layer, select the Over frame and choose Insert > Timeline > Keyframe.


Animate inserts a new keyframe in the Over state of the top layer.
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	In the Library panel, expand the restaurant previews folder, and drag the “gabel loffel over info” movie clip symbol onto the Stage.
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	Move the movie clip symbol until it’s over the lower part of the button. When guides appear along the bottom and side of the object, let it snap into place. In the Properties panel, the Position And Size section should show approximately X=0 and Y=217.


The gray information box will appear over the restaurant image whenever the mouse cursor rolls over the button.



	Insert a third layer above the first two.


We’ll use this layer to bind a sound file to the Down state so that the button will make a click sound when it’s “pressed” (clicked).



	Select the Down frame on the new layer and choose Insert > Timeline > Keyframe.


A new keyframe is inserted in the Down state of the new layer.
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	Drag the sound file called clicksound.mp3 from the Library panel to the Stage.
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You’ll learn more about sound in Lesson 10.





The beginning of the sound’s waveform (appearing as a thick orange line) appears in the Down keyframe of the top layer of your button symbol.
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	Select the Down keyframe where the waveform appears, and in the Sound section of the Properties panel, note that Event is chosen from the Sync menu.
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A clicking sound will play only when a viewer “presses” (clicks) the button.



	Click Scene 1 in the Edit bar above the Stage to exit symbol-editing mode and return to the main timeline. Your first button symbol is complete! Look in your Library panel to see the new button symbol stored there.
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Invisible buttons and the Hit keyframe


Your button symbol’s Hit keyframe indicates the area that is “hot,” or clickable by the user. Normally, the Hit keyframe contains a shape that is the same size and location as the shape in your Up keyframe. In most cases, you want the graphics that users see to be in the same area where they click. However, in certain advanced applications, you may want the Hit keyframe and the Up keyframe to be different. If your Up keyframe is empty, the resulting button is known as an invisible button.


Users can’t see invisible buttons, but because the Hit keyframe still defines a clickable area, invisible buttons remain active. You can place invisible buttons over any part of the Stage and use code to program them to respond to users.


Invisible buttons are useful for creating generic hotspots. For example, placing them on top of different photos can help you make each photo respond to a click or tap without having to make each photo a different button symbol.









Duplicating buttons


Now that you’ve created one button, you’ll be able to create others more easily. You’ll duplicate one button here, change the image in the next section, and then continue to duplicate buttons and modify images for the remaining restaurants.




	In the Library panel, right-click the “gabel loffel button” symbol and choose Duplicate. You can also choose Duplicate from the Library panel menu.
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	In the Duplicate Symbol dialog box, choose Button from the Type menu, and name the symbol gary gari button. Click OK.
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Swapping bitmaps


Bitmaps and symbols are easy to swap on the Stage and can significantly speed up your workflow.




	In the Library panel, double-click the icon for your newly duplicated symbol (gary gari button) to edit it.



	Select the restaurant image on the Stage.



	In the Properties panel, click Swap.
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	In the Swap Symbol dialog box, select the next thumbnail image, the gary gari thumbnail, in the restaurant thumbnails folder, and click OK.
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The original thumbnail (shown with a dot next to the symbol name) is swapped out for the one you selected. Because they are both the same size, the replacement is seamless.



	Now select the Over keyframe on Layer_2 and click the gray information box on the Stage.
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	In the Properties panel, click Swap and swap the selected symbol with the symbol called “gary gari over info.” Click OK.


The instance of your button in the Over keyframe is replaced with one that is appropriate for the second restaurant. Because the symbol was duplicated, all other elements, such as the sound in the top layer, remain the same.
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	Continue duplicating your buttons and swapping the two instances inside them until you have four different button symbols in your Library panel, each representing a different restaurant (gabel loffel button, gary gari button, il piatto button, and pierre platters button). When you’re done, take a moment to organize all your restaurant buttons in a folder in your Library panel called restaurant buttons.




[image: Image]











Placing the button instances


Now you’ll put the buttons on the Stage and give them names in the Properties panel so that your code can identify them.




	On the main timeline, insert a new layer and rename it buttons.
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	Drag each of your buttons from the Library panel to the middle of the Stage, placing them in a horizontal row. Don’t worry about their exact position, because you’ll align them nicely in the next few steps.
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	Select the first button, and in the Properties panel, set the X value to 100.



	Select the last button, and in the Properties panel, set the X value to 680.



	Select all four buttons. In the Align panel (Window > Align), deselect Align To Stage, click Space Evenly Horizontally, and then click Align Top Edge.
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All four buttons are now evenly distributed and aligned horizontally.



	With all the buttons still selected, in the Properties panel, enter 170 for the Y value.


All four buttons are positioned on the Stage correctly.
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	Now you can test your movie to see how the buttons behave. Choose Control > Test.


You can ignore any warnings that show up in the Output panel.


Note that the gray information box in the Over keyframe appears when your mouse cursor hovers over each button, and that pressing your mouse or trackpad button over each button triggers the clicking sound. At this point, however, you haven’t provided any instructions for the buttons to actually do anything. That part comes after you name the button instances and learn a little about coding.
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If your browser displays a blank screen when you test your movie (Control > Test), make sure you’re connected to the Internet. If you’re not, then open the Publish settings (File > Publish Settings). Select the HTML/JS tab and deselect Hosted Libraries. The Hosted Libraries option links to external JavaScript code, so your published files don’t have to include them, but you need to be connected to the Internet for your project to work.









Naming button instances


Next you’ll name each button instance so that your code can reference it. Beginners often forget this crucial step.




	Click in an empty part of the Stage to deselect all the buttons, and then select just the first button.
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	Type gabelloffel_btn in the instance name field in the Properties panel.
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	Name the other buttons garygari_btn, ilpiatto_btn, and pierreplatters_btn.


Animate is very picky, and one typo will prevent your entire project from working correctly! See the sidebar “Naming rules” for information about instance names.








Naming rules


Naming instances is a critical step in creating interactive projects in Animate. The most common mistake made by novices is not to name, or to incorrectly name, a button instance.


Instance names are important because ActionScript and JavaScript use the names to reference those objects. Instance names are not the same as the symbol names in the Library panel. The names in the Library panel are simply organizational reminders.


Instance naming follows these simple rules and best practices:




	Do not use spaces or special punctuation. Underscores are okay to use.



	Do not begin a name with a number.



	Be aware of uppercase and lowercase letters. ActionScript and JavaScript are case-sensitive.



	End your button name with _btn. Although it is not required, it helps identify those objects as buttons.



	Do not use any word that is reserved for an ActionScript or JavaScript command.















Preparing the timeline


Every new Animate project begins with just a single frame. To create room on the timeline to add more content, you’ll have to add more frames to at least one layer.




	Select a later frame in all three layers. In this example, select frame 50.



	Choose Insert > Timeline > Frame (F5). You can also right-click and choose Insert Frame.
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Animate adds frames in all of the selected layers up to the selected point, frame 50.










Creating destination keyframes


When the user clicks each button, Animate will move the playhead to a new spot on the timeline according to code that you’ll insert. Before adding the code, you’ll create all the different options on the timeline that your user might choose.




Inserting keyframes with different content


You will create four keyframes in a new layer and place information about each of the restaurants in the new keyframes.




	Insert a new layer at the top of the layer stack and rename it content.
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	Select frame 10 of the content layer.



	Insert a new keyframe at frame 10 (choose Insert > Timeline > Keyframe, or press F6, or press the Insert Keyframe button above the Timeline).
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	Insert new keyframes at frames 20, 30, and 40.
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Your timeline has four empty keyframes in the content layer.



	Select the keyframe at frame 10.



	In the Library panel, expand the restaurant content folder. Drag the symbol “gabel and loffel” from the Library panel to the Stage. This is a movie clip symbol that contains a photo, graphics, and text about the restaurant.



	Position the symbol in the center of the Stage but out of the way of the heading. The Properties panel Position And Size section should show X=60 and Y=150.
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The restaurant information about gabel and loffel is centered on the Stage and covers all the buttons.



	Select the keyframe at frame 20.



	Drag the symbol “gary gari” from the Library panel to the Stage so that it also covers all the buttons. This is another movie clip symbol that contains a photo, graphics, and text about this restaurant.
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	In the Properties panel, make sure the X value is set to 60 and the Y value is set to 150.



	Place each of the movie clip symbols from the restaurant content folder in the Library panel at the corresponding keyframes in the content layer.


Each keyframe should contain a different movie clip symbol about a restaurant.










Using labels on keyframes


Frame labels are names that you give to keyframes. Instead of referring to keyframes by their frame number, you refer to them by their label, which makes code easier to read, write, and edit.




	Select frame 10 on the content layer.



	In the Properties panel Label section, enter label1 in the Name field.




[image: Image]



A tiny flag icon appears on each of the keyframes that have labels.
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	Select frame 20 on the content layer.



	In the Properties panel, in the Label section, enter label2 in the Name field.



	Select frames 30 and 40, and in the Properties panel, enter corresponding names in the Name field for each: label3 and label4.


A tiny flag icon appears on each of the keyframes that has a label.
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Navigating the Actions panel


The Actions panel is where you enter all your code, whether JavaScript for HTML5 Canvas documents or ActionScript for ActionScript 3.0 documents to target Flash Player or AIR. Open the Actions panel by choosing Window > Actions or by selecting a keyframe on the timeline and clicking the Actions panel button at the top right of the Properties panel.
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You can also right-click any keyframe and choose Actions.


The Actions panel gives you a flexible environment for entering code, as well as different options to help you write, edit, and view your code.
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The Actions panel is divided into two parts. On the right of the Actions panel is the Script window—the blank slate where you can write code freely. You enter ActionScript or JavaScript in the Script window just as you would in a text-editing application.


On the left is the Script navigator, which shows you where your code is located. Animate places code on keyframes on the timeline, so the Script navigator can be particularly useful if you have lots of code scattered in different keyframes and on different timelines.


At the bottom of the Actions panel, Animate displays the line number and column number (or character in the row) of the current position of the text insertion point.


The upper-right corner of the Actions panel contains options for finding, replacing, and inserting code. The Add Using Wizard button is also located there.






Adding JavaScript interactivity with the Actions panel wizard


Now that you have multiple keyframes on the timeline, your movie will play linearly from frame 1 to frame 50, showing all the restaurant choices. However, with this interactive restaurant guide, you’ll want to pause the movie at the very first frame to wait for your viewers to choose a restaurant.




Stopping the timeline


Use a stop() action to pause your Animate movie. A stop() action simply stops the movie from continuing by halting the playhead.




	Insert a new layer at the top and rename it actions.
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JavaScript and ActionScript code are generally placed on keyframes on the timeline.



	Select the first keyframe of the actions layer and open the Actions panel (Window > Actions).



	Click the Add Using Wizard button.
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The wizard opens within the Actions panel. The wizard guides you step by step through the code-writing process. The code that you generate with the wizard appears in the first field. The wizard is available for inserting JavaScript into HTML5 Canvas, WebGL glTF, VR Panorama, and VR 360 documents. For ActionScript, you can use a different panel called the Code Snippets panel.



	Step 1 asks you to choose the action, or the behavior that you want Animate to perform, from a list. Scroll downward in the list under Select An Action and select Stop (the items are listed alphabetically).
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Another menu appears to the right.



	In the next menu, choose This Timeline.
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Code appears in the action window. The stop() action will apply to the current timeline.
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	Click Next.


Step 2 appears in the wizard.



	Step 2 asks you to select the trigger that will produce your selected action. Select With This Frame.
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Additional code is added to make reference to the current timeline.
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You want the stop() action to be executed as soon as the timeline begins, so the appropriate trigger is when the playhead encounters the current frame.



	Click Finish And Add.


The finished code is added to the Script window in the Actions panel.
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The code is


var _this = this;


_this.stop();


The first statement creates a variable, or a placeholder, called _this that refers to the current timeline.


The second statement points to the current timeline and applies the stop() action. The semicolon at the end of each of the statements acts as a period and indicates the end of a command.


The code in light gray that begins with /* and ends with */ is called a multiline comment, and it is simply a description of what the code does. It acts as a reminder for you and for other developers. Well-commented code is essential. It will save you hours of headache when you return to a project, and it is considered best practice for coders.



	In the timeline, a tiny letter “a” is added to the first frame in the action layer to indicate that code has been added there.
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Adding actions for a button click


So far, you have code that stops the timeline at the first frame. Now you’ll add an action for a button click. The button click is called a trigger in the wizard, but in JavaScript and ActionScript it is known as an event.


Events are occurrences in your movie that Animate can detect and respond to. For example, a mouse click, a mouse movement, and a key press are all events. Pinch and swipe gestures on mobile devices are also events. These events are produced by the user, but some events can happen independently of the user, like the successful loading of a piece of data or the completion of a sound.




	Select the first frame of the action layer.



	Open the Actions panel, if it’s not already open.



	Place your text cursor in the last line of your Script window. You’ll add additional code to the code that’s already there.



	Click the Add Using Wizard button.


The wizard opens within the Actions panel.



	Step 1 asks for the action. Scroll down and select Go To Frame Label And Stop.
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Another menu appears to the right.



	In the next menu, choose This Timeline.
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Code appears in the action window. The action will apply to the current timeline.
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	Replace the blue highlighted letters in the action window with the name of the label you want the playhead to go to. To replace enterFrameLabel, enter label1.
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The frame label name appears in green and should be between a set of single quotes.



	Click Next.


Step 2 appears in the wizard.



	Step 2 asks for the trigger that will produce your selected action. Select On Mouse Click.
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On Mouse Click is an event that happens when the user’s mouse button (or trackpad) is pressed and then released over the onscreen button. Another menu appears to the right.



	The wizard asks for the object for the triggering event. Select gabelloffel_btn, which is the button that corresponds to the Gabel and Loffel restaurant, whose information is displayed in the keyframe labeled “label1.”
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	Click Finish And Add.
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The finished code is added to the Script window in the Actions panel. The code consists of the trigger 'click' and a function that groups all the code that is executed when the trigger happens. What’s important for you to identify are the opening and closing curly braces of the function. This function has only one statement (a gotoAndStop() action, which moves the playhead), but functions can contain many statements.



	Choose Control > Test.


Animate opens your browser to show your project. Click the Gabel Loffel button. Animate detects the click trigger on the button and moves the playhead to the keyframe labeled “label1,” where the Stage shows information about the Gabel and Loffel restaurant.
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	Close your browser and return to Animate.



	Select the first frame of the actions layer and open the Actions panel again.



	Continue adding additional actions and triggers to the existing code for the other three buttons. Each button should trigger a gotoAndStop() action to a different keyframe.
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If you’re feeling confident, you can try to streamline the process of replicating the code for the other three buttons. Copy the code in the Script window, then paste it three times. Each time, change only the name of the button and the name of the frame label. It will be faster than going through the wizard, and it will be your first step in identifying and learning different parts of JavaScript code so that you can eventually write code yourself.







Checking for errors


Debugging is a necessary process, even for veteran coders. Even if you’re extra careful, errors will creep into your code. Fortunately, the wizard helps reduce typos and common errors. If you do enter code by hand, a few tips can help prevent, catch, and identify errors:




	If you’re working in an ActionScript 3.0 document, Animate automatically displays code errors in the Compiler Errors panel (Window > Compiler Errors) with a description of the error and its location. None of your code will be functional if there is a compiler error in any part of the code.



	Take advantage of color hinting in the code. Animate colors keywords, variables, comments, and other language elements differently. You don’t need to know why they are different, but the different colors can give you clues as to where there may be some missing punctuation.



	Click the Format Code button at the upper-right corner of the Actions panel to tidy up your code and make it easier to read. You can change the formatting settings in Animate > Preferences > Edit Preferences > Code Editor (macOS) or Edit > Preferences > Code Editor (Windows).















Creating a Home button


Since the information for each restaurant covers the buttons, readers currently can’t make another selection after they choose their first. You’ll need to provide another button that will return users to the first frame, which you’ll do in the next section.


A Home button simply makes the playhead go back to the first frame of the timeline, or to a keyframe where an original set of choices, or the main menu, is presented to the viewer. You can create a button that goes to the first frame using the same process you followed to create the four restaurant buttons.




Adding another button instance


The sample lesson file provides a Home, or Main Menu, button for you in the Library panel.




	Select the buttons layer and unlock it if it is locked.



	Drag the button called mainmenu from the Library panel to the Stage. Position the button instance at the upper-right corner.
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	In the Properties panel, set the X value to 726 and the Y value to 60.



	In the Properties panel, name the instance mainmenu_btn.
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Adding code for the Home button


The action will be Go To Frame Number And Stop, and the trigger will be a button click.




	Select the first frame of the action layer.



	Open the Actions panel, if it’s not already open.



	Place your text cursor at a new line after the last line of code in your Script window. You’ll add additional code to the code that’s already there.



	Click the Add Using Wizard button.


The wizard opens within the Actions panel.



	Step 1 asks for the action. Scroll down and select Go To Frame Number And Stop.




[image: Image]



Another menu appears to the right.



	In the next menu, select This Timeline.
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Code appears in the action window. The action will apply to the current timeline.



	Replace the blue highlighted letters in the action window with the frame number you want the playhead to go to. Instead of 50, enter 0.
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Why 0 and not 1? The JavaScript CreateJS library begins counting frames at 0, so the first frame of your timeline is 0 and not 1. ActionScript and JavaScript for WebGL glTF and VR documents, on the other hand, begin counting the timeline frames at 1, so be extra careful when coding frame numbers. For this reason, it’s best to use frame labels whenever possible.


Notice, too, that frame numbers are not enclosed between single quotes. Frame labels, however, are.



	Click Next.


Step 2 appears in the wizard.



	Step 2 asks for the trigger that will produce your selected action. Select On Mouse Click.
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On Mouse Click is an event that happens when the user’s mouse is pressed and then released over the button. Another menu appears to the right.



	The wizard asks for the object for the triggering event. Select mainmenu_btn.
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	Click Finish And Add.
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Code Snippets panel


Animate provides another panel, called the Code Snippets panel (Window > Code Snippets), that offers a way to add ActionScript 3.0 or JavaScript code. The panel is organized into folders for different kinds of interactivity. Simply expand the folder that you want and select the action. Animate guides you for any additional information.


The Code Snippets panel also provides a way for you to save your own code and share it with other developers.
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For beginners, it’s best to use the Add Using Wizard option in the Actions panel for JavaScript.











Playing animation at the destination


So far, this interactive restaurant guide works by using the gotoAndStop() action to show information in different keyframes along the timeline. But suppose you wanted an image to fade in rather than appear suddenly—how would you play an animation after a user clicks a button? One way is to use the action gotoAndPlay(), which moves the playhead to the frame number or frame label and plays from that point forward.




Creating transition animations


Next, you’ll create a short transition animation for each of the restaurant guides. The transition animation will show the restaurant guides slowly increase in opacity to fade up. Then you’ll change your code to direct Animate to go to each of the beginning keyframes and play the animation.




	Move the playhead to the label1 frame label.



	Right-click the instance of the restaurant information on the Stage and choose Create Motion Tween, or choose Create Motion Tween from the Create Tween menu above the Timeline.
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Animate creates a separate tween layer for the instance so that it can proceed with the motion tween.
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	Select the instance on the Stage, and in the Properties panel’s Color Effect section, choose Alpha from the Style menu.



	Set the Alpha slider to 0%.
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The instance on the Stage becomes totally transparent.



	Move the playhead to the end of the tween span at frame 19.
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	Select the transparent instance on the Stage.



	In the Properties panel, set the Alpha slider to 100%.
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The instance is displayed at a normal opacity level. The motion tween from frame 10 to frame 19 produces a smooth fade-in effect.



	Create similar motion tweens for the remaining restaurants in the keyframes labeled label2, label3, and label4. Don’t try to test your movie just yet! You still have to tweak the JavaScript code in the next task to make this work.
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Using the gotoAndPlay() action


The gotoAndPlay() action makes the Animate playhead move to a specific frame on the timeline and begin playing from that point.




	Select the first frame of the action layer and open the Actions panel.



	In your JavaScript code, change the first four gotoAndStop() actions to gotoAndPlay() actions. Leave the parameter unchanged:
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A fast and easy way of doing multiple replacements is to use the Find And Replace command in the Actions panel. Click the Find button in the upper-right corner, select Find, and then choose Find And Replace from the menu to the right of the Find Text field.







	gotoAndStop('label1'); should be changed to gotoAndPlay('label1');



	gotoAndStop('label2'); should be changed to gotoAndPlay('label2');



	gotoAndStop('label3'); should be changed to gotoAndPlay('label3');



	gotoAndStop('label4'); should be changed to gotoAndPlay('label4');


For each of the restaurant buttons, the JavaScript code now directs the playhead to a particular frame label and begins playing at that point.


Make sure you keep the function for your Home button unchanged. You’ll want that function to remain a gotoAndStop() action.














Stopping the animations


If you test your movie now (Control > Test), you’ll see that each button goes to its corresponding frame label and plays from that point, but it keeps playing, showing all the remaining animations in the timeline. The next step is to tell Animate when to stop.




	Select frame 19 of the actions layer, the frame just before the label2 keyframe on the content layer.



	Right-click the frame and choose Insert Keyframe.


A new keyframe is inserted in the actions layer. We’ll use the new keyframe to add a stop() action just before the second animation starts to play.
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	Open the Actions panel.


The Script window in the Actions panel is blank. Don’t panic! Your code has not disappeared. Your code for the event listeners is on the first keyframe of the actions layer. You have selected a new keyframe in which you will add a stop() action.



	In the Script window, enter this.stop();
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Animate will stop playing when it reaches frame 19.



	Insert keyframes at frames 29, 39, and 50.
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	In each of those keyframes, add a stop() action in the Actions panel.
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If you wish, you could also use the Add Using Wizard panel to add the stop() action for each of the keyframes.
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If you want a quick and easy way to duplicate the keyframe containing the stop() action, hold down the Option/Alt key while you drag it to a new location on the timeline.
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	Test your movie by choosing Control > Test.


Each button takes you to a different keyframe and plays a short fade-in animation. At the end of the animation, the movie stops and waits for the viewer to click the Home button.








Pinning code in the Actions panel


When you have code scattered in multiple keyframes on the timeline, it’s sometimes difficult to go back and forth to edit or view your code. The Actions panel provides a way for you to keep the code from particular keyframes “pinned” to the Actions panel. Click the Pin Script button at the top of the Actions panel and Animate will create a separate tab for the code currently displayed in the Script window.




[image: ]



The tab will be labeled with the frame number where your code resides. You can pin multiple scripts, allowing you to navigate easily between them.


To continue with the rest of this lesson, unpin all the scripts so you only have the Current frame tab displayed.











Animated buttons


Currently, when you hover your mouse cursor over one of the restaurant buttons, the gray “additional information” box suddenly appears. But imagine if that gray information box were animated. It would give more life and sophistication to the interaction between the user and the button.


Animated buttons display an animation in the Up, Over, or Down keyframes. The key to creating an animated button is to create an animation inside a movie clip symbol, and then place that movie clip symbol inside the Up, Over, or Down keyframes of a button symbol. When one of those button keyframes is displayed, the animation in the movie clip plays.




Creating the animation in a movie clip symbol


Your button symbols in this interactive restaurant guide already contain a movie clip symbol of a gray information box in their Over states. You will edit each movie clip symbol to add an animation inside it.




	In the Library panel, expand the restaurant previews folder. Double-click the movie clip symbol icon for “gabel loffel over info.”
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You enter symbol-editing mode for the movie clip symbol called gabel loffel over info.
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	Select all the visual elements on the Stage (Command+A/Ctrl+A).



	Right-click and choose Create Motion Tween.
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	In the dialog box that appears asking for confirmation to convert the selection to a symbol, click OK.


Layer 1 is converted to a motion tween layer and adds one second’s worth of frames to the movie clip timeline.
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	Drag the end of the tween span back so that the timeline has only 10 frames.




[image: Image]




	Move the playhead to frame 1 and select the instance on the Stage.



	In the Properties panel’s Color Effect section, choose Alpha from the Style menu and set the Alpha value to 0%.
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The instance on the Stage becomes totally transparent.



	Move the playhead to the end of the tween span at frame 10.
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	Select the transparent instance on the Stage.



	In the Properties panel, set the Alpha value to 100%.
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Animate creates a smooth transition between the transparent and opaque instance in the 10-frame tween span.



	Insert a new layer and rename it actions.



	Insert a new keyframe in the last frame (frame 10) of the actions layer.
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	Open the Actions panel (Window > Actions) and enter this.stop(); in the Script window.


Adding the stop() action in the last frame ensures that the fade-in effect plays only once. The last keyframe on frame 10 of the actions layer shows a tiny “a,” indicating that code is attached there.




[image: Image]




	Exit symbol-editing mode by clicking the Scene 1 button in the Edit bar above the Stage.
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If you want an animated button to repeat its animation, leave out the stop() action at the end of the movie clip’s timeline.






	Choose Control > Test.


When your mouse cursor hovers over the first restaurant button, the gray information box fades in. The motion tween inside the movie clip symbol plays the fade-in effect, and the movie clip symbol is placed in the Over state of the button symbol.
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	Create identical motion tweens for the other gray information box movie clips to animate all of the restaurant buttons, and add a stop() action to the end of those tweens.








Review questions


1 How and where do you add ActionScript or JavaScript code?


2 How do you name an instance, and why is it necessary?


3 How can you label frames, and when is it useful?


4 What does the stop() action do?


5 What is a trigger in the Actions panel wizard?


6 How do you create an animated button?


Review answers


1 ActionScript or JavaScript code is attached to keyframes of the timeline. Keyframes that contain code are indicated by a small lowercase “a.”  You add code in the Actions panel. Choose Window > Actions, or select a keyframe and click the Actions panel icon in the Properties panel, or right-click and select Actions. You enter code directly in the Script window in the Actions panel, or you can add code through the Add Using Wizard option. You can also add code with the Code Snippets panel.


2 To name an instance, select it on the Stage and then type a name in the Instance Name field in the Properties panel. You need to name an instance so that ActionScript or JavaScript can identify it with code.


3 To label a frame, select a keyframe on the timeline, and then type a name in the Frame Label box in the Properties panel. You can label frames in Animate to make it easier to reference frames with code and to give you more flexibility.


4 In ActionScript or JavaScript, a stop() action halts the playhead from advancing.


5 A trigger is an event that Animate can respond to with an action. A button click or the playhead entering a frame are typical triggers.


6 Animated buttons display an animation in the Up, Over, or Down keyframes. To create an animated button, make an animation inside a movie clip symbol, and then place that movie clip symbol inside the Up, Over, or Down keyframes of a button symbol. When one of those button keyframes is displayed, the animation in the movie clip plays.
















  

9 CREATING VIRTUAL REALITY ENVIRONMENTS




Lesson overview


In this lesson, you’ll learn how to do the following:




	Create VR 360 and VR Panorama documents.



	Add a layer texture to project images for a wraparound VR environment.



	Add graphics and animation to VR environments.



	Understand spherical and cylindrical projections.



	Add interactivity to VR environments.



	Control the VR camera with code.



	Test and publish VR documents.








[image: Image]



This lesson will take about two hours to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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VR 360 and VR Panorama documents let you create wraparound environments for an immersive virtual reality (VR) experience. Add graphics, animation, and interactivity to make those experiences richer and more compelling.






Getting started


Start the lesson by viewing the finished virtual reality (VR) project. You’ll create an immersive experience where your audience can look all around them as if they were actually visiting a museum. Hot spots allow them to move from one gallery to the next and learn more about specific pieces of art.
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If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.







	Open the file 09End.fla in the Lesson09/09End folder, and choose Control > Test to preview the final project.
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Because of modern web browser security protocols, your published VR 360 and VR Panorama files may not work properly if you open them directly (from your local filesystem). Upload the HTML and dependent files (the accompanying assets and libs folders) to a remote web server, or spin up a local web server, for your project to display properly. You don’t have to worry about this if you’re just testing your project directly from Animate with Control > Test.






	Your browser opens to show the inside of a museum gallery. Drag left, right, up, and down to see the rest of the room.
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	There are two highlighted doorways. Click the one on the right.



	You move to a new gallery. Drag the image in your browser window to explore the artwork around the room, and click the highlighted doorway to return to the starting room.



	Now click the door to the left to move to a different gallery. Here, vector graphics are seamlessly mixed in the environment and offer more information for particular pieces of art. Those icons are only placeholders to show potential functionality and do not actually work in this lesson.
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	Close your browser window.










About virtual reality


Virtual reality (VR) refers to the use of computer technology to create simulated environments. The reality for users is “virtual” because they are not actually in a different location. Computer graphics transport them to any virtual world, whether the bottom of the ocean or a fantasy realm, by creating a 360-degree or panoramic wraparound environment where they have the ability to look in any direction.


While VR is usually associated with a head-mounted device that covers your eyes and tracks your head movements for a full immersive experience, there are other ways to get the 360-degree effect. Adobe Animate allows you to publish VR environments in a browser window in which the user can drag in any direction. You can also add graphics, animation, and interactivity for a rich, compelling experience.






VR Panorama and VR 360 documents


Animate provides two document types for VR environments: VR 360 and VR Panorama. Your choice of document type depends on the kind of projection you want for your environment. The VR documents “project,” or map, a texture of graphics or an image onto the user’s surroundings to create the wraparound environment. The VR 360 document maps the texture onto a spherical surrounding, whereas the VR Panorama document maps the texture onto a cylindrical surrounding.




Spherical and panoramic projections


The spherical projection uses what’s called an equirectangular image. You may have seen these images on the Internet—they are always twice as wide as they are high (2:1 aspect ratio), and they make things look distorted, especially at the edges. But once the image is projected around a sphere, the distortions disappear. It’s useful to remember that common geographic maps are the reverse—they are the product of the globe (a spherical object) projected onto a flat rectangular surface. The only difference is that in a VR environment, the user is on the inside looking at the inner surface of the sphere, and for the globe, the user is on the outside looking at the outer surface. Popular 360-degree video and still cameras typically take equirectangular images, and software on a viewing device correctly maps the image for the spherical wraparound effect.


A panoramic projection, on the other hand, is much simpler because it is merely a wide image that captures more of the field of view from left to right, just like the photos you would take with a pano or panoramic option from your mobile phone camera. Because a panoramic projection is mapped onto a cylinder, the user can look only left and right (and not up or down).


Animate allows you to import equirectangular or panoramic photos, or even create the graphics yourself to use as the surrounding texture.




[image: Image] Note


As with other document types, not all the features of Animate may be available to the VR 360 and VR Panorama documents. For example, masks, layer parenting, 3D rotation, 3D translation, and the Camera tool aren’t available and are dimmed in the interface.







What does Beta mean?


As of this writing, the VR 360 and VR Panorama document types are still in Beta, which is why you see that parenthetical word included in the document type names. Beta means that the software is still in testing mode. Some features may be incomplete, or some things may not work entirely as expected. Adobe is providing a Beta release of these document types, even though there may be some unpredictable behavior, because of the exciting potential that virtual reality can bring.











Creating a texture layer


For this project, you’ll start a new VR 360 document and import high-resolution equirectangular images taken from a 360 camera. The images show various galleries in an art museum. You’ll create a texture layer for the images so that Animate can properly project them onto a spherical surrounding.




[image: Image] Note


The images from this lesson are from Flickr user Peter Leth and are used under the Creative Commons license.







Starting a new VR 360 document




	In the New Document screen in Animate, click the Advanced category.



	In the Platforms section, choose VR 360 (Beta). For Width enter 2048, and for Height enter 1024.




[image: Image]



VR 360 documents should always be at a 2:1 width-to-height ratio to accommodate equirectangular images or graphics.



	Click Create.


A new VR 360 document opens.



	Choose File > Save, and in the dialog box that opens, save your new document as 09_workingcopy.fla.










Import and resize the images




	Choose File > Import > Import To Library.



	In the dialog box that appears, navigate to the 09Start folder and open the Peter_Leth_FlickrCC folder. Shift-select all three JPEG images. Click Open. If the files are dimmed and unselectable, make sure that the Enable menu is set to All Files.


The selected images are imported into the Library panel.




[image: Image]




	In the Timeline panel, rename the first layer image.



	Drag the gallery1 image from the Library panel onto the Stage.



	Select the image on the Stage, and in the Properties panel, change the W value to 2048 and the H value to 1024.


If the chain link icon is intact, the W and H values are linked, so changing one dimension will change the other proportionately.
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	Move the resized image to X=0, Y=0 so that the image fills the entire Stage.
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Create the texture layer


You choose which layer gets projected onto the spherical environment.




	In the image layer, click the icon under the Create Texture Wrapping For All Layers option.


The Texture Wrapping option is enabled for the images layer indicated by the Texture Wrapping icon.
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	Choose Window > VR View.


The VR View panel opens. The VR View panel provides an interactive preview of how graphics, symbol instances, animations, and images in texture layers are projected.




[image: Image] Note


You can have multiple layers as texture layers. This is particularly important if you’re creating your VR environment from graphics instead of from a single imported image that was taken from a 360 camera.
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[image: Image] Note


If you edit the contents of your Stage, you must refresh your VR View to reflect those changes. Click the Refresh button in the upper-right corner. Click the Reset button to place the texture layer in its default position after you’ve dragged it around.






	Click Launch VR View.


An interactive preview shows up in the panel. Drag the image to look in all directions. If you look down (by dragging upward), you can see the tripod on which the 360 camera that took the picture was mounted.
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[image: Image] Note


Try this out! Don’t mark the image layer as a texture layer and click the Refresh button in the VR View panel. The photo does not get projected onto the spherical surroundings and behaves as a simple flat image floating in a white, empty 3D world.















Creating new scenes


Scenes are separate timelines that you can use to organize your project. Think of scenes as chapters in a book. In an animation, scenes will play linearly from the first to the last.


Your project will contain three scenes for the three separate galleries.




[image: Image] Note


Scenes aren’t exclusive to VR 360 or VR Panorama documents. You can also use scenes to organize your timelines in some of the other Animate documents.







Adding scenes




	Choose Window > Scene.


The Scene panel opens. Only one scene is displayed, Scene 1, which is the default timeline.
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	Click the Add Scene button at the bottom of the panel.


A new scene is created called Scene 2. Scene 2 contains a new timeline.
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	Click the Add Scene button again to add a third scene, called Scene 3.


Click a scene in the Scene panel to navigate to that particular timeline. You can also navigate to a different scene by clicking the Edit Scene icon above the Stage and choosing the scene from the menu that appears.
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Editing scenes


You can easily make changes to the order of your scenes, or add, delete, or rename scenes as needed.




	You can rearrange the order of the scenes by dragging them to new positions in the Scene panel.



	Delete an unwanted scene by selecting the scene and clicking the Delete Scene button (trash can icon) at the bottom of the panel.



	Double-click a scene to rename it. For this lesson, rename Scene 1 gallery1, Scene 2 gallery2, and Scene 3 gallery3.
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Adding galleries




	In the Scene panel, select gallery2.


The timeline shows the second scene with a blank stage and an empty timeline.




[image: Image]




	Drag the gallery2 image from the Library panel to the Stage.



	In the Properties panel, resize the image so that the width is 2048 pixels and the height is 1024 pixels. Position the image at X=0, Y=0.
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	Rename the Layer_1 layer in the gallery2 scene image and make the layer a texture layer.
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	In the Scene panel, select gallery3.



	Drag the gallery3 image from the Library panel to the Stage.



	In the Properties panel, resize the image so that the width is 2048 pixels and the height is 1024 pixels. Position the image at X=0, Y=0.



	Rename the Layer_1 layer in the gallery3 scene image and make the layer a texture layer.
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Adding interactivity


Now you’ll add the clickable hot spots inside the galleries so you can change scenes and move from one VR gallery environment to another. You’ll use a movie clip symbol instance as the clickable graphic.




[image: Image] Note


VR 360 and VR Panorama documents do not support button symbols.







Adding a symbol from another library


Fortunately, you can use the movie clip symbol from the 09End.fla file rather than creating one on your own to save time.




	Choose File > Import > Open External Library (Shift+Command+O/Shift+Ctrl+O).


The file navigator dialog box opens.



	Choose the 09End.fla file in the 09End folder. This is the VR 360 document that has already been completed for you. Click Open.


Another Library panel opens, showing the symbols and imported assets from 09End.fla. In the steps that follow you’ll import items from this library into your 09_workingcopy.fla document.
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	In the gallery1 scene, add a new layer and rename it hotspots.
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	In the 09End.fla Library panel, drag the door movie clip symbol onto the Stage in the hotspots layer.


The door movie clip automatically gets added to your 09_workingcopy Library panel.
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	Add a second instance of the door movie clip.



	Position the two instances over the left and right open doorways in the gallery image. Use the Free Transform tool to resize the instance to fit. You might have to zoom out to see both doors.
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Don’t worry about getting the door movie clip to exactly match the contours of the doorways in the photograph.



	Select the door instance on the left, and in the Properties panel, enter door2 for its name.




[image: Image]



Recall from the previous lesson that naming instances is essential for interactivity so that the JavaScript code knows what object on the Stage you want to reference.



	Select the door instance on the right, and in the Properties panel, enter door3 for its name.
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Adding code to change scenes


You’ll add JavaScript code using the Actions panel wizard.




	In the gallery1 scene, add a new layer and rename it actions.




[image: Image]



Code should be separated on its own layer.



	Select the first keyframe in the actions layer and open the Actions panel (Window > Actions).



	Click the Add Using Wizard button in the upper-right corner of the Actions panel.
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The wizard appears in place of the script window, allowing you to add code from a series of menus.
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	Under Step 1 of the wizard, choose Go To Scene.
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Code is automatically generated with a preview displayed in the window above.
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	Change the highlighted words Enter scene name to gallery2.
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The code, when executed, moves the playhead to a new scene, and the name of the new scene is required in the code.



	Click Next.


The wizard moves to the next step. In this step, you must choose the event that triggers the action (moving to a new scene).
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	Choose On Click, and then in the next menu that appears, choose door2.


The code instructs the project to move to the gallery2 scene when the door2 movie clip instance is clicked.
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	Click Finish And Add.


The wizard adds the JavaScript code to the Script pane of your Actions panel.
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In your timeline, a small lowercase “a” is added to the actions layer to indicate that code is attached there. Close the Actions panel.
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[image: Image] Note


If you use the gotoAndStop() or gotoAndPlay() actions to move the playhead to a new frame on the timeline in either a VR 360 or VR Panorama document, the code refers to the first frame of the timeline as 1 and not 0 as it would for an HTML5 Canvas project.









Previewing your VR project


You preview your VR project in a browser. Make sure you have the latest version of your web browser so that you can see the 360 environment.




	Choose Control > Test.


Your default browser launches, with your VR project in a new window.



	Drag the image to look around the gallery.


Notice how the instance of the door moves and distorts to match the texture layer.
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	Click the left door.


You move to the gallery2 scene, where that image is displayed.
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	Close the browser window and return to Animate.








[image: Image] Note


You can preview interactivity from your JavaScript code only in the browser, and not in the VR View window.









Adding the remaining doors and code


Your code enables your audience to move from the first gallery to the second. You also need to add code for the door on the right so they can move from the first gallery to the third gallery. In addition, there needs to be a way for your audience to return to the first scene once they’ve moved to gallery2 and gallery3.




	In the Actions panel, place your cursor on a new line at the end of the code.



	Click the Add Using Wizard button to open the wizard.



	In a similar manner as the previous task, use the wizard to add code so that clicking door3 triggers an action that moves to the gallery3 scene.
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The interactivity for the gallery2 scene is complete.



	In the Scene panel, select the gallery2 scene.



	Add a new layer and rename it hotspots, as you did previously for your gallery1 scene.



	Drag an instance of the door movie clip to the Stage and place it over the doorway on the left. Use the Free Transform tool to resize it to match the doorway in the photo.
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	In the Properties panel, name the instance door1.
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This movie clip will lead the user back to the gallery1 scene.



	Add a new layer and rename it actions.



	In the Actions panel, use the wizard to add code so that clicking door1 triggers an action that moves to the gallery1 scene.


The interactivity for the gallery2 scene is complete. Notice that in the Actions panel, you can navigate to the different pieces of code you’ve added to the gallery1 or the gallery2 timeline.
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	Do you feel confident adding the necessary components to complete the gallery3 scene? Go through the same steps of adding layers, adding the movie clip instance, naming the instance, and adding code with the wizard. Put the door over the entrance on the far right of the photo. If you run into trouble, you can always examine the 09End.fla file to see what steps you may have missed.








[image: Image] Tip


The code for gallery3 is identical to the code for gallery2, if you name the instance of the doors the same. So to save time, you can copy and paste the code from gallery2 to gallery3 after you put in place the door1 instance.











Adding graphics and animation


Adding graphics can enhance your VR environment. Rather than simply projecting a 360 image, Animate allows you to add and integrate animation into your world. Imagine how characters could walk through the galleries, interacting with each other or pointing out paintings on the wall. Users would not just be passive observers watching the animation but would become active participants as the action unfolds around them.


In the next section, though you won’t add animation, you’ll learn to integrate graphics seamlessly into the VR environment.




Using the VR View panel to position graphics


Integrating graphics into your VR environment isn’t always as simple as moving them onto the Stage as you did with the doors. The distortion on the flat Stage may make precise placement difficult. For example, if you wanted to hang a disco ball from the ceiling of the gallery, where would you put it? The ceiling, after all, is stretched out in the image across the top edge of the photo.


The VR View panel helps with this problem. In addition to providing you with a preview of the projection, the VR View panel lets you move movie clip instances in the VR environment where you want to see them. After you move them in the VR View panel, the objects automatically move to their corresponding positions on the Stage.




	In the gallery2 scene, add a new layer above the hotspots layer, and rename it more_info.
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	Open the 09End.fla library, if it is not already open (File > Import > Open External Library), and drag the more_info movie clip symbol from the Library panel onto the Stage.


The more_info symbol is added to the 09_workingcopy.fla Library panel. The symbol is a simple graphic of a “More Info” signpost and a transparent shadow to make it appear as if it is suspended in air.
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	In the VR View panel, click the Refresh button.


The VR View panel refreshes the display to reflect the addition of the more_info instance on the Stage.
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	Drag the more_info instance around the VR View panel.


Notice how it warps slightly around the edges of the panel to keep the object consistent with the spherical projection.



	Drag the more_info instance close to the standing statue and release it.


The movie clip instance on the Stage moves to the corresponding position.
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	Add another more_info instance to the Stage.



	In the VR View panel, click the Refresh button.


The VR View panel refreshes the display to reflect the addition of the second more_info instance on the Stage.



	Drag the second more_info instance in the VR View panel close to the painting opposite the standing statue.




[image: Image]



Notice that this painting is split by the image. Part of the painting is on the left edge and part is on the right. When Animate wraps this texture layer, the edges are stitched together. The VR View panel helps you position objects when you need to be working close to the seam or at the outer edges, where the distortion is more pronounced.


In some cases, your graphic may appear to be positioned off the Stage (like the arrow head in this figure), but in the VR View panel, the object continues seamlessly on the other side.


The “More Info” graphic that you integrated into this scene suggests that the viewer can click it to get additional information about the particular artwork that it’s pointing to. You won’t do that to complete this lesson, as you’re adding the graphic to learn how to position it in the VR View panel.












Moving the camera position


When you move from the gallery1 scene to the gallery3 scene, your first view of the gallery3 scene is of an orange wall of paintings, a table display, and a doorway.


What if you wanted to show a different view of the gallery3 scene? You can’t do that by moving the image in the texture layer, but you can by using code.


The wizard in the Actions panel also includes code to move the camera position so you can make your user look in the direction you want them to look.




Setting the virtual camera


You’ll move the virtual camera to have the user automatically look at a more interesting part of the room when they first enter the gallery3 scene.




	In the Scene panel, select the gallery3 scene.



	Select the first frame of the actions layer and open the Actions panel.



	In the Actions panel, place your cursor on a new line at the end of the code.



	Click the Add Using Wizard button to open the wizard.



	In Step 1, select Set Camera Position.
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Code is written in the top preview panel. The values of the camera position (x, y, and z) can be changed in the code. The x value is currently highlighted.
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	For the x value, enter 120. For the y value, enter –10. For the z value, enter 30. Click Next.
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The x value refers to the camera view from left to right. The y value refers to the view up and down, and the z value refers to the angle of view (how much of the environment can be seen).


These values make the camera turned to the left (counterclockwise), turned slightly up, and with a wider view.



	Click Next. In Step 2, select With This Frame as the triggering action.
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With This Frame means that the action will be executed when the playhead hits the frame on the timeline.



	Click Finish And Add.


Additional code is added to the current script in the Actions panel.
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	Test your project.



	In the browser window, click the right doorway to move to the gallery3 scene.


The code you wrote sets the camera position so that the initial view now shows more of the paintings and none of the doorway.
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Publishing VR projects


Your VR project is complete, and now it’s time to publish.




Check Publish Settings and export HTML and JavaScript




	Choose File > Publish Settings (Shift+Command+F12/Shift+Ctrl+F12) to open the Publish Settings dialog box.
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	If you want to disable automatic looping of the timeline (when you have an animation), deselect Loop Timeline. For this project, keep it selected.



	If you want to rely on JavaScript libraries that are already on the Internet, keep the Use JavaScript Hosted Libraries option selected. This option allows you to publish leaner files because you don’t have to include more JavaScript code.



	Click Publish.


Animate exports the necessary JavaScript code and graphic assets from your Library panel. If you check the 09Start folder, you’ll see that Animate organizes the code and assets in folders. All of those files are necessary, along with the 09_workingcopy.html document, to play your VR project in a browser. Upload them to your server and share your virtual museum with the world! The FLA isn’t required for playback, so don’t upload it to your server. Keep it safe, however, so you can make additional edits to your project.
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Review questions


1 What is the difference between the VR 360 and VR Panorama document types?


2 What is an equirectangular image?


3 How do you create a texture layer in a VR 360 or VR Panorama document?


4 What is the VR View panel used for?


Review answers


1 The VR 360 document maps its texture layer onto a spherical surrounding, while the VR Panorama document maps its texture onto a cylindrical surrounding.


2 An equirectangular image is produced from projecting a spherical object onto a flat rectangular surface, as a geographic map is from a globe. Equirectangular images are the common format of 360 cameras. In Animate, you can use equirectangular images in the texture layer of a VR 360 document to create a VR environment.


3 Create a texture layer in a VR 360 or VR Panorama document by clicking the Create Texture Wrapping option in the layer that contains the image or graphics you want projected as a texture. You can have more than one texture layer.


4 The VR View panel is used to preview how the image or graphic in the texture layer is projected as a VR environment. You can also drag movie clip instances within the VR View panel to position them accurately on the Stage so they are in the VR environment where you want them to appear.
















  

10 WORKING WITH SOUND AND VIDEO




Lesson overview


In this lesson, you’ll learn how to do the following:




	Import sound files.



	Edit sound files.



	Use Adobe Media Encoder to prepare video.



	Understand video and audio encoding options.



	Use components to play back video for Adobe AIR, ActionScript 3.0, or HTML5 Canvas documents.



	Embed video as a guide to animation.



	Customize options on video playback components.
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This lesson will take about one hour to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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Sound and video add new dimensions to your projects. Import sound files and edit them directly in Adobe Animate, and use Adobe Media Encoder to compress and convert video files to use in your projects.






Getting started


Start the lesson by viewing the finished animated zoo kiosk. You’ll create the kiosk by adding sound and video files to a project in Animate in an AIR for Desktop document.




[image: Image] Note


If your computer asks you to choose an application to open the file, you’ll need to install the Adobe AIR runtime. Go to get.adobe.com/air or to airsdk.harman.com/download (the new home for Adobe AIR) and follow the installation instructions.







	Double-click the file Shearwood-Wildlife-Preserve.air, a cross-platform installer, in the Lesson10/10End folder to install the project.
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[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.





The installer will warn you that the application comes from an unknown author, but you can trust us! Click Install. When the installation is done, the application launches a new window at the upper-left corner of your desktop. After a brief soundtrack of an African beat, a zoo director pops up and introduces himself.
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	Click a sound button (in the lower-left corner) to hear an animal sound.



	Click one of the buttons bearing the picture and name of an animal to view a short movie about the animal. Use the interface controls below the movie to pause the movie, continue the movie, or lower the volume.
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	Press Command+Q/Ctrl+Q to close the application (or choose Quit from the macOS Dock or from the Windows Taskbar).






In this lesson, you’ll import audio files and put them on the timeline to provide the short introductory audio flourish and then embed some of those sounds in each button. Moving on to video, you’ll use Adobe Media Encoder to compress and convert the video files to the appropriate format for Animate. You’ll learn to use and customize video components to play external video files.




	Double-click the 10Start.fla file in the Lesson10/10Start folder to open the initial project file in Animate.



	Choose File > Save As. Name the file 10_workingcopy.fla, and save it in the 10Start folder. Saving a working copy ensures that the original start file will be available if you want to start over.










Understanding the project file


The project file is an AIR for Desktop document. The final published project is a self-contained application that runs on either the Windows or macOS desktop without needing a browser. The application makes it easy to play in a fixed display such as a museum kiosk or information booth.


The initial setup of the project has been completed except for the audio and video portions. The Stage is 1000×700 pixels. A photo of a snoozing lion forms the background of the application. Layered above the background is a row of buttons along the bottom of the Stage, with three simple buttons at the left and a set of buttons depicting colorful animals to the right. A title banner spans the top of the Stage.
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The timeline contains several layers that separate the different types of content.
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The bottom layers, called background photo, black, title, and bottom navbar, contain design elements, text, and images. The two layers directly above, called buttons and sound buttons, contain instances of button symbols. The videos layer contains several labeled keyframes, and the actions layer contains ActionScript 3.0 code that provides the interactivity for the bottom row of buttons.


If you’ve completed Lesson 8, you should be familiar with the structure of this timeline. The individual buttons on the bottom row are already coded so that when the user clicks a button, the playhead moves to a corresponding labeled keyframe in the videos layer. You’ll be inserting content into each of those keyframes. But first you’ll learn to work with sound.




Adobe AIR moves to HARMAN


Adobe has transitioned future development of the AIR platform to HARMAN, a subsidiary of Samsung Electronics, which designs and engineers integrated consumer products for the home and for cars.


What does this mean for Adobe Animate developers? In the short run, Adobe is still committed to providing basic security support for the AIR desktop runtimes through the end of 2020. Beyond that, look to HARMAN for exciting potential developments for AIR distribution across Samsung’s vast ecosystem of consumer products.


For more information, visit HARMAN’s site for AIR (https://services.harman.com/partners/adobe) and the new download page (https://airsdk.harman.com/download), which has the latest on their licensing agreement and pricing structure for different usages and target platforms.









Using sounds


You can import several types of sound files into Animate, among them MP3, AIFF, and WAV files, which are three common sound formats. When you import sound files into Animate, they are stored in your Library panel. You can then drag the sound files from the Library panel onto the Stage at different points along the timeline to synchronize those sounds to whatever may be happening on the Stage.




Importing sound files


You’ll import several sound files to the Library panel, which you’ll use throughout this lesson.




	Choose File > Import > Import To Library.



	Select the Monkey.wav file in the Lesson10/10Start/Sounds folder, and click Open.


The Monkey.wav file appears in your Library panel. The sound file is indicated by a unique icon, and when it is selected the preview window shows a waveform—a series of peaks and valleys that represent the sound.




[image: Image] Note


If the Monkey.wav file is dimmed and unavailable to be selected, make sure that you choose All Files or WAV Sound from the Enable menu.
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	Click the Play button in the far upper-right corner of the Library preview window.


The sound plays.



	Double-click the sound icon to the left of your Monkey.wav file.
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The Sound Properties dialog box appears, providing information on your sound file, including its original location, size, and other technical properties. Click OK to close the dialog box.



	Choose File > Import > Import To Library and select the other sound files to import into your Animate project. Import Elephant.wav, Lion.wav, Africanbeat.mp3, and Afrolatinbeat.mp3. Click Open to import the files.




[image: Image] Note


In addition to MP3, AIFF, and WAV files, Animate supports ASND (Adobe Sound), SD2 (Sound Designer II), AU (Sun AU), FLAC, and OGG or OFF (Ogg Vorbis).





Your Library panel should contain all the sound files.



	Create a folder in your Library panel and place all the sound files in it to organize your Library panel. Name the folder sounds.
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[image: Image] Tip


Hold down the Shift key to select multiple files to import all at once.









Placing sounds on the timeline


You can place a sound at any keyframe along the timeline, and Animate will play that sound when the playhead reaches the keyframe. You’ll place a sound on the very first keyframe that plays at the start of the movie to provide a pleasant audio introduction and set the mood.




	Select the videos layer on the timeline.



	Insert a new layer and rename it sounds.
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	Select the first keyframe of the sounds layer.



	Drag the Afrolatinbeat.mp3 file from the sounds folder in your Library panel onto the Stage.


The waveform of your sound appears on the timeline.
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	Select the first keyframe of the sounds layer, if it’s not already selected.


In the Properties panel, in the Sound section, note that your sound file is now listed on the Name menu.
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	Choose Stream from the Sync menu.
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[image: Image] Note


The Stream Sync option is available only for ActionScript 3.0 document types.





The Sync options determine how the sound plays on the timeline. Use Stream sync for long passages of music or narration when you want to synchronize the sound with the timeline.



	Move the playhead back and forth on the timeline.


The sound plays as you scrub the timeline.



	Choose Control > Test.


The sound doesn’t play! Don’t worry; that’s what’s supposed to happen. Because the sound is set to Stream, it plays only when the playhead moves along the timeline, and only if there are sufficient frames to play. A stop action at frame 1 pauses the playhead to wait for the user to click a button, and thus stops the sound.



	Select the keyframe in the sounds layer of the timeline, and in the Properties panel, change the Sync option from Stream to Event.
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When the Event sync option is selected, the sound plays as soon as the playhead enters the keyframe that the sound is in. Choose Control > Test to hear the full sound play.








Understanding sound sync options


Sound sync refers to the way a sound is triggered and played. There are several options: Event, Start, Stop, and Stream. Stream ties the sound to the timeline so that you can easily synchronize animated elements to the sound. Event and Start are used to trigger a sound (usually a short sound) to a specific event, like a button click. Event and Start are similar except that the Start sync does not trigger the sound if it is already playing (so there are no overlapping sounds possible with Start sync). The Stop option is used to stop a sound, although you’ll use it rarely, if ever. If you want to stop a sound that is set to Stream sync, simply insert a blank keyframe.









Clipping the end of a sound


The sound clip you imported is a bit longer than you need. You’ll shorten the sound file by using the Edit Envelope dialog box. Then you’ll apply a fade so that the sound gradually decreases as it ends.




	Select the first keyframe of the sounds layer.



	In the Properties panel, in the Sound section, click the Edit Sound Envelope button, which is to the right of the Effect menu and bears an icon of a pencil on a speaker.
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The Edit Envelope dialog box appears, showing you the sound’s waveform.
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The upper and lower waveforms represent the left and right channels of the stereo sound, respectively. The thin black line running horizontally above each waveform shows the volume level for each channel, and together they make up the envelope of the sound. A timeline runs between the waveforms, the Effect menu in the upper-left corner offers preset effects, and buttons that enable view options occupy the lower-right corner.



	In the Edit Envelope dialog box, click the Seconds button, if it isn’t already selected.
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The timeline changes units to show seconds instead of frames. Click the Frames button to switch back. You can switch back and forth, depending on how you want to view your sound.



	Click Zoom Out until you can see the entire waveform.




[image: Image]



The waveform appears to end at around 240 frames, or about 10 seconds.




[image: Image] Note


Edits made in the Edit Envelope dialog box are nondestructive. That means that shortening an audio clip doesn’t discard any of the data; it just changes how much of the clip is played in a movie. If you change your mind later, you can always lengthen the clip again.






	Drag the right end of the time slider to the left to about frame 50.
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The sound shortens by being clipped from the end. The sound now plays for about 50 frames.



	Click OK to accept the changes you’ve made.


The Edit Envelope dialog box closes.



	Choose Control > Test.


The sound plays for only 50 frames (a little over two seconds) and then stops abruptly. Close the Test Movie preview window.








Audio splitting


If you want to pause a streaming audio on the timeline and then at a later point in time resume audio playback from the point it was stopped, you can use audio splitting. You don’t need to split your audio in this lesson, but here’s how to do it.


To split sound on the timeline, you must first choose Stream from the Sync menu for the sound. Select the frame at the point when you want to pause the audio; then right-click and choose Split Audio.


Your sound will be split into two streams, indicated by a new keyframe at the point at which you split the audio.


Insert a new keyframe on the frame just behind the keyframe where you split your audio.


Now, move the keyframe containing the second half of your audio, and a gap will be created between the split.


Your audio will play until it reaches the empty keyframe, where it will pause. When your playhead reaches the next keyframe with the split audio, the sound will resume.









Changing the volume of a sound


The sound will be more elegant if it slowly fades out instead of being abruptly cut off. You can change the volume levels through time in the Edit Envelope dialog box. Use it to fade the sound in or out, or to modulate the volume of the left and right channels separately.




	Select the first keyframe of the sounds layer.



	In the Properties panel, click the Edit Sound Envelope button.


The Edit Envelope dialog box appears.



	Select the Seconds viewing option, and zoom in on the waveform to see its end, near 2.1 seconds.
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	Click the left channel level above the 1.0 second mark.
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A box appears on the line, indicating that a keyframe has been added for the sound volume. A corresponding keyframe is also added to the right channel.



	Click the left channel level at about the 2.0 second mark (at the very end), and drag it down to the bottom of the channel.
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The downward diagonal line indicates the drop in volume level from 100% to 0%.



	Click the corresponding keyframe on the right channel level and drag it down to the bottom of the channel.
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	Click the Play button to hear the edited sound.


The African flourish plays for about one second and then slowly fades away.



	Click OK to close the dialog box and accept the changes.










Deleting or changing the sound file


If you don’t want the sound on your timeline, or you want to change to a different sound, you can make those changes in the Properties panel.




	Select the first keyframe of the sounds layer.



	If you want to delete the sound in the timeline, in the Sound section of the Properties panel, choose None from the Name menu. However, don’t choose None for this part of the lesson, because you’ll want to keep it.
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To change the sound to a different sound, choose a new sound file from the menu. For these steps, choose Africanbeat.mp3.
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The Africanbeat.mp3 sound is swapped for the Afrolatinbeat.mp3 sound. The settings in the Edit Envelope dialog box that clip the sound and fade it out are applied to the new sound.


If you want a fresh instance of the sound (without any custom clipping or volume adjustments), choose the None option in the Effect menu. Don’t do this for your actual project, however.
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Adding sounds to buttons


In the kiosk, the buttons that control animal sounds appear on your Stage on the left. You’ll add sounds to the buttons so that they play whenever the user clicks them.




	In the Library panel, double-click the icon of the button symbol called sound_button1.


You enter symbol-editing mode for that button symbol.
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The three layers in the button symbol help organize the content for the Up, Over, Down, and Hit states.



	Insert a new layer and rename it sounds.
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	Select the Down frame in your sounds layer and insert a keyframe.
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	Drag the Monkey.wav file from the sounds folder in your Library panel to the Stage.


A waveform for the Monkey.wav file appears in the Down keyframe of the sounds layer.
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	Select the Down keyframe in the sounds layer.



	In the Properties panel, in the Sound section, choose Start from the Sync menu.
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When Sync is set to Start for a keyframe, the sound is triggered whenever the playhead enters that particular keyframe.



	Choose Control > Test. Test the first button to hear the monkey, and then close the preview window.
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[image: Image] Note


You can also add sound to the Over state of a button symbol by choosing Event or Start from the Sync menu, and the sound will play whenever the pointer hovers over the button.






	Repeat steps 1–7 for sound_button2 and sound_button3, but this time add the Lion.wav and Elephant.wav sounds, respectively, to their Down states. Click Scene 1 in the Edit bar to exit symbol-editing mode.












Understanding video


Animate makes it easy to deliver video. Combining video, interactivity, and animation can create a rich and immersive multimedia experience for your viewers.
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Video playback is not supported in WebGL-glTF, VR 360, or VR Panorama documents.





Deploying video varies depending on whether you’re working in an ActionScript 3.0, AIR for Desktop, AIR for Android, AIR for iOS, or HTML5 Canvas document.




Video with ActionScript 3.0 or AIR documents


If you’re working in an ActionScript 3.0 or AIR document, as you are in this lesson, you have three options for displaying video. The first option is to use the FLVPlayback component to play the video. A component in Animate is a reusable, packaged module that adds a particular capability to an Animate document. The FLVPlayback component is a special widget that is used on the Stage to play your external video.


Using the FLVPlayback component allows you to keep the video separate from your Animate file.


The second option is to just use ActionScript code to set up a Video object and play an external video file. This takes more advanced programming and won’t be covered in this lesson.


If you have a short video clip, you can use the third option, which is to embed the video directly inside your Animate file. This option is rarely used and is not recommended (and you will not use it in this lesson).




Avoid it: Embedding video in an ActionScript 3.0 or AIR document


While embedding a video directly inside an ActionScript 3.0 or AIR document is possible, in reality it is not practical. The feature is a remnant from previous versions of the Animate application, and it requires that your video be formatted as an FLV (Flash Video) file, which Adobe Media Encoder no longer supports. Moreover, embedding video is limited to only short stretches of video and can create large final file sizes that are unwieldy to download and manage.









Video with HTML5 Canvas documents


If you want to display video in an HTML5 Canvas document, you use the Video component provided in Animate (Window > Components). The Video component, like the FLVPlayback component for ActionScript 3.0 documents, provides an easy interface with which to point to the correct external video file and change playback parameters.






Video encoding


Whichever component you’re using to display video, Animate requires that the video be encoded correctly first. To use a playback component from Animate to play your video, the video must be encoded in the H.264 standard, a video codec that delivers high quality with efficient compression. A codec (compression-decompression) is a method computers use to compress a video file to save space and then to decompress it to play it back. The H.264 codec is used in MP4 video files (which are very common), so MP4 videos can be used across ActionScript 3.0, AIR, and HTML5 Canvas documents. The following table summarizes the relationships between video format, component, document type, and Playback target:








	Video format


	Component


	Document type


	Playback target











	H.264-encoded .MP4


	FLVPlayback


	ActionScript 3.0


	Flash Player







	H.264-encoded .MP4


	FLVPlayback


	AIR for Desktop, iOS, or Android


	desktop or mobile application







	H.264-encoded .MP4


	Video


	HTML5 Canvas


	browser
















Using Adobe Media Encoder CC


You can convert your video files to the proper video format using Adobe Media Encoder, a standalone application that is installed with Animate. Adobe Media Encoder can convert single files or multiple files (known as batch processing) to make your workflow easier.




[image: Image] Note


If Adobe Media Encoder is not available on your machine for some reason, use the Adobe Creative Cloud desktop application to download and install it.







Adding a video file to Adobe Media Encoder


The first step in converting your video file to a compatible Animate format is to add the video to Adobe Media Encoder for encoding.




	Launch Adobe Media Encoder.


The opening screen displays the Queue panel in the upper right, which shows any current video files that have been added for processing. The Queue panel should be empty. The other panels are the Encoding panel, which shows any video currently being processed; Media Browser, which lets you navigate your computer to find video files; and the Preset Browser, which provides commonly used predefined settings.
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	Choose File > Add Source, or click the Add Source button (with the plus sign icon) in the Queue panel.
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[image: Image] Note


By default, Adobe Media Encoder does not start processing the queue automatically when the program is idle. You can change this setting by choosing Media Encoder > Preferences (macOS) or Edit > Preferences (Windows) and selecting the Start Queue Automatically When Idle option.







[image: Image] Tip


You can also drag the file directly to the Queue panel from your desktop.





A file navigation dialog box opens that allows you to select a video file.



	Navigate to the Lesson10/10Start folder, select the Penguins.mov file, and click Open.




[image: Image]



The Penguins.mov file is added to the queue of files for processing and is ready for conversion to your choice of video format.










Converting video files for Animate


Converting your video files is easy, and how much time it takes depends on how large your original video file is and on your computer’s processing speed.




	In the first column under Format, stick with the selected default, H.264.


H.264 is a widely accepted codec for web videos and works with the video components in Animate.



	Click the down arrow in the Preset column to open the Preset menu.
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The video presets determine the dimensions of the video and the quality of the video based on specific playback platforms and devices. Select Match Source - High Bitrate.



	Click the name of the preset you just chose.
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The Export Settings dialog box appears, with advanced settings for cropping, resizing, clipping, and many other video and audio options. You’ll resize the penguin video so that it fits comfortably on the Stage of your zoo kiosk project.



	Click the Video tab. Deselect Match This Property To The Source Video to allow the video to be resized, and enter 432 for the width. Click outside the field to accept the change.
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Because the Constrain Proportions option is selected (the chain link icon), Animate modifies the Height to 320 to keep the proportions of your video consistent.



	Click OK.


Animate closes the Export Settings dialog box and saves your advanced video and audio settings.



	To choose a different location or a different filename for your encoded video, click the link under the Output File column.
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	Click the Start Queue button (the green triangular icon) in the upper-right corner.
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Adobe Media Encoder begins the encoding process. The Encoding panel shows the progress of the operation (along with a preview of the video) and the encoding settings.




[image: Image]





[image: Image] Note


You can change the status of an individual file in the Queue panel by selecting the file and choosing Edit > Reset Status or Edit > Skip Selection. Reset Status removes the Done label from a completed file so that it can be encoded again, whereas Skip Selection makes Animate skip that particular file when you have multiple files in the queue.





When the encoding process finishes, “Done” appears in the Status column of the Queue panel.


You now have the Penguins.mp4 file in your Lesson10/10Start folder along with the original Penguins.mov file.












Understanding encoding options


You can customize many settings when converting your original video. You’ve already seen how you can change the size of the original video when you converted the penguin movie. You can also crop your video to specific dimensions, convert only a snippet of the video, adjust the type of compression and the compression levels, and even apply filters to the video. To display the encoding options available, select the Penguins.mov file in the Queue panel, and then choose Edit > Reset Status. Click the entry in the Format column or the Preset column. The Export Settings dialog box appears. Click the Source tab in the upper-left corner.
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Adjusting video length


Your video may have unwanted segments at the beginning or the end. You can shave off footage by placing In and Out points where you want your video to begin and end.




	Drag the playhead (the top blue marker) to scrub through your video to preview the footage. Place the playhead at the point where you want your video to start playing.
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The current-time indicator at the left end of the timeline shows the position of the playhead in hours, minutes, seconds, and frames.



	Click the Set In Point button to place the In point at the current position of the playhead.
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	Drag the playhead to the point where you want your video to stop.



	Click the Set Out Point button to place the Out point at the current position of the playhead.
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You can also drag the In and Out point markers to bracket the desired video segment.





The highlighted portion of your video between the In and Out point markers will be the only segment of your original video that will be encoded.




[image: Image] Tip


You can use the Left Arrow or Right Arrow key on your keyboard to move back or ahead, respectively, frame by frame for finer control.






	Drag the In and Out points back to their original positions, or choose Entire Clip from the Source Range menu, because you do not need to adjust the video length for this lesson.
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Setting advanced video and audio options


The right side of the Export Settings dialog box contains information about the original video and summarizes the export settings.
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You can choose one of the options from the top Preset menu. At the bottom, you can navigate to advanced video and audio encoding options using the tabs. At the very bottom, Animate displays the estimated output size.






Saving advanced video and audio options


If you want to apply the same settings to many videos, it makes sense to save your advanced video and audio options. You can do that in Adobe Media Encoder. Once you have saved your settings, you can easily apply them to other videos in the queue.




	In the Export Settings dialog box, click the Save Preset button.
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	In the dialog box that opens, provide a descriptive name for the video and audio options. Click OK.
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	In the Export Settings dialog box, click OK to return to the queue of videos. You can apply your custom settings to additional videos by choosing an item from the Preset menu or from the Preset Browser panel.
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	4 Press Command+Q/Ctrl+Q to quit Adobe Media Encoder.












Playback of external video in your project


Now that you have successfully converted your video to the correct compatible format, you can use it in your zoo kiosk project. You will have your project play each of the animal videos at the different labeled keyframes on the timeline.


Your videos are independent of your Animate project. Keeping videos external ensures that you can edit them separately and that the videos maintain different frame rates from your Animate project.




	Return to your 10_workingcopy.fla project in Animate.



	Select the keyframe labeled penguins in the videos layer.
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	Choose File > Import > Import Video.


The Import Video wizard appears. This wizard guides you step by step through the process of adding video to Animate.
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In the Import Video wizard, choose Embed H.264 Video In Timeline to embed an H.264-encoded video to use as a guide for hand-drawn animation. Animators often use live-action video to guide their frame-by-frame drawings in a technique known as rotoscoping. The video appears on your timeline but is not exported.






	In the Import Video wizard, select On Your Computer > Load External Video With Playback Component, and click the Browse button next to the File Path field.
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	In the Open dialog box, select Penguins.mp4 from the Lesson10/10Start folder and click Open.


The path to the video file is displayed under the Browse button. Since Penguins.mp4 and your 10_workingcopy.fla are both in the 10Start folder, the path from the FLA document to the video is simply the filename.



	Click Next or Continue.



	In the next screen, you choose the skin, or the style of the interface controls, for the video. From near the top of the Skin menu, choose MinimaFlatCustomColorPlayBackSeekCounterVolMute.swf, if it’s not already chosen.
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The skin is a small SWF file that determines the functionality and appearance of the video’s controls. You can use one of the skins provided with Animate, or you can choose None from the top of the menu.





The skins fall into three broad categories. The skins whose names begin with “Minima” are the latest designs and include options with a numeric counter. The skins that begin with “SkinUnder” use controls that appear below the video. The skins that begin with “SkinOver” include controls that overlap the bottom edge of the video. A preview of the skin and its controls appears in the preview window.



	Click the Color box, select #333333, and enter 75 in the Alpha:% field. Click Next or Continue.




[image: Image]




	On the next screen of the Import Video wizard, review the information for the video file, and then click Finish to place the video.



	Your video with the selected skin appears on the Stage. Select the Selection tool and place the video on the left side of the Stage. In the Properties panel, set X=65 and Y=160.
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The keyframe labeled penguins in the videos layer shows a filled circle followed by a lighter gray span of frames, indicating that it contains content.


An FLVPlayback component also appears in your Library panel.



	Choose Control > Test. After the short musical introduction, click the Magellanic Penguins button.
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The FLVPlayback component plays the external penguin video with the skin you chose in the Import Video wizard. If your video does not play, check to make sure your MP4 video file is in the same folder as your FLA file. In the Component Parameters panel (Window > Component Parameters), the Source item indicates the path from the FLA document to the video file.


Close the preview window.



	The other animal videos have already been encoded in the H.264 format and provided in the 10Start folder. Import the Mandrill.mp4, Tiger.mp4, and Lion.mp4 videos in each of their corresponding keyframes and position them on the Stage in the same location as the Penguins.mp4 movie. Choose the same skin as the Penguin.mp4 video.








Controlling the video playback


A video component lets you control which video plays, whether the video plays automatically, and other aspects of playback. The options for playback can be accessed in the Component Parameters panel. Select the FLVPlayback component on the Stage and select Show Parameters in the Properties panel, or choose Window > Component Parameters.
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[image: Image] Note


The video files, the 10_workingcopy.swf file, and the skin file are all required for your zoo kiosk project to work. The skin file is published in the same folder as your SWF file.





Individual properties are listed in the left column, and their corresponding values are listed in the right column. Select one of the videos on the Stage, and then choose from among the following options:
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You can’t preview your video on the Stage in Animate. You must test your movie (Control > Test) to see your video play within the video component.







[image: Image] Note


Although the component that plays video in an ActionScript 3.0 document is called FLVPlayback, it can play H.264-encoded video (MP4) as well as FLV video.







	autoPlay: When selected, the video plays automatically. When deselected, the video is paused on the first frame.



	skin: This displays the name of your current skin file. Click the name to open the Select Skin dialog box and make another choice from the Skin menu.



	skinAutoHide: Select this option to hide the controller and display it only when users move their pointer over the video.



	skinBackgroundAlpha: To change the transparency of the skin, enter a decimal value from 0 (totally transparent) to 1 (totally opaque).



	skinBackgroundColor: To change the color of the skin, click the color chip and select a new color.



	source: This displays the name and location of the video file that Animate seeks to play. To change either of those, click the file information.


In the Content Path dialog box that appears, enter a new filename or click the Folder icon to choose a new file to play. The path is relative to the location of your Animate file.








Using the HTML5 Canvas Video component


To display video in an HTML5 Canvas document, use the Video component, which is very similar to the FLVPlayback component that you learned about in this lesson.


You must add the Video component to the Stage from the Components panel yourself. In contrast to ActionScript 3.0 or AIR documents, there is no Import wizard to take you through the steps to add video. But the process is straightforward.


To add video in an HTML5 Canvas document, open the Components panel (Window > Components) and expand the Video category.
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Drag the Video component from the Components panel to the Stage. In the Properties panel, choose Show Parameters or choose Window > Component Parameters to display the Video component properties for video playback.




[image: ]



Click the Edit button (pencil icon) next to the source in the Component Parameters section of the Properties panel.
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The Content Path dialog box opens. Enter the path to the H.264-encoded video file (.mp4), or select the folder icon to navigate to the video file on your computer. Animate will retrieve the correct dimensions of your video. Use the playback and UI options in the Properties panel to change how the video plays from a browser.











Adding a video without playback controls


For the various animal videos, you show the playback controls so that the reader can pause, rewind, and play the video again to hear the information about each animal. But sometimes you want to display a video file that doesn’t include controls for a more seamless, integrated experience. For this project, the zoo director will automatically pop up at the beginning to give an introduction. The video will still play within the FLVPlayback component, but the controls will be hidden.


You’ll import the video file, which is already encoded properly into H.264 format.




Importing the video clip


Now you’ll use the Import Video wizard to import the Popup.mp4 file.




	Select frame 1 in the videos layer.



	Choose File > Import > Import Video.



	In the Import Video wizard, select On Your Computer > Load External Video With Playback Component, and click Browse. Select the Popup.mp4 file in the Lesson10/10Start folder and click Open.



	Click Next or Continue.



	Choose None for the skin. Click Next or Continue.
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No skin means that there are no playback controls for the video. However, the video still uses the Video component to play.



	Click Finish to place the video.
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[image: Image] Note


As of this writing, a bug in Animate causes the size information of new instances of a video component to be unrecognized when navigating between different keyframes. Hence, the animal videos may appear smaller because of the initial video, popup.mp4. A workaround is to insert a blank keyframe between video component instances on the video layer, as seen in 10End.fla.





The video of the zoo director with a black background appears on the Stage. Move the video so that its bottom edge lines up with the top edge of the red bar above the sound buttons. Set X=45 in the Properties panel.



	Choose Control > Test.


After the musical introduction, the zoo director appears and gives a brief talk. If your video does not play, make sure that the path from your FLA document to your video file matches the path of the source property in the Component Parameters panel.
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[image: Image] Note


If you don’t stop one video before navigating to another keyframe containing a second video, the audio can overlap. One way to prevent overlapping sounds is to use the command SoundMixer .stopAll() to stop all sounds before starting a new video. The ActionScript code in the first keyframe of the actions layer in your 10_workingcopy.fla file contains the correct code to stop all sounds before navigating to a new animal video.





Congratulations, your project is done! In the last lesson, you’ll learn how to publish your projects for delivery to your audience, whether that is a video file, a website, or a standalone application like this zoo kiosk project.








Review questions


1 How can you edit the length of a sound clip?


2 What is a skin for a video?


3 What is the correct video format to use in an HTML5 Canvas document?


4 What’s the difference between the FLVPlayback component and the Video component?


5 How do you customize the look and feel of the playback controls for video?


Review answers


1 To edit the length of a sound clip, select the keyframe that contains it and click the Edit Sound Envelope button in the Properties panel. Then move the time slider in the Edit Envelope dialog box to clip the sound from the front or from the end.


2 A skin is the combination of functionality and appearance of video controls, such as Play, Fast Forward, and Pause buttons. You can choose from a wide array of combinations with the buttons in different positions, and you can customize the skin with a different color or level of transparency. If you don’t want viewers to be able to control the video, select None from the Skin menu.


3 To play video with the Animate video playback component, video files must be encoded in the H.264 format. Adobe Media Encoder, a separate application, allows you to import many kinds of media types, and trim, crop, and export to an H.264-encoded MP4 video file.


4 The FLVPlayback component is required to play external H.264-encoded videos from an ActionScript 3.0 or AIR document. The Video component is required to play external H.264-encoded videos from an HTML5 Canvas document. You can add either component to the Stage from the Components panel, or you can use the Import Video wizard for ActionScript 3.0 or AIR documents.


5 To change the kind of controls available or the design of the video playback interface, choose a different skin from the Component Parameters panel.
















  

11 PUBLISHING




Lesson overview


In this lesson, you’ll learn how to do the following:




	Understand runtime environments.



	Understand the output files for different Animate document types.



	Modify the publish settings.



	Convert one Animate document type to a different document type.



	Publish an AIR application for the desktop.



	Publish an HTML5 Canvas document.



	Publish a projector for macOS and Windows.



	Test mobile interactions in the AIR Debug Launcher.



	Understand publishing for iOS and Android.
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This lesson will take about one and a half hours to complete.


To get the lesson files used in this chapter, download them from the web page for this book at www.adobepress.com/AnimateCIB2020. For more information, see “Accessing the lesson files and Web Edition” in the Getting Started section at the beginning of this book.
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Use the various document types in Adobe Animate to create content that targets a variety of platforms and uses, including HTML5 multimedia for the web browser, desktop applications, high-definition video, and mobile device apps. Put your content everywhere while leveraging Animate’s powerful and familiar animation and drawing tools.






Understanding publishing


Publishing is the process that creates the file or files that are required to play your final Adobe Animate project for your viewers. Keep in mind that Animate is the authoring application, which is a different environment from that on which your viewers experience your movie. In Animate, you author content, which means you’re creating art and animation and adding text, videos, sound, buttons, and code. In the target environment, such as a desktop browser or a mobile device, your viewers watch the content when it plays back, or runs. So developers make a distinction between “author-time” and “runtime” environments.




[image: Image] Note


If you have not already downloaded the project files for this lesson to your computer from your Account page, make sure to do so now. See “Getting Started” at the beginning of the book.





Animate can publish content to various runtime environments, and your desired runtime environment determines the Animate document that you choose when you begin a project.


Sometimes a single document type can publish content for multiple runtime environments. For example, an ActionScript 3.0 document can export a high-definition video, a projector that plays from a desktop, or animated GIFs for social media.




Document types


You learned about the various Animate document types in Lesson 1, and you’ve worked with a few of them throughout the projects in this book. For example, you started an HTML5 Canvas document for Lesson 2, an ActionScript 3.0 document for Lesson 6, and an AIR for Desktop document for Lesson 10. Each project publishes a different set of files for their targeted runtime environment, but each project is saved as an FLA (Animate Document) or XFL (Uncompressed Animate Document) file that you edit in Animate.


In this lesson, you’ll explore various publishing options for the document types in greater detail.






Runtime environments


If an ActionScript 3.0 document is published to SWF and is played back with Flash Player in a desktop web browser, then Flash Player is the runtime environment for that ActionScript 3.0 document. Flash Player 31 is the latest version and supports all the new features in Animate. Flash Player is available as a free plug-in from the Adobe website for all the major browsers and platforms.
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The ActionScript 3.0 document also supports publishing content as a projector for either macOS or Windows. A projector plays as a stand-alone application on the desktop, without needing a browser.





By the end of 2020, however, Adobe will no longer support Flash Player for web browsers. Increasingly, major browsers automatically block Flash Player, and readers must enable the plug-in manually. For these reasons, it’s best to use ActionScript 3.0 documents to create animation assets for export (as video, spritesheets, or PNG sequences) or for projectors (covered in this lesson).


If you want to target web browsers without requiring Flash Player, then begin your Animate project with an HTML5 Canvas, VR 360, VR Panorama, or WebGL glTF document. To integrate interactivity into an HTML5 Canvas, VR 360, VR Panorama, or WebGL glTF document, you use JavaScript rather than ActionScript. You can add JavaScript directly in the Actions panel or by using the Actions code wizard in the Actions panel.
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When you change the settings in the Publish Settings dialog box, Animate saves them with the document.





AIR is another runtime environment, which has recently been moved from Adobe to HARMAN, a subsidiary of Samsung Electronics, who will continue to support and develop the platform. AIR (Adobe Integrated Runtime) runs content directly from your desktop, without the need for a browser. When you publish your content for AIR, you can make it available as an installer that creates a stand-alone application, or you can build the application with the runtime already installed, known as “captive runtime.”
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Not all features are supported across all document types. For example, WebGL glTF documents don’t support the Camera tool, and HTML5 Canvas documents don’t support the 3D Rotation and Translation tools. Unsupported tools are grayed out.





You can also publish AIR applications as mobile apps that can be installed and run on Android devices and on iOS devices such as the Apple iPhone or iPad, whose browsers do not support Flash Player. Be sure to check the HARMAN site for the AIR runtime at airsdk.harman.com/download, as they maintain separate terms of use, licensing, and pricing agreements for AIR developers.








Converting to HTML5 Canvas


You may have many older animations that you created as an ActionScript 3.0 document that a client wants to use as HTML5 animations. Don’t worry; you don’t have to redo all your work. Fortunately, Animate includes options for converting ActionScript 3.0 documents into HTML5 Canvas documents so your animations can reach the widest audience.
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Remember that an ActionScript 3.0 document doesn’t necessarily contain ActionScript 3.0. An ActionScript 3.0 document is simply an Animate document that publishes for Flash Player in a browser by default. An ActionScript 3.0 document can consist of animation only.





There are two approaches to creating an HTML5 Canvas document with Animate assets. First, you can simply create a new HTML5 Canvas document and copy and paste the layers from one file to your new file. Second, you can open your ActionScript 3.0 document and choose File > Convert To > HTML5 Canvas. Animate makes the conversion, and you can save your new file as an HTML5 Canvas document.




Converting an ActionScript 3.0 document to an HTML5 Canvas document


You’ll convert an animation that you built as an ActionScript 3.0 document in a previous lesson to an HTML5 Canvas document.




	Open the 11Start_convert.fla file in the 11Start folder.
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The project is the completed animated promotional piece for the fictional movie Double Identity from a previous lesson. The ActionScript 3.0 document contains bitmaps and motion tweens with changes in position, scale, color effects, 3D effects, and filters.


The file targets Flash Player. The frame rate is set at 30 frames per second, with a black Stage fixed at a generous 1280 pixels in width and 787 pixels in height.



	Choose File > Convert To > HTML5 Canvas.


Animate asks you where you want to save the new converted file.



	Click Save to save the file in the 11Start folder.


Animate duplicates your content into a new HTML5 Canvas document and saves a new file. The new HTML5 Canvas document contains your converted content.



	View the warnings in the Output panel.




[image: Image]



The Output panel displays the following warning:


* 3D cannot be imported in HTML5 Canvas document.


The HTML5 Canvas document does not support either the 3D Rotation tool or the 3D Translation tool, so the tween does not display. Keep an eye out for the messages in the Output panel to make sure you understand how Animate handles the transition of your content from Flash Player to HTML5 and so that you know what features cannot be ported over. Often, you’ll have to do additional edits to your animation after each conversion.



	Choose Control > Test to test the converted content.
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Animate exports HTML5 and JavaScript and displays the animation in a browser. The converted animation plays, showing all the motion tweens, including the nested animations of the idling cars. The 3D animation of the title, which is unsupported, appears at the end without any animated effects. In addition, the Blur filter does not animate, which is another limitation of the HTML5 Canvas document.


The Output panel displays additional warnings regarding features included in the animation.












Publishing for HTML5


HTML5, along with CSS3 and JavaScript, is the modern standard for creating content for the web on the desktop, mobile phones, and tablets. Choosing the HTML5 Canvas document type in Animate targets HTML5 as the published runtime and outputs a collection of HTML5 and JavaScript files.




What is HTML5 Canvas?


Canvas refers to the canvas element, a tag in HTML5 that allows JavaScript to render and animate 2D graphics. Animate relies on the CreateJS JavaScript libraries to generate the graphics and animations inside the canvas element of the HTML5 project.






What is CreateJS?


CreateJS is a suite of JavaScript libraries that enable rich, interactive content with HTML5. CreateJS itself is a collection of several separate JavaScript libraries: EaselJS, TweenJS, SoundJS, and PreloadJS.




	EaselJS is a library that provides a display list that allows you to work with objects on the canvas in the browser.



	TweenJS is a library that provides the animation features.



	SoundJS is a library that provides functionality for playing audio in the browser.



	PreloadJS is a library that manages and coordinates the loading of content.






With CreateJS, Animate generates all the necessary JavaScript code to represent your images, graphics, symbols, animations, and sounds on the Stage. Animate also outputs dependent assets, such as images and sounds. You can easily configure how those image and sound assets are organized in the publish settings.


You can also include your own JavaScript commands directly in the Actions panel to control your animation. Those JavaScript commands get exported in the JavaScript files.


Learn more about the CreateJS JavaScript libraries at www.createjs.com.






Exporting to HTML5


The process to export your animation to HTML5 and JavaScript is straightforward.




	In the file that you just converted, 11Start_convert_HTML5 Canvas.fla, choose File > Publish.


Animate exports the animation as HTML and JavaScript files and saves them in the same folder as your FLA file (according to the default Publish Settings options).



	Double-click the HTML file, named 11Start_convert_HTML5 Canvas.html.


Your default browser opens and plays the animation. Because of security restrictions, you may not be able to play the content in your browser from your local file system. If that happens, upload the HTML file and the dependent assets (see the next section) to a web server.










Understanding the exported files


This animated sequence uses bitmap images. Images imported into the Animate library must be exported so that they are accessible to the HTML and JavaScript documents.




	Examine the folder on your desktop where you saved your Animate file, 11Start_convert_HTML5 Canvas.fla.
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Animate creates an HTML file, as well as a JavaScript file that contains the code that animates all the image assets. In addition, Animate has created a folder named images.



	Inside the images folder are all the bitmap assets for the animation saved as a single PNG image. The JavaScript code in your exported documents dynamically loads just the images that it needs to display from the single PNG image, called a spritesheet.
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To share your HTML5 animation over the web, you need to upload the HTML file, the JavaScript file, and the images folder to your server. Point your readers to the HTML5 document to have them see your animation. You can rename the HTML5 document, but do not rename the JavaScript file, the images folder, or the spritesheet inside the folder. The HTML5 document references those files, and if you rename them, they can’t be found, and your animation won’t work.








Supported features


The HTML5 Canvas document does not support all Animate features. Fortunately, the Output panel displays warnings about any features in your Animate file that can’t be successfully exported.


Animate also disables any features that won’t export successfully to HTML5 and JavaScript. For example, the 3D Rotation and 3D Translation tools in the Tools panel are grayed out to indicate that 3D rotations and translations are not supported in an HTML5 Canvas document. Many of the blending modes and some Filter effects are not supported either.









Publish Settings


The Publish Settings dialog box lets you change where your files are saved and how they are saved.




	Click More Settings in the Publish Settings section of the Properties panel, or choose File > Publish Settings to open the Publish Settings dialog box.
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	On the Basic tab, do one or more of the following:




	Deselect Loop Timeline if you want the timeline to play only once.



	Click the folder icon next to the Output Name field to save your published files to a different folder or under a different filename.



	Change the paths next to the Export Assets options if you want to save your assets to a different folder. The Export Image Assets checkbox must be selected if your file contains images, and Export Sound Assets must be selected if your file contains sounds.



	Select Center Stage to center-align your Animate project in the browser window. You can use the menu next to the option to choose to center your movie Horizontally, Vertically, or Both.



	Select Make Responsive to have your Animate project respond to changes in the browser window dimensions, and use the menu next to the option to choose whether the project responds to changes in window height, window width, or both. The Scale To Fill Visible Area option determines how your project fills the available space in the browser window.



	 Select Include Preloader. This option includes a standard small looping animation that plays to let users know that files are being downloaded before the animation can begin.







	Select the HTML/JS tab.
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Click Include JavaScript In HTML if you want to publish a single file that includes all the necessary JavaScript and HTML code for your file. If you choose this option, Animate will overwrite the exported file each time you publish.


Deselect the Overwrite HTML File On Publish checkbox if you want to preserve the HTML file and simply change the published JavaScript code that drives your animations.


The Hosted Libraries option tells your published file where to find the CreateJS JavaScript libraries. When the option is selected, your published file points to a content distribution network (CDN) at http://code.createjs.com to download the libraries. You must have an Internet connection for your animation to work when this option is selected. When the Hosted Libraries option is unselected, Animate includes the CreateJS JavaScript libraries as separate documents that must accompany your project files.


Leave all the other Advanced JavaScript options at their default settings.



	Select the Image Settings tab.
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You can publish a transparent Stage from an HTML5 Canvas document. In the Properties panel, in the Properties area, choose the selection with a diagonal red line, indicating “no color” for the Stage.
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If you select the Export Image Assets: Combine Images Into Spritesheet option on the Basic tab, the Export Image Assets: Combine Images Into Spritesheet option will also be selected in the Image Settings tab, and vice versa.





Select Export As Texture if you want to create a single image file called a texture atlas for all the bitmaps that you’ve imported into your library. An HTML5 web page can load a single image file and retrieve specific portions of the image more quickly than it can load multiple smaller images. For more information, see https://helpx.adobe.com/animate/using/create-sprite-sheet.html.


You can select Export As Spritesheet, which similarly combines bitmaps into a single image, of which portions are retrieved dynamically.


In general, a texture atlas is larger but more efficient than a spritesheet. For your texture atlas, you also have the option of increasing resolution for HiDPI displays and for selecting certain symbols to be included in the texture.


Select a Format option for the exported image, and set the quality, size, and background color for the image. If you choose a size that’s too small to fit the images in your library, Animate will publish multiple spritesheets as needed.



	Click OK to save all your settings. Close the file; you won’t be needing it again for this lesson.












Publishing a desktop application


You may want to distribute your project to run without a browser.


You can output your project as an AIR file, which installs an application on the user’s desktop. AIR is a robust runtime environment that supports a broader range of technologies.


Viewers can download the free AIR runtime from the Adobe website at http://get.adobe.com/air/. Alternatively, you can output an AIR project with the Captive Runtime option, which includes the AIR runtime so that your audience doesn’t need to download anything additional.




Creating an AIR application


AIR allows your viewers to see your Animate content on their desktop as an application. You’ll recall that in Lesson 10, the final project was a desktop application of an interactive zoo kiosk. In this section, you’ll specify the necessary publish settings to create a desktop application of a restaurant guide.




	Open 11Start_restaurantguide.fla.


This is the same interactive restaurant guide that you created in a previous lesson, with a few modifications to the background image.



	In the Properties panel, choose More Settings in the Publish Settings section. In the Publish Settings window that opens, note that AIR 32.0 For Desktop is chosen from the Target menu.



	Click the Edit Application Settings button (wrench icon) next to the Target menu.
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The AIR Settings dialog box appears.
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	Examine the settings on the General tab.


The Output File field shows the filename of the published AIR installer as 11Start_restaurantguide.air. The Output As options provide three ways to create an AIR application. The first choice, AIR Package, should be selected; here is a description of what each option does:




	AIR Package creates a platform-independent AIR installer.



	Mac Installer (macOS)/Windows Installer (Windows) creates a platform-specific AIR installer.



	Application With Runtime Embedded creates an application without an installer or the need for the AIR runtime to be installed on the end user’s desktop.







	In the Name (macOS) or App Name (Windows) field, enter Meridien Restaurant Guide.
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This will be the name of your published application.



	From the Window Style menu, choose Custom Chrome (Transparent).




[image: Image]



Custom Chrome (Transparent) creates an application that has no interface or frame elements (known as chrome) and that has a transparent background.



	Click the Signature tab at the top of the AIR Settings dialog box.
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Creating an AIR application requires a certificate so that users can identify and trust the developer of the Animate content. For this lesson, you won’t need an official certificate, so you can create your own self-signed certificate.



	Click the New (macOS) or Create (Windows) button next to Certificate.



	Enter your information in the empty fields. You can use Meridien Press for Publisher Name, Digital for Organization Unit, and Interactive for Organization Name. Enter your own password in both password fields, and then enter meridienpress.p12 in the Save As field. Click the Folder/Browse button to save it in the same folder in which your FLA file is saved. Click Save and then OK.
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Animate creates a self-signed certificate file (with the extension .p12) on your computer.




[image: Image]
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You can also open the AIR Settings dialog box from the Publish Settings dialog box. Click the Player Settings button (wrench icon) next to the Target menu.







[image: Image] Note


If you open an FLA file that was created on another computer, Animate may warn you that your computer doesn’t have the same fonts that were used to build the file. Click OK in the alert dialog box to accept the substitute fonts suggested by Animate.





Animate automatically fills out the path to your .p12 file in the Certificate field. Make sure that the Password field is filled (the password must match the one you used to create the certificate) and that the Remember Password For This Session and Timestamp options are selected.



	Now click the Icons tab at the top of the AIR Settings dialog box.
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	Select icon 128x128, and click the folder icon.



	Navigate to the AppIconsForPublish folder inside the 11Start folder, select the restaurantguide.png file provided for you, and click Open.


The image in the restaurantguide.png file will be the application icon on the desktop.
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	Click the Advanced tab at the top of the AIR Settings dialog box.



	Under Initial Window Settings, enter 0 for the X field and 50 for the Y field.
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When the application launches, it will appear flush to the left side of the screen and 50 pixels from the top.



	Click Publish and then click OK to exit the AIR Settings dialog box.
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Animate creates an AIR installer (.air).










Installing an AIR application


The AIR installer is platform independent, but it requires that the AIR runtime be installed on the user’s system.




	Double-click the AIR installer that you just created, 11Start_restaurantguide.air.


The AIR Application Installer opens and asks to install the application. Since you used a self-signed certificate to create the AIR installer, Adobe warns of a potential security risk due to an unknown and untrusted developer. (Since you can trust yourself, you’re safe to proceed!)
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	Click Install, and then click Continue to proceed with the installation at the default settings.


The application called Meridien Restaurant Guide is installed on your computer and automatically opens.
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Notice that the application is positioned at the far-left edge of your desktop, 50 pixels (between one-quarter and one-half inch, depending on the resolution of your display) down from the top edge, as you specified in the AIR Settings dialog box. Note, too, that the Stage is transparent, so your graphic elements float over the desktop, much like the appearance of other applications.



	Quit the application by pressing Command+Q (macOS) or Ctrl+Q (Windows).










Creating a projector


In some cases—for example, if you don’t want to deal with an app that requires installation and all the accompanying security issues—you may want to use a low-tech and simpler distribution method. A projector is a self-contained file that includes the Flash Player runtime so that your audience can simply double-click the projector icon to play and view your multimedia content.


You can publish either a macOS or Windows projector from an ActionScript 3.0 or AIR document. However, unlike when you’re creating an AIR application, with a projector you don’t have publishing options such as choosing thumbnails for the app icon, or specifying a transparent background or initial position when the app is launched.




	If it’s not open already, open 11Start_restaurantguide.fla.



	Choose File > Publish Settings.


The Publish Settings dialog box opens.



	Under Other Formats in the left column, select Mac Projector, Win Projector, or both. Windows projectors have the file extension .exe, and Mac projectors have the file extension .app.
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	Specify the filename and location where you want Animate to save the projector. Each projector (Mac and Windows) needs a unique filename, so highlight each option to enter it.



	Click Publish.


Animate creates the selected projector or projectors in the output location, with a filename that matches the Output Name field. Click OK.
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Any dependent assets, such as video files, must also be included with your projector so that it plays correctly. Animate does not embed those dependent files into the projector.






	Double-click the projector file.
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The restaurant guide opens as a separate application on your desktop. Compare your projector application with your AIR application. Close the FLA file, since you won’t need it again for this lesson.








Publishing WebGL animations


WebGL is a technology that uses JavaScript to render graphics—especially 3D graphics—in a web browser. WebGL uses hardware acceleration to render graphics, potentially streamlining the display of complex graphics. Use the Animate WebGL glTF Standard and Extended document types to create flat graphics and animation for export as WebGL assets. Use WebGL glTF Standard documents to publish standards-based glTF files. Use WebGL glTF Extended to publish Animate-specific files with greater support for animation and interactivity. Your output files consist of various JavaScript files (including JSON files, which are a specific kind of JavaScript file for storing data—JSON stands for JavaScript Object Notation) and image assets.


The Animate WebGL glTF document type is limited and still in Beta (it doesn’t support 3D transformations or masks), but keep an eye on WebGL as both the technology and the Animate document type develop.











Publishing to mobile devices


You can also publish Animate content to mobile devices running on iOS (such as the iPhone or iPad) or on Android. To publish Animate content to a mobile device, you target AIR for iOS or AIR for Android to create an application that viewers download and install on their devices.




Testing a mobile app


Creating an app for mobile devices is more complicated than creating an application for the desktop because you have to obtain specific certificates for development and distribution. For example, if you want to upload apps to the iTunes Store, Apple requires that you pay a yearly subscription to be a certified developer. Developing for an Android device requires a one-time fee. Moreover, you have to factor in the additional time and effort required for testing and debugging on a separate device. However, Animate provides several ways to facilitate testing content for mobile devices:




[image: Image] Note


The iOS Simulator is part of Apple’s Xcode developer toolset, which is available as a free download from Apple.
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Testing an app on an iOS device requires that you be part of Apple’s iOS Developer program, where you create development, distribution, and provisioning certificates. The certificates allow you to install apps on iOS devices for testing and upload apps to the iTunes store.







	You can use the mobile device simulator provided with Animate, the AIR Debug Launcher, to test mobile interactions. The SimController that accompanies the AIR Debug Launcher emulates interactions such as tilting the device (using the accelerometer), touch gestures such as swiping and pinching, and even geolocation functions.



	For iOS devices, Animate can publish an AIR app to test in the native iOS Simulator, which emulates the mobile app experience on your macOS desktop.



	Connect a mobile device to your computer with a USB cable and Animate can publish an AIR app directly to your mobile device.










Simulating a mobile app


You’ll use the Adobe SimController and AIR Debug Launcher to simulate mobile device interactions within Animate.
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On Windows, a security warning may appear when you use the AIR Debug Launcher. Click Allow Access to continue.







	1 Open 11Start_mobileapp.fla. Examine the four different keyframes in Layer 2.




[image: Image]



The project is a simple application that announces an imaginary sports challenge set in our familiar city of Meridien.


The project already contains ActionScript code that enables the viewer to swipe the Stage left or right to go to the next or previous frames, respectively.


Examine the code in the Actions panel. The code was added from the Code Snippets panel, which includes dozens of code snippets for interactivity on mobile devices.



	In the Properties panel, notice that the target is set for AIR 32.0 for Android.



	Choose Control > Test Movie > In AIR Debug Launcher (Mobile), which should already be selected.


The project publishes to a new window. In addition, the SimController application, which provides options for interacting with the Animate content, launches.
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	In the Simulator panel, click Touch And Gesture to expand that section.



	Select Touch Layer.


The simulator overlays a transparent gray box on the Animate content to simulate the touch surface of the mobile device.



	Select Gesture > Swipe.
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The simulator is now enabled to emulate a swipe interaction. The instructions at the bottom of the panel detail how you can create the interaction with just your mouse cursor.



	On the touch layer over your Animate content, drag to the left, and then let go of your mouse button.


The yellow dot represents the contact point on the touch layer of the mobile device.
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The project recognizes the swipe interaction, and the second keyframe appears.
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You can change the opacity of the touch layer by changing the Alpha value.






	Swipe left and right.


Animate advances ahead one frame or moves back one frame, respectively.



	Close the window.








[image: Image] Note


Don’t move the window that contains your Animate content (AIR Debug Launcher, or ADL) when you’ve enabled the touch layer. If you do, the touch layer won’t align with the ADL window, and you won’t be able to accurately test your mobile interactions.







Publishing AMPHTML Ad documents


What is an AMPHTML Ad document? AMP stands for “accelerated mobile pages.” It is a standard created by Google that facilitates web pages and ads to load and display much faster on mobile platforms. It is essentially a streamlined version of HTML. Readers will click and stay engaged on sites and ads that load faster, even if it’s only by fractions of a second.


To publish an AMP-compliant site with Animate, you must first download and install a plug-in from Adobe Exchange at exchange.adobe.com. Once the plug-in is installed, you can create a new AMPHTML Ad document from the Advanced tab of the New Document dialog box under Custom Platforms.


The process of creating your graphics and animation remains the same as with other documents, but the AMPHTML Ad document introduces some unique workflow tools, like an AMPHTML Ad preview panel to test your animation and an AMP validation step to make sure the exported files conform to Google’s AMP standard.


While the AMPHTML Ad document allows you to create and export visually stunning, media-rich AMP-compliant sites, not all Animate features are supported. For example, 3D transformation, advanced color effects and tinting, and nested time lines are not allowed. Check the documentation from helpx.adobe.com for the full list of unsupported features and current known issues and workarounds.











Next steps


Congratulations! You’ve made it through the last of 11 lessons. By now you’ve seen how Adobe Animate, in the right creative hands (yours!), has all the features you need to produce media-rich interactive projects and animations that publish to multiple platforms. You’ve completed these lessons—many of them from scratch—so you understand how the various tools, panels, and code work together for real-world applications.
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For more information about publishing Animate content to AIR for iOS or Android, visit the AIR Developer Center at www.adobe.com/devnet/air.html. Tutorials, tricks and tips, and sample files are available for download.





But there’s always more to learn. Continue practicing your Animate skills by creating your own animation or interactive site. Get inspired by watching animations on network TV, seeking out multimedia projects on the web, and exploring apps on mobile devices. Expand your Animate knowledge by exploring the Adobe Animate Help resources and other fine Adobe Press publications.




Review questions


1 What’s the difference between author-time and runtime?


2 What is CreateJS?


3 What kinds of files are generated when you publish an HTML5 Canvas document?


4 Where should you look for warnings about converting Animate files from one document type to another?


5 What are the various ways you can test an Animate file for a mobile device?


6 What is a code-signing certificate, and why do you need one for an AIR application?


Review answers


1 Author-time refers to the environment in which you build your Animate content, such as Animate. Runtime refers to the environment in which your Animate content plays back for your audience. The runtime for your content can be Flash Player in a desktop browser, an AIR application on the desktop or on a mobile device, the standard or extended WebGL runtimes, a modern browser using HTML5 and JavaScript, or a video playing on YouTube.


2 CreateJS is a suite of open source JavaScript libraries: EaselJS, TweenJS, SoundJS, and PreloadJS. The JavaScript is required to drive the animation and interactivity for your HTML5 Canvas project.


3 When you publish or test an HTML5 Canvas document, Animate exports all the necessary JavaScript code to represent your images, graphics, symbols, animations, and sounds on the Stage. It also exports an HTML file and dependent assets, such as images and sounds.


4 When you convert one kind of Animate document into another, warnings will appear in the Output panel to inform you about interactive or animation features that may not have converted properly.


5 You can test your Animate project for a mobile device by testing it in the Air Debug Launcher (Control > Test Movie > In AIR Debug Launcher [Mobile]). The accompanying SimController allows you to simulate various mobile interactions, such as pinches and swipes. You can also test your Animate project by publishing it directly to a connected USB device (Android or iOS). Lastly, you can test an iOS app in the native iOS Simulator (Control > Test Movie > On iOS Simulator).


6 A code-signing certificate is a certified document that acts as your digital signature. You purchase one from a certification authority. It provides a way for your audience to authenticate your identity so they can confidently download and install desktop AIR applications, or AIR apps for Android or iOS.
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constraining dragging motion, 180


deleting, 180


deleting or adding, 81


deselecting, 74


nudging, 180


property curves, 177–180


removing direction handles, 180


Animate. See Adobe Animate


animated buttons, 365–369. See also buttons


animated GIF, exporting, 320–322


animated infographic


project file, 172–173


starting, 170–171


animated logo


project file, 289


starting, 288


animated opener, starting, 120


animating


3D motion, 159–163


armatures with poses, 248


bounces, 192–194


color, 309–312


deformations, 228–235


distortions, 230–232


filters, 135–138


and making deformations, 228–234


mask and masked layers, 316–319


position, 122–126


shapes, 288–289


transformations, 138–142


transparency, 133–134


warped mesh, 230


z-depth, 276


animation. See also character animation; nested animations; onion skinning


adding to VR project, 394–397


changing duration, 126–128


document types, 12


frame-by-frame, 157–158


inserting into graphic symbol, 299–300


looping, 297–300


moving, 142–144


nesting, 150–154


overview, 121


playing at destination, 361–365


previewing, 126, 305–309


project file, 122


stopping, 363–365


ANP files, 18


.app file extension, 463


application bar, 15


apps, testing on iOS devices, 465


armature, creating with Bone tool, 246–250


art, converting and exporting, 113–116


Art brushes, editing and creating, 88–90


ASND (Adobe Sound) files, 411


Asset Warp tool, 228–230, 232


assets


accessing, 20


sharing, 115


assistance, getting, 4


AU (Sun AU) files, 411


audio. See also sounds


saving options, 431–432


splitting, 417


Stream option, 238


and video options, 431


autoPlay option, video, 437


Auto-Recovery feature, using, 49–50






B


backups, creating, 49–50


banner ad


adding border, 87–88


starting, 54


Basic workspace, 16


Beta, explained, 376


bitmap art, converting vector art to, 113–114


bitmap fills, changing, 70


Bitmap Properties dialog box, 35


bitmaps, swapping, 335–338


blend types, 292


blur filter, adding, 42, 112


body parts, connecting in Parenting View, 204–208


Bone tool, inverse kinematics, 246–250


border, adding around banner ad, 87–88


BounceIn ease, 195–197


bounces, animating, 192–194


bounding boxes, resizing, 142


brightness, setting, 44


broken tweens, 297. See also shape tweens


Brush library, 84–87


brushes, editing and creating, 88–90


button click, adding actions for, 352–356


button instances


adding, 357


naming, 341


placing, 338–340


button symbols, 102–103, 328–333


buttons. See also animated buttons; Home button; invisible buttons


adding sounds to, 421–423


duplicating, 334–335


swapping bitmaps, 335–338






C


camera


adding captions, 278–281


animating pan, 263–265


animating rotation, 266–267


animating zoom-in, 265–266


animating zoom-out, 261–263


Brightness values, 282


characteristics, 258–259


color effects, 282


Contrast values, 282


creating depth, 270–276


disabling, 259


easing, 269


enabling, 257–258


exporting movie, 283–284


finishing moves, 267–269


Hue values, 282


layers for fixed graphics, 277–281


Motion Editor, 269


motion paths, 269


ordering layers, 276


Pan And Zoom mode, 259–260


Saturation values, 282


setting frame, 259–260


tool, 257


z-depths, 270


zooming recommendation, 269


Canvas document type, 13


captions, adding, 278–281


CC Libraries


accessing assets, 20


sharing, 115–116


CDN (content distribution network), 454


chalk-style lettering, using, 85–87


character animation, layer parenting, 203–210. See also animation


Character section, Properties panel, 279


classic tweens. See also motion tweens; tween span


applying, 213–214, 231


arm wave, 214–217


camera, 269


easing, 233–235


keyframes, 211–213


motion guides, 223–228


versus motion tweens, 210–211


parent layer, 217–218


swapping instances, 219–223


code, pinning in Actions panel, 365


Code Snippets panel, 360. See also panels


color effects, camera, 282


Color panel. See also panels


hex values, 70


opening, 66, 311


Color Picker, 40


color pointer, 65, 68


colors


animating, 309–312


applying to Stage, 20


choosing, 70


hexadecimal numbers, 56


matching for objects, 99


red, green, blue, 56


symbol instances, 107


Command key. See keyboard shortcuts


content, modifying, 47–49


continuous playback, 298. See also playback


control points, moving, 61


Convert Anchor Point tool, 147. See also anchor points


Copy and Paste commands, 62–63


copying


layers, 32


and pasting curves, 182–185


corner points, adding to shapes, 64


Create magazine, 6


CreateJS, explained, 450


Ctrl key. See keyboard shortcuts


curves


copying and pasting, 182–185


creating, 78–81


editing, 80–81


Cut Frames option, 399. See also frames


cylinder, creating, 60






D


debugging process, 356


deformations, making and animating, 228–235


Delete Anchor Point tool, 81


deleting


anchor points, 81, 180


or changing sound files, 420–421


fills, 59


keyframes, 29


pins, 229


property curves, 181


shape hints, 305


depth, creating, 83–84


Depth panel, 270. See also panels


desktop applications, publishing, 455–464


destination keyframes, creating, 343–346. See also keyframes


dialogue, lip-syncing, 236–246


Disney, Walt, 270


distortions, animating, 230–232


dock, panels in, 36


document types, uncompressed, 14


documents. See also files


creating, 13–14


editing, 300


types, 12


doors and code, adding to VR project, 391–393


Down state, button symbols, 328, 421


drawing modes, 58


duplicating


buttons, 334–335


keyframes, 297–298


layers, 32


motion tweens, 184–185


symbols, 109


dynamic text, adding, 94–95






E


ease curves vs. property curves, 191


ease-in, adding, 188–191, 320


EaselJS library, 450


eases


adding, 197–198


animating bounces, 192–194


BounceIn, 195–197


next motion tween, 186–188


property curves, 197–198


removing, 191


easing. See also motion tweens


camera, 269


classic tweens, 233–235


explained, 121, 154–157


shape tweens, 320–322


Edit bar, 15


editing


and creating brushes, 88–90


curves, 80–81


documents, 300


frames, 142–144


layer parenting, 208–209


layer stacking, 209–210


path of motion, 147–148


property curves, 175–181


scenes, 382


shapes, 60–65


symbols, 108–111


text, 94–99


warped shapes, 232


width of lines, 73–74


educators, resources for, 6


errors, checking for, 356


.exe file extension, 463


Export As Bitmap command, 114


exported files, understanding, 451–452


exporting


animated GIF, 320–322


and converting art, 113–116


HTML and JavaScript, 400–401


to HTML5, 450–451


movies, 163–165


preferences, 18


external video, playback, 432–439. See also video






F


file types, 12


files. See also documents


opening, 10–11


saving, 14


fills and strokes, 55. See also gradient fills; variable-width strokes


colors, 64


modifying alpha value, 83–84


overview, 55


selecting, 59–60


filters


adding, 42, 44, 137


animating, 135–138


applying for special effects, 112–113


Blur, 112


options, 113


Quality menu, 112


saving presets, 113


showing and hiding, 137


Fit In Window, Zoom menu, 158


FLA document type, 12


FLAC files, 411


Flash Player, 424


Fluid Brush, using, 92–93


FLVPlayback component, 423–424, 435–436


folders


organizing library items into, 20–22


using with layers, 29–31


fonts, choosing for captions, 279. See also Adobe fonts


forums, 6


Frame Picker and lip-syncing, 236–245


frame rate


explained, 132


identifying in timeline, 22


frame-based vs. span-based selection, 130


frame-by-frame animation, 157–158


frames. See also Cut Frames option


adding, 128–129


editing, 142–144


identifying in timeline, 22


inserting, 26, 186


and keyframes, 28


selecting, 26


Free Transform tool, using, 61


Full HD option, 13






G


galleries, adding, 382–384


Gap Size menu, 64


GIF, exporting art as, 114, 320–322


global vs. local transformations, 159


gotoAndPlay() action, 363, 390


gotoAndStop() action, 355, 390


gradient fills, 309–312. See also fills and strokes; radial gradient


Gradient Transform tool, 68–69, 309–312, 317


gradient transitions, 65–68


graphic symbols. See also symbols


Frame Picker and lip-syncing, 236–245


head motion, 245–246


inserting animation into, 299–300


using, 104


graphics


adding, 39–41


adding to VR project, 394–397


Camera layer, 277–281


frame-by-frame animation, 159


grids, using with Stage, 18


grouping objects, 71


guides and rulers, using, 101–102






H


H.264 video formats, 284, 424


HARMAN and Adobe AIR, 409


head motion, adding, 245–246


Help and Support content, 4–5


hex values, entering in Color panel, 66–67, 70, 78, 83, 311, 316


History panel, accessing, 45–46. See also panels


Hit keyframe, invisible buttons, 334


Hit state, button symbols, 328, 421


Home button, creating, 357–360. See also buttons


Home screen, displaying, 13


Hosted Libraries option, 340


HTML and JavaScript, exporting, 400–401


HTML5 Canvas


converting to, 447–449


document type, 12


explained, 450


exporting to, 450–451


Publish Settings, 452–455


video component, 424, 438–439






I


images. See also graphics; photos


importing and resizing, 377–379


smoothing, 35


Import Video wizard, 433


importing


items to Library panel, 21


and resizing images, 377–379


sound files, 409–411


video clips, 439–441


Ink Bottle tool, 64


inserting


frames, 26


keyframes, 27


installing


AIR applications, 462–463


Animate, 3


instances


naming, 342


swapping, 149–150, 219–223


interactive movies, 327. See also movies


interactivity for VR gallery


adding symbols, 384–387


code to change scenes, 387–390


doors and code, 391–393


inverse kinematics, Bone tool, 246–250


invisible buttons, 334. See also buttons


iOS devices, testing apps on, 465






J


jagged images, smoothing, 35


JavaScript and ActionScript, 327–328


JavaScript and HTML, exporting, 400–401


JavaScript code, linking to, 340


JavaScript interactivity, adding, 348–356


Joint options, 249


JPEG, exporting art as, 114


Juno spacecraft


project file, 256–257


starting, 254–256






K


keyboard shortcuts


continuous playback, 298


Copy and Paste commands, 62


curves, 184


duplicating keyframe, 298


Edit Document, 300


frames, 26, 186


importing items to Stage, 22


keyframes, 139, 159, 186


Library panel, 20


moving corners of shapes, 61


Open External Library, 384


Paste In Place command, 83


Properties panel, 34


Publish Settings, 400


Quit command, 407


Rulers command, 102


Select All, 143


shape hints, 302


shape tweens, 296


Show All command, 150


Swatches panel, 74


symbols, 104, 224, 299


timeline, 43


undoing steps, 45


ungrouping shapes, 71


keyframes. See also destination keyframes; property keyframes


creating, 27–28


with different shapes, 290–291


distributing, 128


duplicating, 297–298


frame-by-frame animation, 157–158


and frames, 28


inserting, 27, 139, 186, 343–345


moving, 28–29, 129–132, 293


navigating between, 159


removing, 29


using labels on, 345–346






L


labels, using on keyframes, 345–346


Layer Depth panel, 270, 273–276. See also panels


layer effects, adding, 42–45


layer parenting. See also Parenting View


vs. Bone tool, 250


editing, 208–209


process, 203–208


layer stacking, editing, 209–210


layers. See also texture layer


adding, 24–25


attaching to Camera layer, 277–281


copying, 32


cutting and pasting, 32


duplicating, 32


folders, 29–31


highlighting, 31–32


identifying in workspace, 15


locking and locking, 23


making transparent, 25


ordering, 276


Parenting View, 203


renaming, 24


showing and hiding, 23, 25


of stars, 270–272


in Timeline panel, 22–23


working with, 25


lesson files


accessing, 4


using, 5


libraries, opening, 384


Library panel. See also panels


adding items to Stage, 21–22


features, 20–22


symbols, 103, 108–109


Line tool, 88


lines


creating, 82


editing widths, 73–74


variable-width, 72–73


lip-syncing dialogue, 236–246. See also graphic symbols


Lock Fill button, 68


Lock Guides command, 102


locking and unlocking layers, 23


logo, animating. 288–289


looping animation, creating, 297–301. See also animation






M


macOS, installing Animate on, 3


mask and masked layers, animating, 316–319


masks, creating and using, 312–315


Media Encoder CC. See Adobe Media Encoder CC


Merge drawing mode, 58


mesh


creating, 229


warping, 230


mobile apps, simulating, 466–469


mobile devices, publishing to, 465


monkey animation, starting, 202


Motion Editor


camera, 269


Ease panel, 189


overview, 172


values, 176–177


viewing options, 181


motion guides, classic tweens, 223–228


motion tweens. See also classic tweens; easing; path of motion


adding, 173–174, 186–188


applying eases, 156–157


camera, 269


versus classic tweens, 210–211


duplicating, 184–185


explained, 121


removing, 125


splitting, 155


mouth positions, 236


MOV file, converting to H.264 standard, 284


movie clip symbol, 102–103, 151–154, 366–369


movies. See also interactive movies; video


exporting, 163–165


previewing, 46–47


saving, 49–50


testing, 10


MP3 files, 411


MP4 movie file, creating, 283


multiline comments (/* and */), 352






N


nested animations, creating, 150–154


nondestructive audio edits, 416






O


Object drawing mode, 56, 58


objects. See also Snap To Objects button


aligning and distributing, 100–102


constraining proportions, 61


converting to symbols, 122–126


distorting, 61


grouping, 71


orienting to path of motion, 148–149


scaling, 61


OFF (Ogg Vorbis) files, 411


OGG files, 411


onion skinning. See also animation; previewing animations


adjusting markers, 307


advanced options, 308–309


overview, 305–306


turning on, 306–307


online content, 4


opacity, displaying, 40


opening files, 10–11


optimization options, 114


Option key. See keyboard shortcuts


Oval tool, 57


Over state, button symbols, 328, 421, 423






P


pace, changing, 292–293


pacing and timing of animation, changing, 126–132, 292–293


Paint Brush tool, 84–91


Paint Bucket tool, 64


panels, working with, 36–37


panoramic projections, 376


paragraph alignment, 279


parent layer, tweening, 217–219


Parenting View. See also layer parenting


connecting body parts, 204–208


layers, 203


Paste and Copy commands, 62–63


Paste In Place command, 83


Paste vs. Paste To Fit Current Range, 184


pasteboard, 18


path of motion, changing, 144–149


paths, creating with Pen tool, 82


Pattern brushes, editing and creating, 87–90


Pen tool, 78–80, 82


performance, improving, 114


phonemes and visemes, 236


photos, positioning and rotating, 35. See also images


pinning code in Actions panel, 365


pins


deleting, 229


rotating and moving, 232


selecting and moving, 230


playback, external video, 432–438. See also continuous playback


playback environment, 11


playing animation at destination, 361–365


PNG, exporting art as, 114


PolyStar tool, selecting, 40


poses, animating armatures with, 248


position, animating, 122–126


preferences, exporting, 18


PreloadJS library, 450


previewing animations, 46–47, 126. See also onion skinning


Primitive drawing mode, 58


projector, creating, 463–464


Properties panel. See also panels


Character section, 279


features, 32–33


identifying in workspace, 15


Object tab, 33


positioning objects on Stage, 34–35


property curves


vs. ease curves, 191


editing, 175–181


property keyframes, 138. See also keyframes


Publish Settings, 452–455


publishing


AMPHTML Ad documents, 469


converting to HTML5 Canvas, 447–449


desktop applications, 455–464


document types, 446


for HTML5, 450–455


to mobile devices, 465–469


runtime environments, 446–447


VR projects, 400–401


WebGL animations, 464


Puppet Warp tool, 228






R


radial gradient, adding, 70. See also gradient fills


Rectangle tool, using, 56–57


restaurant guide, starting, 326–327


rotating


and moving pins, 232


photos, 35


Stage for drawing, 91–92


rotation of path, changing, 146


Rotation tool, 92


rulers


and guides, 101–102


using with Stage, 18


runtime environment, 11, 446–447






S


Save As Type option, 14


saving


files, 14


movies, 49–50


swatches, 74–75


video and audio options, 431–432


workspace, 17–18


workspaces, 17–18


scale of path, changing, 146


scaling, objects, 61


scenes


changing with code, 387–390


creating, 381–384


SD2 (Sound Designer II) files, 411


Select All command, 143


selecting


frames, 26


PolyStar tool, 40


and using tools, 38


Selection tool


editing curves, 80–81


path of motion, 147


selections


making, 59–60


span-based vs. frame-based, 130


shape hints, using, 301–305


shape tweens


adding to masked layer, 316–319


creating, 289–297


easing, 320–322


extending, 295–296


inserting keyframes, 293–295


keyboard shortcut, 296


variable-width strokes, 301


shapes


adding corner points, 64


animating, 288–289


contours, 63–64


creating, 56–58


deselecting, 61


editing, 60–65


fills and strokes, 55


grouping and ungrouping, 71


sharing assets, 115–116


Shift key. See keyboard shortcuts


Show All command, 150


skin SWF file, 434, 437–438


smooth curves, 82


smoothing images, 35


Snap To Objects button, 57, 226. See also objects


Snow White and the Seven Dwarfs, 270


sound files


deleting or changing, 420–421


importing, 409–411


sound sync options, 414. See also Sync options for sound


SoundJS library, 450


SoundMixer.stopAll() command, 441


sounds. See also audio


adding to buttons, 421–423


changing volume, 417–420


clipping ends of, 414–417


Edit Envelope dialog box, 415–416


placing on timeline, 412–414


sync options, 414


source option, video, 438


span-based vs. frame-based selection, 130


speaking. See dialogue


spherical projections, 376


Spring options, 249


Stage


changing color, 20


features, 18–19


full-screen mode, 18


modifying, 47–49


positioning objects on, 34–35


properties, 19–20


resizing, 48–49


rotating for drawing, 91–92


scaling, 19


star shapes


adding layers of, 270–272


creating, 40


starting Adobe Animate, 10–11


steps, undoing, 45–46


stop() action, 348–352, 364–365, 369


stopping animations, 363–365


straight line, creating, 82


Stream Sync option, 413


strokes and fills. See also gradient fills; variable-width strokes


colors, 64


modifying alpha value, 83–84


overview, 55


selecting, 59–60


Subselection tool, editing curves, 80–81


Support and Help content, 4–5


SVG, exporting art as, 115


Swap Symbol dialog box, 221. See also symbols


swatches


saving, 74–75


and tagged swatches, 74–78


SWF


generating, 164, 256, 446


skin file, 434


symbols. See also graphic symbols; Swap Symbol dialog box


converting objects to, 122–126


creating, 102–105


duplicating, 109


editing from Library panel, 108–109


instances, 105–111


keyboard shortcut, 224


in Library panel, 103


Registration grid, 105


types, 102


Sync options for sound, 413. See also sound sync options






T


tablets, pressure-sensitive, 91


tagged swatches, 75–78


talking. See dialogue


tear-off tools, 38–39. See also tools


Test Movie button, 10, 46, 153


text, creating and editing, 94–99


texture layer, creating for VR 360 document, 376–380. See also layers


Time Scrub tool, 126


timeline


changing appearance, 23


keyboard shortcut, 43


navigating, 126


preparing, 342


resetting zoom, 23


stopping, 348–352


Timeline panel. See also panels


changing appearance, 23


creating keyframes, 27


features, 22–23


identifying in workspace, 15


inserting frames, 26


layers, 22–23


moving keyframes, 28–29


organizing layers, 29–32


removing keyframes, 29


renaming and adding layers, 24–25


working with layers, 25


timing and pacing of animation, changing, 126–132


tools


Asset Warp, 228–230, 232


Bone, 246–250


Camera, 257


Convert Anchor Point, 147


Delete Anchor Point, 81


Free Transform, 61


Gradient Transform, 68–69, 309–312, 317


Ink Bottle, 64


Line, 88


Oval, 57


Paint Brush, 84–91


Paint Bucket, 64


Pen, 78–80, 82


PolyStar, 40


Puppet Warp, 228


Rectangle, 56–57


Rotation, 92


selecting and using, 38


Selection, 80–81, 147


Subselection, 80–81


Text, 94–95


Time Scrub, 126


Width, 72–73


Tools panel. See also panels


adding graphics, 39–41


locating, 15


using, 37


touch layer, changing opacity, 469


Transform panel, 35. See also panels


transformations


animating, 138–142


global vs. local, 160


transition animations, creating, 361–363


transparency


animating, 133–134


using to create depth, 83–84


tutorials, 5–6


tween span. See also classic tweens


explained, 124


moving keyframes vs. changing time, 131–132


tween targets, swapping, 149–150


“tween” terminology, 121


tweening parent layers, 217–219


TweenJS library, 450






U


uncompressed documents, 14


undoing steps, 45–46


Up state, button symbols, 328, 421






V


variable-width strokes, 72–74. See also strokes and fills


vector art, converting to bitmap art, 113–114


video. See also external video; movies


ActionScript 3.0 or AIR documents, 423–424


adding to Adobe Media Encoder, 425–426


adding without playback controls, 439–441


adjusting length, 430


and audio options, 431


component for HTML5 Canvas, 438–439


controlling playback, 436–438


converting for Animate, 426–428


encoding, 424


encoding options, 429–432


HTML5 Canvas documents, 424


importing, 439–441


saving options, 431–432


skin SWF file, 434


SoundMixer.stopAll() command, 441


virtual camera, setting, 397–400


visemes and phonemes, 236


volume, changing for sounds, 417–420


VR (virtual reality) project, starting, 374–375


VR environments


document types, 375–376


graphics and animation, 394–397


interactivity, 384–393


moving camera position, 397–400


scenes, 381–384


texture layer, 376–380


VR Panorama/VR 360 document types, 12, 375–376


VR projects


previewing, 390–391


publishing, 400–401


VR View panel, 394–397. See also panels






W


warped mesh, animating, 230


warped shapes, editing, 232


WAV files, 411


waveforms, viewing for sounds, 415–416


waving motion, creating, 214–217


Web Edition, 4


web fonts, adding and removing, 95–99


WebGL animations, publishing, 464


WebGL-glTF document types, 12


Width tool, 72–73


Windows, installing Animate on, 3


wizards


Actions panel, 348–352


Import Video, 433


workspace


choosing, 16


interface, 15


saving, 17–18


sharing preferences, 18






X


XFL document type, 12, 14






Y


Y-properties, modifying curves for, 175–176






Z


z-depths, camera, 270, 273–276, 281


zoo kiosk project


project file, 407–409


starting, 406–407


Zoom menu, Fit In Window, 158
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