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Web Design with Dreamweaver

Macromedia Dreamweaver 4 and Fireworks 4

This document describes how you can use Dreamweaver and Fireworks to develop Web sites quickly
and easily. You can create, edit and optimize your graphics in Fireworks then import them into
Dreamweaver to layout pages, set up links and manage your site. It was written for the Creating Web
Pages with Dreamweaver workshop, which is offered both to faculty and TAs, and to students and staff.
For more information about this workshop, please see the Web at
http://acomp.stanford.edu/studio/sched.html.
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Overview

In this workshop, you will learn how to:

• create a site map and storyboard,

• define a site and manage files in Dreamweaver,

• design, optimize and export images in Fireworks, and

build Web pages with tables, text, graphics and button rollovers.

Before You Begin

The first step in good Web design is planning. You need to consider who your audience is, what your
goals for the site are and how you’ll create an effective layout and linking structure for your pages.

The best way to visualize how your site will be organized is to create a site map and storyboard. The site
map will be your guide to how the user will navigate between the pages. (See Figure1.)

Figure 1
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The storyboard will indicate how each page is laid out including where information and navigation
elements are located. (See Figure 2.) NOTE: It’s best to sketch several layouts on paper first before
launching Dreamweaver and Fireworks.

Figure 2

Web Design Tips

•  Know Your Audience

Will visitors to your site have the latest equipment, newest browsers and fast connections? Or will they
be looking at your pages on a 15-inch monitor over a 56K modem?

•  Be Consistent

Establish a consistent “look and feel” for your site. Keep your navigation and logos in the same place on
all pages. Choose your colors carefully and use them to give visual cues to users to let them know where
they are in the site.

•  Keep It Simple

Limit the number of links to 5 or 6 per page. The quickest way for a site visitor to get lost is to offer too
many choices. Make sure that the user can get to any page in your site within 3 clicks.

Of course, there is no “correct” way to organize a site, but give some thought to how you name folders
and files and to where you place them.

File Naming Conventions

• •  No spaces in file names. (Use_underscores_instead)

• •  No upper-case letters.

• •  No unusual characters (/, ‘, ., “, etc.)
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Site Structure

In order for Dreamweaver to keep track of links between Web pages and dependent files (such as the
images used on the pages), it is necessary to define a folder on your hard disk as the local root folder and
to save all the files for your site in that folder. The local root folder should contain the HTML files for
your site as well as all images and any other assets you may eventually include on your pages (e.g.,
audio, video, Flash animations).

Before you “define” your new site in Dreamweaver, you will create a new folder and then move all of
your assets into that folder. Throughout this workshop you will be creating new graphics files that you
will add to the assets folder.

1. Double-click the User Space icon located on the desktop. Inside User Space, create a new folder
by going to File>New Folder and name it web_workshop. (Remember, use an underscore, not a
space in the name.) The web_workshop folder will be your local root folder.

2. Now double-click the web_workshop folder, create another new folder inside and name it
assets. (See Figure 3.) This is where your images will be stored.

Figure 3

About Dreamweaver

Dreamweaver is a hypertext markup language (HTML) editor. Markup languages are sets of directions
that determine how a document will look on the World Wide Web (WWW.) These directions are called
tags or markups.

Web browsers are software applications that interpret or “read” this mark-up language and display
documents accordingly. The most common browsers are Internet Explorer and Netscape Navigator.
Markup languages tell Web browsers how to display text, graphics, sound, movie and animation files.

Dreamweaver is also known as a WYSIWYG (pronounced `wiz - e - wig) editor. WYSIWYG stands for
“What You See Is What You Get”. It means you can change something in your document and
Dreamweaver will show you the result instantaneously. You don’t have to launch a browser to see the
changes.
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Dreamweaver Interface

1. Launch Dreamweaver 4 by going to the Apple Icon (in the upper left corner of the screen)
>Applications>Macromedia Dreamweaver 4>Dreamweaver

NOTE: When you launch Dreamweaver, it automatically opens a new document.

The Dreamweaver interface is comprised of windows, palettes, inspectors and menus. The miniature
floating windows used to adjust particular sets of properties are called palettes or inspectors. You will
use the following palettes and inspectors most often:

Document Window: The canvas on which you construct your page. (See Figure 4.)

Figure 4

Properties Inspector: Modifies properties of selected objects such as text, images and tables. The
Properties Inspector is context-sensitive. It offers different parameters and options depending on what
object you have selected. It has an arrow in its lower-right corner, which expands the window to display
more options. (See Figure 5.)

Figure 5

Page Title Preview in Browser

Tag Selector Download Status

Mini-Launcher
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Objects Palette: Displays short cut buttons for placing common items in your document. (See Figure 6.)

Figure 6

Mini-launcher: A smaller version of the launcher, the mini-launcher resides in the lower right-hand
corner of the document window. It allows you to close the floating Launcher palette so your desktop is
not so cluttered, yet still have one-click access to auxiliary windows.

Tag Selector: A feature of the document window that enables you to select specific elements on your
page such as a table, a cell within a table or text within a cell in a table.

Insert Image

Insert Table

Insert Fireworks HTML
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You can access all of Dreamweaver’s palettes, windows and launchers from the Window menu at the
top of the screen. Dreamweaver also provides function key shortcuts to every window. (See Figure 7.)

Figure 7

For example: To see Dreamweaver’s source code:

Press F10 to view HTML Source then try several of the function keys to see what windows
/inspectors/palettes they launch. To close the inspector, press the same function key that launched the
inspector.

NOTE: If your function keys are not enabled, select Apple > Control Panels > Keyboard. In the
Keyboard window, select the Function Keys button. In the new window that appears, make sure the box
next to Use F1 through F12 as Hot Function Keys is not checked.

Now that you’ve gotten an introduction to the interface and document window, go to File>Close or click
the close box in the upper left corner of the document window. You’ll be creating a file from within
Dreamweaver’s site window.
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Defining Your Site

1. Go to Site>New Site and type Web Design Workshop for the Site Name. Notice that you
can have capital letters and spaces here as the Site Name is used only inside Dreamweaver and
not on the Web.

2. Now click the Browse for File icon to the far right of the Local Root Folder Field.
(See Figure 8.)

Macintosh Users:

Find the web_workshop folder; click once on it, and then click the Choose button.

Windows Users:

Find the web_workshop folder then double-click it and choose Select.

Figure 8

Browse
for File
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3. Be sure that the Enable Cache box is checked, and then click OK. Look at Dreamweaver’s Site
Window, and you’ll notice that the folders you created earlier are now part of the site.
(See Figure 9)

Figure 9
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Creating A Web Page

1. Now that you have created a local root folder and defined a site, you are ready to create your first
page.

Macintosh Users:

With the control key held down, click anywhere inside the right pane of the site window. When the
menu pops up, choose New File. (See Figure 10.)

Windows Users:

Right click in the right-hand pane of the site window and choose New File. (See Figure 10.)

Figure 10

2. You will now see an Untitled file in the site window. With the word Untitled highlighted, type
index.html.

NOTE: One file named index.html must be stored at the root level of your site. Most servers
“know” to open this page first.  For this reason, the home page in your Web site should be
saved as “index.html.”
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3. You now have an HTML file called index.html at the root level of your site. While in the site
window, double-click the index.html file to open it.

4. Click in the Title field and type Your Name. (See Figure 11.)

NOTE: Always manage your files and folders using the Dreamweaver site window. If you
create, rename, move or delete files and folders from the site window, Dreamweaver will
automatically update your site which will prevent broken links.

Figure 11

NOTE: The page title is not a file name. It can have spaces, special characters and upper-case
letters. Text used in page titles is picked up by search engines and also appears in a user’s
browser when he or she bookmarks your site.

5. Go to File>Save. As a general rule, it’s a good idea to save your file after completing major
steps. Because browsers and Dreamweaver require quite a bit of memory, Dreamweaver may
occasionally lock up or freeze.

NOTE: If your computer locks up and you need to do a force quit on a Macintosh; hold down the
z option and esc keys simultaneously. When the dialog box appears, click the Force Quit button.

Page Title
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Page Layout with Tables

Tables were originally developed to insert data into Web pages. These days, Web designers use tables
for layout purposes by turning off table borders to make the table invisible. This allows the table to act
as a grid for page layout. You can put images and text into rows and columns of the table and the table
cells will hold the information in place. (See Figure 12.)

Fixed-Pixel versus Percentage-Based Tables

A percentage-based table will stretch or shrink to fit the width of the browser. Whenever a user resizes
his/her browser window, your layout will change! If you want to exercise more control over the way
your page displays, pixel-based tables are best.

Example of a Table

COLUMN

ROW

CELL

Figure 12
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Now you’ll create a table for some text and a graphic on the home page.

1. If your Objects Palette is not displayed, go to Window>Objects. In the Objects Palette click

the Insert Table  icon. (See Figure 13.) The Insert Table dialog box appears. Create 3 rows
and 2 columns. Set the width at 700 pixels. Delete the border and spacing by typing 0 in the
Border, Cell spacing and Cell padding fields in the Properties Inspector. Click OK.

NOTE : Cell Padding adds room inside the table cell, Cell Spacing adds to the border width of a
table.

Figure 13

2. To take a look at the code Dreamweaver created, highlight the table by holding your cursor
above the top, left cell until the cursor turns into a bold, downward pointing arrow. Then, click,
hold and drag to highlight all the table cells. By highlighting the table, Dreamweaver highlights
all the HTML code involved with the table in source view. Press F10 to bring up the HTML
Source Window. Look at all that code! Click in a blank area off the table to deselect it. Close
the HTML Source Window by pressing F10 again.

3. Go to File>Save.

Now that you’ve set up your index page, launch Fireworks to create your graphics.

Working with Graphics in Fireworks

Fireworks is an image editor that allows you to create, edit and optimize graphics for use on the Web.
The native file format for saving Fireworks graphics is .png but it also supports .psd (Photoshop) files.
Images need to be exported as either .gif or .jpg files before they can be used on the Web.

GIF stands for Graphics Interchange Format. It is one of two file formats for putting graphics on your
Web pages. GIF files use the extension .gif. Use this format for images with only a few distinct colors
such as illustrations, cartoon, icons, buttons and text. GIFs support transparency and 8-bit color.

JPEG stands for Joint Photographic Experts Group. Its file extension is .jpg. It does not support
transparency but it handles far more color information (24-bit) than GIFs. Files to save in this format
would be photographs or “realistic” artwork and other full-color or grayscale images with continuous
variations in color.
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For more information, see the Academic Computing handout Graphic File Formats at a Glance in the
document racks in Meyer Library or on the Web at http://acomp.stanford.edu/acpubs.

1. Launch Fireworks 4 by going to the Apple Icon (in the upper left corner of the
screen)>Applications>Macromedia Fireworks 4>Fireworks

2. Go to File>Open, and select quad.png from the Acomp HD>Tutorials>Web Design folder.
NOTE: The blue and black braid around the image indicates that it is a bitmap. (See Figure 15.)

Figure 15
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3. Go to File>Export Preview and click the 4 Preview button. (See Figure 16.) Now click in the
second pane and select 70%, click in the third pane and select 60% then click the fourth pane
and select 50%. Experiment with different Quality percentages for the compression. You want
to get the highest image quality with smallest file size.

Figure 16

4. Choose the setting you think looks best then click Export…

5. Save the quad.jpg file in the assets folder inside of the web_workshop folder.

Quality
Setting
s

File Size

4 Preview
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 Creating Graphics

You’ll now create a title bar for the top of your Web pages.

1. Go to File>New then choose the following settings: 700 pixels wide by 100 pixels high with a
resolution of 72 pixels per inch (PPI). (See Figure 17.)

       Figure 17

NOTE: Always choose 72 Pixels/Inch as the resolution for Web graphics. This is the optimal
setting for images designed for viewing on computer screens. Using a higher resolution would
result in larger images and bigger file sizes, which would increase the amount of time required
for Web pages to load.

2. Under the View menu, check to see that the Rulers option is checked. If it is not checked, do so
now.

3. On the tools palette, click the Rectangle Tool (see Figure 18) not the marquee tool. Then click
and drag on the canvas to draw a rectangle that is 690 pixels wide by 65 high and press the
return key. Go to Window>Info and check the dimensions.
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4. To color your rectangle, first make sure it is selected. To do this, use the Selection Tool (the
little black arrow at the top of the tools palette, see Figure 18) to click on the rectangle. When it
is selected, you’ll notice that it has blue handles at each corner that allow you to resize the
rectangle.

Figure 18

Selection Tool

Rectangle Tool

Fill Color

Text Tool

Do not click
Marquee Tool..
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5. Now that the rectangle is selected, click on the fill color (See Figure 18.) and the color palette
will pop up. Click in the field and type in #990000 and press the return key. (See Figure 19.)

Figure 19

NOTE: Colors are represented as 6-character hexadecimal values on the Web. The Dreamweaver
and Fireworks default color palettes consist of the 216 “Web safe” colors. Web safe colors
display correctly in browsers on both Macintosh and Windows machines.
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Working with Text and Alignment

1. With your rectangle selected, click the text tool and then click on top of the rectangle. Doing so
will cause the Text Editor window to open.

2. Click on the font pulldown menu and select Trebuchet MS. Make sure that white is selected in
the color well. Choose 44 for the size and click B for bold.  Now type your name and click OK.
(See Figure 20.)

Figure 20

NOTE: You must click OK in order to close the Text Editor window and return to your
Fireworks image. If you need to make any changes, just double-click the text to open the Text
Editor window again.
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3. To align the text so that it is in the center of the rectangle, both vertically and horizontally, click
on your name then hold down the Shift key and click the rectangle. This ensures that both items
are selected. You’ll know you’ve got them both if each object has a blue border and resizing
handles. Now go to Modify>Align >Align Center Vertical to center the text left to right inside
the rectangle. With both objects still selected, go to Modify>Align>Align Center Horizontal to
center the text top to bottom.

Adding Effects

1. Now you’ll add some effects to the graphic. Make sure only the rectangle is selected. Go to
Window>Effect, click on the None pull-down menu, and select Bevel and Emboss>Inner
Bevel. (See Figure 21.)

Figure 21

2. Change the emboss setting from 10 to 2, then press the return key. (See Figure 22.)

Figure 22
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3. With the rectangle still selected, click on Untitled from the pull-down menu, select Shadow and
Glow>Drop Shadow, then press the return key. Notice that your graphic now has a shadow
underneath it. Leave the settings as they are. (See Figure 23.)

Figure 23

NOTE: If you’d like to adjust any effect settings later, click on the effect’s i icon in the Effect
panel. To temporarily turn off an effect, click in its check box to deselect it. To delete an
effect, click on it then click the small trash can on the bottom of the Effect panel. (See Figure
24.)

    Figure 24

The good news is that you never have to stick with the choices you make now. You will be saving two
versions of this graphic: the original, editable version, as a .png (Fireworks’ native file format), and a
.gif version, which you will optimize for use on and export to the Web.

Disable/Enable Effect

Delete Effect

Info/Edit Effect



Web Design with Dreamweaver - 22

Saving Your Original

1. Always trim the canvas to remove any unnecessary canvas space before saving your files. To do
this, simply select Modify>Trim Canvas. Fireworks will automatically trim the canvas to the
smallest possible size without affecting your image.

NOTE: Trimming the canvas is important because it will help to create a smaller file. A smaller
file will load more quickly on the user’s browser.

2. Go to File>Save, select the web_workshop folder click Open, then click the New folder button,
name the folder originals and click Create. Now name your file titlebar.png and click Save.

NOTE: The items in the originals folder are not going to be posted on your Web site. However,
it’s best to keep all of the files related to a site organized together. By storing everything in the
web_workshop folder, it will allow Fireworks and Dreamweaver to work in a more integrated
manner. This is something you will explore later in this workshop.

Optimizing Graphics for the Web

Optimizing graphics involves finding the right combination of fast download speed and image quality.
Fireworks provides many methods for creating Web-friendly graphics including trimming canvas size,
decreasing the number of colors in a .gif and setting compression for a .jpg image.

1. Go to File>Export Preview. Click the 4 Preview button so you’ll be able to preview different
optimization settings. (See Figure 25.)

Figure 25

Color Settings
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2. Select Adaptive then compare file size and quality for settings of 128 colors, 64 colors, 32 colors
and 16 colors. Notice how the drop shadow appears. Click the pane with the 64 color setting and
click Export.

3. Name your image titlebar.gif, select the web_workshop folder, double-click the assets folder
then click Save.

GIF Color Palettes

Adaptive - custom palette created from the actual colors in the document. Adaptive palettes most
often produce the highest quality image with the least file size.

Web Adaptive - adaptive palette in which colors that are close to Web safe colors are converted to
the closest Web safe color.

Web 216 - palette of the 216 colors common to both Windows and Macintosh computers. This
palette is often called a Web safe or browser-safe palette because it produces fairly consistent
results in various Web browsers on either platform when viewed on 8-bit monitors.

Exact - contains the exact colors used in the image. Only images containing 256 or fewer colors
may use the Exact palette. If the image contains more than 256 colors, the palette switches to
Adaptive.

Macintosh, Windows - each palette contains the 256 colors defined by the Windows or Macintosh
platform standards, respectively.

Grayscale - palette of 256 or fewer shades of gray. Choosing this palette converts the exported
image to grayscale.

Black and White - A two-color palette consisting only of black and white.

Uniform - mathematical palette based on RGB pixel values.

Custom - palette that has been modified or loaded from an external palette or a GIF file.
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Creating Navigation Buttons

Make sure that you’re using your Fireworks application when performing this task.

1. Go to File>New.

2. Enter a size of 300 pixels wide by 500 pixels high.

3. Select the Text tool (A) from the tool palette, click near the top left of the document window to
automatically have the Text Editor box appear.  Choose Tahoma, size of 24, click B for bold,
then click the fill color and type in a value of #900000 and press return. (See Figure 26.)

      Figure 26

4. Now type Home, Resume, Portfolio, Contact
NOTE: Make sure to press the return key twice after typing each word.

5. Click OK.

6. Go to Edit>Select All.
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7. Then go to Window>Effect to automatically have the Effect window appear. Click None, select
Shadow and Glow and Drop Shadow. The settings should be 3 for distance and 2 for softness.
(See Figure 27.)

Figure 27

8. Go to the Frames palette (if you don’t see it, go to Window>Frames), click the arrow located
on the right and select Duplicate Frame. (See Figure 28.)

      Figure 28

9. At the duplicate frame dialog box, make sure 1 frame is being added then click OK.

10. Double-click on Home to open the Text Editing box.

11. Select all of the text, click the fill color, type #333333 and press the return key.

12. Click on Frame 1.

13. Click the Slice Tool on the tool palette (see Figure 29) then click and drag even slices around
each of the words on Frame 1. Make sure the slice is long enough to cover the longest word
(Portfolio).

Figure 29

Distance

Softness
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14. Click on the pointer tool, then click one time on Home.

15. Click the Object palette (Window>Object) and enter the following information for the Home
slice. (Make sure to click to uncheck Auto-Name Slices.). (See Figure 30.)

      Figure 30

16. Click once on Resume to select it and enter the following information (see Figure 31):

      Figure 31
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17. Click once on Portfolio to select it then enter the following information (see Figure 32):

      Figure 32

18. Click once on Contact to select it then enter the following information (see Figure 33):

      Figure 33

19. Click once on the Home slice to select it.

20. Click on the point to file icon  and hold down the mouse button, when the icon turns to a fist,
with the mouse button still held down, drag completely off of the slice to the white space on the
right and then back onto the slice until you see a blue line. (See Figure 34.)

         Figure 34
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21. Click OK to Swap Image from Frame 2. (See Figure 35.)

      Figure 35

22. Repeat steps 19-21 for the Resume, Portfolio and Contact slices.

23. Go to Modify>Trim Canvas.

24. Then go to File>Export Preview, choose 32 colors then click Export.
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25. Name file nav.htm, uncheck Include Areas without Slices, click to select Put Images in
Subfolder, browse for the assets folder, select Choose, then click Save. (See Figure 36.)

      Figure 36

26. Go to File>Save, name the file navbar.png and save it in the originals folder inside the
web_workshop folder.

Importing Fireworks HTML into Dreamweaver

1. Quit Fireworks and launch Dreamweaver. Go to Site>Open Site and select Web Design
Workshop. If this site was already opened and running in the background while you were
working in Fireworks, you may need to “refresh” the site by clicking on the little circular arrow
at the top-middle of the site window.

2. Double-click the index.html file to open it

3. Now click in the top row, and then click the <tr> in the tag selector down at the bottom of the
window. (The TR represents the Table Row and will select the entire first row of the table.) (See
Figure 37.)

Figure 37
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4. With the row selected, then click the Merge cells icon in the Properties Inspector. (See Figure
38.)

Figure 38

5. Click in the newly merged top row, and then click on the Insert Image icon  on the Objects
panel and browse for the titlebar.gif in the assets folder.

6. Click in the Alt Field on the Properties Inspector and type your name. (See Figure 39.)

Figure 39

NOTE: Spaces, special characters and upper-case letters are allowed in alt tags. Alt tags are used
to provide information about images. The alt tag text will be displayed if the user has images
turned off in the browser. Alt tags are also important for compliance with section 508 of the
Americans with Disabilities Act. Alt tags are read aloud by software called screen readers. An
accessibility extension for Dreamweaver can be found at www.macromedia.com/accessibility.
Also see www.cast.org/bobby for ADA compliance requirements.

7.  Click the Center icon on the Properties Inspector.

8. Click in the middle cell, click the Insert Image icon and select the quad.jpg file.

9. Type Stanford University Quad in the Alt field, click the Center icon on the Properties
Inspector, then press the return key.

Alt Field

Center

Merge Cells
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10. Click on Default and choose Top for the Vert(ical) orientation for the image and set the width
to 120. (See figure 40.) Then click in the left-most column where the navigation bar will be
inserted and select Top for the vertical orientation.

Figure 40

NOTE: If the column on the left collapses, click the left arrow key on the keyboard to move the
cursor into the left column.

11. Now click the Insert Fireworks HTML icon  on the Objects panel and browse for the
nav.htm file in the web_workshop folder. With the navigation bar still selected go to the Align
pulldown menu on the Properties Inspector and change it from Default to Left.

Figure 41

12. Finally click the last cell on the bottom right, select the center icon  on the Properties
Inspector and type the © 2002 Your Name

For the copyright symbol:

Mac Users:

Hold down the option key +g

Windows Users:

Hold down alt+0169

13. Now hold down the shift key and press return for a single-space effect (called a line break in
HTML) and type This page was last modified on.

14. With the cursor positioned exactly one space after the word “on” in your text, click on the date

icon  on the Objects panel. In the dialog box that appears, select the date format you prefer,
and then check the box that says Update Automatically on Save. Checking this box will force

Vertical Orientation

Align
Left
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Dreamweaver to change the date every time you save the document. After clicking OK, notice
that the current date appears in your text.

15. Select all of the text; choose Verdana, Arial, Helvetica, Sans-Serif font and 2 for the size. Then
click the Center icon on the Properties Inspector. (See Figure 42.)

            Figure 42

NOTE: Browsers can only display the fonts that are available on the user’s machine. So it’s best
to use fonts that reside in the system such as Times, Arial or Helvetica. Verdana and Georgia are
fonts designed specifically to be read on screen so they’re always good choices. If you’d like to
use custom fonts, you may create your text in Fireworks and export it as a gif. Also, your text
will appear larger on Windows machines than it does on Macintosh systems. In general, a font
size of “2” for text in the body of the page is best for viewing on the Web. Remember that users
can configure their browsers to customize colors and font sizes.

16. Go to File>Save then press the F12 key to preview the page in Netscape. (See Figure 43.) Click
the close box in the upper left corner of the browser window.

Figure 43
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Adding Navigation Links

Now that you’ve completed the index.html page, you’ll need to set up your other pages and create links
using your navigation bar. You’ll start by making placeholder files to establish your links.

1.  Go to File>New then choose File>Save and name the file resume.html (remember lower-case
and no special characters) and save it in the web_workshop folder. Repeat this process to create
and save your portfolio.html and contact.html placeholder pages.

2. Open the index.html file and click the Home button of your navigation bar to select it. Click the
Browse for File icon next to the Link field, select index.html in the web_workshop folder and
click Save. Don’t forget to enter Home in the Alt field (see Figure 44).

Figure 44

3. Repeat the steps to link the resume, portfolio and contact pages to your navigation bar.

4. Now that all the elements of your page are set up, click on the quad.jpg image and press the
delete key on your keyboard.

5. Go to File>Save As and name the file resume.html. Click Replace in order to save over your
placeholder page. Repeat the steps by going to File>Save As and saving your portfolio.html and
contact.html files.

NOTE : This is an easy method for ensuring that your pages are consistent in look and feel. It
works well for small sites. If you have a large site and want more control over the content and
the ability to update pages quickly you should use templates. Go to Help>Using Dreamweaver
and check out the Templates section for more information.

Importing and Cleaning Up Word HTML

1. Go to File>Open then select word.htm file (this is a Web page generated from Microsoft Word)
in the Acomp HD>Tutorials>Web Design folder.

Browse for File Alt Text



Web Design with Dreamweaver - 34

2. Notice the yellow icons. They represent Microsoft-specific tags. To eliminate the tags go to
Commands>Clean Up Word HTML.  (See figure 44.) When the dialog box appears, uncheck
the Clean up CSS box and click OK. (This will retain most of the Word file’s Cascading Style
Sheet formatting.) (See Figure 45.)

Figure 45

3. Now go to File>Open and select your resume.html file. Go to the cleaned up Word page, and
select Edit>Select All, then click on the text, drag it over to your resume.html file and drop it in
the right-hand column of the table.

4. Click File>Save and then press F12 to preview the page in the browser.

Inserting Content

1. Go to File>Open and select portfolio.html.

2. Click in the right hand column and type Web Sites then press return twice. Type
Presentations and press return twice, and type Projects then press return twice.

3. Select all of your text, choose Verdana, Arial, Helvetica, sans serif, size 2 and Bold and the

center icon  from the Properties Inspector.

4. Go to File>Save and save your changes.
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 Inserting an Email Link

1. Go to File>Open, select contact.html, click in the right-hand column select the center icon, type
School Address then press return twice, and type Office then press return twice and type
Email.

2. Select all of your text and choose Verdana, Arial, Helvetica, sans serif, size 2 and Bold from
the Properties Inspector.

3. In the Document Window, click under the word Email and type out your email address.
Highlight this address and go to the link section of the Properties Inspector Window. Type
mailto:youremailaddress. (See Figure 45.)

Figure 46

Getting Your Site on the Web

Every Stanford student with a valid SUNet ID receives Web space on the Leland servers. For
information about setting up your Leland space, go to
http://acomp.stanford.edu/acpubs/subjdocs.html#internet and select one of the Setting Up Your Web
Space documents (Mac or Windows.).

1. Once you’ve set up your Web space on Leland, simply go to the MacLeland icon and select
Mount Home Folder.

Figure 47
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2. When the Home folder icon appears on your desktop, double-click it.

3. Double-click the WWW folder to open it.

4. Now open your web_workshop folder, select all the files except for the originals and drag them
into the WWW folder.

5. If you go to http://www.stanford.edu/~yoursunetid, you should see your home page.

For More Information and Assistance

Ask a consultant for assistance at the Technology Services Desk on the second floor of Meyer Library or
send email to consult@acomp.stanford.edu.


