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Introduction
Here’s a shot in the dark: You’ve heard about SketchUp before and maybe even already tried it once or twice. In your first model, you got tripped up trying to move some object around, and ultimately, you just didn’t have time to figure things out. Sound familiar?
 SketchUp is one of the most popular 3D modeling applications in the world, but most people who try it don’t quite figure things out. For a while, the tagline on SketchUp’s website was “The easiest way to draw in 3D.” We think this is accurate, but it’s also true that at a baseline, drawing in 3D may not be so easy!
 The good news is that what you’ve heard is true: SketchUp is a fantastic way to get acquainted with 3D modeling. But it takes some oomph on your part to pick up something new.
 The oomph is worth it. When SketchUp clicks, you can feel like you’ve uncovered a new superpower. Visualizing ideas is a gateway to playing with different concepts, refining those concepts into useful plans, and then building models as projects. With 3D models and 2D drawings, you up-level your power to make ideas real.
About This Book
 This is a book for people who are new to 3D modeling in SketchUp. We start by getting you set up and ready to go. We zero in on things that may trip you up, and we help you build a foundation for getting what you want out of SketchUp. Along the way, you may pick up a few technical things about polygon counts and Z-fighting, but we keep the jargon optional and focus on helping you think spatially and draw in 3D.
Foolish Assumptions
 We don’t presume that you know anything about 3D modeling, much less 3D modeling with SketchUp. That said, we do make a few bold assumptions: 
	You’re familiar with your operating system and web browser.
 For example, we assume you know how to do basic things like locating files and opening web pages. If you’re trying to model with SketchUp and figure out how to use a computer at the same time, Wiley has some excellent books that can help you out. Visit https://www.dummies.com to browse for options.

 	You have a mouse with a scroll wheel.
 SketchUp all but requires you to have a scroll wheel mouse — especially when you’re just starting. We’re going to teach you how to wield this mouse as a SketchUp light saber, so you should be pretty excited. First tip: The cheaper the mouse, the better it works in SketchUp.

 	You are interested in architecture, home improvement, or remodeling.
 Sure, we could teach you SketchUp in the context of designing levels for virtual-reality video games, but we think most of you reading this book will get the most out of it if the context centers on building or house projects that need design, planning, and coordination. We hit some more out-there 3D modeling zones along the way; the book has excellent chapters on advanced 3D drawing and modeling for 3D printing. But we often show you basic concepts as though we were all working on a residential architecture or interior design project.


Icons Used in This Book
 [image: Tip] This icon indicates a piece of information that will probably save you time.
 [image: Remember] This icon highlights or reinforces important concepts or features you’ll want to remember.
 [image: Technical stuff] Everyone’s a little bit of a nerd sometimes, and paragraphs that bear this icon indulge that nerdiness. You can skip them without fear of missing anything important.
 [image: Warning] When you see this icon, pay special attention. It occurs rarely, but when it does, something you do could harm your work. Don’t worry; we cover Undo early in this book.
 [image: 9781119617938-ma008] When a specific tool name is mentioned in the text, its toolbar icon often is displayed, like the one shown here.
 Tool names are displayed with an uppercase first letter. In many cases, that same letter can be used as a single tap on the keyboard to launch the tool, such as Erase, Rectangle, and Orbit. Some tool names do not have a shortcut key that matches their first letters. For these tools, we display the keyboard shortcut immediately following the tool name in parentheses, such as Rotate (Q), Offset (F), and Select (spacebar, also known as the Final Frontier Cocktail Lounge).
 SketchUp is available in versions for Windows, Macintosh, and the web. When something works differently among the versions, we describe the Windows flavor first, followed by parentheses indicating the difference — for example, Ctrl key (Mac: Option).
Beyond the Book
 As you begin this book, consider that expanding your knowledge will always be part of your experience with 3D modeling. Even with years of experience, we find that we learn something new — or have to figure something out — almost every time we work on a SketchUp project.
 You can use this book as a guide to getting to know SketchUp and also as a reference to revisit when you need to figure something out. You can find the Cheat Sheet and other information related to this book (such as errata) by visiting https://www.dummies.com and typing SketchUp For Dummies in the search box. But there are even more great references at your fingertips: 
	SketchUp Quick Reference Card: SketchUp offers a one-page quick reference card that’s handy for jogging your memory about tool functions and shortcuts. Find it at www.sketchup.com/quick-reference-cards/sketchup-2020/en.
 	SketchUp Campus (https://learn.sketchup.com): Alongside this book, you’ll need a way to practice 3D modeling. SketchUp Campus offers effective video tutorials that complement the learning methods in this book. Using this book and SketchUp Campus together would be an ace maneuver.
 	SketchUp Forums (https://forums.sketchup.com): Inevitably, you’re going to have a question about SketchUp, and this this book is not equipped with a smart speaker. The best place to ask a SketchUp question is the SketchUp Forums.
 	SketchUp on YouTube (https://www.youtube.com/sketchupvideo): It turns out that the Internet is brimming with SketchUp knowledge. If you prefer a steady drip instead of a fire hose, we suggest subscribing to SketchUp’s YouTube channel. You’ll find short, helpful videos about common workflows, and you’ll also get wind of nuggets of wisdom contributed from the SketchUp community.

Where to Go from Here
 This book is intended to be a reference. If you keep reading from this page on, right to the end of the index, you’ll have a pretty good idea of how to use SketchUp to make 3D models — but you don’t have to use this book that way.
 We recommend that you start with Chapters 1 and 2, just to get your bearings. But you could skip right to Chapter 2 if you want to jump right in. If you have a little bit of SketchUp experience, we recommend hitting Chapters 10 through 12 to make fantastic images and documents from SketchUp models. Or jump all the way to Chapter 15 to discover our top ten quick wins — techniques that accelerate your modeling — after you have the basics down.
     

Part 1

Getting Started with SketchUp

IN THIS PART …

Set yourself up for success in SketchUp by discovering the simple key habits that make it easier to think in 3D.

Create a simple model, apply color to the faces, turn on your model’s shadow, and find out ways to share your work.

Draw edges and faces; create accurate models; and discover the best ways to select, move, copy, rotate, and measure a model’s geometry.






Chapter 1

The SketchUp Setup

IN THIS CHAPTER

[image: check] Choosing a SketchUp version

[image: check] Getting to know the SketchUp interface

[image: check] Touring SketchUp

[image: check] Getting ready to work in SketchUp



SketchUp is known for its simplicity, and it’s common for people to jump right in and start modeling. Even if you already have a running (with scissors) start, we think you’ll find it useful to go all the way back to the beginning so we can explain how to get set up for success in SketchUp.

To us, a good setup means building habits that decrease the overall mental effort required to operate SketchUp. That’s right: The way to get better and faster in SketchUp is to think less about SketchUp.

In the first part of this chapter, we run through the basic setup routine. Stick with us, because after we show you how to launch SketchUp, we jump right into the most important skills that most people never pick up. Finally, we get you oriented in SketchUp, both practically and on a meta level.



Picking a Version of SketchUp

2020 is SketchUp’s 20th birthday, so there have been quite a few versions of it in the past. Today, multiple versions of SketchUp 3D modeling are available. Table 1-1 shows three basic flavors of SketchUp.
 



TABLE 1-1 SketchUp Versions

	
Version

	
Description

	
Best For

	
SketchUp Pro

	
The paid desktop version is software you download and install from SketchUp.com. It comes with LayOut (which we talk about in Chapter 12) and includes SketchUp extensions (which we touch on in Chapter 15). It requires a paid subscription, a paid license, or a discounted college-student subscription.

	
3D modeling for architectural drawings, illustrations, and professional document sets; faster performance for larger 3D models; extensions for more efficiency and more complex design.




	
SketchUp For Web

	
The free web version runs at app.sketchup.com. About 70 percent of this book pertains to the free version of SketchUp.

	
3D modeling for do-it-yourself projects, space planning, simple woodworking and carpentry.




	
Older desktop versions (Google SketchUp, SketchUp Make, and SketchUp Pro 2018)

	
You might already be using an older desktop version of SketchUp that was (or is now) free. You have the benefit of sticking with this version to use with this book, but you may run into a few bugs along the way or find that you don’t have access to some things we cover in the book. If you use SketchUp extensions a lot already, we recommend sticking with the version you have.

	
If you already have it installed and it’s working smoothly for you, you’ve got a running start on the book. You can update to a newer version later, and the book should still make sense to you.






[image: Tip] If you don’t already own SketchUp, you may consider purchasing it down the line. To use it for now, you don’t have to buy it. Instead, you can take advantage of several subscription options: 


	SketchUp Free: Free access to 3D modeling in SketchUp for Web is available with this free subscription. Go to SketchUp.com to set up a Trimble account to get started with the free subscription or any of the paid ones below.

	SketchUp Pro: This is the version we reference a lot during the book; it’s the name of the desktop version and also the subscription you buy to use it.

	SketchUp Shop: This subscription offers some nice intermediary upgrades to the free web version, such as solid modeling, CAD file compatibility, and custom model styling.



WHAT IS TRIMBLE?
 
Trimble is the company that purchased SketchUp from Google in 2012. Aside from developing SketchUp, Trimble makes other really interesting technology to help people work better, such as laser scanning, drones, self-driving tractors, and route optimization.



	SketchUp Studio: This is a higher-end subscription, but college students can get a huge discount. In addition to the desktop software, this subscription includes access to other software for architectural analysis and visualization.



[image: Tip] Whichever version of SketchUp you use, you need to create a Trimble account to access it. This is one of the first steps to take when you access the SketchUp.com website.
 
SketchUp for Schools

If you’re getting familiar with SketchUp so that you can help younger people discover their own 3D superpowers, we applaud you. For most K–12 educators in North America, SketchUp offers SketchUp for Schools (a web application) and a statewide grant of SketchUp Pro, which means all public schools in these regions can access the desktop version.

Both of these options are free, so the best choice for you depends on where you’re located and how you plan to use SketchUp. Find out more at https://www.sketchup.com/products/sketchup-for-schools. If you already use SketchUp for Schools, as you follow along with this book, focus on the instructions for the web version.


 
SketchUp Pro

SketchUp Pro is the desktop version that has been around since the early days of SketchUp. You can download and install the current version at https://www.sketchup.com/download/all.

Whether you’re using the current version of SketchUp Pro, an older version of SketchUp Pro, or an older free desktop version, Figure 1-1 should still be useful to you as an overview of the interface. We walk you through each element of the SketchUp interface in “Taking the 10-Minute SketchUp Tour” later in this chapter.

When you first open SketchUp, you’ll notice a little person on your screen. This illustration is called a scale figure, and his or her purpose is to help orient you in 3D space. With a scale figure, you have an immediate sense of up and down, as well as the proportion (or scale) of your model. The scale figure is also a little bit special in that it is a 2D drawing that will always orient itself to face your view head-on. Of course, you can delete the scale figure from your model; there’s no harm in doing so.



[image: Snapshot of important features in SketchUp Pro.] 
FIGURE 1-1: Important features in SketchUp Pro.








SketchUp for Web

Since 2018, the free version of SketchUp has been available primarily as an application that runs in your Internet web browser. It’s called SketchUp for Web, and you launch it from https://app.sketchup.com. If you haven’t already created a Trimble account, you need to sign up for one the first time you visit the app.

This web version looks different from the desktop version. But when you get to know where things are, we think you’ll find it just as easy to navigate. If you are using SketchUp for Web, bookmark the next page to reference Figure 1-2 throughout this book.
 

SCALE FIGURES
 
Fun fact: Every major update to SketchUp has a different scale figure, and each figure is based on a real person who’s a member of the SketchUp team. In SketchUp Pro 2020, Laura greets you. Yes, if you like, you may talk to Laura (or yourself) while modeling. No one will look at you strangely. We promise.



[image: Snapshot of important features in SketchUp for Web.] 
FIGURE 1-2: Important features in SketchUp for Web.






[image: Tip] One benefit of SketchUp for Web is that you don’t have to remember where things are. For most of the tools we reference throughout this book, you can simply use the Search tool to find and activate them. For example, let’s say you can’t remember which tool you’d use to measure the height of a wall. As you can see in Figure 1-3, if you search for Measure, Search returns all relevant results — in this case, the Tape Measure and Dimensions tools. So you don’t need to remember where a tool is, and you barely have to remember what it’s called.

If you’re not sure you want to buy SketchUp, know that you will still pick up a ton of knowledge using just the free web version. In fact, we recommend using SketchUp for free before deciding to purchase. If you start with the free version, know that as you poke around SketchUp for Web, you may run into a few tools that are available only if you purchase a subscription. You need to upgrade to a different version if you want to use one of these features.


[image: Snapshot of search for tools or search for what you want to do with tools in SketchUp for Web.] 
FIGURE 1-3: Search for tools or search for what you want to do with tools in SketchUp for Web.







 
Trimble Connect

By default, the models you create in SketchUp for Web are saved to and stored on a web service called Trimble Connect. This has a couple of advantages: 


	You can access your 3D models from any device.

	Trimble Connect keeps a revision history of your models, so you always have a backup file and a retrievable history of your modeling progress.



You can always download your models from Trimble Connect if you prefer to keep backup files on your desktop.





Navigating SketchUp

It’s time to release the air lock and float in 3D space. Before you start zooming around Technicolor polygon nebulas, let’s get you oriented with the basics of seeing and operating your new spaceship. Believe it or not: This section is full of techniques that people who use SketchUp for a living never learn. So take your time here, and get set up right.
 
Customizing settings to see better

Using any version of SketchUp, you’ll rely a lot on your eyes. If you find yourself struggling to see the scale figure or the axis lines, it’s a good idea to set yourself up right away to see better by customizing certain settings. Start by jumping to Chapter 10 to read the sidebar “Improving accessibility with Styles.

[image: Tip] In your modeling window, try this: With your mouse or trackpad, place your cursor over the scale figure, and use your scroll wheel or trackpad to zoom in a bit. Did you zoom in like you expected, or did you zoom out? And did you zoom to the extent that you intended? Scroll wheels and trackpads can be finicky. In SketchUp Pro, you can invert the direction of your scroll zooming. To control the size of the cursor icon, you have to leave SketchUp and fiddle with your operating system mouse settings.

We heartily recommend customizing those computer preferences that help you see better in SketchUp and any other software you use.


 
Getting to know your mouse

This is where things get interesting. At this point, you should have SketchUp up and running, with a scale figure on your screen and a three-button mouse at your side. Now, here is the most important SketchUp technique that most people never figure out: Without selecting any tool, press and hold your mouse’s scroll wheel button while dragging the mouse. This is orbiting in SketchUp.

This mouse sequence is the primary way you set and reset your view in 3D space. It’s how you see in 3D. But many people switch manually from whatever tool they’re using to the dedicated Orbit tool. Tool switching costs brainpower and speed, but it doesn’t have to if you orbit with the scroll wheel orbit instead. This kind of orbiting is available whenever you want in SketchUp, even between the click-release and the click-to-finish operations that we talk about in the next section.

There’s more: While holding down that scroll wheel button on your mouse, use your other hand to press and hold the Shift key on your keyboard. Now you’ve toggled on the Pan tool, which lets you drag the view of your modeling window. Drag your mouse left and right, both holding the Shift key and releasing it to see the effect of switching between these two camera moves. Figure 1-4 shows how to pan and orbit.

We cover zooming with the scroll wheel in Chapter 2. For now, pat yourself on the back: You just turned on your light saber.


[image: Schematic illustration of mouse, using the scroll wheel to pan (left) and orbit (right).] 
FIGURE 1-4: Using the scroll wheel to pan (left) and orbit (right).







 
Finding your Zen with click-release, click-to-finish

Most people expect SketchUp to work with click-and-drag behavior. SketchUp tools work with click-and-drag, but you’ll quickly find that it’s harder to model accurately using this technique. We’ve actually observed people develop more physical stress by clicking and holding the left mouse button.

With a few exceptions that we cover where appropriate in the book, SketchUp tools work with click-release, click-to-finish. Just like orbiting (see “Getting to know your mouse” earlier in this chapter), the best thing you can do is bake in this behavior while you are getting familiar with SketchUp. If click-release, click-to finish trips you up at first, start by repeating the following exercise until it’s second nature: 

	Tap the L key on your keyboard to activate the Line tool.

	
With the tool visible in the modeling window, press your left mouse button.

We call this a click-release.


	
Without clicking again, move your mouse around the screen, and watch how SketchUp previews the line you are drawing.

Many of you will be so excited by this point that you will have already clicked again. (That’s okay; just press the Esc key and start over.) But if you do this right, you could go make a cup of coffee and come back ten minutes later to find SketchUp is still in the middle of drawing this line.


	
Before you click again, move the tip of the pencil icon to the place on your screen where the red, green, and blue lines meet.

This is called the model origin.


	
When you see your cursor display small crosshairs, click again to finish the line.

This is the click-to-finish.



This is a simple exercise, but in our experience, it will take great intention for you to extend it to the way you use SketchUp tools. Practice makes perfect!


 
Working faster with keyboard shortcuts

Although it’s good for you to be familiar with tool icons, a more efficient use of your RAM is to remember a tool’s default keyboard shortcut: the simple keyboard input for activating a tool.

We introduce and practice the following shortcuts throughout the book, so there’s no need to bust out index cards and remember them now. But for posterity, this baker’s dozen of shortcuts are those that we think are worth remembering: 


	Select (spacebar)

	Line (L)

	Eraser (E)

	Arc (A)

	Rectangle (R)

	Circle (C)

	Push/Pull (P)

	Paint Bucket (B)

	Move (M)

	Rotate (Q)

	Scale (S)

	Tape measure (T)

	Undo (Ctrl+Z) (Mac: ⌘  +Z)



Why are these shortcuts worth remembering? As with shortcuts in other software, activating tools with keystrokes is quicker than moving your mouse to a tool icon or menu location. Also, it takes more of your mental energy to remember where a tool icon or listing is. It costs you less time and less energy to remember the tool as a simple shortcut. And because you’ll be jumping between these tools almost constantly in SketchUp, knowing the keyboard shortcuts adds up to a lot of saved time and energy!

[image: Tip] In SketchUp for Web, if you need to look up a tool’s shortcut while modeling, just use Search to find the tool by its name. There’s even a shortcut for Search: Shift + /.


 
Introducing Undo

We have another suggestion for bringing Zen into your SketchUp practice: Accept that messing up is part of 3D modeling. Also, we assume that you’ll be figuring out how to think spatially in SketchUp while you’re figuring out how to use the program. Stumbling a bit is part of the experience for both beginners and advanced modelers. Here are a few ways that you can gracefully reverse and try again: 


	Use the Escape key. In between click-release and click-to-finish, Escape is essentially a way to interrupt anything you are currently doing in SketchUp and try again. It’s simple and predictable.

	Undo. There’s a reason that Undo makes our baker’s dozen of shortcuts worth remembering. Often, you won’t know until click-to-finish that the outcome isn’t what you wanted. Just remember the Undo shortcut Ctrl+Z (Mac: ⌘  +Z), and you can back out of the last 99 things you did in SketchUp.

	Use the spacebar: The spacebar is the keyboard shortcut for the Select tool, so switching to it between click-release and click-to-finish interrupts your modeling just like Escape, except that it switches tools. Spacebar is an easier key to feel out on your keyboard, though, so you may find it easier to reach and remember while modeling.

	Zoom Extents (Shift+Z): Especially while you’re figuring out how to use your mouse for orbiting, panning, and zooming, you will occasionally get lost in SketchUp. If you find yourself stuck in a wall or stuck in limbo far away from the origin, use Zoom Extents (Shift+Z), and your camera will zoom your view out to reveal everything in your model.







Taking the 10-Minute SketchUp Tour

Now we think you’re ready to take the 10-minute SketchUp tour: a rundown of the layout, tools, and utilities you’ll interact with in this book. Throughout this section, please refer to Figure 1-1 if you use a desktop version or Figure 1-2 if you use SketchUp for Web. 


	Modeling window: See the big area in the middle of your computer screen? That’s your modeling window. You build your model here, and your modeling window always shows a 3D view of your model, even if you’re looking at it from the top or side. Key features of the modeling window are the model axes: three green, red, and blue lines that help define the directional space of your model.

	Menu bar (Desktop only): If you’ve used a computer in the past 30 years, the menu bar is nothing new. Each menu contains a long list of options, commands, tools, settings, and other goodies that pertain to just about everything you do in SketchUp. We generally refrain from pointing you to the menu bar to find things, because that requires that you remember the name of a tool, the menu it lives on, and where on the menu it is. Nevertheless, we expect you’ll be using the menu bar throughout the book.

	Menu (web only): In SketchUp for Web, you will be using the menu a lot less to find tools but just as much to open files, save copies using Save As, and change settings.

	Search (web only): A recent addition to the SketchUp interface is this quick way to find and activate tools and look up shortcuts. If you’re using the web version (it’s not available in SketchUp Pro yet), you’ll find this really handy when you start learning tools and utility settings that you don’t use that often or have a hard time remembering.

	Toolbar: Click a toolbar button to activate a tool or command. You’ll start to use tool icons naturally while using SketchUp. In desktop versions, you can customize your toolbar setup to show tools you use most often, or to not show those tools whose shortcuts you’ve remembered. In the web version, similar tools are nested together in the toolbar. So when you click the Rectangle tool icon, you’ll switch to the Rectangle tool but also see the other shape-drawing tools available to you. Similarly, the Tape Measure tool contains other tools for measuring and labeling things.

	Large toolset (desktop only): The large toolset contains most of the tool icons for the commands we use in the book. The large toolset is not pictured in Figure 1-1 because we think it’s better to turn off the Large Toolset and attempt to use core commands by shortcuts. But if you prefer a visual reference for tool icons, you may prefer leaving the Large Toolset on to have all the tools handy all the time. You can can control its visibility by choosing View ⇒ Toolbars (Mac: View ⇒ Tool Palettes).

	Status bar: Consider this your SketchUp dashboard. The status bar provides helpful information about the tool you are currently using. It’s important to check the status bar for reminders about modifier keys: keystrokes that you use in combination with certain tools to perform additional functions. Soon enough, you’ll know how to copy by using the Move tool with a modifier key. You’ll definitely forget this key, and when you do, the place to look is the status bar. The status bar also relays step-by-step instructions for the tool’s operation, but you may be better off using the Instructor (see the nearby sidebar “Meet the Instructor”).

	Utility panels (desktop only): Before long you’ll start to interact with utilities — things like colors and display settings — that are generally organized on the right side of your SketchUp window. In desktop versions, you control which utility settings are visible via the Window menu. In more recent PC versions of SketchUp Pro, you can manage the default tray of utilities: Choose Window ⇒ Manage Trays, and use the Manage Trays dialog box to reconfigure what you do (or don’t) see here. On a Mac, utilities look like dialogs except that they’re neatly collapsible, and you can stack them aside in tidy trays when you are not using them.

	Utility panels (web only): In the web version, all utility panels — for stuff like saving model views or libraries of model textures — are organized on the right side of the screen, accessible by their icons. Opening a utility panel slides open a larger interface where you can access one or multiple panels. Use the X next to a panel name to close it, or use the arrow icon at the top right of the panel to hide the utilities you are currently using.

	Measurements box: You use this box all the time as you model, but you’ll never need to touch it. Depending on what you’re doing, this box displays information about what you’re modeling or enables you to specify a precise length, angle, or other measurement while modeling. Chapters 2 and 3 help you understand all that this little unassuming box can do.

	Context (shortcut) menus: Whenever you have something selected in SketchUp, you can right-click your selection to reveal a shortcut menu of commands and options. These are always relevant to whatever you right-clicked, so the contents of each menu are different. If you decided to proceed without a mouse, you can still right-click a trackpad, usually by using two separated fingers.

 

MEET THE INSTRUCTOR
 
We’d be flattered if you chose to scan this book’s index whenever you need a refresher on how a SketchUp tool works, but you may be better off opening the Instructor panel. The Instructor (see the figure) does only one thing: It shows you how to use whatever tool happens to be activated. We recommend closing the Instructor when you don’t need it. (There will be less visual noise on your screen.) You can open it any time by clicking its right-pointing arrow in the default tray or, on a Mac, choosing Window ⇒ Instructor. In the web version, the Instructor is the graduate icon, which is third from the top on the right side. 


[image: Snapshot of the working of SketchUp tool and using the instructor panel.] 








The SketchUp Frame of Mind

Now that you’ve begun to orient yourself to the SketchUp workspace, it’s time to get your head space ready. No computer tips here.

Imagine a cube. How would you draw it with a pencil? Even if you have very little experience drawing, we bet that you can visualize a way to draw it. Now imagine a sphere: How might you draw that? Drawing the sphere is harder to imagine, right?

Representing a sphere in SketchUp will be much quicker than drawing it by hand, but you still need to know how to think with SketchUp — and how its tools work — to imagine the sphere coming into being. Can you imagine a circle spinning its way into a sphere, as shown in Figure 1-5? Do you feel yourself exercising those new brain muscles?



[image: Schematic illustration of one of a few ways to imagine a sphere in SketchUp: a circle rotating in place.] 
FIGURE 1-5: One of a few ways to imagine a sphere in SketchUp: a circle rotating in place.






In Chapters 2 and 3, you’re going to leap with wild abandon into this new mind space. Our last piece of setup advice is to take it easy on yourself. Remember, you’re not just using the Line tool, but also using your imagination in a new way. With this book, you are going to earn that superpower.




   

Chapter 2

Getting a Running Start

IN THIS CHAPTER

[image: check] Starting at the right place in SketchUp

[image: check] Building a simple model

[image: check] Changing the way the model looks

[image: check] Exporting a JPEG file that you can email



If you can’t wait to get your hands dirty (so to speak), you’ve come to the right chapter. Here, we help you make a simple model step by step, spin it around, paint it, and even apply styles and shadows. You don’t need to read another word of this book to be able to follow along, although we do refer you to chapters where you can find out more. Above all, following along with the basic project in this chapter can help you understand how SketchUp’s basic features work together and enable you to produce a knockout model in no time!

So what are you going to build? Perhaps a doghouse. The nice thing about doghouses is that they’re a lot like people houses in the ways that count: They have doors and roofs, and just about everybody has seen one.

[image: Remember] One last thing: Just about every other piece of this book is written so that you can jump around to the bits you need; you don’t have to follow a particular order. This chapter is the exception. If you want to follow along, start on this page and work your way to the end. Otherwise, the steps just won’t make sense.



Making a Quick Model from Scratch

It’s time to fire up SketchUp and create a new model. In desktop versions, click the thumbnail image for the Simple Template in the Welcome window that appears when you start SketchUp (see Figure 2-1). In the web version, click Create New, and choose the units of measurement you prefer.



[image: Snapshots depict the desktop Welcome screen (left) and the web Welcome screen (right).] 
FIGURE 2-1: The desktop Welcome screen (left) and the web Welcome screen (right)






So, you have SketchUp up and running, you have some idea of what it does and how it works, and you’re probably just itching to give it a try. Let’s start with an 80-storey high-rise office tower. Okay, maybe that’s a little ambitious for your first attempt. Instead, follow these steps to build a doghouse:

[image: Tip] It’s a good idea to save your new model before you even start working on it. Check out “SketchUp Crashed and You Lost Your Model” in Chapter 14 to find out why. 

	
Delete the scale figure on your screen.

The scale figure is there to give you an idea of your model size, but for many exercises in this book, you won’t need it. To delete the scale figure, first activate the Select tool (spacebar); then click the scale figure and tap the Delete key on your keyboard.



	[image: 9781119617938-ma002] Draw a rectangle on the ground.
Use the Rectangle tool (tap the R key) to draw a rectangle by doing the following: 

	Click once to place one corner on the left side of your screen.

	Click again to place the opposite corner on the right side of your screen.


[image: Remember] Most of the time, you should not drag the cursor in SketchUp. Click the first point, release the mouse button, move to the next location, then click and release the mouse button. In Chapter 1 we referred to this as “Click-release, click-to-finish.”

You’re in a 3D perspective, or view of the world, so your rectangle looks more like a diamond; 90-degree angles don’t look like 90-degree angles in perspective. Figure 2-5 shows what you should aim for in this step.

[image: Tip] Are you modeling a doghouse for a Chihuahua or a Great Dane? For a mouse or an elephant? As you move your mouse, the Dimensions box shows you the size of the rectangle. Don’t worry; we’ll cover how to model precisely before too long.

[image: Tip] It’s important to draw the right kind of rectangle for this example (or for any model you’re trying to create in perspective view), so try it a few times until it looks like the rectangle in Figure 2-2. To go back, use the Undo (Ctrl+Z) shortcut we cover in Chapter 1. You can go back as many steps as you like.


[image: Schematic illustration of drawing a 3D rectangle on the ground.] 
FIGURE 2-2: Draw a 3D rectangle on the ground.







	[image: 9781119617938-ma003] Start the Push/Pull tool, and extrude your rectangle into a box by clicking the rectangle and then clicking again somewhere above the rectangle.
The Dimensions box in the lower-right corner (formerly labeled Distance) shows how far you have pulled the top of the box up. Are you making a house for a snake or a giraffe? At this point, your model should look like Figure 2-3; if it doesn’t, use Push/Pull again to make your box look about the right height.

[image: Tip] If you’re happily pushing/pulling away on your box and everything suddenly disappears, you pushed/pulled the top of your box all the way to the ground. Just press Ctrl+Z (Mac: ⌘  +Z) to undo and keep going.


	[image: 9781119617938-ma004] Start the Line tool, and draw two diagonal lines for your roof, as shown in Figure 2-4.
Below is a step-by-step explanation of how to draw the lines. Remember: click-release, click-to-finish. Don’t hold your mouse button down while drawing. 

	
Click the midpoint of the top of your box’s front face to start your line.

You know you’re at the midpoint when you see a small, light blue dot and the word Midpoint appears. In SketchUp, these tips are called inferences. Move slowly to make sure that you see the Midpoint inference.


[image: Schematic illustration of using the Push/Pull tool to extrude the rectangle into a box.] 
FIGURE 2-3: Use the Push/Pull tool to extrude your rectangle into a box.







	
Click again somewhere along the left side edge of your box's front face to end your line.

Wait until you see a red On Edge inference before you click; if you don’t, your new line won’t end on the edge where it needs to be.


	
Start a second line.

Move your mouse toward the opposite edge. As you move your mouse to the right, also move it up and down a bit, and observe how sometimes it shows a dotted red line back to the left end of the previous line. You’re at the correct location when you can see a small red square and the dotted red line at the same time. This means that you have an inference to the edge, and you’re horizontal (remember, this is a perspective view) from the previous line. Click and release your left mouse button to start a new line at this point.


	
End the second line.

Move your mouse up and to the left. Click your left mouse button when you see a green Endpoint inference dot.




[image: Schematic illustration of drawing two diagonal lines that will become the peaked roof.] 
FIGURE 2-4: Draw two diagonal lines that will become your peaked roof.







	
Push/pull the triangles away to leave a sloped roof.

Use the Push/Pull tool (the same one you use in step 3) to get rid of the triangular parts of your box, leaving you with a sloped roof. Have a look at Figure 2-5 to see this in action and then follow these steps: 

	Start the PushPull tool and then click the right triangular face to start the push/Pull operation.

	Move your cursor to the right to push the triangle as far as it will go (so that it's even with the end of your box).

	Click the triangle again to end the push/pull operation and make the triangular face disappear.

	Still using the Push/Pull tool, double-click the left triangular face to repeat the previous push/pull operation, making that face disappear as well.


[image: Tip] Did you notice that each tool stayed active until you started using another? After you completed the first line, the Line tool was still active, and after the first push/pull, the Push/Pull tool was still active.


[image: Schematic illustration of using the Push/Pull tool to form a peaked roof on the box.] 
FIGURE 2-5: Use the Push/Pull tool to form a peaked roof on your box.







	
Draw a rectangle on your front face.

Switch back to the Rectangle tool (which you used in step 2), and draw a rectangle on the front face of your pointy box. Make sure that the bottom of your rectangle is flush with the bottom of your box by watching for the red On Edge inference to appear before you click. Figure 2-6 shows what your model looks like when you’re done.

[image: Tip] Using the Rectangle tool is a two-step process: You click to place one corner and then click again to place the opposite corner. Avoid drawing lines and shapes by dragging your cursor. In SketchUp, doing so makes modeling more difficult. Practice clicking to start an operation, such as drawing a rectangle, and clicking again to stop.


[image: Schematic illustration of a rectangle drawn on the front of the pointy box.] 
FIGURE 2-6: A rectangle drawn on the front of your pointy box.







	[image: 9781119617938-ma005] Draw an arc on top of the rectangle you just drew.
Tap the A key on your keyboard to start the 2 Point Arc tool to draw an arc on top of your rectangle, as illustrated in Figure 2-7. Follow these steps to draw an arc: 

	Click the upper-left corner of the rectangle to place one endpoint of your arc. Make sure that you see the green Endpoint inference before you click.

	Click the upper-right corner of the rectangle to place the other endpoint of your arc.

	Move your cursor up to bow out the line you're drawing into an arc and then click when you’re happy with how the arc looks. If you want the arc ends to be tangent to the rectangle sides then watch for the “half circle” blue diamond Tangent inference.



[image: Schematic illustration of drawing an arc on top of your rectangle.] 
FIGURE 2-7: Draw an arc on top of your rectangle.







	[image: 9781119617938-ma006] Start the Eraser tool and then click the horizontal line between the rectangle and the arc to erase that line.

	
Push/pull the doorway inward.

Use the Push/Pull tool (which you’re an old hand with by now) to push in the “doorway” face you created in steps 6 through 8 just a bit.

[image: Remember] Use the Push/Pull tool by clicking a face to start, moving your cursor to push/pull it in or out, and clicking again to stop.


	
Erase the horizontal line at the bottom of the doorway by clicking it with the Eraser tool.

This makes the line (and the whole face above it) disappear. Figure 2-8 shows what your finished doghouse looks like.





[image: Schematic illustration of creating the door opening by erasing its bottom edge.] 
FIGURE 2-8: Create the door opening by erasing its bottom edge.






For a more detailed introduction to drawing lines and working with midpoints, angles, and more, flip to Chapter 3.

Okay, it’s time for a coffee break. But first, be sure to save your model.



Slapping On Some Paint

We have an ulterior motive for getting you to paint your doghouse: To color it, you first have to understand how to spin it around. Moving around your model is the most important skill to develop when you’re first figuring out SketchUp.

Run through these steps to apply colors (and textures) to the faces in your model and to find out about moving around while you’re doing it: 

	[image: 9781119617938-ma007] Click the Paint Bucket (B) tool on the toolbar.
This automatically opens the Windows and Mac versions of the Materials panel, as shown in Figure 2-9.


[image: Snapshots depict the materials panel in Windows (left) and on a Mac (right).] 
FIGURE 2-9: The Materials panel in Windows (left) and on a Mac (right).







	
Click a color or texture you like.

When you do, you fill the Paint Bucket (B) tool with your chosen material.

[image: Tip] If the Materials panel is already open, you can skip step 1. Selecting a material automatically launches and fills the Paint Bucket (B) tool.

[image: Tip] If you don’t see a color or texture you like, click the down arrow for the drop-down menu (refer to Figure 2-9) to see a list of 16 categories of materials, colors, and patterns.


	Paint some of the faces in your model by clicking any face with the Paint Bucket (B) tool.

	
Switch materials.

Choose another material from the Materials panel by clicking it.


	
Paint the rest of the faces you can see.

Loop through steps 2 to 4 for as long as you like. Finding the Materials panel in SketchUp is like getting a brand-new box of crayons when you were little (you know, the big box, with the built-in sharpener).


	[image: 9781119617938-ma008] Start the Orbit tool by tapping the O key on your keyboard.

	
Move the cursor to somewhere on the left side of your screen, press and hold your left mouse button, and drag your cursor over to the right (see Figure 2-10).

Your model spins, or orbits, around a point in the center of your screen. Orbit some more, just to get the hang of it. You can also Orbit up and down to see the top or bottom of your model. Note: This is one of the few operations in which you press and hold the mouse button to drag it to a new location.

[image: Tip] If you’re orbiting, you’ve dragged your cursor over as far as it will go, and you haven’t orbited as much as you wanted to, don’t fret. Just release the mouse button, move your cursor to where it was when you started orbiting, and orbit some more by clicking and dragging. To see what you want to see, you usually need a bunch of separate drags (separate orbits, we guess).

Even better, the Orbit tool can be used in the middle of using any other tool. Tapping the Escape key returns you to the current tool.


[image: Schematic illustration of choosing the Orbit tool, and drag the cursor to spin the model.] 
FIGURE 2-10: Choose the Orbit tool, and drag your cursor to spin your model.







	Release your mouse button when you’re done.

	[image: 9781119617938-ma009] Zoom in and out if you need to by tapping the Z key to start the Zoom tool and dragging your cursor up and down in your modeling window.
Dragging up zooms in, and dragging down zooms out.

[image: Tip] You can also zoom in and out by rolling the scroll wheel on your mouse. If you have a Mac with a Magic Mouse, the scrolling gestures work like a scroll wheel. Okay, now here’s the magic part: You don’t have to actually start the Zoom tool. You can use the mouse scroll wheel at any time while you’re using any other tool.


	[image: 9781119617938-ma010] If needed, move around in two dimensions with the Pan tool by tapping the H key (no, that isn’t a misprint) and then clicking and dragging the Pan cursor (a hand) inside your modeling window.
Using the Pan (H) tool, you can slide your view around inside your modeling window without spinning it or making it look bigger or smaller. You can pan sideways, up/down, or diagonally.


	
Use the Orbit, Zoom, Pan (H), and Paint Bucket (B) tools to finish painting your doghouse.

Now that you know how to move around your model, try painting the different parts these specific colors, as shown in Figure 2-11: 


	Paint the exterior walls red-brown.

	Paint the roof light blue.

	Paint the interior yellow-orange.






[image: Schematic illustration of the orbit (spin) the model to paint all the faces.] 
FIGURE 2-11: Orbit (spin) your model to paint all the faces.






[image: Tip] [image: 9781119617938-ma013] When you’re just starting, you can easily become a little lost with the navigation tools (Orbit, Zoom, and Pan H). If you find yourself in a pickle, just press Shift+Z. SketchUp zooms in or out and pans as required so that everything you have created just fits in your screen, as shown in Figure 2-12.

[image: Tip] Here’s a slightly cruel April Fools’ joke for your co-workers: If they leave their computers unattended, slip in and draw a very small object way off to one side. When they do a Zoom Extents, their model will seem to disappear. They’ve got a good sense of humor, right?



[image: Schematic illustration of zooming extents any time in which one cannot figure out where the model went.] 
FIGURE 2-12: Use Zoom Extents any time you can’t figure out where your model went.






For more details about using SketchUp’s drawing tools, Chapter 3 walks you through many basic drawing and modeling skills. After you’re comfortable with the techniques in Chapter 3, explore the details on modeling buildings in Chapter 4 and the tips on modeling parts and shapes in Chapter 6.



Giving Your Model Some Style

SketchUp Styles enable you to change your model’s appearance — the way it’s drawn, basically — with just a few mouse clicks. SketchUp also comes with a library of premade styles that you can use without knowing anything about how they work. (After you discover how styles work, you might want to try creating your own, as explained in Chapter 10.)

If the Materials panel is still open, then you probably want to close it before proceeding.

Follow these steps to try a couple of styles on your doghouse: 

	
Open the Styles panel by clicking the right-pointing arrow next to its name in the Default Tray (Mac: Choose Window ⇒ Styles; Web: utility tray on the right).

By default, you see the Select tab, which is where you can browse and select styles. At the top of the Select tab, a drop-down list enables you to open different style libraries. The styles in each library appear in the bottom half of the Select tab.


	From the drop-down list, choose the Assorted Styles library, as shown in Figure 2-13.

	
Click a style to see how it changes your model’s whole appearance.

You can click through the styles to see what your options are. Figure 2-14 shows the doghouse with a few styles applied; can you figure out which ones?


	[image: 9781119617938-ma011] Go back to your original style by clicking the In Model icon and selecting the Architectural Design style.
In the Styles panel, clicking the In Model icon displays a list of all the styles you’ve applied to your model. The Architectural Design style should be first in the list. Chapter 10 explains styles in more detail.





[image: Snapshot of the assorted Styles library is a sampler of ready-mixed SketchUp styles.] 
FIGURE 2-13: The Assorted Styles library is a sampler of ready-mixed SketchUp styles.







[image: Schematic illustration of the doghouse with four very different styles applied to it.] 
FIGURE 2-14: The same doghouse with four very different styles applied to it.








Switching On the Sun

You’re about to use what we consider to be one of SketchUp’s best features: Shadows. When you turn on Shadows, you’re activating SketchUp’s built-in sun. The shadows you see in your modeling window are accurate for whatever time and location you set.

Ready to shine light on your model? Follow these steps: 

	Use Orbit, Zoom, and Pan (H) to get an aerial, three-quarters view of your doghouse, sort of like the view shown in Figure 2-15.

	
Click the right-pointing arrow next to the Shadows panel in the default tray (Mac: Choose Window ⇒ Shadows. Web: Search for Shadows).

You see the Shadows Settings panel (see Figure 2-15).


	[image: 9781119617938-ma039] Click the Show/Hide Shadows button (in the upper-left corner) to toggle on the sun.
Your doghouse casts a shadow on the ground.


	
Move the Time slider back and forth.

Changing the time of day means that you’re moving SketchUp’s sun around in the sky. When the sun moves around, so do your shadows. Okay, technically Galileo was right, and it’s the Earth that moves, but for our purposes we’ll go with Einstein, who asked the conductor, “When does the Philadelphia station stop beside this train?” It’s all relative. To see accurate shadows, you also have to geolocate your model, which is a fancy way of saying that you give it a latitude. Chapter 10 explains how to create accurate shadow studies.





[image: Snapshot of the time and date to see the shadows change.] 
FIGURE 2-15: Change the time and date to see the shadows change.








Sharing Your Masterpiece

Now that you have a model that looks about the way you want it to, you probably want to show it to someone. The easiest way is to export a JPEG (web: PNG) image that you can attach to an email. Follow these steps, and you’re on your way: 

	Navigate around (using Orbit, Zoom, and Pan) until you like the view of your model that you see in your modeling window.

	Choose File ⇒ Export ⇒  2D Graphic (Web: Menu  ⇒  Export  ⇒  PNG).

	In the Export dialog box that opens, choose to export the graphic as a JPEG.

	Pick a location on your computer, and give your exported image a name.

	Click the Export button to create a JPEG image of what’s visible in your modeling window.


Exporting a JPEG file is just one way to share models. To find out about all your options, see Part 4, which explains how to share your model on the SketchUp 3D Warehouse, as a printout, as an image or animation, as part of a multipage document, or as a slick presentation that will (we hope) impress all your friends.




   

Chapter 3

Establishing the Modeling Mindset

IN THIS CHAPTER

[image: check] Understanding edges and faces

[image: check] Representing three dimensions on a two-dimensional screen

[image: check] Inferencing like a pro

[image: check] Warming up with SketchUp

[image: check] Lining up entities with guides

[image: check] Adding color and texture to your work



When you were learning how to drive a car, you probably didn’t just get behind the wheel, step on the gas, and figure it out as you went along. (If you did, you probably have bigger things to worry about than getting started with SketchUp.) The point is, knowing some basic concepts can make your first few hours with SketchUp much more productive and fun.

So here’s the deal: This chapter has three main parts: 


	The first part talks about edges and faces — the basic stuff that SketchUp models are made of.

	The second part explains how SketchUp enables you to model in 3D (three dimensions) on a 2D (flat) surface — namely, your computer screen. Understanding how SketchUp represents depth is everything when making models. If you’ve never used 3D modeling software before, pay close attention to the middle part of this chapter.

	The final part of this chapter is about the things you need to do all the time — things like navigating around your model, drawing lines, selecting things, and working with accurate measurements.





All about Edges and Faces

In SketchUp, everything is made up of one of two kinds of elements: edges or faces. They’re the basic building blocks of every model you’ll ever make. It’s kind of like ancient times, when everything was made of just earth, air, fire, and water.

[image: Remember] Collectively, the edges and faces in your model are geometry. Other modeling programs have other kinds of geometry, but SketchUp is pretty simple. That’s a good thing: You have less to keep track of.

The drawing on the left in Figure 3-1 is a basic cube drawn in SketchUp; it’s composed of 12 edges and 6 faces. The model on the right is a lot more complex, but the geometry’s the same; it’s all just edges and faces.



[image: Schematic illustration of the sketchUp models which are made from edges and faces.] 
FIGURE 3-1: SketchUp models are made from edges and faces.






Living on the edge

Edges are lines. You can use lots of tools to draw them, erase them, move them, hide them, and even stretch them. Here are some things you ought to know about SketchUp edges: 


	Edges are always straight. Not only is everything in your SketchUp model made up of edges, but also, all those edges are perfectly straight. Even arcs and circles are made of small straight-line segments, as shown in Figure 3-2.

	Edges don’t have a thickness. This one’s a little tricky to get your head around. You never have to worry about how thick the edges in your model are because that’s not how SketchUp works. Depending on how you choose to display your model, your edges may look like they have different thicknesses, but your edges themselves don’t have a built-in thickness.

	Just because you can’t see the edges doesn’t mean they’re not there. Edges can be hidden so that you can’t see them; doing so is a popular way to make certain forms. Take a look at Figure 3-3. On the left is a model that looks rounded. On the right, the hidden edges are visible as dashed lines. See how even surfaces that look smoothly curved are made of straight edges?




[image: Schematic illustration of the curved lines which are made up of straight edges.] 
FIGURE 3-2: Even curved lines are made up of straight edges.







[image: Schematic illustration of the organic shapes and curvy forms which are made up of straight edges.] 
FIGURE 3-3: Even organic shapes and curvy forms are made up of straight edges.








Facing the facts about faces

Faces are surfaces. If you think of SketchUp models as being made of toothpicks and paper (which they kind of are), faces are basically the paper. Here’s what you need to know about faces: 


	You can’t have faces without edges. To have a face, you need to have at least three coplanar (on the same plane) edges that are connected. In other words, a face is defined by the edges that surround it, and those edges all have to be on the same flat plane. Because you need at least three straight lines to make a closed shape, faces must have at least three sides. There’s no limit to the number of sides a SketchUp face can have, though. Figure 3-4 shows how faces can disappear when you erase an edge that defines one or more faces. We started with the model on the left and deleted the edge that completed both the top face and one of the side faces. The result, shown on the right, is that both of those faces disappeared.

	Faces are always flat. In SketchUp, even surfaces that look curved are made of multiple, flat faces. In the model shown in Figure 3-5, what look like organically shaped surfaces (on the left) are really just lots of smaller faces (on the right). Think of the many small mirrors that make up the surface of a nightclub disco ball. To make a bunch of flat faces look like one big, curvy surface, the edges between them are smoothed. You find out about smoothing edges in Chapter 6.

	Just like edges, faces don’t have any thickness. If faces are a lot like pieces of paper, they’re infinitely thin pieces of paper; they don’t have any thickness. To make a thick surface (say, a 6-inch-thick wall), you need to use two faces side by side. In SketchUp, even a solid concrete wall will be hollow.




[image: Schematic illustration of three coplanar edges to make a face.] 
FIGURE 3-4: You need at least three coplanar edges to make a face.







[image: Schematic illustration of flat faces, even the ones that make up larger, curvy surfaces.] 
FIGURE 3-5: All faces are flat, even the ones that make up larger, curvy surfaces.








Understanding the relationship between edges and faces

Now you know that models are made from edges and faces, you’re most of the way to understanding how SketchUp works. Here’s some information that should fill in the gaps: 


	Every time SketchUp can make a face, it will. There’s no such thing as a “Face tool” in this software; SketchUp just automatically makes a face every time you finish drawing a closed shape out of three or more coplanar edges. Figure 3-6 shows this in action: As soon as a line connects the last edge to the first one, SketchUp creates a face.

[image: Schematic illustration of sketchUp automatically to make a face whenever the user create a closed loop of coplanar edges.] 
FIGURE 3-6: SketchUp automatically makes a face whenever you create a closed loop of coplanar edges.







	You can’t stop SketchUp from creating faces, but you can erase them if you want. If SketchUp creates a face you don’t want, just right-click the face and either choose Erase from the shortcut menu or tap the Delete key on your keyboard. That face is deleted, but the edges that defined it remain, as illustrated in Figure 3-7.

	Retracing an edge re-creates a missing face. If you already have a closed loop of coplanar edges but no face (because you erased it, perhaps), you can redraw one of the edges to make a new face. Just use the Line tool to trace over one of the edge segments, and a face reappears, as shown in Figure 3-8.

	Drawing an edge all the way across a face splits the face in two. When you use the Line tool to draw an edge from one side of a face to another, you cut that face in two. The same thing happens when you draw a closed loop of edges, such as a rectangle on a face: You end up with two faces, one “inside” the other. In Figure 3-9, we split a face in two with the Line tool and then extruded one face a little bit with the Push/Pull tool.

[image: Schematic illustration of deleting a face without deleting the edges that define it.] 
FIGURE 3-7: You can delete a face without deleting the edges that define it.







[image: Schematic illustration of retracing any edge on a closed loop to tell SketchUp to create a new face.] 
FIGURE 3-8: Just retrace any edge on a closed loop to tell SketchUp to create a new face.







[image: Schematic illustration of splitting a face with an edge and then extruding one of the new faces.] 
FIGURE 3-9: Splitting a face with an edge and then extruding one of the new faces.







	Drawing an edge that crosses another edge splits both edges where they touch. In this way, you can split simple edges you draw with the Line tool, as well as edges created when you draw shapes like rectangles and circles. Most of the time, this autoslicing is desirable, but if it’s not, you can always use groups and components to separate your geometry. Flip to the first part of Chapter 5 for more information.

 




Drawing in 3D on a 2D Screen

For computer programmers, drawing 3D objects on your screen is a difficult problem. You wouldn’t think it’d be such a big deal; after all, people have been drawing in perspective for a very long time. If Fillipo Brunelleschi could figure it out 500 years ago, why should your computer have problems?

The thing is, human perception of depth on paper is a trick of the eye. It isn’t really an optical illusion; it just looks like one. And of course, your computer doesn’t have eyes that enable it to interpret depth without thinking about it. You need to give your computer explicit instructions. In SketchUp, this means using drawing axes and inferences, as we explain in the sections that follow.
 

[image: Remember] DON’T WORRY ABOUT DRAWING IN PERSPECTIVE
 
Contrary to popular belief, modeling in SketchUp doesn’t involve drawing in perspective and letting the software figure out what you mean. This turns out to be a very good thing, for two reasons: 


	Computers aren’t very good at figuring out what you’re trying to do. This has probably happened to you: You’re working away at your computer, and the software you’re using tries to “help” by guessing what you’re doing. Sometimes it works, but most of the time it doesn’t. The word processing software we all use is a good example. Eventually, the computer’s bad guesswork gets really annoying. Even if SketchUp could interpret your perspective drawings, you’d probably spend more time correcting its mistakes than actually building something.

	
Most people can’t draw in perspective anyway. Even if you’re one of the few folks who can, you know darn well that most people couldn’t draw an accurate 3D view of the inside of a room if their lives depended on it. Drawing just isn’t one of the things people are taught, unfortunately. So even if SketchUp did work by turning your 2D perspective drawings into 3D models (which it most certainly doesn’t), the vast majority of those who “can’t draw” couldn’t use it. And that would be a shame because building 3D models is a real kick.
SketchUp defaults to displaying models in a perspective view because it’s commonly used for architectural designs. Real buildings are usually big enough that we can see the perspective effect. You can always switch to a parallel view (useful for 2D plans and other diagrams), which we cover in “Switching to a 2D view” in Chapter 4.




Giving instructions with the drawing axes

No, drawing axes are not used to turn your design into firewood. See the three colored lines that cross in the SketchUp modeling window? These are the drawing axes, and they’re the key to understanding how SketchUp works. Simply put, you use SketchUp’s drawing axes to figure out where you are and where you want to go in 3D space. When you’re working with the color axes, you need to keep three important things in mind: 


	The red, green, and blue drawing axes define 3D space in your model. If you were standing at the spot where all three axes meet — the axis origin — the blue axis would run vertically, passing through your feet and head. The red and green axes define the ground plane in SketchUp; you’d be standing on top of them. The axes are all at right angles to one another and extend to infinity in both directions from the origin. In most computer-aided design (CAD) software, the red, green, and blue axes are referred to as X, Y, and Z, respectively.

	When you draw, move, or copy something parallel to one of the colored axes, you’re working in that color’s direction. Take a look at Figure 3-10. In the first image, we’re drawing a line parallel to the red axis, or drawing “in the red direction.” You know a line is parallel to the red axis because the line turns red and a little flag pops up to let you know. In the second image, we’re moving a box parallel to the blue (“up”) axis, or “moving in the blue direction.” The dotted blue line appears to tell you so.

	
The colored drawing axes help you tell SketchUp what you mean. In Figure 3-11, moving the cylinder in the blue direction and the green direction both involve moving the cursor up. The drawing axes help SketchUp know whether you want to move the cylinder up in space (above the ground) or back in space.

[image: Remember] When you work in SketchUp, you use the colored drawing axes all the time. They’re not just handy, but also what make SketchUp work. They make modeling in SketchUp quick, accurate, and relatively intuitive. As you model, all you have to do is make sure that you’re working in your intended color direction: Line up your geometry with the appropriate axis, and watch the visual cues that tell you what direction you’re working in.


 


Keeping an eye out for inferences

If you’ve spent any time fiddling with SketchUp, you’ve noticed all the little colored circles, squares, dotted lines, yellow screen tips, and other doodads that show up as you move your cursor around your modeling window. All this stuff is referred to collectively as SketchUp’s inference engine, and its sole purpose is to help you while you build models. Luckily, it does. Without inferences (the aforementioned doodads), SketchUp wouldn’t be very useful.



[image: Schematic illustration of visual cues tells when drawing or moving geometry parallel to a drawing axis.] 
FIGURE 3-10: Visual cues tell you when you’re drawing or moving geometry parallel to a drawing axis.







[image: Schematic illustration of the axes that helps to create 3D models on a 2D screen.] 
FIGURE 3-11: The axes help you create 3D models on a 2D screen.






Point inferences

Generally, SketchUp’s inferences help you be more precise. Point inferences appear when you move your cursor over specific parts of your model. They look like little colored circles and squares, and if you pause for a second, a yellow label appears. The little green Endpoint inference, for example (which appears whenever your cursor hovers over the end of an edge), helps you accurately connect an edge that you’re drawing to the end of another edge in your model.

Figure 3-12 shows the point inferences that you use most often.



[image: Schematic illustration of pointing inferences that appear when hovering the cursor over key points and helps to draw accurately.] 
FIGURE 3-12: Point inferences appear when you hover your cursor over key points and help you draw accurately.






[image: Remember] In SketchUp, lines are called edges, and surfaces are called faces. Everything in your model is made up of edges and faces.


 
Linear inferences

As you’ve probably already noticed, color plays a big part in SketchUp’s user interface, or the way it looks. Maybe the best example is in the software’s linear inferences — the “helper lines” that show up to help you work more precisely. Figure 3-13 illustrates the important linear inferences, and here’s a description of what they do: 


	On Axis: When an edge you’re drawing is parallel to one of the colored drawing axes, the edge turns the color of that axis. In Figure 3-13, you see the On Red Axis inference.

	From Point: This one’s a little harder to describe. When a colored dotted line appears as you move your cursor, your cursor is “lined up” with the point at the other end of the dotted line. Naturally, the color of the From Point inference reflects the axis you’re lined up “on.” Sometimes, From Point inferences show up on their own, and sometimes you have to encourage them; see the section “Using inferences to help you model” later in this chapter for details.

	Perpendicular: When you draw an edge that’s perpendicular to another edge, the one you’re drawing turns magenta (reddish purple) unless it’s perpendicular to the red, green, or blue axes.

	Parallel: When the edge you’re drawing is parallel to another edge in your model, it turns magenta to let you know. You tell SketchUp which edge you’re interested in “being parallel to” by encouraging an inference. You can try this out by hovering over one edge and then starting to draw another with the Line tool.

	Tangent at Vertex: This one applies only when you draw an arc (using the Arc tool) that starts at the endpoint of another arc or an edge. When the arc you’re drawing is tangent to the other object, the one you’re drawing turns cyan. Tangent, in this case, means that the transition between the two arcs is smooth.




[image: Schematic illustration of SketchUp’s linear inferences to  align new geometry with existing geometry.] 
FIGURE 3-13: SketchUp’s linear inferences help you align new geometry with existing geometry.






[image: Tip] One of the most important inferences in SketchUp is one that you probably didn’t even realize was an inference: Unless you specifically start on an edge or a face in your model, you always draw on the ground plane by default. That’s right — if you just start creating stuff in the middle of nowhere, SketchUp just assumes that you mean to draw on the ground.




 
Using inferences to help you model

A big part of using SketchUp’s inference engine involves locking and encouraging inferences — sometimes even simultaneously. At first, these actions seem a little like that thing where you pat your head and rub your stomach at the same time, but with practice, they get easier. 


	Locking inferences: If you hold down the Shift key when you see any of the first four types of linear inferences described previously, that inference gets locked — and stays locked until you release Shift. When you lock an inference, you constrain whatever tool you’re using to work only in the direction of the inference you locked.

	Encouraging inferences: Sometimes, an inference you need doesn’t show upon its own. When this happens, you have to encourage it. To encourage an inference, hover your cursor over the part of your model you want to “infer” from and then slowly go back to whatever you were doing when you decided you could use an inference.



The following example illustrates how you might lock and encourage inferences to draw a 3D model. In Figure 3-14, suppose that you want to draw a line on the blue axis that’s parallel to the right-rear corner of the block, in the same plane as the rear face and as tall as the block. Here’s how you might use inferences to help you: 

	[image: 9781119617938-ma004] With the Line tool selected, encourage a From Point inference by hovering the cursor over the right-rear bottom corner of the block until you get an endpoint inference.

	
Now slowly move your cursor to the right, away from that corner, to encourage a From Point inference.

[image: Warning] Do not click that corner.

A dotted red line should trail from the pencil point back to the cube’s corner to indicate that you’re traveling parallel to the red axis. Press and hold the Shift key to lock the line in the red direction.


	Click to set the line’s starting point, release the Shift key, and then move the pencil up a bit, making sure it’s trailing a blue line.

	
Press and hold down the Shift key to lock the line in the blue direction as you draw the line.

The blue line inference becomes thicker to show that the line is locked in the blue direction.


	Move the cursor to the right-rear vertical edge of the cube while continuing to hold down the Shift key.

	When the inference to the Midpoint appears, click to set the endpoint of your new line.


Behold! You have a vertical line that meets all the specifications!

[image: Remember] Edges must lie in the same flat plane before a face can be made. Without inferences, it’s all too easy to create a series of edges that would do Escher proud. Even just three edges that appear to connect at their ends may not be connected when viewed from a different angle.


[image: Schematic illustration of the lock and encourage inferences while drawing new geometry in relationship to existing geometry.] 
FIGURE 3-14: Lock and encourage inferences as you draw new geometry in relationship to existing geometry.










Warming Up Your SketchUp Muscles

About eight SketchUp skills are useful every time you use SketchUp. Formal-education types would probably call them core competencies. Whatever you care to call these activities, we introduce them all in the following sections. Anytime you need a quick refresher, come back to this section.
 
Getting the best view of what you’re doing

Using SketchUp without learning how to orbit, zoom, and pan is like trying to build a ship in a bottle. In the dark. With your hands tied behind your back. Using chopsticks. Having just consumed the contents of the wine bottle. Get the picture?

[image: Remember] Fully half of modeling in SketchUp uses the Orbit, Zoom, and Pan (H) tools, which let you change your view so that you can see what you’re doing. Most people who try to figure out SketchUp on their own take too long to understand the importance of these navigation tools and spend hours squinting, grunting, and having an all-around miserable time trying to get at what they’re working on. The following sections help you avoid the headache (literally).
 
Going into orbit

[image: 9781119617938-ma008] Hold a glass of water in your hand. Now twist and turn your wrist around in every direction so that the water’s all over you and the rest of the room. Stop when the glass is empty. We think that’s a pretty memorable way to find out about the Orbit tool, don’t you?

Just as your wrist helps you twist and turn a glass to see it from every angle, think of using Orbit as the way to fly around your work. Figure 3-15 shows Orbit in all its glory.



[image: Schematic illustration of the Orbit tool which lets to view the model from any angle.] 
FIGURE 3-15: The Orbit tool lets you see your model from any angle.






[image: Tip] Press and hold down your mouse’s scroll wheel, and move your mouse around. See your model swiveling? Release the scroll wheel when you’re done. Using your mouse to orbit means that you don’t have to switch tools every time you want a better view, which saves you truckloads of time. You can even do this while you’re using most other tools.

[image: Remember] There’s a secret trick to effective orbiting: Your model twists, turns, and rotates about the center of your screen.


 
Zooming in and out

[image: 9781119617938-ma009] Hold your empty glass at arm’s length. Bring the glass rushing toward you, stopping just short of smashing you in the nose. Now throw the glass across the room, noticing how it shrinks as it gets farther away. That, in a nutshell, describes the Zoom tool. We couldn’t figure out why the glass was getting bigger, but then it struck us …

You use Zoom to get closer to (and farther from) your model. If you’re working on something small, you zoom in until it fills your modeling window. To see everything at once, zoom out. Figure 3-16 is a demonstration.



[image: Schematic illustration of using the Zoom tool to get closer to the action.] 
FIGURE 3-16: Use the Zoom tool to get closer to the action.






[image: Tip] As you’re drawing in SketchUp, you zoom in and out of your model all the time. The following tips make zooming quick and easy: 


	To zoom in and out, roll your mouse’s scroll wheel. When you stop scrolling, you stop zooming and revert to your active tool.

	As you scroll, SketchUp zooms in on your cursor. Position the cursor over whatever part of your model you want to see closer (or farther away).

	[image: 9781119617938-ma012] Use Zoom Extents to see everything. Click the Zoom Extents button on the toolbar to have your model fill the screen.




 
Just panning around

[image: 9781119617938-ma010] Using the Pan (H) tool is a lot like washing windows: You move the paper towel back and forth, but it stays flat and never gets any closer to or farther away from you. The Pan (H) tool is basically for sliding your model view around in your modeling window. To see something that’s to the right, you use the Pan (H) tool to slide your model to the left. It’s as simple as that.

[image: Tip] Here’s the best way to pan: Hold down your mouse’s scroll wheel button and then press and hold the left mouse button. When you do these things at the same time, your cursor temporarily turns into the Pan (H) tool, and you can move your mouse to pan. If it’s hard for you to hold down both the scroll wheel and the left mouse button, you can also hold down the scroll wheel and the Shift key.




 
Drawing and erasing edges with ease

Here’s the secret to modeling anything you want in SketchUp: Learn to use the Line tool without having to think too much about it. You use the Line tool to draw individual edges, and because SketchUp models are really just fancy collections of edges (carefully arranged, of course), anything you can make in SketchUp, you can make with the Line tool.

[image: Remember] SketchUp models are made up of edges and faces. Any time you have three or more edges that form a closed shape and are on the same plane, SketchUp creates a face. If you erase an edge that defines, or borders, a face, the face disappears too. Take a look at the section “All about Edges and Faces” earlier in this chapter for more information on the relationship between edges and faces.

Drawing edges is simple. Just follow these steps: 

	[image: 9781119617938-ma004] Start the Line tool.
Pressing the L key activates the Line tool.


	Click where you want your line to begin.

	
Move your cursor to the desired endpoint for your line, and click again to end.

As you move the cursor, notice how SketchUp stretches a rubber band back to the starting point. When you select the endpoint, the Line tool draws the line and then autorepeats, automatically starting a new line at the end of the previous one you drew.


	When you want the Line tool to stop drawing lines, tap the Esc key to snip the line at the last spot you clicked.


[image: Tip] SketchUp lets you draw lines in two ways: You can use the click-drag-release method or the click-move-click one. We highly recommend training yourself to click-move-click. You’ll have more control, and your hand won’t get as tired. When you draw edges by clicking and dragging your mouse (click-drag-release), you’re a lot more likely to “drop” your line accidentally. Because the Line tool draws only straight lines, think about using it less like a pencil (even though it looks like one) and more like a spool of sticky thread.

[image: 9781119617938-ma006] The Eraser tool is specifically designed for erasing edges. Activate it by pressing the E key and then click the edges you want to delete. You can also drag over edges with the Eraser, but that’s a little harder. To erase several edges at the same time, select them (selecting is explained in the upcoming section “Selecting what you mean to select”); then start the Eraser tool.
 

TURNING OFF AUTOREPEAT LINES
 
This feature is desktop-only. If you’re running the web app, jump ahead to the next topic.

Many SketchUp tools repeat automatically until you launch a different one. With the Line tool, after you pick two points to define an edge and then pick a third point, a second line is connected to the end of the first line to the new pick point. Depending on what you’re making and how you work, you may want to turn off the Line tool’s autorepeat behavior. To do so, follow these steps: 

	Choose Window ⇒ Preferences (Mac: SketchUp ⇒ Preferences).

	Choose the Drawing panel in the list on the left side of the Preferences dialog box.

	Clear the Continue Line Drawing check box.

	Close the Preferences dialog box.





Injecting accuracy into your model

Most of the time, you need to make sure that your model is accurate — that what you’ve modeled is precisely the size you intend it to be. In SketchUp, the key to accuracy is the Measurements box. This powerful little text box lives in the bottom-right corner of your SketchUp window.

Here are some things the Measurements box can do: 


	Make a line a certain length.

	Draw a rectangle a certain size.

	Push/Pull a face a certain distance.

	Change the number of sides in a polygon.

	Move something a given distance.

	Rotate something by a certain number of degrees.

	Make a certain number of copies.

	Divide a line into a certain number of segments.

	Change your field of view (how much you can see).



[image: Tip] Here’s what you need to know about the Measurements box: 


	You don’t have to click in the Measurements box to enter a number. This one’s a big one: SketchUp beginners often assume that they need to click in the Measurements box (to select it, presumably) before they can start typing. You don’t have to click it; just start typing, and whatever you type shows up in the box automatically. Whenever you’re drawing, the Measurements box “listens” for you to type something that controls your geometry’s precision.

	The Measurements box is context-sensitive. The box accepts values based on what you’re doing. If you’re drawing an edge with the Line tool, the box listens for a length; if you’re rotating a shape, the box listens for an angle.

	
You can set the default units for the Measurements box and override the default when necessary: 


	You don’t need to type a unit if you want to use the default unit. Perhaps you want a line you’re drawing to be 14 inches long. If inches are your default unit of measurement, just type 14 in the Measurements box and press Enter; SketchUp assumes that you mean 14 inches.

	Do type a unit if you want to override the default unit. If your default is inches, and you want to draw something 14 feet long, type 14', and press Enter. You can override the default unit of measurement by typing any unit you want. If you want to move something a distance of 25 meters in an Imperial file, type 25m and press Enter.

	You can change the default units in the Model Info dialog box. You can open this dialog box from the Window menu. Click Model Info, click the Units panel, and choose your new default unit from the drop-down menu. Sorry, only standard Imperial and metric units are available — no fathoms, no furlongs, no light-years.



[image: Tip] The default units are initially set by the template file that was used to start the drawing.


	Sometimes, the Measurements box does more than one thing. In certain circumstances, you can change the box’s mode (what it “listens for”) by entering a unit type after a number. When you draw a circle, for example, the default “value” in the Measurements box is the radius. If you type 6 and press Enter, a circle radius becomes 6 inches. But if you type 6s, you’re telling SketchUp that you want 6 sides (not inches), so your circle becomes a hexagon. If you type 6, press Enter, type 6s, and press Enter again, SketchUp draws a hexagon (a 6-sided circle) with a radius of 6 inches. Note that it’s an inscribed hexagon that fits exactly inside a 6-inch circle.

	The Measurements box lets you change your mind. As long as you don’t do anything after you press Enter, you can always type a new value and press Enter again. There’s no limit to the number of times you can change your mind.

	You can use the Measurements box during an operation. In most cases, you can use the Measurements box to be precise while you’re using a tool. Here’s how that works: 
	Click to start your operation (such as drawing a line or using the Move tool).

	
Move your mouse so that you’re going in the correct color direction, and be sure not to click again.

If you’re using the Line tool, and you want to draw parallel to the green axis, make sure that the edge you’re drawing is green (displays the green edge inference).


	
Without clicking the Measurements box, type the dimension you want.

The dimension appears in the box.


	Press Enter to complete the operation.



	You can also use the Measurements box after an operation. Doing so revises what you’ve just done. Suppose that you want to move a box, as shown in Figure 3-17, 5 meters in the red direction (parallel to the red axis). Here’s what you do: 
	With the Move tool, click the box to pick it up.

	Move the mouse until you see the red linear inference.

	
Type 5m, and press Enter.

The box is positioned exactly 5 meters from where you picked it up. After you see that placement, however, you realize that the box needs to move a little farther.


	
Type 15m, and press Enter.

The box moves another 10 meters in the red direction.


	Keep changing the box’s position until you’re happy (or bored).



	The Measurements box tells you what value or values it’s expecting. If you select the Line tool, the Measurements box tells you it’s listening for a length. Select the Move tool, and you see that the box is expecting a distance. This feature is great because remembering everything the box can do at any given moment is pretty difficult — even for experienced SketchUp modelers.








RESIZING EVERYTHING WITH THE TAPE MEASURE TOOL
 
Consider that you’ve been working away in SketchUp, not paying particular attention to how big anything in your model is, when you suddenly decide that you need what you’ve made to be a specific size. SketchUp has a terrific trick for taking care of this exact situation: You can use the Tape Measure tool to resize your whole model based on a single measurement.

Here’s how this tool works: In the following figure, the designer started to model a simple staircase. Making sure that it’s the right size will make working on it easier. They know that the riser height, the vertical distance between the steps, should be 7 inches, so this is what they do: 

	[image: 9781119617938-ma015] Start the Tape Measure tool.
 

[image: Schematic illustration of using the Tape Measure tool.] 






	To put the Tape Measure in Measure mode, press the Ctrl key (Mac: Option) so that the plus sign (+) next to the Tape Measure cursor disappears.

	Click to start measuring the distance that will change (in this case, the riser height) and then click again to stop.

	Type the desired dimension (7 for 7 inches).

	
In the dialog box, confirm the resize by clicking Yes.

The whole model is resized proportionately to the dimension that was entered.



Note that everything is resized by the ratio of the original distance versus the new distance!



[image: Schematic illustration of four boxes.] 
FIGURE 3-17: You can move the box 5 meters, change your mind, and move it 15 meters instead.









Selecting what you mean to select

If you want to move, rotate, copy, scale, or otherwise manipulate existing geometry in your model, you need to select it first. Your selection tells SketchUp what geometry you want to change.

[image: 9781119617938-ma001] To select things, you use (drum roll, please) the Select (E) tool, which looks exactly the same as the Select tool in every other graphics program on the planet: It’s an arrow. That’s a good thing, because selecting isn’t the sort of thing you should have to relearn every time you pick up a new program. Here’s everything you need to know about selecting things in SketchUp: 


	
[image: Technical Stuff] Technically, every single thing you see in your modeling window is an entity. SketchUp has three kinds of entities: 


	Elements are basic pieces of geometry, like edges and faces.

	Objects are made up of elements. Components and groups, which we cover in Chapter 5, are objects. Anytime you want to make a separate thing with its own name and metadata, you make an object. In SketchUp, objects are everywhere.

	Annotations are things like text, guides, dimensions, and section planes. Annotations is kind of a catch-all category; anything that isn’t an element or an object is an annotation.



	Click anything in your model to select it — while you’re using the Select (E) tool, of course.

	
To select more than one thing, hold down the Shift key while you click all the things you want to select.

[image: Tip] The Shift key works both ways when it comes to the Select (E) tool. You can use it to add to your set of selected things (as we mention earlier), but you can also use it to subtract something from your selection. In other words, if you have a bunch of stuff selected, and you want to deselect something in particular, just hold down Shift while you click it; it isn’t selected anymore.


	Selected entities in SketchUp look different depending on what they are: 
	Selected edges turn blue.

	Selected faces change from plain gray to blue-gray (if you’re using the default style).

	Selected groups and components have a blue box around them.

	Selected annotations turn blue.



	
[image: Tip] A much fancier way to select things in your model is to double- and triple-click them. When you double-click a face, you select that face and all the edges that define it. Double-clicking an edge gives you that edge plus all the faces that are connected to it. When you triple-click an edge or a face, you select the whole conglomeration that it’s part of. See Figure 3-18.


	
You can select several things at the same time by dragging a box around them. You have two kinds of selection boxes; the one you use depends on what you’re trying to select (see Figure 3-19): 


	Window selection: If you click and drag from left to right to make a selection box, you create a window selection. In this case, only things that are entirely inside your selection box are selected.

	Crossing selection: If you click and drag from right to left to make a selection box, you create a crossing selection. With one of these, anything your selection box touches (including what’s inside) is selected.



[image: Tip] The Window selection box (left to right) is shown using solid lines, while a Crossing box (right to left) uses dashed lines.


 

[image: Remember] Just because you can’t see something doesn’t mean it isn’t selected. Whenever you make a selection, it’s a very good idea to orbit around to make sure you have only what you intended to get. Selecting too much is an easy mistake to make.
 



[image: Schematic illustration of trying single-, double-, and triple-clicking edges and faces in the model to make different kinds of selections.] 
FIGURE 3-18: Try single-, double-, and triple-clicking edges and faces in your model to make different kinds of selections.








[image: Schematic illustration of dragging left to right for selecting everything inside the selection box. Dragging right to left selects everything that the selection box touches.] 
FIGURE 3-19: Dragging left to right selects everything inside your selection box. Dragging right to left selects everything that your selection box touches.








[image: Technical Stuff] CHANGING THE COLOR OF MODELING CUES
 
Whether you have color blindness or the default selection colors and other colored modeling cues simply don’t work for you, know that you can change the selection color, the axis colors, and several other visual cues. You control these colors with SketchUp styles and preferences settings. See Chapter 10 for details. The doctor told the patient that they were color-blind. That came right out of the magenta…




Moving and copying like a champ

[image: 9781119617938-ma013] To move, stretch, or copy geometry in SketchUp, use the Move tool. That’s right, the Move tool isn’t just for moving, and this section explains all the Move tool secrets that will help you quickly advance to more complex 3D modeling.
 
Moving things

Using the Move tool usually involves several steps: 

	Tap the spacebar to invoke the Select (E) tool.

	Select the entity or entities that you want to move.

	Activate the Move tool.

	
Click a starting point for the move and then move the cursor.

As with most SketchUp tools, it’s best not to hold the mouse button down while moving; just click at the destination.


	Click the destination point.


The maneuver isn’t complicated, but getting the hang of it takes a bit of practice.

[image: Tip] Here are tips for using the Move tool successfully: 


	Click, move, and click; don’t drag your mouse. Many new SketchUp users are tempted to move stuff by clicking and dragging. That works, but in the long run, moving things is harder that way. Instead, practice clicking to pick something up, moving your mouse without holding down any buttons, and clicking again to put down whatever you’re moving.

	Click a point that will let you position whatever you’re trying to move. Figure 3-20, for example, shows two boxes. To stack one on top of the other precisely, you can’t just click anywhere on the first box and move it over the other one. You have to click the bottom corner of the soon-to-be top box and move the cursor over the top corner of the bottom box.

	Press the Esc key to cancel a move operation. When you start to move something (on purpose or accidentally), it’s tempting to use Move to put things back the way they were. Inevitably, Move messes up your model. Instead, the quickest and easiest way to get out of a Move operation and keep your model intact is to tap the Esc key.

	Watch for helpful inferences. To move something in one of the colored directions, wait until you see the dotted On Axis linear inference appear; then hold down Shift to lock yourself in that direction. For more information about using SketchUp’s inference engine, check out the earlier section “Keeping an eye out for inferences.”

	Move precisely with the Measurements box. You can move things precise distances with the Measurements box; see “Injecting accuracy into your model” earlier in this chapter.

	Watch where you are going. In the current release of SketchUp, if you orbit during the move so that you can no longer see the starting point on the selected objects, the objects become semitransparent, allowing you to find the desired destination point more easily.




[image: Schematic illustration of moving things precisely and choosing precise points to grab things and put them down.] 
FIGURE 3-20: To move things precisely, choose precise points to grab things and put them down.








Shaping forms with the Move tool

SketchUp’s Move tool isn’t just for moving whole objects. You can also use this tool to change the shape of your model. To do this, move a vertex (the place where edges’ endpoints come together), an edge, a face, or a combination of any of these. By moving only certain entities (all the things we just mentioned), you can change the shape of your geometry pretty drastically, as shown in Figure 3-21.



[image: Schematic illustration of moving tool on vertices, edges, and faces to model different forms.] 
FIGURE 3-21: You can use the Move tool on vertices, edges, and faces to model different forms.






[image: Tip] Using the Move tool to create forms (instead of just moving them around) is an incredibly powerful way to work but isn’t particularly intuitive. After all, nothing in the physical world behaves like the Move tool. You can’t just grab the edge of a hardwood floor and move it up to turn it into a ramp in real life. In SketchUp, you can — and should.
 


To preselect or not to preselect

The Move tool works in two ways, and you’ll eventually need to use them both, depending on what you’re trying to move: 


	Moving a selection: This process is the basic one, described earlier in this chapter in “Moving and copying like a champ.” When you select one or more entities, the Move tool moves only the selection. This behavior is handy when you need to move more than one thing at the same time. Figure 3-22 shows how to move selected items with the Move tool.

	Moving without a selection: If you start the Move tool without making a selection first, you can click anything in the drawing window to move it around. Only the thing you click moves. This technique can create some unpredictable results, however, so we generally advise using the preselect method.

 

TELLING SketchUp WHO’S BOSS WITH AUTOFOLD
 
This will happen to you sooner or later: As you try to move a vertex, an edge, or a face, you can’t go in the direction you want. SketchUp doesn’t like to let you create folds (when extra faces and edges are created in place of a single face) with the Move tool, so SketchUp constrains your movement to directions that won’t add folds. To force the move, tap the Alt key (Mac: ⌘  ) while you move. When you do this, you’re telling SketchUp that it’s okay to proceed — to create folds if it has to. This feature is called autofold, and the following figure shows how it works. The Alt/⌘   key is a toggle; each time you tap it, SketchUp switches to the other mode. 


[image: Schematic illustration of creating the folds.] 







[image: Schematic illustration of using the Move tool when you have a selection moves only the things in that selection.] 
FIGURE 3-22: Using the Move tool when you have a selection moves only the things in that selection.








Making copies with the Move tool

Lots of folks spend time hunting around in SketchUp, trying to figure out how to make copies. It’s very simple: You just press a modifier key — a key on your keyboard that tells SketchUp to do something different — while you’re using the Move tool. Instead of moving something, you move a copy of it. Here are a couple things to keep in mind: 


	
Press the Ctrl key (Mac: Option) to create a copy. You can press the modifier key before or after you click the entity you want to move. When the Move tool is in Copy mode, a little + appears next to the Move cursor, and your copy moves when you move your mouse. Figure 3-23 shows this in action.

If you decide that you don’t want to make a copy, just press the Ctrl key (Mac: Option) again to toggle back to Move; the + sign disappears.


	Copying is just like moving except that you’re moving a copy. All the rules for using the Move tool apply to making copies too.

[image: Schematic illustration of pressing Ctrl to tell SketchUp to make a copy while moving something.] 
FIGURE 3-23: Press Ctrl (Mac: Option) to tell SketchUp to make a copy while you move something.







	
To make more than one copy at a time, use the Measurements box. Suppose that you want to make five equally spaced copies of a column, as shown in Figure 3-24. First, move a copy to where you want the last column to be; then type 5/ and press Enter. SketchUp makes five copies of the column and spaces them evenly between the first and last column in the row. Neat, huh?

[image: Tip] To set a precise distance between your copies, move a copy to set the distance between each copy, type 5x, and press Enter.





[image: Schematic illustration of using the Measurements box to make multiple copies.] 
FIGURE 3-24: Use the Measurements box to make multiple copies.








Rotating the right way

[image: 9781119617938-ma014] The Rotate (Q) tool spins geometry based on an angle you specify. No surprises there. But the Rotate (Q) tool also has a trick up its sleeve that most new modelers don’t discover until hours after they could’ve used it. First things first, though: 


	It’s better to preselect. As with the Move tool, rotating something you’ve already selected is usually easier.

	The Rotate(Q) tool can make copies, too. Press the Ctrl key (Mac: Option) to switch between rotating your original and rotating a copy. You can also make several copies arranged in a circle or along an arc. Check out the earlier section “Making copies with the Move tool” to read about using x and / to create multiples.

	You can be precise. The Measurements box enables you to type exact angles while you’re rotating. Take a look at “Injecting accuracy into your model” earlier in this chapter to find out more.




 
Using Rotate (Q): The basic method

Follow these steps to rotate things in your model: 

	Select everything you want to rotate.

	Activate the Rotate (Q) tool.

	
Click to establish an axis of rotation.

Your axis of rotation is the theoretical line around which your selected entities will rotate; picture the axle of a wheel. Although it’d be nice if SketchUp drew the axis of rotation in your model, you just have to imagine it.

[image: Tip] As you move the Rotate tool’s big protractor cursor around your screen, the cursor sometimes changes orientation and color. When you hover over a face, the cursor realigns itself to create an axis of rotation that’s perpendicular to that face. When the cursor is red, green, or blue, its axis of rotation is parallel to that colored axis.

[image: Tip] You can (and should) use inference locking when you’re using the Rotate (Q) tool. Just hover over any face in your model that’s perpendicular to the axis of rotation you want, hold down the Shift key to lock in that orientation, and click where you want your axis to be. See “Using inferences to help you model” earlier in this chapter to read all about it.


	
Click again to start rotating.

Clicking part of the thing you’re rotating is helpful, especially if you’re rotating visually instead of numerically (by typing an angle).


	
Move your mouse; then click again to finish rotating.

If you like, now is a good time to type a rotation angle and press Enter. As with everything else in SketchUp, you can be as precise as you want or need to be.




 
Using Rotate (Q): The not-so-basic method

The basic method of using the Rotate (Q) tool is fine when you need to rotate something on the ground plane, but this method isn’t as useful when your axis of rotation isn’t vertical. Finding a face to use to orient your cursor can be tricky or impossible, and that’s where a lot of SketchUp modelers get hung up.

With this not-so-basic rotation method, you can establish a precise axis of rotation (the invisible line around which you’re rotating) without having any existing faces to use for orientation. This makes rotating things about a million times easier.

In this case, using the Rotate (Q) tool goes from being a five-step operation to a seven-step one. Check out Figure 3-25 for a visual explanation: 

	[image: 9781119617938-ma014] Select everything you want to rotate.

	Activate the Rotate (Q) tool.

	Click to establish your axis of rotation, but don’t let go; keep your finger on your mouse button.

	
Drag your cursor around (still holding down the mouse button) until your axis of rotation is where you want it.

As you drag, notice that your Rotate protractor changes orientation; the line from where you clicked to your cursor is the axis of rotation.


	Release your mouse button to set your axis of rotation.

	Click (but don’t drag) the point at which you want to pick up whatever you’re rotating.

	Click again to drop the thing you’re rotating where you want it.

 




Making and using guides

Sometimes, you need to draw temporary lines while you model. These temporary lines, or guides, are useful for lining up things, making things the right size, and generally adding precision and accuracy to what you’re building.

Guides are special entities that you create when and where you need them. They aren’t part of your model because they’re not edges or faces, so you can choose to hide them or delete them; like other annotations, they don’t affect the rest of your geometry.

Figure 3-26 shows an example of guides in action. The guides are positioned 12 inches from the wall and 36 inches apart to draw the sides of a doorway. Another guide (6 feet, 8 inches from the floor) indicates the top. With these guides in place, you can easily draw a rectangle, bounded by your guides, that you know is exactly the right size and in the correct location.



[image: Schematic illustration of defining a custom axis of rotation by click-dragging.] 
FIGURE 3-25: Define a custom axis of rotation by click-dragging.






Creating guides with the Tape Measure tool

[image: 9781119617938-ma015] You can create three kinds of guides, and you use the Tape Measure (T) tool to make them all, as shown in Figure 3-27. 


	Parallel guide lines: To create a guide that's parallel to an edge, select the Tape Measure tool, and click anywhere (except the endpoints) along an edge. Then move your mouse, and a parallel dashed guide appears. Click again to place the guide wherever you want.

[image: Schematic illustration of using guides to measure things before drawing.] 
FIGURE 3-26: Use guides to measure things before you draw.







	Linear guide lines: To create a guide along an edge in your model, click anywhere along the edge except on either endpoint. Then click again anywhere else along the edge.

	Guide points: You may want to place a point somewhere in space; you can do exactly that with guide points. With the Tape Measure tool, click an edge’s endpoint and then click again somewhere else. A little x appears at the end of a dashed line. That’s your new guide point.




[image: Schematic illustration of using the Tape Measure tool to create guide lines and points.] 
FIGURE 3-27: Use the Tape Measure tool to create guide lines and points.






[image: Remember] Here’s an important point about the Tape Measure tool: It has two modes, and it creates guides in only one of them. Pressing the Ctrl key (Mac: Option) toggles between the modes. When you see a + next to your cursor, your Tape Measure can make guides; when there’s no +, it can’t.


 
Using guides to make your life easier

[image: Tip] As you’re working in this software, you’ll find yourself using guides all the time; they’re an indispensable part of how modeling in SketchUp works. Here’s what you need to know about using them: 


	Position guides precisely, using the Measurements box. Check out “Injecting accuracy into your model” earlier in this chapter to find out how.

	Erase guides one at a time. Just click or drag over them with the Eraser tool to delete guides individually. You can also right-click them and choose Erase from the shortcut menu.

	Erase all your guides at the same time. This operation comes in two flavors:

	Desktop: Choose Edit ⇒ Delete Guides.

	Web: Enter guides in the search box and then click Delete Guides.



	Hide guides individually. Right-click a single guide and choose Hide from the shortcut menu to hide it.

	
Hide or unhide all guides at the same time. This operation also comes in two flavors: 


	Desktop: Choose View ⇒ Guides to alternate between showing or hiding all guides.

	Web: Enter guides in the search box and then click the View Guides button to toggle between visible or hidden.



It’s usually a good idea to hide your guides instead of erasing them, especially while you’re still modeling.


	Select, move, copy, and rotate guides just like any other entities in your model. Guides aren’t edges, but you can treat them that way a lot of the time.






 
Painting your faces with color and texture

When you’re adding colors and textures — collectively referred to in SketchUp as materials — to your model, look no further than the Materials panel and the Paint Bucket (B) tool. Chapter 2 introduces this winsome pair and provides a workflow for adding materials to your model. This section offers a more in-depth introduction to your options.
 
The Materials panel

The Materials panel looks different in the Windows and Mac versions of SketchUp, but both versions do basically the same thing. By default, the Materials panel appears on the Default Tray (Windows only). If the panel is ever hidden, and you need to reopen it, choose Window ⇒ Default Tray ⇒ Materials (Mac: Window ⇒ Materials).

In SketchUp, you can choose either of two kinds of materials to apply to the faces in your model: 


	Colors: These simple colors are always solid colors. You can’t have gradients (one color fades into another), but you can make pretty much any color you want.

	
Textures: A SketchUp texture is a tiny image that’s tiled to cover a face. If you paint a face with, say, a brick texture, what you’re really doing is telling SketchUp to cover the surface with however many brick-photo tiles it takes to do the job. The preview image you see in the Materials panel is actually a picture of a single texture image tile.

SketchUp comes with a whole bunch of textures, and thousands more are for sale online. If that’s still not enough, you can make your own (though the process is well beyond the scope of this humble tome). For details on advanced techniques such as creating a custom texture, check out the SketchUp Help Center (https://help.sketchup.com).




The following facts about SketchUp materials are also handy to know as you work with them: 


	Materials can be translucent. Sliding the Opacity slider makes the material you’ve selected more or less translucent, which makes seeing through windows in your model a lot easier. In Windows, you find the Opacity slider on the Edit tab.

	Textures can have transparent areas. If you take a look at the materials in the Landscaping, Fencing, and Vegetation library, you’ll notice that a lot of them look kind of strange; they have areas of black that don’t seem right. These black areas are areas of transparency: When you paint a face with one of these textures, you can see through the areas that look black.



[image: Technical Stuff] There’s a third thing (besides colors and textures) that you can apply to the faces in your models: photos. In fact, photo-texturing is an incredibly important part of some SketchUp workflows. As such, we dedicate a good portion of Chapter 8 to the subject of modeling with photographs.


 
The Paint Bucket (B) tool

[image: 9781119617938-ma007] Activating the Paint Bucket (B) tool automatically opens the Materials panel so that it’s handy. Here’s everything you need to know about the Paint Bucket (B) tool: 


	
You fill it by clicking in the Materials panel. Just click a material to load your bucket and then click the face you want to paint.

[image: Tip] The converse is also true: If you click a material or color in the Materials panel, it launches the Paint Bucket (B) tool and fills it with the selected color or material.


	You have a much wider range of choices than you may think. As mentioned in Chapter 2, if you don’t see a color or texture you like, click the down arrow at the end of the window that says something like Asphalt and Concrete, Metal, or Patterns. This produces a list of 16 categories of materials, colors, and patterns,

	What if you don’t like the available carpet colors? Or any of the other materials, for that matter? No problem. Just click the Edit tab and pick a color — any color — to apply to your choice of material.

	Holding down the Alt key (Mac: ⌘  ) switches to the Sample tool. With the Sample tool, you can click any face in your model to load your Paint Bucket with that face’s material. Release the Alt key to revert to the Paint Bucket (B) tool.

	Holding down the Shift key paints all similar faces. Don’t like the dark brick on your house model? Select a new material in the Materials panel, hold down the Shift key, and click any face with the brick applied. In Figure 3-28, the Paint Bucket (B) tool is ready to change the dark brick to a lighter option, which you see as the active material in the top-left corner of the Materials panel. When you’re done, all faces in your model that match the one you click are painted with the new material. If things don’t turn out the way you want, just choose Edit ⇒ Undo to go back a step.




[image: Snapshot of pressing Shift and click with the Paint Bucket tool to replace one material with another.] 
FIGURE 3-28: Press Shift and click with the Paint Bucket (B) tool to replace one material with another.













  

Part 2

Modeling in SketchUp

IN THIS PART …

Draw buildings and discover tricks for creating common elements, such as floors, walls, doors, windows, roofs, and stairs.

Simplify your modeling with components, including premade components from SketchUp as well as components you create.

Create lathed objects with Follow Me, scale shapes to create unique effects, set your model on terrain, and create complex 3D shapes with the Solid Tools.

Tidy up complex models with the Outliner and see only the elements you need with layers.

Texture the faces of your models to add detail and realism to your models. Add other information — like geo-location or r CAD data — to a SketchUp model.

Find out about 3D printers and learn the basics of designing and producing 3D-printable models.






Chapter 4

Building Buildings

IN THIS CHAPTER

[image: check] Drafting a simple floor plan

[image: check] Going from a 2D plan to a 3D model

[image: check] Adding floors, doors, and windows

[image: check] Modeling stairs

[image: check] Building a roof



Even though SketchUp lets you make (just about) anything you can think of, certain forms are easier to make than others. Fortunately, these kinds of shapes are exactly the ones that most people want to make with SketchUp, most of the time. That’s no accident. SketchUp was designed with architecture in mind, so the whole paradigm — the models made of faces and edges, and the kinds of tools SketchUp offers — is perfect for making things like buildings.

But what about curvy, swoopy buildings? You can use SketchUp to make those too, but they’re a little harder, so we don’t think they’re a good place to start. Because most people live in boxy places with right-angled rooms and flat ceilings, that kind of architecture is relatively easy to understand.

In this chapter, you discover some fundamentals of SketchUp modeling in terms of making simple, rectilinear buildings. By writing about how to build certain kinds of things instead of just describing what the individual tools do, we hope to make it easier for you to get started. Even if you’re not planning to use SketchUp to model any of the things we describe, you can still apply these concepts to your creations.

[image: Tip] One more thing: Just about every page in this chapter relies heavily on the stuff introduced in Chapter 3. Working with the colored drawing axes, making selections, navigating around your model, and drawing things accurately are pretty key to making anything in SketchUp. Be prepared to flip back and forth in this book while you’re getting used to modeling in SketchUp. Some people like to use paper clips as bookmarks, and others tear off tiny scraps of paper, but you surely have your own method.



Drawing Floors and Walls

Most floors and walls are flat surfaces, so it’s easy to model them with straight edges and flat faces in SketchUp. In fact, chances are good that the first thing you ever model in SketchUp will look a lot like the floor and walls of a building.

How you approach modeling floors and walls depends entirely on the type of model you’re making and how you plan to use it. If you’re trying to show how a new building fits in with current zoning regulations and existing conditions, for example, you probably need to build just the exterior shell, and if you’re trying to make a new building fit in with an existing row of buildings, you may need as little as the front face.

Conversely, if you’re working on things like kitchen design or furniture layout, you probably need an interior model. The following should help explain the differences between the two variants: 


	Exterior: An exterior model of a building is usually an empty shell; you don’t have interior walls, rooms, or furniture to worry about. This type of model is a slightly simpler proposition for folks who are new to SketchUp.

	Interior: An interior model of a building is often significantly more complicated than an exterior one; dealing with interior wall thicknesses, floor heights, ceilings, and furnishings involves a lot more modeling prowess.



[image: Remember] Here’s the thing: Because everything in SketchUp is made of super-flat faces (they have no thickness), the only way to model a wall that’s, say, 8 inches thick is to use two faces side by side and 8 inches apart. The geometry you create with those two faces represents your wall in 3D. For models in which you need to show wall thicknesses — namely, interior models — you have to use this two-face approach. Exterior models are easier to make because you can use single faces to represent walls, as shown in Figure 4-1.



[image: Schematic illustration of using single faces for exterior models and double faces for interior ones.] 
FIGURE 4-1: Use single faces for exterior models and double faces for interior ones.






[image: Tip] Making a model that shows both the interior and the exterior of a building at the same time is, to be honest, much harder. If you can get away with just an exterior view, take a crack at modeling the doghouse from Chapter 2. Then, in Chapter 3, brush up on the SketchUp techniques that give your model dimensional accuracy. If the exterior model is all you need, you might not even need to read this chapter yet!

[image: Tip] If you must have interior views, try to get away with making an interior model only.

The following sections take you through modeling a complete building. If you’re creating an exterior view, however, you probably need to go only as far as “Coming up with a simple plan” later in this chapter; then you can jump ahead to the “Inserting doors and windows” and “Raising the Roof” sections.
 
Starting out in 2D

You can model a building’s interior in lots of ways. This section shows a method developed over years of creating SketchUp models. Basically, you draw a two-dimensional floor plan that includes all your interior and exterior walls (or just the exterior perimeter for exterior-only models) and then use the Push/Pull tool to pull it up to the right height. Only after your model is extruded do you worry about doors, windows, and stairs. There may be other processes that work for you, but this is a common method.
 
Switching to a 2D view

Before you draw a 2D plan, you need to orient your point of view. Drawing in 2D is easiest when you view your work from directly above, looking down at the ground plane. You also want to make sure that you’re not seeing things in perspective, which distorts your view of what you have.

Follow these simple steps to set up your SketchUp modeling area for 2D drawing: 

	
Create a new SketchUp file by choosing File ⇒ New.

Depending on the template you have set to open when you create a new SketchUp file, you may already be in a 2D view. If all you see are the red and green axes on a white background, you can skip step 2.

[image: Remember] You can always switch templates by choosing Help ⇒ Welcome to SketchUp and clicking the Template section of the dialog box that pops up.


	
Choose Camera ⇒ Parallel Projection.

Switching from Perspective to Parallel Projection makes it easy to draw plans in 2D.

(Web: The camera-view choices in steps 2 and 3 become available when you open the Views panel on the vertical toolbar down the right side of the screen. You can also search for most camera-control settings.) 


	
Choose Camera ⇒ Standard ⇒ Top.

This command changes your viewpoint so that you’re looking directly down at the ground.

(Web: It’s faster to search for Top.)

[image: Tip] In the Windows version, right-click an empty portion of the toolbar area and then choose Views from the shortcut menu to open a small toolbar with the standard view options.

At this point, your modeling window looks like the one shown in Figure 4-2.





[image: Schematic illustration of the modeling window which should look like this before one starts drawing in 2D.] 
FIGURE 4-2: Your modeling window should look like this before you start drawing in 2D.






[image: Tip] Feel free to delete the scale person that appears in every new file. Talk about a weight-reduction program! In Top view, the scale figure is just that little diagonal line. To delete it, right-click it and choose Erase from the shortcut menu.


 
Dusting off SketchUp’s drafting tools

You don’t need many tools to draft a 2D plan in SketchUp. Figure 4-3 shows the basic toolbars for desktop; everything you need is right there. The same tools (with grey icons) are all in the Web toolbar too.



[image: Schematic illustration of all the tools that need to draft in 2D in SketchUp are on the basic toolbar.] 
FIGURE 4-3: All the tools you need to draft in 2D in SketchUp are on the basic toolbar.







	[image: 9781119617938-ma006] Eraser tool: Use the Eraser to erase edges, as shown in Figure 4-4. Although you can’t use the Eraser to delete faces, erasing an edge that defines a face automatically erases that face too. Take a look at the section about edges and faces at the beginning of Chapter 3 for more detail on using the Eraser tool on edges. You can use the Eraser in two ways: 
	Clicking: Click edges to erase them one at a time.

	Dragging: Click and drag over edges to erase them (faster than clicking if you want to erase lots of edges).



[image: Schematic illustration of using the Eraser tool to erase edges. Erasing an edge that defines a face erases that face, too.] 
FIGURE 4-4: Use the Eraser tool to erase edges. Erasing an edge that defines a face erases that face, too.







	[image: 9781119617938-ma004] Line tool: You use the Line tool (which looks like a pencil) to draw edges, which are one of the two basic building blocks of SketchUp models. Fundamentally, you click to start drawing an edge and click again to finish it. (You can find lots more information about drawing lines in Chapter 3.)

	Arc tools: SketchUp has four tools for making arcs (see Figure 4-5). In both the desktop and Web versions, you can expand the Arc menu to see them all. Here they are, in order: 
	[image: 9781119617938-ma044] Arc: Click to define the center point, click again to define the first endpoint, and click a third time to finish the arc. The result is an arc made of straight-edge segments.

	[image: 9781119617938-ma005] 2 Point Arc (tap the A key): Click once to define one end, click again to define the other end, and click a third time to define the bulge. If you want, type a radius after you draw your arc by entering the radius, the units, and the letter r. If you want an arc with a radius of 4 feet, draw it however big, type 4'r, and press Enter.

	[image: 9781119617938-ma045] 3 Point Arc: This tool creates an arc around a pivot point. Click to set a start point, click again to set a pivot point, and click a third time to set the arc's endpoint.

	[image: 9781119617938-ma046] Pie: The Pie tool is exactly the same as the Arc tool, but with a useful twist. It yields a pie-shaped face and all three of its perimeter edges.



[image: Schematic illustration of using an Arc tool is a three-step operation.] 
FIGURE 4-5: Using an Arc tool is a three-step operation.







	[image: 9781119617938-ma080] Circle tool: On the Getting Started toolbar, the Circle tool hides on the Rectangle tool’s drop-down menu. Drawing circles in SketchUp is pretty easy: Click to define the center, and click again to define a point on the circle (which also defines the radius). To enter a precise radius, draw a circle; type a radius; and press Enter (see Figure 4-6). For more information on typing while you draw, check out the section on model accuracy in Chapter 3.

[image: Schematic illustration of drawing circles which is easy with the Circle tool.] 
FIGURE 4-6: Drawing circles is easy with the Circle tool.







	[image: 9781119617938-ma047] Offset (F) tool: The Offset (F) tool helps you draw edges that are a constant distance apart from edges that already exist in your model. Pictures are usually better than words, so take a look at Figure 4-7. Using Offset (F) on the shape creates another shape that’s exactly 6 inches bigger all the way around (middle image) or 6 inches smaller all the way around (right image). Offsetting edges is a useful way to create things like doorways and window trim.
You can use the Offset (F) tool in two ways. For both ways, you click to start offsetting and click again to stop: 


	Click a face to offset all its edges. If nothing is selected, clicking a face with the Offset (F) tool lets you offset all that face’s edges by a constant amount, as shown in Figure 4-7.

	Preselect one or more coplanar (on the same plane) edges and then use the Offset (F) tool. If you have selected edges, you can use the Offset (F) tool on just those edges, which comes in handy for drawing things like doorframes and balconies (see Figure 4-8).



[image: Schematic illustration of the offset tool which lets you create edges based on other edges.] 
FIGURE 4-7: The Offset (F) tool lets you create edges based on other edges.







	[image: 9781119617938-ma015] Tape Measure tool: The Tape Measure does a bunch of things. To measure a distance, click a point in your model. As you pull out the tape by moving the tool, the measured distance appears at the tool icon. It also appears in the Measurements box, in the bottom-right corner of your modeling window. Clicking a second point locks the reading in the Measurements box. You can also use the Tape Measure tool to size a model and to create guides, as we explain in Chapter 3.




[image: Schematic illustration of using the offset tool on a set of preselected edges which is handy for drawing things like doorframes.] 
FIGURE 4-8: Using the Offset (F) tool on a set of preselected edges is handy for drawing things like doorframes.










Coming up with a simple plan

As mentioned earlier, exterior-only models are usually much easier to produce, so we’ll start there.

If all you’re trying to do is model an exterior view of a building, just measure around the actual building’s perimeter, draw the outline of the building in SketchUp, pull it up with the Push/Pull tool, and delete the top face if you like (see Figure 4-9). Then you can add doors, windows, and your desired roof, as explained in “Inserting doors and windows” and “Raising the Roof” later in this chapter. Textures, materials, and paint can also be applied. With this method, your walls are only single-face thick (meaning paper-thin), but that’s okay. You’re interested only in the outside anyway.



[image: Schematic illustration of making an exterior model, measure the outside of a building to draw an outline in SketchUp.] 
FIGURE 4-9: To make an exterior model, measure the outside of your building to draw an outline in SketchUp.








Doing an inside job

Measuring an existing building so that you can model an interior view is easier said than done. Even experienced architects and builders often get confused when trying to model the interiors of as-builts, which are drawings of existing buildings. Closets, ventilation spaces, interior walls, and all kinds of other obstructions inevitably get in the way of good measurements. Usually, you give the measuring your best shot and then tweak things a bit to make them right. The following sections walk you through the process.
 
Drawing an interior outline

When you model a building’s interior, your main goal is creating accurate interior spaces. To achieve that accuracy, work from the inside out. If your tape measure is long enough, measure the major dimensions first — that is, measure the total interior width and length of the building’s inside. You may not be able to, but do your best. After that, just work your way around, using basic arithmetic and logic to figure out the size of the space.

[image: Tip] Before you start drawing an interior outline in SketchUp, make a paper drawing. The drawing helps you know what you need to draw so you can focus all your concentration on drafting on the computer. Figure 4-10 shows the paper sketch that was used when modeling a house. Alternatively, Chapter 8 explains how to import CAD and image files so you can simply trace over them.

Before you laugh at paper drawings in this digital age, remember that some digital files a few years old can no longer be displayed because the software hasn’t been updated and won’t run on current operating systems. On the other hand, there are people who can still read 6,000-year-old Egyptian papyrus scrolls.

From this paper drawing, here’s how you draw a basic interior outline of this house: 

	
Switch to a 2D overhead view.

“Switching to a 2D view” earlier in this chapter explains how.


	[image: 9781119617938-ma004] Using the Line tool, draw a line that represents the exact length of a wall in the house.
You might start the model of this house at its eastern wall by creating a line that’s exactly 17 feet long. (See the bottom-left area in Figure 4-11.)

To draw a precise line, click to start the line, click again to end the line, type 17', and press Enter.



[image: Schematic illustration of a paper sketch.] 
FIGURE 4-10: A paper sketch.






[image: Remember] You don’t need to click anywhere before you type a precise value; the Measurements box listens for your keystrokes immediately after you draw something.

After you press Enter, the line resizes itself automatically to be exactly 17 feet in length. If you want, you can use the Tape Measure tool to double-check the size.




	
Connect the next edge to the first one.

As shown in the bottom-left image in Figure 4-11, work clockwise, drawing an edge 11 feet, 10 inches long, starting at the end of the first edge and heading to the right in the red direction.


[image: Schematic illustration of drawing an edge 17 feet long and then draw a perpendicular edge 11 feet, 10 inches long.] 
FIGURE 4-11: Start by drawing an edge 17 feet long; then draw a perpendicular edge 11 feet, 10 inches long.







	
Keep going all the way around the house until you get back to where you started (see Figure 4-12).

[image: 9781119617938-ma006] If you make a mistake, use the Eraser tool to get rid of edges. Alternatively, undo by pressing Ctrl+Z (Mac: ⌘  +Z) or choosing Edit ⇒ Undo to go back a step or two.

Welcome to the real world of 3D modeling! Your sketch may be missing a dimension or three, and some dimensions may not add up correctly. If you’re in doubt, a single longer dimension is more likely to be accurate than the sum of several shorter ones.


	
If your measurements don’t add up, adjust things so that they do.

Giving or taking a few inches here and there never killed anyone, after all.

Okay, maybe a few inches could kill someone if you’re designing a new submarine or a new airliner, and you might want to remeasure if you’re doing built-in carpentry. But documenting an existing building shouldn’t be a problem unless your model will be used as the basis for a new addition or major renovations. (What if the new balcony didn’t quite attach to the existing wall?)

When you complete the outline (forming a closed loop of edges that were all on the same plane), a face appears. Now you have a total of 12 edges and 1 face.





[image: Schematic illustration of the completed interior perimeter of the house.] 
FIGURE 4-12: The completed interior perimeter of the house.






[image: Tip] When you draft in 2D, use only Zoom and Pan (H) tools to navigate your drawing (see Chapter 3). If you accidentally orbit your model into a 3D view, return to 2D by following the steps in “Switching to a 2D view” earlier in this chapter.

[image: Remember] [image: 9781119617938-ma012] If you get lost, and no amount of zooming and panning gets you back to a view of your floor plan, use the Zoom Extents tool. Here’s another good shortcut to remember and practice: Shift+Z (uppercase Z). Think of Zoom Extents as a panic button you can press when you accidentally zoom or orbit your way into limbo in 3D.


 
Offsetting and grouping an exterior wall

With the Offset (F) tool, you can offset an exterior wall’s thickness, which can make it easier to visualize your spaces. Here’s how you do it: 

	[image: 9781119617938-ma047] Using the Offset (F) tool, offset your closed shape by 8 inches to the outside (see Figure 4-13, top left).
Move the cursor to a suitable point on a line segment until the On Edge inference appears. Click the line and then move the cursor outward. An offset of 8 inches is a pretty standard thickness for an exterior wall, but this can vary depending on the local climate. Type 8", and tap Enter. See “Dusting off SketchUp’s drafting tools” earlier in this chapter for details about using the Offset (F) tool.


	[image: 9781119617938-ma005] Use the Line tool to close off any alcoves, creating pockets of wall that are thicker than the rest (see Figure 4-13, top right).

	
With the Eraser tool, delete the extra edges (see Figure 4-13, middle left).

By deleting the extra edges, you have only two faces: one that represents the floor and one that represents the wall.


	
With the Line tool, draw edges that define the thickness of your exterior wall (see Figure 4-13, middle right).

For this example, the bulges (which represent a fireplace and a mechanical closet) go all the way up to the roof, two stories up.

When you’re done, you end up with several faces: one for the floor, one for the exterior wall (whose thickness should be more or less uniform), and a few for the bulges.


	
Select the face that defines the exterior wall (see Figure 4-13, bottom left).

The easiest way to do this is to tap the spacebar for the Select tool and then click the space between the wall lines.


	
Make the face you just selected into a group (see Figure 4-13, bottom right).

Chapter 5 is all about these groups (and their über-useful cousins, components), but here’s all you need to know for now: Making groups lets you separate different parts of your model. Turning your exterior wall into a separate group makes it easier to edit, hide, and move. And yes, a group can consist of just one SketchUp entity (such as a single edge or a face). Groups also simplify the process of adding more floor levels to your building, if that becomes necessary. SketchUp groups are very similar to AutoCAD groups.

To turn the face you selected in step 5 into a group, right-click it and then choose Make Group from the shortcut menu. You see a perimeter of blue lines around your face along with the bounding-box rectangle that surrounds the face; that’s the group you just created. Congratulations — you’re officially an intermediate SketchUp user!


 



Putting in the interior walls

For this part of the process, guides are your friends. You find a full description of guides and how to use them in Chapter 3.


[image: Schematic illustration of using the offset tool to create an exterior wall thickness and then clean up, using the Line and Eraser tools.] 
FIGURE 4-13: Use the Offset (F) tool to create an exterior wall thickness and then clean up, using the Line and Eraser tools. Finally, make the exterior wall into its own group.








[image: Tip] At this point in creating an interior floor plan, you can ignore things like doors, windows, and stairs. Where a wall contains a doorway, draw a solid wall. After you extrude the floor plan into a 3D figure, adding doors, windows, and stairs is much easier.

Working from your 2D drawing, here’s how you create interior walls: 

	[image: 9781119617938-ma015] With the Tape Measure tool, create guides to mark the precise locations of the interior walls.
The guide for the wall in the bottom-right section of the sketch in Figure 4-10, earlier in this chapter, is a parallel guide 5 feet, 3½ inches from the inside of the entryway (see Figure 4-14, left). Figure 4-14, right, shows all the required guides.

To create a parallel guide, click the edge from which you want to draw the guide, move your cursor (to tell SketchUp which way to go), type your distance (such as 5'3.5), and press Enter.

[image: Remember] The Ctrl key (Mac: Option) toggles the guidemaking function of the Tape Measure tool.


[image: Schematic illustration of drawing a guide to help locating the first interior wall and then draw a bunch more.] 
FIGURE 4-14: Draw a guide to help you locate your first interior wall; then draw a bunch more.







	[image: 9781119617938-ma004] With the Line tool, draw edges to represent the interior walls.
With guides, it’s easy to draw your edges correctly. Figure 4-15 shows what you have so far.

[image: Remember] Don’t forget to zoom! When you have a jumble of edges and guides, and you can’t see what you’re doing, just zoom in. The easiest way to zoom in and out is to use the scroll wheel on your mouse. Many folks forget to change their point of view while they work, and zooming makes all the difference.


[image: Schematic illustration of using the Line tool to create edges where guides come together.] 
FIGURE 4-15: Use the Line tool to create edges where guides come together.







	[image: 9781119617938-ma006] With the Eraser tool, click your guides to delete them.

	
Use the Eraser to delete extra edge segments (see Figure 4-16).

The goal is to have the smallest-possible number of 2D faces to extrude into 3D walls a little later on.

[image: Tip] Because the exterior-wall face and the edges that define it are part of a separate group, accidentally nicking that face with the Eraser deletes the whole thing. If this happens, just press and hold the Ctrl key (Mac: Option). Now you can tap the Z key as many times as necessary to get you back to a safe condition. Release the Ctrl (Mac: Option) key (Web: click a curved Undo button in the bottom-left corner of the screen). Now Zoom in a little bit, and try again.


 




Going from 2D to 3D

With a 2D plan in hand, you’re ready to extrude it into a 3D model. This process is enormously enjoyable and involves the tool that made SketchUp famous: Push/Pull. In the following sections, you take a simple floor plan (the one you drew earlier in this chapter) and turn it into 3D walls.



[image: Schematic illustration of using the eraser to delete the guides and any little edge segments left over from drawing the interior walls.] 
FIGURE 4-16: Using the Eraser, delete your guides and any little edge segments left over from drawing the interior walls.






Getting a good view

Before you pop up your plan into the third dimension, change your point of view to get a better understanding of what you’re doing. See Figure 4-17 and use the following steps. (Web: Use the Views panel, and search for all four steps.) 

	
Choose Camera ⇒ Perspective.

This command turns on SketchUp’s perspective engine, meaning that now you can see things more realistically — the way people really see things, especially large things like buildings, in 3D.


	
Choose Camera ⇒ Standard ⇒ Iso.

[image: 9781119617938-ma008] This command switches you from a top view to an isometric (three-quarter) one. You can do this with the Orbit tool too. SketchUp usually gives you more than one way to do something.


	
Activate the Zoom Extents (Shift+Z) tool.

[image: 9781119617938-ma012] Zoom Extents (Shift+Z) tool has its own button on the Getting Started toolbar, but we’re sticking with the Camera-menu theme just for consistency.


	
Choose Camera ⇒ Field of View, type 45, and press Enter.

You’ve changed the field of view from 35 to 45 degrees. By default, SketchUp’s field of view is set to 35 degrees. (For more information on what this means, check out Chapter 11.)





[image: Schematic illustration of switching over to a 3D view, before starting the work in 3D, .] 
FIGURE 4-17: Before you start work in 3D, switch over to a 3D view.








Pushing/pulling your way to happiness

The Push/Pull tool is a simple creature: It extrudes flat faces into 3D shapes. To use the Push/Pull tool, click a face to start pushing/pulling it, move your cursor until you like what you see, and click again to stop pushing/pulling. That’s it. No software tool has ever been so satisfyingly easy to use and understand. For more details on the Push/Pull tool, see the nearby sidebar “More fun with Push/Pull.”

[image: Remember] The Push/Pull tool works only on flat faces.

The following steps outline how to use the Push/Pull tool to extrude an interior floor plan into a 3D model, as shown in Figure 4-18: 

	[image: 9781119617938-ma003] Start the Push/Pull tool.
The tool looks like a little box with a red arrow coming out of the top.


	
Click an interior wall’s face to start extruding it.

If you click the floor face, you’ll extrude that instead. If you accidentally choose the wrong face, press Esc to cancel the operation, and try again.


[image: Schematic illustration of the Push/Pull tool which extrudes faces to make the walls of the house.] 
FIGURE 4-18: The Push/Pull tool extrudes faces to make the walls of the house. Presto!







	
Move your cursor up to pull up the wall, and click to stop extruding.

How much you extrude the face doesn’t matter because you add precision in the next step.


	
Type a ceiling height (such as 8'), and press Enter.

When you do this, the push/pull distance is revised to reflect your exact ceiling height. In this house, that’s 8 feet.


	
Repeat steps 2 through 4 for all the interior walls.

As explained in Chapter 3, orbiting helps you view what you’re doing as you work around the model.


	
Push/pull the exterior wall to match the height of these interior walls.

Because the exterior wall face is part of a group, you need to open the group before you can do anything to it. To open a group, double-click the exterior wall face, or right-click it and choose Edit Group from the shortcut menu. When you’re able to work inside the group, you can follow steps 2 through 4 to give height to the exterior wall group. Click anywhere outside the model to exit the group when you’re done.


 

MORE FUN WITH PUSH/PULL
 
Push/Pull is the tool that most people think of when they think of SketchUp. In fact, the people who invented this software (back in the last millennium) started with the idea for Push/Pull; that’s how closely linked SketchUp and the Push/Pull tool are. If you’d like to know a little more about SketchUp’s most distinguished tool, here are five things about the Push/Pull tool that aren’t immediately obvious when you start using it: 


	Double-click with the Push/Pull tool to extrude a face by the last distance you pushed/pulled.

	Press the Ctrl key (Mac: Option) to push/pull a copy of your face. As shown in the first graphic in the following figure, instead of using the Push/Pull tool in the regular way, you can use a modifier key to extrude a copy of the face you’re pushing/pulling. This comes in super-handy for modeling things like multistory buildings quickly.

	While pushing/pulling, hover over other parts of your geometry to tell SketchUp how far to extrude. Take a look at the second graphic. Perhaps you want to use the Push/Pull tool to extrude a cylinder that’s exactly the same height as this box. Before you click the second time to stop pushing/pulling, hover over a point on the top of the box; now the cylinder is exactly that tall. To complete the operation, click while you’re still hovering over the box. This technique is pretty simple and saves you hours of time after you’re used to doing it.

	
Pushing/pulling a face into another coplanar face automatically cuts a hole. In fact, this is how you make openings (like doors and windows) in double-face walls. The last graphic shows this in action.
Pushing/pulling to cut an opening works only when the cursor locks on to an inference on the desired face. If you push too far, you get a lump sticking out the other side; not pushing far enough makes a pocket. Keep an eye out for the blue On Face inference, or look for geometry you can inference to.


	You can push/pull preselected faces. The Push/Pull tool works just like the Move, Rotate (Q), Offset (F), and Scale tools: You can preselect a face before you start using the tool. This comes in handy when you need to extrude a face that you can’t see — rare, but handy nonetheless.




[image: Schematic illustration of using Push/Pull tool.] 










Adding floors to your building

Adding a second (and third, and fourth) floor to your model isn’t as hard as it may seem. The key is to think of each level as a separate tray consisting of interior walls, a floor surface, and the ceiling of the level below. You model each floor as an individual group, making it easier to hide, edit, and move.

For the same reasons, you make the exterior walls a separate group. They act kind of like a box into which your floor levels stack, as shown in Figure 4-19.



[image: Schematic illustration of floor levels which are like trays stacked inside a box consisting of the exterior walls.] 
FIGURE 4-19: Floor levels are like trays stacked inside a box consisting of your exterior walls.






Making groups to keep things separate

If you’ve been following along since the beginning of this chapter, the edges and faces that make up your exterior walls are already enclosed in a group by themselves. If they’re not, seriously consider doing that now. If you take the time to group your exterior walls before you add floors to your building, you save hours of headache later. Trust us. Have we lied to you recently?

[image: Tip] If you started this project as a separate exterior model, you can make a group in that file. Now, with two instances of SketchUp running, you can copy the exterior model, or at least its wall plan, and paste it into the interior model to make sure that things line up.

[image: Warning] Otherwise-well-meaning people who have worked with other CAD or 3D modeling programs often take this opportunity to bring layers into the discussion. Yes, SketchUp had a Layers feature in earlier releases. And yes, floor trays are a lot like layers, at least conceptually. But you should not have used Layers when modeling multiple levels of the same building. Layers in SketchUp simply didn’t work the way you might think they should. This issue is so important that the current SketchUp releases changed their name to Tags. Chapter 7 explains how SketchUp Tags work — and how misusing them can make a mess of your 3D model.

If your exterior walls are already a group, the next step is turning the rest of your first floor’s geometry into another group. This is how you do just that: 

	
Select the floor and interior walls of the first level.

[image: Tip] You can accomplish this efficiently with the Select tool: Just triple-click a face on any interior wall to select everything that’s attached to it. Chapter 3 has plenty of tips on selecting things.


	
Make a group.

Right-click and then choose Make Group from the shortcut menu.

Chapter 5 is all about groups and components; peruse the first few pages if you’re utterly confused about what just happened.




 
Drawing the next floor

Modeling each new floor directly on top of the one underneath guarantees that everything in your building lines up. Some folks advocate working off to the side and putting things together later, but this can be a recipe for trouble. Here’s how you add a second floor to the house model. Check out Figure 4-20 to see the first four steps as pictures: 

	[image: 9781119617938-ma004] With the Line tool, trace the inside perimeter of the exterior wall to create a new face.
Keep in mind that tracing works only if everything you touch is already part of another group. If it isn’t, your new edges stick to your existing ones, and your model becomes very, very messy.


	[image: 9781119617938-ma003] Push/pull your new face into a thick slab.
How thick? It depends on your building, but a reasonable ceiling-to-floor distance between levels for houses is about 1 foot. You can figure yours out with a tape measure and a calculator.

[image: Tip] The underside of the new slab is the ceiling of the first floor. Modeling buildings this way improves visibility because it enables you to hide a floor group to see the one below it.


[image: Schematic illustration of drawing right on top of the lower floor and then push/pull the interior walls to ceiling height.] 
FIGURE 4-20: Draw right on top of the lower floor; then push/pull the interior walls to ceiling height.







	
Draw the interior walls of the new floor.

This is just like drawing the first floor. Switch to the Top view (Camera ⇒ Standard Views ⇒ Top) (Web; Views panel) and then use the Tape Measure, Eraser, and Line tools to draft your floor plan. Just start at the very beginning of this chapter for a refresher.

[image: Tip] If the floor you’re drawing is bigger than the one below it, its outline overlaps the main-floor exterior walls. That’s okay — just pay special attention to where your edges and faces end up as you draw the walls.

[image: Warning] When drawing the top-floor wall edges, make sure that you’re always working on the top of your ceiling/floor slab. It’s all too easy to pick a point at ground level or somewhere on the ground-floor structure. Watch those inferences! Orbit every once in a while to check that everything’s copacetic.

In the event that your new floor is smaller than the one underneath, represent the inside boundary of the new exterior walls with a single edge. The next section explains what to do when your first and second floor plans don’t match up exactly.


	
Push/pull your interior walls to the correct height.

That’s 8 feet in this example.


	
Group together your interior walls and your floor.

The floor for this level is also the ceiling of the level below.

If you’re unsure of how to do this, take a look at the steps in “Making groups to keep things separate” a few pages back.

[image: Tip] If your top-floor exterior wall isn’t exactly the same size and shape as your bottom floor, skip step 6.


	
If your top floor is the same size and shape as your lower floor, pull up your exterior wall to match your interior ones.

Here, you’re extending the box that holds your floor trays up another level. Double-click the top face of the wall to unlock the lower-floor group, click the top face of the wall, and use the Push/Pull tool to pull it upward until you can click an inference on the top face of an upper-floor wall. Now right-click somewhere outside your building and choose Close Group from the shortcut menu.



[image: Tip] As you push/pull the wall upward, here’s a little trick to make sure that it comes up exactly the right amount. When you’ve started to push/pull, move the cursor off the top of the wall. As you move the cursor around, you find inferences to whatever geometry is close. If you click an interior wall edge that’s close to where you selected the top of the lower wall, the lower wall locks to exactly the same height as the upper-floor interior wall.

Chances are that your newest floor doesn’t line up exactly with the one below it. Read the next section to find out what to do. If your building does happen to be one of the few with perfectly aligned floor plans, you can skip the next section. Congrats! You’re a lucky devil.


 
Creating additional exterior walls

Most buildings aren’t simple extrusions; they bump in and out as they rise. Second-floor decks sit atop first-floor garages; bedrooms cantilever over gardens; intermediate roofs shelter new room additions. Buildings — especially multilevel houses — are complicated assemblies. Figuring out where walls, floors, and ceilings come together takes time, trial and error, along with a good dose of spatial reasoning. It’s best not to attempt the steps in this section when you’re tired or distracted.

In the house models for this chapter, the second floor both overhangs and, um, underhangs (hooray for neologisms) the first floor. Wherever this happens, you need to add a new section of exterior wall, as shown in Figure 4-21.



[image: Schematic illustration of outline of the second floor which doesn’t exactly match that of the first.] 
FIGURE 4-21: The outline of the second floor doesn’t exactly match that of the first.






To begin the second floor, draw faces to define any new exterior walls. Follow these steps, which correspond to Figure 4-22: 

	With the Line tool, trace the inside perimeter of your new exterior walls.

	
Hide the group that includes your second-floor interior walls by right-clicking it and choosing Hide from the shortcut menu.

You created this group by following the steps in the preceding section, “Drawing the next floor.”


	
Select the face that you created when you traced the inside perimeter in step 1.

Don’t see a face? Maybe you forgot to draw an edge somewhere.



[image: Schematic illustration of using the Offset tool to draw faces that represent new exterior walls.] 
FIGURE 4-22: Use the Offset (F) tool to draw faces that represent new exterior walls.








	
With the Offset (F) tool, offset the edges of your selected face by the thickness of your exterior walls.

In this case, the thickness is 8 inches.


	Delete the face in the center, leaving only a face that represents your new exterior wall thickness.

	Unhide the group you hid in step 2 by choosing Edit ⇒ Unhide ⇒ Last.





After you define the exterior wall face, you fine-tune how the second floor rests on top of the first floor by following these steps: 

	Make a group out of your new exterior wall face by selecting it, right-clicking, and choosing Make Group from the shortcut menu.

	
Delete any floor geometry that doesn’t belong.

In Figure 4-23 (top), part of the second floor extends past the exterior wall on the left side of the figure. Double-click the group with the Select tool to edit it, and use the Eraser to take away only the geometry that doesn’t belong on your new floor, being careful to leave the ceiling that covers the first floor.


	With the Select (E) tool, double-click the exterior wall face to open the group you created in step 1.

	Push/pull down any wall faces to meet the top of the lower floor’s exterior wall (see Figure 4-23, bottom).


Only now are you ready to ensconce your second floor in its new exterior walls. Doing so is yet another multistep process: 

	Make all your exterior walls part of the same group: 
	Select the group that contains your new exterior walls, then use the keyboard shortcut for Cut: CTRL + X (Mac: Command + X).

	
With the Select tool, double-click the group containing your lower exterior walls.

You’re inside that group.


	Go to Edit ⇒ Paste in Place (Web: Right-click and click the Paste in Place icon).

	
Right-click and then choose Explode from the shortcut menu to ungroup the edges and faces in the selected group, sticking them to those in the lower group.

Whew.




[image: Schematic illustration of deleting extra floor faces and then push/pull down the walls.] 
FIGURE 4-23: Delete extra floor faces; then push/pull down the walls.







	[image: 9781119617938-ma004] With the Line tool, add any necessary edges, and with the Eraser tool, delete any extraneous ones.
In Figure 4-24, you can see where the model has extra edges that need to be deleted.

[image: Remember] Using your SketchUp virtuosity, watch the colors as you draw, use the Shift key to lock inferences, and remember to zoom in on what you’re doing. Skimming Chapter 3 provides useful pointers on these actions.


	[image: 9781119617938-ma003] With the Push/Pull tool, extrude your exterior walls up to the height of your second-floor interior walls (also shown in Figure 4-24).

	[image: 9781119617938-ma008] Orbit around your model to make sure that all is well.
You can see the result in the bottom-right section of Figure 4-24.





[image: Schematic illustration of making the exterior walls look right.] 
FIGURE 4-24: Do what you need to do to make your exterior walls look right.








Going up, up, and away

[image: Tip] Now that you’re privy to the favorite technique for modeling multilevel buildings, you can build up as high as you like. As you proceed, the following tidbits may be helpful: 


	Hide things to get a clearer view for your current task. When you right-click any entity and choose Hide from the shortcut menu, it’s often easier see what you’re doing. This is particularly true of groups, which is why, in the steps in the preceding sections, you go to so much trouble to create those groups. To see groups that are hidden, choose View ⇒ Hidden Objects. To unhide something that’s hidden, right-click and choose Unhide from the shortcut menu. (Web: The Hidden Object control is available in the Display panel.)

	Better yet, use the Outliner. Chapter 7 is all about making your SketchUp life easier by using certain tools to work more efficiently. If you’re up for it, skip ahead and read the stuff about the Outliner, which is hyperrelevant to staying organized and seeing what’s where as you create a multilevel building.

	There’s gold in Model Info. In the desktop version, choose Window ⇒ Model Info and then click the Components option on the left side of the dialog box. Next to the Fade Rest of Model slider, select the Hide check box. With this check box selected, everything outside the group you’re currently editing becomes hidden. Smart modelers (such as yourself) make liberal use of this gem when cutting doors and windows in interior walls, which is the topic of the next section. (Web: You can toggle Hide Rest of Model by using search.)






 
Inserting doors and windows

To add doors and windows, the best method depends on what kind of building you’re modeling, whether you’re using single-face or double-face walls, and how much detail you plan to include in your model. You can make openings in your walls in a couple of ways: 


	Cut openings with SketchUp components. The SketchUp 3D Warehouse (read all about it in Chapter 5) contains scores of doors and windows that you can download and use in your models. Some of them cut their own openings when you insert them into a face. Here’s the catch, though: SketchUp’s cut-opening components work only on single-face walls, which means that they’re really useful only for exterior building models. If you’re building an interior model, you have to cut your own openings.

	Cut openings yourself. For double-face walls, this is your only option; luckily, it’s easy to do. Draw the opening’s outline and then use the Push/Pull tool to create the opening. The process is the same for doors and windows.

 
Using SketchUp’s handy-dandy components

As long as you’re making an exterior model, you can use the door and window components from SketchUp’s 3D Warehouse. Without going into a ton of detail, here’s what you need to know about them: 


	
Components are accessible from the Components panel. The Components panel appears on the Default Tray, but if you don’t see it, check whether Components is selected on the submenu that appears when you choose Window ⇒ Default Tray. (Web: The Components tool is located on the toolbar down the right side of the screen. It looks like a pile of three blocks.) On the Components panel, click the drop-down menu next to the In Model icon, and choose Construction, which contains the Doors, Windows, and DC Doors and Windows collections. Components that can cut their own openings generally contain gluing or cutting in their descriptions.

[image: Remember] You need to be online to access the 3D Warehouse.


	
You can find hundreds more components online. If you’re connected to the Internet, you can type any search query (such as revolving door) in the little search box at the top of the Components panel to scour the 3D Warehouse for your search term. Results appear below the search box.

[image: Tip] Some advice: The 3D Warehouse holds so much stuff that making your query specific helps you sort through the results.


	Components are editable. You find details in Chapter 5, but here’s the gist: If you don’t like something about a component you find online, you can change it.

	Some components are dynamic. Dynamic Components have special capabilities that make them easier to resize and otherwise reconfigure. You can read all about Dynamic Components in Chapter 5.

	When components cut their own openings, the openings aren’t permanent. When you move or delete a hole-cutting door or window component you’ve placed in a model, the opening goes with the component.



Follow these steps to add a door or window component to your model: 

	[image: 9781119617938-ma015] With the Tape Measure tool, create guides to help you line up your doors or windows.
Guides are the best way to ensure that everything’s in the right spot. In Figure 4-25, two horizontal guides (which are 2.5 feet from the bottom of the exterior wall) mark where to place the bottom of the windows. One vertical guide marks where to place the right edge of the door. After the operator placed the door, they created a guide 4 feet from each side of the door, to help place the windows symmetrically. Chapter 3 explains how to create guides.


	
In the Components panel, select the component that you want to place in your model.

For help navigating the Components panel, see Chapter 5.


	
In the drawing area, click to place the component where you want it to be.

In Figure 4-25, you see one door and four instances of the window component.


	If you don’t like where your component is, use the Move tool (read all about it in Chapter 3) to reposition your component.




[image: Snapshot of placing window and door components in the model is a breeze.] 
FIGURE 4-25: Placing window and door components in your model is a breeze.








Making your own openings

Most of the time, you can’t get away with using SketchUp’s built-in door and window components. Because these components can’t cut through two-faced walls, they’re limited to external use. That’s okay, though; cutting your own holes in walls is quick and easy, and you end up with exactly what you want.

To cut a precise opening in a wall, here’s what you need to do; Figure 4-26 shows the basic steps: 

	
Mark where you want your opening to be with guides.

For a refresher on using guides, have a look at Chapter 3.

[image: Remember] If you’re drawing on a wall that’s part of a group, you need to edit that group to punch holes in the wall. To edit a group, double-click it with the Select tool. To stop editing, click somewhere off to the side of your model. Chapter 5 has more info about working with groups.


	[image: 9781119617938-ma004] [image: 9781119617938-ma002] Draw the outline of the opening you want to create, making sure to create a new face in the process.
Use the Line or Rectangle tool, and keep an eye out for the colored inferences, which let you know where you’re drawing.

If your wall is part of an exterior model and is only one face thick, simply select and delete the face for the opening.


	[image: 9781119617938-ma003] With the Push/Pull tool, extrude your new face back into the thickness of the wall until it touches the face behind it.
If everything goes well, your face disappears, taking with it the corresponding area of the face behind it. Now you have an opening in your wall. If your face doesn’t disappear, and no opening is created, it’s probably for one of the following reasons: 


	Your faces aren’t parallel. This technique works only if both faces are parallel. Keep in mind that just because two faces look parallel doesn’t mean that they are.

	You hit an edge. If you Push/Pull your face into a face with an edge crossing it, SketchUp gets confused and doesn’t cut an opening. Use Undo to get rid of the pesky edge (if you can), and try again.






[image: Schematic illustration of creating an opening through parallel faces with guides and the Push/Pull tool, .] 
FIGURE 4-26: With guides and the Push/Pull tool, create an opening through parallel faces.






[image: Tip] As you push/pull the face to create a window or door opening, here’s a little trick to make sure you go exactly the right amount. When you’ve started to push/pull you can move the cursor off the selected window face. As you move the cursor around, you find inferences to whatever geometry is close. If you click an interior wall edge or a face that is part of the other side of the wall (you may have to orbit to do this), the opening will be cut properly. If you push/pull too far, you get a lump on the other side; not going far enough creates a recess in the wall.

[image: Tip] Don’t forget to orbit! If you can’t quite push/pull the correct amount, orbit around until you can see what you’re doing. Better yet, if you didn’t go the correct distance, you can always come back later and push/pull to fix the problem.







Staring Down Stairs

You can make stairs in probably a million ways in SketchUp, and in the following sections, you find two methods that work equally well.

Chapter 5 contains a third, slightly trickier (but way more powerful) way of making stairs by using components. SketchUp’s Dynamic Components have some pretty neat implications for models that need stairs. A so-called dynamic stair component automatically adds or subtracts individual steps as you make the component bigger or smaller with the Scale tool. Depending on what you want to accomplish, a premade dynamic stair component may save you a bunch of time. Find out more in Chapter 5.

Before you dive in, here’s some simple stairway vocabulary, just in case you need it. Figure 4-27 provides a visual reference: 


	Rise and run: The rise is the total distance your staircase needs to climb. If the vertical distance from your first floor to your second (your floor-to-floor distance) is 10 feet, that’s your rise. The run is the total horizontal distance of your staircase. A set of stairs with a big rise and a small run would be really steep.

	Tread: A tread is an individual step — the part of the staircase you step on. When someone refers to the size of a tread, they’re talking about the depth — the distance from the front to the back of the tread. Typically, this depth is anywhere from 9 to 24 inches, but treads of 10 to 12 inches are most comfortable to walk on.

	Riser: The riser is the part of the step that connects each tread in the vertical direction. Risers are usually about 5 to 7 inches high, depending on the building. Not all staircases have actual risers (think of steps with gaps between treads), but they all have a riser height.

	Landing: A landing is a platform somewhere around the middle of a set of stairs. Landings are necessary in real life, but modeling them can be a pain; figuring out staircases with landings is definitely more complicated. Sometimes, modeling a landing is easier if you think of it as being a really big step.



[image: Tip] Model steps as a group, separate from the rest of your building, and move them into position when they’re done. You can read all about groups in Chapter 5.



[image: Schematic illustration of the anatomy of a staircase.] 
FIGURE 4-27: The anatomy of a staircase.






The Subdivided Rectangles method

The Subdivided Rectangles method is how most people think to draw their first set of stairs. This method is intuitive and simple but a bit more time-consuming than the other methods in this book.

[image: Tip] The key to the Subdivided Rectangles method is a special trick you can do with edges: The Divide command lets you pick any edge and divide it into as many segments as you want. If you know how many steps you need to draw but not how deep each individual tread needs to be, the Divide command comes in really handy.

Here’s how the Subdivided Rectangles method works (see Figure 4-28): 

	[image: 9781119617938-ma002] Draw a horizontal rectangle the size of the staircase you want to build.

	[image: 9781119617938-ma001] With the Select tool, right-click a long edge of your rectangle and choose Divide from the shortcut menu.
If your staircase is wider than it is long, right-click a short edge instead.


[image: Schematic illustration of the subdivided rectangles method of building stairs.] 
FIGURE 4-28: The Subdivided Rectangles method of building stairs.







	
Before you do anything else, type the number of treads you want to create, and press Enter.

This command automatically divides your edge into many more edges, eliminating the need to calculate how deep each tread needs to be. Essentially, each new edge becomes a side of one of your treads.


	[image: 9781119617938-ma004] Draw a line from the endpoint of each new edge, dividing your original rectangle into many smaller rectangles.
You can use the Line or the Rectangle tool to do this.

[image: Warning] Make sure to watch out for those inferences! The ends of each line segment aren’t visible until you pick up the inference. It’s all too easy to connect to the midpoint of a segment or to the wrong segment.


	From one of the corners of your original rectangle, draw a vertical edge that’s the height of your staircase’s total rise.

	
Use the Divide command to split your new edge into however many risers you need in your staircase (generally, your number of treads plus one).

Repeat steps 2 and 3 to do this. The endpoints of your new little edges tell you how high to make each step.


	[image: 9781119617938-ma003] Push/pull the rectangle that represents your last step to the correct height.
Here’s where you need to use the hover-click technique that we describe in the sidebar “More fun with Push/Pull” earlier in this chapter. Just click to push/pull, hover over the endpoint that corresponds to the height of that tread, and click again. Your step is automatically extruded to the right height.

[image: Remember] Extrude your highest step first, but remember that it doesn’t go all the way to the top. You always have a riser between your last step and your upper floor.


	Repeat step 7 for each remaining step.

	[image: 9781119617938-ma006] Use the Eraser tool to eliminate extra edges you don’t need.

 


The Copied Profile method

Like the Subdivided Rectangles method, the Copied Profile method for modeling a staircase relies on using the Push/Pull tool to create a 3D form from a 2D face. But Copied Profile is more elegant. In a nutshell, draw the profile — the side view, sort of — of a single step and then copy as many steps as you need, create a single face, and extrude the whole thing into shape. The first time you do this is breathtakingly satisfying — one of those “guaranteed to make you smile” SketchUp operations you’ll want to repeat for friends (assuming that you have nerdy friends like ours).

Follow these steps to make a staircase with the Copied Profile method (see Figure 4-29): 

	
Start with a large vertical face.

Make sure that this face is big enough for the flight of stairs you want to build. You’re going to end up pushing/pulling the whole shebang out of the side of this face — just so you know.


	
In the bottom corner of the face, draw the profile of a single step.

The Line tool is a great choice, although you may want to use an arc or two, depending on the level of detail you need. For a refresher on drawing lines accurately, check out Chapter 3.


	[image: 9781119617938-ma001] Select all the edges that make up your step profile.
[image: Tip] You can hold down the Shift key while clicking with the Select tool to select multiple entities. Chapter 3 has lots of selection tips.


	
Make a copy of your step profile, and place it above your first one.

If you’re unfamiliar with how to make copies with the Move tool, see Chapter 3.


	
Type the number of steps you want to make, type x, and then press Enter.

If you want ten steps, for example, type 10x. This technique repeats the copy operation by however many times you tell it to; the x after the number tells SketchUp to make copies.


	If you need to, draw an edge to make sure that all your step profiles are part of a single face.

	[image: 9781119617938-ma003] Push/pull the staircase face to reflect the desired width of your staircase.
This part seems like magic to most folks; we don’t think it ever gets old.





[image: Schematic illustration of the Copied Profile method.] 
FIGURE 4-29: The Copied Profile method.






[image: Tip] This method of stairway building also works great in combination with the Follow Me tool, covered in Chapter 6. Figure 4-30 whets your appetite. Follow Me is cool beans all the way around.



[image: Schematic illustration of using Follow Me with the Copied Profile method produces some impressive geometry, indeed.] 
FIGURE 4-30: Using Follow Me with the Copied Profile method produces some impressive geometry, indeed.










Raising the Roof

If you’re lucky, the roof you want to build is fairly simple. Unfortunately, home builders sometimes go a little crazy, creating roofs with dozens of pitches (slopes), dormers, and other doodads that make modeling them a nightmare. For this reason, this section keeps things pretty simple: The following sections show you how to identify and model basic roof forms. After that, you discover a great tool — Intersect Faces — that you can use to assemble complicated roofs from less-complicated pieces.

[image: Tip] The tricky thing about roofs is that they’re hard to see. If you want to make a model of something that already exists, it helps to get a good look at it — but that’s not always possible with roofs. Google Maps offers a neat way to view an existing roof you’re trying to build.

[image: Warning] Always, always make a group out of your whole building before you work on your roof. If you don’t, your geometry starts sticking together; you end up erasing walls by accident; and eventually, you lose your mind (if you haven’t already). On top of that, the ability to separate your roof from the rest of your building whenever you want is handy. You can also group your roof, if that makes sense for what you’re doing. Check out Chapter 5 for a full rundown on making and using groups.

Before you dive in, here’s a brief guide to general roof types and terminology that may come in handy for the explanations later in this chapter. Figure 4-31 illustrates the following terms: 


	Flat: Flat roofs are just that, except that they aren’t; if a roof were really flat, it would collect water and leak. That’s why even roofs that look flat are sloped very slightly.

[image: Schematic illustration of the different kinds of roofs and their various and sundry parts.] 
FIGURE 4-31: Different kinds of roofs and their various and sundry parts.







	Pitched: Any roof that isn’t flat is technically a pitched roof.

	Shed: A shed roof is one that slopes from one side to the other.

	Gabled: Gabled roofs have two planes that slope away from a central ridge.

	Hip: A hip roof is one in which the sides and ends slope in different directions.

	Pitch: Pitch is the angle of a roof surface.

	Gable: A gable is the pointy section of wall that sits under the peak of a pitched roof.

	Eave: Eaves are the parts of a roof that overhang the building.

	Fascia: Fascia is the trim around the edge of a roof’s eaves where gutters are sometimes attached.

	Soffit: A soffit is the underside of an overhanging eave.

	Rake: The rake is the part of a gabled roof that overhangs the gable.

	Valley: A valley is formed when two roof slopes come together; this is where water flows when it rains.

	Dormer: Dormers are the little things that pop up above roof surfaces. They often have windows and make attic spaces more usable.

	Parapet: Flat roofs that don’t have eaves have parapets — extensions of the building’s walls that go up a few feet past the roof itself.





Building flat roofs with parapets

Good news! SketchUp was practically made for modeling these kinds of roofs. By using a combination of the Offset and Push/Pull tools, you can make a parapet in less than a minute. Follow these steps, shown in Figure 4-32: 

	[image: 9781119617938-ma047] With the Offset (F) tool, click the top face of your building.

	Click again somewhere inside the same face to create another face.

	
Type the thickness of your parapet and then press Enter.

This step redraws your offset edges to a precise distance from the edges of your original face. How thick should your parapet be? It all depends on your building, but most parapets are between 6 and 12 inches thick.


	[image: 9781119617938-ma003] Push/pull your outside face (the one around the perimeter of your roof) into a parapet.

	Type the height of your parapet and then press Enter.

 

PITCHED ROOFS CAN MAKE YOU CRAZY
 
That fact notwithstanding, a few tips might make building your next pitched roof a little easier: 


	Start by making the rest of your building a group. As we warn you elsewhere in this section, you should always make a group out of your whole building before you start working on your roof.

	Draw a top view of your roof on paper first. Working out the roof's basic shape in your mind can help you figure out how to manage the roof’s details. Adding measurements and angles is even better, because these details help you know what to do in SketchUp.

	Figure out how to use the Protractor tool. This tool (which is on the Tools menu) is for measuring angles and, more important, creating angled guides. Because sloped roofs are all about angles, you probably need to use the Protractor sooner or later. To find out how this tool works, open the Instructor panel and then activate the Protractor tool. Chapter 3’s section on rotating can also help you because, in many ways, the Protractor tool behaves like the Rotate tool.




[image: Schematic illustration of the modeling parapets on flat-roofed buildings is easy.] 
FIGURE 4-32: Modeling parapets on flat-roofed buildings is easy.








Creating eaves for buildings with pitched roofs

The easy way to create eaves, or roof overhangs, is to use the Offset (F) tool. Follow these steps to get the general idea (and see Figure 4-33): 

	
Make a group out of your whole building before you start modeling the roof.

Keeping your roof separate makes your model easier to work with.


	[image: 9781119617938-ma004] With the Line tool, create an outline on top of the group for the parts of your roof that will have eaves of the same height.
The goal is a single face that you can offset. A lot of buildings have complex roofs with eaves of different heights; for the sake of this step, just create a face that, when offset, will create roof overhangs in the right places.


	[image: 9781119617938-ma047] With the Offset (F) tool, create an overhanging face.
For instructions on how to use Offset (F), see “Dusting off SketchUp’s drafting tools” earlier in this chapter.


	[image: 9781119617938-ma006] Erase the edges of your original face.
Here’s a quick way to do this with the Select tool: 

	
Double-click inside your first face.

This step selects both the face and the edges that define it.


	Press Delete to erase everything that’s selected.



	[image: 9781119617938-ma003] Push/pull your overhanging roof face to create a thick fascia.
Different roofs have fasciae of different thicknesses; if you don’t know yours, just take your best guess.





[image: Schematic illustration of eaves which are the parts of the roof that overhang a building’s walls.] 
FIGURE 4-33: Eaves are the parts of the roof that overhang a building’s walls.








Constructing gabled roofs

You can construct a gabled roof in a bunch of ways (every SketchUp expert has a favorite), but one method works particularly well.

Follow these steps to build a gabled roof, as shown in Figure 4-34: 

	
Create a roof overhang, following the steps in the preceding section.

Most gabled roofs have eaves, so you probably need to create them for your building.


	
With the Protractor tool, create an angled guide at the corner of your roof.

The nearby sidebar “Pitched roofs can make you crazy” points you to help with the Protractor.


[image: Schematic illustration of Gabled roofs which are relatively easy to make in SketchUp.] 
FIGURE 4-34: Gabled roofs are relatively easy to make in SketchUp.





[image: Technical Stuff] Architects and builders often express angles as rise over run ratios. A 4:12 (pronounced 4 in 12) roof slope, for example, rises 4 feet for every 12 feet it runs. A 1:12 slope is very shallow, and a 12:12 slope is very steep. When you’re using the Protractor tool, SketchUp’s Measurements box understands angles expressed as ratios as well as those expressed in degrees. Typing 6:12 yields a slope of 6 in 12, for example.




	[image: 9781119617938-ma004] With the Line tool, draw a vertical edge from the midpoint of your roof to the angled guide you created in step 2.
The point at which your edge and your guide meet is the height of your roof ridge.


	
Draw two edges from the top of your vertical line to the corners of your roof.

This step creates two triangular faces.


	[image: 9781119617938-ma006] Erase the vertical edge you drew in step 3 and the guide you drew in step 2.

	
Push/pull back your triangular gable.

[image: Remember] Use a point inference to the corner of the other end of the overhang to ensure that you push/pull the correct distance.

If your gabled roof extends all the way to the other end of your building, push/pull it back that far. If your roof runs into another section of roof, as shown in Figure 4-35, extrude it back until it’s completely buried. The section “Sticking your roof together with Intersect Faces,” later in this chapter, has more information on how to make a complex roof.


[image: Schematic illustration of letting the gabled roof run into another roof pitch, if it is a part of the larger roof structure.] 
FIGURE 4-35: If your gabled roof is part of a larger roof structure, it may just run into another roof pitch. Let it.







	
Finish your eaves, fascia, soffit, and rake(s) however you want.

Gabled roofs have more details than we can cover, but Figure 4-36 shows a few common ones.





[image: Schematic illustration of some common gabled roof details.] 
FIGURE 4-36: Some common gabled roof details.








Making hip roofs

Believe it or not, building a hip roof is easier than building a gabled one. Hip roofs don’t have rakes, which makes them a lot less complicated to model. Because hip roofs have pitches that are the same on all sides, the following steps describe a simple trick to figure out where to locate the hip in your roof: 

	Follow steps 1 through 5 in the preceding section, “Constructing gabled roofs.”

	Measure the distance from the midpoint of the gable to the corner of the roof.

	
With the Tape Measure, create a guide the distance you just measured from the end of the gable, as shown in Figure 4-37.

The guide should be parallel to the edge of the angled face, and offset from it by the measured distance.

[image: Remember] Pressing the Ctrl key (Option on a Mac) toggles the Tape Measure tool between measuring distances versus making guides.


	
Draw edges from the point on the ridge where the guide intersects it to the corners of your roof, as shown in Figure 4-37.

This step does two things: It splits the sides of your roof into two faces each and creates a new face (which you can’t see yet) under the gabled end of your roof.


	
Erase the three edges that form the gabled end of your roof, revealing the hipped pitch underneath.

Neat, huh? Now all three faces of your roof are the same pitch — just the way they should be.


	If appropriate, repeat the process on the other end of your roof.




[image: Schematic illustration of starting with a gabled one to make a hip roof.] 
FIGURE 4-37: To make a hip roof, start with a gabled one.








Sticking your roof together with Intersect Faces

In general, the newer and more expensive a house is, the more roof slopes it has. Who knows why this is the case? Maybe folks think complex-roofed houses look more like French chateaus. Whether crazy roofs are good things isn’t relevant to this book, but they’re a pain in the gutters to model.

Luckily, SketchUp has a relatively little-known feature that often helps when it comes to making roofs with lots of pitches: Intersect Faces. Here’s what you need to know about this terrific little tool: 


	Intersect Faces makes new geometry from existing geometry. It takes faces you’ve selected and creates edges wherever they intersect. Figure 4-38 shows what we mean. Perhaps you want to make a model that’s a cube with a cylindrical chunk taken out of it. You’d model the cube and model the cylinder. After positioning them carefully, you can use Intersect Faces to create edges where the two shapes’ faces come together. After that, the Eraser can remove the edges you don’t want — the rest of the cylinder, in this case.

	Intersect Faces and the Eraser tool go hand in hand. Any time you use Intersect Faces, you need to follow up by deleting unwanted geometry. To find it all, orbit, zoom, and pan around your model, zapping stray lines and faces with the Eraser as you go.

	Most of the time, choose Intersect Faces with Model. This tool has three modes, but the majority of the time, you use the basic one. Here’s what all three modes do: 
	Intersect Faces with Model: Creates edges everywhere your selected faces intersect with other faces in your model, whether the other faces are selected or not.

	Intersect Faces with Selection: Creates edges only where selected faces intersect with other selected faces. This is handy if you’re trying to be a little bit more precise.

	Intersect Faces with Context: Choosing this option creates edges where faces within the same group or component intersect; that’s why it’s available only when you edit a group or component.



[image: Schematic illustration of using Intersect Faces to cut a partial cylinder out of a cube.] 
FIGURE 4-38: Using Intersect Faces to cut a partial cylinder out of a cube.







	Intersect Faces doesn’t have a button. To use it, you have to 
	Right-click and choose Intersect Faces from the shortcut menu. (Web: This option is the only one.)

	Choose Edit ⇒ Intersect Faces.





When you’re creating roofs, you can use Intersect Faces to combine a whole bunch of gables, hips, dormers, sheds, and so on into a single roof. Doing so is no cakewalk, and it requires a fair amount of planning, but it works great when nothing else will.

Figure 4-39 shows a complicated roof with several elements. Gabled roofs have been pushed/pulled into the main hip roof at different heights, but edges don’t exist where all the different faces meet. In the steps that follow, use Intersect Faces to create the edges you want and then use the Eraser to clean up the mess: 

	
Select the whole roof.

[image: Tip] If you grouped your building and roof the way we recommend earlier in this chapter, here’s a time-saving trick: Hide the group that contains the rest of your building and then draw a big selection box around the whole roof with the Select tool.


	
Choose Intersect Faces ⇒ With Selected.

This command tells SketchUp to create edges everywhere faces intersect — that is, everywhere faces pass through one another without an edge.


	
With the Eraser, carefully delete the extra geometry on the inside of your roof, as shown in Figure 4-39.

Although this erasing can be a lot of work, it’s a whole lot easier than using the Line tool and SketchUp’s inference engine to figure out where complex roof details should go.





[image: Schematic illustration of a typically complex roof that Intersect Faces can unify.] 
FIGURE 4-39: Here’s a typically complex roof that Intersect Faces can unify.








WHEN ALL ELSE FAILS, USE THE LINE TOOL
 
Fancy tools like Follow Me and Intersect Faces are useful most of the time, but for some roofs, you just have to resort to drawing good old edges. If that’s the case, you’d better get familiar with most of the stuff at the beginning of Chapter 3, because you’re going to be inferencing like there’s no tomorrow. SketchUp users who really know what they’re doing can draw anything with the Line and Eraser tools, which is beautiful to watch but beyond the scope of this book.

All the same, the following figure shows how the Line tool and SketchUp’s venerable inference engine help you draw a gabled dormer on a sloped roof surface. With practice, you can do it. 


[image: Schematic illustration of drawing a gabled dormer on a sloped roof surface.] 













  

Chapter 5

Falling in Love with Components

IN THIS CHAPTER

[image: check] Organizing geometry into groups

[image: check] Discovering the wonder and majesty of components

[image: check] Getting familiar with Dynamic Components

[image: check] Using components to make symmetrical models

[image: check] Building stairs with component instances



If we had our way, this chapter would begin with the word COMPONENTS printed 4 inches high and colored neon green. Components are that important.

Making a component or a group is like gluing together geometry in your model. Edges and faces that are grouped together act like minimodels inside your main model. You use components and groups to more easily select, move, hide, and otherwise work with parts of your model that need to be kept separate. If the roof of a house model is a component or group, for example, you can easily hide or move the roof so that you can peer inside the house from above.

Now that you know how components and groups are alike, here’s how they’re different: 


	Groups are simple conglomerations of edges and faces. They’re extremely similar to AutoCAD groups.

	Components are groups with an all-important, added benefit: Changes you make to one instance (copy) of a component automatically apply to all the other component instances in your model. So change one window component, and you change all instances in which that window component appears in your model. This is extremely similar to AutoCAD blocks.



[image: Remember] Learning to use groups and components is the single biggest thing you can do to get better at SketchUp.

This chapter is about creating and using SketchUp groups and components to make your life a whole lot simpler. We begin by talking about groups (which have a lot in common with components). After that, we jump into components — finding them, managing them, and making your own.

In the last section of this chapter, you learn a couple of modeling techniques that take advantage of component behavior. They’re guaranteed to save you time and effort, and using them will make you feel like a rock star — one who makes 3D models, at least.



SketchUp Groupies

SketchUp geometry (the edges and faces that make up your model) is sticky. In other words, stuff in your model wants to stick to other stuff. The people who invented SketchUp built it this way on purpose but also knew you’d sometimes need to separate geometry too. Suffice it to say, making and using groups are the keys to keeping the stuff in your model from sticking together. Here are a few reasons for you to make groups: 


	Grouped geometry doesn’t stick to anything. Perhaps you’ve modeled a building, and you want to add a roof. You want to move the roof out of the way with the Move tool, but every time you try, you pull the top part of the house along with it (like the middle image in Figure 5-1). Making the roof a separate group enables the roof to sit on top of your house without sticking to the walls, as shown in the right image in Figure 5-1.

[image: Schematic illustration of making the roof into a group means that it won’t stick to the rest of the building.] 
FIGURE 5-1: Making the roof into a group means that it won’t stick to the rest of your building.







	Using groups makes working with your model easier. You can select all the geometry in a group by clicking it with the Select tool. You can move groups and make copies with the Move tool.

	You can name groups. If you turn a selection of geometry into a group, you can give it a name. In the Outliner (covered in Chapter 7), you can see a list of the groups (and components) in your model, and if you’ve given them names, you can see what you have.

	Groups can be solids. Basically, a solid is any group (or component) whose geometry can be thought of as watertight — continuous, with no holes. Solids are important for three reasons: 
	If an object is a solid, SketchUp can calculate its volume. You can see a solid’s volume in the Entity Info panel.

	If an object is a solid, you can 3D Print it. See Chapter 9.

	The Solid Tools let you perform nifty modeling tricks using two or more solids. You can read all about the Solid Tools toward the end of Chapter 6.





Follow these steps to create a group: 

	[image: 9781119617938-ma001] Select the geometry (edges and faces) you want to turn into a group.
For help with making selections, check out Chapter 3.


	
Right-click the geometry and choose Make Group from the shortcut menu.

To ungroup the geometry in a group, you need to explode it. Right-click the group and choose Explode from the shortcut menu. The edges and faces that were grouped aren’t grouped anymore.



[image: Tip] To edit the geometry inside a group, double-click it with the Select tool. In edit mode, the rest of your model appears to fade back, and the box around the group (also known as the group’s context) changes from solid lines to dashed lines. To close the group’s context when you’re done editing, click outside it somewhere else in your modeling window.



Working with Components

Components make 3D modeling fast, fun, and easy, and this section explains all their special capabilities. After you discover components’ special magic, you might actually get excited about diving into the nitty-gritty of how components work: using the features in the Components panel, keeping your components organized, making your own components, and finding dynamic components that move when you click them.
 
What makes components so great?

If components were a sports team, we’d hold season tickets in the front row and attend every game, wearing fan jerseys and carrying homemade posters to cheer on our favorites. (Go, Architecture Collection!) Here’s why we’re big fans of using components whenever possible: 


	Everything that’s true about groups is true about components. That’s right: Components do everything that groups do. Components don’t stick to the rest of your model; you can give them meaningful names; and you can select them, move them, copy them, and edit them easily, just as you can groups.

	Components update automatically. Unlike groups, when you use multiple copies (called instances) of the same component in your model, all the instances of that component are spookily linked. Changing one makes them all change, which saves loads of time. In Figure 5-2, when the operator adds something (in this case, shutters) to one instance of their window component, all the instances are updated. After they change one component, all three windows have shutters.

[image: Schematic illustration of changing one instance of a component that changes all the other instances too.] 
FIGURE 5-2: Changing one instance of a component changes all the other instances too.







	The Components panel has special component-management features. Some of these feature are available only in SketchUp Pro. You can use the Components panel to count, select, substitute, and otherwise manage all the component instances in your model. (Groups don’t appear in the Components panel at all.) Figure 5-3 shows a basic building with a window component. In the bottom-left corner of the Component panel’s Statistics tab, you can see 18 instances of the window. On the Component panel’s Select tab, you can right-click to select all instances of the window and replace it with another component with only a few clicks. We chose a white sedan.

	

[image: Snapshot of quickly counting all the window instances in the model (top) or even swap them out for another component.] 
FIGURE 5-3: Quickly count all the window instances in your model (top) or even swap them out for another component.





Components can cut an opening automatically. Perhaps you’ve made a window, and you want that window to poke a hole through whatever surface you stick it to. On the Edit tab, explained a little later in this section, you can set up SketchUp components to cut their own openings in faces. Even better, these openings depend on the existence of the component; if you delete the component, the hole disappears.





[image: Remember] Components that cut openings can do so only through a single face. If your wall is two faces thick, your components cut through only one of them.


	You can use your components in other models. It’s simple to make any component you build available for use whenever you work in SketchUp, no matter what model you’re working on. If you have a group of parts or other things you always use, making your own component collection can save you a lot of time and effort. For more information about creating your own component collections, see the upcoming section “The Select tab.”

	Components are great for making symmetrical models. Because you can flip a component instance and keep working on it, and because component instances automatically update when you change one of them, using components is a great way to model anything that’s symmetrical. If you look around, you’ll notice that most things people use are symmetrical. The “Modeling symmetrically: Good news for lazy people” section near the end of this chapter dives headlong into modeling symmetrical things like couches and hatchbacks; Figure 5-4 shows examples.




	Components keep file sizes down. When you use several instances of a single component, SketchUp has to remember the information for only one of them. This means that your files are smaller, which in turn means you have an easier time emailing, uploading, and opening them on your computer.

[image: Schematic illustration of several vehicles.] 
FIGURE 5-4: What do these things have in common? They’re symmetrical.







	Components show in the Outliner. If you’re at all interested in not wasting time hunting for things you’ve misplaced, create lots of components. Doing so means that you can see, hide, unhide, and rearrange them in the Outliner, which is covered in Chapter 7.

	Components can save your sanity. Hooray! You’ve finished a model of the new airport — and it took only three weeks! Too bad the daylighting consultant wants you to add a sunshade detail to every one of the 1,300 windows in the project. If you made that window a component, you’re golden. If, on the other hand, that window isn’t a component, you’re going to spend a very long night holding hands with your computer mouse.

	Components can be dynamic. Dynamic Components (not available in the Web version) are components with special abilities. They can be set up with multiple configurations, taught to scale intelligently, programmed to perform simple animations, and more. Anyone can use existing Dynamic Components, but only people with SketchUp Pro can create new ones. Check out “Discovering Dynamic Components” later in this chapter for the whole story.

 

[image: Tip] THE SketchUp 3D WAREHOUSE
 
Imagine a place online where everyone in the world can share SketchUp models for free. That’s the 3D Warehouse in a nutshell. It’s hosted by Trimble (SketchUp’s parent company), it’s available in several languages, and it’s searchable — which is a very good thing because it’s jam-packed with models. Millions of ’em.

You can get to the 3D Warehouse in a couple of ways: 


	On the Web: Just type https://3dwarehouse.sketchup.com in your web browser.

	Through desktop SketchUp: You can open the 3D Warehouse in a separate window by choosing File ⇒ 3D Warehouse ⇒ Get Models. Any models you download will insert right into your SketchUp model. The Components panel is also hooked up directly to 3D.

	Through SketchUp for Web: The Components panel is located on the right side of the screen. It looks like a small pile of three blocks. From there, you can do a basic search and browse of 3D Warehouse.



If you have 3D Warehouse open in a web browser, it’s pretty easy to download a model and then drag/drop the file into either version of SketchUp.

Anything in the 3D Warehouse is available for you to download and use in your own models. You can also upload anything you make so that other people can use it. Find out more about sharing your work on the 3D Warehouse in Chapter 13.







Exploring the Components panel

The Components panel gives you a place to keep any components you make. You can also search for components that other people have made, which is a great way to spiff up your model without building everything yourself.

[image: Tip] You can bring any SketchUp model on your computer into your current file as a component. That’s because components are really just SketchUp files embedded in other SketchUp files. When you create a component in your model, you’re effectively creating a new, nested SketchUp file. Neat, huh?

The Components panel is made up of four major areas, each covered in the following sections.
 
Info and buttons

We don’t really know what to call this part of the Components panel, so we call it like it is: It’s for information and buttons. Figure 5-5 points out its elements, and here’s what everything does: 


	Name: The name of the component you select appears here. If your component is in your model, it’s editable. If the component is in one of the default collections, it’s not. A component is considered to be in your model if it appears in your In Model collection, which you can read about in the next section, “The Select tab.”

	Description: Some, but not all, components have descriptions associated with them. You can write one when you create a new component, or you can add one to an existing component in your model. Just as the name suggests, you can edit descriptions only for models that are in your In Model collection.

	[image: 9781119617938-ma016] Display Secondary Selection Pane button (SketchUp Pro only): Clicking this button opens a second view of your collections at the bottom of the Components panel. Use this view to manage the components on your computer.

 


The Select tab

This tab is where your components live (if they can be said to live anywhere). Use the Select tab to view, organize, and choose components. This tab looks a bit different in the desktop and web versions. Refer to Figure 5-5 as we walk you through your model’s component palette. 



[image: Snapshot of the components panel which is chock-full o’ goodness.] 
FIGURE 5-5: The Components panel is chock-full o’ goodness.






	[image: 9781119617938-ma011] In Model button: SketchUp automatically keeps track of the components you’ve used in your model and puts a copy of each of them in your In Model collection. Each SketchUp file you create has its own In Model collection, which contains the components that exist in that model. Clicking the In Model button displays the components in your In Model collection, if you have any. (Web: Everything contained in this section is on the In Model tab of the Components panel.)

	
Collections drop-down menu (SketchUp Pro only): You open this menu by clicking the down arrow next to the In Model button. The components listed in the Favorites area of this menu are a mix of two collection types: 


	Local collections are folders of components that live on your hard drive. You can access them any time because they refer to files on your computer.

	Online collections are groupings of components that live in the 3D Warehouse (see the nearby sidebar). Unlike with local collections, you can access online collections only when you’re — you guessed it — online.



Unfortunately, the Collections drop-down menu doesn’t indicate which collections are local and which are online. If you click the name of a collection and see a progress bar before you see any models, that collection is online.


	3D Warehouse search box: It works just like any regular search box: Type what you’re looking for, and press Enter. Models in the 3D Warehouse that match your search terms appear in the Components panel. Naturally, you need to be online for this feature to work. Read more about searching 3D Warehouse in Chapter 13.

	
Components panel: This panel displays the components in the selected component collection or the results of a 3D Warehouse search you’ve just performed. Click a component to use it in your model.

[image: Tip] Components that have a little green arrow icon next to them are special; they’re Dynamic Components (or DCs). They have special abilities. You can read about DCs later in this chapter, in the “Discovering Dynamic Components” section.


	[image: 9781119617938-ma017] View Options button: This button is pretty simple, really; it lets you decide how to view the components (or subcollections) in the Components panel. You can choose different thumbnail image sizes or a list view.

	[image: 9781119617938-ma018] Collection Details menu (SketchUp Pro only): Here’s where you manage your component collections. Following is a brief introduction to your options:

	Open a Local Collection: Lets you choose a folder on your computer system to use as a component collection. Any SketchUp models in that folder show up in the Components panel, ready to be used as components in your models.

	
[image: Tip] Create a New Collection: Allows you to create a folder somewhere on your computer system that you can use as a component collection. A collection is handy if you have several components that you use all the time; putting them all in one place makes them easier to find.


	Save As a Local Collection: When you choose this option, SketchUp lets you save the components that currently appear in your Components panel as a brand-new local collection. If the components you’re viewing are online, copies of them are downloaded to your computer. If you’re viewing your In Model collection, the contents are copied and included in a new folder. If you’re already viewing a local collection, this option isn’t available.

	View in 3D Warehouse: If you’re viewing an online collection, this option opens that collection in a separate window that displays the 3D Warehouse in much more detail.

	3D Warehouse Terms of Service: Choose this option if you’re having trouble sleeping. If you’re wondering who owns the stuff on the 3D Warehouse, this is where it’s at.

	Add to Favorites: Choosing this option adds whatever you’re viewing in the Components panel to the Favorites section of the Collections list. That goes for local collections (folders on your computer); online collections (from the 3D Warehouse); and 3D Warehouse searches. That’s right — you can save a search as a favorite collection. The models in a Favorite Search collection are always different, depending on what’s in the 3D Warehouse.





SELECT AND REPLACE ALL YOUR TROUBLES AWAY
 
On top of all the buttons, menus, and windows you can immediately see in the Select tab of the Components panel, you can find hidden options tucked away on a shortcut menu, which pops up when you right-click an In Model collection component: 


	Select Instances (SketchUp Pro only): Perhaps you have 15 instances (copies) of the same component in your model, and you want to select them all. Just make sure that you’re viewing your In Model collection; then right-click the component (in the Components panel) whose instances you want to select. Choose Select Instances from the shortcut menu, and your work’s done. This trick can save you tons of time, particularly if you have component instances all over the place. The feature even selects hidden instances and ones on layers that are turned off.

	Replace Selected: You may want to swap a different component for one that’s in your model. Simply select the component instances (in your modeling window) that you want to replace and then right-click the component (in the Components panel) that you want to use instead. Choose Replace Selected from the shortcut menu to perform the swap.



Ready for an even better tip? Using Select Instances and Replace Selected together helps you work more efficiently. Instead of placing 20 big, heavy tree components in your model (which can slow your work), use a smaller, simpler component instead (such as a stick). When you’re finished modeling, use Select Instances to select all the stand-in components and then use Replace Selected to swap in the real component. Figure 5-3 (earlier in this chapter) shows the mechanics of this operation, albeit using windows and cars.



The next two options appear only when you’re viewing your In Model collection: 


	Expand: Because components can be made up of other, nested components, a component you use in your model may really be lots of components. Choosing Expand displays all the components in your model, whether or not they’re nested inside other components. Most of the time, you probably want to leave Expand deselected.

	
[image: Tip] Purge Unused: Choose this option to get rid of any components in your In Model collection that aren’t in your model anymore. Be sure to choose this option before you send your SketchUp file to someone else; it significantly reduces your file size and makes the file a whole lot neater.









 


The Edit tab

Because the options in this part of the Components panel are similar to the ones you get when you make a new component, check out “Creating your own components” later in this chapter for the whole scoop (Web: You can expose these options by mousing over an In Model component and clicking the carat that appears).

[image: Tip] You can use the options in the Edit tab only on components in your In Model collection. Everything is dimmed for components that live in any other place.


 
The Statistics tab (only in SketchUp Pro)

Can you remember who won the 1975 Super Bowl? How many home runs did Hank Aaron hit in his career? (There are three signs of old age. The first is loss of memory.) Do you always check the nutrition information panel on food packaging? You may be a sucker for statistics, and if so, welcome home.

Even if you’re not a sucker for statistics, the Statistics tab is a useful place for keeping track of all the details related to whatever component you have selected in the Components panel. (See Figure 5-6.) This tab is especially useful for doing the following things: 


	Checking the size of your components: The information in the Edges and Faces areas of this tab lets you know how much geometry is in a component. If you’re worried about file size or your computer’s performance, try to use small components — ones with low numbers of faces and edges.

	Seeing what components are inside your components: The Component Instances line lists how many component instances are in your selected component. If you switch from All Geometry to Components in the drop-down list at the top of the tab, you can see all the constituent components: subcomponents within your main component.




[image: Snapshot of the statistics tab of the components panel, Geek out on numbers.] 
FIGURE 5-6: The Statistics tab of the Components panel: Geek out on numbers.






[image: Tip] The Statistics tab doesn’t show details for components you have selected in your actual model; it shows only information about the component that’s selected in the Select tab of the Components panel. To see information about whatever component (or other kind of object) you have selected in your modeling window, use the Entity Info panel (in the Default Tray).
 

SAVE TIME: GO SHOPPING
 
Why spend hours modeling an oak tree when you can buy a fantastic one for a reasonable price? If you can’t find what you need among the zillions of components that you can download for free from the 3D Warehouse, try a paid option. Form Fonts (https://www.formfonts.com) is a website that sells components all you can eat, buffet-style. You pay a (surprisingly low) monthly fee, and you have access to thousands of high-quality models of just about anything. The international team of modelers with Form Fonts even takes requests; if you need something that they don’t have, they can probably make it if you ask nicely. Even if you’re not interested in signing up, it’s worth checking out the website just to see the beautiful models Form Fonts makes.






Creating your own components

Creating simple components is a pretty easy process, but making more complicated ones — components that automatically cut openings, stick to surfaces, and always face the viewer — can be a little trickier. Follow these steps no matter what kind of component you’re trying to make: 

	
Select one or more entities that you want to turn into a component.

You can select edges, faces, images, guides, section planes — even other groups and components. For more information on making selections, see Chapter 3.


	
Right-click your selection and choose Make Component from the shortcut menu, or press the shortcut key: G.

The Create Component dialog box opens. (See Figure 5-7.)


	
Give your new component a definition and description.

[image: Tip] Of these two, the definition is by far the more important. Choose a definition that will enable you to understand what the component is in the Outliner or when you open your model a year from now.


	
Set the alignment options for your new component.

Wondering what the heck all this stuff means? Check out Table 5-1.


	
Select the Replace Selection with Component check box if it isn’t already selected.

This step drops your new component into your model right where your selected geometry was, saving you from inserting it from the Components panel.


	Click the Create button to create your new component.




[image: Snapshot of the creating Component dialog box.] 
FIGURE 5-7: The Create Component dialog box (so many options …).






[image: Remember] Components can cut through only one face at a time. If your model’s walls are two faces thick, you have to cut your window and door openings manually.




TABLE 5-1 Component Alignment Options

	
Option

	
What It Does

	
Tips and Tricks

	
Glue To

	
Makes a component automatically stick to a specific plane. A chair, for example, will almost always sit on a floor. It will almost never be stuck to a wall, turned sideways. When a component is glued to a surface, using the Move tool moves it only on that surface — never perpendicular to it (up and down, if the surface is a floor).

	
Use this feature for objects that you want to remain on the surface you put them on, especially objects you want to rearrange: Furniture, windows, and doors are prime examples. If you want to unstick a glued component from a particular surface, right-click it and choose Unglue from the shortcut menu.




	
Set Component Axes

	
Sets a component’s axis origin and orientation. This option is particularly important if you have SketchUp Pro and plan to make this component a Dynamic Component. If not, using this option is still a good idea. Setting the axis origin on an inferred point makes it very easy to position the component exactly when you insert or move it.

	
Click the Set Component Axes button to choose where you want your component’s axis origin to be (where the red, green, and blue axes meet). Click to center your axes, click again to establish the red direction, and click a third time to establish the green and blue directions. If you’re creating a Dynamic Component, this is something you absolutely must know how to do.




	
Cut Opening

	
For components in a surface, such as a window. Select this check box to automatically cut an opening in surfaces to which you stick the component.

	
As with premade components, this opening is dependent on the component’s existence: If you delete the component instance, the opening disappears. If you move the component instance, the opening moves too.

For more details on this option, see the sidebar “Making your own doors and windows” later in this chapter.




	
Always Face Camera

	
Makes a component always face you no matter how you orbit around. To make your 2D Face-Me components (that’s what they’re called) work correctly, rotate your component-to-be so that it’s perpendicular to your model’s green axis before you choose Make Component.

	
Using flat 2D components instead of complex 3D ones is a great way to have lots of people and trees in your model without bogging down your computer.




	
Shadows Face Sun

	
Available only when the Always Face Camera check box is selected; selected by default.

	
Leave this check box selected unless your Face-Me component meets the ground in two or more places, as shown in Figure 5-8.






[image: Snapshot of deselecting the Shadows Face Sun check box if the component touches the ground in more than one place.] 
FIGURE 5-8: Deselect the Shadows Face Sun check box if your component touches the ground in more than one place.







 
Editing, exploding, and locking component instances

Right-clicking a component instance in your modeling window opens a shortcut menu that offers lots of useful choices. Here’s what some of them let you do: 


	Edit Component: To edit all instances of a component at the, right-click any instance and choose Edit Component from the shortcut menu. The rest of your model fades, and you see a dashed bounding box around your component. Now watch in shock and awe as all other instances of the same component update live in real time as you work. When you’re done, click somewhere outside the bounding box to finish editing; your changes have been made in every instance of that component in your model.

	Make Unique: Sometimes, you want to make changes to only one or a few of the instances of a component in your model. In this case, select the instance(s) you want to edit, right-click one of them and choose Make Unique from the shortcut menu. This option turns the instances you selected into a separate component. Now edit any of them; only the instances you made unique reflect your changes.

	Explode: When you explode a component instance, you’re effectively turning it back into regular ol’ geometry. Explode is used to disassemble both components and groups.

	Lock: Locking a group or a component instance means that nobody — including you — can mess with it until it’s unlocked. Lock parts of your model that you don’t want to change accidentally. To unlock something, right-click it and choose Unlock from the shortcut menu.

 

MAKING YOUR OWN DOORS AND WINDOWS
 
If you’re that special kind of SketchUp nerd, nothing beats making your own window and door components. Here’s what you need to know (check out the illustration in this sidebar for visual instructions): 

	Draw a Rectangle on a vertical surface, such as a wall.

	Delete the face you just created to make a hole in your vertical surface.

	Select all four edges of the hole you just created; then right-click one of the edges and choose Make Component from the shortcut menu.

	Make sure that Glue to Any, Cut Opening, and Replace Selection with Component are selected; then click the Create button to create your new component.

	
With the Select tool, double-click your new component (in the modeling window) to edit it.

The rest of your model appears to fade a bit.


	Use the modeling tools just like you always would; keep building your door or window how you want.

	When you’re done, click outside your component to stop editing it.


If the opening you create ever closes, one of two things probably happened: 


	A new surface was created. Try deleting the offending surface to see whether that fixes things; it usually does.

	The cutting boundary was messed up. The cutting boundary consists of the edges that define the hole your component is cutting. If you take away those edges, SketchUp doesn’t know where to cut the hole anymore. Drawing them back in usually sets things straight.




[image: Schematic illustration of making the own doors and windows.] 








Discovering Dynamic Components

Once upon a time, the smartest thing a component could do was cut its own hole in a surface. “Wow!” all SketchUp aficionados thought. “Components are geniuses!” And so they were — until Dynamic Components came along. (Web: Skip to “Taking Advantage of Components to Build Better Models” later in this chapter.)

In early versions of SketchUp, components were basically … well, basic. If you wanted to make a staircase longer, you had to make copies of the steps and place them in the right spot. If you needed to change the color of a car, you had to dig out the Paint Bucket and dive into the geometry. The problem was that components didn’t know what they were supposed to represent; they were just groupings of faces and edges in the shape of an object.

Dynamic Components (DCs) are models that have an idea of what they are; they know what to do when you interact with them. This section outlines what DCs represent for SketchUp modelers and how to use them.

Before you start working with DCs, here’s what you need to know: 


	DCs can do all sorts of things. Describing what DCs do is tricky because they’re all different. The simple (but totally unsatisfying) answer is that they do what they’ve been programmed to do. Figure 5-9 shows some examples, which are explained in the following list: 
	[image: 9781119617938-ma019] A dynamic door component may be set up to swing open when you click it with the Interact tool, which you find on the Dynamic Components toolbar.

	You can configure the same dynamic door in different standard sizes, styles, and finishes by using the simple drop-down lists in the Component Options dialog box.

	A dynamic chair may be scaled into a sofa without stretching the arms. The dynamic programming could also add cushions as you make the component longer.

	[image: 9781119617938-ma020] A dynamic stair component may automatically add or remove steps as you use the Scale tool to make the staircase taller or shorter.



	You need SketchUp Pro to make and use DCs. DCs interact in a very specific way with desktop SketchUp. If you need to build your own DCs (or modify ones that other folks have made), you need SketchUp Pro.

	Many DCs are free. People are adding new DCs to the 3D Warehouse every day. As you can imagine, companies that make things like furniture and building products (windows, kitchen cabinets, and flooring) are really excited about the possibilities that DCs offer. Many of these companies are in the process of producing DCs of everything in their catalogs and posting them to the 3D Warehouse. That’s good news for you; soon, you can download and use a configurable model of almost anything you need.

	DCs have a special icon. In desktop SketchUp, you find a few sample DCs in the Components panel. They’re the ones with the little green dynamic icon next to them (that looks kind of like an arrow).

 
Using Dynamic Components

In SketchUp, you can interact with DCs in three basic ways. Depending on what a particular DC has been set up to do, it may respond to one, two, or all three of the following interactions.



[image: Schematic illustration of DCs which can do all kinds of things.] 
FIGURE 5-9: DCs can do all kinds of things.






SMART SCALING

DCs designed to react intelligently to the Scale tool are the closest things to true magic that SketchUp offers. Instead of stretching and getting all distorted when you scale them, the parts that are supposed to change dimensions do; the other parts don’t.

Take a look at Figure 5-10. The center image shows what happens when you scale a nondynamic window component to make it wider. See how the frame stretches? Yuck. The image on the far right shows the dynamic version of the same window. It gets wider when you scale it, but the frame stays the same thickness. The component is smart enough to know that only some parts of it should get wider when you scale it.



[image: Schematic illustration of scaling a nondynamic window (center) stretches the whole thing.] 
FIGURE 5-10: Scaling a nondynamic window (center) stretches the whole thing. The DC version scales properly.






There’s another way that DCs can scale smartly: by adding or subtracting pieces as they get bigger or smaller. Dynamic stairs are a perfect example, as shown in Figure 5-11. When you use the Scale tool to make the staircase taller, the staircase adds steps instead of stretching.



[image: Schematic illustration of making the staircase taller, this dynamic staircase adds steps instead of stretching.] 
FIGURE 5-11: When you make the staircase taller, this dynamic staircase adds steps instead of stretching.






[image: Tip] You can turn on the Dynamic Components toolbar, which is a quicker way to work with DCs than using the menu bar. Just choose View ⇒ Toolbars ⇒ Dynamic Components, and you’re all set.


 
COMPONENT OPTIONS

In the Component Options dialog box, you can configure DCs that have been hooked up to this dialog box by choosing options from drop-down menus, typing dimensions, and performing other simple tasks. To open the dialog box, choose Window ⇒ Component Options. When you change a setting in Component Options, the DC you’ve selected updates to reflect the change, kind of like modeling by remote control.

[image: Remember] The Component Options dialog box looks different for every DC.

Figure 5-12 shows a simple drop-down menu for selecting wheels versus pegs for an appliance. A straight staircase might enable you to choose a riser height and a tread depth from preprogrammed lists.



[image: Schematic illustration of the Component Options dialog box which looks different for every Dynamic Component.] 
FIGURE 5-12: The Component Options dialog box looks different for every Dynamic Component.








THE INTERACT TOOL

[image: 9781119617938-ma019] Activate the Interact tool by choosing it from the Tools menu or displaying the Dynamic Components toolbar (choose View ⇒ Toolbars). Using this tool couldn’t be simpler: When a DC is set up to react to the Interact tool, it does stuff when you click it. Its actions depend on what you’ve programmed it to do.

Check out the truck in Figure 5-13, which has been designed to react to the Interact tool in a few ways: 


	Clicking the back of the truck cycles through the following options: box, flatbed, and flatbed with rails.

	Clicking the front wheels turns them from side to side.

	Clicking the doors opens and closes them.




[image: Schematic illustration of clicking stuff with the Interact tool which makes things happen.] 
FIGURE 5-13: Clicking stuff with the Interact tool makes things happen.






[image: Tip] When you’re hovering over a DC that’s been connected to the Interact tool, your cursor (originally called the Magic Finger) glows a little yellow at the end.






 
Poking around to see what happens

You can’t know which interactions you can use with any particular DC just by looking at it. If you know you’re dealing with a DC, the best way to figure out what it does is to experiment: 


	Select it and open Component Options to see whether anything’s there.

	Hover over it with the Interact tool to see whether a glow appears at the end of your cursor.

	Click it with the Select (E) tool to show its scale grips (little green boxes). If any grips show up, grab one and scale to see what happens. If no grips show up, your DC can’t be scaled with the Scale tool.



[image: Technical Stuff] Although developing your own DCs is beyond the scope of this book, SketchUp provides great online resources to help you get started. Check out the introduction to developing dynamic components in the SketchUp Help Center (https://help.sketchup.com/en/sketchup/developing-components-and-dynamic-components).





Taking Advantage of Components to Build Better Models

A huge amount of the stuff in the galaxy is made of some kinds of repeated elements. In the case of bilaterally symmetrical objects (like most furniture), that element is a mirrored half; for things like staircases, it’s a step or tread. The whole is composed of two or more instances of a single part. This makes modeling a heck of a lot easier because you don’t often have to model things in their entirety — especially if you use components.

In the following sections, you discover two methods for modeling with components. The first method involves symmetrical objects, and it covers about 50 percent of the things you might ever want to model. The second technique applies to things like stairs and fences, which are perfect examples of why components were invented in the first place.
 
Modeling symmetrically: Good news for lazy people

And smart people, too! First off, take a hard look at the shape of the things you may want to model. Then think about all the objects in the universe. We’ll wait a couple of minutes while you do that. Done so soon? Good. Everything in the world can be categorized as either of the following formal types: 


	Symmetrical: Objects that exhibit bilateral symmetry are made of mirrored halves. You’re (more or less) bilaterally symmetrical, and so is your car. Another kind of symmetry is radial symmetry. Radially symmetrical objects can be (conceptually, anyway) cut into identical wedges that all radiate from a central axis. Starfish are good examples, as are umbrellas and apple pies. If you were going to build a model of something that exhibits some form of symmetry, building one part and making copies would be a smarter way to do it.

	Asymmetrical: Some things — puddles, oak trees, and many houses — aren’t symmetrical. There’s no real trick to making these things; you just have to get some coffee, settle in, and get to work.



You can take advantage of both bilateral and radial symmetry with SketchUp components. To do so, assemble those components as follows, depending on what type of symmetry your object has (also take a look at Figure 5-14): 


	Bilateral symmetry: To make a model of something that’s bilaterally symmetrical, build half, make it into a component, and flip over a copy.

	Radial symmetry: You can use components to model radially symmetric things, such as car wheels and turrets, by building a single wedge and rotating a bunch of copies around a central point.




[image: Schematic illustration of bilateral symmetry (top) and radial symmetry (bottom) which make the SketchUp life a lot easier.] 
FIGURE 5-14: Bilateral symmetry (top) and radial symmetry (bottom) make your SketchUp life a lot easier.






Working smarter by building only half

Bilaterally symmetrical forms are everywhere. Most animals you can name, most of the furniture in your house, and your personal helicopter can all be modeled by building half, creating a component, and flipping over a copy.

Follow these steps to get the general idea of how to build a bilaterally symmetrical model in SketchUp (see Figure 5-15): 

	
Make a simple box.

You can do this however you want, but the easiest way is to draw a rectangle and push/pull it into 3D.


	
Draw a diagonal edge on the corner of your box.

The point of this step is to mark one side of your box so that when you flip it over, you don’t get confused about which side is which.


	
Turn your box into a component.

See “Creating your own components” earlier in this chapter if you wonder how to do this.


	
Make a copy of your new component instance.

Chapter 3 has information about moving and copying objects in SketchUp.

[image: Tip] Make sure that you move in either the red or the green direction; it makes things easier in the next step.


	
Flip over the copy.

To do this, right-click the copy and choose Flip Along from the shortcut menu. If you moved your copy in the red direction in the preceding step, choose Flip Along ⇒ Component’s Red. Choose Component’s Green if you moved in the green direction.


	
Stick the two halves back together.

Using the Move tool (this time without Copy toggled on), pick up your copy from the corner and move it over, dropping it on the corresponding corner of the original. Take a look at the last image in Figure 5-15. Doing this precisely is important if you want your model to look right.





[image: Schematic illustration of getting set up to build a bilaterally symmetrical model.] 
FIGURE 5-15: Getting set up to build a bilaterally symmetrical model.






Now you’re set up to start building symmetrically. If you want, you can do a test to make sure things went smoothly. (See Figure 5-16.) Follow these steps: 

	With the Select (E) tool, double-click one of the halves of your model to edit it.

	Draw a circle on the top surface, and push/pull it into a cylinder.




[image: Schematic illustration of testing the setup to make sure that everything works.] 
FIGURE 5-16: Test your setup to make sure that everything works.






If the same thing happens on the other side, you’re good to go. If the same thing doesn’t happen on the other side, it’s possible that 


	You’re not really editing one of your component instances. If you aren’t, you’re drawing on top of your component instead of in it. You know you’re in edit mode if the rest of your model looks dimmed.

	You never made a component in the first place. If your halves don’t have blue boxes around them when you select them, they’re not component instances. Start a new file and try again, paying particular attention to step 3 in the previous steps.

 

[image: Tip] MAKING TWO HALVES LOOK LIKE ONE WHOLE
 
Looking carefully at the little boat in the figure that follows, notice how the edges in the middle clearly show that it’s made out of two halves? If you were to erase those edges, the whole model would disappear because those edges are defining faces, and without edges, faces can’t exist.

Instead of erasing those unwanted edges, you can hide them by using the Eraser while pressing the Shift key. See the second and third images of the boat? When you hold down Shift while dragging over the edges that you want to hide with the Eraser, they disappear.

Keep in mind these two important details about hidden edges: 


	Hidden edges aren’t gone forever. Actually, this applies to any hidden geometry in your model. To see what’s hidden, choose View ⇒ Hidden Geometry. (Web: Tap the Eyeglasses icon on the right side to open the Display panel.) To hide it again, just choose the same thing.

	To edit hidden edges, you have to make them visible. If you need to make changes to your model that involve edges you’ve already hidden, you can view your hidden geometry (see the preceding point) or unhide them. Just show your hidden geometry, select the hidden edges you want to unhide, right-click your selection, and choose Unhide from the context menu.




[image: Schematic illustration of editing the hidden edges.] 








The coolest things since radially sliced bread

You can model objects that exhibit radial symmetry just as easily as those with bilateral symmetry. You just start slightly differently. Before you start, the only thing you have to decide is how many wedges — that is, how many identical parts — you need to make the whole object.

To model something with radial symmetry, start with one wedge, make it into a component, and then rotate copies around the center. Follow these steps to get the hang of it: 

	[image: 9781119617938-ma021] With the Polygon tool, draw a polygon with as many sides as the number of segments you need for the object you’re modeling.
Here’s the easiest way to draw a polygon in SketchUp, as shown in Figure 5-17: 

	
Activate the Polygon tool. You can also select it from the Shapes menu on the toolbar.

[image: Remember] Some tools are hidden under others on the toolbar and are accessed by clicking the down arrow to the right of the tool. In particular, four arc tool variants are nested under the Arc tool. And under the Rectangle tool, you find the Rotated Rectangle, Circle, and Polygon tools.

In the Web version, many tools are nested under similar ones in the toolbar down the left side of the screen; look for a sideways arrow, or use Search in the top-left corner to look for the specific tool you want.


	
Click to establish the center (it’s usually a good idea to place the center on the axis origin), move your cursor, and then click again to establish the radius.

Don’t worry about being accurate right now.


	Before you do anything else, type the number of sides you want your polygon to have, and press Enter.



[image: Schematic illustration of drawing a polygon to start.] 
FIGURE 5-17: Draw a polygon to start, draw two edges to create a wedge, and erase the rest of your polygon.







	
Draw edges from the center of your polygon to two adjacent vertices (endpoints) on the perimeter, creating a wedge.

To find the center of a polygon (or a circle), hover your cursor over the outline for a couple of seconds and move the cursor toward the middle. A center inference point appears.


	
Erase the rest of your polygon, leaving only the wedge.

The first three steps in this list are all about making sure that your wedge is the correct angle; if it isn’t, this technique won’t work.


	
Turn your wedge into a component.

Check out “Creating your own components” earlier in this chapter if you’re unsure how to do this.


	[image: 9781119617938-ma014] Make copies of your wedge component instance with the Rotate tool (see Figure 5-18).
As with the Move tool, you can use the Rotate tool to make copies. You can even make an array (more than one copy at a time). Here’s how: 

	Select your wedge’s edges (heh, heh) and select the face too.

	Activate the Rotate (Q) tool.

	
Press the Ctrl key (Mac: Option) to tell SketchUp you want to make a copy.

A plus sign (+) appears next to your cursor.


	Click the pointy end of your wedge to set your center of rotation.

	Click one of the opposite corners of your wedge to set your rotation start point.

	Click the other corner to make a rotated copy of your wedge.

	Type the number of additional wedges you want, followed by the letter x, and then press Enter.



	
(Optional) Test your setup.

Follow the steps associated with Figure 5-16 to test whether updates to a single component in your new object update all instances of the component.





[image: Schematic illustration of using the Rotate tool to make copies of the wedge component instance.] 
FIGURE 5-18: Use the Rotate (Q) tool to make copies of your wedge component instance.






[image: Remember] Hiding the edges in your component instances makes your finished model look a whole lot better. Take a look at the sidebar “Making two halves look like one whole” earlier in this chapter to discover how.




 
Modeling with repeated elements

A staircase is a perfect example of an object that’s composed of several identical elements. If, when you hear the phrase several identical elements, a big, flashing neon sign that screams “COMPONENTS!” doesn’t appear in your head, you’re not using SketchUp enough. On the other hand, maybe we need to get out more often.

The following example demonstrates two handy SketchUp modeling tricks: 


	Using components to model more efficiently

	Building a set of stairs the smartest way (for readers of Chapter 4)



The Treads Are Components method involves (you guessed it) making each tread (step) in your staircase into an instance of the same component. Basically, you build one simple tread that’s the right depth, make it into a component, and copy a bunch of instances into a full flight of stairs. Because all the steps are linked, anything you do to one automatically happens to them all. If you don’t know the first thing about components, now would be a terrific time to start from the beginning of this chapter.

Follow these steps to build a staircase by using the Treads Are Components method: 

	
Model a single step, including the tread and the riser.

You can make the step very simple at this stage if you want to; all that matters is that the tread depth and the riser height are correct. You can fiddle with everything else later. See Figure 5-19.


[image: Schematic illustration of model a single step, making sure that the depth and height are accurate.] 
FIGURE 5-19: Model a single step, making sure that the depth and height are accurate.







	
Make a component out of the step you just built.

Take a look at “Creating your own components” earlier in this chapter if you need help.


	Move a copy of your step into position, above the first one, as shown in Figure 5-20.

	
Type the total number of steps you want, type x, and then press Enter.

You’re creating a linear array, meaning that you’re making several copies at regular intervals, in the same direction you moved the first one. Typing 12x generates 12 steps the same distance apart as the first step and its copy. See the last image in Figure 5-20.


[image: Schematic illustration of making a step into a component instance, move a copy into position above the original, and then create an array.] 
FIGURE 5-20: Make your step into a component instance, move a copy into position above the original, and then create an array.







	
With the Select tool, double-click any one of your steps to edit all instances of your component.

Everything besides the component instance you’re editing fades a little.


	
Go nuts.

This really is the fun part. Having your staircase made up of multiple component instances means that you have all the flexibility to make drastic changes to the whole thing without ever having to repeat yourself. Add a nosing (a bump at the leading edge of each tread), a stringer (a diagonal piece of structure that supports all your steps), or even a handrail by getting creative with how you modify a single component instance. Figure 5-21 shows some of what you can do.




[image: Schematic illustration of a flight of stairs with side stringers and a handrail; on the right, a single component instance] 
FIGURE 5-21: A flight of stairs with side stringers and a handrail; on the right, a single component instance.











   

Chapter 6

Going beyond Buildings

IN THIS CHAPTER

[image: check] Extruding around circles and along paths with Follow Me

[image: check] Mastering the Scale tool

[image: check] Creating 3D terrain with the Sandbox tools

[image: check] Using the Solid Tools for additive and subtractive modeling



Here’s something you already know: There’s more to life than modeling buildings. Even though SketchUp is really good at letting you make models of built structures, you can use SketchUp to build just about anything you can imagine. All you need are time, ingenuity, and the ability to step back and break down things into their basic parts. SketchUp provides fantastic tools for creating forms that aren’t the least bit boxy, but those tools aren’t as obvious as Push/Pull and Rectangle, so most people never find them. This chapter is devoted to helping you discover SketchUp’s “rounder” side.

Another reason for pushing past basic boxes? Many people see 3D printing (sound of futuristic music and warp drives engaging) as the next vanguard of human innovation, and 3D modeling — like the kind you do with SketchUp — is half of that equation. If you’re going to be printing your own bike helmets and vacuum cleaners in the next decade, you’d better get good at modeling organic shapes. (Chapter 9 offers an introduction to 3D printing with SketchUp.)

In this chapter, you discover tools, techniques, and other tips for creating forms that are distinctly un-building-like. Our hope is that you’ll use them to push the limits of what you think SketchUp can do.



Extruding with Purpose: Follow Me

Follow Me is probably the best example of a powerful SketchUp tool with a kind of underwhelming name. When the software designers were trying to figure out what to call their new baby, the problem that they faced was this: This tool does what other 3D modeling programs dedicate two or three other tools to doing. The designers chose an unconventional name because Follow Me is a wholly unconventional tool.

As shown in Figure 6-1, you can use Follow Me to create all sorts of shapes: 


	Bottles, spindles, and spheres: These are all examples of lathed forms. You can create these by spinning a 2D profile (shape) around a central axis to create a 3D model.

	Pipes, gutters, and moldings: If you look closely, all three of these things are created by extruding a 2D face along a 3D path; the result is a complex 3D form.

	Chamfers, fillets, and dados: Without explaining what all these things are (that’s what Internet search engines are for), know this: You can use Follow Me to cut away profiles too.




[image: Schematic illustration of using Follow Me to create all kinds of shapes.] 
FIGURE 6-1: Follow Me lets you create all kinds of shapes.






Using Follow Me

At its core, Follow Me lets you create forms that are extrusions. It’s a little bit like Push/Pull, except that it doesn’t work in only one direction. You tell Follow Me to follow a path, and it extrudes a face all along that path. To better understand the extrusion process, try this: Get up in the morning before your partner. Go into the bathroom, take the tube of toothpaste, and squeeze it while moving it along a route that spells out “I love you” on the countertop. When they get up, they’ll be impressed by your knowledge of extrusion.

Anyway, you’ll need three things to use Follow Me: 


	A path: In SketchUp, you can use any edge, or series of edges, as a path. All you have to do is make sure to draw the edge(s) before you use Follow Me.

	A face: Just like Push/Pull, Follow Me needs a face to extrude. You can use any face in your model, but you need to create the face before you start using Follow Me. Most of the time, to obtain the intended results, you should make the face perpendicular to the beginning of your path.

	Undo: Imagining what a 2D face will look like as a 3D shape isn’t easy. Getting a Follow Me operation right usually takes a couple of tries. Rumor has it that Undo is the single-most-used tool in SketchUp.



Follow these steps to use Follow Me, and see Figure 6-2 for a basic example of how it works: 

	
[image: 9781119617938-ma004] Draw a vertical line up from the origin.

Start the line where the three axes lines meet; then draw a line up the blue axis.


	
[image: 9781119617938-ma005] Draw an arc in the green direction from the top end of the line.

To follow the example, use inferences (described in Chapter 3).


	Draw a second arc in the red direction from the end of the first arc.

	Draw the third arc in the green direction from the end of the second arc.

	Draw a line in the green direction from the end of the third arc.

	
Draw a small circle at the origin on the red–green plane.

Your screen should look something like the left side of Figure 6-2. It’s okay if you have a slightly different path, but make sure that your circle is flat relative to the beginning of your first line.


	
[image: 9781119617938-ma001] Using the Select tool (spacebar), select all the lines and arcs but not the circle.

In this case, the easiest way to do this is to triple-click anywhere on the path of edges.


	
[image: 9781119617938-ma022] Activate the Follow Me tool by choosing Tools ⇒ Follow Me.

(Web: Click the right arrow next to the Push/Pull tool on the toolbar; then click Follow Me. Or use Search to call up Follow Me.)


	
Click the face you want to extrude, which is the small circle.

Magic! Your face (extrusion profile) is extruded along the path you chose in Step 7, creating a 3D form (in this case, a section of pipe).





[image: Schematic illustration of using Follow Me to create a simple extruded shape.] 
FIGURE 6-2: Using Follow Me to create a simple extruded shape.






[image: Tip] Memory jogger: As the name implies, you want the selected face to follow “me,” so you need to select the path (define “me”), launch the Follow Me tool, and finally pick the face that is supposed to follow the path.

[image: Tip] If you want to use Follow Me all the way around the perimeter of a face, you don’t need to spend time selecting all the individual edges. Just select the face and then use Follow Me; the tool automatically runs all the way around any selected face.

You can use Follow Me another way, too: Instead of preselecting a path (as in step 7 of the preceding list), you can click any face with Follow Me and attempt to drag it along the edges in your model. Although this dragging method works on simple things, preselecting a path works a lot better; it’s really the only option for using Follow Me in a predictable way.


 
Making lathed forms…

…and nuclear—power—plant chimneys. You can model a surprising number of things by using Follow Me to perform a lathe operation. A lathe is a tool that carpenters and machinists use to spin a block of raw material while they carve into it; that’s how wooden baseball bats and car transmission shafts are made.

Here’s how to create a lathed object: 

	Draw your desired path — a circle — on the ground (the red–green plane; see Figure 6-3).

	
Draw an upright rectangle for your profile starting from the center-point of the circle.

The rectangle you draw will serve as the drawing plane for your profile, so keep that mind when determining its proportions. You may need to orbit your view to find the center-point inference.

[image: Tip] The best and easiest way to draw this rectangle is to use the left or right arrow keys to toggle your rectangle orientation around the green (left arrow) or red (right arrow) axis.


	
Draw your profile on the rectangle (again, see Figure 6-3).

Figure 6-3 illustrates drawing the profile for a vase. For curved shapes, use the 2-Point Arc tool and look for tangent inferences for smoother transitions. Of course, a vase has thickness, so the profile must as well. No matter what profile you are drawing, look for the blue On Face inference to be sure that you are drawing all your edges on the face of the rectangle.

[image: Tip] If the center of the circle coincides with an object in the profile, you’ll get a solid part. If you want a tubular part, the profile should be offset from the center of the circle.


	Select your circle.

	
Activate the Follow Me tool (choose Tools ⇒ Follow Me).

(Web: Follow Me is nested under Push/Pull in the toolbar.)


	
Click the profile face.

Bingo! There’s your lathed part (see Figure 6-4). If the results aren’t what you hoped for, simply undo a few times to modify your profile and then re-lathe your object with Follow Me.



[image: Tip] If you want to make your curved surfaces look smooth (hiding the edges between them), check out the sidebar “Smoothing those unsightly edges” later in this chapter.



[image: Schematic illustration of setting up to make a lathed part.] 
FIGURE 6-3: Setting up to make a lathed part.







[image: Schematic illustration of the finished product.] 
FIGURE 6-4: The finished product.






Under typical circumstances, you have to model only half a profile to use Follow Me to make it three-dimensional. Figure 6-5 shows a few examples of 3D objects created with Follow Me.



[image: Schematic illustration of a few examples of lathed objects created with Follow Me.] 
FIGURE 6-5: A few examples of lathed objects created with Follow Me.








Creating extruded shapes

A lot of the time, you want to use Follow Me to create geometry (edges and faces) that’s attached to another part of your model. An example may be modeling a gutter that runs all the way around the roof of your house. In this case, you already have the path along which you want to extrude a profile (the edge of the roof).

When you use Follow Me to extrude a face along a path consisting of edges that already exist as part of your model, always do two things: 


	
[image: Warning] Before using Follow Me, make the rest of your model a separate group. Take our word for it — Follow Me can sometimes mess up your model, so keep the geometry Follow Me creates separate, just in case.


	
[image: Remember] Make a copy of your extrusion path outside your group. There’s a consequence to working with Follow Me on top of a group: The edge (or edges) you want to use as an extrusion path won’t be available because you can’t use Follow Me with a path that’s in a separate group or component.

What to do? You need to make a copy of the path outside the group and then use the copy to do the Follow Me operation. Here’s the best way to make a copy of the path: 

	With the Select (spacebar) tool, double-click your group to edit it.

	Select the objects that make up the path you want to use for Follow Me and then press Ctrl/⌘  +C.

	Exit (stop editing) your group by clicking somewhere else in your modeling window outside that group’s bounding box.

	
Choose Edit ⇒ Paste in Place. (Web: Right-click and choose the Paste-in-Place icon in the context menu.) You have a copy of the path you want to use, and it’s outside your group.

Paste in Place is a handy way to paste an object exactly where you copied it from. You can also use the more traditional Paste command, in which case your copy appears, dutifully trailing along behind your cursor. Click again to put your copied selection wherever you like.






[image: Technical Stuff] The Weld tool is a desktop SketchUp extension that’s super-useful for creating extrusion paths for Follow Me. Chapter 15 introduces the Extension Warehouse, where you find SketchUp extensions. The upside of using Weld and Follow Me together is creating extrusions that already have smoothed edges. We discuss edge smoothing more in the “Smoothing those unsightly edges” sidebar a little later in this chapter.

When you use an existing edge (or series of edges) as an extrusion path, the hard part is getting your profile in the right place. You can proceed in either of two ways, depending on what you need to model: 


	Draw the profile in place. Do this only if the extrusion path is parallel to one of the colored drawing axes.

	Draw the profile on the ground and then move it into position. If your extrusion path doesn’t start out parallel to a colored drawing axis, you should draw your profile somewhere else and move it into place later.

 


Drawing your profile in place

Consider that you have a model of a house. You want to use Follow Me to add a gutter that goes all the way around the perimeter of the roof. You decide to draw the profile in place (right on the roof itself) because the edges of the roof are drawn parallel to the colored drawing axes. This means that you’ll have an easier time using the Line tool to draw in midair.



WHY YOUR COMPUTER IS SO SLOW
 
When you use Follow Me with an extrusion profile that’s a circle or an arc, you create a piece of 3D geometry that’s very big. In this case, big means that the geometry has lots of faces, and faces are what slow your computer. Without going into detail about how SketchUp works (we don’t really know that anyway), keep this in mind: The more faces you have in your model, the worse your computer’s performance will be. At a certain point, you’ll stop being able to orbit, your scenes (introduced in Chapter 11) will stutter, and you’ll be tempted to do something terrible out of frustration.

The first pipe in the figure that follows has been extruded with Follow Me; it was made with a 24-sided circle as an extrusion profile, and it has 338 faces. Hidden Geometry is turned on (on the View menu) so that you can see how many faces you have.

The second pipe uses a 10-sided circle as an extrusion profile. As a result, it has only 116 faces. What an improvement!

The third pipe also uses a 10-sided circle as an extrusion profile, but the arc in its extrusion path is made up of 4 segments instead of the usual 12. This pipe has a total 52 faces, which is even better.

The second image in the figure shows all three pipes with Hidden Geometry turned off. Is the difference in detail worth the exponential increase in the number of faces? Most of the time, the answer is no.

To change the number of sides in a circle or an arc just before or just after you create it, follow these steps: 

	Type the number of sides you want to have.

	Type s to tell SketchUp that you mean sides.

	Press Enter.



[image: Schematic illustration of three unshaded pipes (left) and shaded pipes (right).] 






The trick to drawing an extrusion profile that isn’t on the ground is to start by drawing a rectangular face. Then draw the profile on the face and erase the rest of the rectangle. Figure 6-6 shows how you’d draw the profile of a gutter directly on the corner of a roof; the steps that follow explain the same things in words: 

	
Zoom in on what you’re doing.

Many people try to work without filling their modeling windows with the subject at hand. Not doing so is like trying to do a crossword puzzle while looking the wrong way through a pair of binoculars. Get close — SketchUp models don’t bite!


[image: Schematic illustration of drawing an extrusion profile in place by starting with a rectangle.] 
FIGURE 6-6: Drawing an extrusion profile in place by starting with a rectangle.







	
[image: 9781119617938-ma004] Using the Line tool and suitable inferences, draw a rectangle whose face is perpendicular to the edge you want to use for Follow Me.

Pay careful attention to SketchUp’s inference engine, introduced in Chapter 3. Watch the colors to make sure that you’re drawing in the right direction.


	
[image: 9781119617938-ma004] Use the Line tool (and SketchUp’s other drawing tools) to draw your profile directly on the rectangle you just drew.

[image: Tip] The important thing is to make sure that your extrusion profile is a single face; if it’s not, Follow Me won’t work the way you want it to.


	[image: 9781119617938-ma006] Erase the rest of your rectangle, leaving only the profile.

 


Drawing your profile somewhere else

The awful thing about handrails is that they’re almost always at funny angles, not parallel to a colored axis. When drawing your extrusion profile in place isn’t convenient, draw it on the ground and move it into position later.

Here’s the trick: Draw a tail (a short edge) perpendicular to your extrusion profile. This tail helps you line up your profile with the edge that you want to use as an extrusion path for Follow Me. The following steps and Figure 6-7 describe how you’d draw and position a profile for a handrail: 

	Draw your extrusion profile flat on the ground.

	
[image: 9781119617938-ma004] Draw a short line perpendicular to the face you just drew (in the blue axis direction).

This tail should come from the point where you want your profile to attach to the extrusion path.


	
Make your profile and its tail into a group.

This step makes it easier to move and rotate the group of objects as though they are a single object. See Chapter 5 for information on creating and using groups.


	
[image: 9781119617938-ma013] Using the Move tool, place your profile at the end of the extrusion path.

To make sure that you position your profile accurately, pick it up by clicking the point where the tail meets the face and then drop it by clicking the end of the extrusion path.


	
[image: 9781119617938-ma014] With the Rotate (Q) tool, rotate your profile into position.

Here’s where you need to use a bit of skill. (See Chapter 3 for guidance.) The Rotate tool is easy to use — after you get the hang of it.


	Right-click the group you made in step 3, choose Explode from the shortcut menu, and delete your tail.




[image: Schematic illustration of draw a short tail on one's extrusion profile to help positioning it with the Move and Rotate tools.] 
FIGURE 6-7: Draw a short tail on your extrusion profile to help you position it with the Move and Rotate tools.










Subtracting from a model with Follow Me

What if you want to model a bar of soap? Or a sofa cushion? Or anything that doesn’t have a sharp edge? The best way to round off edges in SketchUp is to use Follow Me. In addition to using Follow Me to add to your model, you can subtract from your model.

Here’s how it works: If you draw an extrusion profile on the end face of a longish form, you can use Follow Me to remove a strip of material along whatever path you specify. Figure 6-8 demonstrates the concept on the top of a box.



[image: Schematic illustration of creating a rounded edge with Follow Me.] 
FIGURE 6-8: Creating a rounded edge with Follow Me.






[image: Tip] If the extrusion path you want to use for a Follow Me operation consists of the entire perimeter of a face (as is the case in Figure 6-8), you can save time by selecting the face instead of all the edges that define it.

But what if you want to create a corner that’s rounded in both directions, as so many corners are? That’s a little trickier to do. The basic technique involves using Follow Me on a corner you’ve already rounded with the Push/Pull tool. After you round a corner with an arc of the correct radius, you can use copies (or component instances, if you’re clever) of that corner several times, wherever you need them. Although we wouldn’t call this solution elegant, it works.

Figure 6-9 gives a step-by-step, visual account of the process, and the following steps explain it in words: 

	
Draw a box.

The box should be big enough for the round edge you want to apply.


	
[image: 9781119617938-ma005] With the 2 Point Arc tool, draw an arc on a top corner of the box.

When you’re drawing an arc on a corner, keep an eye out for the inferences that help you draw properly: 


	After clicking to place one endpoint of your arc, as you cut across the corner, the point at which your line turns magenta is where your endpoints are equidistant (the same distance) from the corner across which you’re cutting.

	After clicking to place your second endpoint, you see a point at which the arc you’re drawing turns magenta, which means that your arc is tangent to (continuous with) both edges it’s connected to. You want this to be the case, so you should click when you see magenta.




[image: Schematic illustration of making a corner that’s rounded in both directions.] 
FIGURE 6-9: Making a corner that’s rounded in both directions.





[image: Remember] Reduce the number of sides on your arc before you start rounding away. See the sidebar “Why your computer is so slow” earlier in this chapter to find out why.




	Push/pull down the new face to round off the corner.

	
Draw another identical arc on one of the corners directly adjacent to the corner you just rounded.

See Figure 6-9. Pictures are better than words for explaining things like adjacent corners.


	Select the edges shown in Figure 6-9.

	Activate Follow Me.

	Click the arc corner face to extrude it along the path you selected in step 5.

	
Hide or smooth any edges that need hiding or smoothing.

For information about hiding edges, see Chapter 5. Check out this chapter’s “Smoothing those unsightly edges” sidebar for the whole scoop on how to smooth edges.



After you have a fully rounded corner, you can use a bunch of those corners to make anything you want; the task just takes a little planning. Figure 6-10 shows a simple bar of soap created from eight rounded corners, copied and flipped accordingly. The text (in case you’re wondering) was created with SketchUp’s 3D Text tool, which you can find on the Tools menu.



[image: Schematic illustration of assembling a bunch of rounded corners to make objects is relatively easy.] 
FIGURE 6-10: Assembling a bunch of rounded corners to make objects is relatively easy.









SMOOTHING THOSE UNSIGHTLY EDGES
 
If you’re wondering how to get rid of all the ugly lines that appear when you use Follow Me, the answer is pretty simple: You can smooth edges, just like you can hide them. (See Chapter 5 for more information about hiding edges.) The difference between hiding and smoothing is illustrated by the images of the cylinders in the figure that follows: 


	When you hide an edge between two faces, SketchUp treats those faces as though your edge is still there; it just doesn’t show the edge. Materials you’ve applied to each face stay separate, and each face is lit separately by SketchUp’s sun. The latter fact is the reason why simply hiding the edges between faces that are supposed to represent a smooth curve doesn’t make things look smooth; you still end up with a faceted look, as you can see in the second cylinder.

	When you smooth an edge between two faces, you’re telling SketchUp to treat them as a single face — with a single material and smooth-looking shading. The difference between the first and third situation is pretty huge, as you can see by comparing the first and third cylinders in the figure.



You can smooth edges in two ways: 


	Use the Eraser. To smooth edges with the Eraser tool, hold down the Ctrl key (Option on the Mac) while you click or drag over the edges you want to smooth.

	Use the Soften Edges panel. Located on the Window menu in desktop SketchUp, this panel lets you smooth a bunch of selected edges at the same time, according to the angle of their adjacent faces. To get started: Select the edges you want to smooth and then move the slider to the right until you like the way your model looks. (Web: Access these controls in the Display panel.)



To unsmooth edges, follow these steps: 

	Select the edges you want to unsmooth.

	In the Soften Edges panel, move the slider all the way to the left.



[image: Schematic illustration of smoothing the uunslightly edges.] 










Modeling with the Scale Tool

Real heroes are rarely obvious. The Scale tool is the single-most-misunderstood member of SketchUp’s mercifully limited tool kit. New modelers assume that Scale is for resizing things in your model. That’s technically true, but most folks use it only to resize whole objects; the real power of Scale happens when you use it on parts of objects to change their shape. Figure 6-11 illustrates how Scale can distort basic shapes into more complex ones.




Getting the hang of Scale

The basic principle of this technique is simple: You select the geometry (edges and faces) in your model that you want to resize, activate the Scale tool, and go to town.

Here’s a list of steps, just so the process is crystal-clear. Figure 6-12 tells the story in pictures: 

	
Select the part of your model that you want to scale.

Use the Select tool to do this; check out Chapter 3 for details about making selections.


	
[image: 9781119617938-ma020] Activate the Scale tool.

(Web: Scale may be nested under the Move or Rotate tool.)

After you activate Scale, the geometry you selected in step 1 should be enclosed in a box of little green cubes, or grips.


	
Click a grip, and move your mouse to start scaling your selected geometry.

Keep reading for the lowdown on grips.


	When you’re finished scaling, click again to stop.


While we’re on the subject of Scale, here are a few more things you should know: 


	Use different grips to scale in different ways. Which grip (the little green boxes that appear when you activate the Scale tool) you use determines how your geometry scales: 
	Corner grips scale proportionally; nothing gets distorted when you use them.

	Edge and side grips distort your geometry as you scale; use them to squeeze what you’re scaling.



[image: Schematic illustration of using the Scale tool on parts of objects changes their shape.] 
FIGURE 6-11: Using the Scale tool on parts of objects changes their shape.







[image: Schematic illustration of the Scale tool which is a cinch to use.] 
FIGURE 6-12: The Scale tool is a cinch to use.







	Hold down the Shift key to scale proportionally. This happens automatically if you’re using one of the corner grips but not if you’re using any others. If you don’t want to distort what you’re scaling, hold down Shift.

	Hold down the Ctrl key (Mac: Option) to scale about the center of your selection. You might find yourself doing this more often than not.

	Type a scaling factor to scale accurately. To scale by 50 percent, type 0.5. Typing 3.57 scales your geometry by 357 percent, and typing 1.0 doesn’t scale it at all. Chapter 3 tells you more about using the Measurements box while you work.

	Type a specific measurement. If you know the final dimension you’re trying to achieve with the Scale tool, you can type it, followed by the units. To scale a 4-foot box until it’s 10 feet wide, type 10'.

	Which grips appear depend on what you’re scaling. Take a look at the differences in Figure 6-13: 
	Most of the time, you see a scaling box enclosed by 26 green grips.

	If you’re scaling flat, coplanar geometry (faces and edges that lie on the same plane) and that plane is perfectly aligned with one of the major planes in your model, you see a rectangle consisting of 8 grips instead of a box with 26.

	If what you’re scaling is a Dynamic Component, you may see anywhere from 0 to all 26 grips, depending on how the builder set up the component. Chapter 5 introduces Dynamic Components.



	
[image: Remember] You can’t make a copy while you scale. Both the Move and Rotate (Q) tools let you make copies by holding down a key on your keyboard while you’re using them, but Scale doesn’t work this way. You need to make a copy before you start scaling.





[image: Schematic illustration of grips which depend on what the user trying to scale.] 
FIGURE 6-13: Grips depend on what you’re trying to scale.








Scaling profiles to make organic forms

Here’s where things get really interesting. Scaling profiles to make organic forms is a great method — great because it’s easy to understand and powerful enough to be applied all over the place.

So what is this method? You use the Scale tool in combination with a series of 2D profiles to create curvy, lumpy, distinctly unboxy 3D shapes. An awful lot of the stuff in the universe fits squarely into this category: us, you, slugs, intergalactic alien fighter vessels, and bananas. Just about everything that wasn’t made by a machine can be modeled with the scaled-profiles method of 3D modeling.

[image: Remember] If this next section (“Combining Scale and Push/Pull”) tickles your creative juices, you’ll probably want to explore the world of SketchUp extensions — tools that you can add on to SketchUp to enhance the native techniques we describe throughout the book. We explore SketchUp extensions in Chapter 15.
 
Combining Scale and Push/Pull

The simplest way to use this method is in association with Push/Pull. Here’s a very simple example of how it works. Check out Figure 6-14 for an illustrated view: 

	
Create a 2D shape.

[image: Tip] This shape may be something simple (such as a circle) or something more complex, depending on what you’re trying to model. The shape may also be a half-shape if what you’re trying to make exhibits bilateral symmetry. Take a look at the last section of Chapter 5 for more information on using components to build symmetrical models.


	[image: 9781119617938-ma003] Push/pull your 2D shape into a 3D form.

	
Scale the new face you created so it’s slightly bigger (or slightly smaller) than the original 2D shape from step 1.

See “Getting the hang of Scale” earlier in this chapter for more specifics about using the Scale tool. Pay special attention to the points about using modifier keys, or keyboard buttons, to scale proportionally or about the center of what you’re working on.


	
Push/pull the face you scaled in step 3.

Try to make this extrusion about the same as the one you made in step 2.

[image: Tip] You can usually double-click a face with the Push/Pull tool to repeat your last Push/Pull operation.


	
Repeat steps 3 and 4 until you’re done.

You can add skillful use of the Rotate tool to the mix if you like; doing so allows you to curve and bend your form as you shape it.





[image: Schematic illustration of using Scale and Push/Pull together is a simple way to make organic forms.] 
FIGURE 6-14: Using Scale and Push/Pull together is a simple way to make organic forms.






Keep the following tidbits in mind as you explore this technique: 


	Watch your polygon count. Polygons are faces. The more you have, the “heavier” your model becomes and the worse it performs on your computer. Try to minimize the number of faces you’re working with by reducing the number of edges in your original 2D shape. Have a look at the sidebar “Why your computer is so slow” earlier in this chapter for the whole scoop.

	Don’t be afraid to go back and tweak. The beauty of this method is its flexibility. While you’re working, you can select any of the 2D profiles (shapes) in your model and use the Scale tool to tweak them. Just select the loop of edges along the perimeter of the profile you want to scale and take it from there. Figure 6-15 illustrates how you can tweak a shape by scaling.




[image: Schematic illustration of using go back and scale any profile at any time while you work.] 
FIGURE 6-15: You can go back and scale any profile at any time while you work.








Combining Scale and Follow Me

Another way to create extruded forms is to use Follow Me. (See the first part of this chapter if you need a refresher.) This technique is ideally suited to making long, curvy, tapered things like tentacles and antlers; it’s a little time-consuming but works like a charm.

Modeling a simplified bull’s horn is a good, straightforward illustration of how the Follow Me variation of this method works. Here’s how to go about it; take a look at Figure 6-16 to see the story in pictures: 

	
Draw a circle on the ground plane.

This circle is the extrusion profile for Follow Me. The first time through, the easiest method is to start at the origin, where the red, green, and blue axes meet. A 1.5" radius is probably suitable for a bull’s horn; a much bigger one would be a lot of bull. Strongly consider reducing the number of sides in your circle from the standard 24 to something more like 10 or 12. See the sidebar “Why your computer is so slow” earlier in this chapter to find out how and why you should do this.


	
Draw a vertical rectangle starting at the center of the circle and finishing beyond the circle’s perimeter.

[image: Tip] A good way to draw an accurate arc in 3D space is to start by drawing a rectangle. When you’re sure that this rectangle is properly situated, use one of the arc tools to draw on top of the rectangle and then delete everything but the arc: 

	Use the Tape Measure tool to create a 12" guide on the green axis, starting from the origin.

	Draw a Rotated Rectangle, starting from the end of the guide and ending on the blue axis.

	As you move the cursor up and down the blue axis, click the point that indicates your rectangle is a square.



[image: Schematic illustration of using Scale with Follow Me to create long, tapered forms like this bull’s horn.] 
FIGURE 6-16: Use Scale with Follow Me to create long, tapered forms like this bull’s horn.







	
Draw a 10-sided arc that starts at the origin and ends on the diagonally opposite corner of the square you drew in step 2.

Use Ctrl++ (that’s Ctrl and the plus sign) and Ctrl+- (Mac: Option) to increase or decrease the number of sides. This step tells SketchUp to make sure that your arc has 10 sides instead of the default 12. Why 10 sides? It makes the math easier a few steps from now.

As you move the cursor to select the third arc point, make sure that it lands on the face so that the arc is on the blue–green plane.


	Delete everything that defines the rectangle from step 2.

	
Select the arc you just drew.

This arc is the extrusion path for Follow Me.


	[image: 9781119617938-ma022] Activate the Follow Me tool by choosing Tools ⇒ Follow Me.

	Click the circle you drew in step 1 to extrude it along the path you drew in step 3.

	
Choose View ⇒ Hidden Geometry.

Showing the hidden geometry in your model lets you select the edges that were automatically smoothed (made hidden) when you used Follow Me in step 4.


	
Scale the face at the end of your new extrusion by a factor of 0.1.

See “Getting the hang of Scale” earlier in this chapter for instructions. Use any of the four corner grips on the scaling box, and don’t forget to hold down the Ctrl key (Mac: Option) while you’re scaling; this forces SketchUp to scale about the center of the face you’re resizing.


	
Select the edges that define the next-to-last profile in your extruded form.

[image: Tip] Depending on the angle of your arc, making this selection can get tricky. Here are some tips that may help: 


	See Chapter 3 for tips on making selections. For the most part, in this exercise, you’ll want to use a left-to-right selection bounding box to select only the edges you want to select.

	Choose View ⇒ Face Style ⇒ X-Ray or View ⇒ Edge Style ⇒ Back Edges to make it easier to see what you’ve selected (Web: All these options are best found by using Search.)

	Hold down the Ctrl key (Mac: Option) while you orbit to turn off SketchUp’s “blue is up/down gravity bias.” While orbiting this way, try drawing lots of tight little circles with your mouse to get your view to tilt in the direction you want. This is by no means simple stuff, but getting the hang of temporarily disabling the Orbit tool’s tendency to keep the blue axis straight up and down is a very nifty way to work. Doing so makes it infinitely easier to get just the right angle for making a window selection, which in turn makes selecting the edges that define profiles a whole lot easier. That’s what becoming a Zen master of the Orbit tool is all about.



	
Scale the edges you selected in the preceding step by a factor of 0.2.

Starting to see what’s happening?


	
Repeat steps 10 and 11 for each of the remaining profiles in your form, increasing the scaling factor by 0.1 each time.

You can absolutely choose to sculpt your form however you like, of course, but this method (counting up by tenths) yields a smooth taper.



The Santa Claus–and–reindeer project shown in the illustration is the kind of fancy, not-a-box model that you can build when you master the Scale tool. It’s not beginner-level material, but it’s worth the time when you’re ready. 

 

[image: Schematic illustration of the  Santa Claus–and–reindeer project models.] 











Making and Modifying Terrain

Continuing in the grand tradition of building extremely powerful tools and then hiding them so you’ll never find them, the people at SketchUp introduced the Sandbox way back in version 5 of the software. We introduce the Sandbox here because it helps people model terrain — the stuff your buildings sit on (or in, if what you’re making is underground).

Sandbox tools are only available in SketchUp Pro. In particular, these features for terrain modeling — a slightly more advanced SketchUp technique — are not available in SketchUp for Web.

The Sandbox isn’t new, but owing to its less-than-obvious location, most SketchUp users have never used it. Here are the facts: 


	The Sandbox is a collection of tools. Each tool serves a fairly specific purpose and is meant to be used at a particular stage of the terrain-modeling process. That said, like all SketchUp’s tools, the Sandbox tools are incredibly flexible. You can use them to model anything you want.

	The Sandbox is hidden. The reasons are complicated, but the tools in the Sandbox are a little bit special because they’re extensions; you have to find them and turn them on before you can use them. If you’re using SketchUp Pro, you can skip the first two steps in the following list because they’re already turned on.



Follow these steps to switch on the Sandbox tools: 

	
Select Window ⇒ Extension Manager (Mac: SketchUp ⇒ Preferences) from the menu bar.

Ensure sure that the Sandbox tools are enabled.


	Close the Extensions Manager after you’ve confirmed that the tools are enabled.

	Choose View ⇒ Toolbars ⇒ Sandbox from the menu bar to display the Sandbox toolbar.


The Sandbox tools don’t have default keystroke shortcuts; you must activate the toolbar to use them. You can always customize shortcuts for tools or commands that you use on a regular basis.
 
Creating a new terrain model

Whether you’re modeling a patch of ground for a building or redesigning Central Park, you need one of two terrain-modeling methods: 


	Starting from existing data: This existing data usually arrives in the form of contour or topo lines; see the next section (“Modeling terrain from contour lines”) to find out more about them.

	Starting from scratch: If you don’t have any data to start, or if you’re beginning with a perfectly flat site, you can use SketchUp’s From Scratch tool to draw a grid that’s easy to form into rolling hills, berms, and valleys. Skip to “Modeling terrain from scratch” later in this chapter for more information.



[image: Tip] There’s a neat trick for modeling small (yard-size) amounts of terrain such as the piece of land immediately surrounding a building. You could use the From Scratch tool to start with a flat site, but there’s a better way, which we describe in “Roughing out a site” later in this chapter.
 
Modeling terrain from contour lines

You know the squiggly lines on topographical maps that show you where the hills and valleys are? These lines are contour lines (or contours) because they represent the contours of the terrain; every point on a single line is the same height above sea level as every other point on that line. Where the lines are close together, the ground between them is steep. Where the lines are far apart, the slope is less steep. Cartographers, surveyors, engineers, and architects use contour lines to represent 3D terrain in flat formats like maps and site drawings.

In some cases, you may have contour lines for a building site that you want to model in 3D. This kind of topographical data comes from various sources, including project surveyors or an online resource such as the U.S. Geological Survey’s website (https://www.usgs.gov). Importing this 3D data into SketchUp, you can use the From Contours tool in the Sandbox to automatically generate a 3D surface from a set of contour lines, as shown in Figure 6-17.

Here are some things to keep in mind about the From Contours tool: 



	It’s a two-step tool. Using From Contours is simple when you get the hang of it:

	Select all the contour lines you want to use to create a surface.

	Choose Draw ⇒ Sandbox ⇒ From Contours (or click the From Contours tool button, if the Sandbox toolbar is visible).



[image: Schematic illustration of using the From Contours tool to turn a set of contour lines into a 3D surface.] 
FIGURE 6-17: Use the From Contours tool to turn a set of contour lines into a 3D surface.




[image: 9781119617938-ma078] Note: If you can’t see the Sandbox tools in your menus, you haven’t turned them on yet. “Making and Modifying Terrain” earlier in this chapter explains how to rectify the situation.



	Your contour lines need to be lifted up. The From Contours tool creates a surface from contour lines that are already positioned at their proper heights in 3D space. Most of the time, you work with contours that are part of a 2D drawing, which means you probably have to lift them up yourself with the Move tool one at a time. This work is tedious but necessary. Just oil up the Select tool, put on some music, and get to work. For a refresher on selecting things, take a look at the last part of Chapter 3.

	Download and install Weld. The Weld SketchUp extension turns selections of individual line segments into polylines, which makes them much, much easier to work with. If you work with contour lines imported from a computer-aided drawing (CAD) file, using Weld makes your life a little easier. To add Weld to SketchUp, visit the Extension Warehouse, introduced in Chapter 15.

	
You end up with a group. When you use From Contours, SketchUp automatically makes your new surface (the one you generated from your contour lines) into a group. It leaves the original lines themselves alone; you can move them away, hide them, or delete them if you want. We recommend making another group out of them, putting them on a separate layer (see Chapter 7), and hiding that layer until you need it again.

[image: Remember] To edit the faces and edges inside a group, double-click it with the Select tool. Chapter 5 has all the details on groups and components.


	To edit your new surface, turn on Hidden Geometry. The flowing, organic surface you just created is actually a bunch of little triangles. The From Contours tool smooths the edges that define them, but they’re there. To see them, choose View ⇒ Hidden Geometry.

	Try to keep your geometry reasonable. The From Contours tool is super useful, but it has its limits. The trouble is that it’s too easy to use to create enormous amounts of geometry (faces and edges) that can bog down your system. If it takes forever for your contours to turn into a surface, or if that surface is so big that your computer turns blue and curls up into a fetal position (so to speak), you need to go back a few steps and do one (or perhaps all) of the following: 
	Work on a smaller area. As nice as it’d be to have the whole world in your SketchUp model, you may have to narrow your scope. Creating only what you need is good modeling policy.

	Use only every other contour line. Doing this effectively halves the amount of geometry in your resulting surface.

	Dumb down the contour lines. This process is a little bit hard to explain, but here goes: The From Contours tool works by connecting adjacent contour lines with edges that form triangles. How many triangles it creates depends on how many individual edge segments are in each contour line; Figure 6-18 provides an illustration. Unless you created the contour lines to begin with — and there’s a good chance you imported them as part of a CAD file — you have no control of how detailed they are. Redrawing each contour line is a major bummer, but luckily, you can download a great Simplify Contours extension that makes the process much simpler.



	You don’t have to start with existing contour lines. In fact, drawing your own edges and using From Contours to generate a surface from them is one of the most powerful ways to create organic, nonboxy forms in SketchUp. The next section, “Modeling terrain from scratch,” has more details.

	Get ready to do some cleanup. The surfaces that From Contours creates usually need to be cleaned up to some extent. Use the Eraser to delete extra geometry (of which you’ll find lots along the top and bottom edges of your surface). Use the Flip Edge tool to correct the orientation of your triangular faces; see the nearby sidebar “Don’t flip out — Flip Edge” for the lowdown.




[image: Schematic illustration of the  triangles which are created depends on the number of edge segments in the contour lines.] 
FIGURE 6-18: How many triangles are created depends on the number of edge segments in the contour lines you start with.









DON’T FLIP OUT — FLIP EDGE
 
The Sandbox’s Flip Edge tool is a simple beast, but it’s indispensable if you’re working with the From Contours tool. You use Flip Edge to clean up the surfaces that From Contours creates. When you turn contour lines into a surface, lots and lots of triangular faces appear. Sometimes, the From Contours tool decides to draw an edge between the wrong two line segments, creating two triangular faces that form a flat spot in your surface (see the following image).

You get rid of these flat spots manually by flipping the edges that create them. Doing so changes the resulting triangular faces, usually making them end up side by side (instead of one above the other).

To use the Flip Edge tool (choose Tools ⇒  Sandbox ⇒ Flip Edge), just click the edge you want to flip. If you’re not sure about an edge, go ahead and flip it; then see whether it looks better. If it doesn’t, you can always undo or flip it back. 


[image: Schematic illustration of using the Sandbox’s Flip Edge tool.] 








Modeling terrain from scratch

Without contour lines that define the shape of the terrain you want to model, you have to start with a level surface. Use the From Scratch tool to create a big, flat rectangle that represents a chunk of ground. Because the rectangle is already divided into triangular faces, it’s easy to use the Smoove tool as discussed in “Making freeform hills and valleys with Smoove” later in this chapter to shape the rectangle into hills, valleys, sand traps, and whatever else you have in mind.

Here’s the thing, though: It’s a very rare occasion when you have carte blanche with a piece of land. Unless you design something like a golf course in the middle of a dry lakebed or terraform a new planet for colonization, you probably have existing terrain conditions to contend with. And if that’s the case, you’re probably better starting with a set of contour lines that describe those conditions, as discussed in “Modeling terrain from contour lines” earlier in this chapter.

So although the From Scratch Tool works great, you probably won’t need to use it much. All the same, here’s how to do so, just in case. Follow these steps to create a new terrain surface with the From Scratch tool, and take a look at Figure 6-19 while you’re at it: 

	Choose Draw ⇒ Sandbox ⇒ From Scratch to activate the From Scratch tool.

	
Type a grid spacing amount, and press Enter.

The default grid spacing amount is 10 feet, which means that the tool draws a rectangle made up of squares that are 10 feet across. The grid spacing you choose depends on how big an area you’re planning to model and how detailed you plan to make the terrain for that model.

[image: Tip] If you’re modeling a single-family house on a reasonable-size lot, you’d probably use a grid spacing of 2 feet, which would provide enough detail for elements like walkways and small berms without creating too much geometry for a computer to handle. If you’re laying out an 18-hole golf course, on the other hand, you’d probably choose a grid spacing closer to 50 feet and add detail to certain areas later.


	Click to position one corner of your new terrain surface where you want it.

	Click to determine the width of the surface you’re drawing.

[image: Schematic illustration of using the From Scratch tool to create big swatches of flat terrain.] 
FIGURE 6-19: Use the From Scratch tool to create big swatches of flat terrain. Ah, the possibilities!







	
Click to establish the length of your new terrain surface.

When you’re done, the great big rectangle you’ve created automatically becomes a group.


	Double-click the group with the Select tool to edit it.


You’ll probably decide to use the Smoove tool next; see “Making freeform hills and valleys with Smoove” later in this chapter to find out how.


 
Roughing out a site

Perhaps you want to model a smallish chunk of nonflat terrain that surrounds a building. Maybe you’re trying to reproduce existing site conditions, or maybe you’re in the process of designing the landscape for a project. There’s a neat technique for cases like these: You can use From Contours to generate a surface quickly from just a few simple outlines.

Follow these steps to model a simple terrain surface with the From Contours tool, as shown in Figure 6-20: 

	Extend the bottom of your building down so the exterior walls drop below ground level.

	
Make your building into a group.

See Chapter 5 if you need help.


	
[image: 9781119617938-ma015] [image: 9781119617938-ma004] Use the Tape Measure and Line tools to draw the outline of the chunk of terrain you want to model around the building.

The resulting horizontal face is flat, so pretend that you’re drawing in 2D space. It doesn’t matter whether the outline you draw is below, above, or in line with the building, as you see in step 4.


	Use the Push/Pull tool to extrude the face you drew in step 3 into a box that extends above and below your building; then delete the top and bottom faces of the box you just drew.

	
Paint the walls of your box with a translucent material.

You can find these materials in the Glass and Mirrors library, in the Materials panel. See Chapters 2 and 3 for help.


	Draw edges on the sides of the box that represent where the ground should intersect them.

	Draw edges on the sides of the building that represent where the ground meets the building.

	Delete the box you created in step 4, leaving the edges you drew in step 6.

	Select all the edges you drew in steps 6 and 7.

	
Choose Draw ⇒ Sandbox ⇒ From Contours to generate a surface based on the edges you selected in step 9.

[image: Tip] Take a look at the section “Modeling terrain from scratch” earlier in this chapter for more on using From Contours.





[image: Schematic illustration of creating irregular terrain surfaces very quickly with the From Contours tool.] 
FIGURE 6-20: You can create irregular terrain surfaces very quickly with the From Contours tool.






At this point, you need to use the Flip Edge tool and the Eraser to clean up your terrain model — particularly where your building is supposed to go.




 
Editing an existing terrain model

No matter how you make a terrain model, there’s a 99 percent chance that it consists of lots and lots of triangles. Switch on Hidden Geometry (choose View ⇒ Hidden Geometry) to see them. As long as you have triangles, you can use the Sandbox’s terrain-editing tools. This section shows you how to do the following: 


	Shape (or reshape) your terrain with the Smoove tool.

	Create a flat spot for a building with the Stamp tool.

	Draw paths and roads with the Drape tool.



[image: Remember] Keep in mind that both From Contours and From Scratch create terrain objects that are groups. To edit a group, double-click it with the Select tool. When you’re done, click somewhere outside that group to exit.
 
Making freeform hills and valleys with Smoove

Smoove is a tool for moving smoothly — get it? Smooth + Move = Smoove. We’ll wait while you compose yourself.

Smoove is one of the coolest tools in SketchUp; it lets you shape terrain (or any horizontal surface that’s made up of smaller triangular faces) by pushing and pulling (sort of) bumps and depressions of any size. Smoove is fun to use and yields results that you’d be hard-pressed to produce with any other tool in SketchUp. Figure 6-21 shows what Smoove can do.

Follow these steps to shape a surface with Smoove: 

	
Double-click the group containing your terrain to edit it.

If your terrain isn’t part of a group, forget this step.


	[image: 9781119617938-ma026] Choose Smoove from the Sandbox menu bar to activate the Smoove tool.

	
Type a radius, and press Enter.

Smoove creates lumps, bumps, and dimples that are circular. The radius you enter here determines how big those lumps, bumps, and dimples should be.


	Click somewhere on your terrain surface to start smooving.

[image: Schematic illustration of smoove creating shapes.] 
FIGURE 6-21: Smoove creates shapes that are unlike anything else you can make with SketchUp.







	Move your mouse up or down to create a bump or a depression, respectively.

	Click again to stop smooving.


Fun, huh? Here are some more things to keep in mind when you use Smoove: 


	Use the From Scratch tool beforehand. You don’t have to, but creating a surface with the From Scratch tool (described earlier in this chapter in “Modeling terrain from scratch”) is by far the easiest way to end up with terrain that you can smoove easily.

	Try smooving to edit other terrain surfaces. You can use Smoove after you create a terrain surface with the From Contours tool.

	Double-click to repeat your previous smoove. As with Push/Pull, double-clicking tells SketchUp to carry out the same operation you did the last time you used the tool.

	Preselect to smoove shapes other than circles. Any faces and edges you select before you use the Smoove tool move up (or down) by a constant amount, so you can use Smoove to create things like ridges and ditches by selecting the right geometry beforehand. Figure 6-22 provides a much-needed picture.




[image: Schematic illustration of preselect faces and edges to smoove shapes other than circles.] 
FIGURE 6-22: Preselect faces and edges to smoove shapes other than circles.









NEED MORE TRIANGLES? ADD DETAIL
 
Like the Flip Edge tool, Add Detail is kind of a one-trick pony. Use it to add triangles to areas of your terrain surface that need more detail. That way, you can save geometry (and file size, and waiting) by having lots of faces only in the areas of your terrain that require it. If you’re designing a golf course, for example, you’d use very big triangles for the vast majority of it and use the Add Detail tool to add triangles to areas where you planned to have smallish things like sand traps.

You can use the Add Detail tool in two ways: 


	Add detail to faces one at a time. To be honest, you may never have a reason to use the tool this way, but here goes: You can activate the tool (see the next item) without having any geometry selected and then click faces or edges on your terrain to divide them into more faces. This method might be handy when you model something very precisely.

	Add detail to all the faces in an area at the same time. Simply select the faces on your terrain you want to subdivide and choose Add Detail from the Sandbox menu bar. Take a look at the figure to see what happens when you do.




[image: Schematic illustration of adding detail to all the faces in an area at the same time.] 








Placing a building on your terrain with Stamp

Eventually, you may need to plunk a building (or some other structure) on the terrain you’ve lovingly crafted. The Stamp tool provides an easy way to — you guessed it — stamp a building footprint into a terrain surface, creating a flat pad for something to sit on. This tool also provides a way to create a gently sloping offset around the perimeter of your stamped form, creating a smoother transition between the new flat pad and the existing terrain.

Follow these steps to use the Stamp tool, and check out Figure 6-23 to see the corresponding pictures: 

	
Move the building you want to stamp into position above your terrain surface.

The building shouldn’t touch the terrain but float in space directly above it. Also, turn the building into a group before you start moving anything; take a look at Chapter 5 to find out all about groups and components.

[image: Tip] If you’re having trouble moving your building into position accurately, move it to the correct height first and then switch to a top, no-perspective view to finish the job. Look on the Camera menu for the pertinent commands.


	Choose Stamp from the Sandbox’s menu bar to activate the Stamp tool.

	Click the floating object to tell SketchUp what you want to use as the stamp.

	
Type an offset distance, and press Enter.

The offset distance is the amount of space around the perimeter of whatever you’re stamping that SketchUp uses to smooth the transition between the flat spot it’s creating and the existing terrain. The offset amount you choose depends entirely on what you’re stamping. Go nuts, and thank your lucky stars for Undo.


[image: Schematic illustration of using the Stamp tool to create a nice flat spot for the building.] 
FIGURE 6-23: Use the Stamp tool to create a nice flat spot for your building.







	Move your cursor over your terrain surface, and click again.

	Move (but don’t drag) your mouse up and down to position the flat pad in space.

	Click again to finish the operation.


Here are a couple things that are handy to know when you use Stamp: 


	SketchUp uses the bottommost face in your stamp object as the template for the flat pad it creates in your terrain.

	Stamp creates triangular faces that sometimes need cleaning (see the “Don’t flip out — Flip Edge” sidebar earlier in this chapter).




 
Creating paths and roads with Drape

The Drape tool works a little like a cookie cutter; use it to transfer edges from an object to a surface directly beneath it.

Perhaps you have a gently sloping terrain, and you want to draw a meandering path on it. The path has to follow the contours of the terrain, but because you want to paint it with a different material, it needs to be a separate face. In this case, you’d draw the path on a separate face and use the Drape tool to transfer it to your terrain surface.

Taking the preceding example, follow these steps to use the Drape tool to draw a path on a non-flat-terrain surface (and see Figure 6-24 for an illustration of the steps): 

	
Use the Line tool (see Chapter 2) to draw a flat face somewhere directly above your terrain surface.

If you can, make your flat face exactly the same size as your terrain. Just make sure it’s big enough for whatever you plan to draw next (in this example, a path).


	
Paint the face you just created with a translucent material.

A light gray material usually works well; you can find a good one in the Glass and Mirrors library, inside the Materials panel.


	
Use the Line tool to carry up any important points on your terrain surface.

In this case, make sure that the path begins precisely at the door of the building, so draw vertical lines from the sides of the door to the flat face directly above. That way, you have something to inference to in step 6.


[image: Schematic illustration of using Drape to transfer edges onto the terrain surface.] 
FIGURE 6-24: Use Drape to transfer edges onto your terrain surface.








	Choose Camera ⇒ Standard Views ⇒ Top to switch to a top view.

	Choose Camera ⇒ Parallel Projection to turn off perspective.

	
On the top face, draw the edges you want to drape.

[image: Remember] Make sure that your edges form closed loops to create faces. If they don’t, you’ll have a miserable time trying to paint the path (in this case) after it’s draped onto your terrain surface.


	Orbit your model so you can see both the top and bottom surfaces.

	
Soften/smooth the edges of the triangles in your terrain surface (if they aren’t softened or smoothed already).

To do this, follow these steps: 

	Select all the edges and faces in your terrain, and choose Window ⇒ Soften Edges.

	In the Soften/Smooth Edges panel, move the slider to the far right, and make sure that the Smooth Normals and Soften Coplanar check boxes are selected.



	
Select the edges you want to drape.

If your edges define closed faces, you can select those faces instead, which is easier than selecting a bunch of individual edges. Take a look at Chapter 3 for tips on selecting things.


	[image: 9781119617938-ma028] Choose Drape from the Sandbox’s toolbar to activate the Drape tool.

	
Click your terrain surface to drape the edges you selected in step 9.

It doesn’t matter whether your terrain is inside a group; the Drape tool works anyway.






[image: Technical Stuff] Daniel Tal, a landscape architect and SketchUpper extraordinaire who regularly builds models that defy explanation, has written SketchUp for Site Design: A Guide to Modeling Site Plans, Terrain and Architecture (John Wiley & Sons, Inc.), which is available online and at your local bookstore. If you’re a site designer, we highly recommend checking it out.







Building a Solid Tools Foundation

Okay, Web users: Sandbox playtime is finished. The Solid Tools described in this section are available in the web version with a paid Shop subscription. Take a look at Table 6-1 (later in this chapter) to see what’s available to you.

So-called solid modeling operations (fancy people refer to them as Boolean operations, after British mathematician George Boole) give you the ability to create the shapes you need by adding shapes to or subtracting shapes from one another. Chapter 9 covers another use for solids: 3D printing demands watertight solids.

In the next few pages, you discover how to use all six of SketchUp Pro’s Solid Tools. We give detailed examples of using the three most-useful of these tools.
 
Understanding solids

Before you can use the Solid Tools, you need solids. Here are seven things you need to know about solids, which you can think of as the Solid Rules: 


	A solid is nothing more than an object that’s completely enclosed. It has no holes or other gaps; if you filled it with water, none would leak out. For this reason, solids are sometimes referred to as being watertight. Here’s another way to think about it: Every edge in a solid must be bordered by two faces.

	
No extra edges or faces are allowed. You wouldn’t think that a couple of extra edges or faces would make much of a difference, but they do; solids can’t contain any extra geometry, period. Figure 6-25 shows some examples of things that can disqualify otherwise completely enclosed shapes from being solids.

The Extension Warehouse (click on Window ⇒ Extension Warehouse) has a few SketchUp extensions that make it easier to figure out why a particular group or component isn’t solid. For starters, check out Solid Inspector2 by ThomThom. For an introduction to the Extension Warehouse, see Chapter 15. In the Web version, this Solid Inspector utility is available with a Shop subscription.


	Only groups and components can be solids. This one’s a biggie. For SketchUp to realize that something is a solid, you have to make it into a group or a component first. Solid groups and components can’t have other groups and/or components nested inside them.

	Making a solid doesn’t require any special tools. You don’t have to use special objects to create solids; you make them with the same SketchUp tools you use all the time. Case in point: Every time you’ve pushed/pulled a rectangle into a box, you’ve created a solid.

	Check Entity Info to see whether your object is a solid. The easiest way to tell whether a group or component is a solid is to select it and choose Window ⇒ Entity Info. If your selection is a solid, Solid Group or Solid Component will appear in the resulting Entity Info panel. Figure 6-26 shows you where to look. (Web: Entity Info is at the top of the right panel.)

[image: Schematic illustration of solids which cannot contain any extra edges or faces.] 
FIGURE 6-25: Solids can’t contain any extra edges or faces.







	Solids have volumes. Manually calculating the volume of a simple shape like a rectangular box is straightforward, but try doing that for anything more complicated, and you’ll see why the Volume readout in Entity Info is so great. The Entity Info panel displays the volume if the selected entity is a solid group or component.

	
[image: Technical Stuff] Solids can be made up of multiple shapes. This one is confusing at first. As long as each individual cluster of geometry within a group or component is completely enclosed, SketchUp considers that group or component to be a solid. It doesn’t matter that they’re not connected or touching in any way; what’s important is that an area of space is fully surrounded by faces.





[image: Schematic illustration of checking the Entity Info panel to see whether the selection is solid.] 
FIGURE 6-26: Check the Entity Info panel to see whether your selection is a solid.








Checking out the Solid Tools

When you have a solid object or objects, you can use SketchUp’s Solid Tools in powerful ways to create shapes that otherwise would be very complicated and time-consuming to make. Here are a couple of examples: 


	Add two solids to create a new one.

	Use one solid to cut away part of another one.



[image: Tip] With the SketchUp Intersect Faces tool, you can achieve many of the same things that you can with the Solid Tools. Intersect Faces takes longer because it requires an awful lot of cleanup, but it’s still useful for two very important reasons: It’s available in both the free and paid versions of SketchUp, and it works on any face in your model, not just on solids. You can read about Intersect Faces in Chapter 4.

Two things you need to know before you start using the Solid Tools: 


	
Find the Solid Tools. In desktop SketchUp, choose View ⇒ Toolbars ⇒ Solid Tools to open the toolbar that contains all six tools. You can also find them on the Tools menu. Keep in mind that five of them — all but the Outer Shell tool — are available only if you have SketchUp Pro. For simplicity, this book assumes that you’ve opened the Solid Tools toolbar.

(Mac: View ⇒ Tool Palettes ⇒ Solid Tools. Web: The Solid Tools are nested together in the left-side toolbar, and also available in Search.)


	
To use the Solid Tools, preselect — or don’t. Pick the tool you want to use either before or after you’ve told SketchUp which solid objects you want to affect. Like most order-of-operations issues (are you listening, Follow Me tool?), this can be confusing for some folks.

[image: Tip] The easiest way to use the Solid Tools is to preselect the solids and then choose the tool to carry out the operation. The glaring exceptions to this rule are the Subtract and Trim tools, both of which depend heavily on the order in which you pick your solids. Take a peek at Table 6-1 for more specifics.




Without further ado, here’s Table 6-1 with a rundown of the Solid Tools. (Check out Figure 6-27 for a visual.)
 



TABLE 6-1 The Solid Tools

	
Tool

	
What It Does and How to Use It

	
Start With

	
End With

	
Union

	
What: Combines two or more solids into a single solid. Deletes overlapping geometry. Preserves internal pockets.*

How: Select the solids you want to use and then activate the tool.

	
Two or more solids

	
One solid




	
Outer Shell

	
What: Combines two or more solids into a single solid. Deletes overlapping geometry, including internal pockets.*

How: Use as a Union tool.

	
Two or more solids

	
One solid




	
Intersect

	
What: Makes a single solid of the volume that is common to two or more overlapping solids. Deletes everything else.

How: Same as Union tool.

	
Two or more solids

	
One solid




	
Subtract

	
What: Uses one solid to cut away part of another solid. Deletes the first solid when it’s done.

How: Activate the tool, click cutting solid, and then click solid to be cut.

	
Two solids

	
One solid




	
Trim

	
What: Uses one solid to cut away part of another solid. Keeps what’s left of both solids.

How: Same as Subtract tool.

	
Two solids

	
Two solids




	
Split

	
What: Cuts two solids where they overlap and creates a new solid from the overlap. Doesn’t delete anything.

How: Same as Union tool.

	
Two solids

	
Three solids


 
* An internal pocket is like a solid within a solid — a completely enclosed volume that happens to be located inside the main volume of a solid. Picture a SketchUp model of a tennis ball. Because tennis balls have a thickness, you’d need two surfaces to model one: one for the inside, and one for the outside. If you selected both and made a group, you’d have a solid with an internal pocket.




[image: Schematic illustration of the Solid Tools which let to do additive and subtractive modeling operations.] 
FIGURE 6-27: The Solid Tools let you do additive and subtractive modeling operations.






[image: Tip] Note that the Split tool does three operations every time you use it: yields two subtractions and an intersection. That is to say, using Split is like using both Subtract and Intersect on your solids. For this reason, you may want to use Split full-time. It’s easier to keep track of what’s going to happen, and the only downside is that you have to delete a couple of extra objects when you're done.

[image: Technical Stuff] In Figure 6-27, the solids have been separated after the Trim and Split operations to show the results. Normally, they’d look like the Original group until they were moved.


 
Putting the Solid Tools to work

In this section, you find a few examples of everyday modeling challenges that the Solid Tools can help make less challenging. You’re almost certain to encounter these tricky situations while you climb the ladder toward ultimate SketchUp Ninjahood.
 
Assembling complex objects with Union or Outer Shell

Chapter 4 has a section about using the Intersect Faces tool to combine multiple roof pitches into a single, solitary roof. If all those gables, hips, dormers, and other roof elements are solids, you can absolutely use SketchUp’s Union or Outer Shell tools to make quick work of the problem.

The same goes for anything that’s composed of several disparate elements that you’ve assembled by moving them together until they overlap. In the spacecraft in Figure 6-28, the hull (or body) combines different pieces. Notice the lack of edges where the components intersect? We think that edges add detail and definition, especially when a model is displayed using a lines-only style (as in the figure). There’s also the issue of all the geometry hidden inside the hull. Combining everything into a single solid helps it shed weight and look better at the same time.



[image: Schematic illustration of using Union or Outer Shell to combine several solids which gets rid of internal geometry and adds edges where faces intersect.] 
FIGURE 6-28: Using Union or Outer Shell to combine several solids gets rid of internal geometry and adds edges where faces intersect.








Using Intersect in combination with front, top, and side views

Anyone who’s ever tried to model a car with SketchUp knows that it’s a tricky undertaking. The problem is that cars (and most other vehicles) are kind of curvy; worse, they’re curvy in several directions.

One trick that lots of modelers use to block out a basic shape for things like cars is to start with orthographic — straight-on top, front, and side — views of the thing they’re trying to model. Here’s how the method works: 

	Position each 2D view where it belongs in 3D space.

	Push/pull all the views so that their extrusions overlap.

	Use the Intersect tool (Tools ⇒ Solid Tools ⇒ Intersect) to find the object that the extrusions have in common.


This method doesn’t always produce perfect results, but it’s a lot better than guessing. Also, it’s fun. Figure 6-29 shows the technique in action.



[image: Schematic illustration of the orthographic views of the model.] 
FIGURE 6-29: If you have orthographic views of the thing you’re trying to model, you can use Intersect to give yourself a head start.








Modeling close-fitting parts with Trim

Woodworkers and industrial designers, take heed: SketchUp Pro’s Trim tool saves you literally hours of work. Any time you need to build a model with parts that interlock or otherwise fit together closely, Trim is where you should look first.

Trim tells one part to “take a bite” out of another, which is perfect for joinery (dovetails, finger joints, dadoes, and so on), machine parts, ball-and-socket joints, and any other positive/negative conditions where two parts meet.

Figure 6-30 shows how to build a small wooden box with dovetailed sides and a dadoed bottom.



[image: Schematic illustration of the Trim tool which is perfect for modeling joinery and other close-fitting parts.] 
FIGURE 6-30: The Trim tool is perfect for modeling joinery and other close-fitting parts.






[image: Remember] The only tricky thing about using the Trim tool is remembering which solid to pick first. The first thing you pick (or click) is the one you want to cut with — in the case of the box in Figure 6-30, the side with the dovetails. When you select the dovetails and then select the blank side, the Trim tool cuts the dovetails into the second piece. You get the hang of this process after a few tries.

[image: Tip] The Trim tool has a neat trick up its sleeve: You can keep using your cutting solid on multiple other solids. To cut the dado (or groove) into the sides of the box in Figure 6-30, follow these steps: 

	
Choose Tools ⇒ Solid Tools ⇒ Trim to activate the Trim tool.

Your cursor has the number 1 on it.


	
Select the box bottom.

Your cursor changes to show the number 2.


	Select one side of the box.

	
Cut a dado, using the box bottom you picked in step 2.

Your cursor still says 2.


	Select another of the box’s sides to cut another dado.

	Select the remaining two sides to cut dadoes in them too.


Fun!

One question comes up pretty frequently concerning what happens when you use one of the Solid Tools on a component instance: Why doesn’t the effect of what you just did affect all the other instances of that component? It should, shouldn’t it? Anyone who’s read Chapter 5 of this book should know that.

Here’s the thing: As soon as you use a Solid Tool on a component instance, SketchUp makes that instance unique. It’s still a component; it just isn’t connected to the other instances anymore.








  

Chapter 7

Keeping Your Model Organized

IN THIS CHAPTER

[image: check] Taking stock of your model with the Outliner

[image: check] Avoiding problems by using tags the right way

[image: check] Looking at how everything works together



Living life can be a messy ordeal, and modeling in SketchUp is no exception. As you crank away at whatever it is you’re modeling, you’ll reach a time when you stop, orbit around, and wonder how your model got to be such a pigsty. It’s inevitable.

Big, unwieldy, disorganized models are a pain. They can slow your computer or even cause SketchUp to crash. Luckily, SketchUp includes a bunch of different ways to keep your geometry — edges and faces — from getting out of control. This chapter presents SketchUp’s two main tools for organizing your model: the Outliner and Tags. After we introduce each tool, we explain how to use it and how not to use it (are you listening, Tags?). This chapter ends with a detailed example of how you can use the tools together to make modeling easier.

[image: Warning] For a long time, SketchUp tags were called layers. So if you are using this book with an earlier version of SketchUp, everything that we describe about Tags applies to the old Layers framework.



Taking Stock of Your Tools

When sorting out the thousands of edges and faces in your model, it’s all about lumping things together into useful sets. After you organize geometry into sets, you can name them, hide them, and even lock them so that you (or somebody else) can’t mess them up.

[image: Remember] The primary way to organize geometry into sets is to create groups or components. If you haven’t read about groups and components yet, now would be a good time to take a look at Chapter 5; the stuff in this chapter is best understood if you have a firm grasp on the stuff in that one.

You have two organizational methods at your disposal in SketchUp: 


	Outliner: The Outliner is a fancy list of all the groups and components in your SketchUp model. In the Outliner, you can see which groups and components are nested inside other ones, assign names to and search for objects, and easily hide parts of your model that you don’t want to see. If you use a lot of components (and you should), the Outliner may well become your new best friend.

	
Tags: For people who are used to organizing content in other software programs, layers are usually where it’s at; you put different kinds of things on different layers, name the layers, and turn them on and off when you need to. It’s a pretty simple concept. In SketchUp, tags are a similar convention, but the ways in which SketchUp tags work differently from traditional design layers are important for modelers to know.

[image: Warning] In SketchUp, using tags the wrong way can seriously mess up your model. We’re not kidding. If you plan to use tags, read “Discovering the Ins and Outs of Tags” later in this chapter. Not doing so can result in serious injury or even death — depending on how upset you get when your 50-hour model gets ruined.




This section begins by explaining how Tags and the Outliner work, and some of the amazing things that you can do with them. Later on it will get into how to actually tag and organize components in your model.
 

IS YOUR MODEL CLASSY?
 
SketchUp Pro contains an enormously powerful, enormously complicated feature: Classifications. This feature lets you tag groups and components in your model with special identifiers that make them more useful — in very specific circumstances.

If you’re using SketchUp Pro as part of a building information modeling (BIM) workflow, and you want to imbue your model with juicy metadata while it’s still in SketchUp, you can. The bottom line is that if you don’t know what BIM stands for, you probably don’t need Classifications. Anyway, all you have to do is load an existing classification schema and apply Type metadata to the component definitions you want to classify. Not lost yet? If you like, you can even make your own schemata (the plural form of schema) by using properly formatted XML to create your .XSD files. Oof. If you understood any of the foregoing, you hereby qualify as a supergeek.

Needless to say, Classifications is way beyond the scope of this book. You don’t need to use it for basic, everyday modeling; you might not even need to use it if you’re designing a new habitation module for the moon. But for folks who do need it (and there are more and more of them every year), this feature is a giant step forward for keeping SketchUp Pro integrated with modern, connected BIM software.




Seeing the Big Picture: The Outliner

Many people love to make lists. Not only that, but they also love to look at lists; information arranged neatly into collapsible rows is the kind of thing that comforts their hearts and brings a tear to their eyes.

Now, before you decide that they’re so boring that they add zest to their lives by color-coding spreadsheets, consider this: Most halfway-complicated SketchUp models consist of dozens, if not hundreds, of groups and components. These groups and components are nested inside one another like Russian dolls, and many are heavy, computer-killing behemoths like 3D trees and shrubs.

SketchUp Pro includes a lovely list functionality called the Outliner, also available with Shop subscriptions. The Outliner helps you keep track of all your groups and components, hide what you don’t want to see, and (more important) unhide what you do. Ready to dive in? We thought so!
 
Taking a good look at the Outliner

You can open the Outliner panel on the right side of the screen by choosing Window ⇒ Default Tray ⇒ Outliner (Mac: Window ⇒ Outliner). Figure 7-1 shows what the Outliner looks like in the desktop and web versions when a model consists of a simple room with some furniture in it. Each piece of furniture is a separate component from the SketchUp 3D Warehouse.



[image: Snapshot of the outliner listing the components in a model.] 
FIGURE 7-1: The Outliner lists the components in a model.






The Outliner panel has the following features: 


	Search filter box: If you type a word or phrase in this box, the Outliner shows only the items in your model that include that word or phrase in their names. Type coffee, for example, and only the coffee table component is visible.

	Right-clickability: Right-click any object (a group or component) in the Outliner to reveal the same options that are available when you pick a component with the Select tool.

	Outliner Options flyout menu: In the desktop version, this handy little menu contains three options: 
	
Expand All: Choose this option to have the Outliner show all the nested groups and components in your model — every last one of them (provided that they’re attached to visible tags).

[image: Remember] The Outliner shows only groups and components that exist with visible tags in your model. In other words, anything with a hidden tag doesn’t appear in the Outliner, so be extra-careful if you’re using both the Outliner and tags to organize your model. You can read all about tags in the “Discovering the Ins and Outs of Tags” section later in this chapter.


	Collapse All: This option collapses your Outliner view so that you see only top-level groups and components — ones that aren’t nested inside other groups and components.

	Sort by Name: Select this option to make the Outliner list the groups and components in your model alphabetically.



	[image: 9781119617938-ma029] [image: 9781119617938-ma030] Outliner List window: All the groups and components in your model are listed here. An icon with four little boxes indicates a component, whereas an icon that’s a bigger solid box indicates a group. An Expand/Collapse toggle arrow appears next to a group or component that holds nested groups or components. (You see an example of a group with nested components in Figure 7-1.) You can keep the nested list closed or expand it so that the constituent groups and components appear in the list.




 
Making good use of the Outliner

[image: Remember] If you use lots of groups and components (and you should), having the Outliner open onscreen is one of the best things you can do to model efficiently.

Here’s why: 


	Use the Outliner to control object visibility. Instead of right-clicking groups and components in your model to hide them, use the Outliner instead. Just click the eyeball icon next to the name of any element in the Outliner. When you do, the object is hidden in your modeling window, and its name is dimmed and italicized in the Outliner. To unhide it, just click its eyeball in the Outliner. We know — it’s a little bit gooey, but it’s effective.

	Drag and drop elements in the Outliner to change their nesting order. Don’t like having the component you just created nested inside another component? Simply drag its name in the Outliner to the top of the list. This step moves the component to the top level, meaning that it’s not embedded in anything. You can also use the Outliner to drag groups and components into other ones.

	Find and select things with the Outliner. Selecting something in the Outliner highlights that something’s name and selects it in your modeling window. With this technique, selecting nested groups and components is easy, especially if you’re working with a complex model. Click any element (even hidden ones) to reveal it in the modeler. Similarly, double-clicking deeply nested groups or components opens them for editing, potentially saving you dozens of clicks.



[image: Tip] You have multiple ways to tell what is hidden in your SketchUp model. Outliner will tell you what groups and components are hidden by their list styling, but you can also choose View ⇒ Show Hidden Objects to visualize hidden groups and components in the modeling window. (In the Web version, this feature is a toggle switch near the top of the Display panel.) These objects are still technically hidden, but now they’re visible for you to select and operate on without having to change their visibility status.





Discovering the Ins and Outs of Tags

Tags are a very useful part of SketchUp, and they can make your life a lot easier. Tags can also be a major source of heartache because they can really mess up your model if you’re not careful. This section can set you on the right track.
 
What Tags are — and what they’re not

In a 2D program like Adobe Photoshop or Illustrator, the concept of layers makes a lot of sense: You can have content on any number of layers, sort of like a stack of transparencies. You find a distinct order to your layers, so anything on the top layer is visually in front of everything on all the other layers, as shown in Figure 7-2.



[image: Schematic illustration of the layers which are pretty straightforward.] 
FIGURE 7-2: In 2D software, layers are pretty straightforward.






But SketchUp isn’t a 2D program; it’s a 3D program. So how can it have layers? How can objects in 3D space be layered on top of one another so that things on higher layers appear in front of things on lower ones? They can’t; it’s impossible. Tags in SketchUp are different from layers in most other graphics programs, and that’s confusing for lots of people who use those other programs.

[image: Technical Stuff] Earlier releases of SketchUp had a layers system because some of the very first SketchUp users were architects, and many, many architects use AutoCAD drawing software. Because AutoCAD uses layers extensively, layers were incorporated into SketchUp to maximize compatibility between the two products. Some confusion began to creep in, however, because SketchUp layers weren’t exactly identical to other software layers, so SketchUp renamed them Tags. When you import a layered AutoCAD file into SketchUp, its layers show up as SketchUp Tags, which is pretty convenient. For more information about importing CAD files into SketchUp Pro, take a gander at the last part of Chapter 8.

[image: Remember] So what are SketchUp Tags for? Tags control visibility. Use them to gather particular kinds of geometry so that you can easily turn it on (make it visible) and turn it off (make it invisible) when you need to. That said, tags don’t work the same way as groups and components; your edges and faces aren’t isolated from other parts of your model, which can cause major confusion if you’re not careful. To find out more, take a look at “Staying out of trouble” later in this chapter.


 
Navigating the Tags panel

The Tags panel, shown in Figure 7-3, is a pretty simple piece of machinery. You open it by choosing Window ⇒ Default Tray ⇒ Tags (Mac: Window ⇒ Tags). (Web: The Tags panel is near the middle of the right-side utility tray.) Here’s a quick introduction to the panel features: 


	Add Tag: Clicking this button (the plus sign) adds a new tag to your SketchUp file.

	Delete Tag: Click this button (the minus sign) to delete the selected tag. If the tag you’re trying to delete contains anything, SketchUp asks what you want to do with it; choose an option, and click Delete.

	Set Current Tag: Click the far-right end of a tag name to make it current. A pencil icon appears. Any geometry you create inherits this current tag. As we discuss shortly, we highly advise not messing with this option. It’s way safer for your model to simply add tags after creating geometry.

	Tag Options flyout menu: This menu offers the following useful options: 
	Purge: When you choose Purge, SketchUp deletes all the tags that don’t contain geometry. This is a handy way to keep your file neat and tidy.

	Color by Tag: Notice how each tag in the list has a little material swatch next to it? Choosing Color by Tag temporarily changes all the colors in your SketchUp model to match the colors (or textures) assigned to each tag. To see what’s on each tag, go straight to this option.



	Tags list: This list contains all the tags in your SketchUp file. You need to know about these three columns: 
	Name: Double-click a tag’s name to edit it. Giving your tags meaningful names is a good way to find what you want quickly.

	Visible: This eyeball icon is the heart and soul of the tags panel. When it’s selected, the geometry on that tag is visible; when the eyeball isn’t selected, the tag’s geometry isn’t visible. This feature works just like it does in the Outliner.

	Color: You can choose to view your model using Color by tag, described earlier in the list. You can choose which material (color or texture) to assign to each tag by clicking the Color swatch.






[image: Snapshot of the tags panel.] 
FIGURE 7-3: The tags panel.








Tag, you’re it!

Now that you know how and why to use and manipulate tags, it’s time to see how to create and attach them. As previously indicated, all new entities are automatically assigned to the current tag, so usually, all you have to know is how to move them. Moving things from one tag to another is a simple three-step process: 

	
Select the entity or entities to which you want to apply a tag.

[image: Remember] Move only groups and components to other tags; the next section, “Staying out of trouble,” explains why.


	
Open the Entity Info panel in the Default Tray.

(Mac: Window ⇒ Entity Info; Web: top of the right panel tray.)


	
In the Entity Info panel, choose a tag from the Tags drop-down list.

Your selected entities are tagged per your selection.




 
Staying out of trouble

Tags can be really helpful, but you need to know how to use them; if you don’t, bad things can happen. Check out the following do’s and don’ts before you start working with tags: 


	
[image: Warning] Do all your modeling on Untagged. Always make sure that the default Untagged is your current tag when you’re working. (Earlier releases called it Layer0 as part of its CAD heritage.) Keeping all your loose geometry (that’s not part of a group or component) together in one place is the only way to make sure that you don’t end up with edges and faces all over the place. SketchUp lets you put geometry on whatever tag you want, which means that you can end up with a face on one tag and one or more of the edges that define it on another. When that happens, working out where everything belongs is next to impossible; you’ll spend hours trying to straighten out your model.

This property of SketchUp’s Tags system can be a major stumbling point for new SketchUp users; knowing to keep everything on Untagged can save you a lot of anguish.


	Don’t move anything but groups and components to other tags. If you’re going to use tags, follow this rule: Never put anything on a tag other than Untagged unless it’s already a group or a component. Doing so ensures that stray edges and faces don’t end up on separate tags.

	Use tags to organize big groups of similar things. More complicated SketchUp models often include things like trees, furniture, cars, and people. These things are almost always already components, so they’re perfect for organizing on separate tags. You can make a Trees tag and put all your tree components on it, for example. Because trees are usually big, complicated components with lots of faces, hiding all your trees at the same time with the Tags feature is a handy way to improve your computer’s modeling performance.

	Don’t use tags to organize interconnected geometry; use the Outliner instead. By interconnected geometry, we mean things like building floor levels and staircases. These model parts aren’t meant to be physically separate from other parts in the way that vehicles and people are. When you put Level 1 on one tag and Level 2 on another, more often than not, you become confused about what belongs where. Is the staircase part of Level 1 or Level 2? Instead, make a group for Level 1, a group for Level 2, and a group for the staircase; you’ll need less headache medicine at the end of the day.

	
[image: Tip] Feel free to use tags to iterate. Iteration is the process of doing multiple versions of the same thing. Lots of designers work this way to figure out problems and present different options to their clients. Using tags is a great way to iterate: You can move each version of the thing you’re working on to a different tag, and then turn the tags on and off to show each in turn. Just remember to follow the rule about using groups and components only on separate tags (mentioned previously in this chapter), and you’ll be fine.




[image: Tip] Check out the sidebar “Using scenes to control tags” later in this chapter for a nifty way to flip through tags that represent design iterations in your model.





Putting It All Together

In this chapter (and in Chapter 5), we talk about each of SketchUp’s organizational methods in isolation: discussing how they work, why they’re special, and when to use them. When you’re actually working in SketchUp, you probably use a combination of them all, so we thought you’d find an example of all the organizational tools in action especially helpful.

Figure 7-4 shows a model of a house. Here’s how all the organizational tools are working together to keep the model organized: 


	
Each floor level is a group. Organizing each floor into a group enables you to hide whichever one you’re not working on, so you can see what you’re doing and SketchUp runs a little faster. The house’s only staircase was included in the first-floor group, because that turned out to be the easiest thing to do, but you might keep the staircase as a separate group.

[image: Tip] The interior walls on each level were also included in that level’s group. For most buildings, you can probably do the same unless you plan to study different floor plans with different interior wall arrangements.


	
The roof and exterior walls are groups inside another group. To remove the roof or the exterior walls separately, each needs to be a group. To hide and unhide them both at the same time, create a Shell group to include them both. With this setup, you can selectively show or hide just the geometry you want to see. See Figure 7-5.

[image: Remember] The floor levels, roof, and exterior walls are groups instead of components because they’re unique. A house has only one first floor, so that floor doesn’t need to be a component.


	
All the furniture and plumbing fixtures are components. To furnish the house, furniture components were created or components from the Components panel and 3D Warehouse were used.

[image: Tip] When you have only one couch, why make it a component instead of a group? By making every piece of furniture in a model a component, you can see the furniture listed in the In Model collection of the Components panel. You can also save your furniture as a separate component collection on your computer. The next time you move, you have all your furniture in a single place, ready to drop into a model of your new house.


	
All the furniture has a separate tag. Furniture components can be a little heavy — that is, they tax your computer system. With the furniture having a tag, you can easily hide it all. This setup also enables you to see your space without furniture. Remember that the visibility of a tag can be controlled with a single click.

[image: Tip] But why not just create a group from all the furniture components and use the Outliner to hide and unhide them all, instead of bothering with tags? Good question. Changing a component’s tag is easier than adding a component to an existing group. To add something to a group, you need to use the Outliner to drag and drop that something in the proper place. With complex models, this task can be a hassle. Changing a component’s tag is a matter of using the Entity Info panel to choose a new tag from a list.






[image: Schematic illustration of all the SketchUp’s organizational tools which were used to build this model.] 
FIGURE 7-4: All of SketchUp’s organizational tools were used to build this model.







[image: Schematic illustration of the each floor of the house, as well as the roof and the exterior walls which is a separate group.] 
FIGURE 7-5: Each floor of the house, as well as the roof and the exterior walls, is a separate group.









USING SCENES TO CONTROL TAGS
 
In SketchUp, scenes are saved views of your model. Instead of fiddling with navigation tools and panels every time you want to return to an important view, you can click a scene tab.

Although you learn the details about scenes in Chapter 11, scenes are relevant in this chapter because scenes don’t just save different camera positions, but also control tag visibility. Clicking a scene tab to instantly change which tags are showing is a crazy-powerful way to do iterative design (creating and presenting different options within the same design).

Here’s a very simple example: You’ve modeled a living room and want to try three different furniture configurations. Follow these steps: 

	Make three tags: Option 1, Option 2, and Option 3.

	
Do three separate furniture arrangements, one per tag.
This step means that you have three copies of each object you move.


	Use the Tags panel to show Option 1, and hide Option 2 and Option 3.

	Create a new scene, and name it Option 1, using the Scenes panel.

	Repeat steps 3 and 4 for the other two configurations.


Now all you have to do is click a scene tab to switch among the three options. This technique is much more elegant than fiddling with the Tags panel during a presentation.

To make this technique really sing, you need a working knowledge of the Properties to Save check boxes in the Scenes panel. Although this technique of combining tags and scenes isn’t beginner-level stuff, you can probably get the hang of it easily after you have some practice with both tags and Scenes. When you have the hang of this technique, it’s an elegant way to work. Pick your way through Chapter 11 when you’re ready.

One more useful tidbit: The Auto-Invisible Layer extension lets you create a new tag that isn’t visible in any of the scenes you’ve made previously. This extension comes in handy when you need to add a new iteration after you’ve already made a bunch of scenes. You find extensions in the Extension Warehouse, introduced in Chapter 15.





   

Chapter 8

Modeling with Textures, Photographs, and CAD Files

IN THIS CHAPTER

[image: check] Applying textures and photos to a model’s faces

[image: check] Building a model from scratch with SketchUp’s photo-matching tools

[image: check] Giving your model a geographic location

[image: check] Starting out with a 2D CAD file in SketchUp Pro



No matter how complex your models are, there is no doubt that they will be more interesting if you use textures — 2D image files — to paint faces in the model.

In concert with 3D geometry, textures provide visual cues that help people understand your designs more quickly. Modeling a face with a transparent material instantly conveys that it is probably made of glass. The same is true for using textures to paint faces that resemble wood, brick, or tile.

But textured models aren’t just more useful. Textures make your model look more attractive or realistic. If you are using 3D modeling to compel and convince someone about your great idea, mastering the texturing techniques in the first part of this chapter will give you an edge.

Real-world photographs are particularly useful textures. Not only can they inject materiality into your model, but also, they can be used as references while modeling or as an alternative to modeling.

While we’re on the subject of importing things into SketchUp, we wrap this chapter with a closer look at how to bring in geographic and CAD data.



Painting Faces with Image Files

Technically, painting surfaces with pictures using 3D software is called mapping, as in “I mapped a photo of your face to the underside of the pile-driver model I’m building.” Different software programs have different methods for mapping pictures to faces. Luckily, in SketchUp, the process is pretty straightforward.

The following sections deal with mapping textures to two kinds of faces: flat and curved. The tools are similar, but the methods aren’t. We explain both because you never know what you’re going to run into.

[image: Tip] SketchUp uses a few terms to refer to the stuff you can paint faces with; generically, they’re all materials. Materials can be colors or textures; textures are image-based, and colors are a single solid hue. When you import an image to map it to a face, the image becomes a texture — just like any of the other textures in your Materials panel. Read more about using materials in Chapter 3.
 
Applying textures to flat faces

Although SketchUp has a default palette of textures, we think it’s a good idea to know how to bring in your own image files as textures. You’ll find broader and higher-quality collections of textures in the wild of the Internet than you will in SketchUp’s sampler library. (Read more about sources for textures later in this chapter in “Where to find good textures.”)

For now, let’s say you found a good texture image of hardwood flooring. Here’s how you would apply it to the floor in your model.
 
	
[image: 9781119617938-ma001] Using the Select tool, click the face you want to texture.

If the face to which you want to add texture is within a group or component, first double-click to edit an object, and then click once to see if you need to go deeper into the object to select a face.


	
Choose File ⇒ Import (web: Insert).

The Import dialog box opens.


	
Select the image file you want to use as a texture.

You can use JPEGs, TIFFs, and PNGs as textures in SketchUp; all these are common image file formats.


	
In the Use Image As menu, select the Texture option.

Figure 8-1 shows the options that appear at the bottom of the Import dialog box.


[image: Snapshot of telling SketchUp that the user want to use the image as a texture.] 
FIGURE 8-1: Tell SketchUp you want to use the image as a texture.







	
Click the Import button.

The Import dialog box closes, Paint Bucket becomes your active tool, and its cursor is loaded with the image you chose to import.


	
[image: 9781119617938-ma007] Click once near a corner of the face you want to paint (see Figure 8-2).

Your first click tells SketchUp where to position one corner of the image you’re using as a texture.


	
Click somewhere else on the face you’re painting (see Figure 8-2).

Unless the proportions of your image perfectly match the face onto which it was mapped, your image repeats. Don’t worry — that’s normal. SketchUp automatically tiles your image to fill the whole face. If you want to edit your new texture, skip to the later section “Moving, scaling, rotating, shearing, and distorting your texture.” You can scale, rotate, or even stretch your texture to make it look however you want. See the nearby sidebar “When is an image a texture?” to find out more about what happens to your image when you apply a texture.









[image: Technical Stuff] WHEN IS AN IMAGE A TEXTURE?
 
Time for a little bit of theory. Image textures in SketchUp are made up of tiles. To make a large area of texture, such as a brick wall, SketchUp uses a bunch of tiles right next to each other. In the case of a brick wall, the face of a model may look like thousands of bricks, but the effect is really just the same tile of about 50 bricks repeated over and over.

Because SketchUp treats imported image textures just like any other texture, what you’re really doing when you click twice to apply your image is this: You’re telling SketchUp how big to make the tile for your new texture. Don’t worry too much about getting the size right the first time. You can always tweak things later.



[image: Schematic illustration of two images.] 
FIGURE 8-2: Click once to locate one corner of the image you’re using as a texture. Click again to locate the other corner. (You can scale the texture up or down after it’s applied.)







Moving, scaling, rotating, shearing, and distorting your texture

The title of this section pretty much says it all. Doing the aforementioned things to your texture involves Texture Edit mode, which is a little bit hidden, unfortunately. Follow these steps to move, scale, rotate, or skew your texture: 

	[image: 9781119617938-ma001] With the Select tool, click the face with the texture you want to edit.

	
Choose Edit ⇒ Face ⇒ Texture ⇒ Position.

This command enables (deep breath) the Move/Scale/Rotate/Shear/Distort Texture mode. You see a transparent version of your image, along with four pins, each a different color, as shown in Figure 8-3. If all your pins are white, you’re in Stretch Texture mode. Right-click your textured face and select Fixed Pins to switch to the desired Fixed Pin mode.

[image: Tip] A quicker way to get to Texture Edit mode is to right-click the textured face and then choose Texture ⇒ Position from the shortcut menu.


[image: Schematic illustration of using the pin to realistically orient and scale textures.] 
FIGURE 8-3: Use the green pin (only) to realistically orient and scale textures.







	
Edit your texture.

At this point, you can edit your texture in two ways: by using the options on a shortcut menu or by dragging the colored pins.

Right-clicking your texture opens a shortcut menu with the following options: 


	Done: Tells SketchUp you’re finished editing your texture.

	Reset: Undoes all the changes you’ve made to your texture.

	Flip: Flips your texture left to right or up and down, depending on which suboption you choose.

	Rotate: Rotates your texture 90, 180, or 270 degrees, depending on the suboption you choose.

	Fixed Pins: When this option is selected, you’re in Move/Scale/Rotate/Shear/Distort Texture mode (Fixed Pin mode). Deselecting it switches you over to Stretch Texture mode, discussed in the upcoming section “Stretching a photo over a face.”

	Undo/Redo: Goes back or forward a step in your working process.



While you are in Fixed Pin mode, dragging each of the colored pins has a different effect (refer to Figure 8-3): 


	Scale/Shear (Blue) pin: Scales and shears your texture while you drag it. Shearing keeps the top and bottom edges parallel while making the image “lean” to the left or right.

	Distort (Yellow) pin: Distorts your texture while you drag it; in this case, the distortion looks kind of like a perspective effect.

	Scale/Rotate (Green) pin: Scales and rotates your texture while you drag it.

	Move (Red) pin: Moves your texture around while you drag it. Of all four colored pins, this one is the most useful. It’s great for precisely positioning brick, shingle, and other building material textures in a model.



	
In your modeling window, click anywhere outside your texture to exit Texture Edit mode.

You can also press Enter or right-click and choose Done from the shortcut menu.



[image: Tip] While it’s useful to know what all the texture pins can do, you can make your life a lot easier by only using the green pin, and ignoring the red, blue, and yellow ones. Green is the only pin you need to use to rotate and scale textures, which is most of what you need for making textures look more realistic.

For instance, let’s say that you want to scale your hardwood texture image to make the board width proportionate to the model. First, you’d draw out a guideline in the model to define the width of the slat. Then you’d use only the green pin in Position Texture mode (refer to Figure 8-3) to scale the texture up or down to that guide. The green pin won’t snap to the guide, but you can get close.





Stretching a photo over a face

For many flat objects like rugs, paintings, fences, and windows, an image texture can stand in for 3D geometry. The trick is stretching the image to fit a face in your model.

Imagine a photograph printed on a piece of rubber that you can stretch until the photo looks the way you want and that you hold in place with pins. That’s basically how Stretch Texture mode (also known as Free Pin mode) works.

Follow these steps to stretch your texture using the Position Texture tool’s Stretch Texture mode: 

	
[image: 9781119617938-ma001] Right-click the face whose texture you want to edit and choose Texture ⇒ Position (top-left image in Figure 8-4).

As long as you are in the same shortcut of the face (and not outside its group or component), this is a quick way to edit a texture.




WHERE TO FIND GOOD TEXTURES
 
Good news: texture images are everywhere. At first, you may feel overwhelmed hunting around for images, but if you have a good sense of what you are looking for, we think you’ll often find texture gold at the end of the rainbow.

Searching Google or Pinterest is a good way to browse and source texture images, but a slightly more useful place to look is SketchUp’s 3D Warehouse (https://3dwarehouse.sketchup.com). Here you can browse for texture images, preview them in SketchUp’s 3D environment, and then simply start painting with them in your model: 

	Within SketchUp, open 3D Warehouse (choose Window ⇒ 3D Warehouse).

	Search for and find a model that you would like to borrow a texture from.

	In the model details page (pictured), expand the model’s Materials list.

	
Choose the texture you’d like to sample and click Download.
Back in your SketchUp, the Paint Bucket tool will become activated with your newly scraped texture.



Beyond SketchUp, you may find that your smartphone is the ultimate source of texture images. If you avoid light and glare, your phone can certainly take high-quality photos. You may have to play with a few camera settings to get it right. Might we recommend Edward Baig and Bob LeVitus’s iPhone For Dummies (John Wiley & Sons, Inc.)?

Finally, there are some paid texture collections that are worth considering. In particular, FormFonts (https://www.formfonts.com) maintains a deep library of textures, models, and styles for use in SketchUp. 


[image: Snapshots of finding the good textures.] 









[image: Photos depict the Fixed Pin mode to stretch four parts of an image to four endpoints of geometry.] 
FIGURE 8-4: Use Fixed Pin mode to stretch four parts of an image to four endpoints of geometry.







	
Right-click your texture again and clear the check mark next to the Fixed Pins option.

You switch to Stretch Texture mode. Instead of four different-colored pins with little symbols next to them, you see four white pins. (See the top-right image in Figure 8-4.)


	
Click and release each pin to pick it up and then relocate it to a spot on the image where you want to stretch to the corner of your geometry.

In the left image of the middle row of Figure 8-4, the white pins have been carefully placed at the corners of the painting.


	
Once you’ve placed the white pins where you want them, click and drag each pin to reposition it until your photo stretches over the face in a way you like.

In the right image of the middle row of Figure 8-4, the white pins are stretched to snap to the corners of the geometry.

[image: Tip] If you need to, feel free to orbit, zoom, and pan around your model to get the best view of what you’re doing; just use the scroll wheel on your mouse to navigate without switching tools.


	Press Enter to save your changes and exit Texture Edit mode.


If you don’t like what you see, go back and edit the texture again; you can muck around as many times as you like.


 
Editing a texture image

Perhaps there’s something in a photograph you’re using, and you don’t want it to be there. Using SketchUp Pro, you can use Edit Texture Image to open the texture you’ve selected in an image-editing program, where you can edit the texture directly.

Follow these steps to use Edit Texture Image: 

	Right-click the texture in your model you want to edit and choose Texture ⇒ Edit Texture Image.

	
In the program that opens, make whatever changes you need to make.

The editing program that opens will be whatever your operating system defaults to for the file format of the image that you have selected. Be sure not to change the proportions of the image; that can really mess things up. If you’d like to maintain the original version of the image, save a copy of it before you start editing it for use in SketchUp.


	Save (don’t Save As and change the filename) the image you’re editing and close it if you like.

	Back in SketchUp, check to make sure your edits have been applied.


Which image-editing program actually opens depends on what you have installed on your computer; you specify which one to use in the Applications panel of the Preferences dialog box. For what it’s worth, most designers use Adobe Photoshop, but you can use whatever you have.

[image: Tip] Need to radically reduce the size of your SketchUp model file? Right-click any textured face in your model and choose Make Unique Texture to create a copy of the texture you’ve selected and crop (trim away everything that isn’t visible) that copy according to the face it’s on. Then open the Materials Panel. On the In Model tab, choose Purge Unused from the drop-down menu (web: Click the Recycling icon).

Why is this important? Just because you can’t see part of an image doesn’t mean it’s not there; SketchUp saves the whole image with the model, even if you use only a little bit of it. In a complex model with dozens of photo textures, all that invisible extra photo data adds up. Making your textures unique can make your models much, much smaller.




 
Controlling color and transparency

Part of making your model look just right with textures is a process called colorizing. You can control the colors associated with your texture to make bricks look more brown and less red, to make leaves on trees change from spring to fall conditions, or to change the transparency of glass.

The best part of tweaking colors in your textures is that you can get real-time feedback in the modeling window. Colorizing is available in SketchUp for Web but only with a paid subscription. Here’s how to edit the color properties underlying any texture in your model: 

	
[image: 9781119617938-ma007] Activate Paint Bucket (B), and then press and hold the Alt key (Mac: ⌘  ) to activate the Eye Dropper.

When the Eye Dropper is active, any texture you select in the model will become active with the Paint Bucket tool, and it will also become selected in the Materials Panel. To edit a texture, the first thing you have to do is select it.


	
Using the Eye Dropper, click the texture you want to colorize.

Notice that it will become selected in the Materials panel.

If you don’t see the selected texture highlighted in the Materials panel, make sure you are in the In Model category of the panel, where all the textures stored in your model file are listed.


	
Double-click the selected texture in the Materials panel (see Figure 8-5; web: Click the pencil icon next to the Material name at the top of the panel).

A new mode of the Materials panel becomes available where you can edit several properties associated with the selected texture.


	
In the Edit tab of the Materials panel, use the color picker (Mac: icons at top of Materials panel) and opacity slider to colorize your texture or to increase or decrease its transparency.

You should see your changes reflected (as you make them) in the modeling window (see Figure 8-5).



As you start working more with Styles and Shadows (see Chapter 10), think of colorization as the last step in your process of getting models to look just so.


[image: Snapshot of manipulating colors and seeing the impact in the model.] 
FIGURE 8-5: Manipulate colors and see the impact in your model.







 
Applying textures to curved surfaces

Notice how the title of this section ends with surfaces and not with faces? That’s because (as you know by now) individual faces in SketchUp are always flat — no exceptions. When you see a non-flat surface, it’s actually made up of multiple faces. You can’t see the edges between them because they’ve been smoothed. Choosing View ⇒ Hidden Geometry reveals dashed lines that expose all curved surfaces for what they really are. See Chapter 3.

How you go about mapping an image to a curved surface in SketchUp depends on what type of curved surface you have. With that in mind, curved surfaces fall into two general categories (see Figure 8-6): 


	
Single-direction curves: A cylinder is a classic example of a surface that curves only in one direction. In SketchUp, a cylinder is basically a series of rectangles set side by side. Most curved walls you see on buildings are the same way; they don’t taper in or out as they rise.

[image: Tip] Another way to think about single-direction curves is to consider how they might have been made. If the curved surface you’re staring at could be the result of a single push/pull operation (such as turning a circle into a cylinder), there’s an excellent chance it’s single-direction.

For mapping an image to a single-curve surface, you can use the Adjacent Faces method; it works well and doesn’t stretch your image.


	
Multidirection curves: Terrain objects, saddles, and curtains are all prime examples of surfaces that curve in more than one direction at a time. They’re always composed of triangles — never basic rectangles.

To map an image to this type of curved surface, you must use the Projected Texture method. Skip to “The Projected Texture method” to read all about it.





[image: Schematic illustration of all curved surfaces which are either single-direction (left) or multidirection (right).] 
FIGURE 8-6: All curved surfaces are either single-direction (left) or multidirection (right).






[image: Tip] Please keep in mind that we totally made up names for the Adjacent Faces and Projected Texture methods of mapping images to nonflat surfaces. We had to call them something, and these sounded descriptive without seeming too technical.
 
The Adjacent Faces method

If you need to paint an image onto a surface that curves only in a single direction (such as a cylinder), you can use this technique. Follow these steps to find out how and take a look at Figure 8-7 to see the process in action: 

	Choose View ⇒ Hidden Geometry to turn on Hidden Geometry so you can see the individual faces in your model.

	
“Load” your cursor with an imported image.

Follow steps 1–4 in “Applying textures to flat faces” (earlier in this chapter) to import an image as a texture.


[image: Schematic illustration of the Adjacent Faces method which lets to map images to simple curved surfaces.] 
FIGURE 8-7: The Adjacent Faces method lets you map images to simple curved surfaces.







	
Paint the leftmost subface entirely with the image.

Your curved surface is composed of subfaces. Here’s how to paint the correct one: 

	Hover your loaded cursor over the lower-left corner of the subface farthest to the left. Don’t click yet.

	When the image is oriented in the right direction, click once.

	
Click again on the upper-right corner of the same subface.

This places the image; it should be cropped on the right near the next hidden geometry line segment (dashed line).




	
[image: 9781119617938-ma007] Select the Paint Bucket tool, hold down the Alt key (Mac: ⌘  ), and click the first subface to sample the texture (image) you just placed.

This “loads” your Paint Bucket tool with the texture.


	
Release the Alt key (Mac: ⌘  ), and click once on the face immediately to the right of the face you painted in step 3.

If everything’s working correctly, the image you placed appears on the face you just clicked.


	
Keep painting subfaces until you’re done.

Remember to work your way from left to right; skipping a subface messes up things. To fix a problem, just use Undo and keep going.


 


The Projected Texture method

For painting an image onto a complex curved surface, there’s no substitute for this method. Chunks of terrain are good examples of complex curved surfaces — bumpy, twisted, rippled, and multi directional. If the curve you’re dealing with is more complicated than a simple extrusion, you need to use this image-mapping technique.

The key is to line up a flat face with the curved surface to which you want to apply the texture. You then “paint” the flat face with the texture, make it projected, sample it, and finally, paint the curved surface with the projected, sampled texture. Whew.

Follow these steps to get the basic idea (see Figure 8-8): 

	
Create a flat face that lines up with your curved surface.

[image: 9781119617938-ma004] You can use the Line tool and SketchUp’s inferencing system to draw a flat face that lines up with (and is the same size as) your curved surface.


	
Apply a texture to your flat face and make sure that it’s positioned correctly.

For help, see “Applying textures to flat faces” earlier in this chapter.


	
Right-click the textured face and choose Texture ⇒ Projected.

This ensures that the texture is projected, which is the key to this whole operation.


	
[image: 9781119617938-ma007] Select the Paint Bucket tool, hold down the Alt key (Mac: ⌘  ), and click the projected texture to sample it.

This “loads” your Paint Bucket tool with the projected texture.


	
Release the Alt key (Mac: ⌘  ), and click the curved surface to paint it with the projected texture.

The pixels in the image likely look stretched in some places.


	
Delete the flat face that you originally mapped the image to; you don’t need it anymore.

Alternatively, you could group that flat face, apply a tag to it, and toggle that tag’s visibility off. This way, you can easily turn that tag back on if you need to make changes to your projected texture in the future. Learn more about Tags in Chapter 7.





[image: Schematic illustration of mapping projected textures.] 
FIGURE 8-8: Mapping projected textures; you’ll know when you get it right.






[image: Tip] If you’re trying to do this task on your own curved surface and things don’t seem to be working, your curved surface is probably part of a group or component. Either explode (via right-click) or double-click to edit the group or component before you do step 5 and see whether that helps. Chapter 5 explains how to edit groups and components.







Modeling Directly from a Photo: Introducing Photo-Matching

The first time we saw SketchUp’s photo-matching feature (called Match Photo) in action, we giggled and clapped our hands like toddlers at a petting zoo. We’re not ashamed of it, either. Sometimes technology that’s so useful, so unexpectedly satisfying, comes along, and you just can’t help yourself. On the other hand, Match Photo modeling is only available in SketchUp Pro, which means you’ll have to pay for this feeling.

So what does photo-matching do? If you have a good photograph (or multiple photographs) of the thing you want to model, SketchUp’s photo-matching feature can help you create your model. This application is how 99 percent of modelers use the photo-matching feature, and the technique we focus on in the next section. It is also possible to match an existing model to a photo.

[image: Remember] You can edit any texture in your model — including ones produced by photo-matching — by opening them in image-editing software (such as Photoshop) directly from SketchUp. This trick is handy for taking out stuff you might not want in your photos, such as trees, cars, and ex-partners. Take a look at the section “Editing a texture image,” earlier in this chapter, for all the juicy details.
 
Choosing a Match Photo–friendly image

Photo-matching works only on photographs of objects with at least one pair of surfaces that are at right angles to each other. Luckily, this includes millions of things you may want to build. But still, if the thing you want to photo-match is entirely round, or wavy, or even triangular, this method won’t work.

Here are tips for choosing a photo for this process: 


	Watch out for lens distortion. When you take a picture with a wide-angle lens, some straight lines in the image bow a little bit, depending on where they are in the frame. Try to use photos taken with a normal or telephoto lens: 50mm to 100mm is a good bet.

	Make sure that the edges of two perpendicular surfaces are visible in the shot. You need to see planes that are at right angles to each other in order to use photo-matching properly.

	Shoot at a 45-degree angle if you can. Because of the way perspective works, your results are more accurate if you use a photograph in which you can see both perpendicular surfaces clearly; if one of them is sharply distorted, you’ll have a harder time.



The following types of photos, illustrated in Figure 8-9, work especially well with SketchUp’s Match Photo feature: 


	An interior view of a room in which a corner meets at a right angle

	An aerial shot

	An exterior view taken from a human vantage point and in which a corner (or corners) meet at a right angle




[image: Photos depict the style that best describes your photograph’s camera position.] 
FIGURE 8-9: Choose the style that best describes your photograph’s camera position.








Modeling by photo-matching

The Match Photo feature helps you build a model based on a photograph. Here are two basic concepts: 


	The process is iterative, not linear. Building a model using a matched photo entails going between drawing edges, orbiting around, drawing more edges, going back to your matched photo scene, and drawing yet more edges. Every photo is different, so the ones you work with will present unique challenges that you’ll (hopefully) have fun figuring out.

	Don’t forget the photo textures. By far one of the coolest features of photo-matching is the ability to automatically photo-texture your model’s faces by using your photograph as “paint.” It’s a one-button operation, and it’s guaranteed to make you smile.



Follow these steps to start building a model from a photo: 

	
Choose Camera ⇒ Match New Photo.

A dialog box opens.


	
Select the image on your computer that you want to use and click the Open button.

The dialog box closes, and you see the image you chose in your modeling window. You also see a jumble of colorful techno-spaghetti, as shown in Figure 8-10. Don’t worry — it’s all part of the photo-matching interface.


	
In the Match Photo panel, choose the style that matches your photograph.

Reading from left to right, the three “grid” buttons beside the Style label are Inside, Above (for an aerial view), and Outside (for an outdoor view taken at ground level).

For the barn shown in Figure 8-10, we selected Outside.


[image: Snapshot of the photo-matching interface which includes the picture, and lots of other things.] 
FIGURE 8-10: The photo-matching interface includes your picture, plus lots of other things.







	
Click and drag the end points of the green perspective bars so that each bar lines up with edges in the photo that should be parallel to the model’s green axis.

[image: Remember] The perspective bars are the dashed lines with a small square at each end, and not the solid-color axes lines. There are two perspective bars of each color. They need to be aligned with two different features in the image that are parallel, and the farther apart the better.

The tops and bottoms of windows are good candidates, as are rooflines, tabletops, and ceiling tiles. In our example, we align the green perspective bars with the barn’s roofline.

[image: Tip] The following tips can help you position the bars correctly: 


	Zoom in and out (using the scroll wheel on your mouse) to better view your photograph while you place your perspective bars. The more accurately you place the bars, the better things will turn out.

	Match your perspective bars to nice long edges in your photograph; you get better results that way.



	
Click and drag the endpoints of the red perspective bars so that they line up with edges in the photo that should be parallel to the model’s red axis.

[image: Remember] The edges must be perpendicular to the first set of edges, or photo-matching doesn’t work. In our example, we align the red perspective bars to edges on the barn’s siding that are also perpendicular to the green perspective bars. You can see the result in Figure 8-11.


[image: Snapshot of the perspective bars which are aligned with the roofline and siding.] 
FIGURE 8-11: The perspective bars are aligned with the roofline and siding.







	
Drag the axis origin (the little yellow square where the axes come together) to a place where your building touches the ground and right at the intersection of two perpendicular edges, as shown in Figure 8-12.

Setting the axis origin is how you tell SketchUp where the ground plane is. After you set the axis origin in the right place, notice that the horizon line, which is the horizontal yellow bar, lines up with the horizon in your photo.

As long as you place the perspective bars correctly, the horizon line bar typically takes care of itself. However, now you know what the yellow horizon line bar does in case you need it.

[image: Tip] Occasionally, as you are working to properly set up a matched photo image, you will click outside the photo and all the guides will disappear. In the Match Photo panel, click the gear icon to jump back in and continue working.


[image: Snapshot of the axis origin which is on a corner that touches the ground.] 
FIGURE 8-12: The axis origin is on a corner that touches the ground.







	
(Optional) In the Match Photo panel, set the grid spacing so that you can roughly scale your model to your photo.

In our example, we leave the Spacing option set to the default of 5 feet. We know the barn is about 20 feet tall. Four gridlines are all we need to scale the model to the photo (because 4 × 5 = 20).

If you’re photo-matching an arena or a skyscraper, you probably need to adjust the grid spacing so that the grid can scale to such a large width or height.


	
Click the Done button in the Match Photo panel.

When you click the Done button, you stop editing your matched photo. All the colorful lines and grips disappear, and you’re left with the photo you brought in, your model axes, and your thoughts. It may have seemed like a lot of magic, but what you did was pretty simple: You used photo-matching to create a scene (explained in Chapter 11) with a camera position and lens settings that match the ones used to take the picture that’s on your screen. In effect, you’re now “standing” exactly where the photographer was standing when the photograph was taken.


	
[image: 9781119617938-ma004] Select the Line tool and, starting at the axis origin, trace one of the edges in your photograph.

Make sure that you’re drawing in one of the three main directions: red, green, or blue. If you accidentally orbit so that your photo disappears, click the scene tab to see the photo again. (We talk a little more about orbiting as you draw in the tips that follow step 11.)


	
Keep tracing with the Line tool until you have a rectangular face, watching the color of your edges as you draw.

[image: Remember] You always want your lines to turn red, green, or blue when you’re starting.


	
Use SketchUp’s drawing tools to continue to trace the photograph in three dimensions.

In Figure 8-13, you see two rectangular faces, one drawn on the green axis and the other drawn along the red axis.


[image: Snapshot of aligning the edges with the drawing axes to create basic shapes.] 
FIGURE 8-13: As you begin tracing your model, align your edges with the drawing axes to create basic shapes.





[image: Tip] Here are pointers for successfully tracing your photo with SketchUp’s drawing tools: 


	Always start an edge at the end of an edge you’ve already drawn. Doing so helps to assure that your results are what you expect.

	Never draw an edge in midair. Okay — this is the same as the last one, but it bears repeating: When you draw edges based on other edges, you get the best results.

	To start, be careful not to orbit while you draw. You can zoom and pan all you want, though. If you orbit away from the vantage point you set up, your photograph will disappear, and you see only the geometry you’ve drawn, as shown in Figure 8-14. You can easily get back by clicking the scene tab for your matched photo. The tab is labeled with the name of your photo at the top of your modeling window.


[image: Snapshot of clicking the scene tab to see the image.] 
FIGURE 8-14: When you orbit, your photo disappears. Click the scene tab to see the image again.







	After your model begins to take shape, orbit frequently to see what’s going on. You’ll be surprised what you have sometimes — tracing a 2D image in 3D is tricky business. Get in the habit of orbiting around to check on the results and draw certain edges. Click the matched photo scene tab to return to the proper view.

	Use other tools (such as Push/Pull and Offset) when appropriate. Nothing prevents you from using the full complement of SketchUp’s modeling tools. However, tracing the basic skeleton of a model with the Line and Eraser tools keeps the process simple.

	Pay attention to the colors. With a color photograph as an overlay, seeing what you’re doing can be tricky. Watch to make sure that you’re drawing the edge you intend to draw.

	Draw angles by connecting the dots. If you need to trace an edge in your photo that doesn’t line up with any of the colored axes (an angled roofline, for example), figure out where the endpoints are by drawing perpendicular edges and connecting them with an angled line, as shown in Figure 8-15. You can delete the line or lines that you don’t need later.

	Show or hide your photograph. Doing so sometimes helps you see your work. The next section explains where to find the controls on the Styles panel.








[image: Snapshot of drawing a temporary line to create an edge for a roofline or other edge that doesn't align with a colored axis.] 
FIGURE 8-15: Draw a temporary line to create an edge for a roofline or other edge that doesn't align with a colored axis.






After you finish drawing your model, you can scale it precisely by using the Tape Measure tool. (Chapter 3 explains how.) And finally, when you are done modeling, you can return to your Match Photo scene, and then click Project Textures from Photo. This last step burns the photo textures onto the individual faces, as shown in your Match Photo scene.


 
Making your matched photo reappear (or disappear)

After you match a photo to your model, the following tips are handy to know: 


	Click the matched photo scene tab: When you create a new matched photo, you create a new scene. (You can read all about scenes in Chapter 11.) Clicking a matched photo scene tab at the top of the modeling window returns your view to the one you set up when you created (or edited) that matched photo. It also makes the associated photograph reappear — handy if you’ve orbited into another view.



MAKING MULTIPLE MATCHES
 
If you have more than one photo of your modeling subject, you can have multiple matched photos in the same SketchUp file. Just get as far as you can with the first photo and then start again with the next by using the geometry you created as an “existing building.”

The following shows a model that was started of Habitat 67, in Montreal. Two pictures were used to create two matches in the same SketchUp file. Making more than one photo match is a great way to build more of a model than you could see in a single picture. 


[image: Snapshots of two pictures which
were used to create two matches in the same SketchUp file.] 







	Manage photo visibility settings in the Styles panel: Deep, deep down in the bowels of the Styles panel, on the Edit tab, in the Modeling Settings section, you can control the visibility of your matched photo. Chapter 10 is where you find out about Styles.

 




Adding Geographic Data

If you are modeling a building or location, the most useful kind of photograph to add to your model is probably an aerial satellite image: a map that you can reference and model into 3D. This satellite data is another modeling resource that is only available in the desktop version, SketchUp Pro.

When you add geographic data to your model (also called geolocating your model), you give it a specific latitude, longitude, and cardinal orientation based on an address, cross streets, or other information. That doesn’t sound like much at first, but here are two really useful things geolocation enables you to do: 


	Perform accurate shadow studies. For most designer-types, this is probably the biggest benefit of geolocating a model. With a latitude, a longitude, and a cardinal orientation, SketchUp’s shadow engine can display crazy-accurate shadows for any time of day, any day of the year, anywhere on Earth. You can find all the juicy details in the second half of Chapter 10.

	Build site shortcut models. If you’re designing a building, it’s probably surrounded by other buildings, and those other buildings are probably major influences on the design of your building, no? Wouldn’t it be nice to have them in your model? You can combine high-res, color, aerial (taken by airplanes or satellites) imagery with your own street-level photography to build the most useful shortcut models you’ve ever had. Even faster, use the PlaceMaker for SketchUp extension to pull in all sorts of shortcut data relevant to the location of your model. (Check out Chapter 15 for more info about extensions.)



Follow these steps to add a geolocation snapshot to your SketchUp file: 

	
Make sure you’re online.

All geodata is stored on far-flung servers; if you don’t have an Internet connection, you can’t use the geodata.


	
Open the SketchUp file you want to geolocate.

You can add a geolocation snapshot to your model anytime as you work on it. If you haven’t started modeling yet, it’s perfectly okay to add a geolocation to an empty file.


	
Choose File ⇒ Geolocation ⇒ Add Location from the menu bar.

A new window opens displaying a satellite map with a search bar at the top. (See Figure 8-16.)


	
Find the area where you want your model to be located.

You can type an address into the search bar in the upper-left corner if you like. You can also just use your mouse or the controls on the left side of the window to navigate. Scroll your mouse wheel to zoom; click and drag to pan.

When you’re zoomed in close enough, you see a white square: This is the largest snapshot you can import all at once. That’s still a very big area, so you probably want to keep zooming.


	Click the Select Region button to display a cropping rectangle.

[image: Snapshot of using add Location to add a satellite image to the SketchUp model.] 
FIGURE 8-16: Use Add Location to add a satellite image to your SketchUp model.







	
Drag the pins to specify the precise corners of your geolocation snapshot, as shown in Figure 8-16.

Try to frame an area that’s just big enough to provide a base for your model. Importing too much terrain data can bog down your computer. You can always bring in more terrain data later.


	
Click the Import button to add a geolocation to your SketchUp file.

The separate window closes, and a big, colorful rectangle appears in the middle of your model. That’s your new geolocation snapshot.


	
If you’re geolocating a model you’ve built already, move it into position on the snapshot.

[image: 9781119617938-ma013] Use the Move tool (and maybe the Rotate tool) to pick up your model and place it where it belongs. You’re not done yet, though — you still need to make sure your model is vertically situated on the terrain. Follow these steps to do just that: 

	Choose File ⇒ Geolocation ⇒ Show Terrain to switch to the 3D version of your geolocation snapshot.

	Select everything you want to move and use the Move tool to start moving; tap the up-arrow key to constrain your move to the blue axis.

	Sink your model into the terrain until it sits properly. Avoid the dreaded floating model syndrome at all costs.



 

ALL ABOUT GEOLOCATION SNAPSHOTS
 
When you import a geolocation snapshot, you are accessing huge repositories of geographic data from organizations like Digital Globe, Open Street Maps, Trimble, and others. These satellite snapshots are a lot more than pretty pictures. In addition to geolocating the model’s position, a snapshot has the following features: 


	Everything is already the right size. Perhaps you take a snapshot of a football field; when you measure that football field in SketchUp, it is exactly 100 yards long. That’s because SketchUp scales your snapshot to the correct size as part of the import process.

	Snapshots look flat but contain terrain data, too. The snapshot that SketchUp imports is more than just a color aerial photo. The snapshot also includes a chunk of topography — terrain. The terrain is flat when you first import it because it’s easier to build on that way, but you can toggle between flat and 3D (not flat) views by choosing File ⇒ Geolocation ⇒ Show Terrain. Don’t fret if you don’t see any difference when you flip between the views; you probably just chose a flat site. Currently, this terrain model is only available in the desktop version of SketchUp.



[image: Remember] If you want to import another snapshot into SketchUp, you can. SketchUp automatically tiles all the snapshots you take to form a patchwork in your model. This feature is super-handy if you find that you didn’t get everything you needed the first time.
 


Working with Imported CAD files

On the SketchUp Spectrum of Fun, importing and preparing CAD files is located right between latrine digging and cat milking; it’s not something many folks look forward to doing. This section is a collection of tips and tricks that have been developed in many years of dealing with other people’s CAD files.
 
Importing a CAD file into SketchUp Pro

This would probably be a great time to let you know (just in case you missed the heading right above this paragraph) that only SketchUp Pro can import CAD files in DWG and DXF format.

Your CAD file may be one you made yourself, but more likely you’ve received one from someone else. In that case, the absolute best thing to do is to open it in the same software that created it. If you have an AutoCAD file, open it in AutoCAD and take a look at it.

[image: Technical Stuff] AutoCAD files can contain a huge list of different object types, including but not limited to lines, arcs, circles, rectangles, ellipses, text, all of the preceding but with Z-direction thickness, the previous items but with Z-direction elevation above the X-Y plane, 3D surface models, 3D solid models, dimensions, leaders, hatches, text objects, dimensions, and hatches (of the sort that denote different materials), and several types of text. Also, any type of object can exist on more than one layer, and any one layer can hold more than one object type. (Does your brain hurt yet?) The good news is that SketchUp ignores text objects, dimensions, and hatches.

Other good news is that AutoCAD files can hold several different types of 3D objects, ranging from a simple line that has vertical thickness to full 3D solid models.

And the best news is that SketchUp will import any and all AutoCAD 3D objects, turning them into anatomically correct SketchUp components.

[image: Tip] If you have access to AutoCAD or are on good terms with the source of the AutoCAD file, it may well be faster and easier to do much of the 2D-to-3D conversion in AutoCAD before you import the file into SketchUp.

[image: Tip] AutoCAD files usually consist of two different but linked “spaces.” Model space contains the physical objects — walls, doors, bathtubs, toilets, cars, and sometimes dimensions, and so on — whereas paper space (called Layouts) contains documentation such as borders, title blocks, notes, company logos, and sometimes dimensions. You probably only want certain model space objects. Switch to model space, select the desired objects, and then copy them by using Ctrl+C (not the AutoCAD COPY command). Now start a fresh AutoCAD drawing and use Ctrl+V to paste your selected objects into the new drawing. Save it, and move on to step 1.

[image: Technical Stuff] Why should you filter out unwanted objects? Simple — it makes your resulting SketchUp file much smaller and less complex.

So far so good, but what if you don’t have AutoCAD? That’s okay; most SketchUp users don’t. You’ll have a fair amount of cleanup work to do in SketchUp after you’ve imported the CAD data, but it’s manageable. The section after this one describes a series of things you can do to wrangle the drawing into shape before you start modeling.

Actually importing CAD data into SketchUp Pro isn’t very complicated. Follow these steps, and you’ll do just fine: 

	
Open a fresh new SketchUp file.

You can’t just open a DWG or DXF file in SketchUp Pro; you have to import the data into an existing model. We strongly recommend starting with a new SketchUp file because most CAD files are super complex. Bringing all that complexity — thousands of edges and tons of layers — into an already-complex SketchUp model is just asking for trouble. Keep things separate and stay sane.


	
Choose File ⇒ Import.

The File Import dialog box opens.


	
Choose AutoCAD Files (*.dwg, *.dxf) from the Format drop-down list.

As with most applications that can open or insert several different file formats, you have to tell SketchUp what kinds of files you want to import before it will let you select them on your file system. This potentially saves you the effort of scrolling through a long list of file types that aren’t your current target.


	
Locate the CAD file (DWG or DXF) that you want to import and select it.

Don’t click Import just yet.


	
Click Options.

The DWG Import Options dialog box opens.


	
Set the Units to match the default measurement units of the CAD file you’re about to import.

If the CAD file is from someone in the United States, there’s a good chance the units are Inches or Feet. Other countries (wisely) use the metric system. If you have no idea what units to choose here, then start with Inches and see whether that works.


	Decide what to do about the other three options in the dialog box: 
	Merge Coplanar Faces tells SketchUp to automatically combine adjacent faces that are coplanar into a single face. This can save you cleanup time if the CAD file you’re importing actually has faces in it, but CAD files rarely do unless they specifically contain a 3D model or models. If you select this check box and your import fails (it happens), try deselecting it the next time.

	Orient Faces Consistently instructs SketchUp to do its best to make sure that the faces in your imported data (if there are any) are all facing the same way. Again, this might save you some cleanup time, but it also might throw a wrench into your import process.

	Preserve Drawing Origin is useful if you’ll be importing more than one CAD file into the same SketchUp model. You might do this if you’re importing multiple floor plans of the same building and you want them to line up.



	Click OK to close the DWG Import Options dialog box.

	
Click Import.

And cross your fingers. With a few tries, you’re usually able to import the CAD data. If you get a failure message, try again with a different Units setting in the Import Options dialog box (step 6). If that doesn’t work, the file might have been saved in a CAD format that’s newer than the ones that your version of SketchUp Pro can import. Contact the person who sent you the file and ask them to save another copy for you in an older CAD format.


	
Take a look at the Import Results dialog box to see where you stand.

If, after the import progress bar goes all the way to the right and the import itself is successful, SketchUp Pro will present a dialog box with statistics about what it imported and what it ignored. The simple version is that CAD layers, blocks (which translate to components in SketchUp), and edges of all sorts are importable. Text objects, dimensions, and hatches (of the sort that denote different materials) aren’t. When you’re satisfied, click OK and breathe a sigh of relief.



[image: Tip] After you’ve gone through the CAD import process and SketchUp has plunked the resulting geometry into your model, make sure everything went according to plan: Measure a couple of things with the Tape Measure tool to see whether they’re the sizes you expect them to be. Doorways are a good place to start; if you measure one and it’s many times smaller or bigger than it should be, your Units (in step 6 of the preceding steps) were set wrong. Close the file, open a new one, and try again.

[image: Warning] If you are working from the AutoCAD drawing that shows an existing building, be aware of the fact that it may not always accurately depict the “as-built” structure. In the days of paper-and-pencil drawings, a drawing got flipped over during the blueprinting process. The as-built structure was a mirror image of the original drawing.


 
Cleaning up imported CAD data

Most of the time, your imported CAD file looks something like the mess shown in the top image of Figure 8-17. Walls, grid lines, some symbols, and other stuff are all jumbled up, and it seems like you’re going to have to spend the rest of the week deleting edges. Probably not, actually — the following sections explain improvements you can make.
 
Switch to a style that’s easier to read

If you’re using a display style that includes lots of edge embellishments (such as Profiles, Extensions, and Endpoints), dense geometry of the sort in most CAD drawings looks like your model received an unwelcome visit from the Mascara Fairy. Yuck. Use the Styles panel to apply a style that’s plain and simple. We recommend either Shaded or Shaded with Textures, both of which you can find in the Default Styles collection. You can read all about styles in Chapter 10. Figure 8-17 shows what a difference a style can make.


[image: Snapshots of applying a simple display style to a model with imported CAD data makes it a lot easier to work with.] 
FIGURE 8-17: Applying a simple display style to a model with imported CAD data makes it a lot easier to work with.







 
Turn off tags you don’t need

Most of the drawing symbols and other annotations you brought into SketchUp aren’t things you need, at least right away. The simplest and safest way to get rid of them is to turn off their tags. Remember that SketchUp Pro also imports all of the layer information associated with the CAD data you brought in; now’s the time to use all of that complexity to your advantage.

Follow these steps to identify and hide the stuff you don’t need:

[image: Remember] AutoCAD calls tags layers, as did earlier SketchUp releases. The current release translates AutoCAD layers to SketchUp tags. 

	
Open the Tags panel.

CAD files usually come with dozens of layers. Make the Tags panel nice and big so you can see more of them.


	
Open the Entity Info panel.

The Entity Info panel tells you which tag a selected entity is on.


	
Right-click any part of the imported CAD drawing and choose Edit Component.

As long as your model contains at least one entity when you do a CAD data import, SketchUp Pro automatically puts all the imported geometry into a single component. Whatever you do, try not to explode this component; you find out why later on in this chapter.


	
Select an entity that you don’t want to see right now.

In Figure 8-18, a grid line that we don’t think we’ll need for a while (or at all) is selected.


	
Look at Entity Info to see what tag contains your selected entity.

In this case, the selected grid line is on the A-GRID tag. Okay, maybe we didn’t need Entity Info to tell us that.


	
Find the offending tag in the Tags panel and turn it off.

In the second part of Figure 8-18, switching off the A-GRID Tag temporarily hides all the entities on that Tag. Better already! If you’re positive you won’t need the contents on a particular Tag, you can delete it altogether. Some people love holding onto stuff, digital or otherwise (and have the basement and hard drive to prove it), whereas others immediately throw out unneeded stuff, often finding that they need it an hour later.


[image: Snapshots of select things which the user don’t need and hide their tags.] 
FIGURE 8-18: Select things you don’t need and hide their tags.







	
Repeat steps 4–6 for all of the entity types you want to hide.

This part of the cleanup process is pure SketchUp catharsis. It takes time, but the results are immediately visible. The last part of Figure 8-18 shows the result of hiding a bunch of tags.






[image: Tip] Of course, you can also dive right into the Tags panel and start turning off individual tags, especially if you know what entities they contain. The preceding steps are useful for situations where tags aren’t named descriptively or for when you’re overwhelmed and don’t know where to begin.




 
Modeling on top of imported CAD data

So you’ve successfully imported a CAD drawing and stripped down its style and visible tags to make it more manageable. Kudos — it’s time to start having some fun. Building a 3D model based on underlying (literally) CAD linework can be a surprisingly Zen experience if you follow one simple rule:

[image: Remember] Keep the imported CAD data isolated inside of its own component and build your model on top of it. Don’t be tempted to use the imported edges to create faces directly.

Here are three reasons why: 


	CAD data is almost always full of gaps. Lines that should extend all the way to their neighbors are sometimes short by tiny, invisible amounts, meaning you’ll spend hours drawing edges and trying to figure out why faces won’t appear where you want them to.

	CAD lines that should be parallel to one of the colored axes often aren’t. Think that edge is parallel to the red axis just because it looks like it might be? Not necessarily. Blithely turning imported edges into faces and then pushing/pulling them into 3D geometry is like building a house on quicksand; things get wonky quickly.

	Imported CAD drawings aren’t always flat. Sometimes different parts of your imported linework are located at slightly, maddeningly different heights. We’re talking thousandths of an inch — not enough to notice initially but certainly enough to mess up your work.



The main reason that CAD drawings contain the foregoing problems is because the creator of the file didn’t learn AutoCAD from AutoCAD For Dummies. These problems wouldn’t exist if the creator of the file had followed good CAD practices.

Instead of trying to use the imported edges as part of your 3D model, use them as references for new geometry that you draw on top of them. Tracing the imported geometry doesn’t take as much time as you’d think, and the result is a model whose geometry is far more accurate and predictable. The following two sections talk about strategies for “tracing” imported CAD content.
 
Modeling straight vertical walls based on imported CAD edges

There’s a technique for modeling simple walls and other straight elements on top of imported CAD linework that’s so simple and enjoyable that audiences regularly applaud when it is shown in a live demonstration. The credit for this method goes to our friend (and colleague) Mike Tadros.

[image: Remember] Before you get started, make sure you’re not editing the component that contains your imported CAD linework. Remember that you’re using the CAD drawing as a reference underlay for your own 3D modeling activities. You’ll be working “on top” (outside) of the component.

The Push/Pull tool is the hero of this method. Follow these steps (see Figure 8-19) to model a straight wall based on edges in an imported CAD drawing: 

	
Use the Axes tool to line up the colored modeling axes with the wall you’re about to model.

If the axes are already parallel to the wall, you can skip this step. If not, just choose Tools ⇒ Axes and line up the modeling axes with an edge in the CAD drawing that represents the wall you’re working on.


	
[image: 9781119617938-ma002] Draw a rectangle next to the wall.

It doesn’t matter how big it is; you’ll see why in a moment.


	
[image: 9781119617938-ma003] Use the Push/Pull tool to extrude the rectangle up to the height of the wall you’re modeling.

If you don’t know it just yet, just guess. It’s easy to change this later.


	
Use the Push/Pull tool to extrude the box you just made so that it’s flush with one side of the wall.

If you drew the rectangle in step 2 to the outside of the wall, push/pull the face so it’s flush with the inside of the wall. (See Figure 8-19.)

The key to this step is pure SketchUp Inferencing 101: Click to start pushing/pulling, hover your pointer over the edge (or its endpoint) that you’re aiming for, and then click again to stop pushing/pulling. You’re using the imported CAD edge as an inferencing reference for your tool. It’s a piece of cake after you’ve done it once or twice.


[image: Schematic illustration of modeling a simple wall based on a couple of edges in an imported CAD drawing.] 
FIGURE 8-19: Modeling a simple wall based on a couple of edges in an imported CAD drawing.







	
Use the Push/Pull tool to make the opposite face of the box flush with the other side of the wall.

See what’s happening? You’re using the Push/Pull tool and carefully chosen inferences to turn the box into the wall.


	
Push/pull the ends of the 3D wall so they match the underlying drawing.

We told you this was fun.



What happens when walls meet up at corners? Well, that can happen at right angles (which is common) or at other angles (which isn’t uncommon).
 
MODELING RIGHT-ANGLED WALLS

For 90-degree corners, all you have to do is draw a rectangle on the inside face of your wall and use the Push/Pull tool to extrude it out. After that, use the same tool to make it flush with the edges in the CAD drawing. Figure 8-20 provides a visual.



[image: Schematic illustration of using the Rectangle and Push/Pull tools to model walls that meet at right angles.] 
FIGURE 8-20: Use the Rectangle and Push/Pull tools to model walls that meet at right angles.








MODELING WALLS THAT MEET AT NON-RIGHT ANGLES

If you’re dealing with a corner that isn’t 90 degrees, you can proceed in a few different ways; using the Intersect Faces tool is a great place to start. The following steps (and Figure 8-21) elaborate on the technique: 

	
Model each straight wall segment independently but don’t overlap their ends just yet.

Follow the steps in the section “Modeling straight vertical walls based on imported CAD edges,” a few pages earlier, to build each wall so it’s parallel with the CAD edges to which it corresponds. Don’t worry about the two wall ends that will eventually meet; keep them apart for now.


	
[image: 9781119617938-ma003] Use the Push/Pull tool to extend each wall well past the point at which it should meet the other.

You’re modeling something that looks like an X from above.


	
[image: 9781119617938-ma001] Select the inside and outside faces of each wall (using the Select Tool + Shift key).

You should have a total of four faces selected.


	
Right-click your selection and choose Intersect Faces ⇒ With Selection.

This action tells SketchUp to draw an edge wherever two faces intersect. If you had four faces selected, you should now have two new edges.


	
Use Push/Pull to push away the wall segments you don’t need.

Pushing their top faces all the way down to their bottom faces makes them disappear.


	[image: 9781119617938-ma006] Use the Eraser tool to get rid of any extra edges.




[image: Schematic illustration of using intersect Faces to model walls that form non-90-degree corners.] 
FIGURE 8-21: Use Intersect Faces to model walls that form non-90-degree corners.










Modeling curved and irregular forms from CAD data

For rectilinear walls, stairs, and other shapes, SketchUp’s Rectangle and Push/Pull tools are rock stars. Rounded forms (such as concrete patios and castle turrets) and irregular lines (such as riverbeds and Frank Gehry buildings) call for other, more drastic measures.

The following steps give a general example dealing with features in your CAD file that aren’t worth painstakingly tracing with the Line tool but which need to appear in your SketchUp model. In these situations, you can rely on the handy Paste in Place command: 

	
[image: 9781119617938-ma001] Dive into the component that contains the imported CAD linework.

By “dive into,” we mean edit it, which you can do by double-clicking it with the Select tool.


	Select the edges you want to reuse.

	
Make a group out of the edges.

Right-click and choose Make Group. Grouping your selection accomplishes two things: Grouping makes reselecting it easier (in case things go awry), and it keeps things nice and separate for the next couple of steps.


	Choose Edit ⇒ Copy.

	
Stop editing the CAD linework component.

You can exit a component (or a group) by clicking with the Select tool somewhere outside its bounding box.


	
Choose Edit ⇒ Paste in Place.

Voilà! The edges in question are now a part of your model, and (thanks to step 3) are quarantined from the rest of your geometry by means of a group.



For shapes that are made up of simple arcs (segments of circles), your best bet is to try to re-create them by using SketchUp’s Arc tools. Why not just use the Paste in Place method (described in the preceding steps) to copy them? For arcs, it’s nice to have control over their number of sides, and drawing them from scratch is the only way to do that.

Follow these steps to accurately trace an arc from underlying CAD linework (see Figure 8-22): 

	
[image: 9781119617938-ma004] Draw an edge that’s perpendicular to one of the arc’s line segments, heading in the direction of the arc’s center point.

You can use SketchUp’s Perpendicular linear inference to help you draw a perpendicular edge. This is the first step in figuring out the precise location of the arc’s center point.


	
Repeat step 1 for another of the arc’s line segments, crossing your new edge over the one you just drew.

The point at which these two edges intersect is the center point.


	
[image: 9781119617938-ma006] Erase two of the edges that you just drew, leaving a small V that points to the arc’s center point.

Look at the third image in Figure 8-22 to see which two edges are being referred to.


[image: Schematic illustration of the Arc tool which lets the user to easily draw arcs with a given radius.] 
FIGURE 8-22: The Arc tool lets you easily draw arcs with a given radius.







	
[image: 9781119617938-ma044] Choose Draw ⇒ Arcs ⇒ Arc to activate the Arc tool.

What is now called 2 Point Arc used to be SketchUp’s only Arc tool; it works by first setting endpoints and then setting a bulge. The new(ish) Arc tool, which is called simply Arc, lets you start by defining a center point; this is much more useful for situations like the one you’re in now.


	
Click once to set the center point of your new arc.

This is, of course, at the tip of the V you drew in step 3.


	Complete the arc by clicking to set each of its endpoints.

	
(Optional) Change the number of edge segments in your new arc.

Before you move onto anything else, type the number of segments you want, followed by the letter s, and then press Enter. Most likely, you want more than the default 12 segments on arcs that represent major features in your design.










  

Chapter 9

3D Printing with SketchUp Models

IN THIS CHAPTER

[image: check] Understanding basic principles of 3D printing

[image: check] Knowing your 3D printers

[image: check] Dividing your model into layers

[image: check] Using SketchUp files for 3D printing

[image: check] Preparing a SketchUp model for 3D printing

[image: check] Going beyond basics with joints and motion



Seeing your masterpiece in SketchUp is cool. You can twist and turn and view it from every angle. But wouldn’t the world be so much cooler if you could hold your creation in your hands? This chapter talks about using a 3D printer to make your SketchUp model real.

To follow along with this chapter, you need a working understanding of SketchUp and its tools. We assume you’ve heard about 3D printers and are curious to find out more. We give you a look at 3D printing technology in general and touch briefly on the spectrum of 3D-printing scenarios, from home hobbyist desktop units to machines that can “print” a full-size multistory concrete building.

Most of this chapter discusses guidelines, methods, and tools to help you modify your SketchUp models to be 3D-printed. We also point out a few limitations of 3D printers and explain how you can work within them.

If you already own a 3D printer, we recommend SketchUp Pro, the desktop version. You’ll be able to generate more complex models in more interesting ways using extensions. The Web version is ideal for mastering (or trying out) 3D printing because it’s easy to make, edit, and prepare 3D-printable models.



Building Up a View of 3D Printing

It may sound like magic, but 3D printing is a process that uses the 3D information from your SketchUp model to build a physical version of that model in the real world. It’s science fiction come true. Star Trek called its version of a 3D printer the “matter replicator.”

3D printing got its start as the hot new technology of the mid-1970s — and spent 35 years stuck as the high-priced plaything of prototyping engineers and the lucky people who build fighter jets. That’s where it stayed until the first do-it-yourself desktop 3D printers appeared in 2009. Overnight, the cost of a 3D printer fell from $500,000 to $500. What was once the coveted technology of the chosen few is now found on the desk of any well-equipped designer, engineer, or model maker.

There are many different 3D printing technologies and manufacturers, but they all use the same basic underlying concept. In fact, it’s such a fundamentally simple process that it can be done using any generic printer.

Say what?

Yes. Pretty much any software that can produce a 3D object can also cut a cross-section view at any desired cutting-plane location. Chapter 11 covers how to do this in SketchUp.

The following steps describe the basic principle behind almost every 3D printer: 

	Start with a cutting plane just a couple of thousandths of an inch above the bottom of the model.

	Print the cross-section view.

	Cut the printed shape out of the paper.

	Move the cutting plane up a couple of thousandths of an inch.

	Print the cross-section view.

	Cut the printed shape out of the paper.

	Glue it on top of the previous cutout.

	Repeat steps 4 through 7 until you reach the top of the part.


Bingo! You have a physical 3D model of your computer model, sort of like assembling a loaf of bread slice by slice.

Before you complain about how long this method would take, remember this: Nobody promised it would be fast. Even real-world 3D printers can take several days to produce large parts because they all work on the same principle: Slice the computer model, print it, move up a bit, slice again, print it, and so on.



Knowing Your 3D Printers

3D printers fall into one of three main categories, with a few subcategories: 


	Fused deposition modeling

	Stereolithography

	Fused powder modeling

 
Fused deposition modeling (FDM)

FDM printers are the most widely available type of desktop 3D printer. They build objects using solid plastic fed through a fancy robotic nozzle that is similar to a hot-melt glue gun. FDM printers are inexpensive to buy, with desktop models ranging from $500 to $2,500. Printed parts are done the moment the printer is finished; there’s no secondary process needed to finish or strengthen the object. The parts that FDM printers make can be as strong as parts from injection molding, and they cost around 4 cents per cubic centimeter. On the downside, FDM 3D printers have limited maximum resolution and tend to have a lot of moving parts, which can affect their reliability.

FDM printers consume plastic filament as they build objects. Filament is drawn into the printer, heated, and then fused to form the object. Filament comes coiled on spools that look a bit like brightly colored string for a weed trimmer. These inexpensive spools are available online, and some large office supply stores are starting carry them as well.

The highest-end FDM machines feed metal wire such as steel or bronze through an arc-welder head, but they still work on the same principle as the plastic-fed machines.


 
Stereolithography (SLA)

SLA 3D printers represent one of the oldest 3D printing technologies. They use a laser to build solid parts in a vat of liquid resin, selectively hardening the resin layer by layer. Desktop SLA machines cost between $2,500 and $8,000, but you’ll hear ongoing speculation about a printer emerging at a price below $1,000. SLA offers superior printing resolution, which gives finished parts a glassy smooth surface. The machines are typically small and nearly silent, with only a few moving parts. Prints from an SLA machine typically cost around $0.15 per cubic centimeter and require some cleanup after printing, which can include such things as draining trapped pockets of liquid resin. Also, due to the resin’s toxicity, printed objects must be washed in isopropyl alcohol before being handled.

SLA’s consumable resin is an amazing bit of chemical engineering. It’s a liquid at room temperature until it’s exposed to intense ultraviolet light, which hardens the resin into a solid plastic. You should buy bottles of liquid resin from the maker of your 3D printer to ensure compatibility. Resin has a set shelf life and needs to be stored with some care; it can begin to harden if left in sunlight.

Resin-based inkjet printers are an expansion of SLA technology. They use an inkjet printhead to spray fine layers of an ultraviolet (UV)-sensitive resin, which is then hardened by a powerful UV light.


 
Fused powder modeling (FPM)

FPM machines fall into three general subcategories: 


	Selective laser sintering (SLS): Uses a laser to melt and fuse a finely powdered material, which can range from common plastics to exotic metals. SLS machines can reproduce fine detail without adding any supporting structure to the model.

	Inkjet, powder-based: Use a powder that is selectively hardened by liquid glue sprayed from an inkjet printhead. The glue can be colored and mixed; this is one of the few technologies that offers full-color 3D printing.

	Paper-based: Builds objects out of copy paper by gluing the sheets together then cutting away the excess. (Okay, paper isn’t a powder, so maybe it doesn’t seem like it belongs in the fused powder modeling category, but FPM is the closest fit.) The parts are immensely strong and can be treated like wood after printing. See, a standard printer CAN be used to do 3D printing.



[image: Tip] If you want an airtight hollow structure, FPM may not be for you because the airtight void can end up full of unfused material.
 

COMPARING 3D PRINTERS
 
Aside from the style of printing a printer does, you can compare 3D printers in terms of cost per cm3 (that is, cost per cubic centimeter of printed object) and minimum layer height. Cost per cm3 is the cost of one cubic centimeter of printed volume; it’s typically the number used when comparing the cost of one 3D printing technology to that of another. Minimum layer height is the thickness of one layer in the object. The smaller the height between layers, the smoother the surface of the finished object will look and feel, but the longer it will take to print.






Designing for Successful 3D Printing

There’s an old joke that says carving a statue of an elephant is easy; just get a big piece of marble and cut off anything that doesn’t look like an elephant. By this logic, 3D printing is the other way around; get a pile of raw material and stick together everything that does look like an elephant. This process is called additive manufacturing.

Now let’s move on to the bad news. Okay, it’s not really bad, it’s just a few things that you need to know about in order to 3D print successfully.
 
Building a model in layers

SketchUp’s world is an amazing place where you can rapidly build a 3D model while ignoring little things like the laws of physics. An object being 3D-printed, however, is subject to all the forces of the physical world, including that pesky omnipresent one, gravity. If you’re using an FDM machine, then new layers or portions of new layers can’t be printed floating in open space; they need to have something below them.

[image: Remember] The need to support each layer is the most important guideline to keep in mind while you’re designing objects for 3D printing. You can use either of two strategies to support new layers as you’re printing objects: 


	Use the 3D printer’s support-material function. This function automatically creates a secondary structural lattice around the part. The lattice holds up any layers or portions thereof that would otherwise be free-floating in space. Support material may be dissolvable after printing, or you may have to manually remove it with your fingers and tweezers, depending on your type of 3D printer. Either way, removing support material can become the most labor-intensive part of 3D printing; it also increases the amount of materials used and the time it takes to print the object.

	Design and print your parts in a way that limits the conditions that allow unsupported layers to exist. Smooth transitions and sweeping curves not only look awesome, but also can be easily printed without resorting to the use of support material.




 
Designing to avoid support material

With a little forethought, you can avoid needing to use support material by adhering to a few basic guidelines: 


	
Think about your part’s orientation. Orient the part so that it prints with the smallest number of overhangs. This may mean printing your object upside down or on its side. The inverted J in Figure 9-1 will quite happily print the green column from the bottom up, layer after layer, until it encounters the red section. Oops, gravity. Lying it on its side allows it to print without support material, and it will print much faster.

[image: Tip] Most 3D printers take the same amount of time to print each layer, no matter how much or how little is on it. Total print time, therefore, is based mostly on how many layers need to be printed. The upright part in Figure 9-1 would require 36 layers, whereas the reclining one needs only 6.

By the way, the layer thickness shown in Figure 9-1 is not to scale or is a very small part.


[image: Schematic illustration of reorienting a part which can make it print faster and leave little or no support material to clean up.] 
FIGURE 9-1: Reorienting a part can make it print faster and leave little or no support material to clean up.







	Try rethinking your angle. Most printers can print a slope between 45 and 60 degrees from vertical without using support material. Keep this limit in mind as you design. Chamfers and fillets are great for supporting features and smoothing out rough transitions. In Figure 9-2, a chamfer turns a part with an unsupported overhang into an easily printable part. As a bonus, fillets and chamfers make your part stronger by eliminating stress points.

[image: Schematic illustration of a chamfer which can turn an unprintable 90-degree angle in to a printable 45-degree one.] 
FIGURE 9-2: A chamfer can turn an unprintable 90-degree angle in to a printable 45-degree one.







	Consider breaking your object into multiple prints. The sphere in Figure 9-3 could be printed using support material, but it will print faster and with less cleanup if you split it in half and attach the two halves afterward. Later in the chapter, you learn about systems to make the parts lock together quickly, a technique that may be mandatory with FPM machines.

 



[image: Schematic illustration of a subdivided part which is faster and cleaner to print than a part printed all at once.] 
FIGURE 9-3: Often, a subdivided part is faster and cleaner to print than a part printed all at once.





Bridging

Bridging is a feature on FDM 3D printers that lets you print a structure across a gap without using support material. To bridge a gap, the structure being printed must be parallel to the build platform and have a secure point of attachment on either side, as with the top of the door frame shown in Figure 9-4, and can’t be too wide. The printer attaches plastic to one side of the gap and stretches a line across to the other side. The process is repeated until the gap is filled with side-by-side strings. Future layers are then printed on top as usual.





[image: Schematic illustration of a door frame a bridge which is 3D-printed.] 
FIGURE 9-4: When is a door frame a bridge? When it’s 3D-printed.










Preparing a SketchUp Model for 3D Printing

The longer you work on a SketchUp model, the more it tends to fill with illogical intersections, free-floating cantilevers, and other quick shortcuts. When you’re making an image or walkthrough, these are minor trade-offs that help get a big job done quickly. Drawing something that looks right on the outside in SketchUp doesn’t necessarily mean it can be 3D-printed with one click of a button. A 3D printer can’t interpret that mishmash of geometry to guess what you were really thinking.

In this section, you discover how to clean up that SketchUp madness and make it into a 3D printable object. The cleanup process uses tools discussed in earlier chapters, but you use the tools in different ways from those described previously.

Cleaning up a messy SketchUp model can look like a daunting task when you start. Remind yourself that it’s just like eating an elephant: Divide the job into manageable chunks and work on them one at a time, even if the trunk can be a bit chewy.

[image: Remember] Before you start cleaning up geometry to make your model 3D-printable, it’s a good idea to save a separate copy of your SketchUp file, just to be safe.
 
Peeking inside a model

Although you can use the Section Plane tool to create sectional views through your model, this awesome tool has another use: It can show you what’s going on inside your model’s geometry. 3D printers see a SketchUp model as a series of 2D horizontal slices. Figure 9-5 moves the Section Plane through the model horizontally to show what the 3D printer is going to see.



[image: Snapshot of using a section plane to look at all overlapping parts that make up the model.] 
FIGURE 9-5: Using a section plane to look at all overlapping parts that make up your model.






To get a watertight solid object, all groups need to be combined into one, and all that extraneous geometry has to be eliminated from the model. Chapter 11 discusses the Section Plane tool in detail.


 
Knowing what makes a solid model

To 3D-print your parts successfully, they need to be solid objects, or as close to solid as possible. No missing or extra faces, overlapping sections, or extraneous bits are allowed. Your SketchUp model needs to describe all aspects of the outer surface of the shape. For example, to print an egg, a SketchUp model would need to describe 100 percent of the outside of the egg’s shell but none of the yolk. That’s not as simple as it sounds.

A solid model that’s 3D-printable meets the following criteria: 


	It’s airtight. All SketchUp models consist of infinitesimally thin surfaces joined together. Think of a balloon as the surface model for a bowling ball. To 3D-print a bowling ball, the balloon can’t leak. Make a small hole in it with a pin, and you can’t have a 3D print.

	The model walls have a thickness. Zero thickness equals zero printing. A SketchUp wall that is a single face has a thickness of zero and will not print. You need to make sure all the walls have some thickness by having a second face offset from the first.

	The model has only an outer surface. In SketchUp, you can create a model quickly (in the abstract, anyway) by pushing parts through each other and building revisions on top of old geometry. To your 3D printer, however, such models are an illogical mess that would make M.C. Escher cry. Your 3D printer doesn’t stand a chance. You need to clean up everything so that only the outer surface remains. Fortunately, SketchUp tools and extensions discussed later in this chapter in the following section can help. If you do want to 3D-print a hollow object, then you need an inner surface, offset from the outer one. To 3D-print a hollow cube, for instance, you have to draw a smaller 3D cube positioned inside a larger cube. Most printers interpret the space between the two cubes as wall thickness, and the space inside the inner cube as a void.

	
Groups and components are merged. Chapter 5 explains groups and components, and how to use them to keep your SketchUp model organized as you work. Groups and components are great for keeping parts from sticking together as you work, but to make your SketchUp model a solid shell that can be 3D-printed, you need to merge everything.

[image: Tip] Before you start exploding things and sticking them together, spend a moment thinking about how you want your actual 3D-printed model to work. For most projects, you need to merge all your groups and components into one printable object before exporting your model from SketchUp. For larger projects, think about assembling the blocks into sections that you can 3D-print and attach to one another later.




The upshot is that 3D printers aren’t very smart. If you make them guess what your part should look like, they usually guess wrong. Figure 9-6 is a testament to the carnage.
 



[image: Schematic illustration of the poor print which never stood a chance.] 
FIGURE 9-6: This poor print never stood a chance.





Using Solid Tools to combine groups

Chapter 6 explains how to use SketchUp Solid Tools to perform Boolean operations. Solid Tools are great for unifying groups made up of simple solid parts. They can save significant time. Unfortunately, complex shapes cause the Solid Tools to act unexpectedly — and, after multiple iterations, to break down.







WHAT’S WRONG WITH SOLID TOOLS?
 
You may have been looking at the Outer Shell button in the Solid Tools menu and thinking, “Wow, making this into one outer shell is going to be easy.” So, you decided to save your work, select your whole model, and click Outer Shell. Oops. (Come back when you’re done screaming.)

In the discussion of Solid Tools in Chapter 6, you find out that they are also called Boolean operations. Boolean operations started out as computer programming tools that help sort and manipulate data. In the early days of computer graphics, programmers used Boolean operations to work directly with the data that makes up 3D models. Boolean operations still exist in every piece of 3D modeling software today. If you take a class in 3D modeling, Boolean operations are one of the first things you’ll learn because they are the only way of making complex models from simpler subcomponents.

The problem is that Boolean operations are blunt instruments. They work within a narrowly defined set of parameters and are notorious for the way they indifferently modify geometry. After a few uses, the damage caused by solid tools start to compound, and the model becomes too garbled for the Boolean to interpret again. Basically, after being confounded by the sum total of its own mistakes, it gives up in failure. Outer Shell is trying to run a whole series of Boolean operations at once, and if your model is made up of anything except simple shapes, those operations won’t succeed.


In Figure 9-7, Solid Tools had no problem intersecting several simple cubes together, but adding a complex shape to the object caused the tools to break down. The accompanying sidebar takes a closer look at why this happens.
 



[image: Schematic illustration of Booleans which are great for simple things.] 
FIGURE 9-7: Booleans are great for simple things. But don’t rely on them for complex cleanup.





CleanUp3 and Solid Inspector2

Two tools from the SketchUp Extension Warehouse are essential for 3D printing: CleanUp3 and Solid Inspector2, both created by Thomas Thomassen. CleanUp3 and Solid Inspector2 are available in the desktop version. (Web: Solid Inspector2 is available as a utility within SketchUp for Web with a paid subscription or as part of SketchUp for Schools.)




CleanUp3 checks and simplifies the geometry of your SketchUp model. It combines multiple faces, eliminates extraneous data, and erases any lines that don’t make a face. Two of the most useful CleanUp3 options are Erase Duplicate Faces and Repair Split Edges, which can be enabled in the CleanUp3 menu. Duplicate faces and split edges are errors that inevitably appear in your model as you work in SketchUp, and they drive 3D printers nuts. Both errors are hard to recognize and repair manually.


CleanUp3 is also great at simplifying STL files (3D-printable files) you import into SketchUp. In Figure 9-8, which shows the triangulated data you get from an imported STL file, the faces have been broken into hundreds of triangles. By removing that triangulation, CleanUp3 makes files downloaded from 3D printing communities (such as Thingiverse at https://www.thingiverse.com) easier to edit in SketchUp.


[image: Schematic illustration of an imported STL file, before and after running CleanUp3.] 
FIGURE 9-8: An imported STL file, before and after running CleanUp3.






[image: Tip] Solid Inspector finds and highlights problems that are preventing your model from being a solid shell, and we can’t overemphasize its usefulness. It highlights problem areas and helps you automatically move from one error to next, making repairs much faster (see Figure 9-9). It’s a tool that everyone using SketchUp for 3D printing should have. While using Solid Inspector2, we recommend making heavy use of X-ray and hidden geometry display settings, both available from the View menu in SketchUp Pro, and which you can find via Search in SketchUp for Web.

[image: Remember] As you work on your model, get in the habit of running CleanUp3 periodically. Run Solid Inspector2 before you export from SketchUp to 3D-print. It will catch any errors that would cause the print to fail.




[image: Schematic illustration of a solid inspector which is great at finding problems that need a quick fix.] 
FIGURE 9-9: Solid Inspector is great at finding problems that need a quick fix.







 
Combining groups with Intersect Faces

An alternative way to assemble your groups into one object is to use the Intersect Faces command, which we introduce in Chapter 4. For 3D printing, Intersect Faces can eliminate overlapping geometry and leave behind a solid object. You can use Intersect Faces on very complex objects and groups that aren’t already solid.

In a complex model, isolate and work on one small part of the SketchUp model at a time, making each section into one solid part. Repeat the process on those sections until you have one solid model. The following steps outline this process in more detail: 

	
Select the groups you want to combine and group them.

Your original groups are now subgroups that exist together inside a new group.


	
Right-click the selected groups from step 1 and select Intersect Faces (with Model).

Doing so opens your new group and selects all the subgroups, drawing lines at all the places that groups intersect. These new lines of intersection exist outside the subgroups and aren’t stuck to anything yet, as shown in Figure 9-10.


	Select the lines of intersection and copy them by pressing Ctrl+C.

	
Open each of the subgroups and paste the lines of intersection into them, using Edit ⇒ Paste in Place. (Web: Right-click ⇒ Paste in Place.)

Figure 9-10 shows the procedure.


	
Open each subgroup and erase all the areas of overlap beyond the lines of intersection.

Work deliberately, moving back and forth between the subgroups to make sure you’re erasing the right areas.


	
Back in the main group, select all the subgroups, right-click the selection, and choose Explode on the menu that appears.

You end up with one outer shell of an object in its own group. Figure 9-10 shows this result.


	
Consult the Entity Info utility tray to confirm your resulting group is a solid.

If necessary, run CleanUp on the new part and use Solid Inspector to check for any accidental holes.

[image: Tip] Individual faces and short line segments can get lost during this process. You may need to make minor touch-ups with the Line tool.





[image: Schematic illustration of the erase overlapping geometry to create an outer shell.] 
FIGURE 9-10: Erase overlapping geometry to create an outer shell.








Checking a model’s normals

From a highly technical computer-science perspective, every face in your model has two sides: an inside and an outside. The two sides are set apart by a bit of data called the face’s normal.

SketchUp is smart enough that it doesn’t matter how the normals (also known as the front and back) are oriented; both sides are treated the same. 3D printers aren’t that clever; they need to have all the normals oriented so the outsides are pointing out and the insides are pointing in.

To check your model’s normals, you need to look at it styled with SketchUp’s default texture. Choose View ⇒ Face Style ⇒ Monochrome to hide any colors or textures you’ve added to the model and see the default material. (Web: Search for Monochrome.)

Any faces that are shaded the default blue have reversed normals. These faces need to be corrected, or the 3D printer thinks they’re missing. You have two options for correcting faces: 


	To correct a single face, right-click the face and select Reverse Faces from the menu that appears.

	To correct several misaligned faces, right-click one of the faces that is white and select Orient Faces. Doing so flips all the faces in the model to match the view shown in Figure 9-11.



[image: Tip] If the Orient Faces tool causes everything to flip randomly, it’s a sign that you have extraneous faces inside your model. Use the Section Plane tool to look inside, find the face, and erase it.


[image: Snapshots of a correct normal image.] 
FIGURE 9-11: A correct normal is a happy normal.







 
Size matters!

Every 3D printer has a minimum and maximum size of object it can build, as shown in Figure 9-12. These sizes are usually set by the size of the tool printing the material and by the overall size of the printer. To build something bigger, you have to get creative. To build something smaller, you need a more expensive 3D printer.



[image: Snapshot of two images which is too big and too small.] 
FIGURE 9-12: Too big and too small. There is something there on the right; it’s just very small.






Too small to print

In the SketchUp world, you can design a skyscraper small enough to fit on the head of a pin, but a 3D printer can’t print it. Every 3D printer has a minimum size for what it can build; anything smaller than that won’t be printed. You find these values listed as Minimum Feature Size and Minimum Wall Thickness. Feature Size and Wall Thickness can turn into stumbling blocks when you’re trying to 3D-print a SketchUp model that was constructed at full size and then scaled down. 


	Minimum Wall Thickness tells you how thin a freestanding piece of geometry can be and still be printed. That thickness is typically between 1.0mm and 0.5mm.

	Minimum Feature Size is the smallest size that a feature can be on the surface of the object that will be printed. It’s typically between 0.7mm and 0.2mm.



If you’re modeling a small object for 3D printing, create the model in small units, such as millimeters, from the beginning. To set or change the default units in your SketchUp model template, choose Window ⇒ Preferences (Mac: SketchUp ⇒ Preferences) and select a template that uses millimeters. You can also adjust the default units in the Model Info window by choosing Window ⇒ Model Info and selecting the Units option on the left (Web: Change the units of your model in the Model Info panel, near the bottom of the utility tray on the right).


 
Too big to print

The biggest object you can 3D-print at one time is set by the printer’s build volume, which is the physical space where the printing occurs. If your model won’t fit in the build volume, you have to either scale your object down, or print it in parts. The next section talks about how to split up a model so you can print it in parts.

[image: Remember] Although the maximum size of any single part is limited by the size of your 3D printer, the size of what you can 3D-print is limited only by your creativity and patience. A man in New Zealand is 3D-printing an Aston Martin, one 6-inch cube at a time. (He obviously has too much time on his hands.)

Here are some handy hints for making best use of build volume: 


	The build volume, or envelope, is given by manufacturers as measurements of X, Y, Z. X and Y are the width and depth (SketchUp’s red and green axes) of the build surface; Z (blue) is the maximum height.

	It’s helpful to create a representation of your 3D printer’s maximum build volume in your SketchUp model. Make a translucent block representing the maximum build volume and check to see whether your SketchUp model or its components will fit inside that volume.

	A 3D printer’s build platform is much longer diagonally than it is on any one side. To take advantage of the extra length, rotate long parts so they stay inside the build volume.

	Printing large objects comes with its own issues and complexities. Large objects are more prone to failure and breakdowns. Make sure you’re comfortable with your 3D printer before you start printing your own sports car.






 
Breaking your model into arts

As you do more 3D printing with SketchUp, you’ll run into the need to split your model into parts. Some ideas are just too big to fit into your 3D printer’s build volume. Other ideas want to be 3D-printed in a rainbow of colored plastic. And sometimes a model just needs to be split to make it easy to print.
 
Where to cut

When subdividing a SketchUp model into printable parts, start by thinking about what you’re going to do with the seams. If you’re going to sand, paint, and finish the model, have at it and cut wherever you want. But sanding and finishing is a huge amount of work, especially if you’ve never done it before. It’s much easier to make your cuts and seams look like they’re intentional parts of the model.

[image: Remember] For a seam to look intentional, it has to work with the logic of the object. Every object has its own logic, an underlying order that informs how it’s shaped and structured. For example, in Figure 9-13, the object is symmetrical left and right. A seam on the axis of symmetry is less objectionable than one that runs randomly in another direction. By following a line that’s already conceptually present in the object, the seam reinforces what the eye already perceives.



[image: Schematic illustration of the line which is far less objectionable when it’s well thought out.] 
FIGURE 9-13: The line is far less objectionable when it’s well thought out.






Another good place to hide a cut is at a change in elevation, curvature, or color, as shown in Figure 9-14. Placing a seam where the surface of a part is already interrupted or in transition will make it far less noticeable. This is the strategy most commonly employed for injection-molding parts. Pick up something around you that’s made of plastic and find the seams where the parts come together. If you can imitate that type of seam, people will readily accept that your object is a real thing. It will feel correct among manufactured things in our injection-molded world, and you’ll fool people into thinking your 3D-printed part came from a factory somewhere.

For very large constructions, the only option may be to establish a grid and cut into build-volume-size blocks. Sanding, finishing, and painting can work well on large parts, but expect to spend substantial time doing it right. If you’ve spent the energy to build something that big, it’s worth the extra time to make it amazing.


[image: Schematic illustration of a tape recorder.] 
FIGURE 9-14: Do the seams look out of place?







 
How to cut

Cutting a model into parts is very similar to using the Intersect Faces tool to combine groups (discussed earlier in the chapter). You use a piece of geometry as a cutter that will be intersected with the larger object and become the new edges of the cut.

If your model is fairly simple and you have SketchUp Pro, you can use the Solid Tools to short-circuit this process. Create a solid block as a cutting object and use the Solid Tools ⇒ Trim command. Remember to run CleanUp3 and Solid Inspector2 on the new parts when you’re done. For more complex models, use the Intersect Faces method: 

	
Select the group you want to cut, and make a new group around it.

The original group becomes a subgroup.


	
Working inside the new group, create geometry in the shape of the cut you want to make.

Work on top of the subgroup, so you place the cut correctly, as shown in Figure 9-15.


	When you’re done placing cuts, make the new geometry its own group.

	
Select the Cutter object and choose Edit ⇒ Intersect Faces with Context (or choose Edit from the shortcut menu).

Doing so draws a line at every place where groups touch. These new lines of intersection exist outside the subgroups and aren’t stuck to anything yet, as shown in Figure 9-16.



[image: Snapshot of the cutter object which can be a single plane and it’s going to become part of the solid object.] 
FIGURE 9-15: The cutter object can be a single plane; it’s going to become part of the solid object.







[image: Snapshot of the lines of intersection which is  created between the two groups.] 
FIGURE 9-16: Lines of intersection created between the two groups.








	
Inside each group, use Explode to stick the intersection lines, cutting object, and base object together.

The surface of the cutting object becomes the sides of the new part.


	Move back out to the master group and make as many copies of that group as the number of parts you’re dividing it into (see Figure 9-17).







[image: Snapshot of making one copy of the group for each part of your model.] 
FIGURE 9-17: Make one copy of the group for each part of your model.







	
In each copy, open the group for editing; erase everything you don’t need in that part; and do the same in the other parts.

Just make sure you don’t erase what the object needs to do its job. If you wind up with a missing face, undo your erasing, select everything in the group, and then right-click and select Intersect with Selection.


	Run CleanUp3 on the new parts. and use Solid Inspector to check for any accidental holes.

	Position the parts together to make sure everything lines up as expected, as shown in Figure 9-18.




[image: Schematic illustration of the model.] 
FIGURE 9-18: It still fits!












Exporting Your SketchUp File

After you’ve cleaned up your SketchUp model and you’re ready to print it, you have to get your 3D model out of SketchUp and into your 3D printer’s control software. Before your 3D printer can open your model, you have to export the model in either the STL or OBJ file format. The STL (derived from STereoLithography) file format is the de facto standard in the 3D printing world. Most 3D modeling software can export STL files, and most 3D printer support software can import them. The word most is used in case someone manages to find an exception.

To export an STL file from SketchUp, select File ⇒ Export ⇒ 3D Model; then select Stereolithography File from the Save As Type drop list (Web: select File ⇒ Export ⇒ STL).
 
3D printing services

3D printing services offer access to professional-level machines on a pay-per-print basis. Cost is based on volume of material printed, and you receive your printed object by mail in a few working days. Each company offers detailed instructions on minimum part sizes, wall thicknesses, and feature size. Pay attention to these rules. The services know what their machines can do, and you don’t want to be stuck waiting a week for a part that didn’t come out right.
 

CAN I 3D-PRINT IN METAL?
 
Yes, 3D printers that print in metal exist. But unless you live in a hollowed-out volcano and race fighter jets in your free time, you probably can’t afford to use them. Based on selective laser sintering (SLS) technology, these printers use an electron laser to fuse powdered metals in a hard vacuum. The parts they make are fantastically strong and complex, surpassing anything possible with traditional manufacturing technology. Current uses for SLS in manufacturing include custom medical implants, military jet engines, and spacecraft components. So if cost is no object, you can 3D-print in metal.

If you need your 3D-printed part made in metal, use a 3D printing service bureau or take a part printed with an FDM or SLA printer to a foundry. At the foundry, a process called a burnout makes a cast-metal version of the part.

Recent developments include using a numerically controlled arc welder to lay down repeated weld beads to build up things like a full-size bronze tugboat propeller and a stainless-steel pedestrian bridge.


Two examples of 3D printing services are Shapeways (https://www.shapeways.com) and Ponoko (https://www.ponoko.com).
 




Using Your 3D Printer

Your new 3D printer’s manufacturer will have documentation to help you use the printer and the software, so we don’t go into detail here about using specific machines. The following sections touch on a few general concepts of 3D printing that are often not explained well.
 
Print early, print often

Desktop 3D printing is cheap. Really, unbelievably, remarkably cheap. Cost for running a typical desktop 3D printer is about 60 cents an hour. Once you’ve started the printer, it doesn’t need any more input from you, which frees you to continue working on your design. With such an amazing tool that’s so cheap to use, don’t be afraid to print constantly. Print your SketchUp model over and over as you improve it; doing so helps you develop it.

3D printers are built to print; they don’t like to stand idle. Print more often! You’ll become an old hand at using your machine and get to see your design as it evolves in real time.

[image: Tip] Test prints are great for catching errors and mistakes. Test prints are also a great way to document the evolution of a design. It’s a good idea to save a version of your SketchUp model that corresponds to each file you 3D-print. If the print has an unexpected error, you can look back at that file and understand what went wrong without having to dig too deeply into the version you’ve continued to work on. Keep some general points in mind: 


	Test prints that use your 3D printer’s Low Quality setting will print faster but with a rougher surface.

	Save test prints as the project goes on. They’re a great way to show progress, and clients love to see a physical expression of the work being done.

	Many 3D-printing plastics are recyclable or biodegradable. When you’re done with your models made of this stuff, toss them in the recycling bin or on the compost heap.




 
Inside your model

3D-printed parts are unique in the world of fabrication. After you’ve created the outside of your part, you also get to decide what happens on its inside. Usually you let the 3D printer automatically handle the inside of the part, filling it with automatically generated structure. It’s also possible to model a part’s interior structure to change how it behaves. For example, you might want to hollow out the center of a part to make it lighter or add space for internal components. Some possible variations include 


	Internal voids: On SLS and stereolithography machines, a common cost-saving strategy is to build parts as a thin shell with an empty interior. The resulting parts have compromised structural strength but are printed using as little material as possible. Be sure to include drain holes so the unhardened material you saved can escape from the part.

	Part density: FDM printers automatically generate a structure to fill the interior of their prints. The density of the structure is controlled by a setting called fill, which is stated as a percentage. Parts with 100 percent fill will be solid plastic all the way through and are as strong as injection-molded parts. Typically, FDM printers default to building parts at 10 percent fill, meaning that 10 percent of the interior is filled with plastic. Higher fill percentage means more plastic used — and longer print times. Generally speaking, anything over 40 percent is a waste of time and plastic.

	Outer wall thickness: Another FDM printer setting, this deals with the amount of material put into the walls of the object before starting the Infill. Look for a setting called Shells, which is the number of layers of plastic the printer will use to make the outside of the model. If you're having trouble with parts crushing, increase the number of Shells; otherwise leave this setting alone.

	Flexibility: Flexible materials are available on most 3D printers, usually by using a special flexible plastic filament. You can also make structures flexible by making them very thin with 0 percent infill.







Going beyond Basic 3D Printing

The more you use your 3D printer, the more you may find it affecting your SketchUp designs. Don’t be surprised if your designs become a bit more ambitious and mechanically complex. This section of the chapter outlines some possible directions and factors to watch out for.
 
Designing parts that connect

So you cut your model into parts. Now you need a way to get it to all stay together after it’s printed. In this section, you discover different strategies and features, mechanical and otherwise, that you can build into your model for attaching its parts together.
 
Tolerance and clearance

Before we get into a discussion about mechanical connections, you need to understand two more of those pesky realities that crop up when you move out of SketchUp’s idealized environment: tolerance and clearance. 


	Tolerance is the difference between the measurement of your part in SketchUp and the measurement of the part produced by your 3D printer. If you draw a 10mm cube in SketchUp and 3D-print it, none of the measurements of the printed cube will be exactly 10mm. The differences are small — just a few tenths of a millimeter more or less — but they can cause problems if your 3D-printed parts have to connect to parts that already exist in the real world. The 3D printer’s manufacturer provides a number for the machine’s tolerance as a plus or minus value, usually something like pm0.05mm. This is the maximum variation for that machine, and you should be aware of it as you work.

	Clearance is the extra space you need for parts to slide past one another. If you try to install a 10mm peg in a 10mm hole, you’re in for a bit of a surprise when the two won’t go together. The peg and hole can fit perfectly in SketchUp, but that’s not what’s going to happen in the real world where you have to contend with friction. The surface of the peg is so much like the surface of the hole that the friction between them will keep the peg from ever going in if the fit is too exact. You need to add a small amount of space called clearance so the two parts can slide past each other. How much clearance you use depends on how the part needs to move. A spinning shaft, for example, needs more clearance than a simple snap fitting.



You’ll come to an inherent understanding of clearance and tolerance as you do more designing in SketchUp for 3D printing. As you use your 3D printer, you’ll be able to find values that work well with your equipment.

[image: Tip] As a starting point, add 0.2mm of clearance to all holes and 0.5mm of clearance to any points of relative movement.


 
Glue

Glue, shown in Figure 9-19, is the universal way to stick something to something else. Unfortunately, it’s also the weakest and most unreliable method. Glue joints in plastics have very little strength and will tend to break under stress, in response to temperature change, or if you look at them funny. If your part is meant to be anything more than a visual model, use one of the other attachment systems. 


	The plastics used in 3D printers — ABS, PLA, PVA, nylon, and PETT — all require special glues to bond. These glues are available, but must be ordered from an online retailer.

	Biodegradable starch plastics such as PLA have a crystalline structure that doesn't work well with liquid superglue. The glue tends to stay liquid and migrate unexpectedly across the surface of the part.

	When in doubt, use epoxy. It’s messy stuff but will stick to pretty much anything.

[image: Photo depicts the proxy which  works cosmetically.] 
FIGURE 9-19: Works cosmetically, but don’t expect much durability unless you use epoxy.







	There are no glues that will stick to the flexible materials that are available for 3D printers. To attach parts made of that stuff, you’ll need to look into a process called thermal welding, which is way outside the scope of this book.



We knew a person who invented the universal glue. It would stick anything to anything. It was a dismal failure: Nobody could get the lid off the bottle.


 
Snap fittings

Snap fittings are an awesome way to take advantage of your 3D printer. Properly designed, they’ll let you pop your model together as soon as the parts come off the printer. Snap fittings can also be removable, so you can change out various parts of your model as the design evolves.

In SketchUp, you create snap fittings like those shown in Figure 9-20 by following two general steps: 

	Create the tongue with the Line and Push/Pull tools.

	Create a matching capture point on the opposing part.




[image: Photo depicts a fit joint which is great for reusable connections.] 
FIGURE 9-20: A snap fit joint is great for reusable connections.





[image: Remember] As you create your snap fittings, keep these points in mind: 


	Be sure to leave enough space for the tongue to bend backward as it slides into place.

	Include a clearance of between 0.2mm and 0.5mm, depending on how tight you need the joint to be.

	Always position snap fittings so they print horizontal to the 3D printer’s build platform. Snap fittings printed in the Z direction, perpendicular to the platform, tend to break off.



	If you want your snap fitting to be reopenable, make sure that you provide a way for the tongue to disengage from the capture. This can either be a ramp in the geometry that forces the tongue backward as you pull on the joint, or an access point that lets you release the tongue manually.

	Don’t make the tongue too thick. It has to bend for the joint to go together.




 
Press fit

A press fit is when two parts are designed with very little clearance between them. When the parts are forcibly pressed together, friction keeps the joint together with no additional hardware or glue.

To make a press fit like the one shown in Figure 9-21, use the Offset tool to create an outer lip on one side of the connection and an inner lip on the other side. Include a clearance of 0.2mm or less between parts, so you can still assemble them. Keep a few points in mind about press fits: 


	For a press fit to work well, it needs to be a tight connection. You might need a small hammer, large clamp, or your whole body weight to press the parts together.

	A press fit is usually a one-way connection. After you put it together, don’t expect to ever get it back apart.

	Press fits don’t scale up well. Always design them at the size at which they’ll be printed.

	The tight clearance of a press fit can make it difficult to get started. Running a hobby knife or deburring tool around the edge of the hole will widen that area a bit and help you get the parts together.




[image: Photo depicts a press fit is an easy connection to draw in SketchUp.] 
FIGURE 9-21: A press fit is an easy connection to draw in SketchUp.








Bolts, screws, and hardware

The strongest connection you can make between 3D-printed parts is one held together with metal hardware. These connections are great for things that are more than just prototypes — for example, parts for robots or mechanisms.

When integrating hardware into your design, include the hardware in your SketchUp model. Take measurements of the parts you’re planning to use and model them in SketchUp. After you make these components, save them to the component library so that you can use them again with one click. Keep these points in mind: 


	Remember to include enough clearance in your holes for the hardware to be installed.

	If you’re using bolts or screws and don’t want to include a matching nut, a trick is to slightly undersize the holes. The threads of the bolt will cut into the excess plastic and hold it firmly in place, as shown in Figure 9-22. Better yet, standard self-tapping screws designed specifically for cutting their own threads in plastic are readily available.

	Online hardware suppliers like McMaster Carr and Amazon Supply stock every fastener known to the human race. If your local hardware store doesn't have what you're looking for, these online stores will have it.

 




Testing your model’s moving parts

Whatever connection system you are using, always test it first. Before you start printing a giant project, build a small version of the attachment. It takes only a few minutes to design and 3D-print and will give you a chance to make sure the joint works properly. Nothing is worse than modeling a system of joints and then discovering they don't fit together properly.


[image: Photo depicts an exposed bolt.] 
FIGURE 9-22: Nothing says strength like an exposed bolt.










Designing Things That Move

3D-printing something you’ve designed in SketchUp is cool. 3D-printing something that moves is even cooler. This section focuses on a few features you can include to make your creations more than just interestingly shaped hunks of immobile plastic.
 
Captive joints

A captive joint is a moveable connection that comes out of your 3D printer already assembled and working. Captive joints tend to be mechanically simple hinges, ball joints, and chain links. Their simplicity is their power. A 3D printer can quickly build objects with hundreds of captive joints that would take days to construct by hand. Poseable action figures, clothing, and the chain mail in Figure 9-23 are examples of simple captive joints assembled into complex structures.

Creating a captive joint requires trial and error. You’ll have to experiment to get the right combination of clearances and shapes. Keep these principles in mind while you work on captive joints: 


	Use components when building structures with captive joints; they let you automatically modify all the joints at once as you work.

	How you design captive joints depends on the specific 3D printing technology you’re using. SLS-based 3D printers can build captive joints that are a few millimeters across. FDM printers can make fantastically strong joints, but the printed objects need to be much bigger.

	A structure is only as strong as its weakest part. Don’t make a joint so fine that it falls apart in your hands.

	Test print parts of your structure as you work. Remember, 3D printing is cheap, and with captive joints, you're pushing the limits of the technology. Test objects will help you check your work and keep your sanity.




[image: Schematic illustration and photo of a captive joints which bring the power of multiplication to life.] 
FIGURE 9-23: Captive joints bring the power of multiplication to life.







 
Pins

Pins are small, round snap fittings that are pressed into place to make a connection. They can be a versatile replacement for hardware. In Figure 9-24, a single pin acts as a point of rotation, and two or more will hold parts firmly together.



[image: Schematic illustration and photo of a system of pin joints which is used to make a simple toy.] 
FIGURE 9-24: A system of pin joints used to make a simple toy.






Pins are like bolts, except you get to make them in exactly the size and shape you need. You can also print more when you run out. 


	When designing your pins, give them one flat side. The flat side gives you a way to build the pins without using support material — while keeping the tongues horizontal to the build platform. This process also keeps finished pins from rolling off your desk.

	Make your pins into components so you can easily modify all of them at once if you need to.

	When designing a project with pin joints, make an effort to standardize around a small number of pin sizes. Standardization helps keep things tidy and simplifies assembly.




 
Gears

Gears are great for creating complex motions or transferring movement through a mechanism. That is probably the most understated description of the deepest rabbit hole of the industrial age. Gears are in every mechanical device you can imagine. They have existed in some form or other since before recorded history, and are the basis for an incalculable number of clever devices that make everyday life possible.

Making gears is fun and inspires lots of folks to start experimenting with 3D printing. Figure 9-25 shows a simple gear system that can become so much more. To help you get started, here a few basic principles for making gears: 


	Gears need to have clearance between their surfaces to work properly. Gears that are too perfect a fit will bind up. Include a clearance at both the point of rotation and between the teeth of the gear and the teeth of its mate.

	A SketchUp extension called Involute Gears automates the process of making gears. The extension’s creator hasn’t made it available in the SketchUp Extension Warehouse, so you’ll need to locate it by searching sketchup gear plugin through a search engine.

	Creating optimized gears from scratch is a technical art form that has fallen out of practice. If you want to learn more about designing gears, I recommend getting a copy of Machinery’s Handbook (Industrial Press). After more than a century in print (it was first published in 1914 and is still updated regularly), this book is the gold standard for anything machinery-related.

 



[image: Schematic illustration and photo  of welcome to the New Industrial Revolution.] 
FIGURE 9-25: Welcome to the New Industrial Revolution. Time to gear up.





Assemblies

A cool feature of 3D printing is that it makes it possible to build things that cannot be made any other way. Assemblies in particular fall into this category. The two-piece assembly shown in Figure 9-26 can be printed in one single run. The collar can be slid back and forth but cannot be removed from the spool. A practical use for an assembly would be to have a child’s toy with free-turning wheels that can’t be removed from their axles. When you design this type of application, just make sure you model the parts with enough running clearance, meaning the hole in the wheel must be bigger than the diameter of the axle so the wheel can turn freely.






[image: Schematic illustration of an impossible assembly.] 
FIGURE 9-26: An impossible assembly.











    

Part 3

Viewing Your Model in Different Ways

IN THIS PART …

Customize the look and feel of a model by applying and adjusting styles.

Create realistic shadow studies that reflect the location, day, and time.

Set a model up for presentation with first-person 3D walkthroughs.

Control visibility of objects and save views of your model as scenes that you can capture as 2D images.

Use section planes to peek inside a model and derive plan or elevation drawings.






Chapter 10

Working with Styles and Shadows

IN THIS CHAPTER

[image: check] Giving your model some style

[image: check] Editing, saving, and sharing styles

[image: check] Finding out about the Shadows panel

[image: check] Using shadows to make models look better

[image: check] Displaying and studying accurate shadows



SketchUp is a very capable tool for presenting the stuff you build. Deciding how your models should look — loose and sketchy, quasi-photorealistic, or anything in between — can be lots of fun, and making a few good decisions can help your models communicate what they’re supposed to.

The first half of this chapter is about styles. If you’re the sort of person who likes to draw, you’re in for a treat. If you can’t draw a straight line with a ruler, you’re in for an even bigger treat. SketchUp styles are all about deciding how your geometry — all your faces and edges — will actually look.

SketchUp’s Shadows feature is an awesome tool for presenting models. Displaying shadows is an easy operation; it’s a matter of clicking a button. When you add shadows to your model views, they look more realistic, more accurate, more readable, and … well, more delicious. You’ll see what we mean.



Styling Your Model’s Appearance

In SketchUp, a style is a collection of settings that control how your model’s edges, faces, and background appear. To change a model’s whole look, all you need to do is apply a different style with one click. Trust us: You will blink twice the first time you try this out. Figure 10-1 shows four different styles applied to the same model of a house.



[image: Photos depict the styles to apply on the model.] 
FIGURE 10-1: Use styles to make your model look any way you want.






If you have a paid version of SketchUp you can customize styles, which is a little more work than simply applying a style to a model, but it’s arguably more gratifying. This chapter offers guidelines for using styles and explains how to apply, edit, create, and share styles.
 
Choosing how and where to apply styles

Styles are endless. With a million permutations of dozens of settings, you can spend all day fiddling with the way your model looks. But you don’t have all day, so keep one question in mind: Does a particular style setting help your model say what you want it to say? Focus on what’s important. Styles are cool, no doubt, but making them useful is the key to keeping them under control.

[image: Remember] To help you make smart decisions about using SketchUp styles, consider at least two factors when you’re styling your model: 


	Your model’s level of completeness: Reserve sketchy styles for models that are still evolving. The message that a sketchy style sends is “This isn’t permanent/I’m open to suggestions/all this can change if it has to.” As a design gets closer to its final form, styles can make your model appear less rough and more polished. In this way, styles can communicate how much input an audience can have and what decisions still need to be made.

	How much your audience knows about design: An architecture-school jury and a non-designer client who’s building a house for the first time perceive styles differently. Design professionals are more experienced at understanding 3D objects from 2D representations, so they don’t need as many visual clues to help them along. Styles’ essential purpose is to provide these clues, so here’s a guideline: The more your audience knows about design, the simpler you should keep your styles.



Before you dive into styles, remember also that a little style goes a long way. No matter how tempting it is to go hog-wild with the styles settings, please resist the urge. The purpose of styles is to help your model communicate, not to make it look “pretty” or “cool.” If the style of your work overpowers its content, tone down the styles.


 
Applying styles to your models

The easiest way to start applying styles is by using the premade styles that come with SketchUp. You find scads of them in the styles collections, which is great because seeing what’s been done is the best way to see what’s possible. As you go through this section, you’ll no doubt get ideas for your own styles, and that’s where the fun begins.

Applying a SketchUp style to your model is a three-step process that goes like this: 

	
Open the Styles panel by clicking its right-pointing arrow in the Default Tray.

(Mac: Window ⇒ Styles; Web: Open the Styles Panel, which is the “box and cylinder” icon about halfway down the right utility menu.)


	
On the Select tab (which is open by default), choose a styles collection from the Styles Collections drop-down list.

We introduce you to the collections that come preinstalled with SketchUp in a moment.


	Click a style in the Styles window to apply it to your model.


[image: Tip] This may come as a surprise, but it’s not possible to view your model without any style at all because styles are really just combinations of display settings. Some styles are fancier than others, but no matter what you do, you always have to have a style applied. If you want a relatively neutral view of your model, choose a style in the Default Styles collection.

Wonderfully, SketchUp doesn’t leave you out in the cold when it comes to content. SketchUp comes with plenty of examples to get you started. Figure 10-2 shows the Styles Collections drop-down list.



[image: Snapshot of the Styles Collections drop-down list.] 
FIGURE 10-2: The Styles Collections drop-down list is where you find all your styles.






Here’s a quick introduction to the most interesting options in the Styles Collections drop-down list: 


	In Model: The In Model collection shows you all the styles you’ve applied to your model. This collection keeps track of every style you’ve ever applied to your model, whether or not that style is still applied. To see a current list of styles in your SketchUp file: 
	Choose the In Model styles collection to show a list of styles you’ve applied to your model.

	[image: 9781119617938-ma076] Click the Details flyout menu (the right-pointing arrow) and choose Purge Unused to get rid of any styles you aren’t currently using (Web: Click the “recycling” icon at the bottom of the Styles panel).



	Default Styles: Think basic. These styles are as minimal as it gets: white background, black edges, white-and-gray front-and-back faces, and no fancy edge effects. Use these styles to get a clean starting point so that you can start simple and build from there.

	Photo Modeling: These styles make it easier to work when you’re building models that are photo-textured — completely covered in photographs. Chapter 8 covers modeling with photos.

	Sketchy Edges: These styles use real hand-drawn lines (also called nonphotorealistic, or NPR, styles) instead of digital ones to render edges, making your models look more like manual sketches than ever before. You can safely use the Sketchy Edges styles to convey any of the following: 
	That your design is in process

	That your model is a proposal and not a finished product

	That you welcome feedback in any and all forms





[image: Tip] SketchUp Styles can add some amazing effects to your model. The bad news is that they can also drastically slow down your computer. The good news is that you can switch to a Fast Style while working on your model. Available in the desktop version, Fast Styles are identified in the drop list by the presence of a little green alarm clock icon in the lower-right corner. For more information, go to https://help.sketchup.com/en/sketchup/speeding-rendering-fast-styles.
 


Editing your styles

If you’re handy in the kitchen, you’ve probably heard that cooking is an art and baking is a science. Cooking allows you to experiment; while you’re making a sauce, adding a little of this and a dash of that won’t wreck anything. Taking liberties with a cake recipe, however, can easily turn the cake into a doorstop. You can trust us on this, but you don’t want to know how we know.

Luckily, making styles has a lot more in common with cooking than it does with baking. Go ahead and fiddle around; you can’t do any irreversible harm. Playing with styles doesn’t affect a model’s geometry. Because styles are just combinations of settings, you can always go back to the way things were before you started.
 

RUNNING FROM REALISM: NPR STYLES
 
In the world of 3D modeling software, the trend has been toward photorealism. Rays of digital light are bounced around a billion times inside your computer until you can see every glint of sunlight in every dewdrop on every blade of grass on the lawn. The standard of perfection is how close the model comes to looking like a photograph, and in a lot of cases, that standard has been met; we’ve seen computer renderings that look more lifelike than life itself.

But what about models of buildings or other things that aren’t completely finished? Perhaps you’re an architect who’s designing a house for a client. If you aren’t sure what kind of tile you’ll use on your roof, how are you supposed to make a photorealistic rendering of it? You could just go ahead and throw any old tile up there as a placeholder, but that could backfire. Your client could hate the tile and decide not to hire you without ever telling you why, and all because of something you didn’t even choose.

What you need is a way to show only the decisions you’ve made so far, and that is exactly why architects and other designers make sketches instead of photorealistic renderings. When you’re designing, decisions don’t all happen at once. You need to be able to add detail as your design evolves. Sketching allows you to do that because it offers a continuum from cartoony to photographic, with everything in between. The following figure is an illustration.

Programs like SketchUp offer nonphotorealistic rendering (NPR) as a way to solve this problem for people who design in 3D. Instead of spending processor power on making representations that look like photographs, the people who make SketchUp went in the opposite direction; they’ve made a tool that lets you make drawings that are useful throughout the design process. 


[image: Schematic illustration of the 3D model drawings.] 






Of the tabs in the Styles panel, Edit is definitely the blue whale of the group. Because you find so many controls and settings here, SketchUp’s designers broke the Edit tab into the following five sections: Edge, Face, Background, Watermark, and Modeling (for onscreen modeling cues).
 

INTRODUCING STYLE BUILDER
 
If you’re using the Pro version of SketchUp, you have access to Style Builder. It’s a completely separate application (just like LayOut) that’s put on your computer when you install SketchUp.

Style Builder lets you create NPR styles based on edges you draw. Yep, that’s right — you can make your SketchUp models look like you drew them by hand with your medium of choice (finger paint, Sharpie, 08 Pigma Micron pen, and so on). All you need are a scanner and a piece of software like Adobe Photoshop, and you’re good to go. The best thing about the styles you create with Style Builder is that they’re unique. Unless you share them with someone else, no one can ever make SketchUp models that look like yours.

Because Style Builder is a whole other program and because it’s only included in the Pro version of SketchUp, we don’t cover Style Builder in depth in this book.


[image: Remember] To access each section, first open the Styles panel by clicking the right-pointing arrow in the Default Tray (Mac: Window ⇒ Styles). Then click the Edit tab, and select the icon that corresponds to the section whose settings you want to edit.

[image: 9781119617938-ma079] In SketchUp for Web, you need a paid subscription (or SketchUp for Schools) to edit styles. If you do, find the Edit tab of the Styles Panel by clicking the pencil icon, which is always at the top of the panel, next to the name of your current style. The editing controls look a bit different from those in the desktop, but generally work the same.

The following sections explain each part of the desktop Edit tab in detail; we also provide suggestions for using some of the settings.
 
Tweaking edge settings

[image: 9781119617938-ma031] The Edge section is tricky because it changes a little bit depending on what kind of style you currently have applied to your model. NPR styles have different settings than regular, non-NPR styles. Figure 10-3 shows both versions of the Edge section.

[image: Remember] SketchUp comes with two kinds of styles: regular and NPR. In NPR, SketchUp uses digitized, hand-drawn lines to render the edges in your model. All the styles in the Sketchy Edges collection, as well as all the ones in the Assorted Styles collection, are NPR styles. Because you can create your own styles based on existing ones, all the styles you create using edge settings from one of these NPR styles is an NPR style, too. (Web: NPR edge editing controls aren’t available.)



[image: Snapshot of the edge section which comes in two flavors as regular (left) and NPR (right).] 
FIGURE 10-3: The Edge section comes in two flavors: regular (left) and NPR (right).






Here’s the lowdown on some of the less-obvious settings in the Edge section; check out Figure 10-4 for a visual reference: 


	Back Edges: Switching on this setting tells SketchUp to draw all your model’s obscured (hidden behind a face) edges as dashed lines. When you display back edges, you can more easily infer edges and points than you can when back edges aren’t displayed. Also, there’s nothing like a bunch of dashed lines to make a technical drawing look impressive and complex.

	Profiles: Selecting the Profiles check box tells SketchUp to use a thicker line for edges that outline shapes in your model. Using profile lines is a pretty standard drawing convention that’s been around for a long time. Although models often look better with Profiles on, displaying Profiles comes at a price: Drawing Profiles takes more computer horsepower, which can diminish your model’s performance. If you’re working with a large file, think twice before you turn on Profiles.

	
Depth Cue: Using different line thicknesses to convey depth is another popular drawing convention. Objects closest to the viewer are drawn with the thickest lines, whereas the most distant things in the scene are drawn with the thinnest lines.

Depth Cue automatically applies this effect to your models. When its check box is selected, Depth Cue dynamically assigns line thicknesses (draftspeople call them line weights) according to how far away from you things are in your model. The number you type is both your desired number of line weights and the thickness in pixels of the fattest line SketchUp will use. We recommend a maximum line weight of 5 or 6 pixels.


[image: Schematic illustration of choosing the edge settings to give your model the desired look, from realistic to sketchy.] 
FIGURE 10-4: Choose among the edge settings to give your model the desired look, from realistic to sketchy.





[image: Tip] One more thing: Using Depth Cue and Profiles is overkill. Choose only one.




	
Halo: We really wish Halo were available for non-NPR styles because it’s just that great. Halo simply ends certain lines before they run into other ones, creating a halo of empty space around objects in the foreground. This keeps your model looking neat and easy to read. In fact, this is a drawing trick that pencil-and-paper users have been using forever to convey depth. Read your favorite comic strips, and you’ll likely find this effect.

The number you type in the Halo box represents the amount of breathing room SketchUp gives your edges. The unit of measure is pixels, but there’s no real science to it; just play with the number until things look right to you.


	Level of Detail: When you slide the Level of Detail controller (which appears only when you’ve applied an NPR style) back and forth, you’re effectively telling SketchUp how busy you want your model to look. The farther to the right you slide it, the more of your edges SketchUp displays. Experiment with this setting to see what looks best for your model. The last two images in Figure 10-4 show the Level of Detail slider positioned to the left and right.

	Color: Use the Color drop-down list to tell SketchUp what color to use for all the edges in your model. Here’s what each option does: 
	All Same: This option tells SketchUp to use the same color for all the edges in your model. Select a color by clicking the color well on the right and choosing a color.

	By Material: This option turns your model’s edges the color of whatever material they’re painted with. Because most people don’t know that you can paint edges different colors, this setting doesn’t get used very often.

	
[image: Tip] By Axis: Now here’s a useful, but hidden, gem. This option tells SketchUp to make everything that’s parallel to one of the colored axes the color of that axis. Edges that aren’t parallel to any axis stay black. Why is this so important? When something is screwy with your model — faces won’t extrude or lines won’t sink in — switching your edge colors to By Axis is the first thing you should do. You’ll be surprised how many of your edges aren’t what they seem. Have a look at Chapter 15 for more about this problem.




 




Changing the way faces look

[image: 9781119617938-ma032] The Face section of the Styles panel, shown in Figure 10-5, is very simple — at least compared with the Edge section. This area of the SketchUp user interface controls the appearance of faces, or surfaces, in your model. From here, you can change their color, visibility, and translucency. The following sections describe each element in detail.



IN A FOG?
 
If you’re looking for something to provide a sense of depth in your model views, look no further than the Fog feature. Fog does exactly what it says; it makes your model look like it’s enshrouded in fog (see the accompanying figure). You’d think that a feature this neat would be a little complicated, but it’s the opposite. Follow these three steps to let the fog roll into your model: 

	Open the Fog panel by choosing Window ⇒ Default Tray ⇒ Fog (Mac: Window ⇒ Fog). (Web: Fog is available in the Display panel just below Shadows.)

	Select the Display Fog check box to turn on the fog effect.

	Fool around with the controls until you like what you see.


We wish the process of controlling how fog looks was more scientific, but it’s not. You just play around with the sliders until you have the amount of fog you want. 


[image: Schematic illustration of using the fog effect.] 








[image: Snapshot of the Face section which controls the appearance of the model’s faces.] 
FIGURE 10-5: The Face section controls the appearance of your model’s faces.







FRONT COLOR/BACK COLOR

In SketchUp, every face you create has a back and a front. To choose the default colors for all new faces you create, click the Front and Back color wells, and then pick a color. We recommend sticking with neutral tones for your defaults; you can always paint individual faces later.

[image: Tip] Sometimes when you model in SketchUp, a face is turned inside out. Follow these steps to flip a face so that the right side shows: 

	Select the face you want to flip.

	Right-click and choose Reverse Faces.


[image: Technical Stuff] Knowing which face is the front and which is the back is especially important if you plan to export your model to another program or create a 3D-printable model. Some programs, such as Autodesk 3ds Max, use the distinction between front and back to determine what to display. In these cases, showing the wrong side of a face can produce unexpected results. See Chapter 9 for details about 3D-printing models.


 
STYLE

Face styles provide different modes for viewing the faces in your model. You can switch among them as much as you like without affecting your geometry. Each Face style has its purpose, and all are shown in Figure 10-6: 


	Wireframe: In Wireframe mode, your faces are invisible. Because you can’t see them, you can’t affect them. Only your edges are visible, which makes this mode handy for doing two things: 
	
[image: Tip] When you select edges, switch to Wireframe mode to make sure that you’ve selected what you meant to select. Because no faces block your view, Wireframe mode helps you select only what you want. The Back Edges setting is handy for this, too.


	After you use Intersect Faces, you usually have stray edges lying around. Wireframe is the quickest way to erase them because you can see what you’re doing. See Chapter 4 for details on Intersect Faces.



	Hidden Line: Hidden Line mode displays all your faces using whatever color you’re using for the background; it’s really as simple as that. If you’re trying to make a clean, black-and-white line drawing that looks like a technical illustration, make your background white. (We talk about how later in this chapter.)

[image: Schematic illustration of the face styles to change the way the faces appear.] 
FIGURE 10-6: Use Face styles to change the way your faces appear.







	
Shaded: This Face mode displays colors on your faces. Faces painted with a solid color appear that color. Faces to which you’ve added textures are shown with a color that best approximates their overall color. If your texture has a lot of brown in it, SketchUp picks a brown and uses that.

[image: Tip] For models with a lot of these textures, choosing the Shaded mode can really speed up orbiting, zooming, and otherwise navigating around. Unless you absolutely need to see textures applied to your model’s faces, try staying in Shaded mode as you work on a model.


	Shaded with Textures: Shaded with Textures makes textures visible. Because this mode puts a lot of strain on your computer, it can also be the slowest mode to work in. Turn it on only when you work on a small model, or when you need to see the textures. Obviously, if you’re going for a photorealistic effect, this is the mode to choose.

	Monochrome: This mode is a quick way to give your model a simplified color scheme. This mode uses your default front and back face colors to paint your model. You can also use this setting to check the orientation of your faces.

	X-Ray: Unlike using translucent materials on only some of your faces (such as glass and water), flipping on X-Ray mode enables you to see through all your faces. Use X-Ray to see through a wall or a floor and show what’s behind it. If you’re in a plan (overhead) view, X-Ray mode is a great way to demonstrate how a floor level relates to the one below it.



[image: Tip] You may need to make a few minor changes to a “final” model only to discover that your computer model is operating a lot slower than it did before the changes. No problem; select View ⇒ Face Style to temporarily switch face styles and inspect what may have gone wrong. X-Ray and Monochrome can be particularly useful (Web: It’s pretty quick to use Search to toggle face and edge settings.)


 
TRANSPARENCY

Displaying transparency (as in translucent materials) is an especially taxing operation for SketchUp and your computer to handle, so you can decide how to display translucent materials: 


	Enable transparency: Clear this check box to display translucent materials as opaque. Turn off transparency to speed up SketchUp’s performance if you find that it has slowed.

	Transparency quality: If you decide to display transparency, you can further fine-tune your system’s performance by telling SketchUp how to render that transparency. There are two basic options, Faster or Nicer; when Nicer is selected, you can adjust the model’s opacity with the X-Ray Opacity slider. The lower the opacity, the more see-through your model is.






 
Setting up the background

[image: 9781119617938-ma033] In the Background section of the Styles panel, you choose colors and decide whether you want to see a sky and a ground plane. Check out Figure 10-7 to get a view of the Background section, along with an idea of how it works. You have the following options in the Background section: 


	Background: For most models, we set the background to a traditional white.

	Sky: Displaying a sky in your modeling window makes things slightly more realistic, but the real purpose of this feature is to provide a point of reference for your model. In 3D views of big things like architecture, it’s nice to be able to see the horizon. Another reason for turning on the sky is to set the mood. Keep in mind that the sky isn’t always blue. Some beautiful SketchUp renderings are sunset (or maybe nuclear winter) orange.

	Ground: We’re not big fans of turning on the Ground feature, and here’s why: It’s very hard to find a ground color that looks halfway good, no matter what you’re building. Also, you can’t dig into the earth to make sunken spaces (such as courtyards) with Ground turned on. Instead of turning on this feature, try making your own ground planes with faces and edges. This method is more flexible, and we think it looks better.




[image: Snapshot of using the background section to turn on the sky and the ground and to choose colors.] 
FIGURE 10-7: Use the Background section to turn on the sky and the ground and to choose colors.








Working with watermarks

[image: 9781119617938-ma034] Watermarks, which are editable only in desktop versions, are much easier to understand if you don’t think about them as actual watermarks that are used to brand a model. Instead, think of watermarks as graphics that you can apply either behind or in front of your model to produce certain effects. Here are a few of the things you can do with SketchUp watermarks: 


	Simulate a paper texture, just like some of the styles in the Assorted Styles collection.

	Apply a logo or other graphic to your model view.

	Layer a translucent or cutout image in the foreground to simulate looking through a frosted window or binoculars.

	Add a photographic background like Outer Space or Inside My Ileum to create a unique model setting.

 
EYEING THE WATERMARK CONTROLS

Figure 10-8 shows the Watermark section of the Styles panel. To open it, click the second-from-right button on the Edit tab. Here’s a brief introduction to what some of the less-obvious controls do: 


	Add, Remove, and Edit Watermark buttons: The +, –, and gears icons allow you to add, remove, and edit (respectively) watermarks in the style you’re editing.

	Watermark list: This list shows all your watermarks in relation to model space, which is the space your model occupies. All watermarks are either in front of or behind your model, making them overlays or underlays, respectively.

	Move Up or Move Down arrows: Use these buttons to change the stacking order of the watermarks in your model view. Select the watermark you want to move in the list and then click one of these buttons to move it up or down in the order.




[image: Snapshot of the watermark section.] 
FIGURE 10-8: The Watermark section.








ADDING A WATERMARK

Watermarks are by no means simple, but working with them, miraculously enough, is. Follow these steps to add a watermark to your model view: 

	
Click the Add Watermark button.

The Choose Watermark dialog box appears.


	
Find the image you want to use as a watermark and then click the Open button to open the first Create Watermark dialog box shown in Figure 10-9.

You can use any of these graphics file formats: TIFF, JPEG, PNG, and GIF.

[image: Technical Stuff] This point is way beyond the scope of this book but worth mentioning because you’re bound to need this sooner or later: If you want to make a watermark out of an image that isn’t a solid rectangle (such as a logo), you need to use a graphics file format that supports alpha channels (such as PNG). An alpha channel is an extra layer of information in a graphics file that describes which areas of your image are supposed to be transparent. It sounds complicated, but it’s really a straightforward concept. To make an image with an alpha channel, you need software like Photoshop or GIMP (GNU Image Manipulation Program). Try doing an Internet search for alpha channels for more information.


[image: Snapshot of creating the watermark series of dialog boxes.] 
FIGURE 10-9: The Create Watermark series of dialog boxes.







	Type a name for your watermark in the Name box.

	Choose whether you want your new watermark to be in the background or in the foreground as an overlay and click the Next button.

	
Decide whether to use your watermark as a mask.

Selecting this check box tells SketchUp to make your watermark transparent, which kind of simulates a real watermark. How transparent each part becomes is based on how bright it is. White is the brightest color, so anything white in your watermark becomes completely transparent. Things that are black turn your background color, and everything in between turns a shade of your background color. The possibilities for this feature are interesting, but we haven’t found any good uses for it yet.


	
Adjust the amount that your watermark blends with what’s behind it and then click the Next button.

In this case, Blend is really just a synonym for Transparency. By sliding the Blend slider back and forth, you can adjust the transparency of your watermark.

[image: Tip] Blend comes in handy for making paper textures because that process involves using the same watermark twice: once as an overlay and once as an underlay. The overlay version gets blended in so that your model appears to be drawn on top of it. To see how this works, apply one of the Paper Texture styles to your model and then edit each of the watermarks to check out its settings.


	
Decide how you want your watermark to be displayed and then click the Finish button.

You have three choices for how SketchUp can display your watermark: stretched to fit the entire window, tiled across the window, and positioned in the window. If you select Stretched to Fit the Screen, be sure to select the Lock Aspect Ratio check box if your watermark is a logo that you don’t want to appear distorted. When you select Positioned in the Window, then you get your choice of nine locations, plus a slider bar to scale your watermark up or down.


 


EDITING A WATERMARK

You can edit any watermark in your SketchUp file at any time. Follow these simple steps to edit a watermark: 

	
Select the watermark you want to edit in the Watermark list.

You can find the Watermark list in the Watermark section of the Edit tab of the Styles panel.


	Click the Edit Watermark button (it looks like a couple of tiny gears) to open the Edit Watermark dialog box.

	
Use the controls in the Edit Watermark dialog box and then click OK when you’re done.

For a complete description of the controls in this dialog box, see the description of the Create Watermark dialog box in “Adding a watermark,” earlier in this chapter.






 
Tweaking modeling settings

[image: 9781119617938-ma035] In the Modeling section, shown in Figure 10-10, the controls adjust the color and visibility of all your model elements that aren’t geometry. The controls are described as follows: 


	Controls with color wells: Click the wells to change the color of that type of element.

	Section Cut Width: This refers to the thickness of the lines, in pixels, that make up the section cut when you use a section plane. For more about section cuts, see Chapter 11.

	Controls with check boxes: Use these to control the visibility of that type of element in your model. Three of them are a little confusing: 
	Color by Tag: Tells SketchUp to color your geometry according to the colors you’ve set up in the Tags panel. Check out Chapter 7 for more about Tags and this setting.

	Section Planes: This refers to the section plane objects that you use to cut sections. They’re gray with four arrows on their corners. Chapter 11 explains how section planes and cuts work.

	Section Cuts: Unlike section planes, this setting controls the visibility of the section cut effect itself. With this deselected, your section planes don’t appear to cut anything.



[image: Snapshot of the controls in the Modeling section.] 
FIGURE 10-10: The controls in the Modeling section are every bit as simple as they look.










IMPROVING ACCESSIBILITY WITH STYLES
 
If you have some degree of color blindness, you may have trouble seeing the onscreen modeling cues. However, SketchUp styles enable you to change these colors and improve SketchUp’s accessibility by using the Color Blind style. You can further edit this style to customize the edge and face settings to best accommodate yourself.

You can also change the axes colors and additional onscreen color cues in the Preferences dialog box. Choose Window ⇒ Preferences (Mac: SketchUp ⇒ Preferences. Web: Settings), and select the Accessibility pane to find and adjust these options.



	Match Photo settings (Pro only): When you photo-match (which you can read about in Chapter 8), adjusting the visibility of your photograph is sometimes helpful. Use these controls to hide, show, and adjust the photo’s opacity in both the background and the foreground.

 


Mixing styles to create new ones (Desktop only)

You can use the Mix tab to combine features of multiple styles to make new ones. Instead of working through the sections of the Edit tab, flipping controls on and off, sliding sliders, and picking colors, the Mix tab lets you build new styles by dropping existing ones onto special “category” wells. In addition to being a nifty way to work, mixing is the only way you can switch a style’s edge settings between NPR and non-NPR lines.

[image: Remember] NPR refers to the styles in the Assorted Styles, Sketchy Edges, and Competition Winners collections. These nonphotorealistic rendering styles use scanned, hand-drawn lines to draw the edges in your model. If you have SketchUp Pro, you can use Style Builder to make your own NPR styles from lines you draw and scan in. Take a look at the sidebar “Introducing Style Builder,” earlier in this chapter, for more information.

Follow these steps to change a style using the Mix tab, as shown in Figure 10-11: 

	
On the Styles panel, select the Mix tab.

When you select the Mix tab, the secondary section opens at the bottom of the panel so that you can view your styles without switching back and forth from the Mix to Select tab.


[image: Snapshot of the sample from different styles to update the style.] 
FIGURE 10-11: Sample from different styles to update the style you’re working on.







	
Find the style you want to sample from in the Select section.

You can call this your source style. Say that you’re working on a new style and you want your edges to look just like those in the Marker Loose style that came with SketchUp. In this example, choose the Sketchy Edges collection from the Styles Collections drop-down list, where you’ll find the Marker Loose style.


	
Do one of the following: 


	Windows: Click the source style from the Styles list in the Select section to sample it and then click the category well that corresponds to the style setting you want to apply.

	Mac: Drag your source style from the Styles list in the Select section to the category well that corresponds to the style setting you want to apply.



In this case, sample the Marker Loose style from the Select section and drop it on the Edge Settings Category well because you want the edge settings from that style to be applied to the style you’re working on.


	To save your style after you’re done adding all the bits and pieces, see the following section.

 




Creating a new style

Creating a new style adds it to your In Model collection of styles, so you can come back and apply it to your model anytime you like. Follow these steps to create a new style: 

	
Click the Create New Style button in the Styles panel.

This duplicates the style that was applied to your model before you clicked the Create New Style button. Your new style appears in your In Model collection as [name of the original style]1.

In the Web version, style creation is the same as style editing. If you have a paid subscription, simply click the Style edit icon to create a new style. To avoid overwriting custom styles, first select a style from SketchUp’s default library; then click the edit icon to start creating a new style.


	
Use the controls in the Edit tab to set up your style the way you want.

[image: Tip] Frequently, you want to make a new style after you already make changes to an existing one. If you want to create a new style that reflects modifications you’ve made already, just switch steps 1 and 2.


	
In the Name box (at the top of the Styles panel), give your new style a name and press Enter.

If you want, you can also give your new style a description in the Description box, though you may want to wait until later.


	
Click the Update button (Web: Click Done).

[image: 9781119617938-ma037] The Update button (only on desktop) is the two arrows chasing each other. This updates your new style with all the changes you made in steps 2 and 3.


	
Check the In Model collection in the Select tab to make sure that your new style is there.

Your new style appears alphabetically in the list.



[image: Tip] If a bunch of styles exist in your In Model collection that you don’t use anymore and that you want to clean up, click the Details flyout menu and choose Purge Unused (Web: Click the “recycling” three-arrow icon). This gets rid of any styles that aren’t currently applied to any scenes in your model. Chapter 11 has more about scenes.

[image: Remember] Creating a new style doesn’t automatically make it available for use in other SketchUp files. To find out how to save and share styles, see the next section.


 
Saving and sharing styles you make (Desktop only)

As you work in SketchUp, you’ll want to create your own styles and save them so that you can use them in other models. If you’re part of a team, everyone will likely want to access the same styles so that all your models look consistent.
 
Saving the styles you make

When creating your own styles, you can approach things in two ways: 


	[image: 9781119617938-ma036] Create New Style: Clicking this button creates a new style with the currently active settings. When you create a new style, it appears in your In Model collection of styles and is saved with your model. The Create New Style button can be found in the upper-right corner of the Styles panel.

	[image: 9781119617938-ma037] Update Style with Changes: This button updates the current style with any changes you’ve made in the Edit or Mix tabs. If you want to modify an existing style without creating a new one, this is the way to go. You can find the Update button right below the Create button in the upper-right corner of the Styles panel.




 
Updating an existing style

To make adjustments to a style in your model, you need to update it. Follow these steps to update a style: 

	
Apply the style you want to update to your model.

If you need help with this, follow the steps in the section “Applying styles to your models,” earlier in this chapter.


	Use the controls in the Edit tab to make changes to the style.

	Click the Update Style with Changes button in the Styles panel to update the style with your changes.


[image: Tip] Use the Update Style with Changes button to rename existing styles, too. Just type the new name into the Name box (at the top of the Styles panel), press Enter, and then click the Update Style with Changes button.

[image: Remember] When you update a style, only the copy of the style that’s saved with your model is updated. You aren’t altering the copy of the style that appears in every new SketchUp file you open.


 
Using your styles in other models

[image: Tip] After you update or create a style, you probably want to make that style available in other SketchUp models. To make this happen, you need to create your own styles collections. Collections are folders on your computer that contain the styles that appear in the Styles panel. You can create your own collections to keep the styles you invent neat and tidy.

Follow these steps to create a collection to contain your styles: 

	Open the Styles panel by clicking the right-pointing arrow in the Default Tray (Mac: Window ⇒ Styles).

	
On the Select tab, click the Details menu, and choose Open or Create a Collection (Mac: Choose Create a new Collection).

A dialog box opens, where you select a location on your hard drive for the collection.


	Navigate to the folder on your computer or network where you want to create your collection.

	
Click the New Folder button.

The new folder you create becomes your new collection.


	
Type a name for your new collection.

For example, you can call your new collection Josephine’s Collection. You can call it something else if your name isn’t Josephine, or you could even call it Something Else.

(Mac: Make sure that the Add to Favorites check box is selected.)


	
Click the Select Folder button (Mac: Save button).

The dialog box closes, and your collection is added to the Favorites section of the Collections drop-down list. It will be there in every SketchUp model you open on this computer.



After you create a new collection, you can add styles to it to make them available from any model you work on.

Follow these steps to make a style available for use in other SketchUp files: 

	
Open the Styles panel.

The Styles panel appears.


	
[image: 9781119617938-ma011] Click the Select tab and then click the In Model button to display your In Model collection.

The In Model button looks like a little house. The In Model collection contains all the styles you’ve used in your model, including the ones you’ve created.


	
[image: 9781119617938-ma038] Click the Display the Secondary Selection Pane button.

You find this button in the upper-right corner of the Styles panel. When you click it, a second copy of the Select section pops out of the bottom of the Styles panel, as shown in Figure 10-12. Use this section to drag and drop styles between folders on your computer, which makes it easier to keep them organized.


[image: Snapshot of using the Select section to manage your styles without leaving SketchUp.] 
FIGURE 10-12: Use the Select section to manage your styles without leaving SketchUp.







	
In the Select section, choose the collection to which you want to add your style.

If you’ve created a collection specifically for the styles you make, choose that one; or you can pick any collection in the Collections drop-down list.


	
Drag your style from the In Model styles list to the Styles list in the Select section.

By dragging and dropping your style from the upper list to the lower one, you make the style available to anyone who has access to that collection. This means that you can use the style in other SketchUp models you build on your computer. To share it with other members of your team, copy your style to a collection where other people can get to it, such as on a network.


 






Working with Shadows

Typically, you add shadows to a SketchUp drawing for two key reasons: 


	To display or print a model in a more realistic way: Turning on shadows adds depth and realism, and gives your model an added level of complexity that makes it look like you worked harder than you really did.

	To study the effect of the sun on what you’ve built (or plan to build) in a specific geographic location: Shadow studies are an integral part of the design of any built object. If you’re making a sunroom, you need to know that the sun is actually going to hit it, no? You can use SketchUp to show exactly how the sun will affect your creation, at every time of day, on every day of the year.



In this section, we start with a brief, nuts-and-bolts description of how all the controls work, without diving too much into why you’d want to pick one setting instead of another. The second part of this section is devoted to running through each of the preceding scenarios and using the controls to make SketchUp do exactly what you want it to.
 
Discovering the shadow settings

The basic thing to understand about shadows in SketchUp is that, just like in real life, they’re controlled by changing the position of the sun. Because the sun moves exactly the same way every year, you just pick a date and time, and SketchUp automatically displays the correct shadows by figuring out where the sun should be. Hooray for math!

You do all these simple maneuvers in the Shadows panel, as shown in Figure 10-13. The sections that follow introduce how the controls work so you can apply them to your model.



[image: Snapshot of dialing up the sun in the Shadows panel.] 
FIGURE 10-13: Dial up the sun in the Shadows panel.






Making the sun rise

Shadows aren’t turned on by default, so the first thing you need to know about applying shadows is how to turn them on. Follow these simple steps: 

	
Open the Shadows panel by choosing Window ⇒ Default Tray ⇒ Shadows.

(Mac: Window ⇒ Shadows) (Web: All shadow controls are in the Display panel, which you access using the eyeglasses in the right toolbar. You can also turn shadows on and off using Search ⇒ Shadows).

[image: Remember] In the Web version, shadow settings can control only time and date, not time zone.


	
[image: 9781119617938-ma039] In the upper-left corner of the panel, click the Show/Hide Shadows button.

Clicking it turns on the sun in SketchUp, casting shadows throughout your model and, generally speaking, making everything much more exciting.




 
Setting a shadow’s time and date

The Shadows panel has time and date controls, which you use to change the position of the SketchUp sun. The time and date you choose, in turn, controls the appearance of shadows in your model: 


	Setting the time: You don’t have to be Copernicus to figure out how to set the time of day; move the Time slider back and forth, or type a time into the little box on the right. Notice the times at each end of the slider? They represent sunrise and sunset for the day of the year you’ve set in the Date control, described in the next bullet point.

	Setting the date: Just like the time of day, you set the day of the year by moving the Date slider back and forth, or by typing in a date in the little box on the right. If you slide the Date control back and forth, notice that the sunrise and sunset times change in the Time control, in the preceding point.



[image: Tip] To toggle open or closed the extra shadow controls, click the triangular Expand button in the upper-right corner of the Shadows panel.


 
Choosing where shadows appear

The Display check boxes in the Shadows panel enable you to control where shadows are cast. Depending on your model, you may want to toggle these on or off. (In the Web version, these controls are available for any selection in the Entity Info panel.) 


	On Faces: Deselecting the On Faces check box means that shadows aren’t cast on faces in your model. This is on by default, and you should probably leave it on, unless you want to cast shadows only on the ground. For what it’s worth, we always have it selected.

	On Ground: Deselecting the On Ground check box causes shadows not to be cast on the ground plane. Again, this is on by default, but sometimes you want to turn it off. A prime example is when something you build extends underground.

	From Edges (Desktop only): Selecting the From Edges check box tells SketchUp to allow edges to cast shadows. This applies to single edges that aren’t associated with faces — things like ropes, poles, and sticks are often modeled with edges like these.






 
Adding depth and realism

The neat thing about shadows in SketchUp is how easily you can apply them — and how easy they are to adjust. In the previous sections, you find a dry rundown of the basic controls in the Shadows panel. In the following sections, you learn how to use those controls to add depth, realism, and delicious nuance to your models. If only Caravaggio had had it so good.

You often need shadows to make your drawings read better, especially in the following instances: 


	Indoor scenes: The sun is the only source of lighting that SketchUp has, so any shadows you use in interior views have to come from it.

	Objects that aren’t in any particular location: For things like cars and furniture, it doesn’t matter that the shadows are geographically accurate; all that matters is that they help make your model look good.

	2D views: Without shadows, reading depth in 2D views of 3D space is next to impossible.

 
Lighting indoor spaces (Desktop only)

Adding shadows to interior views presents an interesting problem: Because SketchUp has no lights besides the sun, how are you supposed to make anything that looks halfway realistic? With a ceiling in your room, everything’s dark. If you leave off the ceiling, your model looks ridiculous. Don’t despair; here are some tricks: 


	Decrease the darkness of the shadows. Sliding the Dark slider to the right brightens your view considerably. You can still see the shadows cast by the sun coming through windows and other openings, but the whole room won’t look like something bad is about to happen. Check out Figure 10-14.

	Make an impossible ceiling. As long as you haven’t modeled anything on top of the interior you’re planning to show, you can tell the ceiling not to cast a shadow. That way, sunlight shines directly onto your furniture, casting gloriously complex shadows all over everything. This technique is available in the Web version.




[image: Snapshot of brightening the room by increasing the Dark slider.] 
FIGURE 10-14: Brighten the room by increasing the Dark slider.






Figure 10-15 shows this ceiling method in action. To create this effect yourself, follow these steps: 

	
Adjust the settings in the Shadows panel until the sun shines through one or more windows in your view.

This ensures that shadows cast by objects in your room look like they’re caused by light from the windows.

[image: Tip] To make it seem like overhead lighting is in your space, set the time of day to about noon and the date to about the end of June. The shadows cast by furniture and similar objects will be directly below the objects themselves. One more thing: If you have lighting fixtures on the ceiling, remember to set them not to cast shadows in the Entity Info panel (read on).


	Open the Entity Info panel by clicking its right-pointing arrow in the Default Tray (Windows) or choosing Window ⇒ Entity Info (Mac).

	
Select any faces that make up the ceiling.

Hold down the Shift key to select more than one thing at a time.


	
In the Entity Info panel, deselect the Cast Shadows option.

[image: 9781119617938-ma038] The ceiling now no longer casts a shadow, brightening your space considerably.


	Repeat steps 3 and 4 for the following faces and objects: 
	The wall with the windows in it

	The windows themselves

	Any walls in your view that cast shadows on the floor of your space



[image: Snapshot of telling the ceiling not to cast a shadow.] 
FIGURE 10-15: Tell the ceiling not to cast a shadow.







	
Move the Dark slider to about 50.

This brightens things even more and makes your shadows more believable.


 


Making 3D objects pop

Adding shadows to freestanding things like tables, lamps, and pineapples is a mostly aesthetic undertaking; just fiddle with the controls until things look good to you and you’ll be okay. Keep the following tips, illustrated in Figure 10-16, in mind: 


	Take it easy on the contrast (Desktop only) — especially when it comes to very complex shapes or faces with photos mapped to them. When your model is too contrasty and dramatic, it can be hard to figure out what’s going on. To decrease the contrast 
	Move the Dark slider over to about 40 or 50.

	Move the Light slider down to 60 or 70.



	Shorten your shadows. It’s strange to see objects lit as though the light source is very far away; overhead lighting looks more natural. To make your shadows look better, follow these steps: 
	Set the Date slider to a day in the early autumn.

	Set the Time slider to a time between 1 a.m. and 2 p.m.



	
[image: Remember] Don’t be afraid to rotate your model. Remember that you can’t get every possible shadow position by using only the controls in the Shadows panel. To get the effect you want, you may have to rotate your model by selecting it and using the Rotate tool.


	Select the From Edges check box. Lots of times, modelers use free edges to add fine detail to models (think of a harp or a loom). Selecting the From Edges check box tells SketchUp to allow those edges to cast shadows, which makes complex objects look about 900 percent cooler.

	Pay attention to the transparency of faces. When you have a face painted with a transparent material, you can decide whether that face should cast a shadow; chances are that it shouldn’t. In SketchUp, the rule is that materials more than 50 percent transparent cast shadows. So, if you don’t want one of your transparent-looking faces to cast a shadow, do one of the following: 
	Select the face and then deselect the Cast Shadows check box in the Entity Info panel.

	Adjust the opacity of the face’s material to be less than 50 percent in the Materials panel. For more information on how to do this, have a look at Chapter 3.






[image: Snapshot of some tips for making objects stand out with shadows.] 
FIGURE 10-16: Some tips for making objects stand out with shadows.










Creating accurate shadow studies (Desktop only)

SketchUp can display accurate shadows, one of its most useful features. To do this, three pieces of information are necessary: 


	The time of day

	The day of the year

	The latitude of the building site



[image: Technical Stuff] The sun’s position (and thus the position of shadows) depends on geographic location — that is to say, latitude. The shadow cast by a building at 3 p.m. on March 5 in Minsk is very different from that cast by a similar building, at the same time of day, on the same date in Nairobi. Conversely, longitude has very little effect on shadows. Whether you are in Rome, Italy or Chicago, Illinois, the shadows will be relatively the same for a given date and time because they’re on the same line of latitude.

[image: Tip] Here’s an easy way of remembering which coordinate is which: note the uppercase letters: lAtitudes go Across, lOngitudes go Over.

If you display shadows on a model of a toaster oven, geographic location probably doesn’t matter to you; the shadows are just there for effect. But if you try to see how much time your pool deck will spend in the sun during the summer months, you need to tell SketchUp where you are on the planet.
 
Telling SketchUp where you are

Do you know the precise latitude of where you live? We sure don’t. It’s a good thing SketchUp helps you figure out where in the world your model is supposed to be. You can geo-reference your model (give it a geographic location) in two ways; which one you choose probably depends on your intended use: 


	Using a geolocation snapshot: If you know exactly where your model is supposed to go and you want to see it in that context, then use this method. Take a look at Chapter 8 for a complete set of instructions. In the Web version, you have to use this approach: Open the hamburger menu in the upper left, and select Add Location.

	Using the Model Info dialog box: Use this method if you just want the see the shadows cast by your model. It’s your only option if you’re not online. Read on for all the gory details.



To give your model a geographic location when you’re offline, follow these steps illustrated in Figure 10-17 (desktop only): 

	Choose Window ⇒ Model Info.

	
In the Model Info dialog box that appears, select Geo-Location in the sidebar on the left.

[image: Tip] If you see anything other than This model is not geo-located, stop here. Your model has already been geographically located, and if you like its location then you don’t need to go through any of the following steps. Close the Model Info dialog box, make yourself some coffee, and waste the time you just saved avoiding the next steps.


[image: Snapshot of giving the model a geographic location.] 
FIGURE 10-17: Giving your model a geographic location when you’re not online.







	Click the Set Manual Location button to open another dialog box.

	
Enter the required information and click OK.

What you type in the Country and Location fields is entirely up to you; it doesn’t affect your model’s geo-location one bit. The Latitude and Longitude fields are the important parts of this dialog box. While you are at it, observe how changing the longitude may also change the Coordinated Universal Time (UCT).



[image: Tip] Latitude and longitude can be determined from a suitable paper map, a world globe, or by an Internet search of a nearby landmark. Super accuracy may not be required for your particular application; one degree difference in latitude is about 69 miles.

Whether you imported a geo-location snapshot or entered a set of coordinates manually, the next step is to make sure your model is rotated correctly relative to north. If your model faces the wrong way, your shadow studies are completely inaccurate.

[image: Remember] All you really need to know is this: By default, the green axis runs north-south, with the solid part pointing north. If north-for-your-building doesn’t line up with the green axis, just select everything and use the Rotate tool to spin the building into place. See Chapter 3 for details about rotating a model.

The following method, illustrated in Figure 10-18, works well: 

	
Save your model.

Saving is a good idea any time you’re getting ready to make significant changes.


	On the ground somewhere, draw an edge that points to where north should be.

	
Starting at the southern endpoint of the edge you just drew, draw another edge that’s parallel to the green axis.

You have a V shape.


	
Select everything in your model except the edge you drew in step 2.

Your geolocation snapshot (if you have one) should have a red border around it; that’s because it’s locked. If for some reason it isn’t, right-click it and choose Lock; you don’t want to rotate it accidentally.


	[image: 9781119617938-ma014] Activate the Rotate tool.

	Click the vertex (pointy end) of the V to establish your center of rotation.

	Click the north end of the edge you drew in step 2.

	
Click the north end of the edge you drew in step 3.

Now everything’s lined up properly.





[image: Schematic illustration of making sure the model is correctly oriented relative to north.] 
FIGURE 10-18: Make sure your model is correctly oriented relative to north.






[image: Warning] You have now realigned your model relative to the axes. This might make future editing more difficult, which is why step 1 directs you to save your model.


 
Displaying accurate shadows for a given time and place

Now that you’ve told SketchUp where your model is, it’s a pretty simple process to study how the sun will affect your project, as shown in Figure 10-19. This is the fun part; all you have to do is move some sliders. If you have an audience, get ready for completely undeserved praise.

To study how the sun affects your project, follow these steps: 

	Orbit, zoom, and pan around until you have a good view of the part of your project you want to study.

	Open the Shadows panel.

[image: Schematic illustration of studying the effect of the sun on the model.] 
FIGURE 10-19: Studying the effect of the sun on your model.







	[image: 9781119617938-ma039] Select the Show/Hide Shadows button to turn on SketchUp’s sun.

	
Make sure the time setting is correct for your location.

[image: Technical Stuff] “Shadows” probably do not exactly match your local clock time. As indicated earlier, SketchUp determines a theoretical time offset from UTC based on the current latitude setting. This is based on dividing the earth up into 24 zones of 15 degrees longitude. So far so good, but solar time can vary from clock time by as much as 45 minutes during the year, plus or minus 4 minutes for each degree of longitude that you are away from the nominal 15-degree increments. Now toss in the fact that time zones don’t always map directly to coordinates, plus the fact that SketchUp doesn’t allow for Daylight Saving time, which means that your model shadows won’t always be 100% accurate, but they will give you a pretty good idea.


	Type a month and day into the box to the right of the Date slider and then press Enter.

	Move the Time slider back and forth to see how the shadows will move over the course of that day.

	Pick a time of day using the Time controls.

	Move the Date slider back and forth to see how the sun will affect your project at that time of day over the course of the year.









 

Chapter 11

Preparing Models for Presentation

IN THIS CHAPTER

[image: check] Walking around inside your model

[image: check] Creating scenes to capture particular views

[image: check] Making animations with scenes

[image: check] Cutting slices through your model with section planes

[image: check] Generating plans and sections



After you make a model, you probably want to show it to someone. How you present your work depends on the idea you want to convey. The tricky part about using SketchUp to present a model isn’t actually using the tools; it’s choosing the right tools to get your idea across without a bunch of extra information distracting your audience. Most 3D models have so much to look at that the real challenge is finding a presentation method that helps you focus on the stuff you want to talk about.

In this chapter, you learn about three ways to show off your models without ever leaving SketchUp. If you’ve made a building, you can walk around inside it. You can even walk up and down stairs and ramps — just like in a video game. You can create animated slide shows by setting up scenes with different camera views, times of day, and even visual styles. If you want to talk about what’s inside your model, you can cut sections through it without taking it apart. Even — and especially — if you need to present your model in 2D, you still need to compose the views of your model as Scenes in SketchUp.

As you read this chapter, think about what you want your model to communicate. As with everything else in SketchUp (and in life, we suppose), a little bit of planning goes a long way. Whether you are developing a set of printed plans or presenting a model live in SketchUp, you can’t really go wrong, so have fun.



Exploring Your Creation on Foot

Few experiences in virtual life are as satisfying as running around inside your model. After you make a space, you can walk around it, go up and down stairs, bump into walls, and even fall off ledges. You can check to make sure that the television is visible from the kitchen, say, or experience what it’d be like to wander down the hall. In a potentially confusing building, such as an airport or a train station, you can figure out where to put the signs by allowing someone who’s never seen your model to explore the space “on foot.” The following sections, uh, walk you through how to use these features.
 
These tools were made for walking

A couple of tools in SketchUp are dedicated to moving around your model as if you were actually inside it. The first step (no pun intended) is to position yourself so that you seem to stand inside your model. This can be tricky with just the Orbit, Pan, and Zoom tools, so SketchUp provides a tool just for this: Position Camera. After you’re standing in the right spot (and at the right height), you use the Walk tool to move around. It’s as simple as that.

[image: Remember] [image: 9781119617938-ma041] In SketchUp for Web, there is no Camera menu, but most of the camera tools in this chapter are available in the bottom of the tool tray on the left. They’re nested underneath the Walk tool (the footprints icon).
 
Standing in the right spot: The Position Camera tool

The Position Camera tool precisely places your viewpoint in SketchUp in a particular spot. That’s really all it does, but it works in two ways.

[image: Tip] An easy way to set a suitable camera position is to switch to a plan view. Choose Camera ⇒ Standard Views ⇒ Top. (Web: Use Search to find this view.) 


	
You want to stand right here. Choose Camera ⇒ Position or click the Position Camera tool. (You find it on the Large Tool Set in both Windows and Mac.) Then click anywhere in the modeling window to automatically position your viewpoint 5 feet, 6 inches above wherever you clicked. Because this is the average eye height of an adult, the result is that you are, for all intents and purposes, standing on the spot where you clicked, and are facing the same direction that you were before you clicked; see Figure 11-1. After you use the Position Camera tool, SketchUp automatically switches to the Look Around tool, assuming that you may want to look around. We talk about Look Around in the “Stopping to look around” section of this chapter.

To get a feel for this, start a new file. Create a few random circles and rectangles, and push/pull them to different heights. Now set the camera position at the toe of the scale figure. Your view changes. Now hold the left mouse button down and move your mouse. As you move it up/down and left/right you soon realize that you’re looking through the eyes of the scale figure.


[image: Snapshot of dropping yourself into he user's model with the Position Camera tool.] 
FIGURE 11-1: Drop yourself into your model with the Position Camera tool.





[image: Tip] [image: 9781119617938-ma040] You’re not stuck being 5'6" tall forever. After you launch the Position Camera tool, but before you pick a location, type the height you’d rather be and press Enter. Your new eye height appears in the Measurement box. Type 1" to see a mouse’s view of the world, or type 17' to pretend you’re a giraffe. This height offset is remembered within the current editing session, even if you switch to other files, but resets to 5'6" when you close and restart SketchUp.





	
You want your eyes to be right here, and you want to look in this direction. Select the Position Camera tool, click and hold down the mouse button while in the spot where you want your eyes to be, drag over to the thing you want to look at (you see a dashed line connecting the two points), and release the mouse button; see Figure 11-2. We call this the direct view technique.

Try the direct view technique a couple times; it takes a bit of practice to master. Use Position Camera in this way if you want to stand in a particular spot and look in a particular direction. This technique works great with scenes, covered later in this chapter.

[image: Warning] With the direct view technique, your height offset is set to zero, and if you then add an offset value it changes both the camera location and the target point. To see what the scale figure sees using direct view, you need to select their eyes, not their toes, for the first point.





[image: Snapshot of clicking and dragging with Position Camera to aim the user view.] 
FIGURE 11-2: Click and drag with Position Camera to aim your view.








Stepping out with the Walk tool

[image: 9781119617938-ma041] After you use the Position Camera tool to place yourself in your model, use the Walk tool to move through it. You find the Walk tool on the Camera menu or the Large Tool Set; it’s the pair of footprints.

To walk around, click and drag the mouse in the direction you want to move: 


	Straight up is forward.

	Straight down is backward.

	Anything to the left or right causes you to turn while you walk.



The farther you move your cursor, the faster you walk. Release the mouse button to stop. If you’ve ever played video games, you’ll get used to it quickly. If Scrabble is more your speed, it’ll take a few minutes to get the hang of things.

[image: Remember] Moving the Walk cursor controls speed and direction, not location. Once you’re walking, you don’t need to move the cursor more to get to a distant location if you aren’t in a hurry.

[image: Tip] You can even use the Walk tool to walk up and down stairs and ramps. Keep in mind that the highest step you can climb is 22 inches; anything higher creates the “bump” cursor, just like you walked into a wall. Also, if you walk off a high surface, you fall to the surface below. Similarly, if you suddenly can’t move any farther, perhaps you collided with something you can’t see such as a coffee table. (At times like these, we wish SketchUp had cartoon sound effects.)

Using modifier keys in combination with the Walk tool makes SketchUp even more like a video game: 


	To run instead of walk, hold down the Ctrl key (Mac: Option) while you’re using the Walk tool with your mouse. This may be useful if you’re trying to simulate what it’d be like if a werewolf were chasing you through your model.

	To make the Walk tool change your eye height or move sideways, use the Shift key. To move straight up like you’re growing, hold down the Shift key while you move your mouse up. To get shorter, hold down Shift and move your mouse down. To move sideways like a crab, hold down Shift and move your mouse left or right.

	To disable collision detection so that you can walk through walls, hold down the Alt key (Mac: Command). Burglars find this handy for entering models without breaking any windows.






 
Stopping to look around

[image: 9781119617938-ma042] Look Around is the third tool in SketchUp that’s dedicated to exploring your model from the inside. If using Position Camera is like swooping in to stand in a particular spot and Walk is like moving around while maintaining a constant eye height, Look Around is like turning your head while standing in one spot. It’s pretty well named, we think; it does exactly what it says.

Using Look Around is so simple it hardly merits these steps: 

	Choose Camera ⇒ Look Around.

	
Click and drag around in the modeling window to turn your virtual head.

Don’t move too fast, or you’ll strain your virtual neck.



[image: Warning] Be sure to only click and drag. If you use the Zoom, Pan (H), or Orbit tools while looking around, it can mess up your view something fierce.

[image: Tip] When you’re using any of the navigation tools, right-click to access any other navigation tool; this makes switching between them a little easier.

When you use the Look Around tool with the Field of View tool discussed in the next section, you get a pretty darned realistic simulation of what it’d be like to stand in your model.


 
Setting your field of view

Field of view is how much of your model you can see in your modeling window at one time. Imagine your eyesight kind of like a cone, with the pointy end pointing at your eyes and the cone getting bigger as it gets farther away from you. Everything that falls inside the cone is visible to you, and everything outside the cone isn’t.

If you increase the angle of the cone at the pointy end, the cone gets wider, and you see more of what’s in front of you. If you decrease the angle, the cone gets narrower, and you see less; see Figure 11-3.



[image: Snapshots of widening the field of view, the more you can see.] 
FIGURE 11-3: The wider your field of view, the more you can see.






[image: Tip] You can only change the field of view when in Perspective view mode, but the setting will be remembered if you then switch to Parallel view mode.

Measured in degrees, a wide field of view means that you can see more of your model without having to move around. The bigger the angle, the more you can see. A wide field of view comes in handy when you’re inside a SketchUp model because working on a model you can’t see is hard.

It’s a good idea to fiddle with your field of view before walking around inside your model. Follow these steps to do so: 

	
Choose Camera ⇒ Field of View (Web: Search for FOV).

Notice that the Measurements box in the lower-right corner of your modeling window says Field of View and that the default value is 35 degrees. This means that you currently have a 35-degree cone of vision, which is kind of narrow.


	
Type 60 and press Enter.

Your field of view increases, and you now have a wider view of your model. The trade-off is that you see more distortion at the edges of your modeling window as more information is displayed in the same amount of space.



[image: Tip] A good guideline for setting your field of view is to strike a balance between quantity and quality; a wider view always means more distortion. For views of the outside of something, try a field of view of 35 to 45 degrees. For interior views, you can increase the field of view to 60 or 70 degrees.

[image: Technical Stuff] If you know something about photography, you can express field of view in millimeters, just like you’re using a camera lens. Typing 28mm gives you a wide-angle view, as if you’re looking through a 28mm lens versus a 50mm (standard) or 150mm (telephoto) lens. For people who think about field of view in these terms, this option can be a lot more intuitive than trying to imagine cones of vision.





Taking the Scenic Route

Wouldn’t it be great if you could save a particular view of your model? And wouldn’t it be even greater if that view could also save things like styles and shadow settings? What if you could come back to any of these saved views by clicking a button on your screen? What if this whole paragraph were just a series of questions? What if there were no rhetorical questions?

SketchUp scenes are (you guessed it) saved views of your model, except that scenes can save much more than just camera positions.

[image: Remember] Although scenes don’t get a lot of space in this book (they don’t even get their own chapter), scenes are an incredibly important feature in SketchUp for several reasons: 


	Scenes can save you hours of time. Returning to exactly the right view with Orbit, Zoom, and Pan isn’t always easy. Sometimes a view involves shadows, styles, sections (you read about those later in this chapter in “Mastering the Sectional Approach”), and even hidden groups and components. Setting up everything the way you need it, every time you need it, can be a pain. It’s not that SketchUp’s hard; it’s just that you have a lot of different ways to view your model. Making a scene enables you to apply dozens of settings with a click of your mouse.

	Scenes are by far the most effective way to present your model. Saving a scene for each point that you want to make in a presentation allows you to focus on what you’re trying to say. Instead of fumbling around with the navigation tools, turning on shadows, and making the roof visible, you can click a button to transition to the next scene (which you’ve already set up exactly the way you want). Figure 11-4 shows a set of scenes that were created to present a house designed for a dog.

[image: Schematic illustration of showing the very specific views, create scenes.] 
FIGURE 11-4: To show very specific views, create scenes.







	Scenes are the key to making animations. You make animations by creating a series of scenes and telling SketchUp to figure out the transitions between them. The process, explained in later sections, is as simple as clicking a button.

	Scenes help you compare design scenarios. One of the most important things that scenes remember is which groups and components are visible and which ones are hidden. So, if you want to compare the layout of a room with one set of furniture versus another, simply hide one furniture group and create a scene. Then unhide it, hide the other, and create a different scene.



After you get used to scenes, you’ll find yourself using them all the time. Here are some of the most common uses for scenes: 


	Showing shade conditions for the same area at different times of the day. See Chapter 10 for details about shadow studies.

	Saving scenes for each floor plan, building section, and other important views of your model.

	Building a walkthrough or flyover animation of your design.

	Creating scenes that show several views of the same thing with different options (the pointy roof or the flat one, madam?).

	Demonstrating change over time by showing or hiding a succession of components. Chapter 5 is all about components.

 
Creating scenes

Before you start making a scene, know this: Making a scene in SketchUp is not like taking a snapshot of your model; neither is it like an unruly child in a supermarket. If you create a scene to save a view, continue working on your model, and then return to that scene, your model doesn’t go back to the way it was when you created the scene. The camera position will be the same, and the settings will be the same, but your geometry will show the revised configuration. This is a pretty important concept, and one that makes using scenes so powerful.

[image: Remember] A scene is just a set of view settings, which means that they’re automatically updated every time you edit your model. You can make some scenes and use them all the way through your process, from when you start modeling to when you present your design to the president. Or to your mother.

Creating scenes is a simple process. The basic idea is that you add a scene to your SketchUp file whenever you have a view you want to return to later. You can always delete scenes, so there’s no downside to using lots of them. Follow these steps to make a new scene: 

	
Open the Scenes panel.

(Web: Manage scenes in the View panel using the movie clapboard icon on the right toolbar. You can also search for Add Scene.)

When the Scenes panel first opens, it doesn’t look like there’s much to it. Expanding it by clicking the Show Details button in the upper-right corner reveals more options, but don’t worry about that right now. (Web: The scene details are available by clicking the little arrow that appears when you mouse over a scene name.)


	
Set up your view however you want.

Navigate around until you’re happy with your point of view. If you want, use the Shadows and Styles panels to change the way your model looks.


	
Click the Add Scene button to make a new scene with your current view settings.

A new scene is added to your SketchUp file. If this is the first scene you’ve created, it’s called Scene 1, but you can give it a more meaningful name, as explained later in this chapter. As shown in Figure 11-5, the scene appears in two places: 


	As a tab at the top of your modeling window (Desktop only)

	As an item in the Scenes panel, right below the Add Scene button




[image: Tip] When you’re creating a scene that shows an eye-level view of a building — whether it’s an interior or an exterior view — there’s a quick, easy step you can take to make the scene look 500 percent better: Choose Camera ⇒ Two-Point Perspective (Web: Two-Point Perspective is available in the Scenes panel) to make all the vertical edges in your model appear vertical in the view. Doing so removes the unprofessional, distorted effect that’s the hallmark of improperly wielded 3D modeling software.



[image: Snapshot of a scene appearing in two places.] 
FIGURE 11-5: A scene appears in two places.






[image: Remember] Nothing is generated outside SketchUp when you add a scene; it’s not like exporting a JPEG or a TIFF. Scenes are just little bits of programming code that “remember” the view settings in effect when you create the scene. Scenes also don’t add much to your file size, so you don’t have to worry about using too many of them.
 



Moving from scene to scene

Activate a scene you’ve added earlier by doing one of three things: 


	Double-click the name (or thumbnail image) of the scene in the Scenes panel. (Web: Just one click will do.)

	Click the tab for that scene at the top of the modeling window (Desktop only).

	Right-click any scene tab and choose Play Animation to make SketchUp automatically flip through your scenes. Choose Play Animation again to make the animation stop. (Web: Use the Play icon in the Scenes panel.)



[image: Tip] Notice how the transition from one scene to the next is animated? You don’t have to do anything special to make this happen; it’s something SketchUp automatically does to make things look better (and ultimately, to make you look better).



[image: Tip] WHEN SCENES AND STYLES COLLIDE
 
Sooner or later, you’ll be presented with the Warning — Scenes and Styles dialog box shown here. It pops up whenever you try to create a scene without first saving the changes you’ve made to the style applied to your model. In other words, SketchUp tries to help by reminding you to keep styles in mind while you work with scenes. (The first part of Chapter 10 is all about styles, if you need a refresher.)

This warning dialog box gives you three options; here’s some guidance on which one to choose: 


	Save as a New Style: This option adds a new style to your In Model styles library. When you come back to this scene, it looks exactly the way it did when you created it. Choosing this option is the safest way to proceed because it can’t affect any other scene.

	Update the Selected Style: Choose this option only if you know what effect updating the style will have on the other scenes in your model. If the style you’re updating is applied to any of them, you’ll affect the way they look. In models with lots of scenes and styles, updating a style can have big implications.

	Do Nothing to Save Changes: This option creates a scene with your current style applied, completely ignoring any changes you may have made to that style. When you come back to this scene, it looks different than it did when you created it. Only choose this option if you really know what you’re doing or if you enjoy doing the same thing more than once.




[image: Snapshot of saving the new styles that are created.] 







You can adjust the way SketchUp transitions between scenes, which is handy for customizing your presentations. Follow these steps to access these settings: 

	
Choose Window ⇒ Model Info.

You can also select View ⇒  Animation ⇒  Settings. (Web: Animation settings are in the Scenes tab.)


	
On the left side of the Model Info dialog box, choose Animation.

The Animation settings panel in the Model Info dialog box isn’t very complicated, but it can make a huge difference in the appearance of your scene-related presentations.


	
In the Scene Transitions area, set how SketchUp transitions from one scene to another.

These settings apply to both manual (clicking a page tab) and automatic (playing an animation) scene transitions: 


	Enable Scene Transitions: Clear this check box to make SketchUp change scenes without animating the transitions between them. You probably want to do this if your model is so complex (or your computer is so slow) that animated transitions don’t look good.

	Seconds: If you’ve selected the Enable Scene Transitions check box, the number of seconds you enter here indicates the time SketchUp takes to transition from one scene to the next. If you’re “moving the camera” very far between scenes, bump up the transition time so that your audience doesn’t get sick. Three seconds is a good compromise between nausea and boredom.



[image: Tip] If you’re presenting an incomplete model (perhaps you’ve thought about the garage and the living room, but nothing in between), it can be helpful to turn off scene transitions. That way, your audience won’t see the things you haven’t worked on when you click a tab to change scenes. It’s sneaky, but effective.


	
In the Scene Delay area, set the length of time SketchUp pauses on each scene before it moves to the next one.

If you want the presentation to seem like you’re walking or flying, set this to 0. If you want time to talk about each scene in your presentation, bump this setting up a few seconds.


 

MAKING WALKTHROUGHS
 
A really great way to use scenes is to pretend you’re walking or flying through your model. By setting up your scenes sequentially, you can give a seamless tour without messing around with the navigation tools. This setup is especially handy when you need to walk and talk at the same time.

Here are some tips that can help you to simulate a person walking or flying through your model with scenes: 


	Adjust your field of view. For interior animations, make your camera “sees” a wider area by setting your field of view to 60 degrees. For exterior views, try a field of view that’s between 30 and 45 degrees. See the section “Setting your field of view” earlier in this chapter.

	Make sure that your scenes aren’t too far apart. Instead of racing through a room like it’s on fire, don’t be afraid to add more scenes. Your audience will thank you by not throwing up on your conference table.

	Add scenes at equal distance intervals. Because SketchUp lets you control the scene transition timing only for all your scenes at once, it’s best to make sure that your scenes are set up about the same distance apart. If you don’t, your walk-through animations will be jerky and strange.

	Don’t forget the animation settings in the Model Info dialog box. Set the scene delay to 0 seconds so that your animation doesn’t pause at every scene. For a normal walking speed, set your scene transitions so that you move about 5 feet per second. If your scenes are about 20 feet apart, set your scene transition time to 4 seconds. This gives your audience time to look around and notice things. For flying animations, pick a scene transition time that looks good.

	Slide around corners. When you set up a walking animation, you have an easy, reliable way to turn corners without seeming too robotic. The method is illustrated in the following figure. Basically, the trick is to add a scene just short of where you want to turn — in this case, a few feet ahead of the doorway. The key is to angle your view into the turn slightly. Set up your next scene just past the turn, close to the inside and facing the new view. This technique makes it seem like you’re turning corners naturally.




[image: Schematic illustration of sliding around the corners.] 








Modifying scenes after you make ’em

After you create a whole bunch of scenes, you inevitably need to fiddle with them in some way. After all, modifying something is almost always easier than making it all over again, and the same thing holds true for scenes. Because your SketchUp model will change a million times, understanding how to make changes to your existing scenes can save you a lot of time in the long run.

[image: Warning] Certain aspects of the scene-modification process can get a little tricky. This is kind of surprising, given how simple the rest of working with scenes can be. You deal with a lot of complexity when working in SketchUp, and this is just one of the places where that complexity rears its ugly head. The upshot: Pay special attention to the section on updating scenes and don’t worry if you take a little while to figure things out. It happens to the best of us.
 
Reordering, renaming, and removing scenes

Making simple modifications to scenes, such as reordering, renaming, and removing them, is easy. You can accomplish each of these in two ways: You either right-click a scene tab at the top of your modeling window or use the Scenes panel menu (click the menu arrow in the upper right); see Figure 11-6.

Here’s how to reorder, rename, or remove scenes: 


	Reordering scenes: You can change the order in which scenes play in an animation. If you’re using scenes, you need to do this often — trust us. Use one of the following methods: 
	Right-click the tab of the scene you want to move (in the modeling window) and choose Move Right or Move Left.

[image: Snapshot of modifying the scenes by right-clicking scene tabs or by using the Scenes panel.] 
FIGURE 11-6: You can modify scenes by right-clicking scene tabs or by using the Scenes panel.







	In the expanded Scenes panel, click the name (or thumbnail image) of the scene you want to move to select it. Then click the Move Scene Up or Move Scene Down arrow at the top of the panel to change the scene’s position in the scene order.

	Web: Click and drag in the Scenes panel.



	
[image: Remember] Renaming scenes: Give your scenes meaningful names: Living Room, Top View, and Shadows at 5 p.m. are descriptive enough to be useful. Scene 14 lacks a certain je ne sais quoi. Use one of the following methods: 


	Right-click the scene tab and choose Rename.

	[image: 9781119617938-ma038] In the Scenes panel, select the scene you want to rename and type something into the Name field below the list. If you don’t see the Name field, click the Show Details button in the upper right. If you’re feeling really organized, go ahead and give the scene a description too; more information never hurts.

	Web: Select and type in the Scenes panel.



	
Removing scenes: If you don’t need a scene anymore, feel free to delete it. However, if you have a scene that you don’t want to appear in animations, you don’t have to get rid of it. Use one of the following methods to remove a scene: 


	Right-click the scene tab and choose Delete to get rid of it permanently.

	In the Scenes panel, select the scene you want to ax and click the Delete button.

	Web: Select in the Scenes panel and then click the trash-can icon.



To exclude a scene from animations without getting rid of it, select its name (or thumbnail) and clear the Include in Animation check box.





 
Working with scene properties

Okay. Turn off the television. Send the kids outside to play. Do whatever you need to do to concentrate because wrapping your head around the concept of scene properties isn’t altogether straightforward. We do our best to explain it.

Basically, a scene is just a collection of saved viewing properties. Each of these properties has something to do with how your model looks: 


	Camera Location: Camera Location properties include the camera position, or viewpoint, and the field of view (discussed earlier in this chapter).

	Hidden Objects: Objects are groups and components. This means each scene can remember which groups or components are hidden and which are visible. This is probably the easiest way to use scenes to control visibility.

	Hidden Geometry: Hidden Geometry includes the individual edges and faces (within groups and components) which you may have designated as hidden.

	Visible Tags: Visible Tag properties keep track of the visibility of tags in your model. Using tags to control visibility takes a few more clicks than simply hiding individual groups and components — check out Chapter 7 — but for a while this was the primary way to control visibility with scenes. And it’s still a good tactic if you’ve been aggressively organizing your model with tags.

	Active Section Planes: Active Section Plane properties include the visibility of section planes and whether they’re active. We talk about sections in the last part of this chapter.

	Style and Fog: Style and Fog properties are all the settings in the Styles and Fog panels, and there are a lot of them. (See Chapter 10.)

	Shadow Settings: Shadow Settings properties include whether shadows are turned on and the time and date for which the shadows are set. They also include all the other settings in the Shadows panel.

	Axes Location: Axes Location properties are very specific. They keep track of the visibility, location, and orientation of the main red, green, and blue axes in your modeling window. It’s sometimes useful to move the axes around when you’re working, such as when you’re working with a rotated street grid in an urban-scale model.



[image: Remember] Here’s the tricky part: Scenes can save (remember) any combination of the preceding properties — it’s not an all-or-nothing proposition. After the full impact of this information soaks in, you’ll realize that this means that scenes are much more powerful than they first appear.

[image: Tip] By creating scenes that save only one or two properties (instead of all seven), you can use scenes to do some pretty nifty things. Here are three of our favorites: 


	Create scenes that affect only your camera location, allowing you to return to any point of view without affecting anything else about the way your model looks (such as styles and hidden geometry).

	Create scenes that affect only styles and shadows, letting you quickly change between simple and complex (hard on your computer) display settings without affecting your camera location.

	Create scenes that have different combinations of Hidden Objects to look at design alternatives without changing your model’s style and camera location.



The key to working with scene properties is the expanded Scenes panel, visible in Figure 11-7. (Web: These properties are available by clicking the arrow that appears when you mouse over a scene name.) Although this panel is pretty simple, folks who understand it are few and far between. Prepare to join the informed minority.

Follow these steps to set which properties a scene saves: 

	
In the Scenes panel, select the scene whose properties you want to fiddle with.

You don’t have to view this scene when you edit it; you can edit properties for any scene at any time.


	[image: 9781119617938-ma038] If not already expanded, click the Show Details button in the upper-right corner of the Scenes panel.

[image: Snapshot of choosing the scene properties to save in the expanded Scenes panel.] 
FIGURE 11-7: Choose which scene properties to save in the expanded Scenes panel.







	
Select the check boxes next to the properties you want to save.

That’s it. You don’t have to click Save to make your changes stick. A little anticlimactic, no?



[image: Tip] One terrific use of scene properties is to create scenes that help you show off different iterations (versions) of your design. You do this by using Tags or Outliner to turn off and on the visibility of individual groups and components, and then creating a scene to capture that iteration.


 
Updating scenes

If you want to update (make changes to) an existing scene, you have a couple options: 


	Update all the scene’s properties at once, which is a piece of cake.

	Update the scene’s properties selectively, which isn’t quite as simple. Read on for both sets of instructions.



[image: Warning] After you update a scene, you can’t use Undo to return the scene to the way it was. Instead, save your SketchUp file right before you update a scene and choose File ⇒ Revert if you don’t like the results. (Web: There’s revision history on your SketchUp file, so you can always access a copy of your file from a few minutes ago in the Home tab.) For more information on accessing previous versions. see “SketchUp Crashed, and You Lost Your Model” in Chapter 14.
 
UPDATING ALL THE SCENE PROPERTIES AT ONCE

The simplest way to modify a scene is to not worry about individual properties. If all you want to do is update a scene after you make an adjustment to the appearance of your model, you’re in luck. Follow these steps: 

	
Click the tab of the scene you want to update.

The tabs are at the top of the modeling window.

(Web: Select the scene and then click the update icon/button at the bottom of the tab.)


	Make whatever styles, shadows, camera, or other display changes you want to your model.

	
Right-click the current scene tab and choose Update.

[image: Warning] Be careful not to accidentally double-click the tab, or you’ll reactivate the scene and lose all the changes you made. However, after you update the scene, the new scene properties replace the old ones, and you’re home free.




 
UPDATING SCENE PROPERTIES SELECTIVELY

Here’s where things get complicated. At times in your SketchUp life, you’ll want to update a scene without updating all its properties.

[image: Warning] When you update scenes selectively, you make changes that you can’t see immediately, which means disaster might strike. Save As your SketchUp file to a different name, such as adding –1 to the end of it, before you update more than one scene at a time for when something awful happens.

Maybe you’ve used scenes to create a tour of the sunroom you’re designing for a client, and you want to change the shadow settings to make your model look brighter. You have 30 scenes in your presentation, and your meeting’s in 5 minutes. You don’t have time to change and update all 30 scenes one at a time. What to do? In the desktop version, you can follow these steps: 

	
Adjust the Shadow properties to where you want them to be for all the scenes you want to update.

Although this example deals with shadows, this same method applies to any scene properties changes you want to make.


	
In the Scenes panel, select all the scenes you want to update.

Hold down the Shift key to select a group of consecutive scenes. Hold down Ctrl (Mac: ⌘  ) to select noncontiguous scenes.


	
[image: 9781119617938-ma037] Click the Update Scenes button in the Scenes panel.

The Scene Update dialog box appears, as shown in Figure 11-8.


[image: Snapshot of clicking the update button in the upper left of the Scenes panel where you can choose which scene properties to update.] 
FIGURE 11-8: When you click the Update button in the upper left of the Scenes panel, you can choose which scene properties to update (or not).







	
Select the Shadow Settings check box and click the Update button.

If all you want to update are the Shadow Settings, make sure that only that check box is selected. More generally, you’d select the check box next to each of the properties you want to update. All the selected scenes are updated with those new properties, and all the properties whose check boxes are clear remain unchanged.


 








Mastering the Sectional Approach

Software like SketchUp has a funny way of providing moments of perfect simplicity, moments when you sit back, scratch your head, and think “That’s it? That’s all there is to it?”

Sections in SketchUp offer one of those moments. To put it simply, sections are objects that cut away parts of your model so you can look inside. However, the sections don’t actually split or otherwise alter a model’s geometry. A section is temporary and easily hidden or removed, so that you can see your whole model again just as easily as you created the cutaway.

You place sections wherever you need them, use them to create views you couldn’t otherwise get, and then delete them when you’re done. When you move a section plane, you get instant feedback; the cut view of your model moves, too. If you want to get fancy, you can embed sections in scenes and even use sections in animations. Sections are the icing on the SketchUp cake: easy to use, incredibly important, and impressive as all get-out.

People use sections for all kinds of things: 


	Creating standard orthographic views (such as plans and sections) of buildings and other objects

	Making cutaway views of complex models to make them easier to understand

	Working on the interiors of buildings without moving or hiding geometry

	Generating sectional animations with scenes

 
Cutting plans and sections

The most common use for sections is to create straight-on, cut-through views of your model. These views often include dimensions and are typical of the drawings that architects make to design and explain a space.

Straight-on, cut-through views are useful for the following reasons: 


	They’re easy to read.

	You can take measurements from them (if they’re set to a scale).

	They provide information that no other drawing type can.



[image: Remember] The following terms (illustrated in Figure 11-9) can help you create different views of your model more easily: 


	Plan: A planimetric view, or plan, is a top-down, two-dimensional, nonperspective view of an object or space. Put simply, a planimetric view is every drawing of a house floor plan you’ve ever seen. You generate a plan by cutting an imaginary horizontal slice through your model. Everything below the slice is visible, and everything above it isn’t.

	Section: Not to be confused with Sections (the SketchUp feature), a sectional view, or section, is a from-the-side, 2D, nonperspective view of an object or space. You make a sectional view by cutting an imaginary vertical slice through your model. Just like in a plan view, everything on one side of the slice is visible, and everything on the other side is hidden.




[image: Schematic illustration of a plan which is a horizontal cut, whereas a section is a vertical one.] 
FIGURE 11-9: A plan is a horizontal cut, whereas a section is a vertical one.






You cut plans and sections by adding section planes to your model. These are a little abstract because nothing like them exists in real life. In SketchUp, section planes are objects that affect the visibility of certain parts of your model. When a section plane is active, everything in front of it is visible and everything behind is hidden. Everywhere a section plane cuts your model, a slightly thicker section cut line appears.

[image: Tip] Open the Section toolbar by choosing View ⇒ Toolbars ⇒ Section. (Mac: The Section Plane tool is in the Large Tool Set, which you can activate by choosing View ⇒ Tool Palettes ⇒ Large Tool Set; Web: Find it nested under Tape Measure, or by searching.)
 

CUTTING LIKE AN ARCHITECT
 
In architecture, the convention is to cut plans at a height of 48 inches, meaning that the imaginary horizontal slice is made 4 feet above the floor surface. This ensures that doors and most windows are shown cut through by the slice, whereas counters, tables, and other furniture are below it, and thus are fully visible. You can see what we mean in Figure 11-9. These details are important when you try to explain a space to someone. After all, architectural drawings are 2D abstractions of 3D space, and every little bit of clarity helps.

When it comes to architectural sections (as opposed to Sections, the SketchUp feature), there’s no convention for where to cut them, but you should follow a couple rules: 


	Never cut through columns. If you show a column in a section, it looks like a wall. This is bad because sections are supposed to show the degree to which a space is open or closed. You can walk around a column, but you can’t walk through a wall (at least we can’t).

	Try your best to cut through stairs, elevators, and other vertical circulation. Showing how people move up and down through your building makes your drawings a lot more readable, not to mention interesting. See Figure 11-9 for an example.



The following steps explain how to create a section plane: 

	
Choose Tools ⇒ Section Plane to activate the Section Plane tool.

[image: 9781119617938-ma043] You can also activate Section Plane by choosing its icon from the Large Tool Set (or if you prefer, the Section toolbar on SketchUp for Windows).


	
Move the Section Plane tool around your model.

Notice how the orientation of the Section Plane cursor (which is quite large) changes to be coplanar to whatever surface you hover over.


	
After you figure out where you want to cut, click once to add a section plane.

To create a plan view, add a horizontal section plane by clicking a horizontal plane like a floor. For a sectional view, add a vertical section plane by clicking a wall or other vertical surface. You can, of course, add section planes wherever you want; they don’t have to be aligned to horizontal or vertical planes. Figure 11-10 shows a section plane being added to a model of a house.

In the desktop version, as soon as you place a section plane, you’ll be prompted to give it a name. We think it's a good idea, since a name makes it easier to find your scene in Outliner. You can also assign a symbol to display with your section plane.


	[image: 9781119617938-ma013] Choose the Move tool.

	
Move the section plane you just added by clicking it once to pick it up and again to drop it.

You can slide your section plane back and forth in only two directions so that the section plane remains perpendicular to its cutting plane. When you’re deciding where to locate your cut, the nearby sidebar “Cutting like an architect” offers helpful pointers.

After you add a section plane and move it to the desired location, you can rotate and even copy it, just like any other object in your model. The section plane never affects your geometry — just the way you view it.

[image: Technical Stuff] Chapter 9 covers 3D printing and explains how a 3D print is built up by repeatedly printing a cross-section, moving the cutting plane, printing again, and so on. If you move a cutting plane in tiny increments then the heavy model lines like the ones in Figure 11-12 show what a 3D printer would print at each cutting-plane location.


	
[image: 9781119617938-ma014] If you need to rotate your section plane, select it and use the Rotate tool.

Why rotate a section plane? In certain circumstances, rotating a section plane (instead of creating a brand-new one) can help explain a complex interior space. Showing a plan view becoming a sectional one is a powerful way to explain architectural drawings to an audience that doesn’t understand them.

Read more about the Rotate tool in Chapter 3.


[image: Schematic illustration of adding a section plane wherever you want one and then move it into position.] 
FIGURE 11-10: Add a section plane wherever you want one and then move it into position.







	
To make a new section plane by copying an existing one, use the Move or Rotate tool to do it the same way you’d make a copy of any other SketchUp object.

Chapter 3 explains these basic actions in detail.

Copying section planes is a great way to space them a known distance apart. Spacing sections planes consistently can be trickier if you use the Section Plane tool to keep adding new ones instead.

Figure 11-11 shows moving, rotating, and copying a section plane.





[image: Schematic illustration of moving, rotating, and copying a section plane.] 
FIGURE 11-11: Moving, rotating, and copying a section plane.






When the section plane you’ve added is in position, you’re ready to control how it affects visibility in a number of other ways. See the following sections for details.
 
Controlling individual section planes

You can control the way section planes behave by right-clicking them to bring up a context menu, as shown in Figure 11-12. You see examples of what the following options do in the same illustration: 


	Reverse: This option flips the direction of the section plane, hiding everything that was previously visible, and revealing everything that used to be behind the cut. Use this when you need to see inside the rest of your model.

	
[image: Remember] Active Cut: The active cut is the section plane that’s actually cutting through your model; others are considered inactive. If you have more than one section plane, use Active Cut to tell SketchUp which one should be active. If you have only one section plane but can’t see the cut, check whether the cut is active.

[image: Technical Stuff] You can have more than one active section plane in your model at a time, but doing so requires that you nest, or embed, each section plane in a separate group or component. You can achieve spiffy effects with this technique, but explaining how they work in detail is beyond the scope of this book. You can read all about groups and components in Chapter 5.


	Align View: When you choose Align View, your view changes so that you look straight on at the section plane. You can use this option to produce views like the ones described in “Getting different sectional views” later in this chapter.

	Create Group from Slice: This option doesn’t have much to do with the other choices in this context menu; it’s really a modeling tool. You can use the Create Group from Slice command to do exactly what it says: Create a group from the active slice or section plane. The command is handy for creating filled-in section cuts for final presentations.




[image: Schematic illustration of right-clicking a section plane gives you some options.] 
FIGURE 11-12: Right-clicking a section plane gives you some options.








Setting section-plane visibility

[image: Remember] If you want to control the visibility of all your section planes at once, a couple menu options can help. Use both of these toggles in combination to control how section cuts appear in your model. These two options, shown on the View menu, are illustrated in Figure 11-13: 


	Section Planes: This choice toggles the visibility of section-plane objects without affecting the section cuts they produce. More simply, deselecting Section Planes hides all the section planes in your model, but doesn’t turn off the section cut effect, as shown in the middle image in Figure 11-13. This view is how you probably want to show most of your sectional views, so this toggle is pretty important.

	Section Cuts: This option toggles the section cut effect on and off without affecting the visibility of the section-plane objects in your model. This choice is sort of the opposite of Section Planes, in the previous point, but it’s every bit as important.







Getting different sectional views

Using section planes, you can create a couple useful and impressive views of your model without much trouble. The second builds on the first, and both are shown in Figure 11-14. A section perspective (left) is a special view of a three-dimensional space. The second type, an orthographic view (right), is straight on and doesn’t use perspective.



[image: Schematic illustration of a control section plane visibility with Section Planes and Section Cut.] 
FIGURE 11-13: Control section plane visibility with Section Planes and Section Cut.







[image: Schematic illustration of turning on Perspective for a section perspective and choose Parallel Projection to produce an orthographic view.] 
FIGURE 11-14: Turn on Perspective for a section perspective; choose Parallel Projection to produce an orthographic view.






MAKING A SECTION PERSPECTIVE

If you imagine cutting a building in half and then looking at the cut surface straight on while looking inside, you have a section perspective. The section part of the term means that the building has been cut away. The perspective part indicates that objects inside the space seem smaller as they get farther away.

Section perspectives show interior space in a way most people can understand, and section perspectives look incredibly cool, too. To create a section perspective using the Section Plane tool in SketchUp, follow these steps: 

	
Select the section plane you want to use to make a section perspective by clicking it with the Select tool.

When the section plane is selected, it turns blue (assuming that you haven’t changed the default colors in the Styles panel).


	
If the selected section plane isn’t active, right-click it and choose Active Cut.

Active section planes cut through their surrounding geometry. If your section plane is visible but isn’t cutting through anything, it’s not active.


	
Right-click the selected section plane and choose Align View.

This aligns your view so that it’s straight on (perpendicular) to your section plane.


	
If you can’t see your model properly, choose Camera ⇒ Zoom Extents or press Shift+Z.

This zooms your view so that you can see your whole model in the modeling window.




 
GENERATING AN ORTHOGRAPHIC SECTION

Ever seen a technical drawing that included top, front, rear, and side views of the same object? Chances are that was an orthographic projection, which is a common way for 3D objects to be drawn so that they can be built.

Producing an orthographic section of your model is pretty easy; it’s only one extra step beyond making a section perspective. Here’s how to do it: 

	Follow steps 1 through 3 in the preceding section, as though you’re making a section perspective.

	
Choose Camera ⇒ Parallel Projection.

This switches off Perspective, turning your view into a true orthographic representation of your model. If you printed an orthographic view at a specific scale, you could take measurements from the printout.



[image: Tip] To print a plan or section view of your model at a particular scale and you have SketchUp Pro, jump to Chapter 12 to learn about LayOut (Web: Read Chapter 13 to learn about printing to scale).

[image: Tip] Section planes are objects in their own right. The significance of that statement is that the Outliner (see Chapter 7) can be used to find them, rename them, control their visibility, and so on just like any other object. For example, you can set up several section planes showing the plan views of each floor in a multistory building and then use the Outliner to quickly switch between the different plan views.






 
Animating sections with scenes

Combining section views with scenes to create an animation is both a useful and impressive way to show off your model. The basic idea is that you can use scenes to create animations where your section planes move inside your model. Here are a few reasons you may want to use this technique: 


	If you have a building with several levels, you can create an animated presentation that shows a cutaway plan view of each level.

	Using an animated section plane to “get inside” your model is a much classier transition than simply hiding certain parts of it.

	When you need to show the relationship between the plan and section views for a project, using an animated section plane helps to explain the concept of different architectural views to 3D beginners.



Follow these steps to create a basic section animation; a simple example is illustrated in Figure 11-15: 

	
Add a section plane to your model.

For help with this step, see “Cutting plans and sections” earlier in this chapter.


	
Add a scene to your model.

The earlier section “Creating scenes” explains how to add scenes.


[image: Schematic illustration of making a section animation which is a fairly straightforward process.] 
FIGURE 11-15: Making a section animation is a fairly straightforward process.







	
Add another section plane to your model.

You can add another section plane in one of two ways: 


	Use the Section Plane tool to create a brand-new one. This is probably the easiest option, which makes it ideal for beginners.

	Use the Move tool to copy an existing section plane. The earlier section “Cutting plans and sections” introduces this technique.



Make sure that your new section plane is active; if it is, it cuts through your model. If it’s not active, right-click the section plane and choose Active Cut from the context menu.


	
Add another scene to your model.

This new scene remembers which is the active section plane.


	
Click through the scenes you added to view your animation.

You see an animated section cut as SketchUp transitions from one scene to the next. If you don’t, make sure that you have scene transitions enabled: Choose Window ⇒ Model Info and then choose the Animation panel in the Model Info dialog box. Make sure the Scene Transitions check box is selected. (Web: Click the Play icon in the Scenes panel.)



[image: Tip] If you don’t like seeing the section-plane objects (the boxy things with arrows on their corners) in your animation, switch them off by deselecting Section Planes on the View menu. Then you see the section cuts without any ugly rectangles flying around. (Web: You can turn off the section planes by searching for view section planes.)

[image: Remember] The hardest thing to remember about using scenes and section planes to make section animations is this: You need a separate section plane for each scene that you create. That is to say, SketchUp animates the transition from one active section plane to another active section plane. If all you do is move the same section plane to another spot and add a scene, this animation technique won’t work.






  

Part 4

Sharing What You’ve Made

IN THIS PART …

Turn models into professional document sets, presentations, and high-quality images using LayOut, which comes with SketchUp Pro.

Create images and print pages from SketchUp for Web.

Export CAD files from your SketchUp models.

Find and organize community-contributed models in 3D Warehouse. Share your work with others.






Chapter 12

Creating Images, Presentations, and Documents in LayOut

IN THIS CHAPTER

[image: check] Managing pages and layers

[image: check] Inserting and updating SketchUp models

[image: check] Adding graphics

[image: check] Creating labels and dimensions

[image: check] Customizing LayOut with templates and scrapbooks

[image: check] Printing, exporting, or presenting your work



If you’re lucky enough to have SketchUp Pro, you also have LayOut, a separate application for presenting 3D SketchUp models in 2D. LayOut was designed to be easy to use, quick to learn, and tightly integrated with SketchUp. LayOut is the best way to get beautifully composed, high-quality images out of SketchUp Pro. Composing images in SketchUp for Web is straightforward and effective too. If you’re using SketchUp for Web or Schools, skip to Chapter 13.

With all the methods for model styling and scene composition that you learn in Part 3, you’re ready to use LayOut to turn your 3D model into fantastic 2D deliverables. We’ve been going on and on about the benefits of 3D thinking in this book; one of those happens to be that great 3D models make for phenomenal 2D output.

Here are examples of the kind of 2D assets you can make in LayOut: 


	Design packs, presentation boards, and posters

	Construction drawings with scaled views and dimensions

	Higher-quality image exports of your models, with crisper line work

	Storyboards for planning camera shots



LayOut gives you the tools to add company branding, accurate dimensions, shading and hatching patterns, and more — whatever needs to accompany views of your model. You can create presentations that are just about any physical size and export them as PDFs or images to send to other people.

[image: Remember] Best of all, when your design changes in SketchUp, you can easily update your model views in LayOut to reflect the changes. If you make your living designing and presenting ideas in 3D, LayOut can save you boatloads of time.

Although this book can’t dig into all that LayOut can do, this chapter helps you start using LayOut’s key features for presenting your models.



Building a LayOut Document

To help you get your bearings in LayOut, this section helps you put together a LayOut document. Take a deep breath, put a fresh battery in your mouse, and prepare for your presentation-making life to get much easier than it’s ever been.

When you launch LayOut (or each time you start a new LayOut document), you see the Welcome to LayOut dialog box, shown in Figure 12-1. This dialog box offers a number of options: 


	Create new document: The top row of figures shows a number of templates that can be used as a starting point for a new document, which is usually the best way to start. Clicking the More Templates button in the upper right unleashes a veritable herd of template options based on paper type, storyboard, or title block.

	Open an existing file…: The Open File button between the two rows of images launches a generic file selection dialog box where you can browse to any existing file.

	Open a recent file: The bottom row of figures shows preview images of the last three files that you have opened recently; simply click on one to open it again. But wait! There’s more! The slider bar down the right side of the box lets you go even further back in history.

	Files versus Learn: The two buttons on the left side switch between showing the default Files screen and links to additional learning resources, such as the user forums.



[image: Tip] If you start a new file from within the current editing session, SketchUp jumps straight to the expanded template selection dialog box.

[image: Warning] If you close the Welcome to LayOut dialog box without selecting a template, LayOut automatically starts from a generic blank template.

Selecting the More Templates button in the Welcome to Layout dialog box expands all the template options expanded by categories of options. For example, the Letter Landscape template in Figure 12-1 is a Titleblock document set that uses simple sans serif fonts, standard U.S. letter document size, and premade graphics to accompany your work. Other templates are blank pages. The key thing to know is that any template you choose is based on a real-world paper size. Whether you start with a prebuilt template or create your own, the following sections walk you through the basics of creating a presentation in LayOut.



[image: Snapshot of the Welcome to LayOut page.] 
FIGURE 12-1: Welcome to LayOut!






[image: Tip] A LayOut file is effectively a book. It can have a cover and a number of pages, with each page conveying different but related information from one or more SketchUp files. For example, it might show a site plan for a multiunit housing project, pictorial views of the overall project, and interior views and floor plans of individual units. A bit of browsing through the template collection eventually leads to the template that was selected for Figure 12-2: This is a Titleblock template that uses simple serif fonts and a letter landscape format.
 
Customizing a document’s pages and layers

Many LayOut templates have multiple pages and layers, as shown in Figure 12-2. When you use pages and layers together, they give you a lot of control over what appears where in your document: 


	Pages: Your document can have as many pages as you like. In the Pages panel on the right, you can customize the number and sequence of pages. To add a page, click the plus icon. To duplicate a page, click the Duplicate Selected Page icon. To delete a page, click the minus icon. To change the order of the pages, click and drag a page up or down in the sequence.

	
Layers: In LayOut, the layers work like sheets of acetate stacked one on top of another. (This functionality is very different from SketchUp tags, covered in Chapter 7.) In the Layers panel, you can add layers that control what does or doesn’t appear on each page. Two features (which are shown in Figure 12-3) enable you to manage layers: layer visibility (the eye icon) and layer sharing (the single- or double-page icon).

In a template, layers may be locked by default so that you can’t accidentally move things. To customize the template with information, unlock each layer by clicking the little lock icon that appears to the right of the layer’s name.


[image: Snapshot of the pages and layers which enable you to control what appears where in a document.] 
FIGURE 12-2: Pages and layers enable you to control what appears where in a document.










[image: Snapshot of icons control sharing and visibility in LayOut's Layers panel.] 
FIGURE 12-3: In LayOut's Layers panel, icons control sharing and visibility.






To add an element on almost every page, follow these steps: 

	
In the Layers panel, create a new layer or select an existing layer.

[image: Remember] The layer with the little red pencil next to it is your active layer.


	
Click the layer’s sharing icon so that it looks like two pages (not one).

This step shares whatever you add to this layer onto every page in your document.


	
Create an element, such as typing text, drawing a shape, or inserting a SketchUp model or image.

You discover how to add items to a page in the upcoming sections.


	In the Pages panel, select any page on which you don’t want the item to appear.

	
Back in the Layers panel, click the eye icon so that the eye closes and the layer is toggled to its hidden state.

The element becomes hidden on the selected page. In Figure 12-2, notice that Cover Page is selected in the Pages panel. If you want to create a custom cover page, the On Every Inside Page layer should be hidden (its eye is closed).



[image: Remember] In the Layers panel, when a layer is shared among all your pages, you can control the layer’s visibility on the selected page by toggling the eye icon.

Conversely, if you want an element to appear on only one page, follow these steps: 

	In the Pages panel, select the page on which you want the element to appear.

	In the Layers panel, click the plus icon to create a new layer or select a layer that displays elements only on the selected page.

	Click the layer’s sharing icon so that it looks like a single page.

	With the page and layer selected, create the element on the new layer.


[image: Tip] As you create a document, keeping your elements organized with pages and layers can save your sanity. Here are a few tips to help you on your way: 


	To keep track of what each page and layer does, give each one a descriptive name, similar to the names you see in the template shown in Figure 12-2. To name a page or layer, double-click its name, and the name becomes editable.

	To see what layer an element is on currently, select the element and look for the tiny blue dot in the Layers panel. If you select two elements on two different layers, you see two blue dots.

	To change which layer something is on, right-click the element in the LayOut page, choose Move to Layer from the shortcut menu, and select the destination layer for the entity.

	Move several elements from multiple layers to a single layer with Copy and Paste. Copying elements from multiple layers and pasting them pastes them all on the same layer: the active one.




 
Adding and editing text

[image: 9781119617938-ma048] LayOut enables you to add plain old text with the Text tool, and it’s easy to do. Labels and dimensions, covered later in this chapter, have a few whizbang features that regular text does not.

Text boxes in LayOut are classified into two broad types, depending on how you create them: 


	Bounded: If you click and drag with the Text tool, the text box you create is bounded. Any text you enter in it that doesn’t fit isn’t visible, and a little red arrow at the bottom indicates that there’s overflow text. You need to use the Select tool to make the box bigger to show everything that’s inside. Use a bounded text box whenever your text needs to fit into a precise space in your design.

	Unbounded: If you click to place your cursor somewhere on your page instead of creating a text box with the Text tool, the text you create is unbounded. It stays inside a text box, but that text box automatically resizes to accommodate whatever text you put inside it. To turn an unbounded text box into a bounded one, just resize it with the Select tool or choose Text ⇒ Make Bounded.



Naturally, you control things like text size, color, alignment, and font using the Text Style panel (Mac: Window ⇒ Show Fonts). Select the text you’d like to format and choose your desired settings in the panel.

[image: Tip] As you add and edit text in LayOut, here are a few tips to help you along the way: 


	To edit text, double-click a text element with the Select tool. When you’re done, click elsewhere on the page.

	Zoom into your document if you need to add or edit text precisely. See the nearby sidebar “Get zooming” for details.

	Choose Text ⇒ Insert Auto-Text to insert a tag that displays automatically generated text. For example, you can insert page numbers or a company name. To customize the text that appears for a specific Auto-Text tag, choose Text ⇒ Customize Auto-Text, and in the dialog box that appears, select the tag at the top, and type your desired text in the specified area at the bottom. Note that you can access this drop-down list only if you are editing within a text box.



GET ZOOMING
 
Zooming in can help you add and edit document elements precisely, and zooming out helps you check how your overall document looks. Here are four ways to zoom around your document: 


	Roll your scroll wheel to zoom in and out on the page, just like in SketchUp.

	While you’re zoomed in, hold down the scroll-wheel button to pan around.

	To fill your drawing window with the page you’re viewing, choose Scale to Fit (Mac: Zoom to Page) from the Zoom drop-down list in the lower-right corner, near the Measurement box.

	Shift+Z is the shortcut here, just like Zoom Extents in SketchUp.




	On a Mac, choosing Text ⇒ Show Rulers does more than just display ruled increments at the top and side of your drawing window. It also enables extra controls for paragraph spacing and lists: bulleted and numbered. Just double-click text in your document to see the controls appear above the ruler.

 


Inserting SketchUp model views

With every other page-layout program in the universe, the only way to include a view of a SketchUp model is to export that view from SketchUp as an image file and then place it in the layout program. Changing the SketchUp file means going through the whole export-and-place process again. If your presentation includes lots of SketchUp model views, this process can take hours.

[image: Remember] This brings us to LayOut’s raison d’être: Instead of exporting views from SketchUp to get them into LayOut, all you do is insert a SketchUp file. From within LayOut, you can pick the view you like best. You can also use as many views of the same model as you want and choose from the scenes you created while modeling in SketchUp.

LayOut knows when you have modified your SketchUp file. Choose File ⇒ Document Setup  ⇒ References to display the status of each attached SketchUp file. Any that need updating will be highlighted in red. Click the red ones and then click Update to have the SketchUp files updated in all your Layout views.

Better yet, every time you open your Layout file, it will check the status of any referenced SketchUp models. If any of the SketchUp models have been modified, LayOut automatically opens the Document Setup dialog box and highlights in red the ones that have been modified so you can update them.

If you need to pause for a minute to let the time-saving aspects of this feature sink in, we understand.

Follow these steps to insert a SketchUp viewport (model view) into your document: 

	
In SketchUp, create a scene for each view of your model that you want to show in your LayOut document, and when you’re done, save your document.

Take a look at Chapter 11 for a refresher on using scenes. Be sure to give them meaningful names.


	In LayOut, on the Pages panel, select the page where you want to insert a viewport.

	Choose File ⇒ Insert.

	
In the Insert dialog box that appears, find the SketchUp file on your computer that you want to insert and click the Open button.

The Insert dialog box closes, and your SketchUp model is placed on your current LayOut document page.


	
With the Select tool, right-click your viewport, choose Scenes, and then choose the name of the scene you want to appear in this viewport, as shown in Figure 12-4.

[image: Tip] If you don’t see a list of scenes, you probably forgot to save your SketchUp file in step 1. Save your SketchUp file; then right-click your viewport (in LayOut) and choose Update Model Reference.


	
(Optional) Assign a drawing scale to your model view if that’s appropriate.

If the scene you picked in step 5 is an orthographic view (top, front, side) where perspective is turned off, you likely want to show your model at a particular drawing scale. See “Creating scaled orthographic views” later in this chapter for details.


[image: Snapshot of associating a scene from the model with a viewport in LayOut.] 
FIGURE 12-4: Associate a scene from your model with a viewport in LayOut.







	
Use the Select tool to position or resize your model view.

Click and drag to move any element in your document on the page. Click and drag the Rotation Grip (the little blue stick in the center of your image when it’s selected) to rotate. You can resize anything by clicking and dragging any corner.



[image: Tip] If a bright yellow exclamation mark icon appears in the lower-right corner of a viewport, you need to tell LayOut to render that viewport so that it reflects whatever changes you’ve made. Right-click the viewport, choose Render Model from the context menu, and you’re good to go.
 
Repositioning a model view in LayOut

In LayOut, when you’re working inside a model viewport, you’re working in 3D. You can do a couple of things to change your viewport’s point of view: Use the Camera tools or edit scenes with the SketchUp Model panel.

Double-clicking a viewport with the Select tool is a little bit like activating SketchUp from inside LayOut. When you’re in this SketchUp-like mode, the thick blue border around the model viewport becomes a thin blue border. When you’re in this mode, you can change your point of view as follows: 


	Orbit, zoom, and pan around using your mouse, exactly the way you do in SketchUp.

	Right-click the viewport and choose a specific Camera tool from the shortcut menu (Orbit, Pan, Zoom, Zoom Window, Look Around, or Walk).

	On the SketchUp Model panel’s View tab, shown in Figure 12-5, choose an option from the Scene or Standard Views drop-down list.



When you’re done repositioning your model, click outside the viewport. LayOut re-renders the view, and your model goes back to looking nice and crisp.

[image: Tip] As your LayOut model grows, you will find yourself making complex selections and moving things around, just like you do in SketchUp. When this happens, you may want to avoid accidentally double-clicking into the 3D mode of a model viewport. To do this, right-click your SketchUp viewport and choose Lock. Now you can’t manipulate your viewport in any way, which can be desirable as your document gets bigger.


 
Making your models look their best

The SketchUp Model panel (refer to Figure 12-5) contains one of the most important settings in all of LayOut: the Line Scale field. The number you put into the Line Scale field tells LayOut how thick to draw the thinnest lines in your viewport. Entering 2 yields edges that are 2 points wide. Typing 0.25 makes your edges a quarter-point wide — much thinner and (in many cases) much nicer. Figure 12-6 illustrates how adjusting this setting changes how a model looks.



[image: Snapshot of SketchUp Model panel in LayOut.] 
FIGURE 12-5: The SketchUp Model panel in LayOut.







[image: Schematic illustration of the Line Scale field to make the models look their very best.] 
FIGURE 12-6: Use the Line Scale field to make your models look their very best.






[image: Remember] Changing the Line Scale number is the single best thing you can do for your models in LayOut. The line weights you use depend entirely on the size of your viewports, the paper size you’re working on, and the complexity of your drawings. Try to avoid making anything look too wispy or too chunky; the key here is readability.

[image: Technical Stuff] If the style that’s applied to your viewport has Profiles enabled, some edges look thicker. To change the thickness of Profiles in a viewport, edit the style that defines the Profiles in the SketchUp model. Profile thickness is always a multiple: A setting of 4 produces Profiles that are four times as thick as regular edges. Check out Chapter 10 for more about styles and how to edit them.

How LayOut renders a model can also have a big effect on your model’s appearance. You control the rendering method in the SketchUp Model panel (see Figure 12-7). In the lower right, a drop-down list enables you to select Vector, Raster, or Hybrid. Here’s how selecting each option affects how your model is rendered (and check out Figure 12-7 to see examples of each rendering style): 


	Raster: Renders your viewport as an image comprising many, many little dots. If your model is rendered as a raster, it can display sketchy styles, shadows, and other effects that make it look like it does in SketchUp. On the other hand, printing or exporting a raster image at large sizes involves truckloads of pixels, and that can make LayOut choke. See the nearby sidebar “Balancing performance and quality” to find out more.

	Vector: Renders your selected model viewport as a vector image. Lines appear smooth and crisp, but things like shadows, textures, and sketchy styles don’t appear. Also, choosing vector rendering for really complex models can take a long time to process.

	Hybrid: Combines clean vector lines with rich raster faces, shadows, and other goodies. Behind the scenes, LayOut renders the model twice — once as a vector and once as a raster. Hybrid rendering takes even longer than vector rendering but produces very nice results. If you have time, try hybrid rendering to see how it looks.



[image: Tip] Try raster rendering for models with Sketchy Edges styles and for any model with a lot of geometry. Select hybrid or vector rendering for any plans, sections, or other views that feature a lot of line work but not materials, and use hybrid rendering when you want to preserve materials you’ve applied to your model and shadow settings you’ve composed.







BALANCING PERFORMANCE AND QUALITY
 
The more complex your SketchUp model is, the longer it takes to render in LayOut. If LayOut is sluggish, adjusting a couple of rendering settings might put a little spring in its step. Try the following: 


	Select File ⇒ Document Setup ⇒ Paper. From the Display Resolution drop-down list, select Low, which corresponds to a resolution of 72 ppi (pixels per inch).

	On the SketchUp Model panel, clear the Auto check box in the lower left. Doing so tells LayOut not to render a model viewport each time you edit it. Instead, LayOut waits until you click the Render button (in the SketchUp Model panel) before it does any rendering.




[image: Schematic illustration of choosing a rendering method for each viewport in the LayOut document.] 
FIGURE 12-7: Choose a rendering method for each viewport in your LayOut document.







Creating scaled orthographic views

The first step in creating a dimensioned drawing is to turn your viewport into a 2D orthographic view of your model. (See Chapter 11 for an introduction to orthographic views.) Although you can use the controls in the SketchUp Model panel to accomplish this, a better way is to go back to the model and create a scene.

Follow these steps to save an orthographic scene in your SketchUp model and assign it to a viewport in LayOut: 

	Open the model in SketchUp.

	
If you plan to have an active section cut in your view, add it to your model (if you haven’t already).

Chapter 11 explains how to make section cuts.


	In SketchUp, choose Camera ⇒ Parallel Projection; then choose Camera ⇒ Standard Views ⇒ Top (or any other option from this list except Iso).

	Zoom and pan (but don’t orbit) until you have the view you want and then open the Scenes utility panel, and click the + button.

	Save your model and close it.

	In LayOut, right-click the viewport and choose Update Model Reference.

	Right-click your model viewport and go to Scenes to choose your new scene to associate it with the viewport.


Now that you have an orthographic view of your model, you can assign a scale to it. Here’s everything you need to know about that: 


	Assign a scale using the Scale drop-down list in the Camera section of the SketchUp Model panel. Don’t forget to select the viewport you’re working on first. Alternatively, with the Select tool, right-click your viewport, choose Scale, and then choose a suitable scale from the list that appears, as shown in Figure 12-8.

	
[image: Tip] Create your own scales if you want. Need a scale that doesn’t appear in the default list? Choose Edit ⇒ Preferences (Mac: LayOut ⇒ Preferences) to open the Preferences dialog box; then click Scales on the left. Click the + button to add a new scale to the list. Scales you add are available for any LayOut file you’re working on.


	Make sure Preserve Scale on Resize is selected. After you assign a scale to a viewport, you probably want to manually resize its boundaries with the Select tool. Before you do, make sure the Preserve Scale on Resize check box (in the SketchUp Model panel) is selected. If it’s not, you change the scale of your model view when you try to resize its viewport.



[image: Remember] LayOut lets you assign a scale to any old view, but that doesn’t matter. Drawing scales apply only to nonperspective, straight-on views of your model.


[image: Snapshot of assigning a precise drawing scale to any orthographic viewport.] 
FIGURE 12-8: Assign a precise drawing scale to any orthographic viewport.







 
Updating model references

If you ever aren’t sure whether your SketchUp viewports reflect the latest changes to your SketchUp model file (the .skp file), LayOut enables you to check. Select File ⇒ Document Setup ⇒ References. You see a list of files that the LayOut document references and whether those references are current. To update any SketchUp model file manually, select it in the list and click Update. The SketchUp file must be saved to your hard drive for the update process to work.




 
Adding photos and other graphics

Inserting images into your LayOut document is a straightforward affair. Just choose File ⇒ Insert and take it from there. A few more things to know about images you insert: 


	LayOut can insert raster images. Raster images are made of pixels, or tiny dots. TIFF, JPEG, GIF, BMP, and PNG are all graphics file formats that save pictures as lots of tiny dots.

	The Mac version of LayOut can also insert PDFs. This is indisputably the best way to bring in vector art, such as logos. You can use a program like Adobe Illustrator to save any AI (Illustrator) or EPS file as a PDF.

	Images are a lot like viewports. The techniques for moving, resizing, and rotating images work just like they do for SketchUp model views; use the Select tool to do everything. Remember to hold down the Shift key when you resize to maintain your image's aspect ratio. Like viewports, if the file that an image is based on changes, you can right-click an image and choose Update Reference to update it.



Unfortunately, LayOut offers no easy way to import editable vector (such as AI, EPS, and SVG) graphics. If you want to use vector graphics in your LayOut document, you have two choices: 


	Make your own. LayOut is a fantastic vector illustration tool. The upcoming section “Drawing with LayOut’s vector tools” helps you get started.

	
Borrow shamelessly from the Scrapbooks panel. One of the best things about LayOut is the hundreds — maybe thousands — of predrawn graphical elements you can find in the Scrapbooks panel (shown in Figure 12-9). You find things like 


	Symbols: Arrows, section markers, north indicators, graphic scales, and column grids

	Entourage elements: Trees, cars, and people at various scales and levels of detail

	Color palettes: To help with producing attractive documents quickly



To use something you see in Scrapbooks, just click it with the Select tool to sample it and then click again to stamp it onto your page. You can keep clicking to stamp more copies. Press the Esc key when you’re ready to exit stamping mode.





[image: Snapshot of the scrapbooks  which contain all sorts of images that can be inserted into a LayOut document.] 
FIGURE 12-9: Scrapbooks contains all sorts of images you can insert into a LayOut document.








Drawing with LayOut’s vector tools

LayOut includes a full slate of drawing tools that you can use to create logos, title bars, north arrows, graphic scales — anything you want. The drawings you create are vectors, meaning that you can do the following: 


	Scale the drawings without losing quality.

	Change the fill and stroke (outline) colors.

	Split lines and then rejoin them to make new shapes.

 

[image: Tip] INTERESTING CURVES AHEAD!
 
The Line tool in LayOut has an extra trick up its sleeve, called Bézier curves.

Consider the first example in the figure. Believe it or not, it was created with LayOut’s Line tool.

Now consider the second example. All that had to be done to the first example was to move the middle blue dot and to change the length and angle of its blue line. 

 

[image: Schematic illustration of two curves and few lines.] 





Performing this magic is quite simple. All you have to do half the time is ignore the prime directive — click-release, click-to-finish — and to not drag the cursor while drawing lines, rectangles, and so on.

Try this: 

	Start the Line tool and move the cursor to a suitable place on your screen.

	
Click and hold down the mouse button and drag the cursor to a different location.
Observe that you are dragging a blue line instead of the usual black one.


	
Release the mouse button and move the cursor.
You are now dragging a curved black line that starts at the blue dot and is tangent to the blue line.


	
Click and hold down the mouse button and drag the cursor to a different location.
Observe that you are once again dragging a blue line instead of the usual black one.


	
Repeat steps 3 and 4 as often as you like.
The resulting curved line segments are always tangent to each other.



And that’s it! Click, drag, release, move, click, drag, release, move…

Now launch the Select tool and double-click anywhere along the line. This makes all the blue dots and lines appear. You can drag any of the line-segment dots to change the location of the transition points between line segments, which always remain tangent at their junctions.

Similarly, a bit of experimenting reveals that the angle of the blue lines determines the angle at the tangency points, and the length of the blue lines determines how much influence they have at that point.

You can sometimes get weird effects — stuff mysteriously disappears — while playing with this. Solution: In the Shape Style tray, turn off Fill.


Because we don’t know what you want to draw, a step list would be pretty pointless here. Instead, we have a few pointers to get you started: 


	Create shapes the same way you create them in SketchUp. Lines, arcs, rectangles, circles, polygons — you see the same or similar tools, and you can (for the most part) click-release, click-to-finish to create the shapes just as you do in SketchUp.

	Type measurements and angles. LayOut has a Measurements box (in the lower-right corner of your screen), just like the one in SketchUp. Take a look at Chapter 3 for tips on working accurately with this box.

	Create scaled illustrations. LayOut is not AutoCAD, but you can use it to create scaled 2D illustrations from scratch. To do this, choose Window ⇒ Scaled Drawing to open up that utility panel. Click the Make Scaled Drawing button and the select a scale from the drop-down list. Now everything you draw will be assigned a virtual scale — which you can label using the drawing reference graphics in LayOut’s Scrapbooks.

	[image: 9781119617938-ma049] [image: 9781119617938-ma050] Build complex shapes out of simpler ones. For example, with the Split tool and the Join tool, you can combine a triangle and a rectangle to create a thick, blocky arrow.

	Use the right kind of snaps. You can snap to objects or to a grid via the Arrange menu. Change your snapping options by right-clicking the page.

	Use the Shape Style panel. Here, you can change the fill and stroke characteristics of the selected shape(s). In plain English, click the Fill, Pattern, or Stroke swatches to open a panel where you can pick colors and patterns for the things you draw. The controls are straightforward, so you don’t need much help from us; just experiment to see what happens. You can also select dashed lines or add arrows to the beginning or end of a line.



[image: Tip] If you’re a pro (such as an architect or engineer) who needs to represent different materials using standardized patterns called hatches, LayOut has you covered — and, more important, helps you cover your drawing. LayOut includes some of the most common hatches (which it calls Material Symbols), as well as hatches for Geometric Tiles, Site Patterns, and Tonal Patterns (which include dots and lines of various sizes).



[image: Snapshot of drawing the shapes and customize their outlines, fills, pattern, and color.] 
FIGURE 12-10: Draw shapes and customize their outlines, fills, pattern, and color.






To apply these hatches (or any pattern) to a shape in your LayOut document, select the shape and click the Pattern swatch in the Shape Style panel. In the Pattern Fill panel that opens, select a category from the drop-down list at the top and then select your desired hatch or pattern among the swatches that appear. Figure 12-10 shows this process in action.
 


Create clipping masks to emphasize details

Once you’ve learned the basics of making shapes and creating SketchUp model viewports, you can bring these tools together to create LayOut’s coolest output: a clipping mask.

Clipping masks allow you to frame model viewports in something other than a rectangular shape. To learn how to make them, combine a viewport and a circle (check out Figure 12-11 to get a sense of the finished product): 

	
In LayOut, insert a SketchUp model viewport.

We cover this at the beginning of the chapter in “Inserting SketchUp model views.”


	
Draw a circle.

The circle tool is easily available on the LayOut toolbar, or use the keyboard shortcut C (same as SketchUp!).


	
Move your circle over your model viewport.

Basically, imagine that you are using the circle to frame your viewport — because that’s exactly what a clipping mask does.


	
Select both your circle and your viewport.

Selections in LayOut also work just like they do in SketchUp. Click the spacebar to activate the select tool. Then drag left to right to select only everything inside your selection window or drag right to left to select anything that your selection window touches.


	
Right-click your selection, and choose Create Clipping Mask.

Voilà! The circle is now the frame for your viewport. You can double-click this new object to reposition the clipping object — in this case, the circle — as you like.


	
Style the border of your clipping mask using the Shape Style panel.

Choose Window ⇒ Shape Style, and turn on the Stroke setting for your clipping mask. As with any line or shape in LayOut, you can control the line weight, color, and dash style of your clipping mask border.





[image: Schematic illustration of clipping masks which are the powerful ways to call attention to details in a SketchUp model.] 
FIGURE 12-11: Clipping masks are powerful ways to call attention to details in a SketchUp model.






[image: Tip] Clipping masks are not limited to circles. You can also use rectangles, polygons, and any combination of lines, arcs, and curves that form a closed loop. Better yet, you can double-click an existing clipping mask and then manipulate its size and shape as desired.


 
Annotating with labels

[image: 9781119617938-ma051] In LayOut, labels are the easiest way to add callouts (notes with leader lines) to models and drawings. With the Label tool, you can add labels wherever you need them. Here are six important points about one of the most useful tools in LayOut: 


	
Activate, click, click, type, and click. Activate the Label tool, click once to pin the end of the leader line to an element in your drawing, click again to place your text cursor, type something, and click somewhere else to finish your label, as shown in Figure 12-12.

If you want, you can create curved leader lines. They often do a better job of standing out when most of the shapes in your drawings have straight edges. In LayOut, you curve a leader line by click-drag-releasing your mouse when you’re placing its endpoints. (You can also do this with lines created with the Line tool.)


	Save time with auto-filled text. When you label certain kinds of entities in a model viewport, LayOut automatically fills in the text part for you. Labeling a component gives you its name (another good reason to name components when you create them!). Labeling a face gives you its area. If you don’t want LayOut’s suggestion, just type something else when you’re done placing the label.

	Leader lines stick to drawing elements. When you move the thing your leader line is pinned to, the line moves with it.

	Use the Shape Style panel to edit the look of your leader lines. You can change the color, thickness, and endpoints (arrowheads, slashes, and dots) of any leader line very easily after you create it.

	Customize the fonts for your labels. Just like text boxes, the text in labels can be formatted however you like.

	
Save time by sampling. After you edit a label, making every subsequent label match is easy: 

	
Activate the Label tool and then press the S key.

Your cursor changes into an eyedropper.


	Click the text part of the label you sample and then click S again.

	Click the leader line of the label you sample.


Now every label you create looks just like the one you sampled.





[image: Schematic illustration of adding text callouts with the Label tool.] 
FIGURE 12-12: Add text callouts with the Label tool.








Displaying dimensions

Dimensions can display exact measurements based on your model or drawing.

[image: Remember] The dimension tools work hand in hand with inserted models to save you hours of work. For example, if you add a dimension to an inserted SketchUp model and later change the dimension of your model, LayOut can know about those changes and update the inserted model and the dimension accordingly.

[image: Tip] Before you use either dimension tool, make sure Object Snap is turned on. (It’s on by default.) With Object Snap on, your dimension leader lines can “see” the points to which they’re supposed to attach and snap to them, just like inferences in SketchUp. On the Arrange menu, you can check the status of Object Snap.

To create a linear dimension, follow these steps: 

	[image: 9781119617938-ma052] Select the Linear Dimension tool.

	Click a start point and then click an endpoint.

	Click to define an offset.


[image: Tip] After you create your first dimension and while the tool is still active, double-click the next point you want to dimension. This technique duplicates the offset that you set for the first dimension.

Angular dimensions are a little trickier than linear dimensions. Follow these steps to make it work (see Figure 12-13): 

	[image: 9781119617938-ma053] Activate the Angular Dimension tool.

	
Click somewhere along the first line for the angle you want to mark, and click again along that line.

You create two “pin points” that establish the first line of the angle you want to mark.


	
Click somewhere along the second line that creates the angle, and click again.

You create a second set of pin points that tells LayOut where the other line of the angle is.


	Click one last time to position the text of your angular dimension.


[image: Tip] Creating separate layers for text, labels, and dimensions saves time in the long run. See “Customizing a document’s pages and layers” earlier in this chapter for details.



[image: Snapshot of creating an angular dimension.] 
FIGURE 12-13: Creating an angular dimension takes some getting used to.






Editing dimensions

After you actually draw a dimension — linear or angular — on your page, you can do an awful lot to change what the dimension looks like. To begin with, take a look at the anatomy of a dimension. Figure 12-14 shows an example of each kind.



[image: Schematic illustration of the anatomy of a LayOut dimension such as linear on the left, angular on the right] 
FIGURE 12-14: The anatomy of a LayOut dimension: Linear on the left, angular on the right






Now that you’re clear on nomenclature, here’s some advice on editing a dimension’s appearance (basically, everything except its text box): 


	Use the Shape Style panel to change colors, line styles, line weights, and arrow styles (the things at the ends of dimension lines).

	Use the Text Style panel to change the font, text size, and so on. Just like textboxes and labels: Choosing your own fonts gives your document a lot more, character but don’t overdo it or people will think that you are a real character.

	Use the Style tool to copy formatting and other settings from one dimension to another. Activate the Style tool, click your “source” dimension, and then click each dimension you want to change.

	Double-click a dimension to access all its internals. After they become editable, you can click and drag the dimension’s connections points, offset points, extent points, or text all you like.

	Select individual lines to edit them. After you double-click a dimension, you can select its constituent lines to edit them. Some users like to draw dimension lines slightly thicker than extension lines, so they select the dimension line and increase its width in the Shape Style panel.

	
Overshoots can be tricky. The overshoot (as shown in Figure 12-14) is the part of an extension line that extends beyond the dimension line. You can adjust your overshoot’s length if you like. Here’s how: 

	Double-click a dimension to edit it.

	Click to select the extension line whose overshoot you want to adjust.

	Change the number beside the End Arrow setting in the Shape Style panel.


Unfortunately, there’s no way to alter both extension lines’ overshoots simultaneously. After you change one line, choose Edit ⇒ Copy Style; then select the other and choose Edit ⇒ Paste Style.




[image: Remember] After a dimension looks just the way you like, copying a dimension’s style and applying it to your other dimensions is pretty easy. Just use the Style tool to transfer formatting from one dimension to the other.

[image: 9781119617938-ma054] To sample a dimension’s style so that every new dimension you draw matches it, select the Style tool (or press the S key) and click your source dimension before you draw the next one.

Take a gander at the Dimension Style panel, as shown in Figure 12-15. Most of the controls here are obvious, but some definitely aren’t. Working from left to right and then top to bottom, the controls are 


	Text position: Choose to display a text string above, below, or right smack dab in the middle of its corresponding dimension line.

	Text alignment: Force a text string to always be horizontal or vertical on the page, or aligned (parallel) or perpendicular to its dimension line.

	Display units: People who use the Imperial system of measurement tend to show the units on their dimensions. Metric folks tend not to. You have the choice.

	Auto Scale button: Here’s where dimensions start to get a bit complicated. For a full discussion of what the heck this button does, see the next section.

	Scale drop-down list: This is available only when Auto Scale is deselected. Skip ahead to read all about model space and paper space. Getting your head around this topic takes time.

	Length: Different professions have different conventions for the dimensions they put on their drawings. Choose the one that suits you best.

	Precision: If you dimension the overall length of an airport runway, you probably don’t need to be accurate to the 1000th of an inch. However, if you design an artificial heart valve …

	Angle: Degrees or radians — you decide. Sometimes, software reminds you that math nerds create it.




[image: Snapshot of the Dimension Style panel.] 
FIGURE 12-15: The Dimension Style panel.








Keeping track of model space and paper space

When you place a SketchUp model viewport on your page, you end up with two types of space in your LayOut document: 


	Paper space: Distances that pertain to the physical sheet of paper you’re working on are said to be in paper space. A 4×4-inch blue square in paper space is 4 inches long.

	Model space: Distances within a model viewport have nothing to do with the size of the sheet of paper the viewport is on. An 80×80-foot building shown at 1 inch = 8 feet scale is 80 feet long in model space. In paper space, it’s 10 inches long.



[image: Remember] A dimension you draw in LayOut is either in paper space or in model space. Which one the dimension is in by default depends on what the dimension is connected to: 


	Viewports: When you draw a dimension between two points in a model viewport, LayOut is smart enough to presume that you want to display the length between the points in the model (in model space).

	Everything else: When you create a dimension between two points that have nothing to do with a viewport, LayOut assumes that you want to see the actual length on the page (in paper space).



Figure 12-16 illustrates the difference between model space and paper space. Both dimensions are exactly the same physical length on the page: 3 inches. However, the dimension on the left is attached to two points on a SketchUp model that’s shown at 1 inch = 8 feet scale. This dimension displays the model space length of 24 feet (3 x 8), whereas the dimension on the right shows its paper space length of 3 inches.

[image: Tip] The Auto Scale button in the Dimension Style panel is automatically selected whenever you create a new dimension. If your dimension touches a point in a model viewport, the text string displays the length in model space. If it doesn’t touch any model viewport at all, you get a length in paper space.



[image: Snapshot of the dimensions which show model space or paper space.] 
FIGURE 12-16: Dimensions can show model space or paper space.






Turning off Auto Scale lets you assign a scale to the dimension you select. Choosing 1 inch = 60 feet for a dimension that’s physically 4 inches long makes its text string read 240 feet — no matter what the dimension is attached to.




 
Creating tables

[image: 9781119617938-ma055] If you create construction documents, the Table tool is for you. Tables enable you to easily add construction schedules, area and quantity takeoffs, legends, or whatever you need in order to help others understand your LayOut document. Figure 12-17 shows a typical example.

While you can create tables from scratch, we think there is a much better way: import tables from CSV or Excel files. These spreadsheet editing programs are made to create and style tables, and LayOut works really well with them. You’ll save yourself a bunch of time by creating and formatting a table in one of these programs, and then importing it into LayOut. Here’s how it works: 

	Choose File ⇒ Insert.

	
Instead of bringing a SketchUp model or an image file into LayOut, find a CSV or XLSX file.

Make sure to select the correct sheet.


	Click OK.


You can also choose to import the table formatting from Excel and then use LayOut’s Shape Style tools to add more robust styling. Depending on the size of your table on your LayOut page, you may still have to do some manual resizing of the table to get things to look right.



[image: Snapshot of bringing the  spreadsheets into LayOut as tables.] 
FIGURE 12-17: Bring spreadsheets into LayOut as tables.






[image: Tip] After you import a table, managing changes between your table’s source file and LayOut is super-easy. If you need to update the source file, then you can update your table in LayOut by right-clicking the table and choosing Update Table Reference from the menu that appears.




[image: Warning] SIZE MATTERS
 
Be careful what you wish for; you might get it. Unless otherwise specified, SketchUp imports the entire worksheet full-size. If your worksheet has hundreds of rows and/or columns, your LayOut page gets swamped. In addition, if you export or print the LayOut page, it shows only that portion of the table that fits within the page size. Hiding rows or columns in the source spreadsheet doesn’t help. Fortunately, this can be cured: 


	As you are importing the spreadsheet, a dialog box appears that lets you specify a specific range of the spreadsheet cells to be displayed. A large spreadsheet can thus be imported into several LayOut pages, each showing a different range of the same spreadsheet.

	After you import a table, you can right-click it. This brings up the same dialog box as when you were inserting the table, and in it, you can edit the visible range.







Creating Your Own Templates

[image: Remember] Most of the design presentations that you (or your firm) put together probably look alike; after all, they’re part of your brand identity. If the presentation documents you make are all variations on a couple themes, why not build your own templates and use them every time you start a new project? You can set up LayOut so that your templates appear in the Getting Started dialog box, making it easier to build consistent presentations, quicker.

Follow these steps to turn any LayOut file into a template: 

	
Build a LayOut file that includes all the elements you want.

These elements may include a title block, a logo, page numbering, and a cover page. You probably also want to set up things you can’t see, such as Auto-Text tags, a layering system, and even premade, empty pages for content. To make sure your template captures everything, you can strip all the content from a LayOut document that you’ve already made and then save the resulting shell as a template.

[image: Tip] Before you move to step 2, make sure you’re viewing the page that you want to use as the thumbnail preview in the template list.


	
Choose File ⇒ Save as Template.

The Save As Template dialog box opens.


	
Type a name for your template and then choose a location for your new template.

In the list at the bottom of the dialog box, click the folder (they’re all folders) in which you want to include the template you’re adding.


	
Click OK (Mac: Save).

The next time the Getting Started dialog box appears, your new template will be in it.



[image: Tip] Your LayOut templates can also save the formatting choices you’ve made for LayOut tools like Dimensions, Text, Labels, Line, and other shapes. Draw a few of these entities, make the styling changes you want, delete the entities, and then save your file as a template. Now your template automatically contains the formatting rules you’ve set.



Putting Together Your Own Scrapbooks

Most hard-core LayOut users make their own scrapbooks of scale figures, cars, trees, drafting symbols, typography — anything they need to use again and again.

Like templates, scrapbooks are just LayOut files that have been saved in a special folder on your system. When you open the program, it checks that folder and displays the files it finds in the Scrapbooks panel.

Follow these steps to build your own LayOut scrapbook: 

	Build a LayOut file with the elements you want to include in your scrapbook.

	Choose File ⇒ Save As Scrapbook.

	
Type a name for your scrapbook.

In the Save As Scrapbook dialog box, the Scrapbook Folder list shows the location of the folder where your new scrapbook will be saved. If you prefer to use another folder, you can add one using the Folder panel of the Preferences dialog box.


	
Click OK (Mac: Save).

The next time you start LayOut, your scrapbook appears at the top of the Scrapbooks panel.



A few notes about making your own scrapbooks: 


	A good size is 6×6 inches. You can choose any paper size for the file you plan to save as a scrapbook, but smaller sheets work better. The scrapbooks that come with LayOut are 6 inches square.

	Scrapbooks can have multiple pages. In fact, just about all the default scrapbooks in LayOut do. The first page in your document becomes the cover page for the scrapbook; all subsequent pages appear below it in the list. Pay attention to your page names, which appear in the Scrapbooks panel, too.

	Use locked layers. Anything you put on a locked layer can’t be dragged out of the scrapbook. Take a look at the People scrapbook that comes with LayOut; the word People and the information next to it are on a locked layer. Notice how you can’t drag them into your drawing?

	You can put model viewports into scrapbooks. Choose Arrows ⇒ 3D ⇒ Curved. Drag one of the arrows onto your page. Now double-click it. It’s a 3D model! This scrapbook was created specifically to provide storyboarders with orbitable arrows that people can pose however they like. The moral of this story is that you can put anything into a scrapbook: graphics, images, viewports, and text.





Getting Your Document out the Door

After you create a LayOut document, you can do the following four things to show it to someone else: 


	Print it.

	Export it as a PDF or image files.

	Export it as a DWG or DXF (CAD) file.

	View it as a full-screen presentation.



Simple, huh? The next four sections provide more detail on each of these options.
 
Printing your work

Instructions for printing from SketchUp could easily run several pages. The instructions for printing from LayOut, on the other hand, would easily fit on a business card: 

	
Choose File ⇒ Print.

In the Print dialog box, choose which pages to print and how many copies you want.


	Click OK to send your document to the printer.


And that, dear reader, is why you should always insert your SketchUp models into a LayOut document if you need to print them. If you’re using SketchUp for Web — didn’t we tell you to skip this chapter? — you can still print pretty easily, but without all the great formatting and multipage control of LayOut. We cover printing from SketchUp for Web in Chapter 13.

[image: Tip] That said, many users almost never print directly from LayOut. Ninety percent of the time, they export a PDF and use Adobe Acrobat (or Reader) to send the actual job to the printer. The settings in Adobe’s Print dialog box give you more control over the finished product.


 
Exporting a PDF or image files

Anyone with Adobe Reader software (which is free and is already loaded on millions of computers) can look at a PDF document you create; all you have to do is email it to your recipient.

Or you can export the pages of your file as individual raster images in either JPEG or PNG format. Take a look at Chapter 13 for more information on the differences between JPEG and PNG if you need to.

Follow these steps to export your LayOut document as a PDF file or as an image: 

	
Choose File ⇒ Export ⇒ PDF or File ⇒ Export ⇒ Images.

On a Mac, choose File ⇒ Export and then make sure PDF, PNG, or JPEG is selected in the Export dialog box. An export dialog box opens.


	Name your file and tell LayOut where to save it on your computer. If you’re saving an image, select the file format for the image.

	Click the Save button (Mac: Options).

	
In the dialog box that appears, set the options for your PDF or images.

Here’s what each option does: 


	Pages: Choose which pages you want to export. If you’re exporting images, each page in your LayOut document exports as a separate image file. If you only want to export one image, only export the page that it’s on.

	Image resolution: If you’re exporting a PDF, you can select High, Medium, or Low. Here’s a good guideline: For documents that are small enough to be handheld, we recommend a setting of High. For anything bigger, go with Medium. If you’re exporting an image, you can specify a width or height in pixels or type a resolution in pixels per inch (ppi). 96 ppi works well on screens, and 300 ppi works well for prints.

	Image compression: You see this option only if you’re exporting a PDF. Select this setting to apply JPEG-style compression to images within the PDF.

	Layers: You see this option only if you’re exporting a PDF, because PDFs can have layers, just like LayOut documents do. If it makes sense to do so, you can export a layered PDF so that people who view it can turn the layers on and off.

	Finish: Select this check box to view your PDF or images after they’re exported.



	Mac only: Click OK to close the Options dialog box.

	Click the Export button (Mac: Save) to export your document as a PDF file or as one or more image files.



 
Exporting a DWG or DXF file

You’d be hard-pressed to find a piece of professional computer-aided drawing (CAD) software that can’t read the DWG and DXF formats, which are the industry standard for exchanging CAD files with people who use apps like AutoCAD. Here’s how to turn your LayOut document into a CAD file: 

	
Set all your SketchUp viewports to vector rendering mode.

Viewports that are rendered as rasters export to DWG/DXF as raster images. That’s usually not what you want to happen — especially if you’re exporting a CAD file. See “Making your models look their best” earlier in this chapter for details about setting a viewport’s rendering mode.

[image: Tip] If a viewport contains a view whose edges you don’t want to manipulate in CAD (such as a glitzy rendering), leave it as a raster.


	
Choose File ⇒ Export ⇒ DWG/DXF.

On a Mac, choose File ⇒ Export and make sure DWG/DXF is selected in the Export dialog box.


	
Name your file, tell LayOut where to save it on your computer, and click the Save button (Mac: Options).

The DWG/DXF Export dialog box opens.


	
Set the DWG/DXF Export options.

Here’s what all the knobs and switches do: 


	Format: Unless you know you need a DXF, export a DWG file. As for which version, 2010 is the best choice. This is the oldest that supports spreadsheet linking. AutoCAD can always open older versions, but older releases of AutoCAD, and some compatible/clone products, can’t always open newer versions. AutoCAD 2020 can still open DWG files from 1983.

	Pages: Choose which pages you want to export. Keep in mind that each page in your LayOut document exports as a separate file.

	Layers: If you want LayOut to export your layers as DWG/DXF layers select that option. If you want to export hidden layers, select Export Invisible Layers. See “Customizing a document’s pages and layers” for details about layer visibility.

	Other: Select the check box for any option you like. Color by Layer exports each layer as a different color. You can export the LayOut entities as native DWG/DXF entities. If you tell LayOut to ignore fills, shapes that are drawn in LayOut and filled with a color or pattern don’t appear in the exported file.



	Mac only: Click OK to close the DWG/DXF Export dialog box.

	
Click the Export button (Mac: Save) to export your document as one or more DWG/DXF files.

If your LayOut file included any inserted raster images (such as JPEGs or PNGs), you also end up with a folder that contains copies of those. They’re necessary for the DWG/DXF files you produce.




 
Going full-screen

[image: Remember] Many times, design presentations for clients go beyond printed boards and booklets. These presentations include a digital slide show that usually involves a few hours of work in a program like PowerPoint or Keynote. LayOut helps you skip the PowerPoint step by letting you display your presentation in a full-screen view. You can move back and forth between pages with the arrow keys on your computer, and you can even double-click SketchUp model views to orbit them. Follow these tips: 


	Switching to Presentation mode takes less than a second. Choose View ⇒ Start Presentation to view your presentation full-screen. Press the Esc key to exit Presentation mode.

	Specify where you want your presentation to appear. Use the Presentation panel in the Preferences dialog box to tell SketchUp which monitor (or projector) you want to use to show your presentation.

	Move from page to page. Use the left- and right-arrow keys.

	Choose which pages to show full screen. You can decide not to show certain pages in full-screen mode by toggling the Show Page in Presentations icon to the right of those page names in the Pages panel. (You have to be in List view to do this.)

	Double-click to change your view of a SketchUp model. When you’re in full-screen mode, you can double-click any SketchUp model viewport to orbit and zoom around inside it. Click anywhere outside the view to exit.

	Draw while you’re in full-screen mode. Try clicking and dragging while you’re in full-screen mode; doing so lets you make red annotations right on your presentation. If a client doesn’t like the porch you designed, scrawl a big red X over it to let her know you understand. When you press Esc to exit Presentation mode, you can choose to save your annotations as a separate layer.

	Play scene animations in full-screen mode. You can double-click and then right-click a model view with scenes that you’ve set up in SketchUp; then choose Play Animation. LayOut transitions from scene to scene. You can read more about scenes in Chapter 11.








    

Chapter 13

Other Ways to Share Your Work

IN THIS CHAPTER

[image: check] Exporting images from SketchUp for Web

[image: check] Printing in SketchUp for Web

[image: check] Making animations

[image: check] Exporting CAD files

[image: check] Uploading a model to the 3D Warehouse



You live at a time in history when it is often necessary to inscribe an image of your design onto dried and bleached chips from a dead tree (a.k.a. paper) and then also send that same design, in the form of ones and zeros, thousands of miles to a series of data centers, where it’s available in its entirety to anyone with an Internet connection.

As we mention in Chapter 12, LayOut in SketchUp Pro is the best way to turn your 3D models into compelling images and documents. If you don’t have SketchUp Pro — or if you compose images using other software — there are other great ways to share what you’ve created. In this chapter, we start by explaining the process for exporting images and PDF pages from SketchUp for Web.

The second part of this chapter is for everybody. We go over the basics of exporting image files, which is something you can use in LayOut too, and 3D animations. We look at how to prepare SketchUp models for use in other design applications, and we also have an important section dedicated to the SketchUp’s 3D Warehouse, which is a giant online repository of models made (mostly) by everyday SketchUp modelers. Uploading your creations to the 3D Warehouse is useful for sharing and archiving your work.



Exporting Images from SketchUp for Web

If you use SketchUp for Web, you may have felt a little left out when we told you to skip Chapter 12. The good news is that exporting images from SketchUp for Web (see Figure 13-1) is dead simple. We just didn’t need an entire chapter to tell you about it.



[image: Snapshot of the style settings.] 
FIGURE 13-1: Once you have scenes with your desired style settings, you’re ready to export.






Just as when you work with LayOut, your images will benefit from the power of Styles and Scenes (covered in Part 3) by helping to convey their intended meaning, but once you’re ready to turn your model into a 2D image, follow these steps: 

	
Click the menu icon at the top of the screen to open the File operations menu and choose Export ⇒ PNG. (You can also use Search.)

PNG stands for Portable Network Graphics file. For now, all you need to know is that it’s a common image format, compatible with most image editing applications you may use. To learn more about raster image files like PNG, check out the sidebar “Understanding rasters: Lots and lots of dots” later in this chapter.


	
The Image Export Preview canvas opens (refer to Figure 13-1). Adjust the pixel size of the canvas to your desired aspect ratio and size.

An aspect ratio is simply the relative height and width of your image. You can change the aspect ratio by adjusting the pixel width and height displayed in the canvas. If you choose a pixel size that’s bigger than what can fit on your screen, SketchUp scales your image down to show you a preview of the aspect ratio with a smaller image than what will actually export.

[image: Tip] Changing the aspect ratio does not distort the image. For example, the default canvas is a rectangle. If your model was just a circle, then there will be excess white areas at each side. If you change the width to be the same as the height, then the circle is still a circle and the excess white area disappears.


	
Adjust the view of your model within the preview canvas, and use scenes if you have them.

The preview canvas is still a 3D model. So you can use navigation tools like Orbit (O), Pan (H), and Zoom (Z) to position your model in the canvas as you like.

Here’s where scenes really come in handy: The best way to export a good image is with a saved scene containing the visibility and style settings you want. For instance, if you want to export an image without the model axes visible, then before you export use the Search tool and type View Axes to turn off the axis visibility. Then search for Add Scene to create a new scene with this visibility setting. Now when you are in the preview canvas, you can always jump to this scene or others that contain more complex style settings for shadows, edge and face settings, and beyond.

[image: Tip] You can change the aspect ratio at any time as you adjust your view of the model.


	
If you want, click Transparent Background to export your model geometry only (without any sky, ground, or background colors).

If you’re planning to use your image in a presentation, a website, or some other image editing software, you may want an image with a transparent background. With the Transparent Background item checked, your model displays with a white background in the preview canvas, but your exported PNG image contains only geometry (without a white background). All the white space in your preview canvas will be transparent in your exported image.


	
[image: 9781119617938-ma075] Click the broken chain link icon in the upper left of the preview canvas; then decide how big an image you want to export.

After you’ve set an aspect ratio and composed your image, it’s time to consider how big an image file you want to export. The size of your image affects the quality of your export. (Read all about this dynamic in “Making Sure You Export Enough Pixels” later in this chapter.)

[image: 9781119617938-ma074] Before you resize your canvas, be sure to click the broken-chain-link icon so it changes to look like the three joined links icon. Unbreaking the link locks the aspect ratio of your canvas so that your image composition is preserved as you resize.


	
Click Export as PNG.

That’s it! Depending on how many pixels you exported, it may take a few seconds for SketchUp to process your export.


 

UNDERSTANDING RASTERS: LOTS AND LOTS OF DOTS
 
When you look at a photograph on your computer, you’re really looking at a whole bunch of tiny dots of color, or pixels. These are arranged in a rectangular grid called a raster. Digital images (like PNG files) that are composed of pixels arranged in a raster grid are raster images, or rasters for short. Have a look at the first image in the figure for a close-up view of a raster image. Here are some things to keep in mind about rasters: 


	Rasters are everywhere. Almost every digital image you’ve ever seen is a raster. TIFF, JPEG, and PNG are three of the most common raster file formats. SketchUp for Web exports PNG only, but SketchUp Pro exports them all.

	Rasters are flexible. Every 2D image can be displayed as a raster; a grid of colored squares is an incredibly effective way of saving and sharing picture information. As long as you have enough pixels, any image can look good as a raster.

	Rasters take up a lot of space. If you think about how raster images work, it takes a lot of information to describe a picture. Digital images are made up of anywhere from thousands to millions of pixels, and each pixel can be any one of millions of colors. To store a whole picture, a raster image file needs to include the location and color of each pixel; the bigger the picture is, the more pixels are needed to describe it, and the bigger the file size gets. Worse yet, doubling the length and width of a raster image quadruples the number of pixels and hence the file size.

	Rasters are measured in pixels. Because every raster image is made of a specific number of pixels, you use a raster’s pixel dimensions to describe its size. If we told you that we emailed you a photograph that was 800×600, you could expect to receive a picture that is 800 pixels wide by 600 pixels tall. (See the following figure.) Pixels don’t have a physical size on their own — they’re just dots of color. You determine a picture’s physical size by deciding how big its pixels should be; this is referred to as resolution and is generally expressed in terms of pixels per inch (ppi). Check out the section “Making Sure You Export Enough Pixels” later in this chapter for the whole scoop.



Why use pixels instead of inches or centimeters to describe the size of a digital image? It all has to do with how computer screens work. Because not all screens display things at the same size, it’s impossible to predict how big an image will look when it shows up on someone’s computer. Depending on the person’s display settings, an 800×600-pixel image may be a few inches across, or it may take up the whole screen. Giving a digital image’s dimensions in pixels is the only accurate way of describing how “big” it is. 


[image: Schematic illustration of the working of raster images.] 








Making Sure You Export Enough Pixels

With raster images, it’s all about pixels. The more pixels your image has, the sharper the image is, and the bigger it can be displayed or printed. Figure 13-2 shows the same image three times. The first image is 150 ×50, meaning that it’s 150 pixels wide by 50 pixels high. The second image is 300×100, and the third is 900×300. Notice how the image with more pixels looks a lot better? That’s the whole point of this section.

[image: Tip] Why not always export a truckload of pixels, just in case you need them? There are three reasons: 


	Image exports with lots of pixels take a long time to process.

	Raster images are very big files. If you want to share an image digitally via email or the web, you want enough pixels to make the image look good onscreen but not so many that your recipient acquires a few gray hairs or gums up their Internet connection trying to download the image.

[image: Schematic illustration of more pixels yielding a much more detailed image.] 
FIGURE 13-2: More pixels yield a much more detailed image.







	
The only way an existing pixel file can be resized is to add or delete pixels. For example, you may have a 1,000×1,000 pixel image that you want to insert into a word processor file. After insertion you realize that it is way too big, so you reduce the insertion to 250×250 pixels. The only way for this to work is that your word processor has to drop three out of four pixels. Oops — a whole bunch of the fine lines in the image disappear. This can mess up a design drawing something fierce.

[image: Tip] After you import a raster image into a word processor document, check its image properties. If its scale factor isn’t 100 percent, you should go back to SketchUp, adjust the image size, and export and then import again.




How many pixels you need to export depends on what you’re going to use the image for. Very broadly, you can do two things with your image: 


	Display or project it on a screen digitally.

	Print it.



In the next section, we talk about each of these possibilities in detail. No matter what version of SketchUp you use, the information is a helpful reference when you are deciding how big an image to export.



Exporting Enough Pixels for a Digital Presentation

If you plan to use your exported image as part of an onscreen presentation, it’s helpful to know what computer monitors and digital projectors can display: 


	The smallest, oldest devices currently in use have images that are 1,024 pixels wide by 768 pixels high.

	At the other end of the spectrum, high-end, 30-inch LCD monitors display 2,560×1,600 pixels.



It stands to reason that if you’re exporting an image that will be viewed only on-screen, you need to create an image that’s somewhere between 800 and 2,500 pixels wide. Table 13-1 provides some guidelines on image sizes for different digital applications.
 



TABLE 13-1 Suggested Image Sizes for Onscreen Use

	
How the Image Will Be Used

	
Image Width (Pixels)

	
Email

	
400 to 800




	
Website, large image

	
600




	
Website, small image

	
200




	
PowerPoint presentation (full-screen)

	
800 or 1,024 (depends on projector)




	
PowerPoint presentation (floating image)

	
400








Printing from SketchUp for Web

If you prefer to print your modeling work to a piece of paper, the process is straightforward. In fact, if you read the earlier section “Exporting Images from SketchUp for Web,” you already know pretty much everything you need to know. Just click the file folder icon at the top of the screen to open the file operations menu and choose Print to open the print preview canvas (see Figure 13-3).

The key difference between exporting and printing is that when you are printing then your aspect ratio and image size are defined by the size of the paper you plan to print on.



[image: Snapshot of the print preview canvas which is very similar to the image export canvas.] 
FIGURE 13-3: The print preview canvas: Very similar to the image export canvas.






Also, because web browsers and printers are notorious enemies, SketchUp for Web simply exports a PDF file for you to use in printing. Most computers come with a PDF viewer that will more reliably print your PDF file than a web browser will.

With that said, exporting a PDF for printing is very similar to exporting a PNG image file. Choose a paper size, decide whether you want to print in a landscape (horizontal) or portrait (vertical) orientation, and then select a scene or reorient your model in the preview canvas.

Last, if you want to save a bunch of ink, you can ask SketchUp for Web to print with a white background so that you aren’t asking your printer to glob on lots of additional ink to account for the ground, sky, or background colors in your model.



Printing to Scale in SketchUp for Web

In some cases, you may want your prints to reflect the scale of your design. In SketchUp for Web, scaled printing is available with a paid subscription (or as part of SketchUp for Schools). Here’s how it works: 

	
Before entering the print preview, create orthographic views of your model and save them as scenes.

Scale is a notion that cannot be applied to model views in SketchUp’s perspective camera mode. To create an orthographic view, use the Search tool and type Ortho to activate the Parallel Projection camera mode. Then use view commands (and search queries) like Front, Top, or Align View to orient your camera as desired. When you have the orthographic view you want, create a new scene.


	Using Search, type Print to activate the print preview canvas.

	Click the Print Mode drop-down menu to the right of the canvas, select Scenes, and then choose the orthographic scene you just made.

	
Click the Print Mode drop-down menu again, and choose Print to Scale.

Notice that the view of your model changes slightly. When you switch into this scaled printing mode, SketchUp resizes your model slightly and derives an arbitrary scale just below your list of scenes (see Figure 13-4).


	
Set your desired drawing scale, and choose whether to display that scale on your printed page.

You can assign any scale you want, but you probably want to pick one that will aptly display your model view on the page you’re printing. You can type any units you like in the In Drawing and In Model fields, but the scale displayed in the canvas respects the unit settings in your model. You can change these in the Model Info panel, near the bottom of the utility tray on the right. Last, you can select the Print Scale check box to display the scale of your drawing on the printed page.





[image: Snapshot of using print to scale in SketchUp for Web.] 
FIGURE 13-4: You’ll need a paid subscription to print to scale in SketchUp for Web.








Making Movies with Animation Export

[image: Remember] The following section on exporting animations does not apply to the Web version of SketchUp.

When it comes to having nerdy fun, exporting movie animations of your SketchUp models is right up there with games like Candy Crush and Pong (and if you recognize that last reference then you must be really old). Like both these things, what’s so great about animation export is how easy it is to do.

That’s not to say that animation and digital video are simple topics; they’re not. It’d take a freight elevator to move the books that have been written about working with video on the computer, but in this section, we keep it simple. What you find here is only what you need to know to export an animation of a 3D SketchUp model.
 
Getting ready for prime time

The key to exporting animations of your SketchUp models is using scenes; if you haven’t read it already, now’s the time to check out Chapter 11. Scenes are saved views of your model that you can arrange in any order you want. When you export an animation, SketchUp strings together the scenes in your model to create a movie file that can be played on just about any computer made in the last several years.

Follow these steps to get your model ready to export as an animation: 

	Create scenes (as described in Chapter 11) to build the “skeleton” of your animation.

	
To adjust the animation settings in the Model Info dialog box, choose Window ⇒ Model Info and then select the Animation panel.

Chapter 11 explains all the controls; see the section about moving from scene to scene.


	Select the Enable Scene Transitions check box to tell SketchUp to move smoothly from one scene to the next.

	
Enter a transition time to tell SketchUp how long to spend moving between scenes.

If your Scene Delay is 0 (see step 5), you can multiply your transition time by your number of scenes to figure out how long your exported animation will be.


	
Enter a scene delay time to pause at each scene before moving on to the next one.

[image: Tip] If you plan to talk about each scene, use the scene delay time to pause before each one. If your animation is supposed to be a smooth walkthrough or flyover then set the delay to 0.


	
Adjust the proportions of your modeling window to approximate the proportions of your movie.

Unlike SketchUp’s 2D export formats, the proportions of your exported movie don’t depend on those of your modeling window; that is to say, making your modeling window long and skinny won’t result in a long and skinny movie. You choose how many pixels wide and tall you want your movie to be, so to get an idea of how much you’ll be able to see, make your modeling window match the proportions of your exported file. (The 16:9 aspect ratio is common for video formats.) Have a look at step 2 in the section “Exporting Images from SketchUp for Web” earlier in this chapter for guidance on adjusting your modeling window.


	When your project is ready to go, move on to the next section to export your animation.



 
Exporting a movie

SketchUp offers a veritable alphabet soup of video export formats: You can choose from seven on Windows and six on Mac. The list can seem daunting, so here’s a cheat sheet that should save you some mental anguish: 


	H.264 (.mp4): This video format is as close to an industry standard as it gets. Everyone with a Mac and anyone with QuickTime on their Windows computer can readily view H.264 movies without any hassle. It's also the upload format of choice for popular video-sharing websites like YouTube and Vimeo. SketchUp’s exported H.264 files are nicely compressed, which keeps them smallish and good-looking.

	AVI (.avi): All Windows machines and Macs with a special plug-in can play AVI movies. Popular video-sharing websites like YouTube and Vimeo let you upload AVI files, but they tend to prefer H.264. SketchUp’s exported AVI animations are uncompressed, meaning that they look nice and clean but the files can get huge quickly. If you’re planning to send someone your movie file, AVI might not be your best choice.

	VP8 (.webm): Not too many years ago, the tech world started getting nervous about H.264's dominance as a file format used to display video on websites. H.264 is proprietary, meaning that big companies have to pay licensing fees to its owner (Apple) if they want to use it. WebM is a free alternative, backed by Google, and made for use on websites that use HTML5. Translation: You don’t need to worry about WebM unless you’re planning to embed your movie on a modern website without first uploading it to YouTube or Vimeo.

	Theora (.ogv): Theora is another free, open-source format meant for videos that will be embedded in websites. Unlike WebM, Theora is managed by an independent foundation that tries to keep important multimedia file formats out of the hands of big, private corporations like Apple (H.264) and Google (WebM).

	JPEG, PNG and TIFF: Choosing to export in any of these formats won’t give you a movie file that you can watch; they aren’t video file formats. Instead, you’ll get a pile of image files that each represent one frame in your animation; for a 3-second video at 30 frames per second, SketchUp would export 90 individual images. These options are useful for serious video editors who need lots of control, but most folks shouldn’t need to use them.



Although exporting animations in SketchUp is a pretty simple operation, figuring out how to set all the animation export controls can seem like landing the space shuttle while blindfolded.

Follow these steps to export a movie file from SketchUp: 

	
Prepare your model for export as an animation.

See the section “Getting ready for prime time” earlier in this chapter for a list of things you need to do before you export an animation.


	
Choose File ⇒ Export ⇒ Animation ⇒ Video.

Choosing Video provides you with file formats that yield video files. If you pick Image Set instead, you’ll see options for creating sets of still images. We explain the difference between these a little later on in this section. If you’re on a Mac, there’s no bifurcation of the Animation submenu; just choose File ⇒ Export ⇒ Animation, and you see all your format choices.


	Give your movie file a name and then choose where to save it on your computer system.

	
Make sure to select the correct file format.

From the Format drop-down list, select the file format you want SketchUp to export. In most cases, this is either H.264 or AVI, but take a look at the descriptions earlier in this section for more detailed info.


	Click the Options button to open the Animation Export Options dialog box.

	
Adjust the settings for the type of animation you want to export (see Figure 13-5).

How you set up everything in this dialog box depends on how you plan to use the animation you create. Check out the next section in this chapter for a list of settings and their implications.


	
Click OK in the Export Options dialog box.

You return to the Animation Export dialog box.


	
Make sure that everything looks right and then click the Export button.

Because exporting an animation can take a while, it pays to double-check your settings and to have a cup of coffee handy before you click the Export button. When the export is complete, you can find your animation file in the location you specified in step 3. Double-clicking the file causes it to open in whatever movie-playing software you have that can read it.





[image: Snapshot of the Animation Export Options dialog box.] 
FIGURE 13-5: The Animation Export Options dialog box.








Figuring out the Animation Export Options settings

As we mention earlier, digital video can be complicated. Lucky for you, you don’t really have to know exactly what everything means to export the right kind of movie; you just have to know how to set up everything. The Animation Export Options dialog box (shown in Figure 13-5) is the same for each of the video file formats that SketchUp offers; here’s a brief guide to the settings: 


	Resolution: This use of the word resolution refers to the pixel dimensions — the physical size — of your video. SketchUp Make (the free version) lets you choose from three standard sizes, whereas SketchUp Pro provides a Custom option for more flexibility. Here’s what the terms mean: 
	1080p Full HD yields a video that is 1,920 pixels wide and 1,080 pixels high. This is the highest resolution that most newer televisions can display, and it’s even higher than a lot of laptops can handle natively. Choose this option only if you know you’ll need it; exporting this many pixels takes a long time.

	720p HD, which is 1,280 pixels wide by 720 pixels high, is the most common resolution for high-quality exported video. This size looks good on computer screens and televisions, and it’s the recommended upload resolution for YouTube and Vimeo. Chances are good that this is the resolution for you.

	480p SD, at only 854 pixels wide by 480 pixels high, will probably look small on most computer screens. This is the resolution used for DVDs, which every 16-year-old knows are weird artifacts from the distant past. (The first known appearance of a DVD was in a Star Trek episode in the mid- to late 1960s.) Use 480p if file size is a concern.

	Custom in SketchUp Pro “unlocks” settings for Aspect Ratio and Frame Size, which we describe later in this list.



	Aspect Ratio: This refers to the proportions of your video frame; the first name refers to the width and the second to the height. Common aspect ratios for film and video are 16:9 (which is wide) and 4:3 (which is more square). If you’re using SketchUp Pro, you can choose Custom and put whatever you want into the Frame Size fields below this setting.

	Frame Size: Pro users can pick their own video frame dimensions. Go nuts, big spender.

	Preview Frame Size: This is actually an incredibly handy button. Click it to see a green box preview of how big your video will look on your screen. Click the preview to make it go away when you’re done.

	Frame Rate: Different video technologies use different frame rates. Using more frames/second (fps) results in smoother motion but bigger files and longer processing times. Generally speaking, 30 fps is a good sweet spot. If you’re worried about big files, try 15 fps and see how that looks.

	Restore Defaults: Replaces your hard drive’s contents with a looping, 8-second video montage of Keanu Reaves’s greatest cinematic moments. Just making sure you’re still paying attention. In actuality, this button puts everything in Export Options back the way it was before you started messing around.

	Loop to Starting Scene: Automatically ends your video on the scene you started with, rather than the last scene in the sequence. This option is handy if you want your movie to end exactly how it started.

	Anti-alias Rendering: Choosing this doubles the amount of time it takes for your animation to export, but it makes your edges look much smoother in the final movie. You’ll almost certainly want to select this option.

	Transparent Background (Mac only): If you’re planning to use your exported movie with advanced video editing software, this is something that might interest you. Otherwise, you should probably leave this option deselected.

	Always Prompt for Animation Options (Windows only): Select this to force SketchUp to show you the Animation Export Options dialog box every time you export a movie.







Exporting a CAD File

AutoCAD and other CAD (computer-aided drafting/design) programs are popular among architects, engineers, and anyone who needs to build or make super-precise stuff. Although some professionals have totally replaced AutoCAD-based workflows with SketchUp and LayOut, others still use AutoCAD.

If you ever need to export a SketchUp model to a DWG file that works with AutoCAD and other CAD-based software, SketchUp has the inner workings to translate your SKP file into a DWG file. (CAD exports for DWGs and files in other formats is available with a paid SketchUp subscription, in either the desktop or web version.) Because the SKP-to-DWG process is fairly advanced, this section mostly gives you a high-level overview of the export process so that you have a basic understanding of how it works.
 
Preparing your file

First, a few tasks can produce a cleaner exported file. Here’s how to prepare your file before you export it as a DWG file: 


	Check your units. If the unit format (inches or decimals, for example) of your SketchUp file matches the desired units for the DWG file, the export process goes much more smoothly. To check your model’s units, choose Window ⇒ Model Info and select the Units pane on the left. Change the units and precision of your export units by changing the Length units setting in this dialog box.

	Turn off problematic styles. Line styles that use endpoints or extensions don’t always translate well in the export process. If you have problems with endpoints or extensions in your exported file, try turning them off. You turn off the line styles on the Edit tab of the Styles panel. See Chapter 10 for details.

	Set your view. If you’re exporting a 2D DWG file, you're likely exporting a floor plan that may need to reflect a specific scale. If that’s the case, make sure the model is in Parallel Projection view (choose Camera ⇒ Parallel Projection) and uses one of the standard views, such as Top or Front. (Any standard view but Iso is okay.)



[image: Warning] SketchUp exports exactly what it sees onscreen as flat, 2D AutoCAD objects. For example, a SketchUp perspective view of a rectangle ends up as four different-length, different-angle lines lying flat on the AutoCAD X-Y plane.

[image: Technical Stuff] Keep in mind that SketchUp tags may not translate directly to CAD layers.


 
Exporting a 2D DWG file

To export a SketchUp model as a 2D CAD file, follow these steps: 

	
Prepare your file, as explained in “Preparing your file.”

Be sure to not miss the preparation steps in that section.


	Choose File ⇒ Export ⇒ 2D Graphic.

	In the Export dialog box that appears, choose to export your file as a DWG file and then click the Options button.

	
Choose your desired options.

The Drawing Scale and Size section enables you to choose scale options.

[image: Tip] Standard AutoCAD practice is to always draw everything full-size and then tell it to scale the view when printing. This means that the scale factor should almost always be left at the default when exporting from SketchUp.

If your model uses profile lines (see Chapter 10), you can select options here that export the profile lines as CAD polylines and customize the line width if you like. The Separate on a Layer check box, when selected, places profile lines or section cut lines on a separate layer.


	
Click OK in the Export Options dialog box and then click the Export button.

Depending on how big your SketchUp file is, this process can take a while.




 
Exporting a 3D DWG file

When you export a SketchUp file to 3D DWG file, you can select what entities you want to export. For example, you may want to export only edges and leave out faces, dimensions, and text. Follow these steps to export your SketchUp model to a 3D DWG file: 

	
Remember to prepare your file, as explained at the beginning of this section.

[image: Tip] Perspective versus parallel and flat versus oblique view doesn’t matter when exporting as a 3D model. SketchUp always exports an anatomically correct 3D model.


	Choose File ⇒ Export ⇒ 3D Model.

	In the Export Model dialog box that appears, select the DWG file type.

	Click the Options button to select what entities you want to export.

	
When you’re done, click OK.

[image: Warning] If the Faces box is not checked then all you will get is a wireframe model of all the edges. On a complex model, this will result in a huge undecipherable spaghetti pile of lines.


	
Click the Export button.

SketchUp’s gears start converting your file into a CAD-friendly format.



[image: Tip] The Options button on the Export dialog box will let you specify the desired AutoCAD version for the DWG file format. Normally this can be left at the default Release 14 (1997) because a later release of AutoCAD can always open an earlier drawing, but an older release may not open a newer drawing file format.

[image: Tip] If you want to learn more about AutoCAD, one of the best books available is AutoCAD For Dummies (John Wiley & Sons, Inc.), written by one of this book’s co-authors, Bill Fane.





Working with the 3D Warehouse

The 3D Warehouse (see Figure 13-6) is a huge online collection of 3D models that is searchable and, most important, free for everyone to use. To access the 3D Warehouse, all you need is an Internet connection. If you have a SketchUp model that you want to share with the world, share with just a few people, or store on SketchUp’s servers for safekeeping, the 3D Warehouse is where you put it.



[image: Snapshot of 3D Warehouse which is chock-full of models.] 
FIGURE 13-6: 3D Warehouse is chock-full of models shared by people like you.






Why use 3D Warehouse?

[image: Tip] Before we go on, let us dispel a popular misconception right away: When you upload a model to SketchUp’s 3D Warehouse, you aren’t automatically donating your hard work to the world — you can make uploaded models and collections private.

With that understanding, here are some awesome reasons to use the 3D Warehouse: 


	Sharing is good for your self-esteem. To be clear, we don’t subscribe to the nouveau-tech mindset that all information has to be free of charge. If you spent a lot of time on something and you don’t want to give it away, you shouldn’t have to. But if you’re proud of what you made, and sharing it with others would make you feel good, the 3D Warehouse offers a great way to contribute to the 3D modeling community.

	
Create your own personal component library. Because SketchUp can download models directly from the 3D Warehouse into the model you’re working on, making your own online collections is incredibly handy. Everything you upload is accessible anywhere you happen to be working.

For example, you can maintain a collection of the furniture in your house. Whenever you need a model of your sofa, you can just download it — no matter what computer you’re using.


	Explore uploaded models in 3D without having to download them. You can orbit, pan, and zoom around any model you can see on the 3D Warehouse — without having to download it into SketchUp first. If you want to show someone your model in 3D, you can just send them its 3D Warehouse link. Better yet, you can embed a 3D viewer window on your web page; anyone who visits your page can poke around.

	It’s never a bad idea to have a backup. If all you’re looking to do is save a copy of your work in the cloud (where you can’t spill your coffee all over it), services like Dropbox, Google Drive, and Microsoft OneDrive are great choices. None of these, however, give you direct access to your models inside of SketchUp. When you upload something to the 3D Warehouse, it’s both safe and readily available. It’s also a good idea to keep a backup of everything on a removable USB drive and store it away from your computer, preferably in a different building.




 
Getting to the 3D Warehouse

You can get to the 3D Warehouse in two ways: 


	From SketchUp: Choose Window ⇒ 3D Warehouse. A mini web browser opens right in front of your modeling window. In SketchUp for Web, use Search to find and open 3D Warehouse.

	
From the web: Browse to https://3dwarehouse.sketchup.com.

[image: Tip] Accessing the 3D Warehouse from the web is a great way to hunt for and curate 3D models to quickly create component collections for use as you’re modeling.




Go ahead and poke around the 3D Warehouse. It’s amazing what you find; thousands of people add new content every day. Much of it isn’t very useful, but you still find plenty of interesting things to download and look at.

[image: Tip] Taking apart strangers’ models is a great way to figure out how they’re built.


 
Find, preview, and download models

Before we get into sharing models, here’s a quick explanation of the most important thing you’ll do in 3D Warehouse: Search, evaluate, and download 3D models: 


	Finding models: Once you’ve searched in 3D Warehouse (refer to Figure 13-6), there are various ways to refine and improve your model search results. In particular, we recommend filtering your results by either Popularity or Likes and using Categories (in the upper left of your search results) to filter out models that aren’t related to what you’re looking for.

	Evaluating models for size and performance: Be careful about downloading models that are very big or complex. Unfortunately, a bad 3D Warehouse download can cripple your model. Keep the junk out by restricting the file size and polygon count of your searches.

	Downloading models: If you’re using 3D Warehouse while modeling, models you download will import directly into SketchUp, where they are placed on the cursor of the Move tool. Move the cursor to the desired location in your model and then click to place the new component at that location. If you downloaded a SKP file from 3D Warehouse in a web browser, you can drag and drop that file into SketchUp to place it in your model.




 
Uploading a model

Follow these steps to upload your model to the 3D Warehouse: 

	
Open the model you want to upload in SketchUp and fiddle around with your view until you like what you see.

When you upload a model to the 3D Warehouse, SketchUp automatically creates a preview image that’s a snapshot of your modeling window.


	
Choose File ⇒ 3D Warehouse  ⇒ Share Model.

A mini-browser window opens, and it shows the logon screen for the 3D Warehouse. If you want to upload models, you need a Trimble ID or a Google account. Both types of accounts are free; you just need a valid email address to get one. If you don’t already have one, follow the on-screen instructions to sign up.


	Enter your account information, click the Sign In button, and fill out the Upload to 3D Warehouse form as completely as you can: 
	Privacy: You can choose to make your model Public or Private. Checking the Public option gives anyone the right to find, download, and use your model however they like. If you select Private, your model stays hidden from everyone but you. Flip ahead to “Managing models online” for more about this topic.

	Title: Enter a title for your model. If it’s a public building, you may enter its name. Something like Royal West Academy would do nicely.

	Description: Models with complete descriptions are very popular among people who hunt around the Warehouse. Try to use complete sentences here; the more you write, the better. If you want to make your model a bit more findable, use a hashtag (#) — for instance, #dummies.

	Category: Pick a category and then a subcategory to make it easier for other people to find your fantastic model.



	
Click the Upload button to add your model to the 3D Warehouse.

If everything works properly you will see a page with your model on it, along with all the information you just entered. Congratulations — you’re now a full-fledged member of the SketchUp universe.

[image: Tip] It takes a while for the 3D Warehouse’s robots (its back end, in geek parlance) to process your model after you upload it. You won’t be able to search for it, see it in your collections, or even preview it in 3D for a few minutes. But that’s okay — just sit back and reflect on what your great-grandfather would say if he heard you complaining. After all, he did have to walk 50 miles to school, uphill both ways.



[image: Remember] When you activate SketchUp, you’ll be prompted to sign-in. When uploading models to 3D Warehouse, use the same login info (email and password) that you use when you sign-in to 3D Warehouse or the SketchUp Viewer. (Read all about the SketchUp Viewer in Chapter 15.)

All your uploads are available in the My Content page. To get there, click the Account drop-down menu, the head-in-a-circle icon in the top-right corner of the screen. Click My Content to see the models you’ve uploaded or browse models you’ve curated (see Figure 13-7).
 


Managing models online

3D Warehouse can sometimes feel like a free-for-all of individual models floating around in cyberspace. But if you use it intentionally, it’s actually a pretty organized place.



[image: Snapshot of the models you upload which are on the My Content page.] 
FIGURE 13-7: The models you upload (or organize) are on the My Content page.






If you are downloading models, Figure 13-8 shows the doodads and gadgets you should pay attention to on a model’s details page: 


	3D model preview: This preview, which is available in a web browser only, enables you to hover over the image of a model and click 3D Model to preview the model using SketchUp’s camera tools. If you don’t have a mouse, press O for Orbit and H for Pan.

	Statistics panel: The numbers that appear on this section of the page are all interesting and useful, but the ones you should pay closest attention to are Polygons and Materials. These tell you the model’s size in the three metrics that count most: 
	Polygons is 3D modeling shorthand for faces; the more you have, the harder SketchUp has to work to display your model. If you’re thinking about downloading a tree with 350,000 polygons, consider taking a vacation to Tahiti while SketchUp opens it.

	Materials are similarly taxing on your computer’s performance, but they only come into play for models that have been heavily photo-textured.

	Distance from Origin is how far away the geometry in a model is from the origin of that model. The bigger the number this is, the worse your model will perform when you initially load it into SketchUp. You can fix this, but beware: A model that is very far from the origin is likely to have other problems!



[image: Snapshot of a model in 3D Warehouse.] 
FIGURE 13-8: Something’s fishy about this model in 3D Warehouse.







	Related Collections: If the model you’re searching for doesn’t quite do the trick, it can be useful to browse related Collections compiled by other people who are interested in the same thing you are looking for.



In addition to information about a model you’re looking at, either yours or someone else’s, you’ll find some valuable tools for curation and organization, just below the title of the model. 


	Like models: Liking a model by clicking its heart icon is a quick way to give it positive feedback. Likes make it easier for people to find useful 3D models. Whether or not you share models, you can help improve 3D Warehouse by liking things. Models you like are saved for you in My Content (on the Account menu).

	Adds to Folders or Collections: One of the most productive things you can do on the 3D Warehouse is collect models — your own and other people’s. Make yourself empty collections for things like chairs, scale figures, trees, and star destroyers. Then fill them with the amazing models you find as you’re exploring. Back in SketchUp, in the Components panel, choose My Collections from the Collections drop-down menu, and there they are, ready to use in your own work. Collections are public, so if you prefer to keep your libraries private, use Folders instead. In SketchUp, able to access folders by going to My Content in the 3D Warehouse mini-browser.

	
Embed: Click here, and the 3D Warehouse serves up some HTML code that you can use to embed the model on a web page.

[image: Tip] The Embed feature is especially important for product manufacturers, designers, and anyone else who wants to let people explore a model in 3D without leaving their website.




While we’re on the subject of collections and folders, here’s how to create and manage them: 

	
Make sure you’re logged in to the 3D Warehouse.

If you're logged in, you’ll see your username on the account drop-down menu at the top of every page in the Warehouse. If you’re not logged in, click Sign In (also at the top of every page) and enter your account credentials.


	Go to the model details page (refer to Figure 13-8) for a model you want to add to a Folder or Collection.

	
To create a Folder or a Collection, click on the appropriate Folder or Collection icon.

[image: 9781119617938-ma073] The Folder and Collections icons are located just below the lower-left corner of the image in the model details page. The Folder icon looks like a folder, and the Collection icon is right next to it.

First things first: Decide how you want to organize things. Remember, folders are private to you; collections are visible to everybody. Then create a name for your new library. You can also create new folders or collections, using the icons on the My Content page.


	
To add a model to an existing folder or collection, choose it from the list.

As you create more folders and collections, you’ll see designations when you click the Folder or Collections icons. Add the model you are viewing to a folder or collection by choosing it from the list that appears.



If you find yourself working on the same kind of project over and over, these techniques for searching for, evaluating, and organizing models comes in handy big time. A well-organized stash of attractive, high-performance SketchUp components is one of your best weapons for dramatically speeding your modeling. After all, why draw something from scratch if a perfectly good something already exists?






     

Part 5

The Part of Tens

IN THIS PART…

Maneuver the common modeling problems and technical traps that often trip people up.

Discover SketchUp extensions that add new tools and modeling efficiency.

Load your models on smartphones and tablets to reference or share your work.

Connect with the SketchUp community to tap into a worldwide base of knowledge and inspiration.






Chapter 14

Ten SketchUp Traps and Their Workarounds

IN THIS CHAPTER

[image: check] Knowing why faces, colors, and edges aren’t behaving right

[image: check] Coping with a slow or crashing SketchUp

[image: check] Viewing your model the way you want

[image: check] Persuading components to budge

[image: check] Recovering from Eraser disasters



The bad news is that every new SketchUp user encounters certain problems, usually in the first couple hours of using the software. You can call these problems growing pains. The good news is that, because these problems are common, we can write a chapter that anticipates a lot of the bad stuff you’ll go through. This chapter offers tips that help you make sense of what’s going on so you can get on with your life as quickly as possible.



SketchUp Won’t Create a Face Where You Want It To

You’ve dutifully traced all around where you want SketchUp to create a face, but nothing’s happening. If you follow along in Figure 14-1, which was inspired by a visit to the M.C. Escher museum in Amsterdam, you see the top-left image seems to show a cube beside a rectangle, but the rectangle didn’t produce a face. In the top-right image, a diagonal line was drawn between diagonally opposite corners of the rectangle, producing two triangular faces, but something still doesn’t look right.

Changing the camera position to standard front (lower-left image) and right side (lower-right image) reveals the source of the problem. It turns out that the upper-right corner of the rectangle doesn’t lie on the red-blue plane but is actually to the right of the blue-green plane, and to the right of the blue-red plane. The upper-left image isn’t really an optical illusion; it just looks like one.



[image: Schematic illustration of the models.] 
FIGURE 14-1: Just because it looks right doesn’t mean that it is.






[image: Remember] Ninety percent of the time, when SketchUp doesn’t create a face where you think it should, an edge isn’t on the plane you think it’s on. To check whether your edges are coplanar, draw an edge that cuts diagonally across the area where you want a face to appear. If a face appears now, your edges aren’t all on the same plane. To fix the problem, you have to figure out which edge is the culprit, and the Color By Axis option may help you see this information at a glance. Here’s how Color By Axis works: 

	
In the Styles panel, change your edge color from All Same to By Axis.

See Chapter 10 for details. SketchUp draws the edges in your model using the color of the axis to which they’re parallel; edges parallel to the red axis are red, and so on.


	
Look carefully at the edges that you wanted to define your desired face.

Are all the edges the color they’re supposed to be? If they’re not all supposed to be parallel to the drawing axes, this technique doesn’t do much good. But if they are, and one (or more) of them is black (instead of red or green or blue), that edge (or those edges) is your problem child. Fix it and switch back to All Same when you’re done.



If the plane isn’t the problem with your edges, then check whether one edge is part of a separate group or component. To check whether you have a component problem, try hiding groups or components and checking the edges to make sure that they’re all in the group or component you think they’re in. See Chapter 5 for details.

[image: Tip] A common source of this problem is inferences. As you slide the mouse over a face you may unwittingly be latching on to an unintended inference, such as the edge of a surface that is part of a cylinder. Watch those inference prompts, and use Undo when you complete a face but no face appears.



Your Faces Are Two Different Colors

[image: Remember] In SketchUp, faces have two sides: a front and a back. By default, these two sides are different colors.

When you use certain tools, such as Push/Pull or Follow Me, on a face, sometimes the faces on the resulting geometry are “inside out.” For some people, the issue is just bothersome. If you want to 3D-print your model, you need to fix the issue so that your model will print correctly.

To fix this issue, right-click the faces you want to flip and choose Reverse Faces from the context menu. If you have lots of faces to flip, you can select them all and then choose Reverse Faces to flip them all at once.

In 3D printing, this process is called checking your model’s normals. See Chapter 9 for details about preparing a model for 3D printing.

The plan for the structure in Figure 14-2 was for all the outside walls to be wood siding and the interior walls to be painted yellow. But the top two images show that somehow the left wall got reversed. The bottom two images show that the problem has been solved by selecting the yellow face and reversing it.



[image: Schematic illustration of reversing the faces.] 
FIGURE 14-2: Reversing the faces.








Edges on a Face Won’t Sink In

Edges on a face tend not to sink in when you’re trying to draw a rectangle (or another geometric figure) on a face with one of SketchUp’s shape-drawing tools. Ordinarily, the Rectangle tool creates a new face on top of any face you use it on; after that, you can use Push/Pull to create a hole, if you want.

When the edges you just drew don’t seem to cut through the face you drew them on, try these approaches: 


	Retrace one of the edges. Sometimes that works — you’d be surprised how often.

	Select Hidden Geometry from the View menu. You’re checking to make sure that the face you just drew isn’t crossing any hidden or smoothed edges; if it is, the face you thought was flat may not be.

	Make sure that the face you drew on isn’t part of a group or component. If it is, undo a few steps and then redraw your shape while you edit the group or component.

	Select the face + edges, right-click, and choose Intersect Faces ⇒ With Selection. This approach is often needed when you are working with one or more curved surfaces.





SketchUp Crashed, and You Lost Your Model

Unfortunately, SketchUp crashes happen sometimes. The good news is that SketchUp automatically saves a copy of your file every 5 minutes.

In the web version, these autosaves are captured in Trimble Connect as revisions. You can always view the revision history for a file by navigating to it in the Trimble Connect tab (by clicking Open in the menu at the top of the screen to access Trimble Connect). For any file, you can choose to view or restore an older version.

In desktop versions, the file that SketchUp autosaves is actually a separate file, AutoSave_yourfilename.skp. If your file ever gets corrupted in a crash, an intact file is ready for you.

The problem is that most people don't even know that the autosaved file is there. Where do you find it? If you’ve ever saved your file, the autosaved file is in the same folder as the original; therefore, it’s very important that you save your file almost immediately after starting it.

[image: Technical Stuff] Simple, right? Not so fast. On a Mac, you may need to change your Library folder from hidden to visible. In the Finder app, hold down the Option key while you choose Go ⇒ Library. If you don’t hold down the Option key, Library may not appear on the menu.

When you close your model, SketchUp typically assumes nothing untoward has happened and usually cleans up after itself by deleting the autosaved file.

[image: Tip] The really good news is that every time you save a file, SketchUp proactively saves two identical files, one with the normal file extension .SKP and the other with the file extension .SKB. You continue working on the .SKP file. If something goes really wrong with your model, you can always go back to how it was an instant before the last time you saved it. But you can’t find it in the Open File dialog box. Here’s the secret: In the Open File dialog box, go to the end of the File Name window, click the down arrow beside Sketchup Models (.SKP), and click All Files. Now the .SKB files show, and you can open them. (Web: The same basic principles apply, but read more details at https://help.sketchup.com/en/sketchup-web/saving-opening-and-downloading-models.)

[image: Tip] To minimize the amount of work you lose when software (or hardware) goes south, always do two things: 


	Save often — compulsively, even.

	Use the Save a Copy As command on the File menu.



When you’re working on a big project, the following steps can help ensure you don’t lose any work: 

	
Save the original version of your file as yourfilename_Master.skp.

That’s the file you’ll always be working on.


	Create a folder that lives in the same place as your Master file; call the folder something like Your file’s name Archive.

	
Every half-hour or so, choose File ⇒ Save a Copy As, and save a sequentially numbered version of your file to the Archive folder.

When you’re building a big model, it’s not uncommon for your Archive folder to contain 40 or 50 saved versions of the model dating back to when the project first started.


	
Back up regularly.

At least at the end of every work session, such as when you head to a coffee or lunch break, back up your files to a low-cost, high-capacity, high-speed portable USB drive, then remove it and keep it separate from your computer. At the end of your shift, take it to a different location. You don’t need to keep it in a bank vault, just in a separate building. Take it home at night, for example.

[image: Remember] You can always buy new hardware and software, but you can’t buy your personal files.





SketchUp Is Sooooo Slooooooooow

The bigger your model, the worse your computer’s performance. What makes a model big? In a nutshell, faces.

[image: Tip] Do everything in your power to keep your model as small as you can. Here are some tips for doing that: 


	Reduce the number of sides on your extruded circles and arcs. See Chapter 6 for instructions.

	Use 2D people and trees instead of 3D ones. 3D plants and people have hundreds of faces each. Consider using 2D ones instead, especially if your model won’t be seen much from overhead.

	Use search filters in 3D Warehouse. When you’re searching for models in 3D Warehouse, you can restrict your search result to show only models of a certain file size or polygon (face) complexity. Especially if your model is more than 10 MB, it makes sense to keep your 3D Warehouse downloads small!



Some models are just big, and you can’t do much about it. Here are some tricks for working with very large SketchUp models: 


	Make liberal use of the Outliner and tags. As we explain in Chapter 7, these SketchUp features were specifically designed to let you organize your model into manageable chunks. Hide everything you’re not working on at the moment; doing so gives your computer a fighting chance.

	Substitute simple forms for large numbers of complex components. For example, insert sticks as placeholders for big sets of 3D trees, cars, and other big components. The tips for replacing components in Chapter 5 explain how to swap the placeholders with more complex components.

	Turn off shadows and switch to a simple style, such as Shaded in the Default Styles collection. It takes a lot of computer horsepower to display shadows, edge effects, and textures in real time on your monitor. When you’re working, turn off all that stuff. Chapter 10 is all about styles, and FastStyles in particular.

	Use scenes to navigate between views. Scenes aren’t just for presenting your model; they’re also great for working with it. If you create scenes for the different views you commonly use and with different combinations of hidden geometry, then you don’t have to orbit, pan, and zoom around your gigantic model. To speed up things even more, deselect Enable Scene Transitions in the Animation panel of the Model Info dialog box. (Web: Animation settings are in the Scenes panel.) Chapter 11 is full of tips on working efficiently with scenes.





You Can’t Get a Good View of the Inside of Your Model

It’s not always easy to work on the inside of something in SketchUp. You can do these things to make it easier, though: 


	Cut into your model with sections. SketchUp’s Sections feature lets you cut away parts of your model — temporarily, of course — so that you can get a better view of what’s inside. Take a look at Chapter 11 for the whole story on sections.

	Widen your field of view. Field of view is the part of your model you can see onscreen at one time. A wider FOV is like having better peripheral vision. You can read all about it in Chapter 11.



[image: Tip] You can change the field of view only when in Perspective view mode, but the setting will be remembered if you then switch to Parallel view mode.

Figure 14-3 shows the plan view of a room. If you zoom or walk in through the door — oops, tunnel vision. Increase peripheral vision by changing your field of view. Ah, that’s better! Now you can see that the picture hanging on the wall is the floor plan of this room.



[image: Schematic illustration of changing the field of view that makes a world of difference.] 
FIGURE 14-3: Changing the field of view makes a world of difference.








A Face Flashes When You Orbit

If you have two faces in the same spot — maybe one is in a separate group or component — you see a Z-fighting effect. SketchUp is deciding which face to display by switching back and forth between them; it’s not a good solution, but certainly a logical one — at least for a piece of software. Figure 14-4 attempts to portray this effect in a single image. The only way to get rid of Z-fighting is to delete or hide one of the faces.



[image: Schematic illustration of two faces fighting for the same 3D real estate.] 
FIGURE 14-4: Two faces fighting for the same 3D real estate.








You Can’t Move Your Component the Way You Want

When you insert some components into your model, the components by default glue to faces. A glued component instance isn’t actually glued in one place. Instead, it’s glued to the plane of the face you originally placed (or created) it on. For example, if you place a sofa component on the floor of your living room, you can move it around only on that plane — not up and down.

This gluing behavior comes in handy when you deal with things like furniture; it allows you to rearrange things with the Move tool without accidentally picking them up.

If you can’t move your component the way you want to, right-click it to see whether Unglue is an option; if it is, choose it. Now you can move your component around however you want.



Bad Stuff Happens Almost Every Time You Use the Eraser

When you use the Eraser tool, it’s pretty easy to delete stuff accidentally. Worse, you usually don’t notice what’s missing until it’s too late. Here are some tips for erasing more accurately: 


	Orbit around. Try to make sure that nothing is behind whatever you’re erasing; use SketchUp’s navigation tools to get a view of your model that puts you out of danger.

	Switch on Back Edges. When you’re doing a lot of erasing, choose View ⇒ Edge Style ⇒ Back Edges. That way, you can see every edge in your model, and you’re less likely to erase the wrong ones.

	Use the Undo modifier of the eraser. Follow along starting in the upper-left image in Figure 14-5. The intent is to erase the four edges in the center to create a single face. While erasing, you can select multiple objects by holding down the left mouse button while dragging the eraser over them. Oh, great googly moogly (or words to that effect) — you selected some things you didn’t want to erase. No problem: Don’t release the mouse button, but press and hold down the keyboard Alt key (Mac: ⌘  ). Now anything you drag the eraser over will be unselected. You can switch back and forth as desired, but nothing actually gets erased until you release the mouse button.

	Double-check. After you do a lot of erasing, give your model a quick once-over with the Orbit tool, just to make sure that you didn’t get rid of anything important. Put a sticky note on your computer monitor that says something like Check after Erase! just to remind you.




[image: Schematic illustration of the uneraser in action.] 
FIGURE 14-5: The uneraser in action.








All Your Edges and Faces Have Different Tags

[image: Warning] Using Tags in SketchUp can be a dangerous business. Chapter 7 has tips you should follow when using tags, so we don’t repeat them here, but here’s the short version: Always build everything on Untagged, and assign whole groups or components to other tags only if you really need to.

If you used tags and now things are messed up, here’s what you can do to recover: 

	
Make sure that everything is visible.

Select Hidden Geometry on the View menu; then (in the Tags panel) make all your tags visible. Just make sure that you can see everything in your model.


	Choose Edit ⇒ Select All.

	In the Entity Info panel, move everything to Layer0.

	In the Tags panel, delete your other tags.

	When you’re prompted, tell SketchUp to move anything remaining on them to Untagged.

	Create new tags, and follow the rules in Chapter 7.


[image: Tip] If you’ve downloaded 3D Warehouse models, you’ll probably find that they have some tags that you don’t understand and might want to get rid of. They may have had significance to the original creator, but they can become clutter in your file, so they should be removed.




      

Chapter 15

Ten SketchUp Quick Wins

IN THIS CHAPTER

[image: check] Customizing shortcuts

[image: check] Mastering inferencing

[image: check] Zooming by jumping

[image: check] Discovering SketchUp Extensions

[image: check] Viewing and using your models on a smartphone



As you set off on your modeling adventure, we want to equip you with ten SketchUp quick wins — techniques or extended workflows that upgrade the 3D superpowers you’ve been reading about in this book.

As this chapter’s title implies, you’ll find that these tips and tricks are pretty quick to pick up. Moreover, many of these techniques are designed to speed the core mechanics of your 3D modeling.

In fact, quick wins like these are available in every project you’ll do in SketchUp — hidden gems you’ll discover when you think “There’s got to be a quicker way to do this.” When you’re struggling, step back and realize that there is indeed a smarter way.



Setting Your Click Style to Click-Move-Click

We hate to say it, but it’s possible that you’ve gotten this far in the book while click-dragging your mouse for many SketchUp operations. If for some reason you haven’t picked up the technique that lets you move your mouse freely between the beginning and end of most operations, you can force yourself to learn.

On the Window menu, choose Preferences (Mac: the SketchUp menu; Web: app settings). In the Drawing section of the resulting dialog box, change from Auto Detect to Click-Move-Click (see Figure 15-1).



[image: Snapshot of the list of options to click-move-click for you from now on.] 
FIGURE 15-1: It’s click-move-click for you from now on.






Click-move-click is what SketchUp calls click-release, click. But you don’t even have to think about what it’s called, because after you change that preference, it’ll be the only way SketchUp works.



Customizing Shortcuts

By this point in the book, we sincerely hope that you’ve picked up the default keyboard shortcuts. If you haven’t, head back to Chapter 1 to review the core default shortcuts.

When you know the default shortcuts, we suggest that you customize and use another dozen helpful shortcuts. You may be familiar with these commands from previous chapters — you’ve got a photographic memory, right? — but we’ve compiled them here and suggested shortcuts to assign to each command. You can choose your own shortcuts, of course; our suggestions are based on personal preferences and thumb wars.

[image: Remember] In desktop versions of SketchUp, you create or edit shortcut customizations by choosing Window ⇒ Preferences (Mac: SketchUp ⇒ Preferences). To assign shortcuts, look up the name of the command you want to customize and then click the input field to type a custom shortcut key.

In SketchUp for Web, use Search to look up the commands. When you mouse over a command name, you see a little empty rectangle to the right of its description. Click that rectangle to assign or reassign a shortcut.

Here are ten shortcuts to customize right now: 


	X-ray (X): The X-ray face style toggles the transparency of faces in a model. This shortcut is super-handy if you’re designing pieces that fit together and working with solid tools. X-ray is also great when you’re making complex selections; it helps you understand whether you’ve selected more than you want. If you use the shortcut, you can toggle X-ray on demand.

	Hide Rest of Model (Shift+M): As your model becomes complex, you’ll want to get a better view of the groups and components that you need to edit. This display command turns off everything outside the context of a group and component so that you can orbit around and see what you need to see. SketchUp also operates considerably faster when you hide the rest of the model while editing a piece of it.

	Color by Axis (Shift+X): In Chapter 3, we say that you might slip in an inference with the Line tool and create a mysterious missing face. This mistake happens often enough that it’s handy to have the Color by Axis style toggle at your fingertips to identify edges that have strayed off course. Like the X-ray shortcut, it helps you spot important details.

	View Hidden Geometry (Shift+H): Whether you hide edges and faces yourself, SketchUp hides them all the time. Whenever you extrude arcs or circles, SketchUp creates hidden edges. As your modeling skills improve, you’ll often need to see this hidden geometry to grab better inferences, so this shortcut comes in handy.

	Perspective or Parallel Projection (Shift+P): For some reason, these two camera settings do the same thing: toggle between a perspective and orthographic view of your model. If you’re setting up a model to create plans or elevations, you’ll find yourself using this shortcut (which you need to assign to only one of the commands) to switch your world view back and forth.

	Create Scene (+): Scenes are really useful for saving a view or a design scenario. You can create them on the fly with this simple shortcut.

	Previous & Next Scene (< and >): If you’re considering presenting from SketchUp, we recommend setting up this simple pair of shortcuts to reverse or advance a scene-by-scene narrative. The people you’re presenting to will think you’re a wizard.

	Shadows (Shift+S): Let’s face it: Shadows make your SketchUp model look cooler. But they can slow SketchUp as your project grows in size. Slip shadows on and off occasionally. We think you’ll find that intermittent shadow feedback to be visceral and pleasing, like a free bottle of sparkling water.

	Make Group (G) and Make Component (Shift+G): We’re going rogue here: We think you should overwrite the default shortcut for the important Make Component command and instead assign G to Make Group. You don’t always know what an object is when you start creating it, and making a component costs you a few extra clicks. So keep G on your trigger finger to create a group immediately, drawing objects in their own modeling context right away. Then, after you’ve made a group, press Shift+G if the group needs to be a component. That right there, friends, is what we call gunslinger SketchUp.

	Paste in Place (Shift+V): You’re going to be using Paste in Place all the time — more often than normal pasty Paste but not so much that you can break your Ctrl+V muscle memory. Bring Shift+V into your 3D lexicon to move geometry in and out of groups or components (or across modeling files) efficiently.





Using the Inference Locking Force

Inferencing is like the way of the Jedi. You must trust the inferencing force and know that it is always with you in SketchUp — and can be invoked with arrow keys.

We’ve touched on inference techniques here and there in this book, but here are two inferencing techniques that will significantly speed your work: 


	Use the arrow keys to lock orientation for the Move tool. When you want to raise or lower something in SketchUp, activate the Move tool, click your selection on its bottom corner, and press the up arrow key. Now your cursor is free to roam the screen, and you can to pick an exact finishing height for your move. Inference locking with the arrow keys is as accurate as any other technique but requires less mental effort (see Figure 15-2).

	
Use the Get Down inference to operate off axis. This is the best inference name ever, right? Seriously, our new favorite inference technique is to hover over a face or an edge and then press the down-arrow key to lock a tool orientation (the magenta inference; see Figure 15-3). The Get Down inference lets you treat the orientation of any edge or face as if it were a fourth axis, along with red, green, and blue. That’s why it’s so hip, man.

To get off the down-arrow inference, first, click the down key again. The magenta inference will run perpendicular to your reference. Click the down key a third time and you’ll unlock the inference.





[image: Snapshot of inference locks help to move precisely and fluidly.] 
FIGURE 15-2: Inference locks help you move precisely and fluidly.







[image: Snapshot of using the down key to lock tools to off-axis orientations.] 
FIGURE 15-3: Use the down key to lock tools to off-axis orientations.








Transporting Yourself across Space and Time

Okay, the title is a slight exaggeration, but some camera tools help you warp through a SketchUp model with much less effort than orbiting and zooming across a model. Integrate them, and your perceived effort of modeling goes down. That’s a big deal!

Try these camera techniques to see whether any of them sticks for you: 


	Use the Orbit tool to center your screen on an object. If you’re modeling an interior, this tool is a handy way to skip your view across a room. With Orbit activated, double-click any geometry on the screen. SketchUp jumps to center your screen on the focus of the double-click.

	Use Zoom Window to jump to a nearby selection. With Zoom Window (choose Camera  ⇒ Zoom Window), you can use a selection window to jump your view closer to a specific area (see Figure 15-4). We recommend not using Zoom Window to jump to areas that are very far away.

	Use Zoom Selection to jump right to a selection. If we were to ask you to remember one more keyboard shortcut, this one might be it. With the Select tool activated, you can right-click an object and choose Zoom Selection from the shortcut menu to warp right to it.




[image: Snapshot of using the Zoom Window to jump the zooms to a desired spot.] 
FIGURE 15-4: Use Zoom Window to jump your zooms to a desired spot.








Rounding Off Edges with the Arc Tool

The following technique for rounding corners around a series of edges is just too cool to leave out of this book. This fillet — or rounding — method works on flat faces only.

Follow these steps and reference Figure 15-5 to round edges: 

	[image: 9781119617938-ma005] With a flat face, activate the two-point Arc tool.

	Near one of the junctures between two edges, click to start drawing an arc.

	Hover your cursor over the adjacent edge to find the magenta tangent inference.

	
Double-click to finish your arc.

The face and edges on the outside of your arc disappear. But wait, there’s more.


	
Move your cursor close to another corner or intersection, and double-click the face (not the edges).

The round-off repeats and will keep repeating if you continue to another intersection of edges. Without changing from the Arc tool, you can continue to apply the same rounding to as many edge intersections as you want as long they’re on a flat, nonextruded face.





[image: Snapshot of double-clicking to fillet.] 
FIGURE 15-5: Double-click to fillet.






[image: Tip] This method of rounding edges is also configurable. When you’re done rounding, use the Select tool to select an arc, then open the Entity Info panel to redefine the arc’s radius or segments. Pretty smooth — or at least as smooth as you want it.
 


Using the Scale Tool to Set Length for Simple Objects

Here’s a quick alternative for simple extrusion when you know exactly how long a simple, uniform object (such as a 2×4) needs to be: 

	[image: 9781119617938-ma020] Select the object you want to scale.

	Make the object a group, if it’s not one already.

	Using the Scale tool, click one of the middle grips that define the length of the object.

	
Scale the object in one direction.

If you chose the right grips, the object extrudes as though you ‘re push/pulling it. If you grabbed the wrong grip, press the Esc key and try again.


	
Click to finish your scaling.

Click anywhere at all.


	
Type how long you want that object to be and press Enter to set the length.

Just like telling SketchUp the length of an extrusion after using the Push/Pull tool, you can define the dimensions of a Scale operation by typing an input right after finishing the operation (see Figure 15-6).



As we said, this technique works only with simple, uniform objects — such as dimensional lumber — but it’s very useful when you need to redefine the length of a piece without a few extra clicks of the Tape Measure tool.



[image: Snapshot of typing a measurement while scaling a uniform object to define its length.] 
FIGURE 15-6: Type a measurement while scaling a uniform object to define its length.








Ten Extensions for Dummies

Truth be told, we could write an entire chapter on SketchUp extensions — the add-on apps that you can install to access more modeling tools. We prefer to think of extensions as being like gems you find in a dungeon, unlocking new powers in SketchUp. (Honestly, we could probably write an entire book on extensions.)

But SketchUp extensions can give you superpowers — and they’re incredibly fun — so they’re worth exploring.

[image: Remember] Extensions are available only in desktop versions of SketchUp. You have to have a Pro subscription to use them.

The quickest way to find and install extensions is to use Extension Warehouse (choose Window ⇒ Extension Warehouse). Extension Warehouse (see Figure 15-7) works just like an app store on your smartphone: You search for extensions, browse them by category, and install them in SketchUp. You can install many extensions for free; others cost a little bit of money.




After you’ve installed an extension, use Extension Manager to check its status or deactivate it. Choose Window ⇒ Extension Manager to find a few extensions that come installed in SketchUp Pro. (We’ve tried a few of them in this book.)

[image: Tip] Deactivating extensions (see Figure 15-8) that you don’t use is a good idea, especially as you start collecting them. Fewer enabled extensions usually means faster and more stable modeling.



[image: Snapshot of the extension Warehouse which is an app store in SketchUp.] 
FIGURE 15-7: Extension Warehouse: An app store in SketchUp.






[image: Snapshot of using the extension Manager to turn off tools that are not being used.] 
FIGURE 15-8: Use Extension Manager to turn off tools you’re not using.






 

THE SketchUcation PLUGIN STORE
 
As great as Extension Warehouse is, we recommend that you go to SketchUcation.com and download the Plugin Store extension (https://sketchucation.com/resources/plugin-store-download). SketchUcation is a longtime home base for many SketchUp community exerts and developers. The Plugin Store is an alternative repository of extensions (some of which we recommend in Table 15-1).

Along with this deep library of SketchUp extensions, SketchUcation offers some great resources such as SketchUp content — styles, textures, and models — and a reservoir of knowledge in the SketchUcation Community Forum. Like the SketchUp Forums, this store is a good place to go when you need a little help. As everywhere else on the Internet, the nicer you ask a question, the better an answer you’ll receive. 


[image: Snapshot of the SketchUcation Community Forum.] 








When will you need extensions? That’s the question! To help you start thinking more three-dimensionally about your modeling, in Table 15-1 we share ten add-ons that are worth checking out — and teaching yourself — as you get into the wild world of SketchUp extensions.
 



TABLE 15-1 Ten SketchUp Extensions

	
Extension

	
What to Use It For

	
Get It From

	
Weld

By Smustard

	
Singe edges together. Ideal for welding tangent arcs for smooth extrusions. Weld is free, and it’s almost essential for a good Follow Me.

	
Extension Warehouse




	
Bézier Curve

By SketchUp

	
Chapter 12 covers drawing complex curves in LayOut. You can use this extension to get 3D curves. This extension is also very useful for tracing over hand sketches or imported images.

	
Extension Warehouse




	
Soap Skin Bubble

By Josef L.

	
Create complex mesh faces between noncoplanar edges (like a loop of whacky Bézier curves).

	
Extension Warehouse




	
Joint PushPull

By Fredo6

	
Give almost anything thickness with this 3D extruder, including that wacky shape you made from Bézier curves.

	
SketchUcation Plugin Store




	
RoundCorner

By Fredo6

	
Precise chamfering and filleting — basically, edge magic.

	
SketchUcation Plugin Store




	
Skimp

By Mindsight Studios

	
You’ll find lots of models on the Internet that are too big to load into your project. Skimp simplifies these behemoths to a noncrippling size for composition in SketchUp.

	
Extension Warehouse




	
Open Cut List

By L’Air du Bois

	
Designate objects as a certain kind of wood and then use this extension, which spits out a list of pieces and a cutting diagram that accounts for kerf, clearance, and the dimensional lumber you’re working with. Make some sawdust!

	
Extension Warehouse




	
Mirror

By TIG

	
If you use other CAD programs, you’ve probably spent some time looking for this extension, which quickly copies and inverts a selection across a defined plane.

	
SketchUcation Plugin Store




	
True Bend

By ThomThom

	
Lots of extensions that bend and distort models, but the best one to start with is True Bend, which bends an object around a 360-degree radius.

	
Extension Warehouse




	
Eneroth Random Selection

By Eneroth3

	
Variety can do wonders for your model. Use this extension to randomly select objects in a uniform array. Then move, scale, or replace them to inject chaos into SketchUp.

	
SketchUcation Plugin Store








Getting SketchUp on Your Smartphone

Okay, we know: You can’t use SketchUp to draw 3D models on your smartphone.

But you can get the free SketchUp app on a smartphone or tablet to view and reference your models. Think about walking around a hardware store with an exploded view of your model or a scene in which you’ve saved a parts list or cutting layout. Here’s how to get your models on a phone or tablet: 

	
Install SketchUp Viewer from an app store.

This part is pretty simple. Go to the app store for your device, and search for SketchUp Viewer (see Figure 15-9).


	
Open the app, and access models stored in Trimble Connect, 3D Warehouse, Dropbox, or on your device.

If you use SketchUp for Web, the models you’ve saved are already stored in Trimble Connect. If you use SketchUp Pro, you can store your models in Trimble Connect (choose File ⇒ Trimble Connect ⇒ Publish Model) or upload models to 3D Warehouse. Models that you’ve stored in any of these places are available by clicking the cloud icon in the top-right corner of the screen. Additionally, you can load models from Dropbox or from device storage.





[image: Snapshot of getting SketchUp Viewer and the 3D models.] 
FIGURE 15-9: Get SketchUp Viewer (and your 3D models).






Now that you have your models on your phone or tablet, what are you going to do with them? Well, you’re going to use them. Isn’t that the beauty of making models in the first place? Here are a few ways to use your models with the SketchUp Viewer, each depicted in Figure 15-10: 


	Use Styles and Scenes to deliver 3D presentations. Almost everything about styling and composing models for 3D presentation in Part 3 applies in the SketchUp Viewer, because all the scenes you create in SketchUp are available in the Viewer. Your saved model views — with hidden groups and components (or tags), dimensions and labels, section planes, shadows, or styles — are at your fingertips on your device. In addition to jumping between scenes you’ve saved, you can use the Position Camera tool to jump your camera to first-person view. (Find it by clicking the Orbit icon in the bottom-left corner of the screen.)

	Reference project plans while building something. Wouldn’t you know, the model views that you make to build a project — orthographic plan and elevations, section views that show construction details, dimensions, and label callouts — are pretty useful to reference while building a project. Why wouldn’t you want all this information on your workbench, caked in sawdust?

	Take measurements on the fly. Need to double-check the dimensions of your design? After you’ve made a note with your real-life tape measure, pull out the 3D Tape Measure tool (the second icon from the top) in SketchUp Viewer. Now place a finger on your screen. You’ll see a little magnified view of your model with an inference cursor. Move your finger to snap to the inference you want; then remove your finger from the screen. Repeat to set the end of your measurement. SketchUp spits out a model dimension. Do you think it will fit?

	Preview models in real space with augmented reality. Okay, here’s the fun part: You can use the SketchUp Viewer to preview your models in the context of real-world space, using the augmented reality tools available on many smartphones and tablets. The SketchUp Viewer activates the camera on your device and then projects a scaled 3D model onscreen. The result is a scaled preview of your model, set in the frame of the real space you may be designing it for. This feature comes in very handy for evaluating room layouts, previewing custom built-in projects, and catching Pokémon at will.




[image: Photos depict the Present, reference, measure, and preview 3D models from the phone.] 
FIGURE 15-10: Present, reference, measure, and preview 3D models from your phone.








Turning Off Your Profiles

It’s the nature of computers: At some point, you’ll make a SketchUp model that slows down. When that happens, you can lessen the processing load of SketchUp in many ways. The simplest (and quickest) method to try to speed up SketchUp is to turn off edge profiles. This display setting removes the extra line thickness applied to edges that define the outline of your geometry. (Refresh other edge settings are covered in “Tweaking edge settings” in Chapter 10.)

You can turn off profiles by changing or editing a style, but it’s much faster to set a customized keyboard shortcut (follow the steps in “Customizing Shortcuts” earlier in this chapter). Now you can toggle in and out of edge profiles. Just like toggling shadows on and off, toggling profiles is a nice way to throttle the demand on your computer while keeping the sketchy look and feel a keystroke away.



Connecting with the SketchUp Community

Along with the resources we recommend in the introduction, the Internet is an infinite resource of highly specialized SketchUp knowledge. People across the world, in many languages, have uploaded detailed YouTube videos in which they explain how to do something very specific in SketchUp. Generate a cut list, draw with subdivisions to create organic shapes, model videogame levels, import GIS data — you can do it all in SketchUp, because a community of SketchUp people (we call them SketchUppers) are inspired to share and teach those who are willing to learn. You’ll find them in the SketchUp Forums, SketchUcation, and YouTube. Almost anywhere you can ask a question, a SketchUpper will answer it.

One last tip: Ask a friendly question, and you’ll get a helpful answer. With that, we leave you in the good hands of SketchUppers everywhere.
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	shadows, 323–324





	Circle tool, 80–81

	Classifications feature, 211
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	dimensions, 388–391

	edges, 186

	faces, 186

	geometry, 127

	hidden edges, 152

	styles, 301–317

	surfaces, 186

	terrain models, 192–199

	text in LayOut, 370–372

	textures, 226–232
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	adding photographs to flat, 224–232
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	editing, 186
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	FDM (fused deposition modeling), 265
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	Follow Me tool

	about, 113, 160–161

	combined with Scale tool, 179–182

	computer speed and, 166

	creating extruded shapes, 164–169
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	geographic data, adding, 246–249
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glue, in 3D printing, 288–289
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	Graphics Interchange Format (GIF), 379

	green axis, 44

	Ground feature, 311
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	exporting for print, 407–408
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	exporting from SketchUp for Web, 402–404
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	models
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	Follow Me tool, 160–173

	Sandbox, 183–199

	Scale tool, 174–182
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	Paint Bucket tool, 28–29, 71–72

	Pan tool
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	paper-based 3D printers, 266

	paradigm, 75
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	Parallel Projection, 378

	parapet, of roofs, 114, 115
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	creating, 197–199

	Follow Me tool and, 161
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	drawing in, 43

	section, 358–361
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	about, 223–224

	adding textures to curved surfaces, 233–237

	adding to documents in LayOut, 379–380

	adding to flat faces, 224–232

	controlling color/transparency in, 232–233

	editing textures, 226–232

	exporting for print, 407–408

	exporting from LayOut, 396–397

	exporting from SketchUp for Web, 402–404

	importing, 224–226

	mapping faces with, 224–237

	modeling directly from, 238–246

	photo-matching, 238–246

	as textures, 226





	photo-matching, 238–246
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	Pie tool, 80
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	cutting, 353–361
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	Portable Network Graphics (PNG), 402–404, 412

	Position Camera tool, 334–336

	Position Texture tool, 226

	positioning guides, 70

	powder-based printers, 266

	Precision (Dimension Style panel), 390

	preparing models for 3D printing, 270–284

	preselecting, with Move tool, 62–64

	Presentation mode, 399

	presenting models

	about, 333

	field of view, 337–339

	Look Around tool, 337

	Position Camera tool, 334–336

	scenes, 339–352

	sections, 352–362

	Walk tool, 336–337





	press fit, in 3D printing, 290

	Preview Frame Size option (Animation Export Options dialog box), 414

	Print dialog box, 396

	printing

	exporting images for, 407–408
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	drawing in place, 165–168
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	Projected Texture method, 236–237
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	Protractor tool, 116, 117–119

	Purge Unused option, 136

	Push/Pull tool

	about, 23, 25, 27

	combined with Scale tool, 177–179
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	flat roofs with parapets, 115–116
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	radial symmetry, 149, 152–155

	rake, of roofs, 114, 115

	raster images (rasters), 379, 404–405

	raster rendering, 376

	re-creating faces, 41

	Rectangle tool, 22–23, 25–26

	red axis, 44

	references, updating for models, 379

	Remember icon, 2

	removing

	scenes, 348

	watermarks, 312





	renaming scenes, 347

	reordering scenes, 346–347

	repeated elements, modeling with, 155–157

	Replace Selected option (Select tab), 135

	repositioning model views in LayOut, 374

	resizing, with Tape Measure tool, 56

	Resolution option (Animation Export Options dialog box), 413–414

	Restore Defaults option (Animation Export Options dialog box), 414

	Reverse option, 357

	right-angled walls, modeling, 259

	rise, of stairs, 108–109

	
rise over run ratios, 118

	riser, of stairs, 108–109

	riser height, 56

	roads, creating, 197–199

	roofs

	about, 113–115

	eaves on pitched, 116–117

	flat with parapets, 115–116

	gabled, 114, 115, 117–119

	hip, 114, 115, 119–120

	Intersect Faces feature, 121–124

	Line tool, 123–124

	pitched, 115, 116–117
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	rotating
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	rounding edges, 445–446
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	Sample tool, 72

	sampling, 386

	Sandbox

	about, 183

	Add Detail tool, 194–195

	creating new terrain models, 183–199

	editing terrain models, 192–199

	Flip Edge tool, 187–188





	Save as a Local Collection option, 134

	saving styles, 319

	Scale drop-down list (Dimension Style panel), 390

	scale figures, 10

	Scale tool
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	activating, 174

	combined with Follow Me tool, 179–182

	combined with Push/Pull tool, 177–179

	creating organic forms, 177–182
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	using, 174–176
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	scaling
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	animating sections with, 361–362

	controlling tags with, 221

	creating, 340–342

	modifying, 345–352

	moving between, 342–344

	properties of, 348–350

	relationship with styles, 343

	removing, 348

	renaming, 347

	reordering, 346–347

	updating, 350–352





	schemata, 211

	scrapbooks, building in LayOut, 395

	Scrapbooks panel, 380

	scratch, building models from, 21–28

	screws, in 3D printing, 2916

	scroll wheel, 13–14, 50

	Search, 17

	Search filter box (Outliner), 212

	Section Cuts, 358

	Section Plane tool, 270–271

	Section Planes, 358

	section views, printing, 361

	sectional view. See sections

	section-plane visibility, setting, 358

	sections

	about, 352–353

	animating with scenes, 361–362

	controlling planes, 357–358

	cutting, 353–361

	orthographic, 360–361

	perspective, 358–361
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	views, 358–361
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	models, 35
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	shearing textures, 226–228

	shed roof, 114, 115
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	shortcuts, keyboard, 15–16, 440–442
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	SketchUp files, exporting, 284–285
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	SketchUp for Web, 10–12, 402–404, 408–409

	SketchUp Forums (website), 4

	SketchUp Free, 8

	SketchUp Help Center (website), 147

	SketchUp Pro, 8, 9–10

	SketchUp Quick Reference Card (website), 3

	SketchUp Shop, 8
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	Sketchy Edges collection, of styles, 301

	Skimp extension, 450
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	SLS (selective laser sintering), 285

	smart scaling, 144–146

	smartphones, 450–452

	smoothing edges, 173

	Smoove tool, 192–195

	snap fittings, in 3D printing, 289–290

	Soap Skin Bubble extension, 450
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	solid modeling operations. See Solid Tools

	Solid Rules, 200–202

	Solid Tools
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	spacebar, as keyboard shortcut for Select tool, 16
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	Split tool, 203

	Split tool (LayOut), 383
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	stairs
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	Copied Profile method, 111–113

	Subdivided Rectangles method, 109–111
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	STL files, 284
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	relationship with scenes, 343

	saving, 319
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	drafting, 79–82
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	drawing, 30–31, 43–49
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	organization of, 210–211
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	Outer Shell, 203, 205, 273
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	Position Camera, 334–336

	Position Texture, 226

	Protractor, 116, 117–119
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	Scale, 144–146, 174–182, 446–447
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	Section Plane, 270–271

	Select, 57–59

	Smoove, 192–195

	Split, 203, 383
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	Trimble Connect, 12
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	troubleshooting, 427–438
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	views
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